Switches de LAN : Integrated Routing and Bridging (IRB)

Compreendendo e Configurando VLAN Routing e Bridging em um Roteador Usando o Recurso IRB

16 Janeiro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (31 Dezembro 2015) | Feedback


Índice


Introdução

Este documento descreve a progressão das VLAN conforme são implementadas com um roteador que esteja realizando roteamento IP, bridging IP e bridging IP com Integrated Routing and Bridging (IRB). Além disso, este documento fornece uma configuração de exemplo que configura a característica de IRB em um roteador.

Nota: O IRB foi desabilitado deliberadamente nos Catalyst 6500 Series Switch e nos Cisco 7600 Series Router. Para mais informação, refira por favor a seção geral das limitações e restrição sob Release Note para o Cisco IOS Release 12.1 E no catalizador 6000 e Supervisor Engine do Cisco 7600 e MSFC.

Antes de Começar

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Pré-requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Informações de Apoio

Para que um VLAN meça um roteador, o roteador deve ser capaz de quadros da transmissão de uma relação a outra, ao manter o cabeçalho de VLAN. Se o roteador está configurado distribuindo um protocolo da camada 3 (camada de rede), terminará o VLAN e as camadas de MAC na relação que um quadro chega sobre. O encabeçamento da camada de MAC pode ser mantido se o roteador está construindo uma ponte sobre o protocolo de camada de rede. Contudo, o Bridging regular ainda termina o cabeçalho de VLAN. Usando a característica IRB no � do Cisco IOS libere 11.2 ou maior, um roteador pode ser configurado distribuindo e construindo uma ponte sobre o mesmo protocolo de camada de rede na mesma relação. Isto permite que o cabeçalho de VLAN esteja mantido em um quadro quando transitar por um roteador de uma relação a outra. O IRB fornece a capacidade para distribuir entre um domínio interligado e um domínio roteado com Bridge Group Virtual Interface (BVI). O BVI é uma interface virtual dentro do roteador que atua como uma interface roteada normal que não apoie a construção de uma ponte sobre, mas representa o grupo de bridge comparável às interfaces roteada dentro do roteador. O número de interface do BVI é o número do grupo de bridge que a interface virtual representa. O número é o link entre o BVI e o grupo de bridge.

Quando você configura e permite o roteamento no BVI, os pacotes que vêm dentro em uma interface roteada, que são destinados para um host em um segmento em um grupo de bridge, estão distribuídos ao BVI. Do BVI, o pacote é enviado ao motor de construção de uma ponte sobre, que para a frente ele através de uma interface interligada. Isto é enviado com base no endereço MAC de destino. Similarmente, os pacotes que vêm dentro em uma interface interligada, mas são destinados para um host em uma rede roteada, vão primeiramente ao BVI. Em seguida, o BVI para a frente os pacotes ao Engine de roteamento antes que os enviar fora da interface roteada. Em uma única interface física, o IRB pode ser criado com as duas subinterfaces VLAN (802.1Q que etiqueta); uma secundário-relação VLAN tem um endereço IP de Um ou Mais Servidores Cisco ICM NT que seja usado distribuindo, e a outra secundário-relação VLAN constrói uma ponte sobre entre a secundário-relação usada distribuindo e a outra interface física no roteador.

Desde que o BVI representa um grupo de bridge como uma interface roteada, deve ser configurado somente com características da camada 3 (L3), tais como endereços de camada de rede. Similarmente, as relações configuradas construindo uma ponte sobre um protocolo não devem ser configuradas com nenhuma características L3.

Conceito de VLAN Routing e Bridging com IRB

Na Figura I, os PCs A e B estão conectados a VLANs que, por sua vez, estão separadas por um roteador. Isso ilustra a concepção errônea comum de que uma única VLAN pode ter uma conexão baseada em roteador no centro.

/image/gif/paws/17054/router_vlan1.gif

Essa figura também mostra o fluxo de três camadas dos cabeçalhos para um quadro que atravessa os links do PC a para o PC B.

Porque o quadro corre através do interruptor, o cabeçalho de VLAN é aplicado porque a conexão é um enlace de tronco. Pode haver várias VLANs em comunicação entre o tronco.

O roteador termina a camada VLAN e a camada de MAC. Examina o endereço IP de destino e para a frente o quadro apropriadamente. Neste caso, o quadro IP deve ser enviada fora da porta para o PC B. Esse também é um tronco de VLAN e, portanto, é aplicado um cabeçalho de VLAN.

Embora a VLAN que conecta o Switch 2 ao roteador possa ser chamada do mesmo número que a VLAN que conecta o Switch 1 ao roteador, na verdade não é a mesma VLAN. O cabeçalho original de VLAN é removido quando o quadro atinge o roteador. Um encabeçamento novo pode ser aplicado como o quadro retira o roteador. Este encabeçamento novo pode incluir o mesmo número de VLAN que foi usado no cabeçalho de VLAN que foi descascado quando o quadro chegou. Isto é demonstrado pelo fato de que o quadro IP movido através do roteador sem um cabeçalho de VLAN anexado, e foi enviado com base nos índices do campo do endereço de destino IP, e não em um campo do ID de VLAN.

Como os dois troncos VLAN ficam em lados opostos do roteador, eles devem estar em sub-redes IP diferentes.

Para que os dois PC tenham o mesmo endereço de sub-rede, o roteador teria que construir uma ponte sobre o IP em suas relações. Contudo, tendo os dispositivos em VLAN compartilhe de uma sub-rede comum não significa que estão no mesmo VLAN.

A figura II mostra a aparência da topologia de VLAN.

/image/gif/paws/17054/router_vlan2.gif

A necessidade de especificar um novo endereço estações final IP durante movimentos pode ser evitada construindo uma ponte sobre IP em algum ou todas as relações no roteador que conecta os VLAN. Contudo, isto elimina todos os benefícios de redes baseada em roteador da construção para controlar transmissões na camada de rede. Figura III mostra que mudanças ocorrem quando o roteador é configurado construindo uma ponte sobre o IP. A figura IV mostra o que acontece quando o roteador é configurado construindo uma ponte sobre o IP com IRB.

A figura III mostra que agora o roteador está interligando o IP. Ambos os PCS estão agora na mesma sub-rede.

Nota: O roteador (ponte) agora para a frente o encabeçamento da camada de MAC transversalmente à relação de ida. O roteador ainda termina o cabeçalho de VLAN e aplica um encabeçamento novo antes de enviar o quadro para fora ao PC B.

/image/gif/paws/17054/router_vlan3.gif

A figura IV mostra o que acontece quando o IRB é configurado. O VLAN mede agora o roteador, e o cabeçalho de VLAN é mantido como o quadro transita pelo roteador.

/image/gif/paws/17054/router_vlan4.gif

Exemplo de configuração de IRB

Esta configuração é um exemplo do IRB. A configuração reserva construir uma ponte sobre um IP entre duas interfaces Ethernet, e distribuir o IP das interfaces interligada usando um Bridged Virtual Interface (BVI). No diagrama de rede seguinte, quando PC_A tenta contactar o PC_B, o r1 do roteador detecta que o endereço IP de Um ou Mais Servidores Cisco ICM NT do destino (PC_B) está na mesma sub-rede, assim que os pacotes são construídos uma ponte sobre pelo r1 do roteador entre a relação E0 e E1. Quando PC_A ou PC_B tentam contatar PC_C, o roteador R1 detecta que o endereço IP de destino (PC_C) está em uma sub-rede diferente e o pacote é roteado usando o BVI. Esta maneira, protocolo IP é construída uma ponte sobre assim como distribuída no mesmo roteador.

Diagrama de Rede

router_vlan5.gif

Configuração

Configuração de exemplo
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R1
!
!
ip subnet-zero
no ip domain-lookup
bridge irb

!-- This command enables the IRB feature on this router.

!
!
!
interface Ethernet0
no ip address
no ip directed-broadcast
bridge-group 1

!-- The interface E0 is in bridge-group 1.

!
Interface Ethernet1
no ip address
no ip directed-broadcast
bridge-group 1

!-- The interface E1 is in bridge-group 1.

!
Interface Serial0
ip address 10.10.20.1 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
no fair-queue
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
interface BVI1
ip address 10.10.10.1 255.255.255.0

!-- An ip address is assigned to the logical BVI for routing


!-- IP between bridged interfaces and routed interfaces.

no ip directed-broadcast
!
ip classless
ip route 10.10.30.0 255.255.255.0 10.10.20.2
!
bridge 1 protocol ieee

!-- This command enables the bridging on this router.

bridge 1 route ip

!-- This command enable bridging as well routing for IP protocol.

!
line con 0
transport input none
line aux 0
line vty 0 4
!
end

Resultados do comando show

show interfaces [interface] irb

Esse comando exibe os protocolos que podem ser roteados ou ligados em ponte para a interface especificada, da seguinte forma:

R1#show interface e0 irb

Ethernet0

Routed protocols on Ethernet0:
ip
    
Bridged protocols on Ethernet0:
ip         ipx

!-- IP protocol is routed as well as bridged.


Software MAC address filter on Ethernet0
 Hash Len    Address      Matches  Act      Type
 0x00:  0 ffff.ffff.ffff     0     RCV  Physical broadcast
 0x2A:  0 0900.2b01.0001     0     RCV  DEC spanning tree
 0x9E:  0 0000.0c3a.5092     0     RCV  Interface MAC address
 0x9E:  1 0000.0c3a.5092     0     RCV  Bridge-group Virtual Interface
 0xC0:  0 0100.0ccc.cccc    157    RCV  CDP
 0xC2:  0 0180.c200.0000     0     RCV  IEEE spanning tree
 0xC2:  1 0180.c200.0000     0     RCV  IBM spanning tree
R1#

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 17054