Switches de LAN : Inter-Switch Link (ISL)

Configurando troncos de ISL em roteadores Cisco

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (11 Novembro 2015) | Feedback


Índice


Introdução

Este documento discute a configuração de troncos do Inter-Switch Link Protocol (ISL) em roteadores Cisco externos como os das séries 7500/7000, 3600, 4500, ou 2500. Este documento não aborda a configuração dos troncos de ISL em switches da Camada 2 (L2) e Camada (L3) como o Cisco Catalyst 6500 ou 4500.

Para obter informações sobre de configurar o ISL e os troncos 802.1Q entre o Switches L2 e L3 do catalizador que executa o OS do catalizador (Cactos) ou o software do ½ do ¿  de Cisco IOSïÂ, refira qualquer uma destes:

Pré-requisitos

Requisitos

Os leitores deste documento devem estar cientes destes tópicos:

  • Apoio ISL em Catalyst Switches

    O apoio ISL é dependente de hardware para Catalyst Switches. Quando você conecta um roteador externo a um Catalyst 6500/6000, 5500/5000 ou 4500/4000 de interruptor, usa um destes comandos determinar o suporte de encapsulamento por módulo:

    • Cactos — capacidades do show port

    • Cisco IOS Software — mostre capacidades das relações

  • Apoio ISL em roteadores Cisco

    No Cisco IOS Software Release 11.2 e Mais Recente, somente a mais o conjunto de recursos é necessário. O conjunto de recursos positivo é IP Plus ou Desktop mais. Todo o Fast Ethernet ou interface Gigabit Ethernet no Roteadores apoiam o entroncamento do ISL VLAN.

    No Cisco IOS Software Release 11.3 e Anterior, somente o IP e as Trocas de Pacote Entre Redes IPX (IPX) com um encapsulamento da IEEE 802.3 (novell-ether) têm o apoio sobre o ISL. Encapsulamentos e protocolos adicionais adicionados Cisco IOS Software Release 11.3.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Informações de Apoio

Um VLAN é um domínio de transmissão lógico. A fim permitir que os dados atravessem entre dois VLAN, ou os domínios de transmissão, você deve usar um dispositivo L3 para distribuir entre os VLAN. O modelo do abrir interconexão do sistema (OSI) da sete-camada define esta regra. Qualquens um dispositivos podem realizar este roteamento:

  • Um roteador externo, tal como os 2500, os 4000, ou os 7000

  • Um roteador interno, tal como um Multilayer Switch Feature Card (MSFC)

  • Um dispositivo externo com software de roteamento, como um host Unix que execute roteado ou bloqueia

O método original era conectar uma porta física diferente no roteador a cada vlan individual. Este método torna-se muito caro enquanto o número de VLAN aumenta. Mas há um método melhor. Os administradores de rede podem decidir usar o trunking VLAN para atribuir pelo contrário vlan múltiplos a uma única interface roteada. Somente o Roteadores com 100 MB ou umas portas Ethernet mais rápidas podem fazer o trunking VLAN.

O trunking VLAN permite que o Fast Ethernet do 100 MB ou as interfaces Gigabit Ethernet do 1000 MB coloquem uma etiqueta no pacote que identifica o VLAN a que o pacote pertence. Quando a outra extremidade do tronco de ISL recebe este pacote rotulado, o tronco de ISL coloca o pacote no VLAN correto. A etiqueta ISL é um encabeçamento 30-byte que seja adicionado em torno do quadro do Fast Ethernet. Consequentemente, o ISL é uma tecnologia de Point-to-Point e trabalha somente entre dois switch Cisco ou Roteadores que apoiam o ISL no Fast Ethernet do 100 MB ou nas interfaces Gigabit Ethernet do 1000 MB.

Esta figura fornece uma descrição visual dos troncos de ISL:

/image/gif/paws/17051/24a.gif

Configurações

Conclua estes passos:

  1. Conecte o roteador ao interruptor com as portas ISL-capazes com o uso dos cabos apropriados.

    Use reto-através da categoria 5 ou cabos de fibra ótica.

  2. Certifique-se de que você criou os VLAN no lado do Catalyst Switch e de que você configurou a porta de switch para ser uma porta de tronco de ISL.

    Nota: Recorde que os roteadores Cisco não podem negociar o Dynamic Trunking Protocol (DTP) ou os quadros do protocolo do Dynamic InterSwitch Link (DISL). Consequentemente, você deve configurar o modo de tronco para ser não-negociação no lado do interruptor. Consulte o ½ do ¿  do toï o documento que configura o entroncamento ISL e 802.1q entre um switch Cactos e um roteador externo (roteamento de interVLAN) ou a seção Informação Relacionada deste documento.

  3. Comece a definir os VLAN no roteador.

    Certifique-se de que você sabe que informação L2 e L3 a configurar para cada VLAN. Isto inclui o endereço IP de Um ou Mais Servidores Cisco ICM NT, o número de rede de IPX, e a outra informação.

version 11.3
no service password-encryption
!
hostname lt-4500-static
!
enable secret 5 $1$XqiP$3ADCgrFMC21pwyVQIkith.
!
no ip domain-lookup
appletalk routing
ipx routing 0000.0c0b.f2f5
!
!
interface FastEthernet0              

!--- Only Layer 1 is configured here.

 no ip address
 full-duplex             
!
interface FastEthernet0.1            

!--- All L2 and L3 are on subinterfaces.

 encapsulation isl 1                 

!--- This defines ISL encapsulation and the VLAN number.

 ip address 10.6.1.220 255.255.255.0
 no ip redirects           
 appletalk cable-range 100-100 100.149
 appletalk zone cisco
 ipx network ABC encapsulation SAP
!
interface FastEthernet0.2
 encapsulation isl 2
 ip address 10.7.1.220 255.255.255.0
 no ip redirects
 appletalk cable-range 200-200 200.135
 appletalk zone cisco1
 ipx network DEADBEEF encapsulation ARPA
!
interface FastEthernet0.3
 encapsulation isl 3
 ip address 10.8.1.220 255.255.255.0
 no ip redirects
 appletalk cable-range 300-300 300.69
 appletalk zone cisco2
 ipx network 1234 encapsulation SNAP
!
ip classless
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

Você precisa de configurar o comando encapsulation isl vlan- antes que você configure toda a outra informação L2 ou L3. A subinterface não tem que combinar o número de ID de VLAN. Contudo, um fósforo faz a administração e pesquisa-a defeitos das edições VLAN mais fáceis.

Você deve usar subinterfaces para evitar uma violação da regra de horizonte dividido. A regra split horizon proibe a propaganda de uma rota por um roteador através de uma relação que o roteador próprio se esteja usando para alcançar o destino. Esta aproximação é muito similar usar-se das subinterfaces ponto a ponto com Frame Relay em um ambiente de WAN.

Debugar e pesquise defeitos

Uma vez que você verificou que seus configuração, Cisco IOS Software, e plataforma de hardware estão corretos, você precisa de verificar que as coisas trabalham corretamente. Use os comandos nesta seção verificar a operação e pesquisar defeitos problemas.

Nota: A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Nota: Antes de emitir comandos de depuração, consulte as informações importantes sobre eles.

  • mostra vlan — Este comando diz-lhe que informação L2 ou L3 é configurada para cada VLAN.

    lt-4500-static# show vlan
    Virtual LAN ID:  1 (Inter Switch Link Encapsulation)
    vLAN Trunk Interface:   FastEthernet0.1       
       Protocols Configured:   Address:              Received:        Transmitted:
               IP              10.6.1.220                   0                   0
           IPX (SAP)        ABC.0000.0c0b.f2f5              0                   8
             AppleTalk           100.149                    0                  22
    Virtual LAN ID:  2 (Inter Switch Link Encapsulation)
    vLAN Trunk Interface:   FastEthernet0.2       
       Protocols Configured:   Address:              Received:        Transmitted:
               IP              10.7.1.220                   0                   0
        IPX (ARPA)     DEADBEEF.0000.0c0b.f2f5              0                   8
             AppleTalk           200.135                    0                  22
    Virtual LAN ID:  3 (Inter Switch Link Encapsulation)
    vLAN Trunk Interface:   FastEthernet0.3       
       Protocols Configured:   Address:              Received:        Transmitted:
               IP              10.8.1.220                   0                   0
           IPX (SNAP)      1234.0000.0c0b.f2f5              0                   9
             AppleTalk           300.69                     0                  23
    
  • relação da mostra — Este comando diz a lhe o estado da interface e subinterface, assim como à cor de vlan das subinterfaces. A cor de vlan é a mesma que o número de VLAN.

    lt-4500-static# show interface
    FastEthernet0 is up, line protocol is up 
      Hardware is DEC21140, address is 0000.0c0b.f2f5 (bia 0000.0c0b.f2f5)
      MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, rely 255/255, load 1/255
      Encapsulation ARPA, loopback not set, keepalive set (10 sec)
      Full-duplex, 100Mb/s, 100BaseTX/FX
      ARP type: ARPA, ARP Timeout 04:00:00
      Last input 00:00:00, output 00:00:03, output hang never
      Last clearing of "show interface" counters 00:04:25
      Queueing strategy: fifo
      Output queue 0/40, 0 drops; input queue 0/75, 0 drops
      5 minute input rate 0 bits/sec, 1 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         415 packets input, 25392 bytes, 0 no buffer
         Received 415 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
         0 watchdog, 0 multicast
         0 input packets with dribble condition detected
         137 packets output, 12378 bytes, 0 underruns
         0 output errors, 0 collisions, 0 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
    FastEthernet0.1 is up, line protocol is up 
      Hardware is DEC21140, address is 0000.0c0b.f2f5 (bia 0000.0c0b.f2f5)
      Internet address is 10.6.1.220/24
      MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, rely 255/255, load 1/255
      Encapsulation ISL Virtual LAN, Color 1.
      ARP type: ARPA, ARP Timeout 04:00:00
    FastEthernet0.2 is up, line protocol is up 
      Hardware is DEC21140, address is 0000.0c0b.f2f5 (bia 0000.0c0b.f2f5)
      Internet address is 10.7.1.220/24
      MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, rely 255/255, load 1/255
      Encapsulation ISL Virtual LAN, Color 2.
      ARP type: ARPA, ARP Timeout 04:00:00
    FastEthernet0.3 is up, line protocol is up 
      Hardware is DEC21140, address is 0000.0c0b.f2f5 (bia 0000.0c0b.f2f5)
      Internet address is 10.8.1.220/24
      MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, rely 255/255, load 1/255
      Encapsulation ISL Virtual LAN, Color 3.
      ARP type: ARPA, ARP Timeout 04:00:00
    
  • mostre {IP | ipx | rota do APPLETALK} — este comando diz-lhe que a subinterface de ISL correta é de aprendizagem ou de emissão a informação de roteamento.

    lt-4500-static# show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
           U - per-user static route, o - ODR
    Gateway of last resort is not set
          10.0.0.0/24 is subnetted, 3 subnets
    C       10.8.1.0 is directly connected, FastEthernet0.3
    C       10.7.1.0 is directly connected, FastEthernet0.2
    C       10.6.1.0 is directly connected, FastEthernet0.1
    
    lt-4500-static# show appletalk route
    Codes: R - RTMP derived, E - EIGRP derived, C - connected, A - AURP
           S - static  P - proxy 
    3 routes in internet
    The first zone listed for each entry is its default (primary) zone.
    C Net 100-100 directly connected, Fa0.1, zone cisco
    C Net 200-200 directly connected, Fa0.2, zone cisco1
    C Net 300-300 directly connected, Fa0.3, zone cisco2
    
    lt-4500-static# show ipx route
    Codes: C - Connected primary network,    c - Connected secondary network
           S - Static, F - Floating static, L - Local (internal), W - IPXWAN
           R - RIP, E - EIGRP, N - NLSP, X - External, A - Aggregate
           s - seconds, u - uses, U - Per-user static
    3 Total IPX routes. Up to 1 parallel paths and 16 hops allowed.
    No default route known.
    C        ABC (ISL vLAN),      Fa0.1
    C       1234 (ISL vLAN),      Fa0.3
    C   DEADBEEF (ISL vLAN),      Fa0.2
    
  • debug vlan packet — Este comando diz-lhe se há um misconfiguration dos pacotes no tronco de ISL ou se a subinterface de ISL errada é de emissão ou de recepção os pacotes.

    cuidado Cuidado: Seja sempre cuidadoso quando você usa todo o comando debug. Os comandos debug podem causar problemas severos de desempenho no roteador. Para desabilitar a eliminação de erros, emita o comando undebug all.

    lt-4500-static# debug vlan packet
    Virtual LAN packet information debugging is on
    lt-4500-static#
    vLAN: Received ISL encapsulated UNKNOWN packet bearing colour ID 2
          on interface FastEthernet0.2 which is not configured to
          route or bridge this packet type.
    vLAN: Received ISL encapsulated UNKNOWN packet bearing colour ID 1
          on interface FastEthernet0.1 which is not configured to
          route or bridge this packet type.
    vLAN: Received ISL encapsulated UNKNOWN packet bearing colour ID 3
          on interface FastEthernet0.3 which is not configured to
          route or bridge this packet type.
    vLAN: ISL packet received bearing colour ID 4 on FastEthernet0
          which has no subinterface configured to route or bridge ID 4.
    vLAN: ISL packet received bearing colour ID 5 on FastEthernet0
          which has no subinterface configured to route or bridge ID 5.
    vLAN: Received ISL encapsulated UNKNOWN packet bearing colour ID 1
          on interface FastEthernet0.1 which is not configured to
          route or bridge this packet type.
    vLAN: Received ISL encapsulated UNKNOWN packet bearing colour ID 2
          on interface FastEthernet0.2 which is not configured to
          route or bridge this packet type.

Informações Relacionadas


Document ID: 17051