IP : Enhanced Interior Gateway Routing Protocol (EIGRP)

Protocolo de encaminhamento de gateway interior aprimorado

12 Agosto 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Tradução Manual (3 Abril 2008) | Inglês (27 Abril 2015) | Feedback


Interativo: Este documento oferece análise personalizada do seu dispositivo Cisco.


Índice


Introdução

O Enhanced Interior Gateway Routing Protocol (EIGRP) é um protocolo de gateway interior adequado para várias topologias e mídias diferentes. Em uma rede bem projetada, o EIGRP é bem dimensionado e fornece tempos de convergência extremamente rápidos, com um mínimo de tráfego de rede.

Teoria da operação EIGRP

Algumas das muitas vantagens do EIGRP são:

  • usos de recurso de rede muito baixos durante a operação normal; somente os pacotes Hello são transmitidos em uma rede estável

  • quando uma mudança ocorrer, simplesmente as alterações de tabela de roteamento estão propagadas, não a tabela de roteamento inteira; isto reduz a carga que o protocolo de roteamento próprio coloca na rede

  • tempo de convergência rápida para mudanças na topologia de rede (em algumas situações a convergência pode ser quase instantânea)

O EIGRP é um protocolo de vetor de distância avançado, que depende do DUAL (Diffused Update Algorithm) para calcular o caminho mais curto para um destino em uma rede.

Principais revisões do protocolo

Há duas revisões principal do EIGRP, das versões 0 e das versões do Cisco IOS 1. mais cedo de 10.3(11), 11.0(8), e 11.1(3) executam a versão anterior do EIGRP; algumas explicações neste papel não podem aplicar-se a essa versão anterior. É altamente recomendado utilizar a versão mais recente do EIGRP, pois ela inclui muitas melhorias de estabilidade e desempenho.

Teoria básica

Um protocolo de vetor de distância típico salvar a informação seguinte ao computar o melhor caminho a um destino: a distância (métrico ou distância total, tal como o contagem de saltos) e o vetor (o salto seguinte). Por exemplo, todos os roteadores da rede na Figura 1 estão executando o Routing Information Protocol RIP. O Roteador dois escolhe o caminho para a rede A examinando a contagem de nós por meio de cada caminho disponível.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp1.gif

Desde que o trajeto através do roteador três é três saltos, e o trajeto com o roteador um é dois saltos, o roteador dois escolhe o trajeto com um e rejeita a informação que aprendeu com três. Se o caminho entre o Roteador Um e a Rede A ficar inativo, o Roteador Dois perderá toda a conectividade com esse destino até que se esgote o tempo da rota de sua tabela de roteamento (três períodos de atualização ou 90 segundos), e o Roteador Três anunciará novamente a rota (o que ocorre a cada 30 segundos em RIP). Sem incluir qualquer tempo de espera, será necessário entre 90 a 120 segundos para o Roteador Dois comutar o caminho do Roteador Um para o Roteador Três.

O EIGRP, em lugar de contar as atualizações periódicas completas para a re-convergência, cria uma tabela de topologia de cada um dos anúncios de seus vizinhos (em lugar de descartar os dados) e faz a convergência procurando uma rota provavelmente sem loop na tabela da topologia ou, caso não conheça outra rota, consultando seus vizinhos. O Roteador 2 salva as informações recebidas dos Roteadores 1 e 3. Ele escolhe o caminho por meio de Um como o melhor caminho (o sucessor e o caminho por meio de Três como o caminho sem loop (um possível sucessor). Quando o caminho pelo roteador um estiver indisponível, o roteador dois examinará sua tabela de topologia e, ao localizar um sucessor adequado, começará a usar o caminho pelo três imediatamente.

Desta explicação resumida, é aparente que o EIGRP deve fornecer:

  • um sistema onde envia somente as atualizações necessárias em um dado momento; isto é realizado com a descoberta vizinha e a manutenção

  • um modo de determinar quais os caminhos que um roteador aprendeu são sem circuito

  • um processo para limpar rotas incorretas das tabelas de topologia de todos os roteadores da rede

  • um processo para consultar vizinhos e encontrar caminhos para destinos perdidos

Abordaremos cada um desses requisitos separadamente.

Descoberta e manutenção de vizinho

Para distribuir informações de roteamento em uma rede, o EIGRP utiliza atualizações de roteamento incrementais não periódicas. Isto é, o EIGRP envia somente atualizações de roteamento sobre os trajetos que mudaram quando aqueles trajetos mudam.

O problema básico com emissão somente de atualizações de roteamento é que você não pode saber quando um trajeto através de um roteador vizinho está já não disponível. Você não pode determinar o tempo das rotas, esperando receber uma nova tabela de roteamento de seus vizinhos. O EIGRP confia em relacionamentos vizinho para propagar confiantemente alterações de tabela de roteamento durante todo a rede; dois Roteadores transformam-se vizinhos quando vê pacotes Hello de cada um em uma rede comum.

O EIGRP envia pacotes de saudação a cada 5 segundos em enlaces de largura de banda alta e a cada 60 segundos em enlaces de multiponto de largura de banda baixa.

  • Saudação de 5 segundos:

    • mídia de broadcast, como Ethernet, Token Ring e FDDI

    • enlaces seriais ponto a ponto, como circuitos concedidos PPP ou HDLC, subinterfaces ponto a ponto de Frame Relay e subinterface ponto a ponto ATM.

    • circuitos multiponto da largura de banda elevada (maior do que o T1), tais como ISDN PRI e Frame Relay

  • Saudação de 60 segundos:

    • A largura de banda T1 de circuitos multiponto ou mais lentos, como interfaces multiponto de Frame Relay, interfaces multiponto de ATM, circuitos virtuais comutados de ATM e BRIs de ISDN

A taxa em que o EIGRP envia pacotes Hello é chamada o intervalo de hello, e você pode ajustá-lo pela relação com o comando ip hello-interval eigrp. O tempo de espera é o tempo durante o qual um roteador considerará um vizinho ativo sem receber um pacote de saudação. O tempo de contenção é tipicamente três vezes o intervalo de hello, à revelia, 15 segundos e 180 segundos. É possível ajustar o hold time com o comando ip hold-time eigrp.

Observe que, se você alterar o intervalo de saudação, o tempo de espera não será ajustado automaticamente para cálculo dessa alteração - você deverá ajustar manualmente o tempo de espera para refletir o intervalo de saudação configurado.

É possível para dois Roteadores assentar bem em vizinhos EIGRP mesmo que os temporizadores de saudação e de espera não combinem. O tempo de espera é incluído nos pacotes de saudação, assim, cada vizinho deverá permanecer ativo, embora o intervalo de saudação e os timers de espera não coincidam.

Quando não houver nenhuma maneira direta de determinar o que o intervalo de hello está em um roteador, você pode pressupo-lo da saída de vizinhos EIGRP da mostra IP no roteador vizinho.

Se você tem a saída de um comando show ip eigrp neighbors de seu dispositivo Cisco, você pode usar o Output Interpreter (clientes registrados somente) para indicar problemas potenciais e reparos. Para usar o Output Interpreter, você deve ter o Javascript permitido.

router# show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address       Interface   Hold Uptime   SRTT   RTO  Q  Seq  Type
                                        (sec)         (ms)       Cnt Num
1   10.1.1.2      Et1           13 12:00:53   12   300  0  620
0   10.1.2.2      S0           174 12:00:56   17   200  0  645


rp-2514aa# show ip eigrp neighbor
IP-EIGRP neighbors for process 1
H   Address        Interface   Hold Uptime   SRTT   RTO  Q  Seq  Type
                                        (sec)         (ms)       Cnt Num
1   10.1.1.2       Et1           12 12:00:55   12   300  0  620
0   10.1.2.2       S0           173 12:00:57   17   200  0  645


rp-2514aa# show ip eigrp neighbor
IP-EIGRP neighbors for process 1
H   Address        Interface   Hold Uptime   SRTT   RTO  Q  Seq  Type
                                        (sec)         (ms)       Cnt Num
1   10.1.1.2       Et1           11 12:00:56   12   300  0  620
0   10.1.2.2       S0           172 12:00:58   17   200  0  645

O valor na coluna Hold da saída do comando nunca deve exceder o tempo de espera e nunca deve ser menor do que o tempo de espera menos o intervalo de saudação (a menos, é claro, que você esteja perdendo pacotes de saudação). Se a coluna de espera geralmente varia entre 10 e 15 segundos, o intervalo de saudação é de 5 segundos e o tempo de espera é de 15 segundos. Se a coluna da posse tem geralmente uma escala mais larga - entre 120 e 180 segundos - o intervalo de hello é 60 segundos e o tempo de contenção é 180 segundos. Se os números não parecem caber um dos ajustes do temporizador padrão, verifique a relação na pergunta no roteador vizinho - os temporizadores de saudação e de espera podem ter sido configurados manualmente.

Nota: 

  • O EIGRP não constrói relacionamentos de peer sobre endereços secundários. Todo o tráfego de EIGRP tem origem no endereço principal da interface.

  • Ao configurar EIGRP por uma rede Frame Relay multiacesso (ponto a multiponto etc.), configure a palavra-chave de difusão nas instruções de frame-relay map. Sem a palavra-chave broadcast, as adjacências não seriam estabelecidas entre dois roteadores EIGRP. Refira a Configuração e Troubleshooting do Frame Relay para mais informação.

  • Não há limitações quanto ao número de vizinhos que o EIGRP pode suportar. O número real de vizinhos suportados depende da capacidade do dispositivo, como:

    • capacidade de memória

    • potência de processamento

    • uma quantidade de informação trocada, tal como o número de rotas enviadas

    • complexidade da topologia

    • estabilidade de rede

Criando a tabela de topologia

Agora que estes roteadores estão conversando um com o outro, qual é o assunto da conversa? As tabelas de topologia, obviamente. O EIGRP, diferente do RIP e do IGRP, não confia na tabela de roteamento (ou encaminhamento) do roteador para manter todas as informações necessárias para sua operação. Em vez disso, cria uma segunda tabela, a tabela de topologias, a partir da qual instala rotas na tabela de roteamento.

Nota: A partir dos Cisco IOS Versions 12.0T e 12.1, o RIP mantém seu próprio banco de dados a partir do qual instala rotas na tabela de roteamento.

Para ver o formato básico da tabela de topologia em um roteador que executa o EIGRP, emita o comando show ip eigrp topology. A tabela de topologia contém as informações necessárias à criação de um conjunto de distâncias e vetores para cada rede alcançável, incluindo:

  • menor largura de banda no caminho para esse destino conforme reportado pelo vizinho upstream

  • retardo total

  • confiabilidade do caminho

  • carga do trajeto

  • unidade de transmissão máxima de caminho mínimo (MTU)

  • distância factível

  • distância relatada

  • origem de rota (rotas externas são marcadas)

Praticável e distância informada são discutidos mais tarde nesta seção.

Se você tem a saída de um comando show ip eigrp topology de seu dispositivo Cisco, você pode usar o Output Interpreter (clientes registrados somente) para indicar problemas potenciais e reparos. Para usar o Output Interpreter, você deve ter o Javascript permitido.

Métrica EIGRP

O EIGRP usa a largura de banda mínima no trajeto a uma rede de destino e ao retardo total para computar métricas de roteamento. Embora você possa configurar o outro medidor, nós não o recomendamos, porque pode causar loop de roteamento em sua rede. A largura de banda e as métricas de retardo são determinadas a partir de valores configurados nas interfaces dos roteadores no caminho para a rede de destino.

Por exemplo, na Figura 2 abaixo, o Roteador Um está calculando o melhor caminho para a Rede A.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp2.gif

Começa com as duas propagandas para esta rede: um através do roteador quatro, com uma largura de banda mínima de 56 e um retardo total de 2200; e o outro através do roteador três, com uma largura de banda mínima do 128 e um atraso de 1200. O roteador 1 escolhe o caminho com a métrica mais baixa.

Deixe-nos computar o medidor. O EIGRP calcula a métrica total escalando a medida de retardo e largura de banda. O EIGRP usa a seguinte fórmula para escalar a largura de banda:

  • Largura de banda = (10000000/largura de banda(i)) * 256

    onde bandwidth(i) é a única largura de banda de todas as interfaces de saída na rota para a rede de destino representada em kilobits.

O EIGRP usa a seguinte fórmula para dimensionar o retardo:

  • atraso = atraso (i) * 256

    em que delay(i) é a soma dos retardos configurados nas interfaces, na rota para a rede de destino, em dezenas de microssegundos. O retardo, conforme mostrado nos comandos delay show ip eigrp topology ou show interface, é em microssegundos, portanto é necessário dividi-lo por 10 antes de poder usá-lo nessa fórmula. Ao longo deste documento, o retardo é utilizado da forma como configurado e mostrado na interface.

O EIGRP usa estes valores escalados para determinar a métrica total à rede:

  • métrica = ([K1 * largura de banda + (K2 *) da largura de banda/(256 - carga) + K3 * atraso] * [K5/(confiança + K4)]) * 256

Nota: Esses valores K devem ser usados depois de um planejamento cuidadoso. Os valores combinados mal K impedem um relacionamento vizinho esteja construído, que podem fazer com que sua rede não convirgem.

Nota: Se o K5 = 0, a fórmula se reduz à métrica = ([k1 * largura de banda + (k2 * bandwidth)/(256 - carga) + k3 * atraso]) * 256.

Os valores padrão para K são:

  • K1 = 1

  • K2 = 0

  • K3 = 1

  • K4 = 0

  • K5 = 0

Para o comportamento padrão, você pode simplificar a fórmula como a seguir:

metric = bandwidth + delay 

Os Cisco routers não realizam cálculos de ponto flutuante; por isso, em cada estágio do cálculo, é necessário arredondar para o menor número inteiro mais próximo para calcular a métrica corretamente. Neste exemplo, o custo total para o Roteador 4 é:

Neste exemplo, o custo total para o Roteador 4 é:

minimum bandwidth = 56k 

total delay = 100 + 100 + 2000 = 2200 

[(10000000/56) + 2200] x 256 = (178571 + 2200) x 256 = 180771 x 256 = 46277376  

E os custos total através do roteador três são:

minimum bandwidth = 128k 

total delay = 100 + 100 + 1000 = 1200 

[(10000000/128) + 1200] x 256 = (78125 + 1200) x 256 = 79325 x 256 = 20307200  

Portanto para alcançar a Rede A, o Roteador Um escolhe a rota no Roteador Três.

Observe que os valores de largura de banda e de atraso que usamos são os valores configurados na interface através da qual o roteador alcança seu próximo salto em direção à rede de destino. Por exemplo, rede anunciada A do roteador dois com o atraso configurado em sua interface Ethernet; O Roteador Quatro adicionou o atraso configurado em sua Ethernet e Roteador Um adicionou o atraso configurado em seu serial.

Distância factível, distância informada e sucessor possível

A distância factível é a melhor métrica ao longo de um trajeto a uma rede de destino, incluindo a métrica à propaganda vizinha que trajeto. A distância relatada é a medição total ao longo de um caminho para uma rede de destino conforme anunciado por um vizinho upstream. Um sucessor possível é um trajeto cuja a distância informada seja menos do que a distância factível (melhor caminho atual). A Figura 3 ilustra este processo:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp3.gif

O roteador um vê que tem duas rotas à rede A: um através do roteador três e outro através do roteador quatro.

  • A rota através do roteador quatro tem um custo de 46277376 e uma distância informada de 307200.

  • A rota através do roteador três tem um custo de 20307200 e uma distância informada de 307200.

Note isso em cada caso EIGRP calcula a distância informada do roteador que anuncia a rota à rede. Em outras palavras, a distância reportada do Roteador Quatro é a métrica para chegar à Rede A do Roteador Quatro, e a distância reportada do Roteador Três é a métrica para chegar à Rede A do Roteador Três. O EIGRP seleciona a rota através do roteador três como o melhor caminho e utiliza a métrica através do roteador três como a distância possível. Como a distância reportada para esta rede pelo Roteador quatro é menor do que a distância possível, o Roteador um considera o caminho pelo Roteador quatro um sucessor viável.

Quando o enlace entre os Roteadores 1 e 3 é desativado, o Roteador 1 examina cada caminho que conhece para a Rede A e descobre que há sucessor viável por meio do Roteador 4. O Roteador 1 usa essa rota, utilizando a métrica por meio do Roteador 4 como a nova distância possível. A rede convirge imediatamente, e as atualizações aos vizinhos downstream são o único tráfego do protocolo de roteamento.

Deixe-nos olhar mais cenário complexo, mostrado em figura 4.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp4.gif

Há duas rotas à rede A do roteador um: um através do roteador dois com uma métrica de 46789376 e outro através do roteador quatro com uma métrica de 20307200. O roteador um escolhe a menor dessas duas métricas como a rota para a rede A e esta métrica se torna a distância factível. Em seguida, deixe-nos olhar o trajeto através do roteador dois para ver se qualifica como um sucessor possível. A distância relatada do roteador dois é 46277376, que é maior do que a distância viável – portanto, este caminho não é um sucessor viável. A essa altura, se você precisasse olhar na tabela de topologia do Roteador Um (por meio de show ip eigrp topology), você veria apenas uma entrada para a Rede A até o Roteador Quatro. (Na realidade há duas entradas na tabela de topologia no roteador um, mas somente um será um sucessor possível, assim que o outro não será indicado na topologia do eigrp da mostra IP; você pode ver as rotas que não são sucessores viáveis, utilizando o comando using show ip eigrp topology all-links).

Deixe-nos supor que o link entre o roteador um e o roteador quatro vai para baixo. O roteador um percebe que perdeu sua única rota para a rede A e consulta cada um de seus vizinhos (neste caso, apenas o roteador 2) para ver se têm uma rota para a rede A. Desde que o roteador dois tem uma rota à rede A, responde à pergunta. Como o Roteador Um não possui mais a melhor rota até o Roteador Quatro, ele aceita a rota até o Roteador Dois para a Rede A.

Decidindo se um caminho não tem circuito

Como o EIGRP usa os conceitos da distância factível, a distância informada, e o sucessor possível para determinar se um trajeto é válido, e não um laço? Na Figura 4a, o roteador três examina as rotas para a rede A. Desde que o horizonte rachado está desabilitado (por exemplo, se estas são interfaces do Frame Relay multiponto), mostras do roteador três três rotas à rede A: pelo roteador quatro, pelo roteador dois (o caminho é dois, um, três, quatro) e pelo roteador um (o caminho é um, dois, três, quatro).

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp21.gif

Se o Router 3 aceitar todas essas rotas, ocorrerá um loop de roteamento. O Roteador 3 pensa que pode chegar à Rede A por meio do Roteador 2, mas o caminho até o Roteador 2 passa pelo Roteador 3 para chegar à Rede A. Se a conexão entre o roteador quatro e o roteador três vai para baixo, o roteador três acredita que pode obter à rede A com um dos outros trajetos, mas devido às regras para determinar sucessores possíveis, nunca usará estes trajetos como substituições. Deixe-nos olhar o medidor para ver porque:

  • totalize a métrica à rede A através do roteador quatro: 20281600

  • totalize a métrica à rede A através do roteador dois: 47019776

  • totalize a métrica à rede A com o roteador um: 47019776

Desde que o trajeto através do roteador quatro tem a melhor métrica, o roteador três instala esta rota na tabela do forwarding e usa 20281600 enquanto sua distância factível à rede A. Roteador três computa então a distância informada à rede A através do Roteadores dois e um: 47019776 para o caminho pelo Roteador 2 e 47019776 para o caminho pelo Roteador 1. Porque both of these o medidor é maior do que a distância factível, o roteador três não instala uma ou outra rota como um sucessor possível para a rede A.

Imagine que o link entre os Roteadores 3 e 4 esteja desativado. O roteador três consulta cada um de seus vizinhos em busca de uma rota alternativa para a Rede A. O roteador dois recebe a consulta e, como ela vem de seu sucessor, pesquisa cada uma das outras entradas de sua tabela de topologia para ver se há um sucessor adequado. O único a outra entrada na tabela de topologia é do roteador um, com uma distância informada igual à última melhor métrica conhecida através do roteador três. Porque a distância informada com o roteador um é não menos que a última distância factível conhecida, o roteador dois marca a rota como inacessível e pergunta cada um de seus vizinhos - neste caso, somente roteador um - para um trajeto à rede A.

O roteador três igualmente envia uma pergunta para a rede A ao roteador um. O Roteador Um examina a tabela de topologia e percebe que o outro único caminho para a Rede A é através do Roteador Dois com uma distância informada igual à última distância viável conhecida através do Roteador Três. Mais uma vez, desde que a distância informada através do roteador dois é não menos que a última distância factível conhecida, esta rota não é um sucessor possível. O Roteador Um marca a rota como inalcançável e consulta seu único vizinho, o Roteador Dois, sobre um caminho para a Rede A.

Esse é o primeiro nível das consultas. O roteador três perguntou cada um de seus vizinhos na tentativa de encontrar por sua vez uma rota à rede A., o Roteadores um e dois marcou a rota inacessível, e perguntou cada um de seus vizinhos restantes na tentativa de encontrar um trajeto à rede A. Quando o roteador dois recebe a pergunta do roteador um, examina sua tabela de topologia e nota que o destino está marcado como inacessível. Respostas do roteador dois ao roteador um que a rede A é inacessível. Quando o roteador 1 recebe a consulta do roteador 2, ele envia de volta uma resposta informando que a rede A não pode ser alcançada. Agora o Roteadores um e dois concluiu que a rede A é inacessível, e responde à pergunta original do roteador três. A rede convergiu, e todas as rotas retornam ao estado passivo.

Split Horizon e Poison Reverse

No exemplo anterior, supomos que split horizon não estava vigorando, para mostrar como o EIGRP utiliza a distância possível e a distância relatada para determinar a probabilidade de uma rota ser um circuito. Em algumas circunstâncias, contudo, o EIGRP usa horizonte rachado para impedir também loop de roteamento. Antes de tratar os detalhes de como o EIGRP usa horizonte rachado, deixe nos rever o que racham o horizonte é e como trabalha. A regra de horizonte dividido diz:

  • Nunca anuncie uma rota fora da relação através de que você a aprendeu.

Por exemplo, na figura 4a, se o roteador um está conectado ao Roteadores dois e três através de uma única interface multiponto (tal como o Frame Relay), e no roteador um aprendido sobre a rede A do roteador dois, não anunciará a rota à parte traseira da rede A para fora a mesma relação ao roteador três. O roteador um pressupõe que o roteador três obteria informações sobre a rede A diretamente do roteador dois.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp21.gif

O poison é outra forma de evitar loops de roteamento. A regra diz:

  • Assim que você identificar uma rota por meio de uma interface, anuncie-a como inacessível por meio da mesma interface.

Deixe-nos dizer o Roteadores na figura 4a têm o poison reverse permitido. Quando o Roteador 1 identifica a Rede A à partir do Roteador 2, ele anuncia a Rede A como sendo de alcance impossível através de seu enlace para os Roteadores 2 e 3. O roteador três, se mostra qualquer trajeto à rede A com o roteador um, remove esse trajeto devido ao anúncio inalcançável. O EIGRP combina essas duas regras para ajudar a evitar circuitos de roteamento.

O EIGRP usa divisão horizontal ou anuncia uma rota como inalcançável quando:

  • dois roteadores estão em modo de inicialização (trocando tabelas de topologia pela primeira vez)

  • anuncia uma alteração na tabela de topologia

  • enviando uma consulta

Deixe-nos examinar cada um destas situações.

Modo de inicialização

Quando dois roteadores se tornarem vizinhos pela primeira vez, eles trocam tabelas de topologia durante o modo de inicialização. Para cada entrada de tabela que um roteador recebe durante o modo de inicialização, ele anuncia a mesma entrada de volta para o seu novo vizinho com uma métrica máxima (poison route).

Alteração na tabela de topologia

Na Figura 5, o Roteador um usa variações para balancear o tráfego destinado à Rede A entre os dois enlaces seriais – o enlace de 56k entre os roteadores dois e quatro e o enlace 128k entre os roteadores três e quatro. Consulte a seção Load Balancing (Balanceamento de carga) para uma discussão de variação.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp5.gif

O roteador dois vê o trajeto através do roteador três como um sucessor possível. Se o link entre o Roteadores dois e quatro vai para baixo, o roteador dois re-convirge simplesmente no trajeto através do roteador três. Como a regra split horizon declara que você nunca deve anunciar uma rota fora da interface por meio da qual a conheceu, o Roteador dois normalmente não enviaria uma atualização. No entanto, isso deixa o Roteador um com uma entrada de tabela de topologia inválida. Quando um roteador altera a tabela de topologia de modo a alterar a interface através da qual alcança a rede, ele desativa o split horizon e o poison reverses da rota antiga em todas as interfaces. Nesse caso, o Roteador Dois desativa split horizon para essa rota e anuncia a Rede A como inalcançável. O Roteador 1 ouve esse anúncio e libera sua rota para a Rede A por meio do Roteador 2, a partir da sua tabela de roteamento.

Consultas

As consultas resultam em um horizonte dividido apenas quando um roteador receber uma consulta ou atualização do sucessor que está usando para o destino na consulta. Deixe-nos olhar a rede na figura 6.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp6.gif

O roteador três recebe uma pergunta a respeito de 10.1.2.0/24 (que alcança com o roteador um) do roteador quatro. Se três não têm um sucessor para este destino porque um flap do link ou a outra condição da rede temporária, ele enviam uma pergunta a cada um de seus vizinhos; neste caso, Roteadores um, dois, e quatro. Se, contudo, o roteador três recebe uma pergunta ou a atualização (tal como uma mudança métrica) do roteador um para o destino 10.1.2.0/24, ele não envia uma pergunta de volta ao roteador um, porque o roteador um é seu sucessor a esta rede. Em lugar de, envia somente a perguntas ao Roteadores dois e quatro.

Rotas Stuck In Active

Às vezes, as consultas demoram muito a ser respondidas. Tão por muito tempo, de facto, que o roteador que emitiu a pergunta dá acima e cancela sua conexão ao roteador que não está respondendo, reiniciando eficazmente a sessão de vizinho. Ela é conhecida como uma rota Stuck-In-Active (SIA). As rotas SIA mais básicas ocorrem quando uma consulta demora muito para chegar à outra extremidade da rede, e para uma resposta retornar. Por exemplo, na Figura 7, o roteador 1 está registrando um grande número de rotas SIA a partir do roteador 2.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp7.gif

Depois de um pouco de investigação, o problema é reduzido para o retardo no enlace por satélite entre os roteadores dois e três. Existem duas soluções possíveis para esse tipo de problema. A primeira é aumentar a quantidade de tempo que o roteador espera após o envio de uma consulta antes de declarar a rota SIA. Essa configuração pode ser alterada com o uso do comando timers active-time.

A melhor solução, no entanto, é recriar a rede para reduzir o intervalo de consultas (poucas consultas passam pelo enlace do satélite). O intervalo de consulta é coberto na seção Intervalo de consulta. Porém, o intervalo de consulta em si não é uma razão comum para rotas SIA informadas. Mais frequentemente, algum roteador na rede não pode responder a uma pergunta para uma das seguintes razões:

  • o roteador está muito ocupado para responder à consulta (geralmente, devido a uma utilização elevada da CPU)

  • o roteador está com problemas de memória e não é possível alocar a memória para processar a consulta ou construir o pacote de resposta

  • o circuito entre os dois roteadores não está em boas condições - pacotes suficientes são passados para manter o relacionamento vizinho ativo, mas algumas consultas ou respostas estão sendo perdidas entre os roteadores

  • enlaces unidirecional (um link em que o tráfego pode somente fluir em um sentido devido a uma falha)

Troubleshooting de Rotas SIA

O Troubleshooting de rotas SIA normalmente é um processo de três passos:

  1. Encontre as rotas que estão sendo relatadas consistentemente como o SIA.

  2. Encontre o roteador que consistentemente não está respondendo a perguntas para estas rotas.

  3. Descubra o motivo pelo qual o roteador não está recebendo nem respondendo consultas.

O primeiro passo deve ser bastante simples. Se você é mensagens de console de registro, uma investigação rápida do log indica que rotas são mais frequentemente SIA marcado. O segundo passo é mais difícil. O comando recolher esta informação é show ip eigrp topology ative:

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, 
       r - Reply status 

A 10.2.4.0/24, 0 successors, FD is 512640000, Q 
    1 replies, active 00:00:01, query-origin: Local origin 
         via 10.1.2.2 (Infinity/Infinity), Serial1 
    1 replies, active 00:00:01, query-origin: Local origin 
         via 10.1.3.2 (Infinity/Infinity), r, Serial3 
    Remaining replies: 
         via 10.1.1.2, r, Serial0

Os vizinhos que exibem um R, ainda têm que responder (o temporizador ativo mostra por quanto tempo a rota esteve ativa). Note que estes vizinhos não podem aparecer na seção das Respostas restantes; podem aparecer entre os outros RDB. Preste atenção especial às rotas que possuem respostas pendentes e que estão ativas há algum tempo, geralmente, de dois a três minutos. Execute esse comando diversas vezes e você começará a ver quais vizinhos não estão respondendo às consultas (ou quais interfaces parecem ter muitas consultas não respondidas). Examine este vizinho para ver se está esperando consistentemente respostas de alguns de seus vizinhos. Repita este processo até que você encontre o roteador que consistentemente não está respondendo a perguntas. Você pode procurar problemas no link para esse vizinho, essa utilização de memória ou CPU ou outro problema com esse vizinho.

Se você é executado em uma situação onde pareça que a escala da pergunta é o problema, é sempre o melhor reduzir a escala da pergunta um pouco do que aumentando o temporizador de SIA.

Redistribuição

Esta seção examina diferentes cenários que envolvem redistribuição. Note por favor que os exemplos abaixo mostram o mínimo exigido configurar a redistribução. A redistribuição pode causar problemas potenciais, como o roteamento não otimizado, os circuitos de roteamento ou a convergência lenta. Para evitar estes problemas, veja por favor o “evitando problemas devido à redistribuição” em redistribuir protocolos de roteamento.

Redistribuição entre dois sistemas autônomos EIGRP

Em figura 8, o Roteadores é configurado como segue:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp8.gif

Roteador um

router eigrp 2000 

!--- The "2000" is the autonomous system 

 network 172.16.1.0 0.0.0.255 

Roteador Dois

router eigrp 2000 
 redistribute eigrp 1000 route-map to-eigrp2000
 network 172.16.1.0 0.0.0.255 
! 
router eigrp 1000 
 redistribute eigrp 2000 route-map to-eigrp1000
 network 10.1.0.0 0.0.255.255

route-map to-eigrp1000 deny 10
match tag 1000
!
route-map to-eigrp1000 permit 20
set tag 2000
!
route-map to-eigrp2000 deny 10
match tag 2000
!
route-map to-eigrp2000 permit 20
set tag 1000

Roteador Três

router eigrp 1000 
 network 10.1.0.0 0.0.255.255

O roteador três está anunciando a rede 10.1.2.0/24 ao roteador dois ao sistema autônomo 1000; O roteador dois está redistribuindo esta rota no sistema autônomo 2000 e está anunciando-a ao roteador um.

Nota: As rotas de EIGRP 1000 são etiquetadas 1000 antes de redistribui-los a EIGRP 2000. Quando as rotas de EIGRP 2000 são redistribuídas de volta a EIGRP 1000, as rotas com 1000 etiquetas estão negadas para assegurar uma topologia sem loop. Para obter mais informações sobre a redistribuição entre protocolos de roteamento, consulte Redistribuindo Routing Protocols.

No roteador 1, vemos:

one# show ip eigrp topology 10.1.2.0 255.255.255.0 
IP-EIGRP topology entry for 10.1.2.0/24 
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 46763776 
  Routing Descriptor Blocks: 
  20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0 
      Composite metric is (46763776/46251776), Route is External 
      Vector metric: 
        Minimum bandwidth is 56 Kbit 
        Total delay is 41000 microseconds 
        Reliability is 255/255 
        Load is 1/255 
        Minimum MTU is 1500 
        Hop count is 2 
      External data: 
        Originating router is 10.1.2.1 
        AS number of route is 1000 
        External protocol is EIGRP, external metric is 46251776 
        Administrator tag is 1000 (0x000003E8)

Observe que, embora o link entre os Roteadores 1 e 2 tenha uma largura de banda de 1,544Mb, a largura de banda mínima mostrada nessa entrada de tabela de topologia é de 56k. Isso significa que o EIGRP preserva todas as métricas ao redistribuir entre dois sistemas autônomos EIGRP.

Redistribuição entre EIGRP e IGRP em dois sistemas autônomos diferentes

Na Figura 9, alteramos as configurações da seguinte maneira:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp9.gif

Roteador um

router eigrp 2000 
 network 172.16.1.0

Roteador Dois

router eigrp 2000 
 redistribute igrp 1000 route-map to-eigrp2000
 network 172.16.1.0
! 
router igrp 1000 
 redistribute eigrp 2000 route-map to-igrp1000
 network 10.0.0.0 
!

route-map to-igrp1000 deny 10
match tag 1000
!
route-map to-igrp1000 permit 20
set tag 2000
!
route-map to-eigrp2000 deny 10
match tag 2000
!
route-map to-eigrp2000 permit 20
set tag 1000

Roteador Três

router igrp 1000 
 network 10.0.0.0

A configuração do Roteador 1 é exibida abaixo:

one# show ip eigrp topology 10.1.2.0 255.255.255.0 
IP-EIGRP topology entry for 10.1.2.0/24 
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 46763776 
  Routing Descriptor Blocks: 
  20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0 
      Composite metric is (46763776/46251776), Route is External 
      Vector metric: 
        Minimum bandwidth is 56 Kbit 
        Total delay is 41000 microseconds 
        Reliability is 255/255 
        Load is 1/255 
        Minimum MTU is 1500 
        Hop count is 1 
      External data: 
        Originating router is 10.1.1.1 
        AS number of route is 1000 
        External protocol is IGRP, external metric is 180671 
        Administrator tag is 1000 (0x000003E8)

As métricas de IGRP são preservadas quando as rotas são redistribuídas no EIGRP com um sistema autônomo diferente,mas são dimensionadas com a multiplicação da métrica IGRP pela constante 256. Há uma interrupção do processo de redistribuição entre IGRP e EIGRP que deve ser observada. Se a rede é conectada diretamente ao roteador que faz a redistribução, anuncia a rota com uma métrica de 1.

Por exemplo, a rede 10.1.1.0/24 está diretamente conectada ao Roteador Dois e o IGRP está fazendo o roteamento para essa rede (há uma instrução de rede sob o roteador de IGRP que compreende essa interface). O EIGRP não está fazendo roteamento para essa rede, contudo está aprendendo sobre a interface diretamente conectada por meio da redistribuição do IGRP. No roteador um, a entrada da tabela de topologia para 10.1.1.0/24 mostra:

one# show ip eigrp topology 10.1.1.0 255.255.255.0 
IP-EIGRP topology entry for 10.1.1.0/24 
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2169856 
  Routing Descriptor Blocks: 
  20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0 
      Composite metric is (2169856/1), Route is External 
                                    
      Vector metric: 
        Minimum bandwidth is 1544 Kbit 
        Total delay is 20000 microseconds 
        Reliability is 0/255 
        Load is 1/255 
        Minimum MTU is 1500 
        Hop count is 1 
      External data: 
        Originating router is 10.1.1.1 
        AS number of route is 1000 
        External protocol is IGRP, external metric is 0 
        Administrator tag is 1000 (0x000003E8)

Observe que a distância relatada do roteador dois, que está em negrito, é 1".

Redistribuição entre EIGRP e IGRP no mesmo sistema autônomo

As alterações a seguir são feitas para as configurações do roteador na Figura 10:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp10.gif

Roteador um

router eigrp 2000 
 network 172.16.1.0 

Roteador Dois

router eigrp 2000 
 network 172.16.1.0
! 
router igrp 2000 
 network 10.0.0.0

Roteador Três

router igrp 2000 
 network 10.0.0.0

E o roteador um é configurado como segue:

one# show ip eigrp topology 10.1.2.0 255.255.255.0 
IP-EIGRP topology entry for 10.1.2.0/24 
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 46763776 
  Routing Descriptor Blocks: 
  20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0 
      Composite metric is (46763776/46251776), Route is External 
      Vector metric: 
        Minimum bandwidth is 56 Kbit 
        Total delay is 41000 microseconds 
        Reliability is 255/255 
        Load is 1/255 
        Minimum MTU is 1500 
        Hop count is 1 
      External data: 
        Originating router is 10.1.1.1 
        AS number of route is 2000 
        External protocol is IGRP, external metric is 180671 
        Administrator tag is 0 (0x00000000)

Essa configuração se parece surpreendentemente como a saída anterior quando estávamos redestribuindo entre dois sistemas autônomos diferentes executando o IGRP e o EIGRP. A rede 10.1.1.0/24 diretamente conectada é tratada da mesma forma nas duas situações:

one# show ip eigrp topology 10.1.1.0 255.255.255.0 
IP-EIGRP topology entry for 10.1.1.0/24 
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2169856 
  Routing Descriptor Blocks: 
  20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0 
      Composite metric is (2169856/1), Route is External 
      Vector metric: 
        Minimum bandwidth is 1544 Kbit 
        Total delay is 20000 microseconds 
        Reliability is 255/255 
        Load is 1/255 
        Minimum MTU is 1500 
        Hop count is 1 
      External data: 
        Originating router is 10.1.1.1 
        AS number of route is 2000 
        External protocol is IGRP, external metric is 0 
        Administrator tag is 0 (0x00000000)

Então, essa rede, que está diretamente conectada com o Roteador Um, é redistribuída de IGRP para EIGRP com uma métrica de 1 - a mesma métrica vista na redistribuição entre dois sistemas autônomos diferentes.

Há duas advertências com redistribução EIGRP/IGRP dentro do mesmo sistema autônomo:

  • Rotas EIGRP internas sempre têm preferência sobre as rotas EIGRP ou IGRP externas.

  • O medidor da rota de EIGRP externa é comparado às métricas de IGRP escaladas (a distância administrativa é ignorada).

Deixe-nos examinar estas advertências em figura 11:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp11.gif

O roteador um anuncia 10.1.4.0/24 no sistema autônomo 100 IGRP; O roteador quatro anuncia 10.1.4.0/24 como um externo no sistema autônomo de EIGRP 100; O Roteador 2 executa tanto o EIGRP quanto o IGRP no sistema autônomo 100.

Se ignorarmos a rota EIGRP anunciada pelo roteador 4 (desativando o enlace entre os roteadores 2 e 4, por exemplo), o roteador 2 mostra:

two# show ip route 10.1.4.0 
Routing entry for 10.1.4.0/24 
  Known via "igrp 100", distance 100, metric 12001 
  Redistributing via igrp 100, eigrp 100 
  Advertised by igrp 100 (self originated) 
                eigrp 100 
  Last update from 10.1.1.2 on Serial1, 00:00:42 ago 
  Routing Descriptor Blocks: 
  * 10.1.1.2, from 10.1.1.2, 00:00:42 ago, via Serial1 
      Route metric is 12001, traffic share count is 1 
      Total delay is 20010 microseconds, minimum bandwidth is 1000 Kbit 
      Reliability 1/255, minimum MTU 1 bytes 
      Loading 1/255, Hops 0

Note a distância administrativa é 100. Quando nós adicionarmos a rota de EIGRP, mostras do roteador dois:

two# show ip route 10.1.4.0 
Routing entry for 10.1.4.0/24 
  Known via "eigrp 100", distance 170, metric 3072256, type external 
  Redistributing via igrp 100, eigrp 100 
  Last update from 10.1.2.2 on Serial0, 00:53:59 ago 
  Routing Descriptor Blocks: 
  * 10.1.2.2, from 10.1.2.2, 00:53:59 ago, via Serial0 
      Route metric is 3072256, traffic share count is 1 
      Total delay is 20010 microseconds, minimum bandwidth is 1000 Kbit 
      Reliability 1/255, minimum MTU 1 bytes 
      Loading 1/255, Hops 1

Note o medidor para estas duas rotas são o mesmos após a escamação do IGRP ao EIGRP (veja a seção do medidor):

  • 12001 x 256 = 3072256

onde 12001, uma métrica de IGRP, é com o roteador um; e 3072256, uma métrica EIGRP, são através do roteador quatro.

O roteador Dois prefere a rota externa EIGRP com a mesma métrica (depois de escalar) e uma maior distância administrativa. Isso é verdadeiro sempre que ocorrer redistribuição automática entre EIGRP e IGRP dentro do mesmo sistema autônomo. O roteador sempre prefere o caminho com a métrica de custo mais baixa e ignora a distância administrativa.

Redistribuição de e para outros protocolos

A redistribuição entre EIGRP e outros protocolos – por exemplo, RIP e OSPF – funciona da mesma maneira que qualquer outra redistribuição. É sempre o melhor usar a métrica do padrão ao redistribuir entre protocolos. Você deve estar ciente de dois problemas ao fazer a redistribuição entre EIGRP e outros protocolos:

Redistribuição de rotas estáticas para interfaces

Quando você instalar uma rota estática em uma interface e configura uma instrução de rede utilizando o eigrp de roteador, que inclui a rota estática, o EIGRP redistribui essa rota como se ela estivesse diretamente conectada à interface. Deixe-nos olhar a rede em figura 12.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp12.gif

O roteador um tem uma rota estática para a rede 172.16.1.0/24 configurada por meio da interface Serial 0:

ip route 172.16.1.0 255.255.255.0 Serial0

E o roteador um igualmente tem uma instrução de rede para o destino desta rota estática:

router eigrp 2000 
 network 10.0.0.0 
 network 172.16.0.0 
 no auto-summary 

O Roteador Um redistribui essa rota, mesmo que não redistribua rotas estáticas, porque o EIGRP o considera uma rede diretamente conectada. No roteador dois, isto olham como segue:

two# show ip route 
    .... 
        10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks 
    C       10.1.1.0/24 is directly connected, Serial0
    D       10.1.2.0/24 [90/2169856] via 10.1.1.1, 00:00:47, Serial0
         172.16.0.0/24 is subnetted, 1 subnets 
    D       172.16.1.0 [90/2169856] via 10.1.1.1, 00:00:47, Serial0

Note a rota a 172.16.1.0/24 aparece como uma rota de EIGRP interno no roteador dois.

Sumarização

Há dois formulários da sumarização no EIGRP: resumos automáticos e sumários de manual.

Sumarização automática

O EIGRP executa um resumo automático cada vez que cruza uma beira entre duas redes principal diferentes. Por exemplo, na Figura 13, o roteador dois anuncia somente a rede 10.0.0.0/8 ao roteador um, pois a interface usada pelo roteador dois para alcançar o roteador um está em uma rede principal diferente.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp13.gif

No Roteador Um, se parece com o seguinte:

one# show ip eigrp topology 10.0.0.0 
IP-EIGRP topology entry for 10.0.0.0/8 
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 11023872 
  Routing Descriptor Blocks: 
  172.16.1.1 (Serial0), from 172.16.1.2, Send flag is 0x0 
      Composite metric is (11023872/10511872), Route is Internal 
      Vector metric: 
        Minimum bandwidth is 256 Kbit 
        Total delay is 40000 microseconds 
        Reliability is 255/255 
        Load is 1/255 
        Minimum MTU is 1500 
        Hop count is 1

Esta rota não é marcada como uma rota sumária em nenhuma maneira; olha como uma rota interna. A métrica é a melhor dentre as rotas resumidas. Note que a largura de banda mínima nesta rota é 256k, embora haja os links na rede de 10.0.0.0 que têm uma largura de banda do 56K.

No roteador que está executando o resumo, é construída uma rota em null0 para o endereço resumido:

two# show ip route 10.0.0.0 
Routing entry for 10.0.0.0/8, 4 known subnets 
  Attached (2 connections) 
  Variably subnetted with 2 masks 
  Redistributing via eigrp 2000 

C       10.1.3.0/24 is directly connected, Serial2 
D       10.1.2.0/24 [90/10537472] via 10.1.1.2, 00:23:24, Serial1 
D       10.0.0.0/8 is a summary, 00:23:20, Null0 
C       10.1.1.0/24 is directly connected, Serial1

A rota para 10.0.0.0/8 está marcada como resumo através de Null0. A entrada de tabela de topologia para esta rota sumária olha como o seguinte:

two# show ip eigrp topology 10.0.0.0 
IP-EIGRP topology entry for 10.0.0.0/8 
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 10511872 
  Routing Descriptor Blocks: 
  0.0.0.0 (Null0), from 0.0.0.0, Send flag is 0x0 
          (note: the 0.0.0.0 here means this route is originated by this router) 
      Composite metric is (10511872/0), Route is Internal 
      Vector metric: 
        Minimum bandwidth is 256 Kbit 
        Total delay is 20000 microseconds 
        Reliability is 255/255 
        Load is 1/255 
        Minimum MTU is 1500 
        Hop count is 0

Para fazer o roteador 2 anunciar os componentes da rede 10.0.0.0 em vez de um resumo, configure para sem auto-resumo no processo EIGRP no roteador 2:

No Roteador 2

router eigrp 2000 
 network 172.16.0.0 
 network 10.0.0.0 
 no auto-summary

Com o auto resumo desligado, o roteador um agora vê todos os componentes da rede 10.0.0.0:

one# show ip eigrp topology 
IP-EIGRP Topology Table for process 2000 

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, 
       r - Reply status 

P 10.1.3.0/24, 1 successors, FD is 46354176 
         via 20.1.1.1 (46354176/45842176), Serial0 
P 10.1.2.0/24, 1 successors, FD is 11049472 
         via 20.1.1.1 (11049472/10537472), Serial0 
P 10.1.1.0/24, 1 successors, FD is 11023872 
         via 20.1.1.1 (11023872/10511872), Serial0 
P 172.16.1.0/24, 1 successors, FD is 2169856 
         via Connected, Serial0

Há alguns caveats ao lidar com o resumo de rotas externas que serão cobertos mais adiante na seção Resumo automático de rotas externas.

Sumarização manual

O EIGRP permite resumir rotas internas e externas em praticamente qualquer limite de bit usando o resumo manual. Por exemplo, na Figura 14, o roteador dois está resumindo 192.1.1.0/24, 192.1.2.0/24 e 192.1.3.0/24 no bloco CIDR 192.1.0.0/22.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp14.gif

A configuração no roteador dois é mostrada abaixo:

two# show run 
.... 
! 
interface Serial0 
 ip address 10.1.50.1 255.255.255.0 
 ip summary-address eigrp 2000 192.1.0.0 255.255.252.0 
 no ip mroute-cache 
! 
.... 

two# show ip eigrp topology 
IP-EIGRP Topology Table for process 2000 

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, 
       r - Reply status

P 10.1.10.0/24, 1 successors, FD is 45842176 
         via Connected, Loopback0 
P 10.1.50.0/24, 1 successors, FD is 2169856 
         via Connected, Serial0 
P 192.1.1.0/24, 1 successors, FD is 10511872 
         via Connected, Serial1 
P 192.1.0.0/22, 1 successors, FD is 10511872 
         via Summary (10511872/0), Null0 
P 192.1.3.0/24, 1 successors, FD is 10639872 
         via 192.1.1.1 (10639872/128256), Serial1 
P 192.1.2.0/24, 1 successors, FD is 10537472 
         via 192.1.1.1 (10537472/281600), Serial1

Note o comando ip summary-address eigrp sob o serial0 da relação, e a rota sumária através do null0. No Roteador um, observamos isso como uma rota interna:

  one# show ip eigrp topology 
IP-EIGRP Topology Table for process 2000 

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, 
       r - Reply status 

P 10.1.10.0/24, 1 successors, FD is 46354176 
         via 10.1.50.1 (46354176/45842176), Serial0 
P 10.1.50.0/24, 1 successors, FD is 2169856 
         via Connected, Serial0 
P 192.1.0.0/22, 1 successors, FD is 11023872 
         via 10.1.50.1 (11023872/10511872), Serial0

Resumo automático de rotas externas

O EIGRP não fará o auto-resumo das rotas externas, a menos que haja um componente da mesma rede principal que seja uma rota interna. Para ilustrar, vamos observar a Figura 15.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp15.gif

O roteador três está injetando rotas externas a 192.1.2.0/26 e a 192.1.2.64/26 no EIGRP usando o comando redistribute connected, segundo as indicações das configurações abaixo.

Roteador Três

interface Ethernet0 
 ip address 192.1.2.1 255.255.255.192 
! 
interface Ethernet1
 ip address 192.1.2.65 255.255.255.192
!
interface Ethernet2
 ip address 10.1.2.1 255.255.255.0
!router eigrp 2000 
 redistribute connected 
 network 10.0.0.0 
 default-metric 10000 1 255 1 1500

Com essa configuração no Roteador Três, a tabela de roteamento no Roteador Um mostra:

  one# show ip route
.... 
     10.0.0.0/8 is subnetted, 2 subnets 
D       10.1.2.0 [90/11023872] via 10.1.50.2, 00:02:03, Serial0 
C       10.1.50.0 is directly connected, Serial0 
     192.1.2.0/26 is subnetted, 1 subnets 
D EX    192.1.2.0 [170/11049472] via 10.1.50.2, 00:00:53, Serial0 
D EX    192.1.2.64 [170/11049472] via 10.1.50.2, 00:00:53, Serial0

Embora o resumo automático faça com normalmente que o roteador três resuma as 192.1.2.0/26 e 192.1.2.64/26 rotas em um destino da rede principal (192.1.2.0/24), não faz este porque ambas as rotas são externos. No entanto, se você reconfigurar o enlace entre os Roteadores 2 e 3 para 192.1.2.128/26 e adicionar instruções dessa rede nos Roteadores 2 e 3, o resumo automático 192.1.2.0/24 será gerado no Roteador 2.

Roteador Três

 interface Ethernet0 
 ip address 192.1.2.1 255.255.255.192 
! 
interface Ethernet1
 ip address 192.1.2.65 255.255.255.192
!
interface Serial0 
 ip address 192.1.2.130 255.255.255.192 
! 
router eigrp 2000 
 network 192.1.2.0

Agora o roteador dois gera o resumo para 192.1.2.0/24:

two# show ip route 
.... 
D       192.1.2.0/24 is a summary, 00:06:48, Null0
....

E o Roteador Um mostra somente a rota sumária:

 one# show ip route 
.... 
     10.0.0.0/8 is subnetted, 1 subnets 
C       10.1.1.0 is directly connected, Serial0 
D    192.1.2.0/24 [90/11023872] via 10.1.50.2, 00:00:36, Serial0

Processamento e intervalo de consulta

Quando um roteador processa uma consulta de um vizinho, as seguintes regras se aplicam:

Pergunta de Estado da rota Ação
vizinho (não o sucessor atual) passivo resposta com informação do sucessor atual
sucessor passivo tentativa de encontrar o sucessor novo; se bem sucedido, responda com informação nova; se não bem sucedido, marque o destino inacessível e pergunte todos os vizinhos exceto o sucessor anterior
qualquer vizinho nenhum caminho por este vizinho antes da consulta resposta com o melhor caminho conhecido atualmente
qualquer vizinho desconhecido antes da consulta responda que o destino é inacessível
vizinho (não o sucessor atual) ativo se não houver um sucessor atual para estes destinos (normalmente, isso seria verdadeiro), responda com um inalcançável
se houver um bom sucessor, responda com as informações do caminho atual
sucessor ativo tentativa de encontrar o sucessor novo; se bem sucedido, responda com informação nova; se não bem sucedido, marque o destino inacessível e pergunte todos os vizinhos exceto o sucessor anterior

As ações no impacto acima da tabela a escala da pergunta na rede determinando quanto Roteadores recebe e na resposta à pergunta antes da rede convirgem na topologia nova. Para ver como essas regras afetam a maneira como as consultas são tratadas, vamos analisar a rede na Figura 16, que está sendo executada em condições normais.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16.gif

O seguinte acontecimento pode ser esperado em relação à rede 192.168.3.0/24 (no lado extremo direito):

  • O Roteador Um tem dois caminhos para 192.168.3.0/24:

    • pelo Roteador Dois com uma distância de 46533485 e uma distância reportada de 20307200

    • por meio do roteador três com uma distância de 20563200 e uma distância relatada de 20307200

  • O Roteador Um escolhe o caminho por meio do Roteador Três e mantém esse caminho por meio do Roteador Dois, como um sucessor possível.

  • O Roteadores dois e três mostra um trajeto a 192.168.3.0/24 através do roteador quatro

Suponha que o 192.168.3.0/24 falhe. Que atividade podemos esperar encontrar nessa rede? As figuras 16 até 16h ilustram o processo.

O roteador cinco marca 192.168.3.0/24 como inacessível e consulta o roteador quatro:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16a.gif

O Roteador Quatro, após o recebimento de uma consulta de seu sucessor, localizar um novo sucessor possível para essa rede. Não encontra um, assim que marca 192.168.3.0/24 como o Roteadores inacessível e da pergunta dois e três:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16b.gif

O Roteadores dois e três, por sua vez, vê que perdeu sua somente rota viável a 192.168.3.0/24, e marca-o como inacessível; ambos enviam consultas ao Roteador 1:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16c.gif

Para a simplicidade, deixe-nos supõem que o roteador um recebe a pergunta do roteador três primeiramente, e marca a rota como inacessível. Então, o roteador um recebe a consulta do roteador dois. Embora outra ordem seja possível, todas terão o mesmo resultado final.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16d.gif

O roteador um responde a ambas as perguntas com inalcançáveis; O roteador um é agora passivo para 192.168.3.0/24:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16e.gif

Roteadores resposta dois e três à pergunta do roteador quatro; Os roteadores dois e três são agora passivos para 192.168.3.0/24:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16f.gif

O roteador cinco, em cima de receber a resposta do roteador quatro, remove a rede 192.168.3.0/24 de sua tabela de roteamento; O roteador cinco é agora o passivo de rede 192.168.3.0/24. O Roteador Cinco envia as atualizações de volta para o Roteador Quatro, portanto, a rota é removida das tabelas de topologia e de roteamento dos roteadores restantes.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16g.gif

É importante compreender que embora possa haver outros caminhos de consulta ou ordens de processamento, todo o Roteadores na rede processa uma pergunta para a rede 192.168.3.0/24 quando esse link vai para baixo. Alguns roteadores podem acabar processando mais de uma consulta (Roteador Um, neste exemplo). De facto, se as perguntas eram alcançar o Roteadores em uma ordem diferente, alguns terminariam acima o processamento de três ou quatro perguntas. Este é um bom exemplo de uma consulta não vinculada em uma rede EIGRP.

Como os pontos de sumarização afetam o intervalo de consulta

Deixe-nos agora olhar os trajetos a 10.1.1.0/24 na mesma rede:

  • O roteador dois tem uma entrada de tabela de topologia para a rede 10.1.1.0/24 com um custo de 46251885 com o roteador um.

  • O roteador três tem uma entrada de tabela de topologia para a rede 10.1.1.0/24 com um custo de 20281600 por meio do roteador um.

  • O Roteador quatro tem uma entrada de tabela de topologia para a rede 10.0.0.0/8 (porque os Roteadores dois e três estão resumindo automaticamente o limite de rede principal) através do Roteador três com uma métrica de 20307200 (a distância relatada pelo roteador dois é maior que a métrica total do roteador três, portanto o caminho pelo roteador dois não é um sucessor possível).

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp17.gif

Se o 10.1.1.0/24 for desativado, o roteador um o marcará como inacessível e, em seguida, consultará cada um de seus vizinhos (roteadores dois e três) por obter um novo caminho para essa rede:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp17a.gif

O Roteador dois, ao receber a consulta do Roteador um, marca a rota como inalcançável (porque a consulta é do seu sucessor) e, em seguida, consulta os Roteadores três e quatro.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp17b.gif

Ao receber a consulta do roteador um, o roteador três marca o destino como inalcançável e consulta os roteadores dois e quatro:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp17c.gif

O Roteador Quatro, quando recebe as consultas dos Roteadores Dois e Três, responde que 10.1.1.0/24 não pode acessado (observe que o Roteador Quatro não conhece a sub-rede em questão, pois só tem a rota 10.0.0.0/8):

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp17d.gif

Os roteadores dois e três respondem um para o outro que 10.1.1.0/24 não pode ser acessado:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp17e.gif

Como os Roteadores Dois e Três agora não têm consultas pendentes, ambas respondem para o Roteador Um que 10.1.1.0/24 não pode ser alcançado:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp17f.gif

A consulta, nesse caso, é compactada pelo auto-resumo nos Roteadores 2 e 3. O roteador cinco não participa do processo de consulta e não é envolvido na re-convergência da rede. As consultas também podem ser ligadas por resumo manual, bordas de sistema autônomo e listas de distribuição.

Como os limites do sistema autônomo afetam o intervalo da consulta

Se um roteador estiver redistribuindo rotas entre dois sistemas EIGRP autônomos, ele responderá à consulta dentro das regras de processamento normais e iniciará uma nova consulta no outro sistema autônomo. Por exemplo, se o enlace para a rede anexada ao Roteador Três for desativado, o Roteador Três marcará a rota como inalcançável e consultará o roteador dois por um novo caminho:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp18.gif

O Roteador 2 resposta que essa rede não pode ser acessada e ativa uma consulta no sistema autônomo 200 em direção ao Roteador 1. Quando o roteador três recebe a resposta para sua consulta original, ele remove a rota de sua tabela. O roteador Três agora está passivo para esta rede:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp18a.gif

O Roteador Um responde para o Roteador Dois e a rota fica passiva:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp18b.gif

Embora a consulta original não tenha se propagado por toda a rede (ela foi limitada pelo bordo de sistema autônomo), a consulta original vaza para o segundo sistema autônomo na forma de uma nova consulta. Esta técnica pode ajudar a evitar problemas de SIA (stuck in active) em uma rede, com a limitação do número de roteadores pelos quais uma consulta deve passar antes de ser respondida, mas não resolve o problema geral, ou seja, que cada roteador deve processar a consulta. Na verdade, esse método de restrição de uma consulta pode agravar o problema impedindo o resumo automático de rotas que, de outra forma, seriam resumidas (as rotas externas não são resumidas a menos que exista um componente externo na rede principal).

Como as listas de distribuição afetam o intervalo da consulta

Um pouco do que obstrui a propagação de uma pergunta, listas de distribuição no EIGRP marcam toda a resposta da pergunta como inacessível. Deixe-nos usar como um exemplo figura 19.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp19.gif

Na figura acima:

  • O roteador três tem uma lista distribuída aplicada a suas interfaces seriais que só permite anunciar a rede B.

  • O Roteadores um e dois não sabe que a rede A é alcançável através do roteador três (o roteador três não é usado como um ponto do trânsito entre o Roteadores um e dois).

  • O roteador um dos usos do roteador três como seu caminho preferido à rede A, e não usa o roteador dois como um sucessor possível.

Quando o roteador um perde sua conexão à rede A, marca a rota como inacessível e envia uma pergunta ao roteador três. O roteador três não anuncia um caminho para a rede A devido à lista de distribuição em suas portas seriais.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp19a.gif

O roteador três marca a rota como inalcançável e, em seguida, consulta o roteador dois:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp19b.gif

O roteador dois examina sua tabela de topologia e encontra que tem uma conexão válida à rede A. Observe que a consulta não foi afetada pela lista de distribuição no Roteador três:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp19c.gif

O roteador dois responde que a rede A é alcançável; O roteador Três agora tem uma rota válida:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp19d.gif

O Roteador três gera a resposta à consulta do Roteador um, mas a lista de distribuição faz o Roteador três enviar uma resposta de que a rede A está inalcançável, mesmo que o Roteador três tenha uma rota válida para a rede A.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp19e.gif

Regulando pacotes

Alguns protocolos de roteamento consomem toda a largura de banda disponível em um enlace de largura de banda enquanto estão convergindo (adaptando-se para uma alteração na rede). O EIGRP evita esse congestionamento ritmando a velocidade na qual os pacotes são transmitidos em uma rede, usando apenas uma parte da largura de banda disponível. A configuração padrão do EIGRP é usar até 50 por cento da largura de banda disponível, mas isso pode ser alterado com o comando a seguir:

router(config-if)# 
ip bandwidth-percent eigrp 2 ? 
  <1-999999>  Maximum bandwidth percentage that EIGRP may use

Essencialmente, cada vez que o EIGRP enfileira um pacote a ser transmitido em uma relação, usa a seguinte fórmula para determinar quanto tempo esperar antes de enviar o pacote:

  • (8 * 100 * tamanho do pacote em bytes) / (largura de banda em kbps * porcentagem da largura de banda)

Por exemplo, se o EIGRP enfileira um pacote a ser enviado sobre uma interface serial que tenha uma largura de banda do 56K, e o pacote é 512 bytes, esperas EIGRP:

  • (8 * 100 * 512 byte)/(56000 bit por segundo *) da largura de banda) de 50% (8 * 100 * 512/(56000 * 50 pés) 409600/2800000 0.1463 segundos

Isto permite que um pacote (ou os grupos de pacotes) pelo menos de 512 bytes estejam transmitidos neste link antes que o EIGRP envie seu pacote. O cronômetro de controle determina quando o pacote é enviado e é, normalmente, expresso em milissegundos. O tempo de adequação para o pacote no exemplo acima é 0.1463 segundos. Há um campo em show ip eigrp interface que exibe o temporizador de ritmo, conforme demonstrado abaixo:

router# show ip eigrp interface
IP-EIGRP interfaces for process 2	

                    Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface    Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se0            1        0/0        28       0/15         127           0
Se1            1        0/0        44       0/15         211           0
router#

O tempo exibido corresponde ao intervalo de espaçamento para a unidade de transmissão máxima (MTU), o maior pacote que pode ser enviado pela interface.

Roteamento Padrão

Há duas maneiras de injetar uma rota padrão no EIGRP: redistribua uma rota estática ou resuma-à 0.0.0.0/0. Use o primeiro método quando desejar dirigir todo o tráfego para destinos desconhecidos a uma rota padrão no centro da rede. Este método é eficaz para anunciar conexões ao Internet. Por exemplo:

ip route 0.0.0.0 0.0.0.0 x.x.x.x (next hop to the internet) 
! 
router eigrp 100 
 redistribute static 
 default-metric 10000 1 255 1 1500

A rota estática que é redistribuída no EIGRP não tem que ser para a rede 0.0.0.0. Se você usa outra rede, você deve utilizar o comando ip default-network para marcá-la como uma rede padrão. Refira configurar um Gateway of Last Resort para mais informações.

O resumo a uma rota padrão só é efetivo quando você quer oferecer uma rota padrão aos sites remotos. Desde que os sumários são configurados pela relação, você não precisa de preocupar-se sobre a utilização de distribuir-lista ou de outros mecanismos para impedir que a rota padrão esteja propagada para o núcleo de sua rede. Observe que um resumo para 0.0.0.0/0 substitui uma rota padrão aprendida de qualquer outro Routing Protocol. A única maneira de configurar uma rota padrão em um roteador que usa este método é configurar uma rota estática a 0.0.0.0/0. (Começo no Cisco IOS Software 12.0(4)T, você pode igualmente configurar uma distância administrativa na extremidade do comando ip summary-address eigrp, assim que o sumário de local não cancela as 0.0.0.0/0 rotas).

router eigrp 100 
 network 10.0.0.0 
! 
interface serial 0 
 encapsulation frame-relay 
 no ip address 
! 
interface serial 0.1 point-to-point 
 ip address 10.1.1.1 
 frame-relay interface-dlci 10 
 ip summary-address eigrp 100 0.0.0.0 0.0.0.0

Balanceamento de carga

O EIGRP coloca até quatro rotas de custo igual na tabela de roteamento e, em seguida, o roteador balanceia a carga. O tipo de balanceamento de carga (por pacote ou por destino) depende do tipo de switching sendo realizada no roteador. Entretanto, o EIGRP também pode fazer o balanceamento de cargo por meio de links de custo não iguais.

Nota: Ao utilizar trajetos máximos, você poderá configurar o EIGRP para utilizar até seis rotas de mesmo custo.

Deixe-nos dizer lá são quatro trajetos a um destino fornecido, e o medidor para estes trajetos é:

  • trajeto 1: 1100

  • trajeto 2: 1100

  • trajeto 3: 2000

  • trajeto 4: 4000

O roteador, à revelia, coloca o tráfego no trajeto 1 e 2. Usando o EIGRP, você pode usar o comando variance instruir o roteador colocar igualmente o tráfego nos trajetos 3 e 4. A variação é um multiplicador: o tráfego será colocado em qualquer enlace que tiver uma métrica inferior ao melhor caminho multiplicado pela variação. Para carregar o equilíbrio sobre os trajetos 1, 2, e 3, variação 2 do uso, porque 1100 x 2 = 2200, que é maior do que a métrica através do trajeto 3. Analogamente, para adicionar também o caminho 4, emita o comando variance 4 under the router eigrp. Refira como faz o trabalho do balanceamento de carga de caminho de custo desigual (variação) no IGRP e no EIGRP? para obter mais informações.

Como o roteador divide o tráfego entre estes trajetos? Divide a métrica através de cada trajeto na métrica a maior, arredonda-se para baixo ao inteiro o mais próximo, e usa-se este número como o contagem da porção do tráfego.

router# show ip route 10.1.4.0 
Routing entry for 10.1.4.0/24 
  Known via "igrp 100", distance 100, metric 12001 
  Redistributing via igrp 100, eigrp 100 
  Advertised by igrp 100 (self originated) 
                eigrp 100 
  Last update from 10.1.2.2 on Serial1, 00:00:42 ago 
  Routing Descriptor Blocks: 
  * 10.1.2.2, from 10.1.2.2, 00:00:42 ago, via Serial1 
      Route metric is 12001, traffic share count is 1 
      Total delay is 20010 microseconds, minimum bandwidth is 1000 Kbit 
      Reliability 1/255, minimum MTU 1 bytes 
      Loading 1/255, Hops 0

Para este exemplo, os contagens da porção do tráfego são:

  • para os trajetos 1 e 2: 4000/1100 = 3

  • para o trajeto 3: 4000/2000 = 2

  • para o trajeto 4: 4000/4000 = 1

O roteador envia os primeiros três pacotes sobre o trajeto 1, os três pacotes seguintes sobre o trajeto 2, os dois pacotes seguintes sobre o trajeto 3, e o próximo pacote sobre o trajeto 4. O roteador reinicia enviando os próximos três pacotes pelo caminho 1 e assim por diante.

Nota: Mesmo com a variância configurada, o EIGRP não enviará tráfego por um caminho de custo desigual se a distância informada for maior do que a distância viável para essa rota específica. Consulte a seção Distância factível, distância informada e sucessor possível para obter mais informações.

Usando a métrica

Ao configurar inicialmente o EIGRP, lembre-se de duas regras básicas se estiver tentando influenciar a métrica do EIGRP:

  • A largura de banda deve sempre ser ajustada à largura de banda real da relação; os enlaces serial multipontos e outras situações combinadas mal da velocidade de mídia são as exceções a esta regra.

  • O atraso sempre deve ser usado para influenciar decisões de roteamento EIGRP.

Porque o EIGRP usa a largura de banda de interface para determinar a taxa em que para enviar pacotes, é importante que estes estejam ajustados corretamente. Se é necessário influenciar os EIGRP choosis do trajeto, use sempre o atraso para fazer assim.

Em umas mais baixas larguras de banda, a largura de banda tem mais influência sobre a métrica total; em larguras de banda mais altas, o atraso tem mais influência sobre a métrica total.

Utilizando tags administrativas em redistribuição

As etiquetas administrativas externas são úteis para dividir os circuitos de roteamento de redistribuição entre o EIGRP e outros protocolos. Ao marcar a rota quando ela é redistribuída no EIGRP, você pode bloquear a redistribuição do EIGRP no protocolo externo. Não é possível alterar a distância administrativa para um gateway padrão que seja instruído de uma rota externa porque, no EIGRP, a alteração da distância administrativa se aplica somente para rotas internas. A fim aumentar a métrica, use um mapa de rotas com lista de prefixos; não mude a distância administrativa. Um exemplo básico de configurar estas etiquetas segue, mas este exemplo não mostra a configuração completa usada quebrando laços da redistribução.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp20.gif

O Roteador 3, que redistribui as rotas conectadas no EIGRP, mostra:

three# show run 

.... 

interface Loopback0 
 ip address 172.19.1.1 255.255.255.0 
! 
interface Ethernet0 
 ip address 172.16.1.1 255.255.255.0 
 loopback 
 no keepalive 
! 
interface Serial0 
 ip address 172.17.1.1 255.255.255.0 

.... 

router eigrp 444 
 redistribute connected route-map foo  
 network 172.17.0.0 
 default-metric 10000 1 255 1 1500 

.... 

access-list 10 permit 172.19.0.0 0.0.255.255 
route-map foo permit 10 
 match ip address 10 
 set tag 1 

.... 

three# show ip eigrp topo 
IP-EIGRP Topology Table for process 444 

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, 
       r - Reply status 

P 172.17.1.0/24, 1 successors, FD is 2169856 
         via Connected, Serial0 
         via Redistributed (2169856/0) 
P 172.16.1.0/24, 1 successors, FD is 281600 
         via Redistributed (281600/0) 
P 172.19.1.0/24, 1 successors, FD is 128256, tag is 1 
         via Redistributed (128256/0)

O Roteador Dois, que está redistribuindo rotas de EIGRP para RIP, mostra:

two# show run 

.... 

interface Serial0 
 ip address 172.17.1.2 255.255.255.0 
! 
interface Serial1 
 ip address 172.18.1.3 255.255.255.0 

.... 

router eigrp 444 
 network 172.17.0.0 
! 
router rip 
 redistribute eigrp 444 route-map foo 
 network 10.0.0.0 
 network 172.18.0.0 
 default-metric 1 
! 
no ip classless 
ip route 1.1.1.1 255.255.255.255 Serial0 
route-map foo deny 10 
 match tag 1 
! 
route-map foo permit 20 

.... 

two# show ip eigrp topo 
IP-EIGRP Topology Table for process 444 

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, 
       r - Reply status 

P 172.17.1.0/24, 1 successors, FD is 2169856 
         via Connected, Serial0 
P 172.16.1.0/24, 1 successors, FD is 2195456 
         via 172.17.1.1 (2195456/281600), Serial0 
P 172.19.1.0/24, 1 successors, FD is 2297856, tag is 1 
         via 172.17.1.1 (2297856/128256), Serial0

Observe a tag 1 em 172.19.1.0/24.

O roteador um, que está recebendo as rotas RIP redistribuídas pelo roteador 2, mostra:

one# show run

.... 

interface Serial0 
 ip address 172.18.1.2 255.255.255.0 
 no fair-queue 
 clockrate 1000000 

router rip 
 network 172.18.0.0 

.... 

one# show ip route 

Gateway of last resort is not set 

R    172.16.0.0/16 [120/1] via 172.18.1.3, 00:00:15, Serial0 
R    172.17.0.0/16 [120/1] via 172.18.1.3, 00:00:15, Serial0 
     172.18.0.0/24 is subnetted, 1 subnets 
C       172.18.1.0 is directly connected, Serial0

Note que 172.19.1.0/24 faltam.

Entendendo a saída dos comandos EIGRP

mostre o tráfego do eigrp IP

Este comando é usado ao Exibir informação sobre configurações nomeadas EIGRP e configurações do sistema autônomo de EIGRP (COMO). A saída deste comando mostra a informação que foi trocada entre o EIGRP Router vizinho. Uma explicação de cada campo de saída segue a tabela.

mostre o tráfego do eigrp IP

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp20a.gif

Explicações de configuração

  • Os hellos enviados/recebidos mostram o número de pacotes Hello enviados e recebidos (enviado -1927/received - 1930).

  • As atualizações enviadas/recebidas indicam o número de pacotes de atualização enviados e recebidos (sent-20/received-39).

  • As perguntas enviadas/recebidas significam o número de pacotes da pergunta enviados e recebidos (sent-10/received-18).

  • As respostas enviadas/recebidas mostram o número de pacotes de resposta enviados e recebidos (sent-18/received-16).

  • Os acks enviados/suportes recebidos para o número de pacotes de reconhecimento enviaram e receberam (sent-66/received-41).

  • As SIA-perguntas enviadas/recebidas significam o número de colado em uns pacotes ativos da pergunta enviados e recebidos (sent-0/received-0).

  • As SIA-respostas enviadas/recebidas indicam o número de colado em uns pacotes de resposta ativos enviados e recebidos (sent-0/received-0).

  • Olá! o processo ID é olá! o identificador do processo (270).

  • O processo ID PDM representa o identificador protocolo-dependente do processo de IOS do módulo (251).

  • A fila do soquete indica o IP aos contadores de fila do soquete do processo dos hello de EIGRP (current-0/max-2000/highest-1/drops-0).

  • A fila de entrada mostra o processo dos hello de EIGRP aos contadores de fila do soquete EIGRP PDM (current-0/max-2000/highest-1/drops-0).

show ip eigrp topology

Este comando indica somente sucessores possíveis. Para exibir todas as entradas na tabela de topologia, use o comando show ip eigrp topology all-links. Uma explicação de cada campo de saída segue a tabela.

show ip eigrp topology

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp22.gif

Explicações de configuração

  • A significa ativo. Um P também pode ser exibido, significando Passivo.

  • 10.2.4.0/24 é o destino ou a máscara.

  • os sucessores 0 mostram quantos sucessores (ou trajetos) esteja disponível para este destino; se sucessores forem capitalizados, a rota está em transição.

  • O FD é 512640000 mostra a distância factível, que é a melhor métrica para alcançar este destino ou a melhor métrica conhecida quando a rota foi active.

  • a tag is 0x0 pode ser definida e/ou filtrada com o uso de mapas de rotas com os comandos set tag e match tag.

  • Q significa que uma consulta está pendente. Este campo pode igualmente ser: U, para a atualização pendente; ou R, para a resposta pendente.

  • 1 replies mostra o número de respostas pendentes.

  • active 00:00:01 exibe a extensão desta rota quando ativa.

  • origem da pergunta: A origem local mostra que esta rota originou a pergunta. Este campo pode igualmente ser: Origens múltipla, significando que os vizinhos múltiplos enviaram perguntas neste destino, mas não o sucessor; ou o origem do sucessor, significando o sucessor originou a pergunta.

  • via 10.1.2.2 mostra que tomamos conhecimento dessa rota a partir de um vizinho cujo endereço IP é 10.1.2.2. Este campo pode igualmente ser: Conectado, se a rede é conectada diretamente a este roteador; Redistribuído, se esta rota está sendo redistribuída no EIGRP neste roteador; ou Sumário, se for uma rota sumária gerada neste roteador.

  • (Infinidade/infinidade) mostra a métrica para alcançar este trajeto através deste vizinho no primeiro campo, e a distância informada através deste vizinho no segundo campo.

  • r mostra que consultamos esse vizinho e estamos aguardando uma resposta.

  • Q é a sinalização de envio para esta rota, indicando que há uma consulta pendente. Este campo pode igualmente ser: U, significando lá é uma atualização pendente; ou R, significando lá é uma resposta pendente.

  • Serial1 é a interface pela qual é possível alcançar esse vizinho.

  • A via 10.1.1.2 mostra o vizinho do qual estamos esperando uma resposta.

  • r indica que o vizinho foi consultado sobre a rota e que nenhuma resposta foi recebida.

  • Serial0 é a interface através da qual este vizinho fica acessível.

  • Através de 10.1.2.2 (512640000/128256), Serial1 mostra que essa rota está sendo usada (indica qual caminho o próximo caminho/destino usará quando houver múltiplas rotas de custo igual).

show ip eigrp topology <rede>

Esse comando exibe todas as entradas da tabela de topologia desse destino, e não apenas os sucessores possíveis. Uma explicação de cada campo de saída segue a tabela.

show ip eigrp topology network

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp23.gif

Explicações de configuração

  • O estado é voz passiva significa que a rede está no estado passivo, ou, ou seja nós não estamos procurando um trajeto a esta rede. As rotas quase sempre estão em estado passivo nas redes estáveis.

  • O flag de origem de consulta é 1. Se essa rota estiver ativa, esse campo oferecerá informações sobre quem originou a consulta.

    • 0: Essa rota está ativa mas nenhuma consulta foi originada para ela (estamos procurando por um sucessor possível localmente).

    • 1: Esse roteador originou a consulta dessa rota (ou a rota é passiva).

    • 2: Computadores em difusão múltiplos para isto pergunta. Este roteador recebeu mais de uma consulta de mais de uma origem sobre esta rota.

    • 3: O roteador de que nós aprendemos o trajeto a esta rede está perguntando para uma outra rota.

    • 4: Origens de consultas múltiplas para esta rota, incluindo o roteador através do qual aprendemos esta rota. Semelhante ao 2, mas isso também significa que há uma string da origem de consulta que descreve as consultas pendentes desse caminho.

  • 2 sucessores significam que há dois caminhos viáveis a esta rede.

  • O FD é 307200 e mostra a melhor métrica atual para essa rede. Se a rota estiver ativa, isto indica a métrica do caminho que estava sendo usada anteriormente para rotear pacotes nesta rede.

  • Os blocos de descritor de roteamento cada um das seguintes entradas descrevem um trajeto à rede.

    • O 10.1.1.2 (Ethernet1) é o próximo salto para a rede e a interface que o próximo salto atingiu.

    • de 10.1.2.2 é a fonte desta informação de caminho.

    • Indicador de envio é:

      • 0x0: Se há os pacotes que precisam de ser enviados com relação a esta entrada, este indica o tipo de pacote.

      • 0x1: Este roteador recebeu uma consulta para esta rede e necessita enviar uma resposta de unicast.

      • 0x2: Esta rota está ativa e deve ser enviada uma consulta de transmissão múltipla.

      • 0x3: Esta rota mudou, e uma atualização do Multicast deve ser enviada.

  • A métrica composta é (307200/281600) e mostra o total dos custos calculados da rede. O primeiro número nos parênteses é os custos total à rede através deste trajeto, incluindo o custo ao salto seguinte. O segundo número no parênteses é a distância relatada ou, em outras palavras, o custo que o roteador de próximo salto utiliza.

  • Route is Internal significa que a rota foi originada dentro do AS (Sistema autônomo) do EIGRP. Se a rota foi redistribuída nesse EIGRP AS, esse campo indica que a rota é Externa.

  • A métrica do vetor mostra a métrica individual usada pelo EIGRP para calcular o custo a uma rede. O EIGRP não propaga a informação de custos total durante todo a rede; as métricas de vetor são propagadas e cada roteador calcula o custo e a distância reportada individualmente.

    • A largura de banda mínima de 10000 Kbits é a largura de banda mais baixa no caminho para essa rede.

    • Total delay is 2000 microseconds mostra a soma dos retardos no caminho dessa rede.

    • A confiabilidade é 0/255 mostra um fator de confiabilidade. Este número é calculado dinamicamente, mas não usado à revelia nos cálculos métricos.

    • A carga é 1/255 indica que a quantidade de carga que o link está levando. Esse número é calculado dinamicamente e não é utilizado por padrão quando o EIGRP calcula o custo para usar esse caminho.

    • Minimum MTU is 1500 (MTU mínimo é 1500) Este campo não é usado em cálculos métricos.

    • O contagem de saltos é 2 que este não é usado nos cálculos métricos, mas limita o tamanho máximo de um EIGRP COMO. O número máximo de saltos que o EIGRP aceitará é 100, por padrão, embora o máximo possa ser configurado como 220 com saltos máximos de métrica.

Se a rota é externo, a informação seguinte é incluída. Uma explicação de cada campo de saída segue a tabela.

Rota externa

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp24.gif

Explicações de configuração

  • O roteador de origem mostra que é o roteador que injetou a rota no EIGRP AS.

  • O AS externo mostra de que sistema autônomo (se existir) veio esta rota.

  • O protocolo externo mostra o protocolo de onde esta rota veio (se houver um).

  • external metric mostra a métrica interna no protocolo externo.

  • A etiqueta de administrador pode ser configurada e/ou filtrada usando mapas de rota com os comandos set tag e match tag.

mostre a topologia do eigrp IP [active | pendente | zero-sucessores]

Mesmo formato de resultado do comando show ip eigrp topology, mas também contém uma parte da tabela de topologias.

show ip eigrp topology all-links

O mesmo formato de saída como show ip eigrp topology, mas também mostra preferencialmente todos os enlaces na tabela de topologia e não apenas possíveis sucessores.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 16406