Discar e acessar : """Integrated Services Digital Networks (ISDN), Channel-Associated Signaling (CAS)"""

Autenticação ISDN e retorno de chamada com ID do chamador

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

A autenticação baseada no ID de chamada fornece a maior Segurança pelos clientes remotos de autenticação baseados não somente no usuário - identificação e senha, mas igualmente em discar o lugar.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Informações de Apoio

Este documento explica primeiramente os significados diferentes para o comando dialer caller (com exceção de seu uso para a rechamada) quando usado em uma interface de perfil de discador um pouco do que uma relação do grupo giratório de discador.

Neste último caso, é um comando da seleção análogo ao chamador isdn em uma interface. No caso anterior, é um comando que forneça um mecanismo para ligar chamadas recebidas ao perfil do discador correto baseado no número do chamador que é apresentado no mensagem setup Q.931 entrante. A falha combinar o número apresentado de parte chamando com um número de discador chamador em um perfil do discador não faz com necessariamente que o atendimento esteja rejeitado como que não pode ser ativado se a interface física é configurada para a autenticação de PPP. Você pode igualmente combinar o nome de host apresentado com o valor configurado do nome remoto do discador para ligar nesta base. Isto é porque ligar com base no número apresentado de parte chamando não é os únicos possíveis critérios para um ligamento bem sucedido. Refira configurar e pesquisando defeitos Perfis de discagem para obter mais informações sobre da ligação e dos Perfis de discagem.

Do Software Release 12.0(7)T e Mais Recente do ½ do ¿  de Cisco IOSïÂ, remova a autenticação de PPP da interface física para poder selecionar os atendimentos baseados unicamente no número do chamador. Nesses casos, os atendimentos para que o roteador não podem encontrar um valor de harmonização do chamador do discador são rejeitados como que não pode ser ativado. Você pode usar o PAP ou a RACHADURA para configurar a autenticação de PPP na interface do discador se você quer autenticar corretamente estes atendimentos.

A chamada inicial é rejeitada (não respondido) com a opção de chamada de volta adicionada à autenticação de identificador de chamada. Contudo, a rechamada é iniciada ao número chamado para fazer a conexão. Você pode usar a rechamada para:

  • Consolidação e centralização da conta de telefone

  • Economia de custo em ligações nacional

  • Controle de acesso

Esta configuração de exemplo ilustra o uso do comando dialer caller number[callback] configurar a seleção do ID de chamada e permitir opcionalmente o ISDN Caller ID Callback para o perfil do discador DDR. Você pode igualmente usar este comando para o DDR anterior. Este comando configura o Cisco IOS Software para aceitar ou rejeitar a chamada ISDN baseada no número PSTN da chamada originada. Por exemplo, o comando dialer caller 1234 permite que o roteador aceite a chamada ISDN com o número chamado 1234.

Nota: Esta configuração exige que a informação de identificador de chamada da passagem do telco ao roteador ou ao servidor de acesso. Nenhum atendimento é aceitado se você permite a seleção do ID de chamada mas não tem a informação de identificador de chamada que está sendo passada ao roteador.

Refira configurar o ISDN Caller ID Callback para obter mais informações sobre das condições prévias e dos outros recursos opcionais disponíveis com autenticação de ID e rechamada do chamador ISDN.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Nota: Estas configurações são truncadas para indicar somente a informação relevante.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/15925/ISDN_3Rt.gif

Configurações

Este documento utiliza as seguintes configurações:

Nesta encenação, o Roteadores 2 e 3 ambos inicia chamadas DDR ao roteador 1. que o roteador1 autentica ambo o Roteadores 2 e 3 baseados unicamente no roteador1 identificação de chamador é configurado ao roteador de retorno de chamada 2, mas não ao roteador de retorno de chamada 3.

Dica: Escolha as seções apropriadas da configuração configurar a seleção do ID de chamada ou a característica da chamada de volta de identificador de chamada, mas não ambas. Por exemplo, o diagrama mostra que a rechamada precisa a configuração do roteador 2 e o roteador1. Contudo, escolha somente a configuração da interface do discador associada com o roteador2 (é marcado claramente no interface dialer 1) desde que o roteador1 executa ambas as tarefas.

Roteador 1
version 12.1
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router1
!
isdn switch-type basic-net3
!
interface Loopback0
ip address 10.0.0.1 255.255.255.0
!
interface BRI0
no ip address
dialer pool-member 1

!--- BRI 0 is a member of dialer pool 1 which is defined 
!--- under interface Dialer 1.

isdn switch-type basic-net3
!
interface Dialer1

!---  DDR dialer interface to call Router 2.

description for Router2
ip unnumbered Loopback0
encapsulation ppp
dialer pool 1

!--- Interface BRI 0 is a member of dialer pool 1.

dialer enable-timeout 2

!--- The time (in seconds) to wait before initiating callback.

dialer string 6121  

!--- This number is used to call back Router 2.

dialer caller 6121 callback

!--- Permits calls from 6121 and initiates callback 
!--- to the same number.
 
dialer-group 1

!--- Use dialer-list 1 to define interesting traffic.

!
interface Dialer2

!--- This interface is used to authenticate calls from Router 3.
!--- (Callback is NOT initiated to Router 3.)

description for Router3
ip unnumbered Loopback0
encapsulation ppp
dialer pool 1

!--- Interface BRI 0 is a member of dialer pool 1.

dialer caller 6101

!--- Permit calls from number 6101.

dialer-group 1

!--- Use dialer-list 1 to define interesting traffic.

!
dialer-list 1 protocol ip permit

!--- Define IP as interesting traffic.

Roteador 2
version 12.1
service timestamps debug datetime msec
service timestamps log datetime ms
!
hostname Router2
!
isdn switch-type basic-net3
!
interface BRI0
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-net3
!
interface Dialer1
ip address 10.0.0.2 255.255.255.0
encapsulation ppp
dialer pool 1
dialer string 6122

!--- The number to dial for Router 1 
!--- (which initiates a callback).

dialer caller 6122

!--- Accept calls from 6122 (Router 1).

dialer-group 1
no cdp enable
!
dialer-list 1 protocol ip permit

Roteador 3
version 12.1
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router3
!
isdn switch-type basic-net3
!
interface BRI0
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-net3
!
interface Dialer1
ip address 10.0.0.3 255.255.255.0
dialer pool 1
encapsulation ppp
dialer string 6122

!--- The number to dial for Router 1.

dialer-group 1
no cdp enable
!
dialer-list 1 protocol ip permit

Nota: O roteador cliente disca o servidor de chamada de volta na maioria de cenários de chamada de volta. Os dois Roteadores negociam então parâmetros de chamada de volta. O server desliga o atendimento e inicia a rechamada. O lado da chamada pôde colocar poucas chamadas de saída consecutivas ao server ao esperar o server ao retorno de chamada durante o intervalo entre a desconexão de chamada inicial e a rechamada. Este é comportamento DDR normal porque o cliente detecta que a chamada inicial falhou e não sabe que uma rechamada é em andamento.

Emita o comando dialer redial no lado da chamada a fim impedir que o cliente disque constantemente o servidor de chamada de volta. Isto suprime chamadas feitas adicionais ao server ao esperar a rechamada. As chamadas são eliminadas até que o temporizador predefinido expire. Por exemplo, o cliente espera 15 segundos antes de iniciar um redial se o tempo de intervalo de rediscagem do discador é 15 segundos. A rechamada é terminada e o cliente não tem que discar outra vez dentro desse tempo.

Refira configurar temporizadores de rediscagem depois que tentativas de discagem de rechamada falha para obter mais informações sobre de executar o redial do discador.

Verificar

Use esta seção para confirmar se a sua configuração funciona corretamente.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

comandos show

Os determinados comandos de exibição são apoiados pelo OIT, que permite que você ver uma análise do emissor de comando de execução.

  • mostre o active isdn — Indica a informação sobre atendimentos atuais e fornece a informação em ambo o chamadas ISDN atuais recebidas e enviadas.

  • show users – Exibe informações sobre as linhas ativas no roteador. Você pode igualmente usar o comando show caller se sua versão do Cisco IOS a apoia.

  • show dialer - Mostra as informações gerais de diagnóstico para interfaces configuradas para DDR.

Exemplo de saída de show

Router1#show isdn active

---------------------------------------------------------------------------
ISDN ACTIVE CALLS
---------------------------------------------------------------------------
Call  Calling   Called    Remote  Seconds Seconds Seconds Charges
Type  Number    Number    Name    Used    Left    Idle    Units/Currency
---------------------------------------------------------------------------
Out              6121     6121       24      96      23      0
In       6101             6101        7     113       6
---------------------------------------------------------------------------

Observe que uma chamada recebida e uma chamada enviada estão em andamento. A chamada feita é numerar 6121, que corresponde ao roteador2. A chamada recebida é de 6101, que corresponde ao roteador3. Igualmente note que um número identifica os roteadores remotos no campo de nome remoto um pouco do que um nome desde que a autenticação de PPP não é configurada.

Router1#show user

Line       User       Host(s)              Idle       Location
*  0 con 0                idle                 00:00:00
BR0:1                   Sync PPP             00:00:33   PPP: 10.0.0.2
BR0:2                   Sync PPP             00:00:15   PPP: 10.0.0.3
Interface  User      Mode                     Idle Peer Address

Observe que um canal B está usado para conectar ao roteador2 quando o outro canal B conectar ao roteador 3. verifica que os endereços IP de Um ou Mais Servidores Cisco ICM NT combinam aqueles configurados no Roteadores 2 e 3.

Troubleshooting

Use esta seção para resolver problemas de configuração.

Comandos para Troubleshooting

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Nota: Consulte Informações Importantes sobre Comandos de Depuração antes de usar comandos debug.

  • debug dialer [events | pacotes]

  • debug isdn event

  • debug isdn q931

  • debugar a negociação ppp — Indica a informação no tráfego e nas trocas PPP ao negociar os componentes de PPP que incluem o protocolo de controle de link (LCP), a autenticação, e o protocolo network control (NCP). Uma negociação de PPP bem-sucedida abre primeiramente o estado do LCP e, em seguida, autentica e, finalmente, negocia o NCP.

Refira a utilização do comando show isdn status para o Troubleshooting de BRI se você encontra questões de camada mais inferior de ISDN.

Exemplo de debug

Router1#show debug
     Dial on demand: Dial on demand events debugging is on 
     PPP: PPP protocol negotiation debugging is on 
     ISDN: ISDN Q931 packets debugging is on

Esta seção indica o resultado do debug do roteador1 e mostra que roteador1 do roteador de chamada 1. do roteador2 a seguir inicia uma rechamada ao roteador2 e estabelece uma conexão.

Nota: Algumas destas linhas do resultado do debug são interrompidas em múltiplas linhas para fins de impressão.

*Mar  1 04:50:34.782: ISDN BR0: RX <-  SETUP pd = 8  callref = 0x0B
*Mar  1 04:50:34.790:         Bearer Capability i = 0x8890
*Mar  1 04:50:34.798:         Channel ID i = 0x89
*Mar  1 04:50:34.802:         Calling Party Number i = 0xA1, '6121
',Plan:ISDN, Type:National

!--- Calling party information is provided by the switch.

*Mar  1 04:50:34.818:         Called Party Number i = 0xC1, '6122',Plan:ISDN,
   Type:Subscriber(local)

!--- Called party information is provided by the switch.

*Mar  1 04:50:34.838: ISDN BR0: Event: Received a DATA call from 6121 on
   B1at 64 Kb/s
*Mar  1 04:50:34.842: BR0:1 DDR: Caller id 6121 matched to profile  

!--- The ISDN call (from Router 2) is authenticated.

*Mar  1 04:50:34.842: Di1 DDR: Caller id Callback server starting to  6121

!--- Initiates callback to 6121.
 
*Mar  1 04:50:34.866: ISDN BR0: TX ->  RELEASE_COMP pd = 8  callref = 0x8B
*Mar  1 04:50:34.870:         Cause i = 0x8095 - Call rejected
*Mar  1 04:50:36.778: ISDN BR0: RX <-  SETUP pd = 8  callref = 0x0C
*Mar  1 04:50:36.786:         Bearer Capability i = 0x8890
*Mar  1 04:50:36.794:         Channel ID i = 0x89
*Mar  1 04:50:36.798:         Calling Party Number i = 0xA1, '6121',Plan:ISDN,
   Type:National
*Mar  1 04:50:36.814:         Called Party Number i = 0xC1, '6122',Plan:ISDN,
   Type:Subscriber(local)
*Mar  1 04:50:36.834: ISDN BR0: Event: Received a DATA call from 6121 on B1at
   64 Kb/s
*Mar  1 04:50:36.838: BR0:1 DDR: Caller id 6121 matched to profile
*Mar  1 04:50:36.838: Di1 DDR: callback to 6121 already started
*Mar  1 04:50:36.862: ISDN BR0: TX ->  RELEASE_COMP pd = 8  callref = 0x8C
*Mar  1 04:50:36.866:         Cause i = 0x8095 - Call rejected

!--- Reject call (then initiate callback).

*Mar  1 04:50:36.878: DDR: Callback timer expired

!--- The timer is configured with the dialer enable-timeout command.

*Mar  1 04:50:36.878: Di1 DDR: beginning callback to  6121
*Mar  1 04:50:36.882: BR0 DDR: rotor dialout [priority]
*Mar  1 04:50:36.882: BR0 DDR: Dialing cause Callback return call

!--- The dialing cause is callback.

*Mar  1 04:50:36.886: BR0 DDR: Attempting to dial 6121

!--- Dialing 6121 (Router 2).

*Mar  1 04:50:36.902: ISDN BR0: TX ->  SETUP pd = 8  callref = 0x0E
*Mar  1 04:50:36.906:         Bearer Capability i = 0x8890
*Mar  1 04:50:36.914:         Channel ID i = 0x83
*Mar  1 04:50:36.922:         Called Party Number i = 0x80, '6121',Plan:Unknown,
   Type:Unknown
*Mar  1 04:50:36.998: ISDN BR0: RX <-  CALL_PROC pd = 8  callref = 0x8E
*Mar  1 04:50:37.002:         Channel ID i = 0x89
*Mar  1 04:50:37.402: ISDN BR0: RX <-  CONNECT pd = 8  callref = 0x8E
*Mar  1 04:50:37.418: ISDN BR0: TX ->  CONNECT_ACK pd = 8  callref = 0x0E
*Mar  1 04:50:37.426: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up

!--- The interface is up.

*Mar  1 04:50:37.446: DDR: Freeing callback to  6121
*Mar  1 04:50:37.446: BRI0:1: interface must be fifo queue, force FIFO
*Mar  1 04:50:37.450: BR0:1 PPP: Phase is DOWN, Setup
*Mar  1 04:50:37.454: BR0:1 PPP: Treating connection as a callout
*Mar  1 04:50:37.454: BR0:1 PPP: Phase is ESTABLISHING, Active Open
*Mar  1 04:50:37.462: BR0:1 LCP: O CONFREQ [Closed] id 1 len 10
*Mar  1 04:50:37.462: BR0:1 LCP:    MagicNumber 0xE1288054 (0x0506E1288054)
*Mar  1 04:50:37.466: %DIALER-6-BIND: Interface BR0:1 bound to profile Di1
*Mar  1 04:50:37.478: BR0:1 PPP: Treating connection as a callout
*Mar  1 04:50:37.486: BR0:1 LCP: I CONFREQ [REQsent] id 2 Len 10
*Mar  1 04:50:37.490: BR0:1 LCP:    MagicNumber 0x000F4499 (0x0506000F4499)
*Mar  1 04:50:37.494: BR0:1 LCP: O CONFACK [REQsent] id 2 Len 10
*Mar  1 04:50:37.498: BR0:1 LCP:    MagicNumber 0x000F4499 (0x0506000F4499)
*Mar  1 04:50:37.502: BR0:1 LCP: I CONFACK [ACKsent] id 1 Len 10
*Mar  1 04:50:37.506: BR0:1 LCP:    MagicNumber 0xE1288054 (0x0506E1288054)
*Mar  1 04:50:37.506: BR0:1 LCP: State is Open

!--- The LCP negotiation is complete.

*Mar  1 04:50:37.510: BR0:1 PPP: Phase is UP
*Mar  1 04:50:37.514: BR0:1 IPCP: O CONFREQ [Closed] id 1 Len 10
*Mar  1 04:50:37.518: BR0:1 IPCP:    Address 10.0.0.1 (0x03060A000001)
*Mar  1 04:50:37.522: BR0:1 IPCP: I CONFREQ [REQsent] id 2 Len 10
*Mar  1 04:50:37.526: BR0:1 IPCP:    Address 10.0.0.2 (0x03060A000002)
*Mar  1 04:50:37.530: BR0:1 IPCP: O CONFACK [REQsent] id 2 Len 10
*Mar  1 04:50:37.534: BR0:1 IPCP:    Address 10.0.0.2 (0x03060A000002)
*Mar  1 04:50:37.550: BR0:1 IPCP: I CONFACK [ACKsent] id 1 Len 10
*Mar  1 04:50:37.550: BR0:1 IPCP:    Address 10.0.0.1 (0x03060A000001)

!--- IPCP address negotiation.

*Mar  1 04:50:37.554: BR0:1 IPCP: State is Open
*Mar  1 04:50:37.562: BR0:1 DDR: dialer protocol up
*Mar  1 04:50:37.570: Di1 IPCP: Install route to 10.0.0.2

!--- Route to Router 2 is installed.

*Mar  1 04:50:38.510: %LINEPROTO-5-UPDOWN: Line protocol on InterfaceBRI0:1,
   changed state to up

Nesta seção, o roteador3 do roteador de chamada 1. do roteador3 das exibições do resultado do debug então é autenticado com base na informação de identificador de chamada e conectado ao roteador1 sem uma rechamada.

*Mar  1 04:50:54.230: ISDN BR0: RX <-  SETUP pd = 8  callref = 0x0D

!--- Receive a call setup.

*Mar  1 04:50:54.238:         Bearer Capability i = 0x8890
*Mar  1 04:50:54.242:         Channel ID i = 0x8A
*Mar  1 04:50:54.250:         Calling Party Number i = 0xA1, '6101',Plan:ISDN,
   Type:National

!--- Calling party (Router 3) information is provided by the switch.

*Mar  1 04:50:54.266:         Called Party Number i = 0xC1, '6122',Plan:ISDN,
   Type:Subscriber(local)

!--- Called party (Router 1) information is provided by the switch.

*Mar  1 04:50:54.286: ISDN BR0: Event: Received a DATA call from 6101 on B2at
   64 Kb/s
*Mar  1 04:50:54.290: BR0:2 DDR: Caller id 6101 matched to profile 

!--- The ISDN call (from Router 3) is authenticated.

*Mar  1 04:50:54.290: BRI0:2: interface must be FIFO queue, force FIFO
*Mar  1 04:50:54.294: BR0:2 PPP: Phase is DOWN, Setup
*Mar  1 04:50:54.298: %DIALER-6-BIND: Interface BR0:2 bound to profile Di2

!--- The interface is bound to interface Dialer 2.

*Mar  1 04:50:54.314: ISDN BR0: TX ->  CALL_PROC pd = 8  callref = 0x8D
*Mar  1 04:50:54.318:         Channel ID i = 0x8A
*Mar  1 04:50:54.326: %LINK-3-UPDOWN: Interface BRI0:2, changed state to up
*Mar  1 04:50:54.350: BR0:2 PPP: Treating connection as a callin
*Mar  1 04:50:54.354: BR0:2 PPP: Phase is ESTABLISHING, Passive Open
*Mar  1 04:50:54.354: BR0:2 LCP: State is Listen
*Mar  1 04:50:54.630: ISDN BR0: TX ->  CONNECT pd = 8  callref = 0x8D
*Mar  1 04:50:54.698: ISDN BR0: RX <-  CONNECT_ACK pd = 8  callref = 0x0D
*Mar  1 04:50:54.706:         Channel ID i = 0x8A
*Mar  1 04:50:54.766: BR0:2 LCP: I CONFREQ [Listen] id 31 Len 10
*Mar  1 04:50:54.770: BR0:2 LCP:    MagicNumber 0x099285FD (0x0506099285FD)
*Mar  1 04:50:54.774: BR0:2 LCP: O CONFREQ [Listen] id 1 Len 10
*Mar  1 04:50:54.778: BR0:2 LCP:    MagicNumber 0xE128C3F7 (0x0506E128C3F7)
*Mar  1 04:50:54.782: BR0:2 LCP: O CONFACK [Listen] id 31 Len 10
*Mar  1 04:50:54.786: BR0:2 LCP:    MagicNumber 0x099285FD (0x0506099285FD)
*Mar  1 04:50:54.790: BR0:2 LCP: I CONFACK [ACKsent] id 1 Len 10
*Mar  1 04:50:54.794: BR0:2 LCP:    MagicNumber 0xE128C3F7 (0x0506E128C3F7)
*Mar  1 04:50:54.798: BR0:2 LCP: State is Open

!---  LCP negotiation is complete.

*Mar  1 04:50:54.802: BR0:2 PPP: Phase is UP
*Mar  1 04:50:54.806: BR0:2 IPCP: O CONFREQ [Closed] id 1 Len 10
*Mar  1 04:50:54.810: BR0:2 IPCP:    Address 10.0.0.1 (0x03060A000001)
*Mar  1 04:50:54.814: BR0:2 IPCP: I CONFREQ [REQsent] id 17 Len 10
*Mar  1 04:50:54.818: BR0:2 IPCP:    Address 10.0.0.3 (0x03060A000003)
*Mar  1 04:50:54.822: BR0:2 IPCP: O CONFACK [REQsent] id 17 Len 10
*Mar  1 04:50:54.826: BR0:2 IPCP:    Address 10.0.0.3 (0x03060A000003)
*Mar  1 04:50:54.830: BR0:2 IPCP: I CONFACK [ACKsent] id 1 Len 10
*Mar  1 04:50:54.834: BR0:2 IPCP:    Address 10.0.0.1 (0x03060A000001)

!--- IPCP address negotiation is complete.

*Mar  1 04:50:54.834: BR0:2 IPCP: State is Open
*Mar  1 04:50:54.842: BR0:2 DDR: dialer protocol up
*Mar  1 04:50:54.850: Di2 IPCP: Install route to 10.0.0.3

!--- Route to Router 3 is installed.

*Mar  1 04:50:55.802: %LINEPROTO-5-UPDOWN: Line protocol on InterfaceBRI0:2,
   changed state to up

Informações Relacionadas


Document ID: 15925