Voz : H.323

Configurando o relé do hookflash em portas de voz FXS/FXO

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Quando você integra as tecnologias de Voz sobre IP (VoIP) com a central telefônica privada (PBX) legada e redes telefônicas públicas comutadas (PSTN), às vezes, é necessário passar um tipo de sinalização conhecido como o “hookflash”. Um hookflash é uma breve interrupção na corrente de loop nos troncos de loopstart que o sistema conectado não interpreta como desconexão de chamada.

Uma vez que o PBX ou o PSTN detectam o hookflash, põe geralmente a corrente chama a posse e fornece um tom de discagem secundário ou um acesso aos outros recursos tais como transferência ou o acesso da espera de chamada.

Um hookflash é feito momentaneamente comprimindo o berço em um telefone. Alguns monofones de telefone mandam um botão chamado o “flash” ou “recordar” que envia uma “ruptura de loop programado”, ou os “flashes calibrados que é um hookflash que tenha uma sincronização precisa.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Cisco 1750 Router

  • Software Release 12.2.5a de Cisco IOS�

  • O suporte de software da versão 2 de H.323 é uma condição prévia. Isto esteve disponível desde o Cisco IOS Software Release 12.05T e Mais Recente. A detecção de flash de conexão/geração é apoiada em portas de voz análogas da estação de câmbio internacional (FXO) e do escritório de câmbio internacional (FXO). Estes estão disponíveis nestas plataformas de hardware da Cisco:

    • 1750/51/60

    • 2600

    • 3600

    • 3700

    • MC3810

    • Catalizador 4000 com Módulo de Gateway de Acesso (AGM)

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Informações de Apoio

Muitos clientes usam uma combinação de FXS e de portas FXO para estender os monofones de telefone através das redes IP. Querem preservar para a frente características do PBX existente, tais como o atendimento, a sem resposta ao correio de voz, e a transferência/posse nas extensões remotas. Um software mais adiantado do Cisco voip não forneceu o controle total para permitir a integração transparente. Contudo, com a liberação do Suporte H.323 versão 2 no Cisco IOS Software Release 12.0.5T e Mais Recente, é agora possível detectar e passar a sinalização de hookflash através das redes IP.

Quando a porta FXS estiver configurada para um “hookflash longo” no valor de temporizador (maior de 500 milissegundos), os usuários podem queixar-se que quando penduram acima e pegaram imediatamente o monofone, o atendimento não cancelou. Se o valor é ajustado demasiado baixo, o hookflash pode ser interpretado como um complexo, mas um valor mais alto significa que o monofone tem que ser deixado pendurado-acima por um período mais longo para cancelar o atendimento. Em alguns casos, o salto do berço pode causar problemas também. Enquanto o monofone é pendurado-acima, a tensão da mola no botão Hook Button causa pequenas rupturas múltiplas na linha conhecida como o salto do berço. O ajustamento cuidadoso do hookflash no valor cronometrando pode ser precisado para os melhores resultados. Uma possibilidade é nesses casos usar os monofones com um botão instantâneo que envie um hookflash de um período específico. A porta FXO pode ser ajustada para combinar este valor e a porta FXO a seguir gera o flash de gancho de saída. Muitas PBXes têm uma opção do Classe de serviço (CoS) chamada “flashes calibrados ou “ruptura de loop programado” que permita que reconheçam hookflashes da duração específica e ignorem outras interrupções de loop mais curtos ou mais longas. Tais ajustes são úteis em eliminar disconexões e a geração falsas de sinais de hookflash inválidos ao PBX.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Configurar PLAR OPX e relé do hookflash

Use este procedimento para configurar o Off-Premises eXtension da linha privada, ringdown automático (PLAR) (OPX), e relé do hookflash.

  1. Configurar a porta FXO no roteador mainsite como a conexão PLAR-OPX.

    O modo de OPX permite que os usuários remotos em portas FXS apareçam a um PBX central como uma extensão diretamente conectada. Quando a porta FXO detecta um sinal do anel do PBX, o roteador envia uma instalação de chamada VoIP à porta remota FXS mas não toma o fora-gancho da porta FXO. Em consequência, o PBX vê somente o sinal de resposta do atendimento quando a porta do roteador FXS de RemoteSide é pegarada. Depois que o PBX alcança o timeout sem resposta (anéis do atendimento para fora), a seguir pode terminar o atendimento, transfere o atendimento ao correio de voz, ou soa uma outra extensão/grupo de anel. Sem modo de OPX, a porta FXO vai imediatamente fora-gancho depois que detecta a soada e o PBX é então incapaz de executar para a frente um atendimento, sem resposta, ou rola sobre ao correio de voz.

  2. O roteador de site remoto deve ser configurado para detectar e passar então o sinal de hookflash na porta FXS.

    Desde que o hookflash é uma interrupção momentânea no loop atual na porta FXS e não pode ser enviado como um sinal de áudio, o roteador passa o sinal de hookflash através do relé multifrequency do tom dual (DTMF) como “!” caractere. O roteador com a porta FXO envia então uma ruptura do loop curto que o dispositivo externo ver como um hookflash. Para passar corretamente o sinal de hookflash, os dial peer de VOIP precisam de ser configurados para o DTMF-relé h245-signal.

  3. Os temporizadores da porta física têm que ser ajustados para serir as características do monofone na porta FXS e a duração do laço do hookflash estoira da porta FXO como mostrado aqui:

    • A porta de voz FXS (roteador de site remoto) usa o comando timing hookflash-in msec onde o milissegundo é o valor máximo de uma interrupção de loop (nos milissegundos) do monofone de telefone que é interpretado como um hookflash. Uma interrupção de loop maior do que o valor configurado é considerada enquanto uma disconexão e o atendimento são deixados cair. Todo o intervalo sob este valor faz com que o roteador envie “!” caráter através do relé DMTF H.245-signal.

    • A porta de voz FXO (roteador mainsite) usa o comando timing hookflash-out msec onde o milissegundo é a duração da interrupção de loop que parte nos milissegundos. Quando o roteador recebe um sinal do relé DMTF H.245-signal, a porta FXO gera uma interrupção de loop para o intervalo configurado.

Diagrama de Rede

Este documento utiliza a configuração de rede mostrada neste diagrama.

/image/gif/paws/15405/pbx_across_ip.gif

Configurações

Este documento utiliza as configurações mostradas aqui.

MainSite
MainSite#show run 
Building configuration...

Current configuration : 1121 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname MainSite
!
memory-size iomem 20
ip subnet-zero
!
call rsvp-sync
voice rtp send-recv
!
interface Loopback1
 ip address 205.1.1.1 255.255.255.0
!
interface Serial0
 bandwidth 1500
 ip address 192.168.1.1 255.255.255.252
 no fair-queue
 clockrate 1300000
 ip rtp priority 16384 16383 100
!
router eigrp 1
 network 192.168.1.0
 network 205.1.1.0
 no auto-summary
 no eigrp log-neighbor-changes
!
ip classless
no ip http server
ip pim bidir-enable
!
voice-port 1/0
 timing hookflash-out 500
 
!--- Outgoing hookflash is 500 msec. 

 connection plar opx 200
 
!--- Use PLAR OPX option on the FXO port. 

!
voice-port 1/1
 timing hookflash-out 500
 
!--- Outgoing hookflash is 500 msec.

 connection plar opx 201
 
!--- Use PLAR OPX option on the FXO port.

!
dial-peer voice 100 pots
 destination-pattern 100
 port 1/0
!
dial-peer voice 101 pots
 destination-pattern 101
 port 1/1
!
dial-peer voice 200 voip
 incoming called-number .
 destination-pattern 20.
 session target ipv4:200.1.1.1
 dtmf-relay h245-signal
 
!--- H.245-signal to pass hookflash.

 ip precedence 5
!
line con 0
line aux 0
line vty 0 4
!
no scheduler allocate
end

Site remoto
RemoteSite#show run 
Building configuration...

Current configuration : 1096 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RemoteSite
!
memory-size iomem 25
ip subnet-zero
!
call rsvp-sync
voice rtp send-recv
!
interface Loopback0
 ip address 200.1.1.1 255.255.255.0
!
interface Serial0
 bandwidth 1500
 ip address 192.168.1.2 255.255.255.252
 no fair-queue
 ip rtp priority 16384 16383 100
!
router eigrp 1
 network 192.168.1.0
 network 200.1.1.0
 no auto-summary
 no eigrp log-neighbor-changes
!
ip classless
no ip http server
ip pim bidir-enable
!
!
voice-port 1/0 
 timing hookflash-in 1000
 
!--- Interpret loop breaks of up to 1 second.   
  
 connection plar 100
 
!--- PLAR provides dial tone from remote PBX. 

!
voice-port 1/1
 timing hookflash-in 1000
 
!--- Interpret loop breaks of up to 1 second.    
 
 connection plar 101
 
!--- PLAR provides dial tone from the remote PBX.

!
dial-peer voice 100 voip
 incoming called-number .
 destination-pattern 10.
 session target ipv4:205.1.1.1
 dtmf-relay h245-signal
 
!--- Use H.245-signal to pass hookflash.

 ip precedence 5
!
dial-peer voice 200 pots
 destination-pattern 200
 port 1/0
!
dial-peer voice 201 pots
 destination-pattern 201
 port 1/1
!
!
line con 0
line aux 0
line vty 0 4
!
no scheduler allocate
end

Verificar e solucionar problemas

Esta seção fornece a informação que você pode se usar para verificar e pesquisar defeitos sua configuração.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Nota: Antes de emitir comandos debug, consulte Informações importantes sobre comandos debug.

  • debugar h225 {asn1 | eventos} - informação adicional dos indicadores sobre os índices reais de mensagens do registo H.225, da admissão, e do estado (RAS).

    asn1 Indica que somente os índices ASN.1 de toda a mensagem H.225 enviada ou recebida estão indicados.
    eventos Indica que os eventos da chave Q.931 que ocorrem ao colocar um atendimento de H.323 de um gateway a outro são indicados.

O hookflash é passado porque uma mensagem H.245 através do TCP assim que dela é possível para monitorar a sinalização usando debuga o asn1 h245 para indicar os pacotes H.245.

Estes são dois debugam traços. O primeiro mostra o recibo do '5' do dígito (a sinalização de chamada H.245 passa o dígito e a duração). O segundo traço mostra um hookflash (mostrado como “! "). Não há nenhuma duração para um hookflash. O sinal é mandado a porta FXO baseada no valor cronometrando configurado milissegundo do hookflash-para fora.

MainSite#
MainSite#debug h245 asn1 
H.245 ASN1 Messages debugging is on
MainSite#
00:52:17: H245 MSC INCOMING ENCODE BUFFER::= 6D 810B66A0 0F9F58AD AF684A00 00
00:52:17: 
00:52:17: H245 MSC INCOMING PDU ::=

value MultimediaSystemControlMessage ::= indication : userInput : signal : 
    {
      signalType "5"
      
!--- Digit relayed is 5. 

      duration 4000
      rtp 
      {
        timestamp 2913953866
        logicalChannelNumber 1
      }
    }

00:52:18: H245 MSC INCOMING ENCODE BUFFER::= 6D 82064001 26000000 
00:52:18: 
00:52:18: H245 MSC INCOMING PDU ::=

value MultimediaSystemControlMessage ::= indication : userInput : signalUpdate :
 
    {
      duration 295
      
!--- Digit duration was 295 msec. 

      rtp 
      {
        logicalChannelNumber 1
      }
    }

MainSite#


!--- This trace from the destination router shows 
!--- the hookflash passed as the character '!'. 

MainSite#
00:52:36: H245 MSC INCOMING ENCODE BUFFER::= 6D 81020420 
00:52:36: 
00:52:36: H245 MSC INCOMING PDU ::=

value MultimediaSystemControlMessage ::= indication : userInput : signal : 
    {
      signalType "!"
     
 !--- Hookflash is passed as '!'. 

    }

MainSite#

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 15405