Serviços de rede de aplicativos : Cisco LocalDirector 400 Series

Configurando o failover padrão e classificado no LocalDirector

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Cisco anunciou a fim--venda para o Cisco LocalDirector. Para mais informação, refira o fim da vida útil do 400 Series de LocalDirector e as observações e os boletins de produto da Fim--venda.


Índice


Introdução

A informação nesta Nota Técnica aplica-se a toda a versão de hardware e software do Cisco LocalDirector em uma configuração de failover.

Dois tipos de Failover podem ser executados em LocalDirector: failover padrão e failover stateful. No Failover (NON-statefull) padrão, toda a informação da conexão existente é perdida em cima do Failover; entretanto, o failover de stateful mantém as informações de sessão, bem como as informações de sessão difícil.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento aplica-se a toda a versão de hardware e software do Cisco LocalDirector em uma configuração de failover.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Comandos de failover

  • failover ip address ip_address – Define o endereço IP de failover. O argumento dos ip_address indica o endereço IP de Um ou Mais Servidores Cisco ICM NT usado pela unidade em standby para comunicar-se com a unidade ativa. Use esse endereço IP com o comando ping para verificar o status da unidade de standby. Esse endereço deve estar na mesma rede do endereço IP do sistema. Por exemplo, se o endereço IP for 192.168.1.1, defina o endereço IP de failover como 192.168.1.2.

  • failover [active] - Permite o acesso ao recurso de failover opcional. O argumento ativo opcional faz de um LocalDirector a unidade ativa.

  • interface_number replicate da relação — Permite a comutação classificada, e especifica uma relação enviando dados de replicação. O argumento interface_number indica o número por meio do qual a unidade LocalDirector ativa envia dados de replicação de conexão à unidade de standby. O padrão é a interface 0.

  • failover alias ip address endereço_IP - Atribui um endereço IP de alias de failover. O endereço IP é usado pela unidade em standby para se comunicar com a unidade ativa.

  • reinicialização de failover — Toma uma unidade fora do estado falho.

  • show failover - Mostra o status de failover de LocalDirector, status do cabo, status do host primário e secundário e descrições de interface.

  • ethernet de fechamento | interface_number FDDI — Desabilita uma relação.

Para mais informação, refira a referência do comando localdirector.

Configurações

Nota: Use a Command Lookup Tool (somente clientes registrados) para obter mais informações sobre os comandos usados nesta seção.

LocalDirector em failover padrão

Esta é uma configuração básica de LocalDirector no failover padrão:

LocalDirector em failover padrão
: Saved 
: LocalDirector 420 Version 4.1.2 
syslog output 20.3 
no syslog console 
enable password 000000000000000000000000000000 encrypted 
hostname localdirector 
no shutdown ethernet 0 
no shutdown ethernet 1 
shutdown ethernet 2 
shutdown ethernet 3 
interface ethernet 0 100full 
interface ethernet 1 100full 
interface ethernet 2 auto 
interface ethernet 3 auto 
mtu 0 1500 
mtu 1 1500 
mtu 2 1500 
mtu 3 1500 
multiring all 
no secure  0 
no secure  1 
no secure  2 
no secure  3 
ping-allow 0 
ping-allow 1 
no ping-allow 2 
no ping-allow 3 
ip address 10.1.1.1 255.0.0.0 
arp timeout 30 
no rip passive 
rip version 1 
failover ip address 10.1.1.2 
failover 
failover hellotime 30 
password cisco 
snmp-server enable traps 
snmp-server community public 
no snmp-server contact 
no snmp-server location 
no dns-boomerang enable 
virtual 10.1.1.5:0:0:tcp is 
real 10.1.1.4:0:0:tcp is 
real 10.1.1.3:0:0:tcp is 
bind 10.1.1.5:0:0:tcp 10.1.1.3:0:0:tcp 
bind 10.1.1.5:0:0:tcp 10.1.1.4:0:0:tcp 
: end 
[OK] 
localdirector(config)#

LocalDirector em failover classificado

Está abaixo uma configuração de exemplo de LocalDirector na comutação classificada. Unidades de failover total compartilham informações de conexões ativas e são configuráveis de forma per-virtual. Sempre que o estado da conexão TCP (Transmission Control Protocol) muda, os dados são enviados para o protocolo LocalDirector em standby via protocolo total LocalDirector. Isto permite que o estado atual de todas as sessões de TCP seja espelhado ao LocalDirector em standby.

O protocolo LocalDirector-statefull usa pacotes de UDP para enviar as alterações de estado para o Standby LocalDirector pela interface Ethernet. Use uma interface Ethernet separada para enviar mensagens da comutação classificada. Com comutação classificada, não há nenhuma interrupção do serviço ao cliente. É ideal para os aplicativos imprescindíveis e garante alta disponibilidade.

Nota: Esse exemplo usa a interface Ethernet 2, que tem um crossover entre os dois LocalDirectors para transferir informações de estado. Este exemplo igualmente usa estes comandos replicate:

replicate interface 2 
replicate 10.1.1.5:0:0:tcp

Esses comandos informam o LocalDirector para replicar o estado da conexão de unidades ativas para standby no Ethernet 2 e também para replicar todas as informações de estado de 10.1.1.5 virtual para a unidade de standby.

LocalDirector em failover classificado
: Saved 
: LocalDirector 420 Version 4.1.2 
syslog output 20.3 
no syslog console 
enable password 000000000000000000000000000000 encrypted 
hostname localdirector 
no shutdown ethernet 0 
no shutdown ethernet 1 
no shutdown ethernet 2 
shutdown ethernet 3 
interface ethernet 0 100full 
interface ethernet 1 100full 
interface ethernet 2 100full 
interface ethernet 3 auto 
mtu 0 1500 
mtu 1 1500 
mtu 2 1500 
mtu 3 1500 
multiring all 
no secure  0 
no secure  1 
no secure  2 
no secure  3 
ping-allow 0 
ping-allow 1 
no ping-allow 2 
no ping-allow 3 
ip address 10.1.1.1 255.0.0.0 
arp timeout 30 
no rip passive 
rip version 1 
failover ip address 10.1.1.2 
failover 
failover hellotime 30 
password cisco 
snmp-server enable traps 
snmp-server community public 
no snmp-server contact 
no snmp-server location 
no dns-boomerang enable 
virtual 10.1.1.5:0:0:tcp is 
real 10.1.1.4:0:0:tcp is 
real 10.1.1.3:0:0:tcp is 
replicate interface 2 
replicate 10.1.1.5:0:0:tcp 
bind 10.1.1.5:0:0:tcp 10.1.1.3:0:0:tcp 
bind 10.1.1.5:0:0:tcp 10.1.1.4:0:0:tcp

Nota: Todas as relações reagem inicialmente do modo de espera, significando que o Monitoramento de redes não começou. Depois que as interfaces de rede entram no modo normal, o Monitoramento de redes começa. Isso ocorre quando mensagens LocalDirector-HELLO começam a ser enviadas a cada cinco segundos.

Se nenhuma mensagem LocalDirector-HELLO for recebida durante um intervalo de 30 segundos, as unidades entram em modo de teste para determinar qual unidade falhou. Se o cabo serial for desconectado, as unidades manterão suas funções atuais. Se a unidade não passa um teste, tornar-se-á falhada e a outra unidade tornar-se-á ativa. Cada vez que? estado? das mudanças da conexão de TCP, os dados são enviados ao LocalDirector em standby através do protocolo LocalDirector-statefull. O estado de todas as sessões de TCP é espelhado para o Standby LocalDirector. Se um virtual é mudado para apoiar a comutação classificada então a informação de estado para somente as novas conexões está enviada ao LocalDirector em standby. Protocolo LocalDirector de estado total não copia o estado das sessões existentes de TCP.

Verificando o status do failover

O comando show failover pode ser usado para indicar o status de comutação atual das unidades e de suas relações, segundo as indicações deste exemplo:

Failover Off 
Cable status: My side not connected 
        This host: Secondary - Active 
                Active time: 1 weeks, 3 days, 1 hours, 2 minutes, 5 seconds 
                Interface 5 (10.86.16.225): Normal (Waiting) 
                Interface 4 (10.86.16.225): Normal (Waiting) 
                Interface 3 (10.86.16.225): Normal (Administratively down) 
                Interface 2 (10.86.16.225): Normal (Administratively down) 
                Interface 1 (10.86.16.225): Normal (Waiting) 
                Interface 0 (10.86.16.225): Normal (Waiting) 
        Other host: Secondary - Standby 
                Interface 5 (0.0.0.0): Normal (Waiting) 
                Interface 4 (0.0.0.0): Normal (Waiting) 
                Interface 3 (0.0.0.0): Normal (Administratively down) 
                Interface 2 (0.0.0.0): Normal (Administratively down) 
                Interface 1 (0.0.0.0): Normal (Waiting) 
                Interface 0 (0.0.0.0): Normal (Waiting)

Isso mostra que os pacotes de saudações estão circulando entre as duas unidades e que duas das interfaces dos LDs foram encerradas.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 15060