Cisco Interfaces and Modules : Módulo de switching de conteúdo da Cisco

Configurando o balanceamento de carga do servidor IOS com provas HTTP no modo despachado

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

A característica do Server Load Balancing (SLB) de Cisco IOS� é uma solução com base em IOS de Cisco que forneça o Server Load Balancing. Esta característica permite que você defina um servidor virtual que represente um conjunto de servidores reais, conhecido como uma fazenda do server. Quando um cliente inicia uma conexão ao servidor virtual, a carga IO SLB equilibra a conexão a um servidor real escolhido, segundo o algoritmo de balanceamento de carga configurado ou o predictor.

OS IO SLB podem ser configurados para operar-se nos seguintes dois modos.

  • modo despachado — Neste modo, o endereço do servidor virtual é sabido aos servidores reais. Você deve configurar cada um dos servidores reais com endereços de loopback para sua interface de loopback exclusiva. Isto é necessário para dar a cada máquina na fazenda do server o mesmo endereço IP de Um ou Mais Servidores Cisco ICM NT que o servidor virtual real. O servidor real de destino será permitido então responder diretamente aos clientes que usam o endereço de loopback, apenas como para seu próprio endereço IP de Um ou Mais Servidores Cisco ICM NT. OS IO SLB reorientam pacotes ao servidor real na camada 2 na camada de controle de acesso de mídia (MAC). Desde que o endereço IP de Um ou Mais Servidores Cisco ICM NT do servidor virtual não é alterado no modo despachado, os servidores reais devem ser a camada 2-adjacent a IO SLB, ou os roteadores de intervenção não puderam poder distribuir ao servidor real escolhido.

  • modo direcionado — Neste modo, o servidor virtual pode ser atribuído a um endereço IP de Um ou Mais Servidores Cisco ICM NT que seja desconhecido aos servidores reais. OS IO SLB traduzem os pacotes trocados entre um cliente e um servidor real, traduzindo o endereço IP de Um ou Mais Servidores Cisco ICM NT do servidor virtual a um endereço do servidor real com o Network Address Translation (NAT). Para usar o modo direcionado, adicionar o comando nat server à fazenda do server.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Liberação 12.1(6)E do Supervisor IOS do Catalyst 6000 Family para o Supervisor Engine 1 com MSFC1 (c6sup11-jsv-mz.121-6.E1)

  • Servidores de Web de Microsoft Windows 2000/IIS

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Sondas HTTP

Pontas de prova do protocolo supports hypertext transfer IO SLB (HTTP), pontas de prova do sibilo, e pontas de prova do Wireless Session Protocol (WSP). Você pode usar o método da prova HTTP para verificar a Conectividade e para monitorar os servidores reais que são carga equilibrada. As pontas de prova determinam o estado de cada servidor real na fazenda do server. Neste exemplo, as provas HTTP são configuradas usando a porta TCP 80. As provas HTTP são configuradas para conectar cada oito segundos e para pedir um comando get do método, procurando um código de 200 respostas do server. Estas configurações são todos os valores padrão.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/15055/ios_slb-01.gif

Configurações

Configuração de IOS SLB usando o Catalyst 6509
Current configuration:

version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname cat6

!

boot buffersize 126968

boot system flash slot0:c6sup11-jsv-mz.121-6.E1.bin

!

redundancy

 main-cpu

  auto-sync standard

ip subnet-zero

!

no ip finger

no ip domain-lookup

!

ip slb probe KEEPALIVE http

!

ip slb serverfarm SERVERS

 probe KEEPALIVE

 !

 real 10.1.1.3

  inservice

 !

 real 10.1.1.5

  inservice

!

ip slb vserver WEBSITE

 virtual 172.17.63.215 tcp www

 serverfarm SERVERS

 inservice

!

cns event-service server

!

interface GigabitEthernet1/1

 no ip address

 shutdown

!

interface GigabitEthernet1/2

 no ip address

 shutdown

!

interface FastEthernet2/1

 no ip address

 switchport

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet2/2

 no ip address

 shutdown

!

interface FastEthernet2/3

 no ip address

 switchport

 switchport access vlan 200

 switchport mode access

!

interface FastEthernet2/4

 no ip address

 switchport

 switchport access vlan 200

 switchport mode access

!

interface FastEthernet2/5

 no ip address

 shutdown

!

interface FastEthernet2/48

 no ip address

 shutdown

!         

interface Vlan1

 no ip address

 shutdown

!

interface Vlan100

 ip address 172.17.63.211 255.255.255.192

!

interface Vlan200

 ip address 10.1.1.250 255.255.255.0

!

ip default-gateway 172.17.63.193

ip classless

ip route 0.0.0.0 0.0.0.0 172.17.63.193

no ip http server

!

line con 0

 transport input none

line vty 0 4

 password cisco

 login

!

end

Comandos show e resumo de comandos

show ip slb mode Command

O comando show ip slb mode indica o estado do modo SLB.

cat6#show ip slb mode 
     SLB forwarding mode = rp (default) 
     SLB configured mode = rp (default) 

Para executar o Cisco IOS software de SLB, você deve configurar o modo usando o modo do slb da mostra IP [csm | comando rp] antes de alguma configuração. No comando show ip slb mode, o argumento rp é padrão. Você pode somente configurar o argumento csm se você tem o módulo content switching (CS). O CS fornece conexões de alto desempenho entre as fazendas do server dos dispositivos de rede baseadas nos pacotes de informação 7 diretos da camada 4. Você pode representar um grupo de servidores reais (fazenda do server) como um exemplo do servidor único (servidor virtual), equilibrar o tráfego à fazenda do server selecionando um dos servidores reais (Server Load Balancing), e o tráfego do limite aos servidores individuais (conexões difíciis) e às fazendas do server (políticas). Para mais informação, veja configurar o modo seguro (do roteador) no módulo content switching.

Comando show ip slb vserver

O comando show ip slb vserver exibe informações sobre o servidor virtual. Abaixo também é possível ver o estado do servidor virtual e quantas conexões existem:

cat6#show ip slb vserver 

slb vserver      protocol      virtual              state      conns 
------------------------------------------------------------------------ 
WEBSITE         TCP       172.16.63.215/32:80      OPERATIONAL   0 

Comando show ip slb reals

O comando show ip slb reals exibe informações para cada servidor real, por exemplo o farm de servidores em que cada servidor reside, os estados dos servidores, os limites e as conexões.

cat6#show ip slb reals 

real             server farm      weight     state        conns 
------------------------------------------------------------------- 
10.1.1.5         SERVERS           8        OPERATIONAL     0 
10.1.1.3         SERVERS           8        OPERATIONAL     0 

Comando show ip slb serverfarms

O comando show ip slb serverfarms exibe informações sobre o server farm. Esse comando mostra o preditor utilizado para o balanceamento de carga. Neste exemplo, o round robin, que é padrão, está sendo utilizado. Você não verá “nenhuns” sob o NAT porque o dispositivo reage do modo despachado.

cat6#show ip slb serverfarm 

server farm      predictor    nat        reals    redirect    bind id 
-------------------------------------------------------------------------- 
SERVERS       roundrobin     none         2          0             0 

Comando show ip slb conns

Os conns do slb da mostra IP [virtual_server-name do vserver | endereço de IP do cliente | o comando do [detail] do firewallfarm-nome do Firewall] indica as conexões ativa.

  • vserver - Indicadores somente que aquelas conexões conectaram a um servidor virtual particular.

  • Virtual Server-nome - Nome do servidor virtual.

  • cliente - Indica conexões com um endereço IP particular de cliente.

  • IP address - Endereço IP de Um ou Mais Servidores Cisco ICM NT do cliente.

  • detalhe - Informação de conexão detalhada dos indicadores.

Se nenhuma opção é especificada, o comando show ip slb conns indica a saída para todas as conexões ativa de IOS SLB.

cat6#show ip slb conns 

vserver         prot    client             real                state            nat 
----------------------------------------------------------------------- --------------- 
WEBSITE         TCP  10.21.188.123:2187    10.1.1.5            ESTAB            none 
WEBSITE         TCP  10.21.188.123:2190    10.1.1.5            CLOSING       	none 
WEBSITE         TCP  10.21.188.123:2192    10.1.1.3            ESTAB            none 
WEBSITE         TCP  10.21.188.123:2197    10.1.1.3            CLOSING       	none 
WEBSITE         TCP  10.21.188.123:2200    10.1.1.5            SYNCLIENT        none 
WEBSITE         TCP  10.21.188.123:2201    10.1.1.5            SYNCLIENT        none 

cat6#show ip slb conns detail 

WEBSITE, client = 10.21.188.123:2187 state = ESTAB, real = 10.1.1.5, 
nat = none  v_ip = 172.17.63.215:80, TCP, service = NONE 
  client_syns = 1, sticky = FALSE, flows attached = 0 
WEBSITE, client = 10.21.188.123:2205 state = CLOSING, real = 10.1.1.5, 
nat = none v_ip = 172.17.63.215:80, TCP, service = NONE 
  client_syns = 3, sticky = FALSE, flows attached = 0 
WEBSITE, client = 10.21.188.123:2206 state = ESTAB, real = 10.1.1.5, 
nat = none v_ip = 172.17.63.215:80, TCP, service = NONE 
  client_syns = 2, sticky = FALSE, flows attached = 0 

Comando show ip slb probe

O comando show ip slb probe indica a informação sobre IO SLB.

Há três estados operacionais da ponta de prova:

  • FALHADO - A ponta de prova tem falhado atualmente.

  • OPERACIONAL - A ponta de prova está funcionando normalmente.

  • TESTAR - A ponta de prova nunca sucedeu, devido a nenhuma resposta. OS IO SLB não mantêm nenhum contador ou temporizador para este estado.

A outra informação indicada é a seguinte:

  • Indisponibilidade - O número de intervalo entre provas bem-sucedidas.

  • Atual - O tempo desde que o último sucesso da ponta de prova. Isto é, a duração (até agora) da interrupção atual.

  • Cumulativo - O tempo total o servidor real esteve sob o teste da ponta de prova e falhou. Este valor é a soma das horas atual mais o tempo total de todas as paradas anterior.

cat6#show ip slb probe 

Server:Port          	State        Outages  	Current    Cumulative 
----------------------------------------------------------------------- 
10.1.1.3:80             OPERATIONAL    1        never         00:05:22 
10.1.1.5:80             OPERATIONAL    0        never         00:00:00 

Circuito fechado em modo despachado

Depois que você configurou a característica SLB no Catalyst 6500, você deve configurar cada servidor real com um dispositivo/relação do laço de retorno. Configurar o endereço IP de Um ou Mais Servidores Cisco ICM NT do servidor virtual como o endereço IP de loopback, com um netmask de 255.0.0.0.

Route Table 
======================================================================= ==== 
Interface List 
0x1 ........................... MS TCP Loopback interface 
0x2 ...00 60 b0 87 dc 1a ...... AMD PCNET Family Ethernet Adapter 
0x1000004 ...02 00 4c 4f 4f 50 ...... MS LoopBack Driver 
======================================================================= ==== 
Active Routes: 
Network	        Destination         Netmask         Gateway     Interface   Metric 
0.0.0.0         0.0.0.0             10.1.1.250      10.1.1.3        1 
10.1.1.0        255.255.255.0       10.1.1.3        10.1.1.3        1 
10.1.1.3        255.255.255.255     127.0.0.1       127.0.0.1       1 
10.255.255.255  255.255.255.255     10.1.1.3        10.1.1.3        1 
127.0.0.0       255.0.0.0           127.0.0.1       127.0.0.1       1 
172.17.63.215   255.255.255.255     127.0.0.1       127.0.0.1       1 
224.0.0.0       224.0.0.0           10.1.1.3        10.1.1.3        1 
224.0.0.0       224.0.0.0           172.17.63.215   172.17.63.215   1 
255.255.255.255 255.255.255.255     10.1.1.3        10.1.1.3        1 
======================================================================= ==== 

Examine o endereço de rede em cada fileira da tabela, onde você vê que o endereço de loopback aparece. Para que os server comuniquem-se corretamente, você precisa uma referência a um endereço de rede de transmissão múltipla bem conhecido. Isto está na oitava fileira do exemplo, assim que você precisa de suprimir do Default-route extra. Este é esse cujo o endereço de rede começa com o mesmo primeiro dígito que o endereço de cluster, e é seguido por três zero. No exemplo acima, a rota extra está na segunda fileira.

Os seguintes são endereços de rede de transmissão múltipla bem conhecido:

224.0.0.0      224.0.0.0    172.17.63.215      172.17.63.215       1 

Os seguintes são rotas padrão automático-instaladas removidas da tabela acima:

0.0.0.0          0.0.0.0    172.17.63.193   172.17.63.215       1

Você deve suprimir da rota extra para permitir uma comunicação apropriada com o servidor virtual SLB.

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 15055