Switches de LAN : Roteamento Inter-Vlan

Configuração do Roteamento entre VLANs e o Entroncamento de ISL/802.1Q em um Switch Catalyst 2900XL/3500XL/2950 Utilizando um Roteador Externo

16 Janeiro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Tradução Manual (22 Maio 2008) | Inglês (20 Outubro 2015) | Feedback


Índice


Introdução

Este documento fornece configurações de exemplo sobre o InterSwitch Link (ISL) e o entroncamento 802.1Q entre um switch Catalyst 3512-XL e um roteador Cisco 2600; os resultados de cada comando são exibidos à medida que eles são executados. Os roteadores das séries Cisco 3600 e 4500/4700, ou outros membros dos roteadores da série Cisco 2600, com interfaces FastEthernet e qualquer Catalyst 2900XL, 3500XL, 2940, 2950 ou 2970 pode ser usado nos cenários apresentados neste documento para obter os mesmos resultados.

O entroncamento é um modo de conduzir o tráfego de vários VLANs por um link ponto a ponto entre dois dispositivos. Dois modos em que o entroncamento Ethernet pode ser implementado são:

  • ISL (protocolo de proprietário de Cisco, e não apoiado pelos 2940 ou 2950 Series Switch)

  • 802.1Q (padrão IEEE (Instituto de engenheiros elétricos e eletrônicos))

Vamos criar um tronco que transportará o tráfego de dois VLANs (VLAN1 e VLAN2) através de um único link entre o roteador Catalyst 3500 e Cisco 2600.

Estamos utilizando o roteador Cisco 2600 para fazer o roteamento InterVLAN entre VLAN1 e VLAN2. Os Series Switch do catalizador 2900XL/3500XL/2940/2950/2970 são Switches da camada 2 (L2), e não são capazes do roteamento ou da comunicação entre os VLAN. Para uns detalhes mais adicionais no Roteamento Inter-Vlan, refira o roteamento entre a visão geral do capítulo dos LAN virtuais do manual de configuração dos serviços de Switching de Cisco IOS�, Versão 12.1.

Para criar os exemplos neste documento, nós usamos o seguinte Switches em um ambiente de laboratório com configurações esclarecida:

  • Cisco IOS running 12.0(5.x)XU do Catalyst 3512XL Switch

  • Cisco 2621 Router executando Cisco IOS 12.1(3)T

  • Cisco IOS 12.1(1)T running do Cisco 2621 Router

As configurações neste documento foram implementadas em um ambiente de laboratório isolado. Certifique-se de que você entende o impacto potencial de qualquer configuração ou comando em sua rede antes de utilizá-la. As configurações em todos os dispositivos foram limpas com o comando write erase para garantir uma configuração padrão.

Antes de Começar

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Pré-requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

Notas importantes

Para o Switches do catalizador 2900XL/3500XL/2940/2950/2970:

O Switches do Catalyst 2940 e 2950 Series apoia somente o entroncamento 802.1q, e não apoia o entroncamento ISL.

Em um 2900XL Switch do DRAM catalyst do 4 MB, o entroncamento é apoiado somente com os seguintes módulos capazes de entroncamento:

  • WS-X2914-XL-V: módulo de switch 4-port 10/100 ISL/802.1Q

  • WS-X2922-XL-V: módulo de switch 2-port 100BaseFX ISL/802.1Q

  • WS-X2924-XL-V: módulo de switch 4-port 100BaseFX ISL/802.1Q

  • WS-X2931-XL: Uplink de 1000BaseX para Catalyst 2900 XL

  • WS-X2932-XL: Uplink de 1000BaseT para Catalyst 2900 XL

Refira a tabela 1 abaixo para à lista de modelos de switch atual que apoia o entroncamento:

Tabela 1

Modelos de Switches Versão mínima necessária para o truncamento ISL Versão mínima exigida para entroncamento IEEE 802.1Q Versão atual exigida para tunelamento (ISL/802.1Q)
WS-C2916M-XL (Switch de 4 Mb) 11.2(8)SA4 (Edição de empreendimento) 11.2(8)SA5 (Edição de Empreendimento) 11.2(8.6)SA6 (Edição original)
C2912-XL 11.2(8)SA4 (Edição de empreendimento) 11.2(8)SA5 (Edição de Empreendimento) 12.0(5)WC(1) ou posterior
C2924-XL 11.2(8)SA4 (Edição de empreendimento) 11.2(8)SA5 (Edição de Empreendimento) 12.0(5)WC(1) ou posterior
WS-C2924C-XL 11.2(8)SA4 (Edição de empreendimento) 11.2(8)SA5 (Edição de Empreendimento) 12.0(5)WC(1) ou posterior
WS-C2924M-XL 11.2(8)SA4 (Edição de empreendimento) 11.2(8)SA5 (Edição de Empreendimento) 12.0(5)WC(1) ou posterior
WS-C2912MF-XL 11.2(8)SA4 (Edição de empreendimento) 11.2(8)SA5 (Edição de Empreendimento) 12.0(5)WC(1) ou posterior
WS-C2924M-XL-DC 12.0(5)XU 12.0(5)XU 12.0(5)WC(1) ou posterior
WS-C3508G-XL 11.2(8)SA4 (Edição de empreendimento) 11.2(8)SA5 (Edição de Empreendimento) 12.0(5)WC(1) ou posterior
WS-C3512-XL 11.2(8)SA4 (Edição de empreendimento) 11.2(8)SA5 (Edição original) 12.0(5)WC(1) ou posterior
WS-C3524-XL 11.2(8)SA4 (Edição de empreendimento) 11.2(8)SA5 (Edição de Empreendimento) 12.0(5)WC(1) ou posterior
WS-C3548-XL 12.0(5)XP (Edição de empreendimento) 12.0(5)XP (Edição de empreendimento) 12.0(5)WC(1) ou posterior
WS-C3524-PWR-XL 12.0(5)XU 12.0(5)XU 12.0(5)WC(1) ou posterior
WS-C2940-8TF ISL Não Suportado 12.1(13)AY 12.1(13)AY ou posterior para 802.1Q. ISL Não é Suportado.
WS-C2940-8TT ISL Não Suportado 12.1(13)AY 12.1(13)AY ou posterior para 802.1Q. ISL Não é Suportado.
WS-C2950-12 ISL Não Suportado 12.0(5)TWC(1) 12.0(5)WC(1) ou posterior para 802.1Q. ISL Não é Suportado.
WS-C2950-24 ISL Não Suportado 12.0(5)TWC(1) 12.0(5)WC(1) ou posterior para 802.1Q. ISL Não é Suportado.
WS-C2950C-24 ISL Não Suportado 12.0(5)TWC(1) 12.0(5)WC(1) ou posterior para 802.1Q. ISL Não é Suportado.
WS-C2950T-24 ISL Não Suportado 12.0(5)TWC(1) 12.0(5)WC(1) ou posterior para 802.1Q. ISL Não é Suportado.
WS-C2950G-12-EI ISL Não Suportado 12.0(5)TWC(1) 12.0(5)WC(1) ou posterior para 802.1Q. ISL Não é Suportado.
WS-C2950G-24-EI ISL Não Suportado 12.0(5)TWC(1) 12.0(5)WC(1) ou posterior para 802.1Q. ISL Não é Suportado.
WS-C2950G-48-EI ISL Não Suportado 12.0(5)TWC(1) 12.0(5)WC(1) ou posterior para 802.1Q. ISL Não é Suportado.
WS-C2950SX-24 ISL Não Suportado 12.0(5)TWC(1) 12.0(5)WC(1) ou posterior para 802.1Q. ISL Não é Suportado.
WS-C2950-24-EI-DC ISL Não Suportado 12.0(5)TWC(1) 12.0(5)WC(1) ou posterior para 802.1Q. ISL Não é Suportado.
WS-C2955T-12 ISL Não Suportado 12.1(13)EA1 12.1(13)EA1 ou mais tarde para o 802.1Q. ISL Não é Suportado.
WS-C2955S-12 ISL Não Suportado 12.1(13)EA1 12.1(13)EA1 ou mais tarde para o 802.1Q. ISL Não é Suportado.
WS-C2955C-12 ISL Não Suportado 12.1(13)EA1 12.1(13)EA1 ou mais tarde para o 802.1Q. ISL Não é Suportado.
WS-C2970G-24T 12.1(11)AX 12.1(11)AX 12.1(11)AX ou mais recente
WS-C2970G-24TS 12.1(14)EA1 12.1(14)EA1 12.1(14)EA1 ou mais tarde

Nota: Na tabela acima, somente o WS-C2916M-XL é um switch DRAM do 4 MB. Todo o outro comuta listado é switch DRAM do 8 MB. Para determinar se seu interruptor tem o 4 MB ou o 8 MB do DRAM, inscreva o comando show version do nível de usuário. Para mais informação, veja como determinar a quantidade de memória de switch usando a seção da interface da linha de comando do software em upgrade nos Catalyst 2900-XL/3500-XL switches usando a interface da linha de comando.

Nota: No Switches do catalizador 2900XL/3500XL/2940/2950/2970, uma interface de VLAN, por exemplo, o int vlan 1, o int vlan 2, o int vlan x, pode ser criada para cada VLAN que é configurado no interruptor. Contudo, somente um VLAN pode ser usado em um momento como um VLAN de gerenciamento. O endereço IP de Um ou Mais Servidores Cisco ICM NT é atribuído à interface de VLAN do VLAN de gerenciamento somente. Se o endereço IP for atribuído a uma outra interface de VLAN que não seja usada para gerenciamento, essa interface não será exibida. É preferível criar a interface VLAN somente para a VLAN de gerenciamento.

Para Cisco 2600 Routers:

Para o truncamento 802.1Q, um VLAN não está rotulado. Esse VLAN é chamado de VLAN nativo. A VLAN nativa é usada para tráfego não rotulado quando a porta estiver no modo de truncamento 802.1Q. Ao configurar o entroncamento do 802.1Q, é muito importante manter-se na mente que o VLAN nativo deve ser configurado o mesmos em cada lado do enlace de tronco. É um erro comum não combinar os VLAN nativos ao configurar o entroncamento do 802.1Q entre o roteador e o interruptor. Para detalhes em VLAN nativos, refira a seção do IEEE 802.1Q do Bridging entre IEEE 802.1Q vLANs, nos novos recursos na liberação 12.1(3)T.

Nesta configuração de exemplo, o VLAN nativo é VLAN1, à revelia, no Cisco 2621 Router e no Catalyst 3512XL Switch. Dependendo das necessidades da rede, talvez seja necessário usar um VLAN nativo que não seja o VLAN padrão, VLAN1. Os comandos foram mencionados na seção de configurações deste documento em como mudar o VLAN nativo no Cisco 2600 Router e no Catalyst 3500XL Switch.

As configurações de amostra apresentadas neste documento podem ser usadas em Cisco 2600/3600/4500/4700 Series Router com módulos de rede das interfaces rápidas de Ethernet ou do Fast Ethernet. Além disso, verifique se está utilizando a versão do Cisco IOS que suporta truncamento de VLAN ISL/802.1Q. Para uma lista completa do Roteadores do Cisco 2600/3600/4500/4700 que apoia o trunking VLAN ISL/802.1Q e as versões do Cisco IOS apoiadas, refira a tabela 2 abaixo.

Tabela 2

Modelos de roteador Versão mínima necessária para o truncamento ISL Versão mínima exigida para entroncamento IEEE 802.1Q Conjunto mínimo de recursos requeridos (ISL/802.1Q)
Cisco 2620 11.3(3a)T 12.0(1)T IP PLUS / IP PLUS
Cisco 2621 11.3(3a)T 12.0(1)T IP PLUS / IP PLUS
Cisco 2620 12.1(3a)T 12.1(3a)T IP PLUS / IP PLUS
Cisco 2650 12.1(3a)T 12.1(3a)T IP PLUS / IP PLUS
Cisco 3620 11.3(1)T 12.0(1)T IP PLUS / IP PLUS
Cisco 3640 11.3(1)T 12.0(1)T IP PLUS / IP PLUS
Cisco 3661 12.0(5)T 12.0(5)T IP PLUS / IP PLUS
Cisco 3662 12.0(5)T 12.0(5)T IP PLUS / IP PLUS
Cisco 4500-M 11.3(1)T 12.0(1)T IP PLUS / IP PLUS
Cisco 4700-M 11.3(1)T 12.0(1)T IP PLUS / IP PLUS

Nota: A tabela 2 alista somente o mínimo ou a manutenção atual/versões principal que apoiam esta configuração de exemplo. É possível que modelos de roteadores com determinados módulos de rede tenham versões mínimas do Cisco IOS diferentes. Para uma lista completa do software suportado mínimo para toda a família de roteador, use o Software Advisor (clientes registrados somente).

Nota: A versão suportada mínima não pode necessariamente ser a versão recomendada. Para determinar a melhor versão de manutenção para seus produtos da Cisco, a busca para erros alistou o componente do subproduto no Bug Toolkit (clientes registrados somente).

Nota: A tabela 2 alista o conjunto mínimo de recursos exigido para fazer o Roteamento Inter-Vlan e o entroncamento IP para apoiar esta configuração de exemplo. Para uma lista completa dos grupos dos outros recursos apoiados em versões do Cisco IOS diferentes e em Plataformas diferentes, use a área do software da transferência.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a instalação de rede mostrada no diagrama abaixo.

/image/gif/paws/14976/50a.jpg

Configurações

Este documento utiliza as configurações mostradas abaixo.

Nota: Os modelos do roteador com determinados módulos de rede podem ter versões do Cisco IOS com diferenças mínimas que suportam o truncamento ISL.

  • Catalyst 3512-XL

  • Cisco 2600 Router

  • 802.1Q Configuração no roteador para versões do Cisco IOS anteriores a 12.1(3)T

Catalyst 3512-XL

Nota: As seguintes capturas de tela mostram os comandos que foram incorporados no 3512XL Switch. São adicionados comentários com fonte azul em itálico entre os comandos para explicar determinados comandos e etapas.


!-- Set the privileged mode


!-- and Telnet password on the switch.

switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
switch(config)#hostname 3512xl
3512xl(config)#enable password mysecret
3512xl(config)#line vty 0 4
3512xl(config-line)#login
3512xl(config-line)#password mysecret
3512xl(config-line)#exit
3512xl(config)#no logging console
3512xl(config)#^Z


!-- Set the IP address and default gateway for VLAN1 for management purposes.

3512xl#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
3512xl(config)#int vlan 1
3512xl(config-if)#ip address 10.10.10.2 255.255.255.0
3512xl(config-if)#exit
3512xl(config)#ip default-gateway 10.10.10.1
3512xl(config)#end

!-- Set the VTP Mode.
!-- In our example, we have set the mode to be transparent.
!-- Depending on your network, set the VTP Mode accordingly.
!-- For details on VTP,
!-- refer to
!-- Creating and Maintaining VLANs on Catalyst 2900XL and 3500XL Switches.

3512xl#vlan database
3512xl(vlan)#vtp transparent
Setting device to VTP TRANSPARENT mode.


!-- Adding VLAN2. VLAN1 already exists by default.

3512xl(vlan)#vlan 2
VLAN 2 added:
Name: VLAN0002
3512xl(vlan)#exit
APPLY completed.
Exiting....


!-- Enable trunking on the interface fastEthernet 0/1.

3512xl#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
3512xl(config)#int fastEthernet 0/1
3512xl(config-if)#switchport mode trunk


!-- Enter the trunking encapsulation as either isl

3512xl(config-if)#switchport trunk encapsulation isl

!-- or as dot1q:


3512xl(config-if)#switchport trunk encapsulation dot1q

!-- In case of 2940/2950 series switches, none of the above two commands are used,
!-- 2940/2950 series switches only support 802.1q encapsulation which is configured automatically,
!-- when trunking is enabled on the interface by using switchport mode trunk command.

!-- In case of dot1q, you need to make sure that
!-- the native VLAN matches across the link.
!-- On 3512XL, by default, the native VLAN is 1.
!-- Depending on your network needs, you may change
!-- the native VLAN to be other than VLAN1,
!-- but it is very important that you change the native VLAN
!-- on the router accordingly.
!-- You may change the native VLAN, if needed, by using the following command:
!-- 3512xl(config-if)#switchport trunk native vlan <vlan ID>

!-- Allow all VLANs on the trunk.

3512xl(config-if)#switchport trunk allowed vlan all
3512xl(config-if)#exit


!-- The following set of commands will place FastEthernet 0/2
!-- into VLAN2 and enable portfast on the interface.

3512xl(config)#int fastEthernet 0/2
3512xl(config-if)#switchport access vlan 2
3512xl(config-if)#spanning-tree portfast
3512xl(config-if)#exit


!-- FastEthernet 0/3 is already in VLAN1 by default.
!-- Enable portfast on the interface.

3512xl(config)#int fastEthernet 0/3
3512xl(config-if)#spanning-tree portfast
3512xl(config-if)#^Z

!-- For details on why to enable portfast,
!-- refer to:
!-- Using PortFast and Other Commands to Fix Workstation Startup Connectivity Delays.
!-- Remember to save the configuration.

3512xl#write memory
Building configuration...

3512xl#

--------------------------------------------------------------------------------

3512xl#show running-config
Building configuration...

Current configuration:

!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 3512xl
!
no logging console
enable password mysecret
!
!
!
!
!
ip subnet-zero
!
!
!
interface FastEthernet0/1
  switchport mode trunk
!

!-- If 802.1Q is configured,
!-- you will instead see the following output
!-- under interface FastEthernet0/1:
!-- interface FastEthernet0/1
!-- switchport trunk encapsulation dot1q
!-- switchport mode trunk

!
interface FastEthernet0/2
 switchport access vlan 2
 spanning-tree portfast
!
interface FastEthernet0/3
 spanning-tree portfast
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface VLAN1
 ip address 10.10.10.2 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
!
ip default-gateway 10.10.10.1
!
line con 0
 transport input none
 stopbits 1
line vty 0 4
 password mysecret
 login
line vty 5 15
 login
!
end

2600 Router

Nota: As seguintes capturas de tela mostram os comandos que foram inseridos no roteador Cisco 2600. São adicionados comentários com fonte azul em itálico entre os comandos para explicar determinados comandos e etapas.


!-- Set the privileged mode
!-- and Telnet password on the router.

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname c2600

c2600(config)#enable password mysecret
c2600(config)#line vty 0 4
c2600(config-line)#login
c2600(config-line)#password mysecret
c2600(config-line)#exit
c2600(config)#no logging console
c2600(config)#^Z

c2600#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.


!-- Select FastEthernet 0/0 for the trunk configuration.
!-- No L2 or Layer 3 (L3) configuration is done here.

c2600(config)#int fastEthernet 0/0
c2600(config-if)#no shut
c2600(config-if)#exit


!-- Enable trunking on the sub-interface FastEthernet 0/0.1.
!-- Note that actual trunks are configured on the sub-interfaces.

c2600(config)#int fastEthernet 0/0.1


!-- Enter the trunking encapsulation as either isl

c2600(config-subif)#encapsulation isl 1


!-- or as dot1q:
!-- In case of dot1q, you need to make sure that
!-- the native VLAN matches across the link.
!-- On 3512XL, by default, the native VLAN is 1.
!-- On the router, configure VLAN1 as the native VLAN.

c2600(config-subif)#encapsulation dot1Q 1 ?
  native  Make this is native vlan
  <cr>
c2600(config-subif)#encapsulation dot1Q 1 native

!-- On the switch, if you have a native VLAN other than VLAN1,
!-- on the router, configure the same VLAN to be the native VLAN,
!-- by using the above command.

Nota: O comando nativo de dot1Q 1 de encapsulamento foi adicionado ao Cisco IOS versão 12.1(3)T. Se você está usando uma versão anterior do Cisco IOS, refira a configuração do 802.1Q para versões do Cisco IOS mais cedo do que a seção 12.1(3)T deste documento para configurar o entroncamento do 802.1Q no roteador.


!-- Configure L3 information on the sub-interface 0/0.1.

c2600(config-subif)#ip address 10.10.10.1 255.255.255.0
c2600(config-subif)#exit


!-- Enable trunking on the sub-interface FastEthernet 0/0.2.
!-- Note that actual trunks are configured on the sub-interfaces.

c2600(config)#int fastEthernet 0/0.2


!-- Enter the trunking encapsulation as either isl

c2600(config-subif)#encapsulation isl 2


!-- or as dot1q:

c2600(config-subif)#encapsulation dot1Q 2


!-- Configure L3 information on the sub-interface 0/0.2.

c2600(config-subif)#ip address 10.10.11.1 255.255.255.0
c2600(config-subif)#exit
c2600(config)#^Z


!-- Remember to save the configuration.

c2600#write memory
Building configuration...
[OK]
c2600#

Nota: A fim fazer este trabalho da instalação, e sibilar com sucesso entre a estação de trabalho1 e o workstation2, você precisa de certificar-se de que os gateways padrão nas estações de trabalho setup corretamente. O gateway padrão deve ser 10.10.11.1 para a estação de trabalho 1, e para a estação de trabalho 2, o gateway padrão deve ser 10.10.10.1. Para obter detalhes sobre como definir os gateways padrão nas estações de trabalho, consulte as suas respectivas seções neste documento.

Nota: O seguinte parágrafo é somente aplicável, se você configurou o entroncamento do 802.1Q entre o roteador e o interruptor.

Nota: Se você seguiu as etapas de configuração alistadas nas seções acima, e não pode ainda sibilar através dos VLAN (entre a estação de trabalho1 e o workstation2), a seguir há uma possibilidade que você venha através da advertência CSCds42715, em que as palavras-chave de VLAN nativa do 802.1Q não funcionam corretamente quando o interruptor rápido é permitido. A correção de bug foi integrada nas seguintes versões de código: 12.2(0.5), 12.2(0.5)T, 12.1(5)DC, 12.1(5)YB, 12.2(0.18)S, 12.1(5)YD02, 12.2(2)B, 12.2(15)ZN. Você pode verificar o estado e uma breve descrição do erro usando o Bug Toolkit (clientes registrados somente) e entrando no Bug ID CSCds42715.


--------------------------------------------------------------------------------

c2600#show running-config
Building configuration...
 
Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname c2600
!
no logging console
enable password mysecret
!
!
!
!
!
ip subnet-zero
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 encapsulation isl 1
 ip address 10.10.10.1 255.255.255.0
 no ip redirects
!

!-- If 802.1Q is configured,
!-- you will instead see the following output
!-- under interface FastEthernet0/0.1:
!-- interface FastEthernet0/0.1
!-- encapsulation dot1Q 1 native
!-- ip address 10.10.10.1 255.255.255.0

!
!
interface FastEthernet0/0.2
 encapsulation isl 2
 ip address 10.10.11.1 255.255.255.0
 no ip redirects
!

!-- If 802.1Q is configured,
!-- you will instead see the following output
!-- under interface FastEthernet0/0.2:
!-- interface FastEthernet0/0.2
!-- encapsulation dot1Q 2
!-- ip address 10.10.11.1 255.255.255.0

!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip classless
no ip http server
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password mysecret
 login
!
no scheduler allocate
end

802.1Q Configuração no roteador para versões do Cisco IOS anteriores a 12.1(3)T
Conforme descrito anteriormente neste documento, ao configurar o truncamento 802.1Q, é muito importante corresponder a VLAN nativa através do enlace. Nas versões de Cisco IOS Software mais cedo do que 12.1(3)T, você não pode definir o VLAN nativo explicitamente, porque o comando encapsulation dot1Q 1 native sob a secundário-relação não está disponível. Nas versões do Cisco IOS mais adiantadas, é importante configurar a interface de VLAN nativa não como uma secundário-relação, que esteja em nosso exemplo VLAN1. Se configurado erradamente, o roteador esperaria que um quadro do dot1q da etiqueta no VLAN1 e no interruptor não está esperando uma etiqueta no VLAN1. Em consequência, o sem tráfego passará entre o VLAN1 no interruptor e o roteador. Nestas situações põe sempre a configuração para o VLAN nativo sob a interface principal e no tronco crie a subinterface para todo VLANS restante. Na configuração atual do laboratório, siga estas etapas para configurar o roteador Cisco 2600:
 

!-- Set the privileged mode
!-- and Telnet password on the router.

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname c2600
c2600(config)#enable password mysecret
c2600(config)#line vty 0 4
c2600(config-line)#login;
c2600(config-line)#password mysecret
c2600(config-line)#exit
c2600(config)#no logging console
c2600(config)#^Z

c2600#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.


!-- Select FastEthernet 0/0 for the trunk configuration.

c2600(config)#int fastEthernet 0/0
c2600(config-if)#no shut


!-- Note that the IP address for VLAN1 is configured on the main interface,
!-- and no encapsulation for VLAN1 will be done under the sub-interface.

c2600(config-if)#ip address 10.10.10.1 255.255.255.0
c2600(config-if)#exit


!-- Configure dot1q encapsulation for VLAN 2
!-- on sub-interface fastEthernet 0/0.2.

c2600(config)#int fastEthernet 0/0.2
c2600(config-subif)#encapsulation dot1Q 2
c2600(config-subif)#


!-- Configuring L3 information on the sub-interface 0/0.2.

c2600(config-subif)#ip address 10.10.11.1 255.255.255.0
c2600(config-subif)#exit
c2600(config)#^Z


!-- Remember to save the configuration.

c2600#write memory
Building configuration...
[OK]
c2600#

Nota: Para fazer com que esta configuração funcione e para efetuar ping com êxito entre a estação de trabalho 1 e a estação de trabalho 2, é preciso verificar se os gateways padrão nas estações de trabalho estão configurados corretamente. O gateway padrão deve ser 10.10.11.1 para a estação de trabalho 1 e 10.10.10.1 para a estação de trabalho 2. Para obter detalhes sobre como definir os gateways padrão nas estações de trabalho, consulte as seções respectivas neste documento.

c2600#show running-config
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname c2600
!
no logging console
enable password mysecret
!
!
!
!
!
memory-size iomem 7
ip subnet-zero
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 10.10.10.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/0.2
 encapsulation dot1Q 2
 ip address 10.10.11.1 255.255.255.0
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip classless
no ip http server
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password mysecret
 login
!
no scheduler allocate
end

c2600#

comandos debug e show

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

No interruptor do catalizador 2900XL/3500XL/2940/2950/2970, use os comandos seguintes:

  • show int {FastEthernet | Switchport do <module/port> do gigabitethernet}

  • show vlan

  • show vtp status

No Cisco 2600 Router, use os comandos seguintes:

  • show vlan

  • show interface

Exemplo de saída do comando show

Catalyst 3500XL Switch

show int {FastEthernet | Switchport do <module/port> do gigabitethernet}

Esse comando é usado para verificar o status administrativo e operacional da porta. Também é usado para assegurar que a VLAN nativa corresponda em ambos os lados do tronco. A VLAN nativa é usada para tráfego não rotulado quando a porta estiver no modo de truncamento 802.1Q. Refira a criação e a manutenção de VLAN em Catalyst 2900XL e 3500XL Switches para detalhes em VLAN nativos.

3512xl#show int fastEthernet 0/1 switchport
Name: Fa0/1
Switchport: Enabled
Administrative mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: isl
Operational Trunking Encapsulation: isl
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1,2
Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none

Nota: Com relação ao truncamento 802.1q, a saída do comando acima altera o seguinte:

3512xl#show int fastEthernet 0/1 switchport
Name: Fa0/1
Switchport: Enabled
Administrative mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1,2
Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none

show vlan

Este comando é utilizado para verificar se as interfaces (portas) pertencem à VLAN correta. Em nosso exemplo, apenas a interface Fa0/2 pertence à VLAN2. As restantes são membros da VLAN1.

3512xl#show vlan
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/3, Fa0/4, Fa0/5, Fa0/6,
                                                Fa0/7, Fa0/8, Fa0/9, Fa0/10,
                                                Fa0/11, Fa0/12, Gi0/1, Gi0/2
2    VLAN0002                         active    Fa0/2
1002 fddi-default                     active    
1003 token-ring-default               active    
1004 fddinet-default                  active    
1005 trnet-default                    active    

...(output suppressed)

show vtp status

Este comando é usado verificar a configuração do protocolo VLAN trunking (VTP) no interruptor. Em nosso exemplo, usamos o modo transparente. O modo VTP correto depende da topologia da rede. Para detalhes no VTP, refira a criação e a manutenção de VLAN em Catalyst 2900XL e 3500XL Switches.

3512xl#show vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 254
Number of existing VLANs        : 6
VTP Operating Mode              : Transparent
VTP Domain Name                 : 
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0xC3 0x71 0xF9 0x77 0x2B 0xAC 0x5C 0x97
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00

Cisco 2600 Router

show vlan

Este comando diz quais informações de L2 ou L3 estão configuradas para cada VLAN.

c2600#show vlan
 
Virtual LAN ID:  1 (Inter Switch Link Encapsulation)
 
   vLAN Trunk Interface:   FastEthernet0/0.1
 
   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.10.1                  40                  38
 
Virtual LAN ID:  2 (Inter Switch Link Encapsulation)
 
   vLAN Trunk Interface:   FastEthernet0/0.2
 
   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.11.1                   9                   9

Nota: Com relação ao truncamento 802.1q, a saída do comando acima altera o seguinte:

c2600#show vlan
 
Virtual LAN ID:  1 (IEEE 802.1Q Encapsulation)
 
   vLAN Trunk Interface:   FastEthernet0/0.1
 
 This is configured as native Vlan for the following interface(s): FastEthernet0/0
 
   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.10.1                   0                   2
 
Virtual LAN ID:  2 (IEEE 802.1Q Encapsulation)
 
   vLAN Trunk Interface:   FastEthernet0/0.2
 
   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.11.1                  42                  19

Nota: Para o entroncamento do 802.1Q, com versões do Cisco IOS mais cedo então 12.1(3)T, a saída do comando muda como segue:

c2600#show vlan

Virtual LAN ID:  2 (IEEE 802.1Q Encapsulation)

   vLAN Trunk Interface:   FastEthernet0/0.2

   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.11.1                   6                   4

Nota: Nenhum encapsulamento de IEEE 802.1Q é exibido para VLAN1 em nenhuma das sub-interfaces.

show interface

Este comando é usado verificar o status operacional e administrativo da relação.

c2600#show interfaces fastEthernet 0/0
FastEthernet0/0 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:07, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 0 bits/sec, 1 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     217 packets input, 12884 bytes
     Received 217 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     45 packets output, 6211 bytes, 0 underruns(0/0/0)
     0 output errors, 0 collisions, 4 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

c2600#show interfaces fastEthernet 0/0.1
FastEthernet0/0.1 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  Internet address is 10.10.10.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ISL Virtual LAN, Color 1.
  ARP type: ARPA, ARP Timeout 04:00:00

c2600#show interfaces fastEthernet 0/0.2
FastEthernet0/0.2 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  Internet address is 10.10.11.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ISL Virtual LAN, Color 2.
  ARP type: ARPA, ARP Timeout 04:00:00

Nota: Com relação ao truncamento 802.1q, a saída do comando acima altera o seguinte:

c2600#show interfaces fastEthernet 0/0.1
FastEthernet0/0.1 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  Internet address is 10.10.10.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID  1.
  ARP type: ARPA, ARP Timeout 04:00:00

c2600#show interfaces fastEthernet 0/0.2
FastEthernet0/0.2 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  Internet address is 10.10.11.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID  2.
  ARP type: ARPA, ARP Timeout 04:00:00

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 14976