Discar e acessar : """Integrated Services Digital Networks (ISDN), Channel-Associated Signaling (CAS)"""

Configurando o Data Over Voice (DoV) que usa dados de voz recebida isdn e chamada de voz do discador

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento fornece uma configuração de exemplo configurando o Data Over Voice (DoV) que usa os comandos isdn incoming-voice data e dialer voice-call.

Antes de Começar

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Pré-requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nas versões de software e hardware abaixo.

  • Software Release 11.3 ou Mais Recente de Cisco IOS�.

  • Você pode usar todo o roteador com uma interface. Contudo você deve assegurar-se de que o telco apoie o DOV, e que nenhuma corrupção dos dados

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Material de Suporte

Os Dados sobre voz (DOV) permitem o envio de dados em uma chamada de voz utilizando uma linha de ISDN. Uma linha de ISDN pode suportar tanto chamadas de dados quanto chamadas de voz. Dois roteadores que se interconectam com linhas ISDN normalmente usam chamadas de dados (64 kbps ou 56 kbps). Espera-se gerar chamadas de voz por um telefone ou fax. As chamadas de voz também podem ser geradas por um dispositivo conectado a um modem analógico (por exemplo, um PC discando com uma linha do serviço de telefonia tradicional [POTS]).

Em algumas circunstâncias, um usuário pode estar interessado em conectar dois roteadores para chamadas de voz que utilizam linhas ISDN, especialmente ao considerar a diferença de preço entre uma chamada de dados e uma chamada de voz. As linhas de ISDN em geral têm custos por chamada para todas as chamadas (local, longa distância e internacional).

Em alguns casos a fixação do preço das chamadas de voz é mais baixa do que a fixação do preço das chamadas de dados. Para que os roteadores possam se comunicar utilizando chamadas de voz entre duas linhas ISDN, é necessário realizar uma configuração cuidadosa para tornar os roteadores cientes de que as chamadas precisam ser iniciadas como chamadas de voz e que as chamadas de voz recebidas devem ser tratadas como chamadas de dados. No lado externo (quem chama), utilize a opção de classe de mapas para definir as chamadas como chamadas de voz:

map-class dialer name

chamada de voz do discador

Essa classe de mapa define um comportamento e deve ser aplicada às interfaces ISDN nas quais esse comportamento é necessário. Está aqui um exemplo do comportamento da classe de mapas em comandos dialer map ou dialer string.

número de telefone do [broadcast] do nome de host do nome do map class da classe do endereço do protocolo de mapa de discador

map class da classe do número de telefone da corda do dialer

Consulte a documentação do software Cisco IOS para obter uma sintaxe completa desses dois comandos.

No lado da entrada (chamado), adicione o comando isdn incoming-voice data na interface física. Lembre-se que todas as chamadas de voz recebidas serão tratadas como células de dados. Se você estiver usando uma plataforma que suporta chamadas de modem nas BRIs, não poderá configurar uma determinada interface para suportar um dos recursos. Uma interface particular podia segurar chamadas de voz como chamadas de modem ou chamadas de voz como atendimentos DOV, mas não ambas.

Nota: É possível configurar uma interface particular para segurar chamadas de voz porque chamadas de modem ou chamadas de voz como atendimentos DOV. No entanto, é necessário configurar o RPM. Para obter mais informações sobre RPM, consulte o seguinte documento: Resource Pool Management.

É importante compreender que o DOV tem confiabilidade limitada. Espera-se que uma chamada entre as duas linhas de ISDN forneça um caminho digital de ponta a ponta. O equipamento, as linhas, e outros recursos que a companhia telefônica se usa para estabelecer chamadas de dados e de voz são geralmente o mesmo. Contudo, podem ser diferentes. O transporte de voz digital é mais flexível do que o transporte de dados. Para chamadas de dados de ISDN, a rede telefônica garante um transporte de bits em um caminho digital de 64 kbps a 56 kbps. Para chamadas de voz, a rede telefônica pode direcionar e manipular o fluxo de bit de diferentes formas, sem afetar a qualidade de voz, mas todos os dados serão corrompidos quando forem enviados dessa forma. Portanto, o DOV não funciona com algumas linhas de ISDN. Verifique que seu telco pode segurar atendimentos DOV antes que você configure esta característica, mais a configuração de chamada pode succeeed mas os estes dados estarão corrompidos.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a instalação de rede mostrada no diagrama abaixo.

/image/gif/paws/14964/briipun.gif

Configurações

Este documento utiliza as configurações mostradas abaixo.

Roteador 1
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router1
!
aaa new-model
aaa authentication login default local
aaa authentication login CONSOLE none
aaa authentication ppp default local
enable password somethingSecret
!
username Router2 password 0 open4me2
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
interface Ethernet0
 ip address 10.10.186.133 255.255.255.240
 no ip directed-broadcast
!
interface Serial0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface BRI0
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 dialer string 5556700 class DOV

! --- The router will use the map-class DOV when dialing this number
! --- The map-class named DOV is defined below

 dialer load-threshold 5 outbound
 dialer-group 1
 ppp authentication chap
!
ip classless
ip route 0.0.0.0 0.0.0.0 BRI0
no ip http server
!
map-class dialer DOV

! --- map class named DOV is applied to the dialer string under 
! --- the physical interface

 dialer voice-call

! --- Outgoing call is treated as a voice call

!
dialer-list 1 protocol ip permit
!
line con 0
 login authentication CONSOLE
 transport input none
line aux 0
line vty 0 4
!
end

Roteador 2
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router2
!
aaa new-model
aaa authentication login default local
aaa authentication login CONSOLE none
aaa authentication ppp default local
enable password somethingSecret
!
username Router1 password 0 open4me2
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
interface Ethernet0
 ip address 10.8.186.134 255.255.255.240
 no ip directed-broadcast
!
interface Serial0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface BRI0
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 dialer-group 1
 isdn switch-type basic-5ess
 isdn incoming-voice data

! --- Incoming voice calls will be treated as data calls
! --- An interface cannot accept modem calls and DOV calls without RPM

 ppp authentication chap
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.8.186.129
ip route 10.10.186.128 255.255.255.240 BRI0
no ip http server

dialer-list 1 protocol ip permit

line con 0
 login authentication CONSOLE
 transport input none
line aux 0
line vty 0 4
!
end

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

  • status de ISDN da mostra - O estado deve ser:

    layer 1 = active 
    layer 2 = MULTIPLE_FRAMES_ESTABLISHED

    Se o Layer 1 não é ativo, a seguir o adaptador de fiação ou a porta podem ser ruim ou não obstruído dentro. Se a camada 2 está em um estado de TEI_Assign, a seguir o roteador não está falando ao interruptor. Refira a utilização do comando show isdn status para o Troubleshooting de BRI para obter mais informações sobre das soluções de problemas com a conexão ISDN

Troubleshooting

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

Comandos para Troubleshooting

Nota: Antes de emitir comandos debug, consulte Informações importantes sobre comandos debug.

  • debug dialer - Ao Exibir informação a respeito da causa de algum atendimento. Isto primarilty seria usado para determinar se o roteador iniciou o atendimento.

  • debugar o q931 de ISDN - Para verificar conexões ISDN como usuários discar dentro para ver o que está acontecendo com a chamada ISDN (por exemplo, se a conexão está sendo deixada cair). Você pode igualmente verificar a cobertura do portador (que indica se o atendimento é digital ou Voz) deste resultado do debug.

  • debug ppp nego - Para ver se os detalhes da negociação de PPP.

  • debugar o PPP chap - Para verificar a autenticação.

Saída de depurações

Os seguintes debugam a saída do q931 de ISDN mostram o atendimento que conecta usando o DOV. o maui-soho-01 (cliente) disca maui-nas-08 (o server). Observe a cobertura do portador dos atendimentos para indicar como esperado que são chamadas de voz. maui-nas-08 é configurado para tratar chamadas de voz recebida como chamadas de dados (ao contrário das chamadas de modem) e o atendimento é conectado.

maui-soho-01#ping 10.8.186.134 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.8.186.134, timeout is 2 seconds:
Aug 17 15:48:12.523: ISDN BR0: TX ->  SETUP pd = 8  callref = 0x03

! --- Setup message for outgoing call

Aug 17 15:48:12.531:         Bearer Capability i = 0x8090A2

! --- Bearer Cap indicates that the call is a Voice call(u-law)
! --- An ISDN digital call would be indicated with 0x8890 (for 64k) 
! --- or 0x8890218F (for 56k)

Aug 17 15:48:12.543:         Channel ID i = 0x83
Aug 17 15:48:12.550:         Keypad Facility i = '5556700'
Aug 17 15:48:12.908: ISDN BR0: RX <-  CALL_PROC pd = 8  callref = 0x83

Aug 17 15:48:12.916:         Channel ID i = 0x89

Aug 17 15:48:12.927:         Locking Shift to Codeset 5
Aug 17 15:48:12.931:         Codeset 5 IE 0x2A  i = 0x808001038308, 
'555-6700', 0x8001098001, '<'
Aug 17 15:48:13.130: ISDN BR0: RX <-  CONNECT pd = 8  callref = 0x83

! --- maui-nas-08 has accepted the call and responded with the 
! --- CONNECT message

Aug 17 15:48:13.142:         Locking Shift to Codeset 5
Aug 17 15:48:13.150:         Codeset 5 IE 0x2A  i = 0x808001038308, 
'555-6700', 0x8001098909, 'Connected', 0x80010B8001, '('
Aug 17 15:48:13.217: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up.
Aug 17 15:48:13.249: ISDN BR0: TX ->  CONNECT_ACK pd = 8  callref = 0x03
Aug 17 15:48:14.372: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, 
changed state to up
Aug 17 15:48:19.185: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 5556700

Os seguintes debugam são obtidos do maui-nas-08 (server). Observe que a cobertura do portador indica que a chamada é uma chamada de voz. O NAS foi configurado para tratar chamadas de voz recebidas como chamadas de dados nessa interface.

maui-nas-08#
Aug 17 15:48:12.765: ISDN BR2/0: RX <-  SETUP pd = 8  callref = 0x13

! --- Setup message for incoming call

Aug 17 15:48:12.765:         Bearer Capability i = 0x8090A2

! --- Bearer Cap indicates that the call is a Voice call(u-law)
! --- An ISDN digital call would be indicated with 0x8890 (for 64k) 
! --- or 0x8890218F (for 56k)

Aug 17 15:48:12.765:         Channel ID i = 0x89
Aug 17 15:48:12.765:         Signal i = 0x40 - Alerting on - pattern 0 
Aug 17 15:48:12.765:         Called Party Number i = 0xC1, '5556700', 
Plan:ISDN, Type:Subscriber(local)
Aug 17 15:48:12.765:         Locking Shift to Codeset 5
Aug 17 15:48:12.765:         Codeset 5 IE 0x2A  i = 0x808001038001118001, '<'

Aug 17 15:48:12.769: ISDN BR2/0: Event: Received a DATA call from  
on B1 at 64 Kb/s

! --- The incoming voice call (on int bri 2/0) is treated as a data call
! --- This is configured (in interface config mode) using 
! --- isdn incoming-voice data

Aug 17 15:48:12.769: ISDN BR2/0: TX ->  CALL_PROC pd = 8  callref = 0x93
Aug 17 15:48:12.773:         Channel ID i = 0x89
Aug 17 15:48:12.773: %LINK-3-UPDOWN: Interface BRI2/0:1, changed state to up
Aug 17 15:48:12.773: BR2/0:1 PPP: Treating connection as a callin
Aug 17 15:48:12.773: BR2/0:1 PPP: Phase is ESTABLISHING, Passive Open
Aug 17 15:48:12.773: BR2/0:1 LCP: State is Listen
Aug 17 15:48:13.073: ISDN BR2/0: TX ->  CONNECT pd = 8  callref = 0x93

! --- The call is accepted and nas-08 responds with the CONNECT message

Aug 17 15:48:13.073:         Channel ID i = 0x89
Aug 17 15:48:13.121: ISDN BR2/0: RX <-  CONNECT_ACK pd = 8  callref = 0x13


! ---Output omitted

...

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 14964