Discar e acessar : """Integrated Services Digital Networks (ISDN), Channel-Associated Signaling (CAS)"""

Conexão de BRI com PRI usando dados sobre voz

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento fornece uma configuração de exemplo para TData sobre a Voz (DOV), que permite que os dados sejam enviados sobre uma chamada de voz com uma linha de ISDN.

Pré-requisitos

Requisitos

Certifique-se de atender a estes requisitos antes de tentar esta configuração:

  • Versão 12.0 do Cisco IOS Software

  • Cisco 5300 com quatro relações da taxa principal (PRI)

  • Cisco 2503 com um Basic Rate Interface (BRI)

  • O hostname de cada lado

  • Uma senha para a autenticação de PPP

  • Números de telefone das linhas de ISDN

  • Os endereços IP de Um ou Mais Servidores Cisco ICM NT das interfaces Ethernet em ambos os lados

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Informações de Apoio

O DOV permite que os dados sejam enviados sobre uma chamada de voz com uma linha de ISDN. Uma linha de ISDN pode suportar tanto chamadas de dados quanto chamadas de voz. Dois Roteadores que interconecta com linhas de ISDN tipicamente usam chamadas de dados (64 kpbs ou 56 kbps). Espera-se gerar chamadas de voz por um telefone ou fax. As chamadas de voz podem igualmente ser geradas por um dispositivo conectado a um modem analógico, por exemplo, um PC esse dial up com uma linha de serviço de telefonia tradicional (POTS).

Em algumas circunstâncias, um usuário pode conectar dois Roteadores com as chamadas de voz com linhas de ISDN, especialmente quando a diferença de preço entre uma chamada de dados e uma chamada de voz é considerada. As linhas de ISDN têm geralmente cobranças por chamada para todos os atendimentos: local, longa distância, e international. Em alguns casos, o custo das chamadas de voz é mais baixo do que o custo das chamadas de dados.

Para que o Roteadores comunique-se com as chamadas de voz entre duas linhas de ISDN, a configuração cuidadosa é necessária para fazer o Roteadores ciente que os atendimentos precisam de ser iniciados como chamadas de voz e que as chamadas de voz de entrada devem ser seguradas como chamadas de dados. No lado externo (quem chama), utilize a opção de classe de mapas para definir as chamadas como chamadas de voz:

map-class dialer name

chamada de voz do discador

Essa classe de mapa define um comportamento e deve ser aplicada às interfaces ISDN nas quais esse comportamento é necessário. Está aqui um exemplo do comportamento da classe de mapas no mapa de discadores e nos comandos dialer string:

número de telefone do [broadcast] do nome de host do nome do map class da classe do endereço do protocolo de mapa de discador

map class da classe do número de telefone da corda do dialer

Refira a documentação de software do½ do¿Â do Cisco IOSï para a sintaxe completa destes dois comandos.

No lado (chamado) de entrada, adicionar o comando isdn incoming-voice data sob a relação Serial<n>:23. Recorde que todas as chamadas de voz de entrada estão tratadas como chamadas de dados. Se você igualmente quer apoiar chamadas de modem na mesma linha de ISDN, use a característica do gerenciador do conjunto de recurso (RPM); se não, você pode separar aqueles dois serviços em duas linhas de ISDN diferentes com os números de telefone diferentes. Os problemas ocorrem se as duas linhas têm o mesmo número; são parte de um grupo de buscas. Uma interface particular pode segurar chamadas de voz como chamadas de modem ou chamadas de voz como atendimentos de dados sobre voz, mas não ambas.

É importante compreender que o DOV tem confiabilidade limitada. Espera-se que uma chamada entre as duas linhas de ISDN forneça um caminho digital de ponta a ponta. O equipamento, as linhas, e outros recursos que a companhia telefônica se usa para estabelecer chamadas de dados e de voz são geralmente os mesmos, mas elas pode ser diferente. O transporte de voz digital é mais flexível do que o transporte de dados. Para chamadas de dados de ISDN, a rede telefônica garante um transporte de bits em um caminho digital de 64 kbps a 56 kbps. Para chamadas de voz, a rede telefônica pode distribuir e manipular o fluxo de bit em maneiras diferentes contudo não em Qualidade de voz da influência. Desde que todos os dados são corrompidos quando enviados esta maneira, DOV não trabalha com algumas linhas de ISDN.

Configurar

Esta configuração usa um Cisco 5300 com quatro relações da taxa principal (PRI) para terminar atendimentos e um Cisco 2503 com um Basic Rate Interface (BRI) para iniciar os atendimentos. O Cisco 5300 fornece o apoio para 48 atendimentos DOV, 48 chamadas de modem, e 96 chamadas de dados. Os primeiros dois PRI são configurados para segurar chamadas de voz como dados, e os últimos dois são configurados para segurar chamadas de voz como chamadas de modem. Um nome de usuário e senha deve ser configurado para cada usuário que disca dentro. Esta configuração não usa o Terminal Access Controller Access Control System (TACACS+) ou o Remote Authentication Dial-In User Service (RADIUS).

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/14962/britopri_dov.gif

Configurações

Este documento utiliza as seguintes configurações:

  • Roteador 1

  • Roteador 2

Roteador 1
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router1
!
aaa new-model
AAA authentication login default local
aaa authentication login CONSOLE none
aaa authentication ppp default if-needed local
enable password somethingSecret
!
username santiago password 0 letmein
username Router2 password 0 open4me2
ip subnet-zero
no ip domain-lookup
!
isdn switch-type primary-5ess
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 1
 framing esf
 clock source line secondary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 2
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 3
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
!
interface Ethernet0
 ip address 10.10.1.1 255.255.255.0
 no ip directed-broadcast
!
interface Serial0:23
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 ip tcp header-compression passive
 dialer rotary-group 1
 dialer-group 1
 isdn switch-type primary-5ess
 isdn incoming-voice data
!
interface Serial1:23
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 ip tcp header-compression passive
 dialer rotary-group 1
 dialer-group 1
 isdn switch-type primary-5ess
 isdn incoming-voice data
!
interface Serial2:23
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 ip tcp header-compression passive
 dialer rotary-group 2
 dialer-group 1
 isdn switch-type primary-5ess
 isdn incoming-voice modem
!
interface Serial3:23
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 ip tcp header-compression passive
 dialer rotary-group 2
 dialer-group 1
 isdn switch-type primary-5ess
 isdn incoming-voice modem
!
interface FastEthernet0
 ip address 10.10.2.1 255.255.255.0
 no ip directed-broadcast
!
interface Group-Async1
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 async mode interactive
 ip tcp header-compression passive
 peer default ip address pool IPaddressPool
 no cdp enable
 ppp authentication chap
 group-range 1 48
 !
interface Dialer1
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 ip tcp header-compression passive
 dialer-group 1
 ppp authentication chap
!
interface Dialer2
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 ip tcp header-compression passive
 dialer-group 1
 peer default ip address pool IPaddressPool
 ppp authentication chap
!
ip local pool IPaddressPool 10.10.10.1 10.10.10.254
ip classless
ip route 10.8.186.128 255.255.255.240
no ip http server
!
line con 0
 login authentication CONSOLE
 transport input none
line 1 48
 autoselect during-login
 autoselect ppp
 modem Dialin
line aux 0
line vty 0 4
!
end

Roteador 2
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router2
!
aaa new-model
aaa authentication login default local
aaa authentication login CONSOLE none
aaa authentication ppp default local
enable password somethingSecret
!
username Router1 password 0 open4me2
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
interface Ethernet0
 ip address 10.8.186.134 255.255.255.240
 no ip directed-broadcast
!
interface Serial0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface BRI0
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 dialer string 5555700 class DOV
 dialer load-threshold 5 outbound
 dialer-group 1
 isdn switch-type basic-5ess
 ppp authentication chap
!
ip classless
ip route 0.0.0.0 0.0.0.0 BRI0
no ip http server
!
!
map-class dialer DOV
 dialer voice-call
dialer-list 1 protocol ip permit
!
line con 0
 login authentication CONSOLE
 transport input none
line aux 0
line vty 0 4
!
end

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

Use esta seção para resolver problemas de configuração.

Comandos para Troubleshooting

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Nota: Consulte Informações Importantes sobre Comandos de Depuração antes de usar comandos debug.

  • debug dialer — Indica a informação que se refere à causa de todo o atendimento

  • debugar o q931 de ISDN — As conexões ISDN das verificações como usuários discam dentro para ver o que acontece com a chamada ISDN, por exemplo, se a conexão é deixada cair

  • debug ppp nego — Vê os detalhes da negociação de PPP

  • debugar o PPP chap — Verifica a autenticação

  • status de ISDN da mostra — O estado deve ser este:

    layer 1 = active 
        layer 2 = MULTIPLE_FRAMES_ESTABLISHED 

    Se o Layer 1 não é ativo, o adaptador de fiação ou a porta podem ser ruim ou não obstruído dentro. Se a camada 2 está em um estado de TEI_Assign, o roteador não fala ao interruptor.

  • usuário da mostra — Indica os usuários do async/sincronização conectados atualmente

  • mapa de discadores da mostra — Depois que uma conexão ISDN é feita, vê se um mapa de discadores dinâmico foi criado. Sem um mapa de discadores, você não pode encaminhar pacotes.

Troubleshooting do modem

  • debugar o modem — Vê se o roteador recebe os sinais correto do modem interno

  • debug modem csm — Permite a gerência do modem que o módulo de switching de chamadas (CS) debuga o modo


Informações Relacionadas


Document ID: 14962