Discar e acessar : Dial-on-Demand Routing (DDR)

Executando uma discagem de AS5300 com ISDN/Async (DDR externo)

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Esta configuração tem um AS5300 com quatro relações da taxa principal (PRI) e apoio para 96 chamadas de modem ou um grande número chamadas ISDN. É configurada com quatro PRI para permitir Assíncrono e conexões de saída de ISDN. Os Mapas de discagem estáticos são configurados no lado de discagem para cada conexão ISDN/Async. As rotas IP estático são usadas no ambas as extremidades da conexão para evitar a carga adicional desnecessária de um protocolo de roteamento dinâmico. Adicionar uma posição remota exigiria a adição de um mapa de discadores, de username, e de uma rota estática para o destino novo no lado de discagem. Todos os nós remotos têm endereços IP fixos.

Antes de Começar

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Pré-requisitos

Etapa 1 - Configurar e verifique que os clientes de discagem setup corretamente.

Configurações de dialout - Dispositivo a que este AS5300 disca para fora:

  • PRI: Configurando um servidor de acesso com os PRI para Assíncrono que parte e chamadas ISDN - use a configuração do roteador do AS5300 Series da instalação central (hostname AS5300) fornecida no documento.

  • BRI para receber a chamada recebida do AS5300: Configurando o Dial-on-Demand Routing (DDR) ISDN com Perfis de discagem - Use a configuração do Cisco 2503 Router da site de cliente (hostname remoteISDN01) fornecida no documento.

  • Assíncrono para receber a chamada recebida do AS5300: Configurando o grupo assíncrono da relação com Perfis de discagem - Use a configuração do Cisco 2511 Router da site de cliente (hostname remoteAsync01) fornecida no documento

Etapa 2 – Verifique se os circuitos Telco estão funcionando adequadamente. Você pode usar o comando show isdn status verificar que o circuito BRI ou PRI está funcionando corretamente. Consulte o documento Utilizando o Comando show isdn status para o Troubleshooting de BRI para obter mais informações. Você também deve ativar o circuito T1/E1 PRI para chamadas realizadas. Entre em contato com a Telco para verificar essas informações.

Componentes Utilizados

As informações neste documento são baseadas nas versões de software e hardware abaixo.

  • Cisco AS5300, Cisco 2511 e Cisco 2503

  • Software Release 12.2(10b) do½ do¿Â do Cisco IOSïÂ

  • Um modem assíncrono externo

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Material de Suporte

Em algumas situações, pode ser necessário usar os circuitos PRI de Conexões de discagem T1/E1. Isto ajuda a assegurar o cliente ou o escritório filial a que o circuito T1/E1 PRI disca para fora é uma identificação fixada, em vez de um usuário desconhecido que disca dentro com o nome de usuário e senha duplicado à rede.

Produtos Relacionados

Essa configuração pode ser utilizada com qualquer roteador que possua placas T1 ou PRI. Por essa razão, qualquer roteador do AS5xxx Series com uma placa T1 ou PRI pode usar essa configuração. Os Cisco 2600 e 3600 Series Router podem igualmente ser configurados para discar para fora chamadas ISDN com um WAN Interface Card T1/PRI (WIC) ou módulo de rede.

Essa configuração pode também ser modificada para ser usada com portas E1 ou PRI. Configure o controlador E1com a codificação de linha, enquadramento e outras características físicas suportadas pela Telco. A configuração de canal D (interface serial x:15 para E1s) é similar àquela mostrada aqui.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento. Para esta rede, você precisa o seguinte:

  • O tipo de switch PRI, codificação de linha e framing.

  • Os nomes de usuário e as senhas de todos os nós remotos que você estará discando em. Mesmo se você está indo adicionar o TACACS+ ou o RAIO mais tarde, adicionar alguns nomes ao roteador para testar as linhas.

  • O esquema de endereçamento de IP.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a instalação de rede mostrada no diagrama abaixo.

/image/gif/paws/14960/1a.gif

Configurações

Este documento utiliza as configurações mostradas abaixo.

AS5300
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname AS5300
!

!
username remoteISDN01 password 0 xxxx
username remoteAsync01 password 0 xxxx

!--- Usernames for local authentication of the call.
!--- The client presents the username/password 
!--- and the AS5300 authenticates the peer.
!--- This local database of usernames and passwords are 
!--- compared when chap PPP authentication is negotiated 
!--- between the AS5300 and remoteISDN01, remoteAsync01 routers.

!
isdn switch-type primary-5ess

!--- Switch-type for this AS5300. Obtain this information from the Telco.

chat-script kelly "" "atdt\T" TIMEOUT 60 CONNECT \c

!--- A chat script is a string of text that defines the handshaking 
!--- that occurs between the router and the  modem to sucessfully 
!--- handshake with the destination. 
!--- In this chat-script, "kelly" is the chat-script name.
!--- The expect string "" is the null from the destination. 
!--- And the send string "ATDT\T" is to instruct the modem 
!--- to dial the telephone number in the dialer string command, 
!--- which is 9996200 in the Interface dialer 1
!--- TIMEOUT 60 CONNECT \C - waits up to 60 seconds for the input string "CONNECT", 
!--- and \C is an escape sequence to end the chat-script.
!--- Refer to the Modem-Router Connection Guide and Chat-script for more information.

!
controller T1 0

!--- T1 PRI physical controller configuration.

 framing esf

!--- Framing for this T1 is Extended Super Frame (ESF). 
!--- Obtain this information from the Telco.

 clock source line primary

!--- T1 0 is the primary clock source for this AS5300. 
!--- Clock source must be specified for the timing 
!--- and synchronization of the T1 carrier.

 linecode b8zs

!--- Linecoding for this T1. Obtain this information from the Telco.

 pri-group timeslots 1-24

!--- For T1 PRI scenarios, all 24 T1 timeslots are assigned 
!--- as ISDN PRI channels. The router will now automatically create the 
!--- corresponding D-channel: interface Serial 0:23.

!
controller T1 1
 framing esf
 clock source line secondary 1
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 2
 framing esf
 clock source line secondary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 3
 framing esf
 clock source line secondary
 linecode b8zs
 pri-group timeslots 1-24
!
interface Ethernet0
 ip address 171.68.186.54 255.255.255.240
 no ip directed-broadcast
!
interface Serial0:23

!--- D-channel configuration for T1 0.

 no ip address
 no ip directed-broadcast
 encapsulation ppp
 dialer rotary-group 2


!--- T1 0 is a member of rotary group 2.
!--- The rotary group configuration is in interface Dialer2.
!--- This rotary group command enables the Dialin and Dialout for ISDN calls.



 isdn switch-type primary-5ess

 isdn incoming-voice modem

!--- All incoming ISDN analog modem calls that come in 
!--- on an ISDN PRI receive signaling information 
!--- from the ISDN D channel. The D channel is used for 
!--- circuit-switched data calls and analog modem calls. 
!--- This enables all incoming ISDN voice calls to access the call 
!--- switch module and integrated modems.
!--- Calls are passed to the modem and the call negotiates the 
!--- appropriate connection with the far-end modem. 

 no cdp enable
!
interface Serial1:23
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 dialer rotary-group 2
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 no cdp enable
!
interface Serial2:23
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 dialer rotary-group 2
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 no cdp enable
!
interface Serial3:23
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 dialer rotary-group 2
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 no cdp enable
!
interface FastEthernet0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Group-Async1

!--- This interface is configured for Async Dialin and Dialout in the T1 PRI.
!--- Without this interface, Async calls cannot be made.

 no ip address
 no ip directed-broadcast
 async mode interactive

 dialer in-band
 
dialer rotary-group 1

!--- Group-Async 1 is a member of the rotary group.
!--- The rotary group configuration is in interface Dialer 1.

 no cdp enable

 group-range 1 96

!--- Group-range indicates the asynchronous interfaces 
!--- which come under the Group-Async interface.

!
interface Dialer1
 ip address 10.1.1.1 255.255.255.192
 no ip directed-broadcast
 encapsulation ppp
 dialer in-band

 dialer idle-timeout 600

!--- Set an idle-timeout to hold the ISDN line.
!--- Idle timeout for outgoing calls is 600 seconds (10 minutes).
!--- If the ISDN link is idle for more than 600 seconds, it will be dropped.

 dialer map ip 10.1.1.2 name remoteAsync01 modem-script kelly broadcast 9996200

!--- Dialer map statements for the remote router remoteAsync01.
!--- The name must match the one used by the remote router to identify itself.
!--- Use the modem chat script "kelly" for this connection.

 dialer-group 1

!--- Apply interesting traffic definition from the dialer-list 1.

ppp authentication chap
!
interface Dialer2

!--- The  dialer rotary-group 2 command in Int s0:23 activates the interface
!--- Dialer2 for inbound and outbound ISDN calls.

 ip address 10.1.1.65 255.255.255.192
 no ip directed-broadcast
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 600
 dialer map ip 10.1.1.66 name remoteISDN01 broadcast 9996100
 dialer-group 1
 ppp authentication chap
!
no ip http server
ip classless

ip route 10.1.200.0 255.255.255.0 10.1.1.2

!--- Static route for the 10.1.200.0/24 network. 
!--- Interesting Traffic for that network
!--- will be sent to interface Dialer1 and the router 
!--- will initiate the outbound call for Asynchronous connectivity.

ip route 10.1.201.0 255.255.255.0 10.1.1.66

!--- Static route for the 10.1.201.0/24 network. 
!--- Interesting traffic for that network
!--- will be sent to interface Dialer2 and the router 
!--- will initiate the outbound call for ISDN BRI connectivity.

!
dialer-list 1 protocol ip permit

!--- Interesting traffic is defined by the Protocol IP.
!--- This is applied to interface Dialer1 and Dialer2 using the dialer-group 1 command.
!--- The specified dialer-list number must be the same 
!--- as the dialer-group number; in this example, defined to be "1."

!
line con 0
 transport input none
line 1 96
 
script dialer kelly

!--- Enables the chat script kelly configured globally.

 modem InOut
 transport preferred none
 transport output none
line aux 0
line vty 0 4
 login
!
end

remoteAsync01
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname remoteAsync01
!

!
username AS5300 password 0 xxxx

!
modemcap entry default

!--- A modemcap named "default" will be applied 
!--- to lines one through eight of Async interfaces.

!
interface Ethernet0
 ip address 10.1.200.1 255.255.255.0
 no ip directed-broadcast
!
interface Serial0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Async1
 ip address 10.1.1.2 255.255.255.192
 no ip directed-broadcast
 encapsulation ppp
 dialer idle-timeout 600
 async mode interactive

!--- Enables the slip and ppp EXEC commands.

 ppp authentication chap
!
no ip http server
ip classless

ip route 0.0.0.0 0.0.0.0 10.1.1.1

!--- Default static route for the outgoing packets.

!
line con 0
 transport input none
line 1 8
  login local
  modem InOut
  modem autoconfigure type default

!--- Apply the modemcap "default" (configured globally) to initialize the modem.
!--- Refer to the Modem-Router Connection Guide for more information.

  transport input all
  autoselect during-login  autoselect ppp
  speed 38400
  flowcontrol hardware
line aux 0
line vty 0 4
!
end

remoteISDN01
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname remoteISDN01
!

!
username AS5300 password 0 xxxx

!--- Usernames for local authentication of the call.
!--- The client presents the username/password 
!--- and the AS5300 authenticates the peer.
!--- This local database of usernames and passwords are 
!--- compared when chap PPP authentication is negotiated 
!--- between the AS5300 and remoteISDN01 routers.

!
isdn switch-type basic-5ess

!--- Switch-type for this 2503. Obtain this information from the Telco.
.
!
interface Ethernet0
 ip address 10.1.201.1 255.255.255.0
 no ip directed-broadcast
!
interface Serial0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface BRI0
 ip address 10.1.1.66 255.255.255.192
 no ip directed-broadcast
 encapsulation ppp
 dialer idle-timeout 600
 dialer-group 1
 isdn switch-type basic-5ess
 ppp authentication chap
!
no ip http server
ip classless

ip route 0.0.0.0 0.0.0.0 10.1.1.65

!--- Default static route for the outgoing packets.

!
dialer-list 1 protocol ip permit
!
line con 0
 transport input none
line aux 0
line vty 0 4
!
end

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

  • show isdn status - Garante que o roteador está se comunicando corretamente com o switch ISDN. Na saída, verifique se o status da camada 1 está ATIVO e se o estado de status da camada 2 = MULTIPLE_FRAME_ESTABLISHED é exibido. Esse comando exibe também o número de chamadas ativas.

  • show ppp multilink – Exibe informações em conjuntos multilink que estão ativos. Este comando deve ser utilizado para verificar a conexão multilink.

  • show dialer [interface type number] - Exibe informações de diagnóstico geral para interfaces configuradas para DDR. Se o discador surgir adequadamente, o estado do discador é uma mensagem de camada de link de dados que deve ser exibida. Se uma camada física aparecer, então o protocolo de linha será exibido, mas o Protocolo de controle de rede (NCP), não. Os endereços de origem e destino do pacote que iniciou a discagem são mostrados na linha de razão de discagem. Este comando show mostra a configuração do cronômetro e o tempo antes que a conexão expire.

  • show caller user username detail - Mostra parâmetros para o usuário particular, como endereço IP designado, PPP, parâmetros de pacote PPP, etc. Se sua versão de Cisco IOS Software não apoia este comando, use o comando show user.

  • show dialer map – Exibe os mapas configurados de discador dinâmicos e estáticos. Este comando pode ser utilizado para ver se um mapa de discador dinâmico foi criado. Sem um mapa de discadores, você não pode encaminhar pacotes.

  • mostre o serviço isdn - Para verificar o estado dos canais B. (Este comando é somente para os servidores de acesso que apoiam os controladores PRI/T1.)

  • usuário da mostra - Para indicar os usuários do async/sincronização conectados atualmente.

Abaixo há algumas saídas de comandos show para chamadas bem-sucedidas. Preste atenção às seções em negrito e comentários fornecidos nas saídas. Compare a saída que você obtém com o resultado mostrado abaixo.

A seguinte saída é obtida antes de estabelecer a conexão com o Roteadores remoteISDN01 e remoteAsync01.

AS5300#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     171.68.0.0/28 is subnetted, 1 subnets
C       171.68.186.48 is directly connected, Ethernet0
     10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C       10.1.1.0/26 is directly connected, Dialer1
C       10.1.1.64/26 is directly connected, Dialer2
S       10.1.201.0/24 [1/0] via 10.1.1.66
S       10.1.200.0/24 [1/0] via 10.1.1.2

A seguinte saída é obtida após ter estabelecido a conexão com o Roteadores remoteISDN01 e remoteAsync01.

AS5300#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     171.68.0.0/28 is subnetted, 1 subnets
C       171.68.186.48 is directly connected, Ethernet0
     10.0.0.0/8 is variably subnetted, 6 subnets, 3 masks
C       10.1.1.2/32 is directly connected, Dialer1
C       10.1.1.0/26 is directly connected, Dialer1
C       10.1.1.66/32 is directly connected, Dialer2
C       10.1.1.64/26 is directly connected, Dialer2
S       10.1.201.0/24 [1/0] via 10.1.1.66
S       10.1.200.0/24 [1/0] via 10.1.1.2


AS5300#show ip route connected
     171.68.0.0/28 is subnetted, 1 subnets
C       171.68.186.48 is directly connected, Ethernet0
     10.0.0.0/8 is variably subnetted, 6 subnets, 3 masks
C       10.1.1.2/32 is directly connected, Dialer1
C       10.1.1.0/26 is directly connected, Dialer1
C       10.1.1.66/32 is directly connected, Dialer2
C       10.1.1.64/26 is directly connected, Dialer2


AS5300#show controllers t1 0
T1 0 is up.
  Applique type is Channelized T1
  Cablelength is long gain36 0db
  No alarms detected.
  alarm-trigger is not set
  Version info of slot 0:  HW: 4, PLD Rev: 0

Manufacture Cookie Info:
   EEPROM Type 0x0001, EEPROM Version 0x01, Board ID 0x42,
   Board Hardware Version 1.32, Item Number 800-2540-02,
   Board Revision A0, Serial Number 11493161,
   PLD/ISP Version 0.0, Manufacture Date 12-Dec-1998.
 
Framing is ESF, Line Code is B8ZS, Clock Source is Line Primary.
   Data in current interval (197 seconds elapsed):
   0 Line Code Violations, 0 Path Code Violations
   0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
   0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

!--- Output suppressed.

AS5300#show int s0:23
Serial0:23 is up, line protocol is up (spoofing)
  Hardware is DSX1
  MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, loopback not set
  DTR is pulsed for 1 seconds on reset
  Last input 00:00:06, output 00:00:06, output hang never
  Last clearing of "show interface" counters 11:43:21
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/1/16 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 48 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     5075 packets input, 25767 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     2 input errors, 0 CRC, 1 frame, 0 overrun, 0 ignored, 1 abort
     5073 packets output, 25904 bytes, 0 underruns
     0 output errors, 0 collisions, 13 interface resets
     0 output buffer failures, 0 output buffers swapped out
     2 carrier transitions
  Timeslot(s) Used:24, Transmitter delay is 0 flags


AS5300#show users
    Line       User       	Host(s)              Idle       Location
*  0 con 0                	idle                 00:00:00
  11 tty 11    remoteAsyn   Async interface      00:05:40   PPP: 10.1.1.2

Interface      User        Mode                     Idle     Peer Address
Se0:21       remoteISDN    Sync PPP             00:06:12   PPP: 10.1.1.66

remoteAsync01#show users
    Line       User       Host(s)              Idle       Location
*  0 con 0                idle                 00:00:00
   1 tty 1     AS5300     Async interface      00:07:27   PPP: 10.1.1.1
   2 tty 2                Modem Autoconfigure  00:00:00
   3 tty 3                Modem Autoconfigure  00:00:00
   4 tty 4                Modem Autoconfigure  00:00:01
   5 tty 5                Modem Autoconfigure  00:00:00
   6 tty 6                Modem Autoconfigure  00:00:00
   7 tty 7                Modem Autoconfigure  00:00:00
  Interface      User        Mode                     Idle     Peer Address

remoteISDN01#show users
    Line       User       Host(s)              Idle       Location
*  0 con 0                idle                 00:00:00
  Interface     User        Mode               Idle      Peer Address
  BR0:1        AS5300     Sync PPP             00:09:09   PPP: 10.1.1.65


AS5300#show isdn history
--------------------------------------------------------------------------------
                                ISDN CALL HISTORY
--------------------------------------------------------------------------------
Call History contains all active calls, and a maximum of 100 inactive calls.
Inactive call data will be retained for a maximum of 15 minutes.

--------------------------------------------------------------------------------
Call    Calling      Called       Remote  Seconds Seconds Seconds Charges
Type    Number       Number       Name    Used    Left    Idle    Units/Currency
--------------------------------------------------------------------------------

Out   ---N/A---     9996200  +oteAsync01      187                      0
Out   ---N/A---     9996200  +oteAsync01       56                      0
Out   ---N/A---     9996200  +oteAsync01      469     305     294      0
Out   ---N/A---     9996100  +moteISDN01      105     509      90      0
--------------------------------------------------------------------------------

AS5300#show isdn active
--------------------------------------------------------------------------------
                                ISDN ACTIVE CALLS
--------------------------------------------------------------------------------
Call    Calling      Called       Remote  Seconds Seconds Seconds Charges
Type    Number       Number       Name    Used    Left    Idle    Units/Currency
--------------------------------------------------------------------------------
Out   ---N/A---     9996100  +moteISDN01      152     449     150      0
Out   ---N/A---     9996200  +oteAsync01      133     491     108      0
--------------------------------------------------------------------------------


AS5300#show isdn status
Global ISDN Switchtype = primary-5ess
ISDN Serial0:23 interface
        dsl 0, interface ISDN Switchtype = primary-5ess
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
    Layer 3 Status:
        2 Active Layer 3 Call(s)
        CCB:callid=809E, sapi=0, ces=0, B-chan=23, calltype=VOICE
        CCB:callid=809F, sapi=0, ces=0, B-chan=22, calltype=DATA
    Active dsl 0 CCBs = 2
    The Free Channel Mask:  0x801FFFFF
    Number of L2 Discards = 1, L2 Session ID = 10

!--- Output suppressed.


AS5300#Ping 10.1.201.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.201.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/33/36 ms

AS5300#Ping 10.1.200.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.200.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 128/141/148 ms

AS5300#show isdn service
PRI Channel Statistics:
ISDN Se0:23, Channel [1-24]
  Configured Isdn Interface (dsl) 0
   Channel State (0=Idle 1=Proposed 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)
    Channel :  1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4
    State   :  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 2 2 3
   Service State (0=Inservice 1=Maint 2=Outofservice)
    Channel :  1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4
    State   :  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 2

!--- Output suppressed.


AS5300#show modem
 Codes:
   * - Modem has an active call
   C - Call in setup
   T - Back-to-Back test in progress
   R - Modem is being Reset
   p - Download request is pending and modem cannot be used for taking calls
   D - Download in progress
   B - Modem is marked bad and cannot be used for taking calls
   b - Modem is either busied out or shut-down
   d - DSP software download is required for achieving K56flex connections
   ! - Upgrade request is pending

        Avg Hold     Inc calls     Out calls    Busied   Failed    No     Succ
  Mdm     Time      Succ   Fail   Succ   Fail    Out      Dial   Answer   Pct.
  1/0   00:00:00       0      0      0      0       0        0       0      0%
  1/1   00:00:00       0      0      0      0       0        0       0      0%
  1/2   00:00:00       0      0      0      0       0        0       0      0%
  1/3   00:00:00       0      0      0      0       0        0       0      0%
  1/4   00:00:00       0      0      0      0       0        0       0      0%
  1/5   00:00:00       0      0      0      0       0        0       0      0%
  1/6   00:00:00       0      0      0      0       0        0       0      0%
  1/7   00:00:00       0      0      0      0       0        0       0      0%
  1/8   00:00:00       0      0      0      0       0        0       0      0%
  1/9   00:00:00       0      0      0      0       0        0       0      0%
* 1/10  00:02:21       0      0      5      5       0        0       0     50%
  1/11  00:03:11       0      0     23      6       0        0       0     79%
  1/12  00:00:00       0      0      0      0       0        0       0      0%
  1/13  00:00:00       0      0      0      0       0        0       0      0%
  1/14  00:00:00       0      0      0      0       0        0       0      0%

!--- Output suppressed.

Troubleshooting

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

Troubleshooting de Recursos

Comandos para Troubleshooting

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Nota: Antes de emitir comandos debug, consulte Informações importantes sobre comandos debug.

  • debug dialer - Quando o DDR for permitido na relação, esta informação dos indicadores do comando a respeito da causa de algum atendimento (chamado a causa de discagem).

  • debugar o q931 de ISDN - Para verificar as conexões ISDN como chamadas externas são iniciadas.

  • debugar a negociação ppp - Para ver se um cliente está passando a negociação de PPP. Um alto número de negociações de PPP simultâneas pode oprimir o CPU de roteador.

  • debug ppp authentication - Para ver se um cliente foi aprovado na autenticação. Se você está usando uma versão antes do Cisco IOS Release 11.2, use o comando debug ppp chap pelo contrário.

  • debug ppp error – Para exibir erros do protocolo e estatísticas de erros associados à negociação e operação da conexão PPP

Comandos de Troubleshooting do modem

  • debugar o bate-papo - Para ver chat script a execução do quando um atendimento for iniciado.

  • debug modem – Para ver se um roteador está recebendo os sinais corretos do modem.

  • debug modem csm - Para permitir o Modem Management Call Switching Module (CS) debugar o modo.

Troubleshooting de Saídas

Abaixo há saídas de depuração para uma chamada de saída bem-sucedida. Preste atenção às seções em negrito e comentários fornecidos nas saídas. Compare a saída que você obtém com o resultado mostrado abaixo.

Debugando a conexão dialout do T1 PRI AS5300 ao roteador remoteAsync01

AS5300#debug isdn q931
ISDN Q931 packets debugging is on
AS5300#debug chat
Chat scripts activity debugging is on
AS5300#debug dialer events
Dial on demand events debugging is on
AS5300#show debug
Dial on demand:  
  Dial on demand events debugging is on
PPP:  
  PPP protocol negotiation debugging is on
ISDN:  
  ISDN Q931 packets debugging is on  
  ISDN Q931 packets debug DSLs. (On/Off/No DSL:1/0/-)
  DSL  0 --> 7
  1 1 1 1 - - - -


Chat Scripts:
Chat scripts activity debugging is on


AS5300#ping 10.1.200.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.200.1, timeout is 2 seconds:


Dec 30 17:59:16.675: As12 DDR: rotor dialout [priority]
Dec 30 17:59:16.675: As12 DDR: Dialing cause ip (s=10.1.1.1, d=10.1.200.1)

!--- The dialing cause is a ping for 10.1.200.1.
!--- ICMP is tagged as interesting.

Dec 30 17:59:16.675: As12 DDR: Attempting to dial 9996200
Dec 30 17:59:16.675: CHAT12: Attempting async line dialer script
Dec 30 17:59:16.675: CHAT12: Dialing using Modem script: kelly 
 & System script: none

!--- Uses the Chat script kelly to Dialout.

Dec 30 17:59:16.675: CHAT12: process started
Dec 30 17:59:16.675: CHAT12: Asserting DTR
Dec 30 17:59:16.675: CHAT12: Chat script kelly started
Dec 30 17:59:16.675: CHAT12: Sending string: atdt\T<9996200>

!--- The Chat script kelly uses the Telephone no in Interface Dialer 1 to Dialout.

Dec 30 17:59:16.675: CHAT12: Expecting string: CONNECT
Dec 30 17:59:16.755: ISDN Se0:23: TX -> SETUP pd = 8  callref = 0x00B1

!--- Outgoing ISDN Q.931 SETUP message.

Dec 30 17:59:16.755:         Bearer Capability i = 0x8090A2
Dec 30 17:59:16.755:         Channel ID i = 0xA98397
Dec 30 17:59:16.759:         Called Party Number i = 0xA1, '9996200', Plan:ISDN,
 Type:National
Dec 30 17:59:16.823: ISDN Se0:23: RX <- CALL_PROC pd = 8  callref = 0x80B1
Dec 30 17:59:16.823:         Channel ID i = 0xA98397
Dec 30 17:59:17.023: ISDN Se0:23: RX <- ALERTING pd = 8  callref = 0x80B1.....
Success rate is 0 percent (0/5)
AS5300#
Dec 30 17:59:26.115: ISDN Se0:23: RX <- CONNECT pd = 8  callref = 0x80B1

!--- Received Q.931 CONNECT message.

Dec 30 17:59:26.119: ISDN Se0:23: TX -> CONNECT_ACK pd = 8  callref = 0x00B1
Dec 30 17:59:32.119: %ISDN-6-CONNECT: Interface Serial0:22 is now connected to 
 9996200
Dec 30 17:59:49.347: CHAT12: Completed match for expect: CONNECT
Dec 30 17:59:49.347: CHAT12: Sending string: \c
Dec 30 17:59:49.347: CHAT12: Chat script kelly finished, status = Success
Dec 30 17:59:49.351: Di1 IPCP: Install route to 10.1.1.2

!--- A route to the peer is installed.

Dec 30 17:59:51.351: %LINK-3-UPDOWN: Interface Async12, changed state to up
Dec 30 17:59:51.351: As12 DDR: Dialer statechange to up
Dec 30 17:59:51.351: As12 DDR: Dialer call has been placed
Dec 30 17:59:51.351: As12 PPP: Treating connection as a callout
Dec 30 17:59:51.351: As12 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load]
Dec 30 17:59:51.351: As12 LCP: O CONFREQ [Closed] id 149 len 25
Dec 30 17:59:51.351: As12 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Dec 30 17:59:51.351: As12 LCP:    AuthProto CHAP (0x0305C22305)
Dec 30 17:59:51.351: As12 LCP:    MagicNumber 0x4A997A3A (0x05064A997A3A)
Dec 30 17:59:51.351: As12 LCP:    PFC (0x0702)
Dec 30 17:59:51.351: As12 LCP:    ACFC (0x0802)
Dec 30 17:59:53.351: As12 LCP: TIMEout: State REQsent
Dec 30 17:59:53.351: As12 LCP: O CONFREQ [REQsent] id 150 len 25
Dec 30 17:59:53.351: As12 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Dec 30 17:59:53.351: As12 LCP:    AuthProto CHAP (0x0305C22305)
Dec 30 17:59:53.351: As12 LCP:    MagicNumber 0x4A997A3A (0x05064A997A3A)
Dec 30 17:59:53.351: As12 LCP:    PFC (0x0702)
Dec 30 17:59:53.351: As12 LCP:    ACFC (0x0802)
Dec 30 17:59:53.511: As12 LCP: I CONFREQ [REQsent] id 53 len 25
Dec 30 17:59:53.511: As12 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Dec 30 17:59:53.511: As12 LCP:    AuthProto CHAP (0x0305C22305)
Dec 30 17:59:53.511: As12 LCP:    MagicNumber 0x67B12AE8 (0x050667B12AE8)
Dec 30 17:59:53.511: As12 LCP:    PFC (0x0702)
Dec 30 17:59:53.511: As12 LCP:    ACFC (0x0802)
Dec 30 17:59:53.511: As12 LCP: O CONFACK [REQsent] id 53 len 25
Dec 30 17:59:53.511: As12 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Dec 30 17:59:53.511: As12 LCP:    AuthProto CHAP (0x0305C22305)
Dec 30 17:59:53.511: As12 LCP:    MagicNumber 0x67B12AE8 (0x050667B12AE8)
Dec 30 17:59:53.511: As12 LCP:    PFC (0x0702)
Dec 30 17:59:53.511: As12 LCP:    ACFC (0x0802)
Dec 30 17:59:53.543: As12 LCP: I CONFACK [ACKsent] id 150 len 25
Dec 30 17:59:53.543: As12 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Dec 30 17:59:53.543: As12 LCP:    AuthProto CHAP (0x0305C22305)
Dec 30 17:59:53.543: As12 LCP:    MagicNumber 0x4A997A3A (0x05064A997A3A)
Dec 30 17:59:53.543: As12 LCP:    PFC (0x0702)
Dec 30 17:59:53.543: As12 LCP:    ACFC (0x0802)
Dec 30 17:59:53.543: As12 LCP: State is Open

!--- LCP negotation is complete.

Dec 30 17:59:53.543: As12 PPP: Phase is AUTHENTICATING, by both [0 sess, 1 load]
Dec 30 17:59:53.543: As12 CHAP: O CHALLENGE id 25 len 27 from "AS5300"
Dec 30 17:59:53.655: As12 CHAP: I CHALLENGE id 27 len 34 from "remoteAsync01"
Dec 30 17:59:53.655: As12 CHAP: O RESPONSE id 27 len 27 from "AS5300"
Dec 30 17:59:53.671: As12 CHAP: I RESPONSE id 25 len 34 from "remoteAsync01"
Dec 30 17:59:53.671: As12 CHAP: O SUCCESS id 25 len 4
Dec 30 17:59:53.783: As12 CHAP: I SUCCESS id 27 len 4

!--- Two-way CHAP authentication is successful.

Dec 30 17:59:53.783: As12 PPP: Phase is UP [0 sess, 1 load]
Dec 30 17:59:53.783: As12 IPCP: O CONFREQ [Closed] id 25 len 10
Dec 30 17:59:53.783: As12 IPCP:    Address 10.1.1.1 (0x03060A010101)
Dec 30 17:59:53.783: As12 CDPCP: O CONFREQ [Closed] id 25 len 4
Dec 30 17:59:53.783: As12 IPCP: I CONFREQ [REQsent] id 27 len 10
Dec 30 17:59:53.783: As12 IPCP:    Address 10.1.1.2 (0x03060A010102)
Dec 30 17:59:53.783: As12 IPCP: O CONFACK [REQsent] id 27 len 10
Dec 30 17:59:53.783: As12 IPCP:    Address 10.1.1.2 (0x03060A010102)
Dec 30 17:59:53.911: As12 IPCP: I CONFACK [ACKsent] id 25 len 10
Dec 30 17:59:53.911: As12 IPCP:    Address 10.1.1.1 (0x03060A010101)
Dec 30 17:59:53.911: As12 IPCP: State is Open
Dec 30 17:59:53.911: As12 DDR: dialer protocol up
Dec 30 17:59:53.927: As12 LCP: I PROTREJ [Open] id 54 len 10 protocol CDPCP 
 (0x820701190004)
Dec 30 17:59:53.927: As12 CDPCP: State is Closed
Dec 30 17:59:54.783: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async12, 
 changed state to up
Dec 30 17:59:54.783: As12 PPP: Outbound cdp packet dropped, CDPCP is Closed 
 [starting negotiations]
Dec 30 17:59:54.783: As12 CDPCP: State is Closed
Dec 30 17:59:54.783: As12 PPP: Outbound cdp packet dropped, CDPCP is Closed 
 [starting negotiations]
Dec 30 17:59:54.783: As12 CDPCP: State is Closed
Dec 30 17:59:54.783: As12 PPP: Outbound cdp packet dropped, CDPCP is Closed 
 [starting negotiations]
Dec 30 17:59:54.783: As12 CDPCP: State is Closed
Dec 30 17:59:54.787: As12 CDPCP: TIMEout: State Closed
Dec 30 17:59:54.787: As12 CDPCP: State is Listen


remoteAsync01#debug ppp negotiation
PPP protocol negotiation debugging is on
remoteAsync01#
Dec 30 17:58:54: As1 LCP: I CONFREQ [Closed] id 150 len 25
Dec 30 17:58:54: As1 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Dec 30 17:58:54: As1 LCP:    AuthProto CHAP (0x0305C22305)
Dec 30 17:58:54: As1 LCP:    MagicNumber 0x4A997A3A (0x05064A997A3A)
Dec 30 17:58:54: As1 LCP:    PFC (0x0702)
Dec 30 17:58:54: As1 LCP:    ACFC (0x0802)
Dec 30 17:58:54: As1 LCP: Lower layer not up, Fast Starting
Dec 30 17:58:54: As1 PPP: Treating connection as a dedicated line
Dec 30 17:58:54: As1 PPP: Phase is ESTABLISHING, Active Open [0 sess, 0 load]
Dec 30 17:58:54: As1 LCP: O CONFREQ [Closed] id 53 len 25
Dec 30 17:58:54: As1 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Dec 30 17:58:54: As1 LCP:    AuthProto CHAP (0x0305C22305)
Dec 30 17:58:54: As1 LCP:    MagicNumber 0x67B12AE8 (0x050667B12AE8)
Dec 30 17:58:54: As1 LCP:    PFC (0x0702)
Dec 30 17:58:54: As1 LCP:    ACFC (0x0802)
Dec 30 17:58:54: As1 LCP: O CONFACK [REQsent] id 150 len 25
Dec 30 17:58:54: As1 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Dec 30 17:58:54: As1 LCP:    AuthProto CHAP (0x0305C22305)
Dec 30 17:58:54: As1 LCP:    MagicNumber 0x4A997A3A (0x05064A997A3A)
Dec 30 17:58:54: As1 LCP:    PFC (0x0702)
Dec 30 17:58:54: As1 LCP:    ACFC (0x0802)
Dec 30 17:58:54: %LINK-3-UPDOWN: Interface Async1, changed state to up
Dec 30 17:58:55: As1 LCP: I CONFACK [ACKsent] id 53 len 25
Dec 30 17:58:55: As1 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Dec 30 17:58:55: As1 LCP:    AuthProto CHAP (0x0305C22305)
Dec 30 17:58:55: As1 LCP:    MagicNumber 0x67B12AE8 (0x050667B12AE8)
Dec 30 17:58:55: As1 LCP:    PFC (0x0702)
Dec 30 17:58:55: As1 LCP:    ACFC (0x0802)
Dec 30 17:58:55: As1 LCP: State is Open


!--- LCP negotation is complete.


Dec 30 17:58:55: As1 PPP: Phase is AUTHENTICATING, by both [0 sess, 0 load]
Dec 30 17:58:55: As1 CHAP: O CHALLENGE id 27 len 34 from "remoteAsync01"
Dec 30 17:58:55: As1 CHAP: I CHALLENGE id 25 len 27 from "AS5300"
Dec 30 17:58:55: As1 CHAP: O RESPONSE id 25 len 34 from "remoteAsync01"
Dec 30 17:58:55: As1 CHAP: I RESPONSE id 27 len 27 from "AS5300"
Dec 30 17:58:55: As1 CHAP: I SUCCESS id 25 len 4
Dec 30 17:58:55: As1 CHAP: O SUCCESS id 27 len 4


!--- Two-way CHAP authentication is successful.


Dec 30 17:58:55: As1 PPP: Phase is UP [0 sess, 1 load]
Dec 30 17:58:55: As1 IPCP: O CONFREQ [Closed] id 27 len 10
Dec 30 17:58:55: As1 IPCP:    Address 10.1.1.2 (0x03060A010102)
Dec 30 17:58:55: As1 IPCP: I CONFREQ [REQsent] id 25 len 10
Dec 30 17:58:55: As1 IPCP:    Address 10.1.1.1 (0x03060A010101)
Dec 30 17:58:55: As1 IPCP: O CONFACK [REQsent] id 25 len 10
Dec 30 17:58:55: As1 IPCP:    Address 10.1.1.1 (0x03060A010101)
Dec 30 17:58:55: As1 CDPCP: I CONFREQ [Not negotiated] id 25 len 4
Dec 30 17:58:55: As1 LCP: O PROTREJ [Open] id 54 len 10 protocol CDPCP 
 (0x820701190004)
Dec 30 17:58:55: As1 IPCP: I CONFACK [ACKsent] id 27 len 10
Dec 30 17:58:55: As1 IPCP:    Address 10.1.1.2 (0x03060A010102)
Dec 30 17:58:55: As1 IPCP: State is Open
Dec 30 17:58:55: As1 IPCP: Install route to 10.1.1.1


!--- A route to the peer is installed.

Dec 30 17:58:56: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async1, 
  changedstate to up

Debugando a discagem do AS5300 ao roteador remoteISDN01

AS5300#show debug
Dial on demand:
  Dial on demand events debugging is on
PPP:
  PPP protocol negotiation debugging is on
ISDN:
  ISDN Q931 packets debugging is on
  ISDN Q931 packets debug DSLs. (On/Off/No DSL:1/0/-)
  DSL  0 --> 7
  1 1 1 1 - - - -
Chat Scripts:
  Chat scripts activity debugging is on
AS5300#ping 10.1.201.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.201.1, timeout is 2 seconds:

Dec 30 18:12:42.811: Se0:23 DDR: rotor dialout [priority]
Dec 30 18:12:42.815: Se0:23 DDR: Dialing cause ip (s=10.1.1.65, d=10.1.201.1)

!--- The dialing cause is a ping for 10.1.201.1.
!--- ICMP is tagged as interesting.

Dec 30 18:12:42.815: Se0:23 DDR: Attempting to dial 9996100
Dec 30 18:12:42.815: ISDN Se0:23: TX ->SETUP pd = 8  callref = 0x00B2

!--- Outgoing ISDN Q.931 SETUP message.

Dec 30 18:12:42.815:         Bearer Capability i = 0x8890
Dec 30 18:12:42.815:         Channel ID i = 0xA98396
Dec 30 18:12:42.819:         Called Party Number i = 0xA1, '9996100', Plan:ISDN,
 Type:National
Dec 30 18:12:42.867: ISDN Se0:23: RX <- CALL_PROC pd = 8  callref = 0x80B2
Dec 30 18:12:42.867:         Channel ID i = 0xA98396
Dec 30 18:12:43.127: ISDN Se0:23: RX <- CONNECT pd = 8  callref = 0x80B2

!--- Received Q.931 CONNECT message.

Dec 30 18:12:43.135: %LINK-3-UPDOWN: Interface Serial0:21, changed state to up
Dec 30 18:12:43.135: Se0:21 PPP: Treating connection as a callout
Dec 30 18:12:43.135: Se0:21 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load]
Dec 30 18:12:43.135: Se0:21 LCP: O CONFREQ [Closed] id 25 len 15
Dec 30 18:12:43.139: Se0:21 LCP:    AuthProto CHAP (0x0305C22305)
Dec 30 18:12:43.139: Se0:21 LCP:    MagicNumber 0x4AA54104 (0x05064AA54104)
Dec 30 18:12:43.139: ISDN Se0:23: TX -> CONNECT_ACK pd = 8  callref = 0x00B2
Dec 30 18:12:43.167: Se0:21 LCP: I CONFREQ [REQsent] id 55 len 15
Dec 30 18:12:43.167: Se0:21 LCP:    AuthProto CHAP (0x0305C22305)
Dec 30 18:12:43.167: Se0:21 LCP:    MagicNumber 0x575DC27D (0x0506575DC27D)
Dec 30 18:12:43.167: Se0:21 LCP: O CONFACK [REQsent] id 55 len 15
Dec 30 18:12:43.167: Se0:21 LCP:    AuthProto CHAP (0x0305C22305)
Dec 30 18:12:43.167: Se0:21 LCP:    MagicNumber 0x575DC27D (0x0506575DC27D)
Dec 30 18:12:43.175: Se0:21 LCP: I CONFACK [ACKsent] id 25 len 15
Dec 30 18:12:43.175: Se0:21 LCP:    AuthProto CHAP (0x0305C22305)
Dec 30 18:12:43.175: Se0:21 LCP:    MagicNumber 0x4AA54104 (0x05064AA54104)
Dec 30 18:12:43.179: Se0:21 LCP: State is Open

!--- LCP negotation is complete.

Dec 30 18:12:43.179: Se0:21 PPP: Phase is AUTHENTICATING, by both [0 sess, 1.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 32/33/36 msAS5300# load]
Dec 30 18:12:43.179: Se0:21 CHAP: O CHALLENGE id 13 len 27 from "AS5300"
Dec 30 18:12:43.227: Se0:21 CHAP: I CHALLENGE id 36 len 33 from "remoteISDN01"
Dec 30 18:12:43.227: Se0:21 CHAP: O RESPONSE id 36 len 27 from "AS5300"
Dec 30 18:12:43.251: Se0:21 CHAP: I SUCCESS id 36 len 4
Dec 30 18:12:43.263: Se0:21 CHAP: I RESPONSE id 13 len 33 from "remoteISDN01"
Dec 30 18:12:43.263: Se0:21 CHAP: O SUCCESS id 13 len 4

!--- Two-way CHAP authentication is successful.

Dec 30 18:12:43.263: Se0:21 PPP: Phase is UP [0 sess, 1 load]
Dec 30 18:12:43.263: Se0:21 IPCP: O CONFREQ [Closed] id 13 len 10
Dec 30 18:12:43.267: Se0:21 IPCP:    Address 10.1.1.65 (0x03060A010141)
Dec 30 18:12:43.287: Se0:21 IPCP: I CONFREQ [REQsent] id 36 len 10
Dec 30 18:12:43.287: Se0:21 IPCP:    Address 10.1.1.66 (0x03060A010142)
Dec 30 18:12:43.287: Se0:21 IPCP: O CONFACK [REQsent] id 36 len 10
Dec 30 18:12:43.287: Se0:21 IPCP:    Address 10.1.1.66 (0x03060A010142)
Dec 30 18:12:43.287: Se0:21 CDPCP: I CONFREQ [Not negotiated] id 36 len 4
Dec 30 18:12:43.291: Se0:21 LCP: O PROTREJ [Open] id 26 len 10 protocol CDPCP 
 (0x820701240004)
Dec 30 18:12:43.307: Se0:21 IPCP: I CONFACK [ACKsent] id 13 len 10
Dec 30 18:12:43.307: Se0:21 IPCP:    Address 10.1.1.65 (0x03060A010141)
Dec 30 18:12:43.307: Se0:21 IPCP: State is Open
Dec 30 18:12:43.307: Se0:21 DDR: dialer protocol up
Dec 30 18:12:43.307: Di2 IPCP: Install route to 10.1.1.66

!--- A route to the peer is installed.

Dec 30 18:12:44.263: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0:21,
 changed state to up
Dec 30 18:12:49.135: %ISDN-6-CONNECT: Interface Serial0:21 is now connected to
 9996100 remoteISDN01

remoteISDN01#debug ppp negotiation
PPP protocol negotiation debugging is on
remoteISDN01#debug isdn q931
ISDN Q931 packets debugging is on
remoteISDN01#show debug
PPP:
  PPP protocol negotiation debugging is on
ISDN:
  ISDN Q931 packets debugging is on
remoteISDN01#
Dec 30 18:13:04: ISDN BR0: RX <- SETUP pd = 8  callref = 0x1B
Dec 30 18:13:04:         Bearer Capability i = 0x8890
Dec 30 18:13:04:         Channel ID i = 0x89
Dec 30 18:13:04:         Signal i = 0x40 - Alerting on - pattern 0
Dec 30 18:13:04:         Called Party Number i = 0xA1, '2019996100', Plan:ISDN,
 Type:National
Dec 30 18:13:04: ISDN BR0: Event: Received a DATA call from <unknown> on B1 at 
 64 Kb/s
Dec 30 18:13:04: ISDN BR0: Event: Accepting the call id 0x2D
Dec 30 18:13:04: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
Dec 30 18:13:04: BR0:1 PPP: Treating connection as a callin
Dec 30 18:13:04: BR0:1 PPP: Phase is ESTABLISHING, Passive Open [0 sess, 1 load]
Dec 30 18:13:04: BR0:1 LCP: State is Listen
Dec 30 18:13:04: ISDN BR0: TX -> CALL_PROC pd = 8  callref = 0x9B

!--- Outgoing ISDN Q.931 SETUP message.

Dec 30 18:13:04:         Channel ID i = 0x89
Dec 30 18:13:04: ISDN BR0: TX -> CONNECT pd = 8  callref = 0x9B
Dec 30 18:13:05: BR0:1 LCP: I CONFREQ [Listen] id 25 len 15
Dec 30 18:13:05: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
Dec 30 18:13:05: BR0:1 LCP:    MagicNumber 0x4AA54104 (0x05064AA54104)
Dec 30 18:13:05: BR0:1 LCP: O CONFREQ [Listen] id 55 len 15
Dec 30 18:13:05: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
Dec 30 18:13:05: BR0:1 LCP:    MagicNumber 0x575DC27D (0x0506575DC27D)
Dec 30 18:13:05: BR0:1 LCP: O CONFACK [Listen] id 25 len 15
Dec 30 18:13:05: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
Dec 30 18:13:05: BR0:1 LCP:    MagicNumber 0x4AA54104 (0x05064AA54104)
Dec 30 18:13:05: ISDN BR0: RX <- CONNECT_ACK pd = 8  callref = 0x1B

!--- Received Q.931 CONNECT message.

Dec 30 18:13:05:         Signal i = 0x4F - Alerting off
Dec 30 18:13:05: BR0:1 LCP: I CONFACK [ACKsent] id 55 len 15
Dec 30 18:13:05: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
Dec 30 18:13:05: BR0:1 LCP:    MagicNumber 0x575DC27D (0x0506575DC27D)
Dec 30 18:13:05: BR0:1 LCP: State is Open
Dec 30 18:13:05: BR0:1 PPP: Phase is AUTHENTICATING, by both [0 sess, 1 load]
Dec 30 18:13:05: BR0:1 CHAP: O CHALLENGE id 36 len 33 from "remoteISDN01"
Dec 30 18:13:05: BR0:1 CHAP: I CHALLENGE id 13 len 27 from "AS5300"
Dec 30 18:13:05: BR0:1 CHAP: Waiting for peer to authenticate first
Dec 30 18:13:05: BR0:1 CHAP: I RESPONSE id 36 len 27 from "AS5300"
Dec 30 18:13:05: BR0:1 CHAP: O SUCCESS id 36 len 4
Dec 30 18:13:05: BR0:1 CHAP: Processing saved Challenge, id 13
Dec 30 18:13:05: BR0:1 CHAP: O RESPONSE id 13 len 33 from "remoteISDN01"
Dec 30 18:13:05: BR0:1 CHAP: I SUCCESS id 13 len 4

!--- Two-way CHAP authentication is successful.

Dec 30 18:13:05: BR0:1 PPP: Phase is UP [0 sess, 0 load]
Dec 30 18:13:05: BR0:1 IPCP: O CONFREQ [Closed] id 36 len 10
Dec 30 18:13:05: BR0:1 IPCP:    Address 10.1.1.66 (0x03060A010142)
Dec 30 18:13:05: BR0:1 CDPCP: O CONFREQ [Closed] id 36 len 4
Dec 30 18:13:05: BR0:1 IPCP: I CONFREQ [REQsent] id 13 len 10
Dec 30 18:13:05: BR0:1 IPCP:    Address 10.1.1.65 (0x03060A010141)
Dec 30 18:13:05: BR0:1 IPCP: O CONFACK [REQsent] id 13 len 10
Dec 30 18:13:05: BR0:1 IPCP:    Address 10.1.1.65 (0x03060A010141)
Dec 30 18:13:05: BR0:1 IPCP: I CONFACK [ACKsent] id 36 len 10
Dec 30 18:13:05: BR0:1 IPCP:    Address 10.1.1.66 (0x03060A010142)
Dec 30 18:13:05: BR0:1 IPCP: State is Open
Dec 30 18:13:05: BR0:1 LCP: I PROTREJ [Open] id 26 len 10 protocol CDPCP 
 (0x8207 01240004)
Dec 30 18:13:05: BR0:1 CDPCP: State is Closed
Dec 30 18:13:05: BR0 IPCP: Install route to 10.1.1.65

!--- A route to the peer is installed.

Dec 30 18:13:06: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
 changed state to up
Dec 30 18:13:06: BR0:1 PPP: Outbound cdp packet dropped, CDPCP is Closed
 [starting negotiations]
Dec 30 18:13:06: BR0:1 CDPCP: State is Closed
Dec 30 18:13:06: BR0:1 PPP: Outbound cdp packet dropped, CDPCP is Closed
 [starting negotiations]
Dec 30 18:13:06: BR0:1 CDPCP: State is Closed
Dec 30 18:13:06: BR0:1 PPP: Outbound cdp packet dropped, CDPCP is Closed
 [starting negotiations]
Dec 30 18:13:06: BR0:1 CDPCP: State is Closed
Dec 30 18:13:06: BR0:1 CDPCP: TIMEout: State Closed
Dec 30 18:13:06: BR0:1 CDPCP: State is Listen
Dec 30 18:13:10: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to AS5300

Informações Relacionadas


Document ID: 14960