Óptica : Automatic Protection Switching (APS )

Configurando a Redundância para POS/APS

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento discute a característica do Automatic Protection Switching (APS) e fornece um exemplo de como configurar o APS para a Redundância do Pacote sobre SONET (POS).

Este documento permite-o de compreender como o APS trabalha, e ajuda-o a configurar e manter o APS em roteadores Cisco. A topologia de rede em figura 1 é a base deste documento:

Figura 1 – Topologia de rede

pos-aps_14680-a.gif

Pré-requisitos

Requisitos

A Cisco recomenda que você tenha conhecimento destes tópicos:

  • Synchronous Optical NETwork (SONET) e tecnologias POS.

  • Princípios da configuração de roteador Cisco.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Software Release 12.0(10)S de Cisco IOS�.

  • Plataformas de hardware do Cisco 12000 Series.

O apoio para a característica APS está disponível nas plataformas de hardware do Cisco e Series, e no Cisco IOS Software Release 12.2(5) e Mais Recente.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Switching de proteção automática

O recurso APS fornece redundância e permite um switchover de circuitos POS no caso de uma falha de circuito. A aplicação do APS permite que você configure um par de linhas SONET para a linha Redundância. Quando o trabalho (W) a relação falha, a proteção (P) a relação supõe rapidamente a carga de tráfego. No caso de um corte de fibra ótica, a linha ativa comuta automaticamente à linha em standby dentro de 60 milissegundos (iniciação de milissegundo 10 e switchover de 50 milissegundos). O SONET APS executa switchovers no Layer 1 (L1). Consequentemente, o switchover é significativamente mais rápido do que na camada 2 (L2) ou na camada 3 (L3).

O mecanismo de proteção que esta característica usa tem a arquitetura 1+1, como descrito na publicação bellcore TR-TSY-000253, sistemas de transporte SONET, criações genéricas comuns, a seção 5.3. O SONET APS segue com o GR-253 e o ITU-T G.783. Consequentemente, o SONET APS permite que os roteadores Cisco integrem continuamente com SONET adiciona/Multiplexers da gota (ADM). Esta característica permite a configuração de um ou outro switching bidirecional ou unidirecional, mas o switching não-reversível bidirecional é o padrão.

Na arquitetura APS 1+1, cada par de linhas redundantes consiste em uma relação W e em uma relação P. As interfaces W e P estão conectadas a um SONET ADM, que envia o mesmo payload de sinal para as interfaces W e P. Os circuitos W e P podem terminar em duas portas do mesmo adaptador, placa de linha, ou em dois Roteadores diferentes. Quando uma condição da falha de sinal (SF) ou uma condição da redução de sinal (SD) ocorrem, os switch de hardware do W alinham à linha P. Há uma opção reversa. Após detecção de uma condição do SF, os switch de hardware de volta ao W alinham automaticamente após o reparo da linha W, e a passagem de um período configurado. O protocolo protect group da em-faixa (PGP) consegue a coordenação entre a linha W e a linha P. Na opção não-reversível, se uma condição do SF ocorre, os switch de hardware à linha P e não revertem automaticamente à linha W.

No circuito P, os bytes K1/K2 da Linha suspensa (LOH) do quadro SONET indicam o status atual da conexão APS e transmitem qualquer solicitação de ação. As duas extremidades da conexão usam este canal de sinalização para manter a sincronização. O W e o P circuitam-se, dentro do roteador ou do Roteadores em que termina, é sincronizado sobre um canal de comunicação independente (que usa APS PGP), isolado dos circuitos W e P. Este canal independente pode ser uma conexão SONET diferente, Ethernet, ou uma conexão de largura de banda inferior. Em um roteador configurado para o APS, a configuração para a relação P inclui o endereço IP de Um ou Mais Servidores Cisco ICM NT do roteador (normalmente e recomendado ser o endereço de loopback) que tem a relação W.

O APS PGP, que é executado sobre o User Datagram Protocol (UDP), fornece uma comunicação entre o processo que controla a relação W e o processo que controla a relação P. O processo que controla o circuito P usa este protocolo para dirigir o processo que contém o circuito W, sobre se ativar ou desativar o circuito W, no caso da degradação, da perda de sinal do canal, ou da intervenção manual. Se os dois processos perdem uma comunicação um com o otro, o roteador W supõe o controle total do circuito W como se nenhum circuito P existiu.

APS e comandos relacionados

Estão aqui os disparadores APS categorizados hierarquicamente (da mais baixa prioridade à prioridade mais alta):

  • Manual Switch Request.

  • Condição SD (taxa de erros de bits (BER) que excede o ponto inicial SD).

  • Condição do SF (perda do frame (LOF), perda de sinal (LOS), Sinal-linha da indicação de alarme (AIS-L), e uma linha BER que exceda 10-3/or USER-provisionable).

  • Solicitação de Switch Forçada.

Estão aqui as opções de IOS configurar o APS:

GSR(config-if)# aps ?
authentication  Authentication string 
force           Force channel 
group           Group association 
lockout         Lockout protection channel 
manual          Manually switch channel 
protect         Protect specified circuit 
reflector       Configure for reflector mode APS 
revert          Specify revert operation and interval 
signaling      Specify SONET/SDH K1K2 signaling 
timers          APS timers 
unidirectional  Configure for unidirectional mode 
working         Working channel number 

Além do que os comandos ios novos para a característica APS, os comandos pos interface configuration pós-limite e o relatório POS foram adicionados para apoiar a configuração do usuário dos limiares de BER e do relatório dos alarmes SONET. Está aqui um exemplo de saída:

GSR(config-if)# POS threshold ? 
  b1-tca  B1 BER threshold crossing alarm 
  b2-tca  B2 BER threshold crossing alarm 
  b3-tca  B3 BER threshold crossing alarm 
  sd-ber  set Signal Degrade BER threshold 
  sf-ber  set Signal Fail BER threshold 

GSR(config-if)# POS report ?
  all     all Alarms/Signals 
  b1-tca  B1 BER threshold crossing alarm 
  b2-tca  B2 BER threshold crossing alarm 
  b3-tca  B3 BER threshold crossing alarm 
  lais    Line Alarm Indication Signal 
  lrdi    Line Remote Defect Indication 
  pais    Path Alarm Indication Signal 
  plop    Path Loss of Pointer 
  prdi    Path Remote Defect Indication 
  rdool   Receive Data Out Of Lock 
  sd-ber  LBIP BER in excess of SD threshold 
  sf-ber  LBIP BER in excess of SF threshold 
  slof    Section Loss of Frame 
  slos    Section Loss of Signal 

Modos de switching

No modo bidirecional, os canais de Recebimento (Rx) e Transmissão (Tx) são comutados como um par. No modo unidirecional, os canais de Tx e RX são comutados independentemente. Por exemplo, no modo bidirecional, se o canal RX na relação W tem uma perda de sinal do canal, os canais RX e de Tx são comutados.

Modo bidirecional (recomendado)

O roteador W reconhece a falha e notifica o roteador P (com o PGP de interconexão local). O roteador P instrui o roteador W deselect a relação W (com o PGP de interconexão local). As requisições de roteador P o ADM comutar Tx e RX a P (através dos bytes K1/K2 na relação P que vai ao ADM). O roteador P seleciona a relação P e o ADM segue com a requisição de switch e sinaliza a conformidade (através dos bytes K1/K2 no ADM à fibra da relação P).

Modo unidirecional

Quando há um alarme LOS/LOF (falha) no W RX, o roteador W reconhece a falha e notifica o roteador P (com o PGP de interconexão local). O roteador P instrui o roteador W deselect a relação W (com o PGP de interconexão local). O roteador W afirma um Line Alarm Indication Signal (LAIS) para enquanto a relação W deselected para forçar o ADM para comutar o RX à relação P. As requisições de roteador P o ADM comutar à relação P (através dos bytes K1/K2 na relação P à fibra de ADM). O roteador P seleciona a relação P e o ADM segue com a requisição de switch.

No modo unidirecional, o roteador força o ADM para comutar. A fim fazer assim, o roteador afirma o LAIS (persistentemente, se em W; momentaneamente, se em P). Consequentemente, o unidirecional que você vê é bastante real, que o modo unidirecional segue com o GR-253. Contudo, o que o unidirecional igualmente faz é, para forçar um segundo interruptor unidirecional, que faça o interruptor parecer ser bidirecional. Este é o resultado das restrições que são profundamente embutidas em mecanismos de roteamento (IP), os quais assumem, em todos os níveis, que o tráfego deve ter Rx e Tx na mesma interface. Em resumo, o roteador segue com os protocolos unidirecional no GR-253, mas força o interruptor em um modelo que apoie o IP. Daqui, o roteador não apoia Tx e RX em pares de fibra diferentes.

Nota: Um desvio principal do Cisco 12000 Series do GR-253 é que o Cisco 12000 Series não constrói uma ponte sobre transmite a W e a P, mas mantém uma relação ativa em um momento.

Cenários básicos

A interface de trabalho para fibra ADM falha

O ADM vê a falha de fibra e envia a REQUISIÇÃO DE SWITCH do SF ao roteador P (através dos bytes K1/K2 na fibra da relação P), e pede um interruptor à relação P. O roteador P instrui o roteador W deselect (para desativar) a relação W (através da interconexão local). O roteador P seleciona (ativa) a interface P. O roteador P informa o ADM da conformidade com a requisição de switch (através dos bytes K1/K2 na fibra de ADM da relação P).

Falha do ADM para Working Interface Fiber (modo bidirecional)

O roteador W reconhece a falha e notifica o roteador P (através da interconexão local). O roteador P instrui o roteador W deselect a relação W (através da interconexão local). As requisições de roteador ADM P comutar Tx e RX a P (através dos bytes K1/K2 na relação P à fibra de ADM). O roteador P seleciona a relação P e o ADM segue com as requisições de switch e sinaliza a conformidade (através dos bytes K1/K2 no ADM à fibra da relação P).

Falha de ADM para fibras de interface de trabalho (modo unidirecional)

O roteador W reconhece a falha e notifica o roteador P (através da interconexão local). O roteador P instrui o roteador W deselect a relação W (através da interconexão local). O roteador W afirma um LAIS para que a Senhora 100 force o ADM para comutar o RX à relação P. As requisições de roteador ADM P comutar à relação P (através dos bytes K1/K2 na relação P à fibra de ADM). O roteador P seleciona a relação P e o ADM segue com a requisição de switch.

Falha das fibras de transmissão e recepção entre a interface de trabalho e os enlaces ADM

Ambas as sequências começam. Se o roteador P inicia primeiramente o interruptor a P, ou o ADM inicia o interruptor não importa, porque o resultado é o mesmo.

os roteadores Cisco POS-equipados atuam como o equipamento de terminal (TE) para a seção da hierarquia digital SONET/Synchronous (SDH), a linha, e os segmentos do trajeto de um link, e podem detectar e relatar estes erros e alarmes SONET/SDH:

  • Seção: Alarmes de Cruzamento de Limiar (TCA), LOS e LOF (B1)

  • Linha: AIS (linha e caminho), Remote Defect Indication (RDI) (linha e caminho), Remote Error Indication (REI), TCA (B2)

  • Caminho: Eventos de novo ponteiro (NEWPTR), Evento de preenchimento positivo (PSE), Evento de preenchimento negativo (NSE)

A outra informação relatada inclui:

  • SF-ber

  • SD-ber

  • Rótulo de sinal C2 (construção de payload)

  • J1 - byte de rastreamento de caminho

B1, B2 e B3 são categorizados como parâmetros de desempenho-monitoramento, enquanto outros como LOS, LOF e LAIS estão incluídos em alarmes. O monitoramento de desempenho pertence aos alertas avançados, ao passo que os alarmes indicam falhas. O status do byte K1/K2 também é informado para o SONET APS ou para o Multiservice Switching Path (MSP) do SDH.

Bytes K1/K2

Quando você discute o APS, você precisa primeiramente de compreender como o SONET usa os bytes K1/K2 no LOH.

Cada Sinal de Transporte Síncrono-1 (STS-1) consiste em 810 bytes, que incluem 27 bytes para Sobrecarga de Transporte (TOH) e 783 bytes para Envelope de Payload Síncrono (SPE). A tabela 1 ilustra o formato de um quadro STS-1 e as fileiras 9 por 90 colunas.

Tabela 1 – Formato de um quadro STS-1

Caminho suspenso
Seção adicional Enquadramento A1 Enquadramento A2 Enquadramento A3 Caminho J1
B1 BIP-8 Orderwire E1 Usuário E1 B3 BIP-8
D1 Data Com D2 Data Com D3 Data Com Rótulo de sinal C2
Linha suspensa Ponteiro H1 Ponteiro H2 Ação do ponteiro H3 Status do caminho G1
B2 BIP-8 K1 K2 Canal do usuário F2
D4 Data Com D5 Data Com Com Dados D6 Indicador H4
D7 Data Com D8 Data Com D9 Data Com Crescimento de Z3
D10 Data Com D11 Data Com D12 Data Com Crescimento de Z4
Status/crescimento de sincr. S1/Z1 Crescimento de M0 ou M1/Z2 REI-L Orderwire E2 Conexão em tandem Z5

Os bytes K1/K2 de um campo de 16 bits. A tabela 2 alista o uso de cada bit.

Tabela 2 – Descrições do bit do K1

Bits (hex) Descrição
Bits K1 12345678
Bit 5 com 8
NNNN Número do canal associado ao código de comando.
Bit 1 a 4
1111 (0xF) Pedido do travamento de proteção.
1110 (0xE) Solicitação de Switch Forçada.
1101 (0xD) SF - solicitação de alta prioridade.
1100 (0xC) SF - requisição de baixa prioridade
1011 (0xB) SD - requisição de alta prioridade.
1010 (0xA) SD - solicitação de baixa prioridade.
1001 (0x9) Não utilizado.
1000 (0x8) Manual Switch Request.
0111 (0x7) Não utilizado.
0110 (0x6) Espera para restaurar o pedido.
0101 (0x5) Não utilizado.
0100 (0x4) Pedido do exercício.
0011 (0x3) Não utilizado.
0010 (0x2) Reverta a solicitação.
0001 (0x1) Não inverta a requisição.
0000 (0x0) Nenhuma solicitação.

Nota: 1 mordido é o bit de ordem baixa.

Tabela 3 – Descrições de bits K2

Bits Descrição
K2 bit 12345678  
Bit 1 a 4  
NNNN Número do canal associado ao código de comando.
Bit 5  
1 Uma para n (1:n) arquitetura(s).
0 Arquitetura um mais um (1 + 1).
Bit 6 com 8  
111 AIS de linha.
110 RDI da linha.
101 Modo de operação bidirecional.
100 Modo de operação unidirecional.
Outros Reservado.

Nota: Em K2 (12345678):

  • K2[1-4] – Atualmente número de canal interligado.

  • K2[5] – Arquitetura (sempre 0 para 1+1).

  • K2[6-8] – Modo de operação provisionado (4 = unidir; 5 = bidir).

  • K2[6-8] – Igualmente leva o código 6=LRDI e 7=LAIS do alarme.

Nota: No SDH, K2[6-8] leva somente os códigos do alarme. O modo operacional não foi enviado.

Nota: Por exemplo, que são os valores para o K1 e o K2 correspondente no W se o roteador recebe um SF? No lado P?

Nota:  Resposta: Somente o P transmite e lê o K1/K2, nunca o W. No modo bidirecional, se o W recebe um SF, e em nenhum pedido mais alto cancelar-lo, o código de P ao ADM é:

K1= 0xC1 (switch request, SF on 1=working, low priority) 
K2 = 0x05 (protect bridged [working bridge is incomplete];bidirectional)

Nota: Após a resposta de ADM:

K1 = 0x21 (Reverse request, channel 1) 
K2 = 0x15 (Working bridged; bidirectional)

Nota: O txk1k2 do roteador da proteção será:

K1=0xC1 (switch request, SF on 1=working, low priority) 
K2 = 0x15 (working bridged; bidirectional) 

Nota: Nesse ponto, o switch está completa.

Configurar o APS

Figura 2 mostra uma configuração básica APS 1+1 de um GSR a um ADM (ONS15454) no modo bidirecional, não-reversível (padrão no Cisco 12000 Series). O APS é comutada Linear, e é feito no nível de linha (entre o Cisco 12000 Series e o ADM contra o trajeto ou fim-a-fim).

Nota: Este exemplo não tem um canal independente para o PGP porque as relações W e P estão no mesmo roteador.

Figura 2 – Uma configuração básica APS 1+1

pos-aps_14680-a.gif

gsrA# show running-config
! 
interface Loopback0 
ip address 100.1.1.1 255.255.255.0 
no ip directed-broadcast 
! 
interface POS1/0 
ip address 10.1.1.1 255.255.255.0 
no ip directed-broadcast 
crc 16 
aps group 10 
aps working 1 
! 
interface POS1/1 
ip address 10.1.1.3 255.255.255.0 
no ip directed-broadcast 
no keepalive 
crc 16 
aps group 10 
aps revert 1 
aps protect 1 100.1.1.1
! 
router ospf 100 
network 10.1.1.0 0.0.0.255 area 0 
network 100.1.1.0 0.0.0.255 area 0 

gsrB#show running-config 
! 
interface Loopback0 
ip address 200.1.1.1 255.255.255.0 
! 
interface POS3/0
ip address 10.1.1.2 255.255.255.0 
no ip directed-broadcast 
crc 16 
aps group 10 
aps working 1 
! 
interface POS3/1 
ip address 10.1.1.4 255.255.255.0 
no ip directed-broadcast 
no keepalive 
crc 16 
aps group 10 
aps revert 1 
aps protect 1 200.1.1.1 
! 
router ospf 100 
network 10.1.1.0 0.0.0.255 area 0 
network 200.1.1.0 0.0.0.255 area 0 
! 

Monitore e mantenha o APS

A fim fornecer a informação sobre processos do sistema, o IOS Software inclui uma lista extensa dos comandos exec que começam com a mostra da palavra. Quando você executa estes comandos show, as tabelas detalhadas da informação de sistema aparecem. Está aqui uma lista de alguns dos comandos show comuns para a característica APS, junto com exemplos de saída:

  • show aps

  • show controllers POS

  • mostre a relação POS

! 
gsrA# show aps
POS1/1 APS Group 10: protect channel 0 (inactive) 
bidirectional, revertive (1 min) 
SONET framing; SONET APS signaling by default 
Received K1K2: 0x20 0x05 
Reverse Request (protect) 
Transmitted K1K2: 0xE0 0x05 
Forced Switch (protect) 
Working channel 1 at 100.1.1.1 (Enabled) 
Pending local request(s): 
0x0E (No Request, channel(s) 0 1) 
Remote APS configuration: working 
POS1/0 APS Group 10: working channel 1 (active) 

!--- Verify whether the working channel is active.

SONET framing; SONET APS signaling by default 
Protect at 100.1.1.1 
Remote APS configuration: working 

gsrA# show controllers POS 1/0
POS1/0 
SECTION 
LOF = 0          LOS    = 0                            BIP(B1) = 0 
LINE 
AIS = 0          RDI    = 0          FEBE = 0          BIP(B2) = 0 
PATH 
AIS = 0          RDI    = 0          FEBE = 0          BIP(B3) = 0 
LOP = 0          NEWPTR = 0          PSE  = 0          NSE     = 0 
Active Defects: None 
Active Alarms:  None 
Alarm reporting enabled for: SF SLOS SLOF B1-TCA B2-TCA PLOP B3-TCA 
Framing: SONET 
APS 
working (active) 

!--- Ensure that the working channel is active.

COAPS = 0          PSBF = 0 
State: PSBF_state = False 
ais_shut = FALSE 
Rx(K1/K2): 00/00  S1S0 = 00, C2 = CF 
Remote aps status working; Reflected local aps status working 
CLOCK RECOVERY 
RDOOL = 0 
State: RDOOL_state = False 
PATH TRACE BUFFER : STABLE 
Remote hostname : 12012 
Remote interface: POS3/0 
Remote IP addr  : 10.1.1.2 
Remote Rx(K1/K2): 00/00  Tx(K1/K2): 00/00    
BER thresholds:  SF = 10e-3  SD = 10e-6 
TCA thresholds:  B1 = 10e-6  B2 = 10e-6  B3 = 10e-6 
! 
gsrA# show controllers POS 1/1 
POS1/1 
SECTION 
LOF = 0          LOS    = 0                            BIP(B1) = 0 
LINE 
AIS = 0          RDI    = 0          FEBE = 0          BIP(B2) = 0 
PATH 
AIS = 0          RDI    = 0          FEBE = 0          BIP(B3) = 0 
LOP = 0          NEWPTR = 0          PSE  = 0          NSE     = 0 
Active Defects: None 
Active Alarms:  None 
Alarm reporting enabled for: SF SLOS SLOF B1-TCA B2-TCA PLOP B3-TCA 
Framing: SONET 
APS 
protect (inactive) 
COAPS = 0          PSBF = 0 
State: PSBF_state = False 
ais_shut = FALSE 
Rx(K1/K2): 20/05 Tx(K1/K2): E0/05    
Signalling protocol: SONET APS by default 
S1S0 = 00, C2 = CF 
Remote aps status working; Reflected local aps status working 
CLOCK RECOVERY 
RDOOL = 0 
State: RDOOL_state = False 
PATH TRACE BUFFER : STABLE 
Remote hostname : 12012 
Remote interface: POS3/0 
Remote IP addr  : 10.1.1.2 
Remote Rx(K1/K2): 00/00  Tx(K1/K2): 00/00 
BER thresholds:  SF = 10e-3  SD = 10e-6 
TCA thresholds:  B1 = 10e-6  B2 = 10e-6  B3 = 10e-6 
! 
gsrA# show interface p1/0 
POS1/0 is up, line protocol is up  (APS working - active) 

!--- Verify whether the working channel is active.

gsrA# show interface p1/1 
POS1/1 is up, line protocol is down  (APS protect - inactive) 

! 
gsrB# show aps
POS3/1 APS Group 10: protect channel 0 (inactive) 
bidirectional, revertive (1 min) 
SONET framing; SONET APS signaling by default 
Received K1K2: 0x00 0x05 
No Request (Null) 
Transmitted K1K2: 0x00 0x05 
No Request (Null) 
Working channel 1 at 200.1.1.1 (Enabled) 
Remote APS configuration: working 
POS3/0 APS Group 10: working channel 1 (active) 

!--- Verify whether the working channel is active.

SONET framing; SONET APS signaling by default 
Protect at 200.1.1.1 
Remote APS configuration: working 
! 
gsrB# show controllers p 3/0
POS3/0 
SECTION 
LOF = 11         LOS    = 11                           BIP(B1) = 
46701837 
LINE 
AIS = 10         RDI    = 11         FEBE = 1873       BIP(B2) = 8662 
PATH 
AIS = 14         RDI    = 27         FEBE = 460909     BIP(B3) = 
516875 
LOP = 0          NEWPTR = 11637      PSE  = 2          NSE     = 16818 
Active Defects: None 
Active Alarms:  None 
Alarm reporting enabled for: SF SLOS SLOF B1-TCA B2-TCA PLOP B3-TCA 
Framing: SONET 
APS 
working (active)

!--- Verify whether the working channel is active.

COAPS = 103        PSBF = 0 
State: PSBF_state = False 
ais_shut = FALSE 
Rx(K1/K2): 00/00  S1S0 = 00, C2 = CF 
Remote aps status working; Reflected local aps status working 
CLOCK RECOVERY 
RDOOL = 11 
State: RDOOL_state = False 
PATH TRACE BUFFER : STABLE 
Remote hostname : hswan-gsr12008-2b 
Remote interface: POS1/0 
Remote IP addr  : 10.1.1.1 
Remote Rx(K1/K2): 00/00  Tx(K1/K2): 00/00 
BER thresholds:  SF = 10e-3  SD = 10e-6 
TCA thresholds:  B1 = 10e-6  B2 = 10e-6  B3 = 10e-6 
! 
gsrB# show controllers p 3/1 
POS3/1 
SECTION 
LOF = 10         LOS    = 10                           BIP(B1) = 
250005115 
LINE 
AIS = 11         RDI    = 8          FEBE = 517        BIP(B2) = 5016 
PATH 
AIS = 14         RDI    = 25         FEBE = 3663       BIP(B3) = 7164 
LOP = 0          NEWPTR = 184        PSE  = 1          NSE     = 247 
Active Defects: None 
Active Alarms:  None 
Alarm reporting enabled for: SF SLOS SLOF B1-TCA B2-TCA PLOP B3-TCA 
Framing: SONET 
APS 
protect (inactive) 
COAPS = 538        PSBF = 0 
State: PSBF_state = False 
ais_shut = FALSE 
Rx(K1/K2): 00/05 Tx(K1/K2): 00/05 
Signalling protocol: SONET APS by default 
S1S0 = 00, C2 = CF 
Remote aps status working; Reflected local aps status working 
CLOCK RECOVERY 
RDOOL = 10 
State: RDOOL_state = False 
PATH TRACE BUFFER : STABLE 
Remote hostname : hswan-gsr12008-2b 
Remote interface: POS1/0 
Remote IP addr  : 10.1.1.1 
Remote Rx(K1/K2): 00/00  Tx(K1/K2): 00/00 
BER thresholds:  SF = 10e-3  SD = 10e-6 
TCA thresholds:  B1 = 10e-6  B2 = 10e-6  B3 = 10e-6 
! 
gsrB#show interface p3/0 
POS3/0 is up, line protocol is up  (APS working - active) 

!--- Verify whether the working channel is active.

gsrB#show interface p3/1 
POS3/1 is up, line protocol is down  (APS protect - inactive) 
! 

Pesquise defeitos o APS

A fim pesquisar defeitos problemas com APS, recolha a saída destes comandos show and debug:

  • show ver

  • show run

  • show ip int b

  • show contr POS

  • debug aps

  • show aps

Execute as ações necessárias recrear o problema. Emita estes comandos recolher a saída final e desligar debugar:

  • show aps

  • no debug aps

Nota: Em condições normais, o comando debug aps não produz nenhuma saída. Quando uma condição anormal ocorrer, este comandos relatório a circunstância.

Nota: Se as fibras W e P estão no Roteadores diferente (enquanto são geralmente), você deve recolher as saídas do comando em ambo o Roteadores.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 14680