Discar e acessar : Dial-on-Demand Routing (DDR)

Atribua as informações de IP (IP Address, máscara de sub-rede e gateway padrão) para a VLAN de gerenciamento (o padrão é VLAN 1), para que o switch possa ser gerenciado por um PC que esteja utilizando TCP/IP.

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Em determinadas situações, você precisaria de configurar um roteador para discar sites múltiplo. Por exemplo, você pode tem que disca um roteador para conectar parte da sua rede corporativa, e disca o roteador de provedor de serviço do Internet (ISP) para conectar ao Internet.

Este documento apresenta um exemplo de configuração em que um roteador central alcança o Internet, e um Integrated Services Digital Network dos usos do escritório remoto (ISDN). O escritório remoto pode igualmente alcançar o roteador central e o Internet através do roteador central.

Pré-requisitos

Requisitos

Antes que você continue com esta configuração, assegure-se de que você:

  • Verifique se as camadas 1 e 2 de ISDN estão ativas. Para mais informação, veja usando o comando show isdn status para o Troubleshooting de BRI.

  • Obtenha a informação necessária do ISP, tal como o método de autenticação, que poderia ser protocolo de autenticação de cumprimento do desafio (RACHADURA) ou protocolo password authentication (PAP), o nome de usuário e senha, o número a discar, e o endereço IP de Um ou Mais Servidores Cisco ICM NT para a interface do discador (a menos que a relação usa um endereço negociável). Também, encontre se o NAT é precisado de conectar host múltiplos ao ISP.

  • Do roteador remoto, obtenha a informação sobre o método de autenticação, o nome de usuário e senha, o número para discar, e o endereço IP de Um ou Mais Servidores Cisco ICM NT.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Cisco 803 Router com o IP Plus do Software Release 12.1(11) do � do Cisco IOS.

    Nota: Se você precisa de configurar o NAT, assegure-se de que você tenha o conjunto de recursos do IP Plus (tem “está” no nome de arquivo IO).

  • Cisco 2501 Router, que é o escritório remoto que executa o Cisco IOS Software Release 12.2(5).

Nota: A configuração para o roteador ISP não está incluída. Refira a página de suporte de tecnologia do Discar e acessar para alguns exemplos de configuração.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Produtos Relacionados

Essa configuração pode ser usada com qualquer roteador com uma interface BRI. Isto inclui o Roteadores com interfaces BRI incorporados, tais como o Cisco 800 (por exemplo, 801, 802, 803, 804) e os Series Router do Cisco 1600 (por exemplo, 1603-R e 1604-R). Igualmente inclui o Roteadores que aceita o WAN Interface Card BRI (WIC) ou os módulos de rede, como os 1600, 1700, 2600 e 3600 Series. Para obter mais informações sobre WICs de BRI ou Módulos de Rede, consulte WAN Interface Card (WIC) / Platform Hardware Compatibility Matrix for 1600, 1700, 2600 and 3600 Series Routers.

Nota: Use o comando show version verificar se seu roteador tenha uma interface BRI.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/14562/isdn800_14562.gif

Configurações

Nesta configuração, o roteador central é nomeado “central” e o escritório corporativo remoto é nomeado “telecontrole”.

No central, a interface do discador 1 é configurada para acessar a Internet. O endereço IP é dinamicamente atribuído pelo ISP. O NAT é usado para permitir que as redes IP do LAN central, do LAN remota, e de WAN central-remoto alcancem o Internet com a ajuda de um dinâmico-atribuído o endereço IP de Um ou Mais Servidores Cisco ICM NT. Entre em contato com seu ISP para verificar se precisa de NAT.

Nota: Nós configuramos o PAP e a RACHADURA, porque esta depende do que o ISP configurou (contudo, simplesmente um dele é usado).

central
 version 12.1 
  no parser cache 
  service timestamps debug datetime msec 
  service timestamps log datetime msec 
  ! 
  hostname central 
  ! 
  username remote password 0 remote
 
 !--- Username and shared secret password for the router (remote)
  !--- (used for CHAP authentication).
  !--- Shared secret password must be the same on both sides.

  ! 
  isdn switch-type basic-net3
  !  
  ! 
  interface Ethernet0 
   ip address 10.1.0.1 255.255.255.0 
   ip nat inside 

   !--- Ethernet 0 is an inside NAT interface.
   !--- All traffic from this network will be translated.

   no cdp enable 
  ! 
  interface BRI0

   !--- If you have additional BRIs, copy this BRI 0 configuration to the other BRIs.

   no ip address 
   encapsulation ppp 
   dialer pool-member 1

   !--- Assign BRI0 as member of dialer pool 1.
   !--- Dialer pool 1 is specified in interface Dialer 1.

   dialer pool-member 2 

   !--- Assign BRI0 as member of dialer pool 2.
   !--- Dialer pool 2 is specified in interface Dialer 2.

   isdn switch-type basic-net3     

   !--- This depends on the country. 

   no cdp enable 
   ppp authentication chap pap callin

   !--- Permit one-way CHAP and PAP authentication.
   !--- Configure authentication on both the physical and dialer interface.

  ! 
  interface Dialer1 

  !--- Create a dialer interface for every device to which you need to connect.

   description CONNECTION TO INTERNET 
   ip address negotiated 
   
!--- This IP address is obtained from the ISP. If the ISP permits a static
   !--- address, configure that address instead.

   ip nat outside 

   !--- The Outside NAT interface. Because this interface only has one IP address,
   !--- all traffic from the inside network will be Port Address Translated (PAT).

   encapsulation ppp 
   dialer pool 1 

   !--- Dialer profile 1. Remember that interface BRI 0 is a member of this profile.

   dialer remote-name ISP  
   dialer idle-timeout 180 
   dialer string 6122 

   !--- The number used to dial the ISP.

   dialer-group 1 
   
!--- Apply interesting traffic definition from dialer-list 1.

   no cdp enable 
   ppp authentication chap pap callin 
   ppp chap hostname XXXXX   

   !--- XXXXX is the username the ISP expects in order to authenticate this router.
   !--- For more information, refer to the document on ppp chap hostname.

   ppp chap password YYYYY    
  
 !--- YYYYY is the password the ISP expects in order to authenticate this router.

   ppp pap sent-username XXXXX password YYYYY 

   !--- PAP username and password. 
   !--- This is required only if the ISP does not support CHAP.

  ! 
  interface Dialer2 
   description CONNECTION TO REMOTE OFFICE 
   ip address 192.168.17.2 255.255.255.252

   !--- IP address for the connection to the remote office.
   !--- The remote office BRI interface is in the same subnet.

   ip nat inside

   !--- Dialer 2 is an inside NAT interface.
   !--- With this configuration, traffic from remote office is translated
   !--- before it is sent to the ISP.

   encapsulation ppp 
   dialer pool 2 

   !--- Dialer profile 2. Remember that interface BRI 0 is a member of this profile.

   dialer remote-name remote 

   !--- Specifies the remote router name (remote).
   !--- This name must match that used by the remote router to authenticate itself.
   !--- Remember that we configured the router username and password earlier.

   dialer idle-timeout 180 
   dialer string 6121 

   !--- Number used to dial the remote office router.

   dialer-group 1 

   !--- Apply interesting traffic definition from dialer-list 1.

   no cdp enable 
   ppp authentication chap callin 
  ! 
  ip nat inside source list 101 interface Dialer1 overload 

  !--- Establishes dynamic source translation (with PAT) for addresses that are
  !--- identified by the access list 101.

  no ip http server 
  ip classless 
  ip route 0.0.0.0 0.0.0.0 Dialer1 

  !--- Default route. Such traffic will use dialer 1 to the ISP.

  ip route 10.2.0.0 255.255.255.0 Dialer2 

  !--- Route to remote router network. Traffic for 10.2.0.0/24 uses Dialer2.

  ! 
  access-list 101 permit ip 10.1.0.0 0.0.0.255 any 
  access-list 101 permit ip 10.2.0.0 0.0.0.255 any 
  access-list 101 permit ip 192.168.17.0 0.0.0.3 any 
  
!--- Defines an access list that permits the addresses to be translated.
  !--- Note that the Ethernet 0 network, the remote router network and the
  !--- BRI network (between this router and the remote one) will be translated.

  dialer-list 1 protocol ip permit 

  !--- Interesting traffic definition.
  !--- This definition is applied to both connections.
  !--- If you need to define different interesting traffic for each connection,
  !--- create two dialer-lists and apply one to each dialer profile with dialer-group.

  no cdp run 
  ! 
  line con 0 
   exec-timeout 3 0 
  line vty 0 4 
   exec-timeout 3 0 
  ! 
  !  
  end

remoto
version 12.2 
  service timestamps debug datetime msec 
  service timestamps log datetime msec 
  ! 
  hostname remote 
  ! 
  username central password 0 remote 

  !--- Username and shared secret password for the router (central)
  !--- (used for CHAP authentication).
  !--- Shared secret must be the same on both sides. 

  ! 
  isdn switch-type basic-net3
  ! 
  interface Ethernet0 
   ip address 10.2.0.1 255.255.255.0 

   !--- Remember that this network is included in the NAT statements on central.

   no cdp enable 
  ! 
  interface BRI0 
    no ip address 
   encapsulation ppp 
   dialer pool-member 1 

   !--- Assign BRI0 as member of dialer pool 1.
   !--- Dialer pool 1 is specified in interface Dialer 1.

   isdn switch-type basic-net3 
   no cdp enable 
   ppp authentication chap 
  ! 
  interface Dialer1 
   ip address 192.168.17.1 255.255.255.252 
   encapsulation ppp 
   dialer pool 1 

   !--- Dialer profile 1. Remember that interface BRI 0 is a member of this profile.  

   dialer remote-name central 

   !--- Specifies the name of the other router (central).
   !--- This name must match that used by the remote router to authenticate itself.
   !--- Remember that we configured the router username and password earlier.

   dialer string 6131

   !--- The number used to dial the central router. 

   dialer-group 1 
   
!--- Apply interesting traffic definition from dialer-list 1.

   pulse-time 0 
   no cdp enable 
   ppp authentication chap callin 
  ! 
  ip classless 
  ip route 0.0.0.0 0.0.0.0 Dialer1 

  !--- Default route. Such traffic will use dialer 1 to the central router.

  no ip http server 
  ! 
  dialer-list 1 protocol ip permit

  !--- All IP traffic is interesting. 

  ! 
  line con 0 
   exec-timeout 3 0 
  line aux 0 
  line vty 0 4 
   exec-timeout 3 0 
  ! 
  end

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

  • mostre o active isdn — mostra o número ISDN que você se usou para colocar o atendimento, e indica se o atendimento é de entrada ou de partida.

  • show caller ip — indica um sumário de informação de chamador para o endereço IP de Um ou Mais Servidores Cisco ICM NT que você fornece.

  • show IP interface dialer 1 | inclua o Internet — alista um sumário da informação IP e do estado de uma interface do discador.

  • show dialer [interface type number] — informação geral de diagnóstico dos indicadores para as relações configuradas para o Dial-on-Demand Routing (DDR). Se o discador veio acima corretamente, esta mensagem aparece:

    Dialer state is data link layer up

    Se a camada física aparece acima, implica que o protocolo de linha veio acima, mas o protocolo network control (NCP) não fez. Os endereços de origem e destino do pacote que iniciou a discagem são mostrados na linha de razão de discagem. Este comando show igualmente indica a configuração do temporizador, e o tempo antes do tempo de conexão para fora.

Troubleshooting

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

Comandos para Troubleshooting

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Nota: Antes de emitir comandos debug, consulte Informações importantes sobre comandos debug.

  • debug dialer — informação sobre debugging dos indicadores sobre os pacotes ou os eventos em uma interface do discador.

  • debug isdn q931 — exibe informações sobre configuração de chamada e subdivisão de conexões de rede ISDN (Camada 3) entre o roteador local (lado do usuário) e a rede.

  • debugar a negociação ppp — informação dos indicadores no tráfego do Point-to-Point Protocol (PPP) e trocas durante a negociação de componentes de PPP, e inclua a informação no protocolo de controle de link (LCP), na autenticação, e no NCP. Uma negociação de PPP bem-sucedida abrirá primeiramente o estado do LCP e, em seguida, autenticará e, finalmente, negociará o NCP.

  • debugar a autenticação de PPP — causa o comando debug ppp indicar mensagens do protocolo de autenticação, incluindo intercâmbios de pacotes da RACHADURA e trocas PAP.

  • debug ip peer — contém a informação no par.

Saída de depurações

Para pesquisar defeitos a configuração, use estes debuga:

   central#debug isdn q931 
   ISDN Q931 packets debugging is on 
   
   central#debug dialer 
   Dial on demand events debugging is on 
   
   central#debug ppp negotiation 
   PPP protocol negotiation debugging is on 
   
   central#debug ppp authentication 
   PPP authentication debugging is on 
   
   central#debug ip peer 
   IP peer address activity debugging is on 

O roteador chamou a central inicia um atendimento ao Internet: 198.133.219.25 é um endereço IP na Internet.

   central#ping 198.133.219.25

   :.!!!! 
   Success rate is 80 percent (4/5), round-trip min/avg/max = 40/41/44 ms 

   *Mar 1 00:06:12.984: BR0 DDR: rotor dialout [priority] 
   *Mar 1 00:06:12.988: BR0 DDR: Dialing cause ip (s=172.17.243.115, 
    d=198.133.219.25)    
   *Mar 1 00:06:12.988: BR0 DDR: Attempting to dial 6122 
   *Mar 1 00:06:12.996: ISDN BR0: TX -> SETUP pd = 8 callref = 0x01 

   !--- central initiates the call to ISDN number 6122. 

   *Mar 1 00:06:13.000: Bearer Capability i = 0x8890 
   *Mar 1 00:06:13.008: Channel ID i = 0x83 
   *Mar 1 00:06:13.008: Called Party Number i = 0x80, '6122', Plan:Unknown,
   Type:Unknown 
   *Mar 1 00:06:13.088: ISDN BR0: RX <- CALL_PROC pd = 8 callref = 0x81 
   *Mar 1 00:06:13.092: Channel ID i = 0x89 
   *Mar 1 00:06:13.244: ISDN BR0: RX <- CONNECT pd = 8 callref = 0x81 

   !--- central receives a connect message : the ISDN B channel is established. 

   *Mar 1 00:06:13.252: ISDN BR0: TX -> CONNECT_ACK pd = 8 callref = 0x01 
   *Mar 1 00:06:13.260: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up 
   *Mar 1 00:06:13.268: BR0:1: interface must be fifo queue, force FIFO 
   *Mar 1 00:06:13.272: %DIALER-6-BIND: Interface BR0:1 bound to profile Di1 
   *Mar 1 00:06:13.280: BR0:1 PPP: Treating connection as a callout 
   *Mar 1 00:06:13.280: BR0:1 PPP: Phase is ESTABLISHING, Active Open 
   *Mar 1 00:06:13.284: BR0:1 PPP: No remote authentication for call-out 
   *Mar 1 00:06:13.284: BR0:1 LCP: O CONFREQ [Closed] id 1 len 10 
   *Mar 1 00:06:13.284: BR0:1 LCP: MagicNumber 0x108130DD (0x0506108130DD) 
   *Mar 1 00:06:13.300: BR0:1 LCP: I CONFREQ [REQsent] id 132 Len 15 
   *Mar 1 00:06:13.300: BR0:1 LCP: AuthProto CHAP (0x0305C22305) 

   !--- The ISP wants to use CHAP authentication. 

   *Mar 1 00:06:13.304: BR0:1 LCP: MagicNumber 0xE4225290 (0x0506E4225290) 
   *Mar 1 00:06:13.304: BR0:1 LCP: O CONFACK [REQsent] id 132 Len 15 
   *Mar 1 00:06:13.308: BR0:1 LCP: AuthProto CHAP (0x0305C22305) 
   *Mar 1 00:06:13.308: BR0:1 LCP: MagicNumber 0xE4225290 (0x0506E4225290) 
   *Mar 1 00:06:13.308: BR0:1 LCP: I CONFACK [ACKsent] id 1 Len 10 
   *Mar 1 00:06:13.312: BR0:1 LCP: MagicNumber 0x108130DD (0x0506108130DD) 
   *Mar 1 00:06:13.312: BR0:1 LCP: State is Open 
   *Mar 1 00:06:13.320: BR0:1 PPP: Phase is AUTHENTICATING, by the peer 
   *Mar 1 00:06:13.328: BR0:1 AUTH: Started process 0 pid 22 
   *Mar 1 00:06:13.328: BR0:1 CHAP: I CHALLENGE id 118 Len 27 from "posets"    
   *Mar 1 00:06:13.332: BR0:1 CHAP: Using alternate hostname XXXXX 
   *Mar 1 00:06:13.332: BR0:1 CHAP: Username posets not found 
   *Mar 1 00:06:13.336: BR0:1 CHAP: Using default password 
   *Mar 1 00:06:13.336: BR0:1 CHAP: O RESPONSE id 118 Len 26 from "XXXXX"    
   *Mar 1 00:06:13.360: BR0:1 CHAP: I SUCCESS id 118 Len 4 
   
!--- central receives a CHAP SUCCESS from ISP. 

   *Mar 1 00:06:13.360: BR0:1 PPP: Phase is UP 
   *Mar 1 00:06:13.364: BR0:1 IPCP: O CONFREQ [Not negotiated] id 1 Len 10 
   *Mar 1 00:06:13.364: BR0:1 IPCP: Address 0.0.0.0 (0x030600000000) 
   *Mar 1 00:06:13.368: BR0:1 IPCP: I CONFREQ [REQsent] id 108 Len 10 
   *Mar 1 00:06:13.368: BR0:1 IPCP: Address 194.183.201.1 (0x0306C2B7C901) 
   *Mar 1 00:06:13.368: BR0:1: IPPOOL: validate address = 194.183.201.1 
   *Mar 1 00:06:13.372: BR0:1 set_ip_peer(3): new address 194.183.201.1 
   *Mar 1 00:06:13.372: BR0:1 IPCP: O CONFACK [REQsent] id 108 Len 10 
   *Mar 1 00:06:13.376: BR0:1 IPCP: Address 194.183.201.1 (0x0306C2B7C901) 
   *Mar 1 00:06:13.380: BR0:1 IPCP: I CONFNAK [ACKsent] id 1 Len 10 
   *Mar 1 00:06:13.380: BR0:1 IPCP: Address 194.183.201.3 (0x0306C2B7C903) 

   !--- 194.183.201.3 is assigned by ISP to dialer 1 of central. 

   *Mar 1 00:06:13.384: BR0:1 IPCP: O CONFREQ [ACKsent] id 2 Len 10 
   *Mar 1 00:06:13.384: BR0:1 IPCP: Address 194.183.201.3 (0x0306C2B7C903) 
   *Mar 1 00:06:13.396: BR0:1 IPCP: I CONFACK [ACKsent] id 2 Len 10 
   *Mar 1 00:06:13.400: BR0:1 IPCP: Address 194.183.201.3 (0x0306C2B7C903) 
   *Mar 1 00:06:13.400: BR0:1 IPCP: State is Open 
   *Mar 1 00:06:13.400: Di1 IPCP: Install negotiated IP interface address
   194.183.201.3 
   *Mar 1 00:06:13.412: BR0:1 DDR: dialer protocol up 
   *Mar 1 00:06:13.416: Di1 IPCP: Install route to 194.183.201.1 
   *Mar 1 00:06:14.360: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
   changed state to up 
   *Mar 1 00:06:19.276: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 6122
   unknown

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 14562