Discar e acessar : """Integrated Services Digital Networks (ISDN), Channel-Associated Signaling (CAS)"""

Configurando uma interface assíncrona como backup para uma linha serial

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

É comum fornecer caminhos redundantes para conexões WAN, como serial, Frame Relay ou linha em uso, com circuitos DDR. Os modens assíncronos e as linhas de serviço de telefonia tradicional (POTS) circuito-comutadas são usados às interfaces de backup de WAN. É necessário planejamento cuidadoso ao criar backups de cenários de discagem. Considere fatores tais como o tráfego nos links de backup, o número de links suscetíveis à falha, e o planeamento de capacidade da porta aos circuitos de backup de suporte.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nas versões de software e hardware abaixo.

  • Uma plataforma do Cisco 2500 Router.

  • Software Release 12.1(2)T de Cisco IOS� na medição de roteador.

  • Cisco IOS Software Release 12.0(7)T no sphinx do roteador.

  • Os Modens externos conectaram à porta serial no Roteadores.

Nota: Este documento pode ser alterado para o uso em todo o roteador com interfaces assíncronas (ou modens embutido). A configuração da Interface de backup (relação Serial2, neste exemplo) seria incluída sob a “relação Assíncrono x”.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Informações de Apoio

Três métodos comuns disponíveis para fornecer backup de um enlace de WAN são:

  • Interfaces de backup - Uma Interface de backup permanece no modo standby até que o link principal vá para baixo. O link de backup é então, ativado, restabelecendo a conexão entre as duas estações.

  • Vigias do discador – Um vigia do discador fornece conectividade confiável sem depender unicamente da definição do tráfego interessante para disparar chamadas externas no roteador central. O relógio de discador monitora algumas rotas específicas e, caso não seja possível alcançar essas redes, ele ativa o link secundário.

  • Rotas estáticas flutuantes - As Rotas estáticas flutuantes são as rotas estáticas que têm uma distância administrativa maior do que a distância administrativa de rota dinâmica. As distâncias administrativas podem ser configuradas em uma rota estática de modo que a rota estática seja menos desejável do que uma rota dinâmica; daqui, a rota estática não é usada quando a rota dinâmica está disponível. Entretanto, se a rota dinâmica for perdida, a rota estática pode assumir e o tráfego pode ser enviado por esta rota alternativa.

Esta encenação usa a Interface de backup para executar o backup. Para obter mais informações sobre dos usos da Interface de backup refira as interfaces de avaliação de backup, as Rotas estáticas flutuantes, e o Dialer Watch do documento para o backup de chamada DDR.

Para obter mais informações sobre de configurar o backup refira por favor o documento de Configuração e Troubleshooting de DDR Backup. O documento fornece informações sobre a determinação de que método de backup deve ser utilizado e outras informações de configuração.

Leia e entenda os dois documentos acima antes de continuar com essa configuração.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a instalação de rede mostrada no diagrama abaixo.

/image/gif/paws/14281/async_backup_14281.gif

Configurações

Nessa configuração, estamos usando dois Cisco routers (gaugin and sphinx) conectados sobre uma linha dedicada através de suas interfaces seriais 0. As duas interfaces seriais são conectadas por modems assíncronos através de uma linha de rede de telefonia comutada pública (PSTN) e usadas como backup para a linha arrendada.

Nota: Por padrão, essas interfaces funcionam em modo síncrono. Você precisará configurá-las (usando o comando physical-layer async) para funcionar em modo assíncrono.

Usando o comando show version, você pode encontrar se estas relações podem trabalhar no modo assíncrono demasiado. A informação relevante exibida pelo comando show version é mostrada abaixo:

2 Low-speed serial(sync/async) network interfaces

! --- This means it can work in sync or async mode.

Recomenda-se que você termina a configuração e verifica que a conexão de modem pode ser feita. Você pode fazer isso estabelecendo uma sessão Telnet reversa com os modems e fazendo uma chamada para o número do modem remoto.

Nota: É igualmente obrigatório usar uma capacidade do modem (modemcap) segundo o tipo de modem. Para mais informações sobre esse assunto, consulte o Modem-Router Connection Guide (Guia de conexão entre modem e roteador).

gaugin (Cisco 2500) - Roteador Chamador
gaugin#show running-config
 Building configuration...

 Current configuration:
 hostname gaugin

 username sphinx password 0 cisco

 !---Username and shared secret for CHAP authentication.

 !
 chat-script CALLOUT "" "atdt\T" TIMEOUT 60 CONNECT \c

 !--- Chat script used for dialout.

 modemcap entry usr:MSC=& FS0=1 & C1&D2;&H1;&R2;&B1;&W;

 !--- Modemcap for the external modem.
 !--- Refer to Modem-Router Connection Guide for more information.

 interface Loopback1
 ip address 1.1.1.1 255.255.255.255
 !
 interface Serial0
 
!--- Primary link.

  ip address 3.3.3.1 255.255.255.0

 !--- Remote peer serial interface is in same subnet.

  backup interface serial 2

 !--- Designate interface serial 2 as the backup interface.

 !
 interface Serial2

 !--- Backup interface. This interface will be in "Standby" mode until the
 !--- line protocol on interface Serial 0 (the primary) goes down.

  physical-layer async
 
!--- Permit async mode.

  ip unnumbered Loopback1
  encapsulation ppp
  dialer in-band
  dialer map ip 2.2.2.1 name sphinx modem-script CALLOUT 8029

 !--- Dialer map for the peer. 
!--- Note the ip address, the name (which matches the
!--- authenticated username, the chat script used and the number to dial.

  dialer-group 1

 !--- Interesting traffic definition for dialout.

  async mode dedicated
  no peer default ip address

 !--- Do not provide the peer with an IP address. 
!--- It must have one configured.

  no fair-queue
  ppp authentication chap callin

 !--- Use one-way chap authentication.

 !
 ip route 2.2.2.1 255.255.255.255 Serial0
 ip route 2.2.2.1 255.255.255.255 Serial2

 ! -- Identical routes for the peer. 
!--- Note the IP address matches the dialer map ip.
 !--- When the primary is up, the backup in in Standby hence the route using
 !--- Serial 2 will not be used. When the backup is brought out of standby
 !--- it will get used and the serial 0 route is removed (since the link is down/down)
 !--- To create a route for other networks use 
!--- ip route <network> <mask> 2.2.2.1.



 dialer-list 1 protocol ip permit

 !--- Interesting traffic definition. 
!--- Once the backup link is brought out of standby
!--- dialout is ONLY initiaited after the router receives interesting traffic.


 line 2

 !--- Line configuration for the modem on interface Serial 2. 

 script dialer CALLOUT

 !--- Use script CALLOUT.

 modem InOut
 modem autoconfigure type usr

 !--- Use modemcap named "usr" configured earlier.

 transport input all
 speed 115200

 !--- DTE-DCE speed.

 flowcontrol hardware

esfinge (Cisco2500) - Roteador chamado
sphinx#show running-config
 Building configuration...

 Current configuration:
 !
 version 12.0
 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
 !
 hostname sphinx
 username gaugin password 0 cisco

 !--- Username and shared secret for CHAP authentication.

 modemcap entry usr:MSC=& FS0=1 & C1&D2;&H1;&R2;&B1;&W; !
 interface Loopback1
 ip address 2.2.2.1 255.255.255.255
 no ip directed-broadcast
 !
 interface Serial0

 !--- Primary interface
 !--- Note that this router does not initiate the backup when the primary fails
 !--- it will rely on the peer to initiate the connection.

 ip address 3.3.3.2 255.255.255.0
 !
 interface Serial2

 !--- Interface providing backup.
 !--- There is no dialer map/dialer string since it is only accepting the call.
 !--- This interface will be in Up/Up(Spoofing) mode when the primary interface is up.
 !--- Later, configure a floating static route to prevent packet loss.

 physical-layer async
 ip unnumbered Loopback1
 no ip directed-broadcast
 encapsulation ppp
 dialer in-band
 dialer-group 1
 async mode dedicated
 no peer default ip address
 no fair-queue
 no cdp enable
 ppp authentication chap

 ip route 1.1.1.1 255.255.255.255 Serial0
 ip route 1.1.1.1 255.255.255.255 Serial2 2 

 !--- The 2 makes the route a floating static route.
 !--- This is important since the async interface will be in spoofing mode 
 !--- (not in standby mode) when the primary interface is up.
 !--- If we do not use the 2 here, we lose half of the packets in the return path
 !--- since the router will attempt to load balance
 !--- across the 2 links (eventhough the backup is down).
 !--- To create a route for other networks use 
!--- ip route <network> <mask> 1.1.1.1.


 line 2
  modem InOut
  modem autoconfigure type usr
  transport input all
  speed 115200
  flowcontrol hardware

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

  • mostre a série da relação - Indica a informação sobre uma interface serial.

  • show ip route - Exibe o estado atual da tabela de roteamento.

  • show line - Exibe parâmetros de uma linha de terminal.

Troubleshooting

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

Para obter mais informações sobre da Interface de backup do Troubleshooting refira por favor

Comandos para Troubleshooting

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Nota: Antes de emitir comandos debug, consulte Informações importantes sobre comandos debug.

  • show dialer – Exibe informações sobre a interface de um discador.

  • ping - Testa a conectividade.

  • debug modem – Observa a atividade da linha do modem em um servidor de acesso.

  • debug ppp negotiation – Exibe informações no tráfego PPP e alterações enquanto negocia componentes de PPP, incluindo o protocolo de controle de link (LCP), autenticação e protocolo de controle de rede (NCP). Uma negociação de PPP bem-sucedida abrirá primeiramente o estado do LCP e, em seguida, autenticará e, finalmente, negociará o NCP.

  • debug ppp authentication – Exibe mensagens de protocolo de autenticação PPP, incluindo intercâmbios de pacote de Protocolo de Autenticação de Desafio (CHAP) e intercâmbios de Protocolo de Autenticação de Senha (PAP). Se você observa uma falha, verifique que o nome de usuário e senha da rachadura está configurado corretamente.

  • debug chat – Exibe a atividade de scripts de bate-papo.

  • debug dialer - Exibe informações de depuração de DDR sobre os pacotes recebidos em uma interface de discador.

No exemplo de saída abaixo, nós podemos ver que a conexão serial principal (serial0) no gaugin (o roteador de chamada) tem um problema e deixa cair a conexão. A Interface de backup (série 2) começa fazer a conexão de backup. Para este exemplo, desconectamos o cabo para testar o enlace de backup.

Nota: Emitir o comando shutdown na interface principal não fará com que o backup disque. Se você emitir um comando shutdown para desativar a conexão principal, o Cisco IOS Software não ativará automaticamente uma conexão de backup. Você deve desativar fisicamente a conexão principal, desconectando cabos ou utilizando outro método equivalente para ativar as interfaces de backup.

   gaugin#
   *Mar 1 00:57:25.127: %LINK-3-UPDOWN: Interface Serial0, changed state to down
   *Mar 1 00:57:26.127: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0,
    changed state to down

    !--- Primary Link is brought down. 
    !--- This will cause the backup link (int Serial 2) to be taken out of standby.

   *Mar 1 00:57:37.143: %LINK-3-UPDOWN: Interface Serial2, changed state to down
   
!--- The Backup link is changes from Standby to Down.

   *Mar 1 00:57:37.147: Se2 LCP: State is Closed..
   *Mar 1 00:57:40.019: TTY2: restoring DTR
   *Mar 1 00:57:41.019: TTY2: autoconfigure probe started
   *Mar 1 00:57:52.147: Se2 DDR: re-enable timeout.
   *Mar 1 00:57:55.067: Se2 DDR: Dialing cause ip (s=1.1.1.1, d=2.2.2.1)
   
!--- Interesting traffic for the peer causes the dialout.

   *Mar 1 00:57:55.071: Se2 DDR: Attempting to dial 8029
   *Mar 1 00:57:55.071: CHAT2: Attempting async line dialer script
   *Mar 1 00:57:55.075: CHAT2: Dialing using Modem script: CALLOUT 
   & System script: none
   
!--- Chat-script named CALLOUT is used.

   *Mar 1 00:57:55.083: CHAT2: process started
   *Mar 1 00:57:55.083: CHAT2: Asserting DTR
   *Mar 1 00:57:55.087: CHAT2: Chat script CALLOUT started
   *Mar 1 00:57:55.087: CHAT2: Sending string: atdt\T<8029>
   *Mar 1 00:57:55.091: CHAT2: Expecting string: CONNECT.........
   *Mar 1 00:58:12.859: CHAT2: Completed match for expect: CONNECT
   *Mar 1 00:58:12.859: CHAT2: Sending string: \c
   *Mar 1 00:58:12.863: CHAT2: Chat script CALLOUT finished, status = Success
   *Mar 1 00:58:12.867: TTY2: no timer type 1 to destroy
   *Mar 1 00:58:12.867: TTY2: no timer type 0 to destroy
   *Mar 1 00:58:12.875: Se2 IPCP: Install route to 2.2.2.1.
   *Mar 1 00:58:14.871: %LINK-3-UPDOWN: Interface Serial2, changed state to up
       Dialer state change to up Serial2 Dialer call has been placed Serial2
   *Mar 1 00:58:14.891: Se2 PPP: Treating connection as a callout

    !--- PPP LCP negotiation begins.

   *Mar 1 00:58:14.891: Se2 PPP: Phase is ESTABLISHING, Active Open
   *Mar 1 00:58:14.895: Se2 PPP: No remote authentication for call-out
   *Mar 1 00:58:14.899: Se2 LCP: O CONFREQ [Closed] id 10 len 20
   *Mar 1 00:58:14.899: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   *Mar 1 00:58:14.903: Se2 LCP: MagicNumber 0x0041E7ED (0x05060041E7ED)
   *Mar 1 00:58:14.907: Se2 LCP: PFC (0x0702)
   *Mar 1 00:58:14.907: Se2 LCP: ACFC (0x0802).
   *Mar 1 00:58:16.895: Se2 LCP: TIMEout: State REQsent
   *Mar 1 00:58:16.899: Se2 LCP: O CONFREQ [REQsent] id 11 len 20
   *Mar 1 00:58:16.899: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   *Mar 1 00:58:16.903: Se2 LCP: MagicNumber 0x0041E7ED (0x05060041E7ED)
   *Mar 1 00:58:16.907: Se2 LCP: PFC (0x0702)
   *Mar 1 00:58:16.907: Se2 LCP: ACFC (0x0802)
   *Mar 1 00:58:17.063: Se2 LCP: I CONFACK [REQsent] id 11 len 20
   *Mar 1 00:58:17.067: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   *Mar 1 00:58:17.067: Se2 LCP: MagicNumber 0x0041E7ED (0x05060041E7ED)
   *Mar 1 00:58:17.071: Se2 LCP: PFC (0x0702)
   *Mar 1 00:58:17.075: Se2 LCP: ACFC (0x0802)
   *Mar 1 00:58:17.083: Se2 LCP: I CONFREQ [ACKrcvd] id 32 len 25
   *Mar 1 00:58:17.083: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   *Mar 1 00:58:17.087: Se2 LCP: AuthProto CHAP (0x0305C22305)
   *Mar 1 00:58:17.091: Se2 LCP: MagicNumber 0xE05307CD (0x0506E05307CD)
   *Mar 1 00:58:17.095: Se2 LCP: PFC (0x0702)
   *Mar 1 00:58:17.095: Se2 LCP: ACFC (0x0802)
   *Mar 1 00:58:17.099: Se2 LCP: O CONFACK [ACKrcvd] id 32 len 25
   *Mar 1 00:58:17.103: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   *Mar 1 00:58:17.103: Se2 LCP: AuthProto CHAP (0x0305C22305)
   *Mar 1 00:58:17.107: Se2 LCP: MagicNumber 0xE05307CD (0x0506E05307CD)
   *Mar 1 00:58:17.111: Se2 LCP: PFC (0x0702)
   *Mar 1 00:58:17.111: Se2 LCP: ACFC (0x0802)
   *Mar 1 00:58:17.115: Se2 LCP: State is Open
    
!--- LCP negotiation is complete.

   *Mar 1 00:58:17.115: Se2 PPP: Phase is AUTHENTICATING, by the peer
   *Mar 1 00:58:17.263: Se2 CHAP: I CHALLENGE id 4 len 27 from "sphinx"
   *Mar 1 00:58:17.271: Se2 CHAP: O RESPONSE id 4 len 27 from "gaugin"
   *Mar 1 00:58:17.391: Se2 CHAP: I SUCCESS id 4 len 4
   *Mar 1 00:58:17.395: Se2 PPP: Phase is UP
   *Mar 1 00:58:17.399: Se2 IPCP: O CONFREQ [Closed] id 4 len 10
   *Mar 1 00:58:17.399: Se2 IPCP: Address 1.1.1.1 (0x030601010101)
   *Mar 1 00:58:17.407: Se2 CDPCP: O CONFREQ [Closed] id 4 len 4
   *Mar 1 00:58:17.411: Se2 IPCP: I CONFREQ [REQsent] id 5 len 10
   *Mar 1.00:58:17.415: Se2 IPCP: Address 2.2.2.1 (0x030602020201)
   *Mar 1 00:58:17.419: Se2 IPCP: O CONFACK [REQsent] id 5 len 10
   *Mar 1 00:58:17.423: Se2 IPCP: Address 2.2.2.1 (0x030602020201)
   *Mar 1 00:58:17.527: Se2 IPCP: I CONFACK [ACKsent] id 4 len 10
   *Mar 1 00:58:17.531: Se2 IPCP: Address 1.1.1.1 (0x030601010101)
   *Mar 1 00:58:17.535: Se2 IPCP: State is Open
   *Mar 1 00:58:17.543: Se2 LCP: I PROTREJ [Open] id 33 len 10 protocol 
   CDPCP (0x820701040004)
   *Mar 1 00:58:17.547: Se2 CDPCP: State is Closed
   *Mar 1 00:58:17.547: Se2 DDR: dialer protocol up
   *Mar 1 00:58:18.075: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2,
    changed state to up

   !--- Connection is successful. Backup link is now active.


   gaugin#show ip route 2.2.2.1
   Routing entry for 2.2.2.1/32
   Known via "connected", distance 0, metric 0 (connected, via interface)
   Routing Descriptor Blocks:
   * directly connected, via Serial2

   !--- The route for the peer uses the backup link.
   !--- Note the static route for primary link is removed
   !--- (since the link is down/down).

   Route metric is 0, traffic share count is 1

   gaugin#show dialer
   Se2 - dialer type = IN-BAND ASYNC NO-PARITY
   Idle timer (120 secs), Fast idle timer (20 secs)
   Wait for carrier (30 secs), Re-enable (15 secs)
   Dialer state is data link layer up
   Dial reason: ip (s=1.1.1.1, d=2.2.2.1)
   Time until disconnect 108 secs
   Connected to 8029
   
   Dial String Successes Failures Last     DNIS  Last status
   8029        4           0      00:01:00       successful
   
   gaugin#show interface serial 2
   Serial2 is up, line protocol is up 

   !--- Backup link is verified to be up.

   Hardware is CD2430 in async mode
   Interface is unnumbered. Using address of Loopback1 (1.1.1.1)
   MTU 1500 bytes, BW 115 Kbit, DLY 100000 usec,    ...   ...

   gaugin#ping 2.2.2.1
   Type escape sequence to abort.
   Sending 5, 100-byte ICMP Echos to 2.2.2.1, timeout is 2 seconds:
   !!!!!
   Success rate is 100 percent (5/5), round-trip min/avg/max = 128/132/136 ms

Está aqui a mesma chamada da perspectiva da esfinge que recebeu o atendimento:

sphinx#
   00:57:29: TTY2: DSR came up

   !--- Modem DSR is first changed to up, indicating an incoming call.

   00:57:29: TTY2: destroy timer type 1
   00:57:29: TTY2: destroy timer type 0
   00:57:29: tty2: Modem: IDLE->(unknown)
   00:57:31: Se2 LCP: I CONFREQ [Closed] id 10 len 20
   
!--- Begin LCP negotiation
.
   00:57:31: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   00:57:31: Se2 LCP: MagicNumber 0x0041E7ED (0x05060041E7ED)
   00:57:31: Se2 LCP: PFC (0x0702)
   00:57:31: Se2 LCP: ACFC (0x0802)
   00:57:31: Se2 LCP: Lower layer not up, Fast Starting
   00:57:31: Se2 PPP: Treating connection as a callin
   00:57:31: Se2 PPP: Phase is ESTABLISHING, Passive Open
   00:57:31: Se2 LCP: State is Listen
   00:57:31: Se2 LCP: O CONFREQ [Listen] id 31 len 25
   00:57:31: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   00:57:31: Se2 LCP: AuthProto CHAP (0x0305C22305)
   00:57:31: Se2 LCP: MagicNumber 0xE05307CD (0x0506E05307CD)
   00:57:31: Se2 LCP: PFC (0x0702)
   00:57:31: Se2 LCP: ACFC (0x0802)
   00:57:31: Se2 LCP: O CONFACK [Listen] id 10 len 20
   00:57:31: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   00:57:31: Se2 LCP: MagicNumber 0x0041E7ED (0x05060041E7ED)
   00:57:31: Se2 LCP: PFC (0x0702)
   00:57:31: Se2 LCP: ACFC (0x0802)
   00:57:31: %LINK-3-UPDOWN: Interface Serial2, 
   changed state to upDialer statechange 
   to up Serial2
   00:57:31: Serial2 DDR: Dialer received incoming call from <unknown>
   00:57:33: Se2 LCP: I CONFREQ [ACKsent] id 11 len 20
   00:57:33: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   00:57:33: Se2 LCP: MagicNumber 0x0041E7ED (0x05060041E7ED)
   00:57:33: Se2 LCP: PFC (0x0702)
   00:57:33: Se2 LCP: ACFC (0x0802)
   00:57:33: Se2 LCP: O CONFACK [ACKsent] id 11 len 20
   00:57:33: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   00:57:33: Se2 LCP: MagicNumber 0x0041E7ED (0x05060041E7ED)
   00:57:33: Se2 LCP: PFC (0x0702)
   00:57:33: Se2 LCP: ACFC (0x0802)
   00:57:33: Se2 LCP: TIMEout: State ACKsent
   00:57:33: Se2 LCP: O CONFREQ [ACKsent] id 32 len 25
   00:57:33: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   00:57:33: Se2 LCP: AuthProto CHAP (0x0305C22305)
   00:57:33: Se2 LCP: MagicNumber 0xE05307CD (0x0506E05307CD)
   00:57:33: Se2 LCP: PFC (0x0702)
   00:57:33: Se2 LCP: ACFC (0x0802)
   00:57:33: Se2 LCP: I CONFACK [ACKsent] id 32 len 25
   00:57:33: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   00:57:33: Se2 LCP: AuthProto CHAP (0x0305C22305)
   00:57:33: Se2 LCP: MagicNumber 0xE05307CD (0x0506E05307CD)
   00:57:33: Se2 LCP: PFC (0x0702)
   0:57:33: Se2 LCP: ACFC (0x0802)
   00:57:33: Se2 LCP: State is Open
   
!--- LCP negotiation is complete.

   00:57:33: Se2 PPP: Phase is AUTHENTICATING, by this end
   00:57:33: Se2 CHAP: O CHALLENGE id 4 len 27 from "sphinx"
   00:57:33: Se2 CHAP: I RESPONSE id 4 len 27 from "gaugin"
   00:57:33: Se2 CHAP: O SUCCESS id 4 len 4

   !--- CHAP authentication is successful.

   00:57:33: Serial2 DDR:
   Authenticated host gaugin with no matching dialer map
   00:57:33: Se2 PPP: Phase is UP
   00:57:33: Se2 IPCP: O CONFREQ [Closed] id 5 len 10
   00:57:33: Se2 IPCP: Address 2.2.2.1 (0x030602020201)
   00:57:33: Se2 IPCP: I CONFREQ [REQsent] id 4 len 10
   00:57:33: Se2 IPCP: Address 1.1.1.1 (0x030601010101)
   00:57:33: Se2 IPCP: O CONFACK [REQsent] id 4 len 10
   00:57:33: Se2 IPCP: Address 1.1.1.1 (0x030601010101)
   00:57:33: Se2 CDPCP: I CONFREQ [Not negotiated] id 4 len 4
   00:57:33: Se2 LCP: O PROTREJ [Open] id 33 len 10 protocol CDPCP
   (0x820701040004)
   00:57:33: Se2 IPCP: I CONFACK [ACKsent] id 5 len 10
   00:57:33: Se2 IPCP: Address 2.2.2.1 (0x030602020201)
   00:57:33: Se2 IPCP: State is Open
   00:57:33: Serial2 DDR: dialer protocol up
   00:57:33: Se2 IPCP: Install route to 1.1.1.1

   !--- A route to the peer is installed.

   00:57:34: %LINEPROTO-5-UPDOWN: Line protocol on 
   Interface Serial2, changed state to up
   
!--- Backup link is up.


   sphinx#ping 1.1.1.1
   Type escape sequence to abort.
   Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
   !!!!!
   Success rate is 100 percent (5/5), round-trip min/avg/max = 132/142/152 ms

   sphinx#show ip route 1.1.1.1
   Routing entry for 1.1.1.1/32
   Known via "connected", distance 0, metric 0 (connected, via interface)
   Routing Descriptor Blocks:
   * directly connected, via Serial2

   !--- The floating static route is now installed.

   Route metric is 0, traffic share count is 1

   sphinx#show dialer

   Serial2 - dialer type = IN-BAND ASYNC NO-PARITY
   Idle timer (120 secs), Fast idle timer (20 secs)
   Wait for carrier (30 secs), Re-enable (15 secs)
   Dialer state is data link layer up
   Time until disconnect 119 secs (gaugin)

Agora vamos reconectar o cabo do link principal. O link principal será movimento indicar que o Up/Up e o link de backup (Serial2) estarão transformados no estado à espera no gaugin (desde que tem o comando backup interface serial 2). Isto fará com que o enlace de modem morram e a série 2 da relação na esfinge a ir para baixo também.

Este comando debug on gaugin mostra esse processo:

   gaugin#
   *Mar 1 00:59:38.859: %LINK-3-UPDOWN: Interface Serial0, changed state to up
   *Mar 1 00:59:39.875: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0,
   changed state to up
   
!--- Primary link is re-established.

   *Mar 1 00:59:59.315: TTY2: Async Int reset: Dropping DTR
   *Mar 1 01:00:00.875: TTY2: DSR was dropped
   *Mar 1 01:00:00.875: tty2: Modem: READY->(unknown)
   *Mar 1 01:00:01.315: %LINK-5-CHANGED: Interface Serial2, 
    changed state to standby mode

   !--- the backup link is returned to standby mode. 
   !--- The modem connection is terminated

   *Mar 1 01:00:01.331: Se2 IPCP: State is Closed
   *Mar 1 01:00:01.335: Se2 PPP: Phase is TERMINATING
   *Mar 1 01:00:01.335: Se2 LCP: State is Closed
   *Mar 1 01:00:01.339: Se2 PPP: Phase is DOWN
   *Mar 1 01:00:01.343: Se2 IPCP: Remove route to 2.2.2.1
   *Mar 1 01:00:01.883: TTY2: dropping DTR, hanging up
   *Mar 1 01:00:01.883: tty2: Modem: HANGUP->(unknown)
   *Mar 1 01:00:02.315: %LINEPROTO-5-UPDOWN: 
   Line protocol on Interface Serial2, changed state to down
   *Mar 1 01:00:02.899: TTY2: cleanup pending. Delaying DTR
   *Mar 1 01:00:03.927: TTY2: cleanup pending. Delaying DTR
   *Mar 1 01:00:04.323: TTY2: no timer type 0 to destroy
   *Mar 1 01:00:04.323: TTY2: no timer type 1 to destroy
   *Mar 1 01:00:04.327: TTY2: no timer type 3 to destroy
   *Mar 1 01:00:04.327: TTY2: no timer type 4 to destroy
   *Mar 1 01:00:04.327: TTY2: no timer type 2 to destroy
   *Mar 1 01:00:04.331: Serial2: allowing modem_process to continue hangup!

As seguintes depurações mostram a mesma transação sob a perspectiva do Sphinx.

   sphinx#
   00:58:54: %LINK-3-UPDOWN: Interface Serial0, changed state to up
   00:58:55: %LINEPROTO-5-UPDOWN: Line protocol on 
   Interface Serial0, changed state 
to up
   
!--- Primary link is brought up.

   00:59:16: TTY2: DSR was dropped

   !--- Modem connection is terminated by the peer.

   00:59:16: tty2: Modem: READY->(unknown)
   00:59:17: TTY2: dropping DTR, hanging up
   00:59:17: TTY2: Async Int reset: Dropping DTR
   00:59:17: tty2: Modem: HANGUP->(unknown)
   00:59:18: TTY2: cleanup pending. Delaying DTR
   00:59:19: %LINK-5-CHANGED: Interface Serial2, changed state to reset
   
!--- The Backup Interface (serial 2)is reset.

   00:59:19: Se2 IPCP: State is Closed
   00:59:19: Se2 PPP: Phase is TERMINATING
   00:59:19: Se2 LCP: State is Closed
   00:59:19: Se2 PPP: Phase is DOWN
   00:59:19: TTY2: cleanup pending. Delaying DTR
   00:59:19: Se2 IPCP: Remove route to 1.1.1.1
   
!--- The route to 1.1.1.1 using Serial 2 is removed since 
   !--- it is has a higher administrative distance of 2.

   00:59:20: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2, 
   changed state to down
   00:59:20: TTY2: cleanup pending. Delaying DTR
   00:59:21: TTY2: cleanup pending. Delaying DTR
   00:59:22: TTY2: destroy timer type 0
   00:59:22: TTY2: destroy timer type 1
   00:59:22: TTY2: destroy timer type 3
   00:59:22: TTY2: destroy timer type 4
   00:59:22: TTY2: destroy timer type 2
   00:59:22: Serial2: allowing modem_process to continue hangup
   00:59:22: TTY2: restoring DTR
   00:59:22: TTY2: autoconfigure probe started
   00:59:24: %LINK-3-UPDOWN: Interface Serial2, changed state to down
   00:59:24: Se2 LCP: State is Closed
   sphinx(config-if)#

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 14281