Discar e acessar : """Integrated Services Digital Networks (ISDN), Channel-Associated Signaling (CAS)"""

Exemplo de configuração do ISDN - IP

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento fornece uma configuração de exemplo para o ISDN o uso do IP.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/14222/40.gif

Configurações

Este documento utiliza as seguintes configurações:

C2503
C2503#write terminal
######
Current configuration:
!
version 10.2
!
hostname C2503
!
enable password test
!
username C4000 password cisco

!--- See the username explanation in the 
!--- Explanation of the C2503 Configuration section of this document.

isdn switch-type basic-dms100
!
interface Ethernet0
ip address 172.16.10.1 255.255.255.0
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
interface BRI0
ip address 172.16.20.1 255.255.255.0
encapsulation ppp
bandwidth 56
dialer idle-timeout 300
dialer map ip 172.16.20.2 name C4000 speed 56 broadcast 14155551234
dialer map ip 172.16.20.2 name C4000 speed 56 broadcast 14155556789
dialer hold-queue 5
dialer load-threshold 100
dialer-group 1
isdn spid1 408555432101 5554321
isdn spid2 408555987601 5559876
ppp authentication chap
!
router igrp 1
network 172.16.0.0
!
ip route 192.168.24.0 255.255.255.0 172.16.20.2
access-list 100 deny ip 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0
access-list 100 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
!
!
dialer-list 1 list 100
!
line con 0
line aux 0
line vty 0 4
password test
login
!
end

C4000
C4000#write terminal
######
Current configuration:
!
version 10.2
!
hostname C4000
!
enable password test
!
username C2503 password cisco

!--- See the username explanation in the 
!--- Explanation of the C4000 Configuration section of this document.

isdn switch-type basic-dms100
!
interface Ethernet0
ip address 192.168.24.65 255.255.255.0
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
interface BRI0
ip address 172.16.20.2 255.255.255.0
encapsulation ppp
bandwidth 56
dialer idle-timeout 300
dialer map ip 172.16.20.1 name C2503 speed 56 broadcast 14085554321
dialer map ip 172.16.20.1 name C2503 speed 56 broadcast 14085559876
dialer hold-queue 5
dialer load-threshold 100
dialer-group 1
isdn spid1 415555123401 5551234
isdn spid2 415555678901 5556789
ppp authentication chap
!
router igrp 1
network 172.16.0.0
network 192.168.24.0
!
ip route 172.16.10.0 255.255.255.0 172.16.20.1
access-list 100 deny ip 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0
access-list 100 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
!
!
dialer-list 1 list 100
!
line con 0
line aux 0
line vty 0 4
password test
login
!
end

Explicação da configuração C2503

C2503#write terminal
######
Current configuration:
!
version 10.2
!
hostname C2503
!
enable password test
!
username C4000 password cisco

O username C4000 é o nome de host do roteador remoto. O comando dialer map, que esta seção explica, usa este username. O username não é diferenciando maiúsculas e minúsculas durante a autenticação. Contudo, o nome que você configura com o comando dialer map é diferenciando maiúsculas e minúsculas. Você deve exatamente combinar o nome de host do roteador remoto, que é "C4000".

Nota: No roteador C2503, o nome que você configura com o comando username deve exatamente combinar o nome que você configura com o comando dialer map. Você emite o comando username no modo de configuração global.

O processo de autenticação do protocolo de autenticação de cumprimento do desafio (RACHADURA) usa a senha. A senha é diferenciando maiúsculas e minúsculas e deve combinar a senha do roteador remoto exatamente.

Nota: A fim evitar a confusão, este exemplo de configuração usa o formulário não criptografado da senha Cisco. Na configuração real, a senha aparece em seu formulário criptografado: 7 13061E010803. Nesta senha, 7 denota o tipo de criptografia e 13061E010803 é o formulário criptografado da senha Cisco. Quando você emite ou faz mudanças ao comando username, sempre incorpore a senha a seu formulário não criptografado e não incorpore o tipo de criptografia (7). O tipo de criptografia é ajustado automaticamente.

  • tipo de switch basic-dms100 isdn — O tipo de switch ISDN deve combinar o equipamento de seu portador. Se você muda o tipo de switch, você deve recarregar o roteador para que o tipo de switch novo tome o efeito.

    interface Ethernet0
    ip address 172.16.10.1 255.255.255.0
    
    interface Serial0
    no ip address
    shutdown
    !
    interface Serial1
    no ip address
    shutdown
    !
    interface BRI0
    ip address 172.16.20.1 255.255.255.0
  • encapsulamento ppp — Use o encapsulamento PPP em vez do High-Level Data Link Control (HDLC) a fim permitir o uso da autenticação chap.

  • largura de banda 56 — A configuração de largura de banda padrão para uma interface BRI é 64 kbps. Se você configura suas instruções de mapa de discador com a opção do speed 56, inclua a instrução de largura de banda.

    Nota: Este comando não controla a velocidade de sua linha ISDN. Os conjuntos de comandos o ponto de referência correto para:

    • As estatísticas da relação da mostra da porta BRI

    • O comando dialer load-threshold

    • Métricas de roteamento do Interior Gateway Routing Protocol (IGRP) /Enhanced IGRP (EIGRP)

  • quietude-intervalo 300 do discador — Este conjuntos de comandos o número de segundos que a conexão ISDN permanece aberta se nenhum tráfego interessante está sendo distribuído. O temporizador é restaurado cada vez que um pacote interessante é enviado.

  • transmissão 14155551234 do speed 56 do nome C4000 do mapa de discadores IP 172.16.20.2

    transmissão 14155556789 do speed 56 do nome C4000 do mapa de discadores IP 172.16.20.2

    Use o comando dialer map com autenticação chap a fim colocar a chamada inicial ao roteador remoto quando o tráfego interessante é enviado à interface BRI. Quando a conexão se torna ativa, o comando dialer idle-timeout determina o intervalo de tempo para que a conexão permaneça ativo. Uma instrução de mapa de discador é necessária para cada número de telefone ISDN que será chamado. Contudo, esteja ciente que duas instruções de mapa de discador que o ponto ao mesmo lugar pode ativar ambos os canais B quando você pode somente querer usar um canal.

    Os parâmetros de comando para esse exemplo são:

    • 172.16.20.2 — O endereço IP de Um ou Mais Servidores Cisco ICM NT da interface BRI do roteador remoto

      A fim determinar este endereço, emita o comando show interface bri 0 na alerta do console do roteador remoto.

    • nome C4000 — O nome de host do roteador remoto

      O nome é diferenciando maiúsculas e minúsculas e deve combinar o nome que você configura para o comando username.

    • speed 56 — Ajusta a velocidade do discador a 56 kbps para os circuitos de ISDN que não são 64 End to End dos kbps

      Inclua este parâmetro nas instruções de mapa de discador de ambo o Roteadores. A maioria de instalações em America do Norte devem ser configuradas para 56 kbps.

    • transmissão — Permite o encaminhamento de pacote de broadcast

      A menos que o comando dialer-list especificar pacotes de transmissão como pacotes interessantes, os pacotes estão enviados somente quando o enlace de ISDN é ativo.

    • 14155551234 e 14155556789 — Os números de telefone ISDN do roteador remoto

  • posse-fila 5 do discador — Este comando permite que os pacotes interessantes sejam enfileirados até o estabelecimento da conexão ISDN. Neste exemplo, cinco pacotes interessantes devem ser enfileirado.

  • limiar de carga 100 do discador — Este comando configura a largura de banda por encomenda. Os conjuntos de comandos a carga máxima antes do discador colocam um outro atendimento através do segundo canal B. O valor da carga é a média pesada calculada para a interface, onde 1 é descarregado e 255 é completamente carregado. O valor de carga real a configurar depende das características de sua rede particular. Neste exemplo, o segundo canal B é ativado quando a carga alcança 39 por cento da utilização máxima, que é 100 divididos por 255.

  • discador-grupo 1O comando dialer-group 1 permite a lista de discadores 1 na interface BRI, que determina que pacotes são interessantes e ativarão a conexão ISDN.

  • isdn spid1 408555432101 5554321

    isdn spid2 408555987601 5559876

    Use os comandos isdn spid se seu portador atribui os identificadores do perfil de serviços (SPID) a suas linhas de ISDN.

  • rachadura da autenticação de PPP — Este comando permite a autenticação chap.

    router igrp 1 
    network 172.16.0.0
  • rota 192.168.24.0 255.255.255.0 172.16.20.2 IP — Este comando ip route cria uma rota estática à rede do roteador remoto através da interface BRI do roteador remoto. Esta é uma exigência porque as rotas dinâmica são perdidas quando o enlace de ISDN está para baixo.

    Os parâmetros de comando para esse exemplo são:

    • 192.168.24.0 — A rede do alvo

    • 255.255.255.0 — A máscara da rede do alvo

      Uns 255 em uma posição do octeto especificam que um exato - combine para esse octeto é necessário. O A0 em uma posição do octeto especifica que algum avalia fósforos.

    • 172.16.20.2 — O endereço do salto seguinte que pode ser usado para alcançar a rede do alvo

  • access-list 100 deny ip 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0

    licença IP 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255 da lista de acesso 100 — este comando access-list determina que pacotes IP são interessantes e ativarão o enlace de ISDN. A lista de acessos a criar depende de seu projeto de rede particular.

    a lista de acesso 100 nega IP 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0 — este comando access-list define todos os pacotes de transmissão como sem interesse.

    licença IP 0.0.0.0 255.255.255.255 0.0.0.0255.255.255.255 da lista de acesso 100 — este comando access-list define todos pacotes IP restantes como interessantes.

  • lista 100 do dialer-list 1 — Este comando aponta à lista de acessos 100, que determina que pacotes IP são interessantes.

    line con 0
    line aux 0
    line vty 0 4
    password test
    login
    !
    end

Explicação da configuração C4000

C4000#write terminal
######
Current configuration:
!
version 10.2
!
hostname C4000
!
enable password test
!
username C2503 password cisco

O username C2503 é o nome de host do roteador remoto. O comando dialer map, que esta seção explica, usa este username. O username não é diferenciando maiúsculas e minúsculas durante a autenticação. Contudo, o nome que você configura com o comando dialer map é diferenciando maiúsculas e minúsculas. Você deve exatamente combinar o nome de host do roteador remoto, que é "C2503".

Nota: No roteador C4000, o nome que você configura com o username deve exatamente combinar o nome que você configura com o comando dialer map. Você emite o comando username no modo de configuração global.

O processo de autenticação chap usa a senha. A senha é diferenciando maiúsculas e minúsculas e deve combinar a senha do roteador remoto exatamente.

Nota: A fim evitar a confusão, este exemplo de configuração usa o formulário não criptografado da senha Cisco. Na configuração real, a senha aparece em seu formulário criptografado: 7 13061E010803. Nesta senha, 7 denota o tipo de criptografia e 13061E010803 é o formulário criptografado da senha Cisco. Quando você emite ou faz mudanças ao comando username, sempre incorpore a senha a seu formulário não criptografado e não incorpore o tipo de criptografia (7). O tipo de criptografia é ajustado automaticamente.

  • tipo de switch basic-dms100 isdn — O tipo de switch ISDN deve combinar o equipamento de seu portador. Se você muda o tipo de switch, você deve recarregar o roteador para que o tipo de switch novo tome o efeito.

    interface Ethernet0
    ip address 192.168.24.65 255.255.255.0
    
    interface Serial0
    no ip address
    shutdown
    !
    interface Serial1
    no ip address
    shutdown
    !
    interface BRI0
    ip address 172.16.20.2 255.255.255.0
    
    encapsulation ppp
  • encapsulamento ppp — Use o encapsulamento PPP em vez do HDLC a fim permitir o uso da autenticação chap.

  • largura de banda 56 — A configuração de largura de banda padrão para uma interface BRI é 64 kbps. Se você configura suas instruções de mapa de discador com a opção do speed 56, inclua a instrução de largura de banda.

    Nota: Este comando não controla a velocidade de sua linha ISDN. Os conjuntos de comandos o ponto de referência correto para:

    • As estatísticas da relação da mostra da porta BRI

    • O comando dialer load-threshold

    • Métricas de roteamento IGRP/EIGRP

  • quietude-intervalo 300 do discador — Este conjuntos de comandos o número de segundos que a conexão ISDN permanece aberta se nenhum tráfego interessante está sendo distribuído. O temporizador é restaurado cada vez que um pacote interessante é enviado.

    dialer map ip 172.16.20.1 name C2503 speed 56 broadcast 14085554321
    dialer map ip 172.16.20.1 name C2503 speed 56 broadcast 14085559876 

    Use o comando dialer map com autenticação chap a fim colocar a chamada inicial ao roteador remoto quando o tráfego interessante é enviado à interface BRI. Quando a conexão se torna ativa, o comando dialer idle-timeout determina o intervalo de tempo para que a conexão permaneça ativo. Uma instrução de mapa de discador é necessária para cada número de telefone ISDN que será chamado. Contudo, esteja ciente que duas instruções de mapa de discador que o ponto ao mesmo lugar pode ativar ambos os canais B quando você pode somente querer usar um canal.

    Os parâmetros de comando para esse exemplo são:

    • 172.16.20.1 — O endereço IP de Um ou Mais Servidores Cisco ICM NT da interface BRI do roteador remoto

      A fim determinar este endereço, emita o comando show interface bri 0 na alerta do console do roteador remoto.

    • nome C2503 — O nome de host do roteador remoto

      O nome é diferenciando maiúsculas e minúsculas e deve combinar o nome que você configura para o comando username.

    • speed 56 — Ajusta a velocidade do discador a 56 kbps para os circuitos de ISDN que não são 64 End to End dos kbps

      Inclua este parâmetro nas instruções de mapa de discador de ambo o Roteadores. A maioria de instalações em America do Norte devem ser configuradas para 56 kbps.

    • transmissão — Permite o encaminhamento de pacote de broadcast

      A menos que o comando dialer-list especificar pacotes de transmissão como pacotes interessantes, os pacotes estão enviados somente quando o enlace de ISDN é ativo.

    • 14085554321 e 14085559876 — Os números de telefone ISDN do roteador remoto

  • posse-fila 5 do discador — Este comando permite que os pacotes interessantes sejam enfileirados até o estabelecimento da conexão ISDN. Neste exemplo, cinco pacotes interessantes devem ser enfileirado.

  • limiar de carga 100 do discador — Este comando configura a largura de banda por encomenda. Os conjuntos de comandos a carga máxima antes do discador colocam um outro atendimento através do segundo canal B. O valor da carga é a média pesada calculada para a interface, onde 1 é descarregado e 255 é completamente carregado. O valor de carga real a configurar depende das características de sua rede particular. Neste exemplo, o segundo canal B é ativado quando a carga alcança 39 por cento da utilização máxima, que é 100 divididos por 255.

  • discador-grupo 1O comando dialer-group 1 permite a lista de discadores 1 na interface BRI, que determina que pacotes são interessantes e ativarão a conexão ISDN.

  • isdn spid1 415555123401 5551234

    isdn spid2 415555678901 5556789

    Use os comandos isdn spid se seu portador atribui SPID a suas linhas de ISDN.

  • rachadura da autenticação de PPP — Este comando permite a autenticação chap.

    router igrp 1
    network 172.16.0.0
    network 192.168.24.0
  • rota 172.16.10.0 255.255.255.0 172.16.20.1 IP — Este comando ip route cria uma rota estática à rede do roteador remoto através da interface BRI do roteador remoto. Esta é uma exigência porque as rotas dinâmica são perdidas quando o enlace de ISDN está para baixo.

    Os parâmetros de comando para esse exemplo são:

    • 172.16.0.0 — A rede do alvo

    • 255.255.0.0 — A máscara da rede do alvo

      Uns 255 em uma posição do octeto especificam que um exato - combine para esse octeto é necessário. O A0 em uma posição do octeto especifica que algum avalia fósforos.

    • 172.16.20.1 — O endereço do salto seguinte que pode ser usado para alcançar a rede do alvo

  • access-list 100 deny ip 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0

    licença IP 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255 da lista de acesso 100 — este comando access-list determina que pacotes IP são interessantes e ativarão o enlace de ISDN. A lista de acessos a criar depende de seu projeto de rede particular.

    a lista de acesso 100 nega IP 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0 — este comando access-list define todos os pacotes de transmissão como sem interesse.

    licença IP 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255 da lista de acesso 100 — este comando access-list define todos pacotes IP restantes como interessantes.

  • lista 100 do dialer-list 1 — Este comando aponta à lista de acessos 100, que determina que pacotes IP são interessantes.

    line con 0
    line aux 0
    line vty 0 4
    password test
    login
    !
    end

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 14222