WAN : Protocolos X.25

X.25 para conversão de TCP

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

O XOT (X.25 sobre o TCP) é projetado pelo Cisco Systems, e detalhado na solicitação para comentários (RFC) 1613, transportar o X.25 sobre internets IP. Isso permite que os pacotes X.25 sejam enviados em uma rede TCP/IP (Protocolo de controle da transmissão/protocolo da Internet) em vez de um link LAPB (Procedimento de acesso de link, equilibrado). O XOT é um método de enviar os pacotes X.25 sobre internets IP com o encapsulamento do pacote X.25 em nível em uns pacotes de TCP.

Este documento apresenta uma configuração de exemplo que ilustra estas duas traduções:

  • Transmission Control Protocol (TCP) à tradução X.25.

  • X.25 para tradução TCP.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Esta tradução exige o conjunto de recursos de empreendimento, que é apoiado somente nas plataformas do Cisco Router 26xx e acima.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/14216/x25_tcptrans1.gif

Como mostrado aqui, os links lado a lado são usados entre o Roteadores 1 e 2 e entre o Roteadores 2 e 3.

Configurações

Este documento utiliza as seguintes configurações:

  • Roteador1

  • Roteador2

  • Roteador3

Nota: Nós truncamos as seguintes configurações para indicar a informação relevante.

Roteador1
version 12.1
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router1
!
interface Serial0
 description DCE connection to s1 Router2
 ip address 10.0.0.6 255.255.255.252
 no ip mroute-cache
 clockrate 56000
!
ip route 192.168.7.0 255.255.255.0 10.0.0.5                                             

Roteador2
version 12.1
service timestamps debug datetime msec                                                  
service timestamps log datetime msec
!
hostname Router2
!
x25 routing
!
interface Loopback0
 ip address 192.168.7.1 255.255.255.0
!
interface Serial0
 description DCE connection to s1 Router3
 encapsulation x25 dce
 no ip mroute-cache
 clockrate 64000
!
interface Serial1
 description DTE connection to s0 Router1
 ip address 10.0.0.5 255.255.255.252
!
x25 route 123 interface Serial0
!
translate tcp 192.168.7.2 x25 123
translate x25 345 tcp 10.0.0.6

Roteador3
Router3#show running-config
Building configuration...
 
Current configuration:
!
version 12.1
service timestamps debug datetime msec
service timestamps log datetime msec
hostname Router3
!
ip subnet-zero
!
x25 routing
!
interface Serial1
 description DTE connection to s0 Router2
 encapsulation x25
 x25 address 123
!
x25 route 345 interface Serial1                                                         

Verificar

Use os comandos seguintes testar que sua rede se está operando corretamente:

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

  • a mostra debuga — permite-o de indicar o uma variedade de debugam a informação, ou de executar atividades de Troubleshooting específicas.

  • telnet 192.168.7.2 — conecta aos sistemas de computador no Internet no modo de prompt.

  • a almofada 345 — registra-o sobre a uma ALMOFADA.

  • mostre X.25 vc — informação dos indicadores sobre os Circuito Virtual Comutado ativo (SVC), e circuitos permanentes (PVC) no modo de exec privilegiado.

A saída mostrada nos testes abaixo é um resultado de incorporar estes comandos nos dispositivos mostrados no diagrama da rede acima. Esta saída mostra que a rede está operando adequadamente.

Teste 1: TCP para tradução X.25

Neste teste, nós executamos uma sessão de Telnet do roteador1 ao endereço IP de Um ou Mais Servidores Cisco ICM NT do roteador2:

  1. Telnet 192.168.7.2 do roteador1.

    Nota: Este endereço pertence à rede 192.168.7.0 /24 no roteador2. Este endereço não deve ser atribuído a nenhum outro sistema na rede.

  2. O roteador2 faz um TCP para tradução x.25 a fim alcançar o roteador3. A saída é exibida abaixo.

Router2#show debug 
   TCP: 
     TCP special event debugging is on 
   X.29 PAD: 
     X25 PAD debugging is on 
   X.25: 
     X.25 special event debugging is on 
   Protocol translation: 
     Protocol Translation debugging is on 
   Router2#
 
Router1#telnet 192.168.7.2 
   Trying 192.168.7.2 ... Open 
   Trying 123...Open 
    User Access Verification 
    Password: 
   Router3>

Router2# 
   *Mar  1 01:50:28.759: TCP0: state was LISTEN -> SYNRCVD [23 -> 10.0.0.6(11007)]    
   *Mar  1 01:50:28.763: TCB00499CAC setting property TCP_TOS (11) C0094 
   *Mar  1 01:50:28.767: tcppad2: fork started 
   *Mar  1 01:50:28.767: TCP: sending SYN, seq 3338770911, ack 4026886977    
   *Mar  1 01:50:28.771: TCP2: Connection to 10.0.0.6:11007, advertising MSS 1460 
   *Mar  1 01:50:28.775: TCP2: Connection to 10.0.0.6:11007, received MSS 556, MSS is 556 
   *Mar  1 01:50:28.791: TCP2: state was SYNRCVD -> ESTAB [23 -> 10.0.0.6(11007)]    
   *Mar  1 01:50:28.803: pad_open_connection: found a valid route 
   *Mar  1 01:50:28.807: Serial0: X.25 O R1 Call (11) 8 lci 1 
   *Mar  1 01:50:28.811: From (0):  To (3): 123 
   *Mar  1 01:50:28.811: Facilities: (0) 
   *Mar  1 01:50:28.815: Call User Data (4): 0x01000000 (pad)    
   *Mar  1 01:50:28.827: Serial0: X.25 I R1 Call Confirm (5) 8 lci 1 
   *Mar  1 01:50:28.831: From (0):  To (0): 
   *Mar  1 01:50:28.835: Facilities: (0) 
   *Mar  1 01:50:28.835: PAD2: Call completed 
   *Mar  1 01:50:28.839: PAD2: Control packet received. 
   *Mar  1 01:50:28.851: PAD2: Input X29 packet type 4 (Read X.3 param) len 1 
   *Mar  1 01:50:28.855: PAD2: Output X29 packet type 0 (Parameter indication) len 45 
       1:1, 2:1, 3:2, 4:1, 5:0, 6:0, 7:4, 
       8:0, 9:0, 10:0, 11:14, 12:0, 13:0, 14:0, 15:0, 
       16:127, 17:21, 18:18, 19:0, 20:0, 21:0, 22:0, 
   *Mar  1 01:50:28.879: PAD2: Control packet received. 
   *Mar  1 01:50:28.883: PAD2: Input X29 packet type 6 (Set and Read) len 9 
       2:0, 4:1, 15:0, 7:21, 
   *Mar  1 01:50:28.887: tcppad2: Sending WILL ECHO 
   *Mar  1 01:50:28.891: PAD2: Output X29 packet type 0 (Parameter indication) len 9 
       2:0, 4:1, 15:0, 7:21,

Router2#show x25 vc
   SVC 1, State: D1, Interface: Serial0 
     Started 00:00:25, last input 00:00:22, output 00:00:22  
  Line: 2 vty 0 Location: Host: 10.0.0.6    
      connected to 123 PAD <--> X25  
  Window size input: 2, output: 2 
     Packet size input: 128, output: 128 
     PS: 5  PR: 4  ACK: 4  Remote PR: 5 RCNT: 0 RNR: no 
     P/D state timeouts: 0  timer (secs): 0 
     data bytes 57/62 packets 5/4 Resets 0/0 RNRs 0/0 REJs 0/0 INTs 0/0 
   Router2# 

Teste 2: X.25 para tradução TCP

Neste teste, nós começamos uma sessão do montador/desmontador de pacote (PAD) do roteador3 ao endereço X.25 do roteador2:

  1. Faça uma ALMOFADA a 345 do roteador3.

  2. O roteador2 faz uma x.25 para tradução TCP a fim alcançar o roteador1. A saída é exibida abaixo.

Router2#show debug 
   TCP: 
     TCP special event debugging is on 
   X.29 PAD: 
     X25 PAD debugging is on 
   X.25: 
     X.25 special event debugging is on 
   Protocol translation: 
     Protocol Translation debugging is on 
   Router2# 

Router3#pad 345 
   Trying 345...Open 
   Trying 10.0.0.6 ... Open 
    User Access Verification 
    Password: CCCC 
   Router1> 
      
Router2# 
   *Mar  1 01:51:31.475: Serial0: X.25 I R1 Call (12) 8 lci 1024 
   *Mar  1 01:51:31.479: From (3): 123 To (3): 345 
   *Mar  1 01:51:31.483: Facilities: (0) 
   *Mar  1 01:51:31.483: Call User Data (4): 0x01000000 (pad)    
   *Mar  1 01:51:31.487: PAD: translate call to 345 
   *Mar  1 01:51:31.491: Call User Data (4): 0x01000000 (pad)    
   *Mar  1 01:51:31.495: PAD: Creating proto translation on tty2 for vc 1024    
   *Mar  1 01:51:31.499: Serial0: X.25 O R1 Call Confirm (5) 8 lci 1024 
   *Mar  1 01:51:31.503: From (0):  To (0): 
   *Mar  1 01:51:31.503: Facilities: (0) 
   *Mar  1 01:51:31.507: PAD2: Call completed 
   *Mar  1 01:51:31.511: padtcp2: fork started 
   *Mar  1 01:51:31.515: PAD2: Output X29 packet type 4 (Read X.3 param) len 1 
   *Mar  1 01:51:31.523: TCB0049E7A4 created 
   *Mar  1 01:51:31.523: TCB0049E7A4 setting property TCP_TOS (11) 49C853    
   *Mar  1 01:51:31.527: TCB0049E7A4 bound to UNKNOWN.44034 
   *Mar  1 01:51:31.531: PAD2: Control packet received. 
   *Mar  1 01:51:31.531: TCP: sending SYN, seq 3401534831, ack 0 
   *Mar  1 01:51:31.535: TCP2: Connection to 10.0.0.6:23, advertising MSS 1460 
   *Mar  1 01:51:31.539: TCP2: state was CLOSED -> SYNSENT [44034 -> 10.0.0.6(23)]    
   *Mar  1 01:51:31.559: TCP2: state was SYNSENT -> ESTAB [44034 -> 10.0.0.6(23)]    
   *Mar  1 01:51:31.563: TCP2: Connection to 10.0.0.6:23, received MSS 1460, MSS is 1460 
   *Mar  1 01:51:31.567: TCB0049E7A4 connected to 10.0.0.6.23 
   *Mar  1 01:51:31.571: PAD2: Input X29 packet type 0 (Parameter indication) len 45 
       1:1, 2:1, 3:2, 4:1, 5:0, 6:0, 7:4, 
       8:0, 9:0, 10:0, 11:14, 12:0, 13:0, 14:0, 15:0, 
       16:127, 17:21, 18:18, 19:0, 20:0, 21:0, 22:0, 
   *Mar  1 01:51:31.583: PAD2: Setting ParamsIn, length 44 
   *Mar  1 01:51:31.587: PAD2: Output X29 packet type 6 (Set and Read) len 9 
       2:0, 4:1, 15:0, 7:21, 
   *Mar  1 01:51:31.599: PADTCP2: Telnet received WILL ECHO (1) 
   *Mar  1 01:51:31.599: PAD2: Control packet received. 
   *Mar  1 01:51:31.607: PADTCP2: Telnet received DO TTY-TYPE (24) 
   *Mar  1 01:51:31.611: PAD2: Output X29 packet type 6 (Set and Read) len 3 2:0, 
   *Mar  1 01:51:31.619: PAD2: Input 
   *Mar  1 01:51:31.619: PAD2: Control packet received.X29 packet type 0 
       (Parameter indication) len 9 2:0, 4:1, 15:0, 7:21, 
   *Mar  1 01:51:31.627: PAD2: Setting ParamsIn, length 8 
   *Mar  1 01:51:31.631: PAD2: Input X29 packet type 0 (Parameter indication) len 3 2:0, 
   *Mar  1 01:51:31.635: PAD2: Setting ParamsIn, length 2 
   *Mar  1 01:51:31.643: PADTCP2: Telnet received DONT TTY-LOCATION (23) 
   *Mar  1 01:51:31.647: PADTCP2: Telnet received DONT TTY-SPEED (32) 
   Router2#  

Router2#show x25 vc 
   SVC 1024,  State: D1,  Interface: Serial0 
     Started 00:00:10, last input 00:00:07, output 00:00:05  
  Line: 2   vty 0    Location:  Host: 123    
     123 connected to 345 PAD <--> X25  
  Window size input: 2, output: 2 
     Packet size input: 128, output: 128 
     PS: 1  PR: 6  ACK: 6  Remote PR: 1  RCNT: 0  RNR: no 
     P/D state timeouts: 0  timer (secs): 0 
     data bytes 3057/60 packets 33/6 Resets 0/0 RNRs 0/0 REJs 0/0 INTs 0/0    
   Router2# 
   Router2# 

Antes de emitir comandos de depuração, consulte as informações importantes sobre eles.

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 14216