WAN : Protocolos X.25

Configurando um roteador como uma ALMOFADA para o XOT a um host assíncrono

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento apresenta uma configuração de exemplo em que um host remoto conecta ao X.25 sobre uma rede do Transmission Control Protocol (TCP) em uma linha dial-up da rede telefônica pública comutada (PSTN). O host não envia nem recebe nenhuns pacotes X.25. Contudo, o roteador remoto que conecta atua como um montador/desmontador de pacote (PAD) X.25 e encapsula e pacotes dos decapsulates X.25 para o host.

Nota: Isto está referido como “a almofada reversa”, enquanto o atendimento X.25 pode somente ser estabelecido do dispositivo X.25 (server) ao host assíncrono, não vice versa. A almofada dianteira exige uma configuração diferente.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Os realces a funcionalidade que Almofada-relacionada nós podemos se usar em serviços de Conversão de protocolo foram introduzidos no Software Release 11.2 de Cisco IOS�.

As seguintes Plataformas apoiam os realces da ALMOFADA:

  • Cisco 2500 Series Routers

  • Cisco 26xx Series Router

  • Cisco 36xx Series Router

  • Cisco 4000 Router

  • Cisco 4500 Router

  • Cisco 4700 Router

  • Series Router do Cisco AS5200

  • Cisco 7000 Series Router

  • Cisco 7200 Series Router

  • Cisco 7500 Series Router

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Informações de Apoio

A ALMOFADA sobre o X.25 sobre TCP (XOT) permite chamadas pad aos destinos que não são alcançáveis sobre as relações X.25 físicas, mas sobre túneis TCP. Esta função permite as chamadas pad que originam de um roteador em um enlace IP para alcançar um dispositivo X.25. O PAD over XOT igualmente permite conexões de XOT recebidas de um enlace IP de ser aceitado como conexões da ALMOFADA ou da Conversão de protocolo no roteador local.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/14188/netdiag1.jpg

Configurações

Este documento utiliza as seguintes configurações:

Roteador remoto
Current configuration:
!
version 12.0
 service pad from-xot                   

!---used for allowing incoming xot to pad connection

 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
!
!OPTIONAL
x29 profile default 2:0, 4:1, 15:0, 7:21 

!---apply customized x29 profile as default to all incoming connections

!
hostname Remote
!
memory-size iomem 25
 ip subnet-zero
 no ip domain-lookup
!
x25 routing
!
interface Serial0
 ip address 10.10.100.2 255.255.255.0
 no ip directed-broadcast
!
interface Serial1
 ip address 10.10.175.1 255.255.255.0
 no ip directed-broadcast
!
interface FastEthernet0
 ip address 10.10.10.42 255.255.255.0
 no ip directed-broadcast
 half-duplex
!
ip classless
 no ip http server
!
x25 route ^100 xot 10.10.100.1
 x25 host remote 250                 
!---map the x25 address of 25099 to the router's
hostname
!
line con 0
 no exec
 exec-timeout 0 0
 transport input none
line aux 0                     

!---to async host

 no exec
 modem InOut
 rotary 99                   

!---enable reverse PAD

 transport input pad
 flowcontrol hardware
line vty 0 4
 login local
!

Roteador principal
Current configuration:
!
version 12.0
 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
!
hostname Main
!
!
memory-size iomem 25
 ip subnet-zero
 no ip domain-lookup
!
x25 routing
!
!
!
interface Serial0
 ip address 10.10.100.1 255.255.255.0
 no ip directed-broadcast
 clockrate 800000
!
interface Serial1
 no ip directed-broadcast
 encapsulation x25 dce
 x25 address 150
 clockrate 56000
!
interface FastEthernet0
 no ip address
 no ip directed-broadcast
 half-duplex
!
ip classless
 no ip http server
!
x25 route ^250 xot 10.10.100.2
 x25 route ^100 interface Serial1
!
line con 0
 transport input none
 line aux 0
 line vty 0 4
 login local
!
no scheduler allocate
end

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

Comandos para Troubleshooting

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Nota: Antes de emitir comandos de depuração, consulte as informações importantes sobre eles.

  • eventos do debug x25 — Informação dos indicadores sobre todo o tráfego X.25 ou uma classe de serviço X.25 específica.

  • debugar a almofada — Os indicadores debugam mensagens para todas as conexões da ALMOFADA.

O seguinte resultado do debug é indicado para um atendimento X.25 bem sucedido do server ao host. Nós executamos estes comandos debug sobre no roteador remoto.

Remote#debug x25 events
Remote#debug pad
WORKING CALL
2d01h: pad_ctxt_up: id 808D6F18, reason 80742B9C (event 0, impetus 10)
2d01h: [10.10.100.1,11042/10.10.100.2,1998]: XOT I P/Inactive Call (20) 8
lci 1
2d01h:   From (5): 10006 To (5): 25099
2d01h:   Facilities: (6)
2d01h:     Packet sizes: 128 128
2d01h:     Window sizes: 2 2
2d01h:   Call User Data (4): 0x01000000 (pad)
2d01h: PAD: incoming call to 25099 on line 5 CUD length 4
2d01h: PAD: Creating TTY daemon on tty5 for vc 1
2d01h: [10.10.100.1,11042/10.10.100.2,1998]: XOT O P3 Call Confirm (5) 8
lci 1
2d01h:   From (0):  To (0):
2d01h:   Facilities: (0)
2d01h: PAD5: Call completed
2d01h: PAD5: Output X29 packet type 4 (Read X.3 param) len 1
2d01h: PAD5: Control packet received.
2d01h: PAD5: Input X29 packet type 0 (Parameter indication) len 45
1:1, 2:1, 3:2, 4:0, 5:0, 6:5, 7:2,
8:0, 9:0, 10:0, 11:14, 12:1, 13:4, 14:0, 15:1,
16:8, 17:24, 18:18, 19:2, 20:255, 21:7, 22:0,
2d01h: PAD5: Setting ParamsIn, length 44
2d01h: PAD5: Output X29 packet type 6 (Set and Read) len 9 2:0, 4:1,
15:0,7:21,
2d01h: PAD5: Control packet received.
2d01h: PAD5: Input X29 packet type 0 (Parameter indication) len 9 2:0,
4:1, 15:0, 7:21,

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 14188