Segurança e VPN : Negociação IPSec/Protocolos IKE

Configurando a criptografia CET com um túnel GRE

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Cisco anunciou o fim da vida para a tecnologia de criptografia Cisco. Para obter mais informações, consulte o Anúncio End-of-Sales.


Índice


Introdução

Para configurar a criptografia da tecnologia de criptografia Cisco (CET) com um túnel, você deve configurar a criptografia na relação do túnel. Adicionalmente, você deve configurar a criptografia na interface física essa as cabeças para o destino final do túnel.

Nota: A criptografia CET é agora fim da vida útil. O IPsec é o esquema de criptografia recomendado para a migração.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/14120/13.gif

Notas de Diagrama de Rede

  • 8.8.8.8, atrás do r3-4k, e 7.7.7.4, atrás do R6-2500, são estações finais. Quando se sibilam, o tráfego atravessa o túnel.

  • O túnel de encapsulamento de roteamento genérico (GRE) é configurado com interfaces de loopback, como a origem e o destino do túnel.

  • O tráfego através do túnel também é criptografado. A aplicação desta característica exige aquela cifrar o tráfego de túnel, o crypto map deve ser anexado à interface de túnel e à interface externa física.

Configurações

Este documento utiliza as seguintes configurações:

r3-4k
hostname r3-4k
  !
  crypto public-key r6-2500 02014544
   F3681B5D 32372A19 0C0CCC4B E707F829 D882CF30 A9B4DBE3 E1911E9C F6A9E162 
   732558DF A20FEFAD 2ACC400E 8DDB10B1 3566FA3A E55A9BBE 00916AAD 20A0C75C
   quit
  !
  crypto map my_crypto_map 10
   set algorithm 40-bit-des
   set peer r6-2500
   match address 128
  !
  interface Loopback0
   ip address 1.1.6.1 255.255.255.0
  !
  interface Tunnel0
   ip address 5.5.5.1 255.255.255.0
   tunnel source Loopback0
   tunnel destination 2.2.6.3
   crypto map my_crypto_map
  !
    interface Ethernet0
   ip address 1.1.1.1 255.255.255.0
   description inside interface
   media-type 10BaseT
   crypto map my_crypto_map
  !
  !
  interface Serial0
   encapsulation frame-relay
   no ip route-cache
  !
  interface Serial0.1 point-to-point
  description outside interface
   ip address 8.8.8.1 255.255.255.0
   frame-relay interface-dlci 100   
  !
  !ip classless
  ip route 0.0.0.0 0.0.0.0 1.1.1.2
  ip route 7.0.0.0 255.0.0.0 5.5.5.2
  
  access-list 128 permit gre host 1.1.6.1 host 2.2.6.3
  !

R1-AGS
!
  hostname R1-AGS
  !
  interface Ethernet0
   ip address 1.1.1.2 255.255.255.0
  !
  interface Serial1
   ip address 2.2.5.2 255.255.255.0
  !
  ip classless
  ip route 1.0.0.0 255.0.0.0 1.1.1.1
  ip route 2.0.0.0 255.0.0.0 2.2.5.3

R6-2500
hostname R6-2500
  !
  crypto public-key r3-4k 04D6265A
   512A7D84 43C348B7 959D2FE2 3122B285 FDA2A362 7272A835 84D03134 DB160DE1 
   27CA2D24 D6C23EFE 3BE25A95 D62EA30B 0F2C3BA8 9AB6DB82 D8127238 266AC987
   quit
  ! 
  crypto map my_crypto_map 10
   set algorithm 40-bit-des
   set peer r3-4k
   match address 128
  !
  interface Loopback0
   ip address 2.2.6.3 255.255.255.0
  !
  interface Tunnel0
   ip address 5.5.5.2 255.255.255.0
   tunnel source Loopback0
   tunnel destination 1.1.6.1
   crypto map my_crypto_map
  !
  interface Ethernet 0
  description inside interface
   ip address 7.7.7.3 255.255.255.0
  !
  interface Serial0
  description outside interface
   ip address 2.2.5.3 255.255.255.0
   crypto map my_crypto_map
  !
  ip classless
  ip route 0.0.0.0 0.0.0.0 2.2.5.2
  ip route 7.0.0.0 255.0.0.0 7.7.7.0
  ip route 8.0.0.0 255.0.0.0 5.5.5.1
  !
  access-list 128 permit gre host 2.2.6.3 host 1.1.6.1

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 14120