Voz : CCS Digital

VoIP com Common Channel Signaling (CCS)

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice

CCS
CAS

Introdução

Este documento ilustra as configurações necessárias para os dois Roteadores neste documento comunicar-se através da Voz sobre IP (VoIP) e do Common Channel Signaling (CCS) sobre um PRI digital.

É importante notar que nesta configuração, os dois Roteadores são lado a lado conectado sobre um segmento IP. Na maioria de topologias contudo, o Roteadores ativado por voz pode existir em qualquer lugar. Geralmente, os roteadores de voz são conectados por conectividade LAN a outros roteadores que estão conectados à WAN. Isto é importante de notar porque se seu Roteadores da Voz não é conectado sobre uma linha alugada, todos os comandos configuration da conectividade de WAN são configurados naquele Roteadores que é conectado a WAN, e não no Roteadores da Voz, porque estão nas configurações neste documento.

Quando um Cisco 3640 Router e um Cisco AS5300 Router forem usados neste exemplo de configuração, estas configurações podem igualmente ser usadas para Cisco 2600 Series Router.

Pré-requisitos

Requisitos

Antes que você possa configurar seu roteador Cisco para usar VoIP, é o melhor se você compreende os conceitos de características do Qualidade de Serviço (QoS) no software do ½ do ¿  de Cisco IOSïÂ. Para aprender mais sobre características de QoS, refira o enfileiramento, o modelagem de tráfego, e a filtração e a Sinalização QoS da página de QoS do Cisco IOS no cisco.com.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Cisco 2600 e 3640 Series Router

  • Cisco AS5300

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Sinalização T1: CAS e CCS

Sinalizar no mundo da telefonia fornece funções tais como a supervisão e o anúncio da linha estado, alertando dispositivos quando um atendimento está tentando conectar, e distribuição e informação de endereçamento.

Há dois tipos diferentes de informação de sinalização dentro do mundo T1:

  • CCS

  • Sinalização associada a canal (CAS)

CCS

O CCS é a transmissão da informação de sinalização fora da faixa da informação. O formulário o mais notável e o mais amplamente utilizado deste tipo de sinalização é ISDN. Uma desvantagem ao uso de um ISDN PRI é a remoção de um DS0, ou canal de voz. Neste caso, para sinalizar o uso. Consequentemente, um T1 teria vinte e três DS0, ou canais B para dados do usuário, e um DS0, ou canal D para sinalizar. É possível às várias pris de controle com um único canal D com cada utilização não da sinalização associada da facilidade (NFAS). Consequentemente, você pode configurar os outros PRI no grupo NFAS para usar todos os twenty-four DS0 como os canais B. O uso da sinalização PRI assegura as taxas de conexão possíveis máximas, especialmente com o advento do Modems 56K. Isto ilustra a capacidade de canaleta desobstruída de ISDN.

Uma outra desvantagem de usar o CCS (como visto no diagrama da rede) é que o PBX precisa um cartão digital do T1 PRI, que seja mais caro do que um cartão da sinalização de E&M. Um cartão da sinalização de E&M está usado no mesmo diagrama da rede se você executa CAS entre o AS5300 e o PBX.

CAS

CAS é a transmissão da informação de sinalização dentro da faixa da informação, ou sinalização in-band. Isto significa que os sinais de voz viajam nos mesmos circuitos que a linha estado, endereço, e sinais de alerta. Porque há twenty-four canais em uma linha T1 cheia, os intercalamentos de CAS que sinalizam pacotes dentro dos pacotes de voz. Consequentemente, há os twenty-four canais completos a usar-se para a Voz.

Os vários tipos de sinalização de CAS estão disponíveis no mundo T1. Os formulários os mais comuns da sinalização de CAS são loopstart, groundstart, e sinalização de E&M. A desvantagem a mais grande da sinalização de CAS é que os bit dos usos da rede dos pacotes IP da informação, tais como pacotes de voz, para executar funções de sinalização. A sinalização de CAS é referida assim frequentemente como o robbed bit signaling.

CAS não é a escolha ideal quando uma tenta conseguir as taxas de conexão possíveis as mais altas com Modems. A maioria de Modems pode ajustar à qualidade de sinal e ainda dar conexões confiável de alta velocidade. Contudo, o uso do Modems 56K em CAS alinha gotas as velocidades de conexão por quase 2 K na direção fluxo abaixo de uma comunicação por tronco que use a sinalização de CAS.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/14079/voip_pri_cookbook_topo.gif

Configurações

Este documento utiliza as seguintes configurações:

Cisco 3640 SÃO JOSÉ
sanjose3640A#show run
Building configuration...
 
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 3640
!
logging buffered 60000 debugging
enable password cisco
!
no ip subnet-zero
!
!
!
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 3/0/0
 operation 4-wire
!
voice-port 3/0/1
 operation 4-wire
!
voice-port 3/1/0
!
voice-port 3/1/1
!
dial-peer voice 1 pots     

!--- More on dial peers.

 destination-pattern 4552468
 port 1/0/1
!
dial-peer voice 2 voip
 destination-pattern 3006
 session target ipv4:10.2.1.2
!
dial-peer voice 3 pots
 destination-pattern 5551234
 port 1/0/0
!
dial-peer voice 4 voip
 destination-pattern 4005
 fax-rate 9600
 session target ipv4:10.2.1.2
!
interface Ethernet0/0
 ip address 10.2.1.1 255.255.255.0
 no ip directed-broadcast
!
interface Serial2/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
 no fair-queue
 clockrate 64000
!
interface Serial2/1
 no ip address
 no ip directed-broadcast
 shutdown
 clockrate 38000
!
interface Serial2/2
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial2/3
 no ip address
 no ip directed-broadcast
 shutdown
!
ip classless
no ip http server
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
end

Cisco AS5300 Raleigh
AS5300#show run
Building configuration...
 
Current configuration:
!
version 11.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname AS5300
!
boot system flash c5300-js-mz_113-6_na2.bin
enable password cisco
!
isdn switch-type primary-dms100
!
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 1
 clock source internal
!
controller T1 2
 clock source internal
!
controller T1 3
 clock source internal
!
!
dial-peer voice 1 voip           

!--- More on dial peers.

 destination-pattern 4552468
 session target ipv4:10.2.1.1
!
dial-peer voice 2 pots
 destination-pattern 3...
 direct-inward-dial
 port 0:D
 prefix 3
!
dial-peer voice 4 pots
 destination-pattern 4...
 direct-inward-dial
 port 0:D
 prefix 4
!
dial-peer voice 3 voip
 destination-pattern 5551234
 fax-rate 9600
 session target ipv4:10.2.1.1
!
!
voice-port 0:D
!
interface Ethernet0
 ip address 10.2.1.2 255.255.255.0
!
interface Serial0:23
 no ip address
 isdn switch-type primary-dms100
 isdn tei-negotiation first-call
 isdn incoming-voice modem
 no cdp enable
!
interface FastEthernet0
 no ip address
 shutdown
!
ip classless
!
logging buffered 60000 debugging
!
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

Comandos para Troubleshooting

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Nota: Antes de emitir comandos de depuração, consulte as informações importantes sobre eles.

  • debugar o inout do ccapi do voip — Usado para seguir o trajeto da execução com o controle de chamada API, que serve como a relação entre o aplicativo da sessão de chamada e o software rede-específico subjacente. Você pode usar a saída deste comando compreender como os atendimentos são segurados pelo roteador.

  • debugar o vpm todo — Usado para permitir todos os comandos debug vpm: debugar o spi do vpm, debugar o sinal do vpm, e o debug vpm dsp.

    Nota: Isto debuga gerencie muita saída.

  • mostre a voz ativa do atendimento — Usado para indicar os índices da tabela de chamada ativa, que mostra todos os atendimentos atualmente conectou através do roteador.

  • mostre a Voz do histórico da chamada — Usado para indicar a tabela de histórico de chamadas. A tabela de histórico de chamadas contém uma lista de todos os atendimentos conectados através deste roteador em ordem de período descendente desde que VoIP foi permitido. Você pode indicar subconjuntos da tabela de histórico de chamadas usando palavras-chaves específicas.

  • porta de voz da mostra — Usado para indicar a informação de configuração sobre uma porta de voz específica.


Informações Relacionadas


Document ID: 14079