Voz : H.323

Compreendendo, Configurando e Troubleshooting da Indicação de Alocação de Recursos

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento descreve momentaneamente a necessidade para o monitor de alocação de recurso, como trabalha, como configurar-lo e pesquisá-lo defeitos, e alguns defeitos do ½ do ¿  de Cisco IOSï (erros) para olhar para.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Versão do Cisco IOS Software 12.2(1)

  • Cisco AS5300, 3660, 2611, 3640

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Conceitos de RAI

Para permitir que gatekeepers tomem decisões inteligentes de roteamento de chamadas, o gateway relata o status de sua disponibilidade de recursos para o seu gatekeeper. Os recursos que são monitorados são os canais DS0 e os canais DSP.

O gateway relata seu status de recurso ao porteiro com o uso do Resource Availability Indication RAS (RAI). Quando um recurso monitorado cai abaixo de um limiar configurável, o gateway envia um RAI ao porteiro que indica que o gateway é quase fora dos recursos. Quando os recursos disponíveis se cruzam então acima de um outro limiar configurável, o gateway envia um RAI que indique que a condição da prostração do recurso já não existe.

Esta característica foi incluída no Cisco IOS Software Release 12.0(5)T no gateway do Cisco AS5300, e no Cisco IOS Software Release 12.1(1)T para outros gateways na versão 2 de H.323.

H.225 Definição de RAI

O RAI é uma notificação de um gateway a um porteiro de sua capacidade de chamada atual para cada protocolo das H-séries e de taxa de dados para esse protocolo. O porteiro responde com um Resource Availability Confirmation (RAC) em cima de receber um RAI para reconhecer sua recepção.

A mensagem RAI inclui:

  • requestSeqNum

  • protocolIdentifier

  • nonStandardData

  • mais endpointIdentifier

  • protocolos

  • almostOutOfResources (TRUE, FALSE)

  • tokens, cryptoTokens

  • integrityCheckValue

A mensagem RAC inclui:

  • requestSeqNum

  • protocolIdentifier

  • nonStandardData

  • tokens

  • cryptoTokens

  • integrityCheckValue

Nota: Esta definição é do protocolo H.225. Na versão 2 de H.323 e na versão 3 de H.323, o RAI é usado para relatar que o gateway tem ou não tem os recursos para processar as chamadas VoIP entrantes. A capacidade de chamada vem na versão 4 de H.323.

Como o RAI funciona no Cisco Gateway e Gatekeeper

  • Os limiares de relatório de recursos são configurados por meio do comando resource threshold no gateway CLI. Os limiares superior e inferior são configuráveis de modo independente para impedir que o gateway opere esporadicamente devido à disponibilidade ou falta de recursos.

    resource threshold [all] [high percentage-value] [low percentage-value]

    O padrão para “alto” e valores " baixo " é 90.

    A utilização é calculada como considerado aqui:

    • Canais acessíveis = Em uso + Livre

    • Utilização = sem uso/acessível

    Quando você calcula a utilização, leve em consideração os canais acessíveis. Os canais deficientes não são contados. O comando show call resource voice stat mostra o número de "Canais Endereçáveis". Os canais endereçáveis são os canais que são associados com os POTS dial peer válidos (por exemplo, um POTS dial peer que seja parada programada não é considerado válido). Os canais endereçáveis não igualam necessariamente os canais acessíveis, desde que você pode ter desabilitado os canais endereçáveis (o controlador está para baixo, ou você busyout alguns dos DS0 como um exemplo).

    Por exemplo, supõe que você tem quatro T1s: dois T1s para chamadas recebidas, dois para que parte. Você ocupou 46 intervalos de tempo dos intervalos de tempo de saída e possui uma chamada em um dos intervalos de tempo de saída. Você terá:

    • Total = 96

    • Endereçável = 48

    • = 46 deficientes

    • Inuse = 1

    • Livre = 1

    A utilização = 1/(1+1)= 50 %. Assim se o limiar alto configurado é 90%, o gateway ainda aceita atendimentos.

    Se você tem "0" Inuse e os canais livres de "0", a seguir você bate imediatamente o limiar alto. Essa é a única forma de parar o envio de chamadas para esse gateway no caso de você precisar fazer a sua manutenção. As duas maneiras de fazer isto são a ocupado para fora todos os intervalos de tempo nas etapas, ou feche os POTS dial peer. Há um risco quando você usa o método dos POTS dial peer. Quando você fechou o correspondente de discagem de POTS, o gatekeeper talvez tenha roteado algumas chamadas para o gateway. Estes atendimentos são desligados com código da causa da desconexão dos “nenhuns circuitos disponíveis”. Isto acontece porque fechar o dial-peer afeta todos os canais configurados sob ele. A melhor maneira é ocupar um determinado número de timeslots até atingir o limiar alto. Uma vez que você alcança esse ponto, seja certo que o porteiro não enviar nenhuns atendimentos quando você ocupado para fora os outros intervalos de tempo.

  • Os cálculos acima tomaram somente os recursos DS0 na consideração. Contudo, os recursos de DSP são monitorados e calculados da mesma forma. Também, segundo que o recurso (DSP ou DS0) alcança o ponto baixo ou o limiar alto primeiramente, o gateway envia os mensagens de RAI.

  • Nenhuma configuração é precisada no porteiro de ativar o RAI.

  • Um mensagem de RAI, como todo o outro mensagem RAS, é UDP. Uma vez que o gateway envia um mensagem de RAI ao porteiro, começa um segundo temporizador três. Se o temporizador expira antes que receba o RAC, o gateway tenta enviar outra vez ao RAI nove mais vezes. Então, dá acima até a disponibilidade de recurso das alterações de status outra vez.

  • O RAI é útil se você quer dar a prioridade a um determinado gateway. Também, uma vez que o ponto inicial é alcançado, a seguir você distribui o tráfego a outros gateways.

  • O porteiro seleciona o gateway baseado na prioridade e no limite de recurso modem. Se todos os gateways têm a mesmos prioridade e recursos, o porteiro faz o Balanceamento de carga. Uma vez que um gateway é marcado como “fora dos recursos”, o porteiro põe o gateway no fundo da lista de prioridades (muda a prioridade de gateway a "1"). Se não há nenhum outro gateway com uma prioridade mais alta ou se todos os gateways nessa zona têm a prioridade "1", a seguir o porteiro ainda envia atendimentos ao gateway que enviou um mensagem de RAI que declara que é quase fora dos recursos.

  • Com o comando lrq reject-resource-low, o porteiro rejeita a chamada entre áreas se todos os gateways nessa zona são marcados como quase-para fora--recursos. Esse comando está integrado ao software Cisco IOS versão 12.1(3a)XI6. Se você não usa este comando, o porteiro não rejeita nenhuns atendimentos de outras zonas quando todos os gateways nessa zona são marcados como fora de recursos.

  • A prioridade do gateway padrão é 5. E o valor padrão pode ser alterado usando o comando zone prefix <nome do gatekeeper> <prefixo de E.164> gw-default-priority <prioridade 0 a 10>. Este comando é igualmente útil caso que você quer distribuir os atendimentos a determinados gateways para esse prefixo. Contudo, este não é o argumento para outro. Também, você não quer configurar cada outro gateway com prioridade "0" usando o comando zone prefix <gatekeeper name> <E.164 prefix> gw-priority.

Casos Práticos

/image/gif/paws/14075/ram.gif

Os atendimentos originam de PBX A no T1s conectado a 5300-4. O atendimento combina um VoIP dial-peer com o destino de sessão RAS. Na configuração 2611-gatekeeper, este atendimento é segurado pela zona B. O 2611-gatekeeper envia o LRQ ao porteiro 3660-2 na zona B e em um RASGO de volta a 5300-4.

O porteiro 3660-2 é configurado para distribuir esse atendimento com prioridade 10 ao 5300-3. A próxima prioridade é o 3640-3 (configurado como prioridade 9). Enquanto 5300-3 têm recursos, todos os atendimentos lhe estão distribuídos.

O porteiro 3660-2 envia o LCF com o 5300-3 como o gateway de destino. Quando 5300-3 recebem o mensagem setup, envia o ARQ a seu porteiro. Após o ACF, estabelece o segundo pé, que é um trecho de telefonia de FGB para PBX B.

Uma vez que 5300-3 são marcados como “sem recursos”, o porteiro 3660-2 na zona B abaixa a prioridade de 5300-3 a "1" e começa-a distribuir o tráfego ao gateway 3640-3 desde que tem uma prioridade mais alta de "9".

No este setup o 5300-3 tem 48 DS0 endereçável e é configurado com um alto valor de limiar de 70 por cento.

Os primeiros 34 atendimentos de PBX A fazem com que 34 DS0 sejam usados em 5300-3. O trigésimo quinto atendimento faz com que o 5300-3 enviem um mensagem de RAI ao porteiro que informa o que se torna sem recursos. O trinta-sexto atendimento e o que segue está distribuído ao 3640-3 enquanto o 5300-3 são ainda “sem recursos”.

Configuração 5300-3

!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 ds0-group 1 timeslots 1-24 type e&m-fgb dtmf dnis
!
controller T1 2
 framing esf
 clock source line secondary 1
 linecode b8zs
 ds0-group 1 timeslots 1-24 type e&m-fgb dtmf dnis
!
interface Ethernet0
 ip address 172.16.13.45 255.255.255.224
 load-interval 30
 h323-gateway voip interface
 h323-gateway voip id cisco_2 ipaddr 172.16.13.42 1718
 h323-gateway voip h323-id 5300-3
 h323-gateway voip tech-prefix 2#
!
voice-port 0:1
!
voice-port 2:1
!
dial-peer voice 11 pots
 incoming called-number .
 destination-pattern 2#987654
 direct-inward-dial
 port 0:1
 prefix 987654
!
dial-peer voice 12 pots
 destination-pattern 2#987654
 port 2:1
 prefix 987654
!
gateway 
 resource threshold high 70 low 60

!--- The gateway is configured for a high resource threshold 
!--- of 70% and low resource threshold of 60%.

!

Configuração do 3640-3

!
controller T1 2/0
 framing esf
 linecode b8zs
 ds0-group 0 timeslots 1-24 type e&m-wink-start
!
interface Ethernet0/0
 ip address 172.16.13.40 255.255.255.224
 half-duplex
 h323-gateway voip interface
 h323-gateway voip id cisco ipaddr 172.16.13.50 1718
 h323-gateway voip id cisco_2 ipaddr 172.16.13.42 1718
 h323-gateway voip h323-id 3640-3
 h323-gateway voip tech-prefix 2#
!
voice-port 2/0:0
! 
dial-peer voice 987654 pots
 destination-pattern 2#987654
 port 2/0:0
 prefix 987654
!
gateway 

!--- No resource monitor is configured on this gateway in this lab setup.

!

3660-2 Configuração do Gatekeeper

!
interface FastEthernet0/0
 ip address 172.16.13.42 255.255.255.224
 duplex auto
 speed auto
!
gatekeeper
 zone local cisco_2 cisco.com 172.16.13.42
 zone remote cisco cisco.com 172.16.13.50 1719
 zone prefix cisco 1*
 zone prefix cisco_2 9* gw-priority 10 5300-3
 
!--- 5300-3 is configured for priority 10 for this prefix.

 zone prefix cisco_2 9* gw-priority 9 3640-3
 gw-type-prefix 2#* default-technology
 no shutdown
!

Configuração do 5300-4

!
controller E1 0
 clock source line primary
 ds0-group 0 timeslots 1-15,17-31 type r2-digital r2-compelled 
 cas-custom 0
!
controller E1 1
 clock source line secondary 1
 ds0-group 1 timeslots 1-15,17-31 type r2-digital r2-compelled 
 cas-custom 1
!
controller E1 2
 clock source line secondary 2
 ds0-group 2 timeslots 1-15,17-31 type r2-digital r2-compelled 
!
controller E1 3
 clock source line secondary 3
 ds0-group 3 timeslots 1-15,17-31 type r2-digital r2-compelled 
!
interface Ethernet0
 ip address 172.16.13.46 255.255.255.224
 no ip mroute-cache
 load-interval 30
 h323-gateway voip interface
 h323-gateway voip id cisco ipaddr 172.16.13.50 1718
 h323-gateway voip h323-id 5300-4
 h323-gateway voip tech-prefix 1#
!
voice-port 0:0
 compand-type a-law
!
voice-port 1:1
 compand-type a-law
!
voice-port 2:2
 compand-type a-law
!
voice-port 3:3
 compand-type a-law
!
dial-peer voice 1234 voip
 incoming called-number .
 destination-pattern 987654
 session target ras
 tech-prefix 2#
!
dial-peer voice 9876 pots
 incoming called-number .
 direct-inward-dial
!
gateway 
!

Configuração do gatekeeper 2611

!
interface Ethernet0/0
 ip address 172.16.13.50 255.255.255.224
 half-duplex
!
!
gatekeeper
 zone local cisco cisco.com 172.16.13.50
 zone remote cisco_2 cisco.com 172.16.13.42 1719
 zone prefix cisco 1* gw-priority 10 5300-4
 zone prefix cisco_2 9*
 gw-type-prefix 1#* default-technology
 no shutdown
!

Status do 5300-3 quando 34 chamadas são ativadas simultaneamente

Use o comando show pool do “do modo do dsprm teste” mostrar quantos DSP estão no uso.

dsprm 4> show pool
VFC-voice-pool      Total=120: free=86/86, in_use=34/34, pending=0/0, disabled=0/0

Use o comando show call resource voice stat do modo enable mostrar as estatísticas de todos os recursos (DSP e DS0).

Nesta saída, a utilização de DSP é 34/120= 28%, e a utilização DS0 é 34/48= 70%. O alto valor de limiar configurado em ambos os casos (utitlization DSP e DS0) não é excedido.

5300-3#show call resource voice stat

Resource Monitor -  Dial-up Resource Statistics Information:

DSP Statistics:

Utilization: 0 percent
Total channels: 120
Inuse channels: 34   

!--- Number of DSP channels used.

Disabled channels: 0
Pending channels: 0
Free channels: 86

DS0 Statistics:

Utilization: 0 percent
Total channels: 96
Addressable channels: 48
Inuse channels: 34 

!--- Number of DS0 channels used.
    
Disabled channels: 24
Free channels: 14

Use o comando show call resource voice threshold do modo enable verificar como mostrado o estado do ponto inicial no gateway aqui.

5300-3#show call resource voice threshold

Resource Monitor -  Dial-up Resource Threshold Information:

DS0 Threshold:

Client Type: h323
High Water Mark: 70
Low Water Mark: 60
Threshold State: low_threshold_hit

!--- DS0 threshold is still below the low value.


DSP Threshold:

Client Type: h323
High Water Mark: 70
Low Water Mark: 60
Threshold State: low_threshold_hit

!--- DSP threshold is still below the low value.

Use o comando show gateway verificar o estado do limite de recurso modem de H.323 se é permitido e active. Igualmente dá-lhe o ponto baixo e os altos valores de limiar configurados.

Nesta saída você pode ver que o limite de recurso modem está permitido e active. “Permitido” significa que configurado e o “Active” significa que os processos de H.323 RAS nos IO estão registrados com o monitor de recurso. Como um exemplo, se o gateway não é registrado com o porteiro, o processo de H.323 RAS não é inicializado e o limite de recurso modem é permitido, mas não ativo. A saída do comando é mostrada aqui.

5300-3#show gateway
 Gateway  5300-3  is registered to Gatekeeper cisco_2

Alias list (CLI configured) 
 H323-ID 5300-3
Alias list (last RCF) 
 H323-ID 5300-3

 H323 resource thresholding is Enabled and Active
 H323 resource threshold values:
  DSP: Low threshold 60, High threshold 70
  DS0: Low threshold 60, High threshold 70
5300-3#show gateway
 Gateway  5300-3  is not registered to any gatekeeper

Alias list (CLI configured) 
 H323-ID 5300-3
Alias list (last RCF) 
 H323-ID 5300-3

 H323 resource thresholding is Enabled but NOT Active
 H323 resource threshold values:
  DSP: Low threshold 60, High threshold 70
  DS0: Low threshold 60, High threshold 70

Status do 3660-2 Gatekeeper quando há 34 chamadas ativas simultâneas

Use o comando show gatekeeper gw-type-prefix verificar a prioridade dos gateways registrados com o porteiro. Veja se alguns são marcados como “sem recursos.”

Nesta saída, todos os gateways têm recursos e não há nenhuma “(sem recursos)” indicada, que significa que o 5300-3 ainda têm recursos.

3660-2#show gatekeeper gw-type-prefix 
GATEWAY TYPE PREFIX TABLE
=========================
Prefix: 2#*    (Default gateway-technology)
  Zone cisco_2 master gateway list:
    172.16.13.40:1720 6789 
    172.16.13.45:1720 5300-3
  Zone cisco_2 prefix 9* priority gateway list(s):
   Priority 10:
    172.16.13.45:1720 5300-3
   Priority 9:
    172.16.13.40:1720 6789 

Também, você pode usar o comando show gatekeeper endpoint ver se alguns dos gateways são embandeirados como fora dos recursos. Se o campo “F” tem a letra “O” sob ele para um gateway, a seguir esse porteiro recebeu um “para fora--recurso” RAI desse gateway.

3660-2#show gatekeeper endpoint
                    GATEKEEPER ENDPOINT REGISTRATION
                    ================================
CallSignalAddr       Port    RASSignalAddr    Port  Zone Name   Type  F 
-------------------- -----  ----------------  ------ ---------- -------    --
172.16.13.40         1720    172.16.13.40     52975   cisco_2   VOIP-GW  
    E164-ID: 6789
    E164-ID: 11
    E164-ID: 336699
    H323-ID: 3640-3
172.16.13.45         1720   172.16.13.45    58131   cisco_2     VOIP-GW  
    H323-ID: 5300-3
Total number of active registrations = 2

Status do 5300-3 quando há 35 chamadas ativas simultaneamente

Nesta saída, a utilização de DSP é 35/120= 29%, e a utilização DS0 é 35/48= 73%. O valor do limiar alto configurado para os canais DS0 é excedido. Também, um mensagem de RAI com o campo " fora de recurso " “VERDADEIRO” é enviado ao porteiro. Isto indica que o gateway não pode aceitar any more atendimentos.

dsprm 4>show pool
VFC-voice-pool      Total=120: free=85/85, in_use=35/35, pending=0/0, disabled=0/0

5300-3#show call resource voice stat

Resource Monitor -  Dial-up Resource Statistics Information:

DSP Statistics:

Utilization: 0 percent
Total channels: 120
Inuse channels: 35
Disabled channels: 0
Pending channels: 0
Free channels: 85

!--- Number of used DSPs is 35.


DS0 Statistics:

Utilization: 0 percent
Total channels: 96
Addressable channels: 48
Inuse channels: 35
Disabled channels: 24
Free channels: 13

!--- Number of used DS0s is 35.

Como você pode ver aqui, o gateway para bater o alto valor de limiar para os canais DS0.

No este output a letra “O” sob o campo " f " indica que o gateway 5300-3 é sem recursos.

5300-3#show call resource voice threshold

Resource Monitor -  Dial-up Resource Threshold Information:

DS0 Threshold:

Client Type: h323
High Water Mark: 70
Low Water Mark: 60
Threshold State: high_threshold_hit

!--- The DS0 resources reached the high threshold value.


DSP Threshold:

Client Type: h323
High Water Mark: 70
Low Water Mark: 60
Threshold State: low_threshold_hit

E no porteiro, você vê que o gateway 5300-3 está marcado como “sem recursos”.

3660-2#show gatekeeper gw-type-prefix 
GATEWAY TYPE PREFIX TABLE
=========================
Prefix: 2#*    (Default gateway-technology)
  Zone cisco_2 master gateway list:
    172.16.13.40:1720 6789 
    172.16.13.45:1720 5300-3 (out-of-resources)
  Zone cisco_2 prefix 9* priority gateway list(s):
   Priority 10:
    172.16.13.45:1720 5300-3 (out-of-resources)
   Priority 9:
    172.16.13.40:1720 6789

!--- 5300-3 is out-of-resources.

3660-2#show gatekeeper endpoint
                    GATEKEEPER ENDPOINT REGISTRATION
                    ================================
CallSignalAddr     Port  RASSignalAddr  Port   Zone Name  Type    F 
-----------------  ----- -------------- ------ ---------- ------- --
172.16.13.40       1720  172.16.13.40   52975   cisco_2   VOIP-GW  
  E164-ID: 6789
  E164-ID: 11
  E164-ID: 336699
  H323-ID: 3640-3
172.16.13.45       1720  172.16.13.45   58131  cisco_2   VOIP-GW O
  H323-ID: 5300-3
Total number of active registrations = 2

Debugs

Ative o ras de depuração e depure o asn1 do h225 se achar que o gateway não está enviando a mensagem RAI adequada ou que o gatekeeper não está enviando a mensagem RAC.

Nota:  debugar o asn1 h225 é verboso. Você tem que consequentemente ser cuidadoso quando você o gerencie sobre, especialmente quando o porteiro ou o gateway estão na produção e está segurando muitos atendimentos. O asn1 debugar h225 mostra todas as mensagens H.225 (não somente RAS). Esta é a saída destes debuga no porteiro 3660-2 depois que trinta e cinco atendimentos estão acima:

No este output o campo " quasesemrecursos " é “VERDADEIRO”. Isto significa os relatórios do gateway ao porteiro que é fora dos recursos. Quando o gateway bate o valor de limiar baixo, envia um outro mensagem de RAI. Contudo, com este campo “FALSO”, diz o porteiro para começar enviar outra vez atendimentos. Todos os mensagens RAS como um número de sequência e toda a resposta a estas mensagens levam o mesmo número de sequência.

RAW_BUFFER::=
81 340000A1 06000891 
*Mar  5 11:26:02.961: PDU DATA = 60E28808

value RasMessage ::= resourcesAvailableIndicate : 
                     
!--- RAI message.

    {
      requestSeqNum 162
      
!--- Sequence number of the H.225 message.

      protocolIdentifier { 0 0 8 2250 0 2 }
      endpointIdentifier {"6165B9D400000006"}
      protocols 
      {
        voice : 
        {
          supportedPrefixes 
          {

            {
              prefix e164 : "2#"
            }
          }
        }
      }
      almostOutOfResources TRUE
      
!--The value of  almostOutOfResources.

    }
*Mar  5 11:26:02.965: RAI (seq# 162) rcvd

Este é o mensagem de RAC enviado do porteiro ao gateway que reconhece sua recepção do mensagem de RAI.

PDU DATA = 60E28808

value RasMessage ::= resourcesAvailableConfirm : 
                     
!--- RAC message.

    {
      requestSeqNum 162
      
!--- Sequence number of the H.225 message.

      protocolIdentifier { 0 0 8 2250 0 2 }
    }


RAW_BUFFER::=
82 0A0000A1 06000891 4A0002
*Mar  5 11:26:02.965: 
*Mar  5 11:26:02.965:       RASLib::RASSendRAC: RAC (seq# 162) sent to 172.16.13.45

Alguns erros a serem observados

Estes são algum do Bug da Cisco ID que esteve em Plataformas diferentes. Quase todos estão resolvidos, mas ajudaria caso você tivesse um problema com o RAI para ver se você está executando em algum destes.

Nota: Você pode alcançar este o Bug da Cisco ID com o Bug Toolkit (clientes registrados somente).

  • CSCds41207

  • CSCds79319

  • CSCds90317

  • CSCdt00087

  • CSCdt68781

  • CSCdt77870

  • CSCdt93779

  • CSCdu55874

  • CSCdu76312

  • CSCdu79860


Informações Relacionadas


Document ID: 14075