IP : Integrated Intermediate System-to-Intermediate System (IS-IS)

Configurando IS-IS para IP em Cisco Routers

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

O propósito deste documento é demonstrar uma configuração básica de Sistema Intermediário para Sistema Intermediário (IS-IS) de IP nos Cisco routers. Além do que a configuração, como monitorar a vária informação IS-IS é demonstrada, como a informação de eleição do Designated Intermediate System (DIS) e a informação de base de dados IS-IS.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

A informação neste documento é baseada no Software Release 12.1(5)T9 do � do Cisco IOS.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Exemplo de configuração do IS-IS

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

A fim permitir o IS-IS para o IP em um roteador Cisco e mandá-lo trocar a informação de roteamento com outros roteadores ativado IS-IS, você deve executar estas duas tarefas:

  • Habilite o processo IS-IS e atribua a área

  • Habilitar IS-IS para IP Routing em uma interface

Outras tarefas de configuração são opcionais, no entanto as duas tarefas acima são obrigatórias. Para obter mais informações sobre das tarefas da configuração opcional, refira configurar o IS-IS integrado.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/13795/is-is-ip-config.jpg

Configurações

Este documento utiliza as seguintes configurações:

As configurações de amostra abaixo configuram todo o Roteadores na topologia acima com estes parâmetros:

  • Área 49.0001

  • Roteadores do nível 1 (L1) e do nível 2 (L2) (este é o padrão salvo disposição em contrário)

  • Nenhum parâmetro opcional

  • Executando IS-IS somente para IP

  • Interfaces de loopback (os laços de retorno são anunciados pelo IS-IS, não pelo IS-IS permitidos)

Roteador 1
!
interface Loopback0
ip address 172.16.1.1 255.255.255.255

!--- Creates loopback interface and assigns
!--- IP address to interface Loopback0.

!
interface Ethernet0
ip address 172.16.12.1 255.255.255.0
ip router isis 


!--- Assigns IP address to interface Ethernet0 
!--- and enables IS-IS for IP on the interface.

!
router isis
passive-interface Loopback0
net 49.0001.1720.1600.1001.00
!

!--- Enables the IS-IS process on the router, 
!--- makes loopback interface passive 
!--- (does not send IS-IS packets on interface), 
!--- and assigns area and system ID to router.

Roteador 2
!
interface Loopback0
ip address 172.16.2.2 255.255.255.255

!--- Creates loopback interface and assigns 
!--- IP address to interface Loopback0.

!
Interface Ethernet0
ip address 172.16.12.2 255.255.255.0
ip router isis

!--- Assigns IP address to interface Ethernet0 
!--- and enables IS-IS for IP on the interface.

!
Interface Serial0
ip address 172.16.23.1 255.255.255.252
ip router isis

!--- Assigns IP address to interface Serial0 
!--- and enables IS-IS for IP on the interface.

!
router isis 
passive-interface Loopback0
net 49.0001.1720.1600.2002.00
!

!--- Enables the IS-IS process on the router,
!--- makes loopback interface passive 
!--- (does not send IS-IS packets on interface), 
!--- and assigns area and system ID to router. 

Roteador 3
!
interface Loopback0
ip address 172.16.3.3 255.255.255.255 

!--- Creates loopback interface 
!--- and assigns IP address to 
!--- interface Loopback0.

!
Interface Serial0
ip address 172.16.23.2 255.255.255.252
ip router Isis

!--- Assigns IP address to 
!--- interface Serial0 and enables 
!--- IS-IS for IP on the interface.

!
router isis 
passive-interface Loopback0
net 49.0001.1234.1600.2231.00
!

!--- Enables the IS-IS process on the router, 
!--- makes loopback interface passive 
!--- (does not send IS-IS packets on interface), 
!--- and assigns area and system ID to router.

Monitorando IS-IS

Existem muitos comandos show disponíveis para o monitoramento do estado de IS-IS em um roteador Cisco. Este documento demonstra alguns dos comandos mais básicos que se baseiam nas configurações de roteador acima.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Monitorando adjacências IS-IS

Utilize o comando show clns neighbor para exibir as adjacências para um roteador específico. Esta é a saída deste comando do roteador1 (r1) e do roteador2 (R2):

R1# show clns neighbor
System Id   Interface  SNPA            State  Holdtime  Type Protocol
R2          Et0        0000.0c47.b947  Up     24        L1L2 ISIS
    
R2# show clns neighbor
System Id  Interface  SNPA             State  Holdtime  Type Protocol
R1         Et0        0000.0c09.9fea   Up     24        L1L2 ISIS
R3         Se0        *HDLC*           Up     28        L1L2 ISIS

No exemplo acima, R2 reconhece R2 em sua interface E0, com o tipo de adjacência L1L2. Como R1 e R2 estão definidos com configurações padrão, enviam e recebem hellos de L1 e L2.

R2 reconhece R1 em sua interface E0 e o Roteador 3 (R3) em sua interface S0. A explicação acima é válida para o tipo de adjacência.

Desde que o r1 e o R2 são na mesma interface Ethernet, hão um DIS para o L1 e o L2. Você pode verificar este que usa o comando show clns interface <int> no roteador1, como mostrado abaixo:

R1# show clns interface ethernet 0
Ethernet0 is up, line protocol is up
  Checksums enabled, MTU 1497, Encapsulation SAP
  Routing Protocol: ISIS
    Circuit Type: level-1-2
    Interface number 0x0, local circuit ID 0x1
    Level-1 Metric: 10, Priority: 64, Circuit ID: R2.01
    Number of active level-1 adjacencies: 1
    Level-2 Metric: 10, Priority: 64, Circuit ID: R2.01
    Number of active level-2 adjacencies: 1
    Next ISIS LAN Level-1 Hello in 5 seconds
    Next ISIS LAN Level-2 Hello in 1 seconds

Na saída acima, R2 é o DIS. É o R2 (DIS) que gera o LSP (Link State Packet) de pseudonó e que é indicado por um LSP-ID - R2.01 diferente de zero

Desde que o métricos/prioridade são os mesmos para ambo o Roteadores no L1/L2, o tiebreaker para o DIS é o endereço de pontos de ligação de subrede (SNPA) o mais alto no segmento de LAN. O endereço SNPA refere-se ao endereço do enlace de dados e, neste caso, é o endereço MAC. O outro exemplo de endereços do link de dados seria os endereços X.25 e o DLCI do Frame Relay.

Observe que o DIS está eleito para os dois níveis e que não existe nenhum backup de DIS, assim como com o OSPF, que tem um DR de backup.

Alguns outros pontos de interesse do saída acima incluem:

  • Tipo de circuito: L1L2

  • Prioridades e métricas L1 e L2 estão nos valores padrões: 10 e 64

  • Adjacências de L1 e L2: 1 (da perspectiva de R1 na interface Ethernet – é R2 somente)

  • saudações de IS-IS LAN para L1 e L2

  • Unidade de transmissão máxima (MTU): 1497. Isto é porque o encabeçamento do Open Systems Interconnection (OSI) IS-IS é encapsulado dentro 3 de um encabeçamento do byte 802.2.

Monitorando o banco de dados IS-IS

O comando show isis database (detail) exibe o conteúdo do banco de dados de IS-IS. Esta é a saída deste comando quando emitida no R2. Como o IS-IS é um protocolo de estado de link, o banco de dados de estado de link deve ser igual para qualquer roteador da mesma área.

R2# show isis database
ISIS Level-1 Link State Database:
LSPID         LSP Seq Num  LSP Checksum  LSP Holdtime    ATT/P/OL
R1.00-00      0x0000008B   0x6843        55              0/0/0
R2.00-00    * 0x00000083   0x276E        77              0/0/0
R2.01-00    * 0x00000004   0x34E1        57              0/0/0
R3.00-00      0x00000086   0xF30E        84              0/0/0
ISIS Level-2 Link State Database:
LSPID         LSP Seq Num  LSP Checksum  LSP Holdtime    ATT/P/OL
R1.00-00      0x00000092   0x34B2        41              0/0/0
R2.00-00    * 0x0000008A   0x7A59        115             0/0/0
R2.01-00    * 0x00000004   0xC3DA        50              0/0/0
R3.00-00      0x0000008F   0x0766        112             0/0/0

Há alguns detalhes a serem observados na saída acima. Primeiramente, sobre o LSP-ID:

O LSP-ID, R1.00-00, pode ser dividido em três seções: R1/00/00

  • R1 = ID do sistema

  • 00 = valor diferente de zero para o pseudonó. Observe que R2.01-00 é o pseudonó LSP.

  • 00 = número do fragmento. Neste caso, há somente uns números do fragmento de 00, que indica que todos os dados cabidos neste fragmento LSP, e não havia nenhuma necessidade de criar mais fragmentos. Se tiver havido informações que não se encaixem no primeiro LSP, o IS-IS terá criado mais fragmentos LSP, como 01, 02 e assim por diante.

* denota os LSP que foram gerados por este roteador, o roteador que o comando show esteve emitido sobre. Além disso, como esse roteador é um roteador L1 e L2, ele contém um banco de dados L1 e L2.

Você pode igualmente olhar um LSP específico e usar a palavra-chave do detalhe para mostrar mais informação. Um exemplo deste é mostrado aqui:

R2# show isis database R2.00-00 detail
ISIS Level-1 LSP R2.00-00
LSPID         LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
R2.00-00    * 0x00000093   0x077E        71            0/0/0
  Area Address: 49.0001
  NLPID:        0xCC
  Hostname: R2
  IP Address:   172.16.2.2 
  Metric: 10         IP 172.16.12.0 255.255.255.0
  Metric: 0          IP 172.16.2.2 255.255.255.255
  Metric: 10         IP 172.16.23.0 255.255.255.252
  Metric: 10         IS R2.01
  Metric: 10         IS R3.00
ISIS Level-2 LSP R2.00-00
LSPID         LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
R2.00-00    * 0x0000009A   0x5A69        103           0/0/0
  Area Address: 49.0001
  NLPID:        0xCC
  Hostname: R2
  IP Address:   172.16.2.2
  Metric: 10         IS R2.01
  Metric: 10         IS R3.00
  Metric: 10         IP 172.16.23.0 255.255.255.252
  Metric: 10         IP 172.16.1.1 255.255.255.255
  Metric: 10         IP 172.16.3.3 255.255.255.255
  Metric: 0          IP 172.16.2.2 255.255.255.255
  Metric: 10         IP 172.16.12.0 255.255.255.0

A saída acima mostra que o endereço de loopback desse roteador é anunciado com um valor de 0. Isso ocorre porque o circuito fechado foi anunciado com um comando passive-interface, sob o processo de IS-IS de roteador, e a própria interface de circuito fechado não está habilitada para IS-IS. Todos os outros prefixos de IP possuem o valor 10, que é o custo padrão nas interfaces que executam IS-IS.

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 13795