IP : Integrated Intermediate System-to-Intermediate System (IS-IS)

Tipos de rede e interfaces Frame Relay IS-IS

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

No protocolo do Intermediate System-to-Intermediate System (IS-IS), há dois tipos de rede: ponto a ponto e transmissão. Ao contrário do protocolo Open Shortest Path First (OSPF), o IS-IS não tem outros tipos de rede como, como os sem transmissão e ponto a multiponto. Para cada tipo de rede, um tipo diferente de pacote IS-IS Hello (IIH) é trocado para estabelecer adjacência. Em redes ponto a ponto, são trocados IIHs ponto a ponto; em redes de transmissão (tais como a LAN), são trocados IIHs da LAN nível 1 ou nível 2. Uma rede Frame Relay que esteja executando o IS-IS pode ser configurada para pertencer a um destes tipos de rede, dependendo do tipo de conectividade (malha integral, malha parcial ou Hub and Spoke) disponível entre os roteadores por meio da nuvem. Este documento dá um exemplo de não correspondência de configuração de tipo de rede nessa situação e mostra como diagnosticar e corrigir o problema.

Pré-requisitos

Requisitos

Os leitores deste documento devem estar cientes destes tópicos:

  • Configurando o Frame Relay

  • Configurando o IS-IS integrado

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

A saída mostrada neste documento é baseada nestes versão de software e hardware:

  • Cisco 2500 Series Routers

  • Software Release 12.2(27) do � do Cisco IOS

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Exemplo de configuração correta

O IS-IS trata interfaces serial multipontos e subinterfaces da mesma forma que trata interfaces de transmissão, mas trata uma subinterface Point-to-Point como se é anexado a uma rede Point-to-Point. Por exemplo, na topologia do exemplo de rede nesta seção, a conexão multiponto MACILENTO entre os três Roteadores inteiramente engrenados é tratada apenas como uma conexão de LAN. Como em um LAN, o nível 1 ou o nível 2 LAN IIH são trocados entre eles, e um Designated Intermediate System (DIS) é elegido.

Nesta topologia de exemplo, todos os três Roteadores estão conectando à perturbação do Frame Relay em interfaces ponto a multiponto ou em secundário-relação. Interfaces principal (como Serial1 no roteador E e o serial0 no roteador G) é multiponto à revelia. O Roteadores H e F tem uma conexão Point-to-Point por uma subinterface Point-to-Point, e usa IIH pontos a ponto.

/image/gif/paws/13794/isis-frint.gif

Estas são as configurações de roteador que são usadas nesta topologia de exemplo:

Roteador E
clns routing
!
interface Serial1
 ip address 10.10.10.1 255.255.255.0
 ip router isis
 encapsulation frame-relay
 clns router isis
 frame-relay map clns 123 broadcast
 frame-relay map clns 121 broadcast
 frame-relay map ip 10.10.10.3 121 broadcast
 frame-relay map ip 10.10.10.4 123 broadcast
 frame-relay lmi-type ansi
!
router isis
 net 49.0001.1111.1111.1111.00
 is-type level-1

Roteador G
clns routing
!
interface Serial0
 ip address 10.10.10.3 255.255.255.0
 ip router isis
 encapsulation frame-relay
 clns router isis
 frame-relay map clns 112 broadcast
 frame-relay map clns 113 broadcast
 frame-relay map ip 10.10.10.1 112 broadcast
 frame-relay map ip 10.10.10.4 113 broadcast
 frame-relay lmi-type ansi
!
router isis
 net 49.0001.3333.3333.3333.00
 is-type level-1

Roteador H
clns routing
!
interface Serial0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 encapsulation frame-relay
 frame-relay lmi-type ansi
!
interface Serial0.1 multipoint
 ip address 10.10.10.4 255.255.255.0
 no ip directed-broadcast
 ip router isis
 clns router isis
 frame-relay map clns 132 broadcast
 frame-relay map clns 131 broadcast
 frame-relay map ip 10.10.10.1 132 broadcast
 frame-relay map ip 10.10.10.3 131 broadcast
!
interface Serial0.2 point-to-point
 ip address 10.20.20.4 255.255.255.0
 no ip directed-broadcast
 ip router isis
 clns router isis
 frame-relay interface-dlci 130
!
router isis
 net 49.0001.4444.4444.4444.00
 is-type level-1

Roteador F
clns routing
!
interface Serial2
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 frame-relay lmi-type ansi
!
interface Serial2.1 point-to-point
 ip address 10.20.20.2 255.255.255.0
 no ip directed-broadcast
 ip router isis
 clns router isis
 frame-relay interface-dlci 103
!
router isis
 net 49.0001.2222.2222.2222.00
 is-type level-1

Emita os vizinhos dos clns da mostra, o banco de dados isis da mostra, e os comandos show isis database details em algum do Roteadores na malha, observar os efeitos da configuração IS-IS na conexão de WAN multiponto. Esta é a saída do comando show clns neighbors em todo o Roteadores:

Router_E# show clns neighbors

System Id      Interface   SNPA                State  Holdtime  Type Protocol
Router_G       Se1         DLCI 121            Up     29        L1   IS-IS
Router_H       Se1         DLCI 123            Up     7         L1   IS-IS

Router_G# show clns neighbors

System Id      Interface   SNPA                State  Holdtime  Type Protocol
Router_E       Se0         DLCI 112            Up     27        L1   IS-IS
Router_H       Se0         DLCI 113            Up     7         L1   IS-IS

Router_H# show clns neighbors

System Id      Interface   SNPA                State  Holdtime  Type Protocol
Router_E       Se0.1       DLCI 132            Up     23        L1   IS-IS
Router_F       Se0.2       DLCI 130            Up     25        L1   IS-IS
Router_G       Se0.1       DLCI 131            Up     28        L1   IS-IS

Router_F# show clns neighbors

System Id      Interface   SNPA                State  Holdtime  Type Protocol
Router_H       Se2.1       DLCI 103            Up     24        L1   IS-IS

A saída do banco de dados isis da mostra mostra que o roteador H é o DIS, com base no pacote de estado de enlace (LSP) ID do psuedonode:

Router_E# show isis database

IS-IS Level-1 Link State Database
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
Router_E.00-00      * 0x00000EA6   0xA415        54            10/0/0
Router_F.00-00        0x00000DD7   0xD76E        46            0/0/0
Router_G.00-00        0x00000DE7   0x780B        40            0/0/0
Router_H.00-00        0x00000DF0   0x4346        37            0/0/0
Router_H.01-00        0x00000DD5   0xFD1F        46            0/0/0

Router_G# show isis database

IS-IS Level-1 Link State Database
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
Router_E.00-00        0x00000E8F   0xD2FD        46            10/0/0
Router_F.00-00        0x00000DC0   0x0657        45            0/0/0
Router_G.00-00      * 0x00000DD0   0xA6F3        41            0/0/0
Router_H.00-00        0x00000DDA   0x6F30        42            0/0/0
Router_H.01-00        0x00000DBE   0x2C08        50            0/0/0

Router_H# show isis database

IS-IS Level-1 Link State Database
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
Router_E.00-00        0x000001EC   0x1D12        44            10/0/0
Router_F.00-00        0x00000124   0x63A2        54            0/0/0
Router_G.00-00        0x00000130   0x0C3B        33            0/0/0
Router_H.00-00      * 0x0000012F   0xEA6C        42            0/0/0
Router_H.01-00      * 0x00000123   0xBA21        43            0/0/0

Você pode igualmente examinar os detalhes do LSP para o psuedonode que é gerado pelo DIS. Nesta saída, o LSP de pseudo nó Router_H.01-00 representa WAN malha cheia, que mostra todo o Roteadores que está anexado à malha (apenas como o LSP de pseudo nó faz em um LAN):

Router_E# show isis database detail Router_H.01-00

IS-IS Level-1 LSP Router_H.01-00
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
Router_H.01-00        0x00000DD6   0xFB20        42            0/0/0
  Metric: 0  IS Router_H.00
  Metric: 0  IS Router_E.00
  Metric: 0  IS Router_G.00

Router_G# show isis database detail Router_H.01-00

IS-IS Level-1 LSP Router_H.01-00
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
Router_H.01-00        0x00000DBE   0x2C08        35            0/0/0
  Metric: 0  IS Router_H.00
  Metric: 0  IS Router_E.00
  Metric: 0  IS Router_G.00

Router_H# show isis database detail Router_H.01-00

IS-IS Level-1 LSP Router_H.01-00
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
Router_H.01-00      * 0x00000126   0xB424        55            0/0/0
  Metric: 0  IS Router_H.00
  Metric: 0  IS Router_G.00
  Metric: 0  IS Router_E.00

Problema de incompatibilidade de configuração

Esta seção examina a devido ao problema a um mau combinação da configuração. A secundário-relação Serial2.1 do roteador F é mudada de point-to-multipoint ponto a ponto, para introduzir um problema entre o Roteadores F e H. Como é mostrado na saída seguinte, a configuração do roteador F foi mudada quando o roteador H ainda conectar ao roteador F através de uma subinterface Point-to-Point.

Roteador H
clns routing
!
interface Serial0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 encapsulation frame-relay
 frame-relay lmi-type ansi
!
interface Serial0.1 multipoint
 ip address 10.10.10.4 255.255.255.0
 no ip directed-broadcast
 ip router isis
 clns router isis
 frame-relay map clns 132 broadcast
 frame-relay map clns 131 broadcast
 frame-relay map ip 10.10.10.1 132 broadcast
 frame-relay map ip 10.10.10.3 131 broadcast
!
interface Serial0.2 point-to-point
 ip address 10.20.20.4 255.255.255.0
 no ip directed-broadcast
 ip router isis
 clns router isis
 frame-relay interface-dlci 130
!
router isis
 passive-interface Ethernet0
 net 49.0001.4444.4444.4444.00
 is-type level-1

Roteador F
clns routing
!
interface Serial2
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 frame-relay lmi-type ansi
!
interface Serial2.1 multipoint
 ip address 10.20.20.2 255.255.255.0
 no ip directed-broadcast
 ip router isis
 clns router isis
 frame-relay interface-dlci 103
!
router isis
 net 49.0001.2222.2222.2222.00
 is-type level-1

Agora, o roteador H já não vê o roteador F como um vizinho IS-IS.

Router_H# show clns neighbors

System Id      Interface   SNPA                State  Holdtime  Type Protocol
Router_E       Se0.1       DLCI 132            Up     23        L1   IS-IS
Router_G       Se0.1       DLCI 131            Up     22        L1   IS-IS

O roteador F vê o roteador H como um vizinho; mas o IS-IS do tipo adjacente em vez do L1, e o protocolo são o System-to-Intermediate System da extremidade (ES-IS) em vez do IS-IS. Isto significa que o roteador F tem um problema de adjacência.

Router_F# show clns neighbors

System Id      Interface   SNPA                State  Holdtime  Type Protocol
Router_H       Se2.1       DLCI 103            Up     272       IS   ES-IS

Causa do problema

O problema revolve em torno do fato de que o roteador F envia LAN IIH em sua subinterface multiponto e o roteador H envia IIH de série em sua subinterface Point-to-Point. Quando você ativa debugar pacotes ajuste isis no roteador H, você pode ver que envia o IIH de série sobre Serial0.2. Contudo, você não vê nenhuns IIH vir através de Serial0.2, embora o roteador F esteja enviando LAN IIH em Serial2.1.

Router_H# debug isis adj-packets

IS-IS Adjacency related packets debugging is on
*Mar  2 01:11:10.065: ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1),
cir type L1, cir id4444.01, length 1500
*Mar  2 01:11:11.421: ISIS-Adj: Sending L1 LAN IIH on Serial0.1, length 1500
*Mar  2 01:11:11.961: ISIS-Adj: Rec L1 IIH from DLCI 132 (Serial0.1),
cir type L1, cir id4444.01, length 1500
*Mar  2 01:11:14.657: ISIS-Adj: Sending L1 LAN IIH on Serial0.1, length 1500
*Mar  2 01:11:15.205: ISIS-Adj: Sending serial IIH on Serial0.2, length 1499
*Mar  2 01:11:17.237: ISIS-Adj: Sending L1 LAN IIH on Serial0.1, length 1500
*Mar  2 01:11:18.765: ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1),
cir type L1, cir id4444.01, length 1500
*Mar  2 01:11:20.181: ISIS-Adj: Sending L1 LAN IIH on Serial0.1, length 1500
*Mar  2 01:11:21.861: ISIS-Adj: Rec L1 IIH from DLCI 132 (Serial0.1),
cir type L1, cir id4444.01, length 1500
*Mar  2 01:11:22.717: ISIS-Adj: Sending L1 LAN IIH on Serial0.1, length 1500
*Mar  2 01:11:24.073: ISIS-Adj: Sending serial IIH on Serial0.2, length 1499
*Mar  2 01:11:25.845: ISIS-Adj: Sending L1 LAN IIH on Serial0.1, length 1500
*Mar  2 01:11:27.289: ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1),
cir type L1, cir id4444.01, length 1500
*Mar  2 01:11:28.637: ISIS-Adj: Sending L1 LAN IIH on Serial0.1, length 1500
*Mar  2 01:11:31.853: ISIS-Adj: Sending L1 LAN IIH on Serial0.1, length 1500
*Mar  2 01:11:31.865: ISIS-Adj: Rec L1 IIH from DLCI 132 (Serial0.1),
cir type L1, cir id4444.01, length 1500
*Mar  2 01:11:33.181: ISIS-Adj: Sending serial IIH on Serial0.2, length 1499
*Mar  2 01:11:35.165: ISIS-Adj: Sending L1 LAN IIH on Serial0.1, length 1500

Quando você ativa mesmo debuga no roteador F, você pode ver que o roteador F está recebendo os IIH de série do roteador H em sua relação Serial2.1, mas está ignorando os hellos. O LAN IIH que o roteador F está tentando enviar é deixado cair com falhas de encapsulamento.

Router_F# debug isis adj-packets

IS-IS Adjacency related packets debugging is on
*Mar  2 01:19:15.113: ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1),
cir type L1, cir id 00, length 1499
*Mar  2 01:19:15.117: ISIS-Adj: Point-to-point IIH received
on multi-point interface: ignored IIH
*Mar  2 01:19:17.177: ISIS-Adj: Encapsulation failed for L1 LAN IIH on Serial2.1
*Mar  2 01:19:20.305: ISIS-Adj: Encapsulation failed for L1 LAN IIH on Serial2.1
*Mar  2 01:19:22.813: ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1),
cir type L1, cir id 00, length 1499
*Mar  2 01:19:22.817: ISIS-Adj: Point-to-point IIH received
on multi-point interface: ignored IIH
*Mar  2 01:19:23.229: ISIS-Adj: Encapsulation failed for L1 LAN IIH on Serial2.1
*Mar  2 01:19:26.157: ISIS-Adj: Encapsulation failed for L1 LAN IIH on Serial2.1
*Mar  2 01:19:28.825: ISIS-Adj: Encapsulation failed for L1 LAN IIH on Serial2.1
*Mar  2 01:19:30.833: ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1),
cir type L1, cir id 00, length 1499
*Mar  2 01:19:30.837: ISIS-Adj: Point-to-point IIH received
on multi-point interface: ignored IIH
*Mar  2 01:19:31.849: ISIS-Adj: Encapsulation failed for L1 LAN IIH on Serial2.1
*Mar  2 01:19:34.929: ISIS-Adj: Encapsulation failed for L1 LAN IIH on Serial2.1
*Mar  2 01:19:38.029: ISIS-Adj: Encapsulation failed for L1 LAN IIH on Serial2.1

Esta é uma análise do que ocorre entre o Roteadores F e H quando os tipos de liink são combinados mal:

  • As adjacências de LAN utilizam um aperto de mão, que conduza a um de três estados possíveis: DOWN, INIT, ou UP.

  • Há umas falhas de encapsulamento para o IIHs de saída do nível 1 do roteador F na secundário-relação Serial2.1, porque não tem — sob a subinterface multiponto — um comando frame-relay map clns enviar o IS-IS PDU.

  • O roteador H não recebe nenhum LAN IIH do roteador F, porque o roteador F tem falhas de encapsulamento quando as envia.

  • O roteador F vê os IIH de série que vêm do roteador H, mas ignoram os hellos porque recebem hellos pontos a ponto em uma subinterface multiponto. O roteador F detecta que há algo que falta ou errado no IIH do roteador H, assim que o roteador F cria uma adjacência de LAN mas considera-a ser aprendido com o ES-IS, um pouco do que L1 de um tipo adjacência com IS-IS.

Solução

A solução é assegurar-se de que os ambos os lados de um link sejam pontos a ponto ou multipontos. Neste caso, mude a secundário-relação Serial2.1 do roteador F de volta a ponto a ponto, para combinar isso que é configurado na relação de Serial0.2 do roteador H. Depois que a mudança, bate a relação.

O resultado do debug seguinte mostra o que acontece depois que você faz a mudança e a relação de Serial2 no roteador F está batida. Agora o roteador F pode enviar e para receber IIH de série em seu Serial2.1 conecte.

Router_F# debug isis adj-packets

*Mar  2 04:32:37.276: %LINK-5-CHANGED: Interface Serial2,
changed state to administratively down
*Mar  2 04:32:38.316: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2,
changed state to down
*Mar  2 04:32:45.868: %LINK-3-UPDOWN: Interface Serial2, changed state to up
*Mar  2 04:32:46.868: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2,
changed state to up
*Mar  2 04:33:05.896: ISIS-Adj: Sending serial IIH on Serial2.1, length 1499
*Mar  2 04:33:13.312: ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1),
cir type L1, cir id 00, length 1499
*Mar  2 04:33:13.316: ISIS-Adj: rcvd state DOWN, old state DOWN, new state INIT
*Mar  2 04:33:13.316: ISIS-Adj: Action = GOING UP, new type = L1
*Mar  2 04:33:13.320: ISIS-Adj: New serial adjacency
*Mar  2 04:33:13.324: ISIS-Adj: Sending serial IIH on Serial2.1, length 1499
*Mar  2 04:33:14.196: ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1),
cir type L1, cir id 00, length 1499
*Mar  2 04:33:14.204: ISIS-Adj: rcvd state INIT, old state INIT, new state UP
*Mar  2 04:33:14.204: ISIS-Adj: Action = GOING UP, new type = L1
*Mar  2 04:33:14.208: ISIS-Adj: L1 adj count 1
*Mar  2 04:33:14.212: ISIS-Adj: Sending serial IIH on Serial2.1, length 1499
*Mar  2 04:33:15.100: ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1),
cir type L1, cir id 00, length 1499
*Mar  2 04:33:15.100: ISIS-Adj: rcvd state UP, old state UP, new state UP
*Mar  2 04:33:15.104: ISIS-Adj: Action = ACCEPT
*Mar  2 04:33:22.924: ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1),
cir type L1, cir id 00, length 1499
*Mar  2 04:33:22.928: ISIS-Adj: rcvd state UP, old state UP, new state UP
*Mar  2 04:33:22.932: ISIS-Adj: Action = ACCEPT

Da perspectiva do roteador H, a configuração é de volta ao normal:

Router_H# show clns neighbors

System Id      Interface   SNPA                State  Holdtime  Type Protocol
Router_E       Se0.1       DLCI 132            Up     28        L1   IS-IS
Router_F       Se0.2       DLCI 130            Up     21        L1   IS-IS
Router_G       Se0.1       DLCI 131            Up     28        L1   IS-IS

A saída do comando debug isis adj packets também voltou ao normal:

Router_H# debug isis adj-packets

*Mar  2 04:40:19.376: ISIS-Adj: Sending L1 LAN IIH on Serial0.1, length 1500
*Mar  2 04:40:21.944: ISIS-Adj: Rec L1 IIH from DLCI 132 (Serial0.1),
cir type L1, cir id 4444.4444.01, length 1500
*Mar  2 04:40:22.020: ISIS-Adj: Sending L1 LAN IIH on Serial0.1, length 1500
*Mar  2 04:40:22.428: ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1),
cir type L1, cir id 4444.4444.01, length 1500
*Mar  2 04:40:24.740: ISIS-Adj: Sending L1 LAN IIH on Serial0.1, length 1500
*Mar  2 04:40:24.780: ISIS-Adj: Rec serial IIH from DLCI 130 (Serial0.2),
cir type L1, cir id 0ngth 1499
*Mar  2 04:40:24.784: ISIS-Adj: rcvd state UP, old state UP, new state UP
*Mar  2 04:40:24.784: ISIS-Adj: Action = ACCEPT
*Mar  2 04:40:26.068: ISIS-Adj: Sending serial IIH on Serial0.2, length 1499
*Mar  2 04:40:27.516: ISIS-Adj: Sending L1 LAN IIH on Serial0.1, length 1500
*Mar  2 04:40:30.432: ISIS-Adj: Sending L1 LAN IIH on Serial0.1, length 1500
*Mar  2 04:40:31.152: ISIS-Adj: Rec L1 IIH from DLCI 132 (Serial0.1),
cir type L1, cir id 4444.4444.01, length 1500
*Mar  2 04:40:31.540: ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1),
cir type L1, cir id 4444.4444.01, length 1500
*Mar  2 04:40:33.292: ISIS-Adj: Rec serial IIH from DLCI 130 (Serial0.2),
cir type L1, cir id 0ngth 1499
*Mar  2 04:40:33.296: ISIS-Adj: rcvd state UP, old state UP, new state UP
*Mar  2 04:40:33.296: ISIS-Adj: Action = ACCEPT
*Mar  2 04:40:33.664: ISIS-Adj: Sending L1 LAN IIH on Serial0.1, length 1500
*Mar  2 04:40:34.420: ISIS-Adj: Sending serial IIH on Serial0.2, length 1499
*Mar  2 04:40:36.328: ISIS-Adj: Sending L1 LAN IIH on Serial0.1, length 1500

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 13794