IP : Hot Standby Router Protocol (HSRP)

Compreendendo e configurando o comando ip unnumbered

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento explica o conceito de IP não numerado e fornece vários exemplos de configuração da referência. O comando ip unnumbered configuration permite habilitar o processamento de IP em uma interface serial sem atribuí-lo a um endereço IP explícito. A interface não numerada IP pode “pedir emprestado” o endereço IP de outra interface já configurada no roteador, o que conserva a rede e o espaço de endereço.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

O que é uma interface sem número?

Considere a rede mostrada abaixo. O roteador A tem uma interface serial S0 e uma interface Ethernet E0.

/image/gif/paws/13786/20a_new.gif

A relação do ethernet0 do roteador a pode ser configurada com um endereço IP de Um ou Mais Servidores Cisco ICM NT como mostrado abaixo:

interface Ethernet0
ip address 172.16.10.254 255.255.255.0

Logicamente, para permitir o IP na relação S0, você precisaria de configurar um endereço IP exclusivo nele. Contudo, é igualmente possível permitir o IP na interface serial e trazê-lo acima sem atribuir um endereço IP exclusivo a ele. Isto é feito pedindo um endereço IP de Um ou Mais Servidores Cisco ICM NT já configurado em uma de outras relações do roteador. Para fazer isto, o comando ip unnumbered interface mode é usado como mostrado abaixo.

interface Serial 0
ip unnumbered Ethernet 0

O comando de modo unnumbered da relação do <number> do <type> IP pede o endereço IP de Um ou Mais Servidores Cisco ICM NT da interface especificada à relação em que o comando foi configurado. O uso do comando ip unnumbered conduz ao endereço IP de Um ou Mais Servidores Cisco ICM NT que está sendo compartilhado por duas relações. Assim, em nosso exemplo, o endereço IP de Um ou Mais Servidores Cisco ICM NT que foi configurado na interface Ethernet é atribuído igualmente à interface serial, e a ambas as relações envolveu a função normalmente. Isto pode ser verificado usando a saída do comando show ip interface brief, como mostrado abaixo:

RouterA# show ip interface brief 

Interface    IP-Address      OK?    Method   Status   Protocol
Ethernet0    172.16.10.254   YES    manual   up       up
Serial0      172.16.10.254   YES    manual   up       up

Como você pode ver da saída do comando show ip interface brief acima, a interface serial tem um endereço IP de Um ou Mais Servidores Cisco ICM NT idêntico àquele da interface Ethernet, e ambas as relações são inteiramente - funcionais. A relação que pede seu endereço de uma de outras relações funcionais do roteador é chamada a “interface não numerada”. Em nosso exemplo, o Serial 0 é a interface não numerada.

A única desvantagem real de que a interface não numerada sofre é que é não disponível para o teste remoto e o Gerenciamento. Você deve igualmente recordar que a interface não numerada deve pedir seu endereço de uma relação que seja em serviço. Se a interface não numerada está apontando a uma relação que não seja funcional (isto é, que não mostra o “status da interface ACIMA”, “protocolo ACIMA”), a interface não numerada não trabalha. Isto é precisamente porque se recomenda que o ponto da interface não numerada a uma interface de loopback desde que os laços de retorno não falham. Finalmente, recorde que o comando ip unnumbered trabalha em interfaces Point-to-Point somente. _quando você configurar comando Multiaccess relação (isto é, Ethernet) ou interface de loopback, seguinte mensagem estar indicar:

RouterA(config)# int e0 
RouterA(config-if)# ip unnumbered serial 0 
Point-to-point (non-multi-access) interfaces only 
RouterA(config-if)# ip unnumbered loopback 0 
Point-to-point (non-multi-access) interfaces only  

IP e IP sem número

Em um Cisco Router, cada interface que se conecta a um segmento de rede deve pertencer a uma sub-rede exclusiva. Os roteadores conectados diretamente possuem interfaces que se conectam ao mesmo segmento de rede e que recebem endereços IP da mesma sub-rede. Se um roteador precisar enviar dados para uma rede que não esteja conectada diretamente, ele procura em sua tabela de roteamento e encaminha o pacote para o próximo salto conectado diretamente próximo ao destino. Se não houver nenhuma rota na tabela de roteamento, o roteador encaminhará o pacote ao gateway como último recurso. Quando um roteador diretamente conectado ao destino final recebe o pacote, ele entrega o pacote diretamente ao host final.

A tabela de IP Routing contém rotas de sub-rede ou rotas de rede principal. Cada rota tem um ou mais endereços do Next Hop diretamente anexados. As rotas de sub-rede são agregadas ou resumidas à revelia em limites de rede principais a fim reduzir o tamanho da tabela de roteamento.

Nota: O esquema de agregação discutido acima supõe um protocolo de roteamento de vetor de distância tradicional tal como o Routing Information Protocol (RIP) ou o Interior Gateway Routing Protocol (IGRP).

Deixe-nos considerar atribuir endereços IP de Um ou Mais Servidores Cisco ICM NT às relações de um roteador que usa uma rede de classe B que seja sub-rede usando oito bit do sub-rede. Toda interface requer uma sub-rede exclusiva. Embora cada conexão serial ponto a ponto possua apenas dois pontos finais para endereçar, se atribuirmos uma sub-rede inteira a cada interface serial, utilizamos 254 endereços disponíveis para cada interface quando apenas dois endereços são necessários. Se nós usamos o IP unnumbered em cada interface serial, nós salvar o espaço de endereços; o endereço de uma interface de LAN “é pedido” e usado como o endereço de origem para atualizações de roteamento e pacotes com origem da interface serial. Desta maneira, o espaço de endereços é conservado. IP sem número apenas faz sentido para enlaces ponto a ponto.

Um roteador que recebe uma atualização de roteamento instala o endereço de origem das atualizações como o novo salto em sua tabela de roteamento. Em geral, o Next Hop é um nó de rede conectado diretamente. Este não é mais o caso se usarmos o IP não numerado, porque cada interface serial "empresta" seus endereços IP de uma interface de LAN diferente, cada um em uma sub-rede diferente e possivelmente em uma rede principal diferente. Quando um IP não numerado é configurado, as rotas aprendidas por meio da interface IP não numerada colocam a interface como o próximo salto do endereço de origem da atualização de roteamento. Assim, evitamos um problema de Invalid Next Hop Address porque a origem da atualização de roteamento vem de um Next Hop que não está conectado diretamente.

Exemplos de configuração

Nota: A informação nestes exemplos de configuração é baseada na versão de software do½ do¿Â do Cisco IOSï 12.2(10b) e foi testada em Cisco 2500 Series Router.

Deixe-nos olhar quatro configurações de amostra diferentes para o IP unnumbered.

Nota: Nós poderíamos ter usado interfaces de loopback em vez das interfaces Ethernet.

Mesma rede principal, sub-redes diferentes

Figura 1 mostra que em ambos os lados do enlace serial nós temos a mesma rede principal com sub-redes diferentes.

Figura 1 – Diagrama da Rede

20a.gif

Router 1.1.1.1 Router 2.2.2.2
Current configuration:

interface Ethernet0
 ip address 171.68.178.196 255.255.255.192 

interface Serial0
 ip unnumbered Ethernet0

router igrp 10
 network 171.68.0.0 

Current configuration:

interface Ethernet 0
 ip address 171.68.179.1 255.255.255.192
 
interface Serial 0
 ip unnumbered Ethernet0 

router igrp 10
 network 171.68.0.0 

Router 1.1.1.1# show ip route

     171.68.0.0/26 is subnetted, 3 subnets
I       171.68.179.0 [100/8976] via 171.68.179.1, 00:00:02, Serial0
C       171.68.178.192 is directly connected, Ethernet0
I       171.68.0.0 [100/8976] via 171.68.179.1, 00:00:02, Serial0

Router 1.1.1.1# ping 171.68.179.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 171.68.179.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/30/32 ms


Router 2.2.2.2# show ip route

     171.68.0.0/26 is subnetted, 3 subnets
C       171.68.179.0 is directly connected, Ethernet0
I       171.68.178.192 [100/8976] via 171.68.178.196, 00:00:02, Serial0
I       171.68.0.0 [100/8976] via 171.68.178.196, 00:00:02, Serial0
     
Router 2.2.2.2# ping 171.68.178.196

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 171.68.178.196, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/32/32 ms

A informação de rota sobre sub-redes é mantida corretamente nesta encenação.

Redes principais diferentes, não sub-redes

Figura 2 mostra que em ambos os lados do enlace serial nós não temos redes principal diferentes e nenhuma sub-rede.

Figura 2 - Diagrama da rede

/image/gif/paws/13786/20b.gif

Router 1.1.1.1 Router 2.2.2.2
Current configuration:

interface Ethernet0
 ip address 171.68.178.196 255.255.0.0 

interface Serial0
 ip unnumbered Ethernet0 
 
router igrp 10
 network 171.68.0.0 
Current configuration:

interface Ethernet 0
 ip address 172.68.1.1 255.255.0.0 

interface Serial 0
 ip unnumbered Ethernet0 
 
router igrp 10
 network 172.68.0.0

Router 1.1.1.1# show ip route

C    171.68.0.0/16 is directly connected, Ethernet0
I    172.68.0.0/16 [100/8976] via 172.68.1.1, 00:01:26, Serial0

Router 1.1.1.1# ping 172.68.1.1

Sending 5, 100-byte ICMP Echos to 172.68.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/28 ms


Router 2.2.2.2# show ip route

I    171.68.0.0/16 [100/8976] via 171.68.178.196, 00:00:21, Serial0
C    172.68.0.0/16 is directly connected, Ethernet0

Router 2.2.2.2# ping 171.68.178.196

Sending 5, 100-byte ICMP Echos to 171.68.178.196, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/29/32 ms

Rede principal com sub-rede, rede principal sem sub-rede

Figura 3 mostra que em um lado do enlace serial nós temos uma rede principal com uma sub-rede, e na outra Rede Principal sem Sub-Rede do lado A.

Figura 3 – Diagrama da rede

/image/gif/paws/13786/20c.gif

Router 1.1.1.1 Router 2.2.2.2
Current configuration:

interface Ethernet0
 ip address 171.68.178.196 255.255.255.192

interface Serial0
 ip unnumbered Ethernet0 
 
router igrp 10
 network 171.68.0.0 
Current configuration:

interface Ethernet 0
 ip address 172.68.1.1 255.255.0.0

interface Serial 0
 ip unnumbered Ethernet0 
 
router igrp 10
 network 172.68.0.0

Router 1.1.1.1# show ip route

     171.68.0.0/26 is subnetted, 1 subnets
C       171.68.178.192 is directly connected, Ethernet0
I    172.68.0.0/16 [100/8976] via 172.68.1.1, 00:00:03, Serial0

Router 1.1.1.1# ping 172.68.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.68.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/31/32 ms


Router 2.2.2.2# show ip route

     171.68.0.0/16 is variably subnetted, 2 subnets, 2 masks
I       171.68.178.192/32 [100/8976] via 171.68.178.196, 00:00:48, Serial0
I       171.68.0.0/16 [100/8976] via 171.68.178.196, 00:00:48, Serial0
C    172.68.0.0/16 is directly connected, Ethernet0

Router 2.2.2.2# ping 171.68.178.196

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 171.68.178.196, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/29/32 ms

Nota: Antes da versão 11.0(2) do Cisco IOS Software, você é exigido pôr uma rota estática para a rede principal 171.68.0.0/16 no roteador 2.2.2.2.

Nessa situação, as informações de sub-rede são perdidas, pois são tratadas como uma rota de host. Na versão 11.0(2) e mais recente do Cisco IOS Software, o Interior Gateway Routing Protocol (IGRP) e o Routing Information Protocol (RIP) fixam este problema enviando a rota sumária para a rede principal através dos link Point-to-Point não numerados.

Duas redes principais diferentes e suas respectivas sub-redes

Figura 4 mostra que em ambos os lados do enlace serial nós temos duas redes principal diferentes com sub-rede respectiva.

Figura 4 – Diagrama da rede

/image/gif/paws/13786/20d.gif

Router 1.1.1.1 Router 2.2.2.2
Current configuration:

interface Ethernet0
 ip address 171.68.178.196 255.255.255.192 

interface Serial0
 ip unnumbered Ethernet0 
 
router igrp 10
 network 171.68.0.0
Current configuration:

interface Ethernet 0
 ip address 172.68.1.1 255.255.255.192 
 
interface Serial 0
 ip unnumbered Ethernet0 
 
router igrp 10
 network 172.68.0.0 

Router 1.1.1.1# show ip route

     171.68.0.0/26 is subnetted, 1 subnets
C       171.68.178.192 is directly connected, Ethernet0
     172.68.0.0/16 is variably subnetted, 2 subnets, 2 masks
I       172.68.0.0/16 [100/8976] via 172.68.1.1, 00:00:02, Serial0
I       172.68.1.0/32 [100/8976] via 172.68.1.1, 00:00:02, Serial0

Router 1.1.1.1# ping 172.68.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.68.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/81/280 ms


Router 2.2.2.2# show ip route

     171.68.0.0/16 is variably subnetted, 2 subnets, 2 masks
I       171.68.178.192/32 [100/8976] via 171.68.178.196, 00:00:22, Serial0
I       171.68.0.0/16 [100/8976] via 171.68.178.196, 00:00:22, Serial0
     172.68.0.0/26 is subnetted, 1 subnets
C       172.68.1.0 is directly connected, Ethernet0

Router 2.2.2.2# ping 171.68.178.196

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 171.68.178.196, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/31/32 ms

Nota: Nas versões do Cisco IOS anteriores à 11.0(2), você deve inserir uma rota estática para a rede principal 171.68.0.0/16 no Roteador 2.2.2.2 e a 172.68.0.0/16 no Roteador 1.1.1.1.

Nessa situação, as informações de sub-rede são perdidas, pois são tratadas como uma rota de host. No Cisco IOS Software versão 11.0(2) e posterior, o IGRP e o RIP corrigem esse problema, enviando a rota sumária da rede principal através de links ponta-a-ponta não-numerados.


Informações Relacionadas


Document ID: 13786