IP : Protocolo IP multicast

Por que o modo escasso de PIM não trabalha com uma rota estática em um endereço HSRP?

15 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento explica porque os pacotes de transmissão múltipla não são enviados quando você configura uma rota estática para o endereço do Hot Standby Router Protocol (HSRP) de um Protocol Independent Multicast (PIM) vizinho no modo escasso.

Pré-requisitos

Requisitos

Os leitores deste documento devem estar cientes destes tópicos:

  • HSRP

  • Modo escasso do PIM

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Diagrama de Rede

http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-multicast/13783-hsrpmcasta.gif

Na figura acima, o Roteadores 2 e 3 está falando o HSRP na sub-rede 10.1.3.0, e o roteador2 é o roteador ativo. O Roteadores 1, 2, e 3 estão falando o Enhanced Interior Gateway Routing Protocol (EIGRP), e Roteador4 tem uma rota padrão estática ao endereço virtual HSRP.

Configurações

Roteador 1 Roteador 2
Current configuration:

! 
ip multicast-routing 
! 
! 
interface Loopback0 
ip address 10.10.10.10 255.255.255.255 
no ip directed-broadcast 
! 
interface Ethernet0 
no ip address 
no ip directed-broadcast 
shutdown 
! 
interface Ethernet1 
ip address 10.1.1.1 255.255.255.0 
no ip directed-broadcast 
ip pim sparse-mode 
! 
interface Serial1 
no ip address 
no ip directed-broadcast 
encapsulation frame-relay 
! 
interface Serial1.1 point-to-point 
ip address 10.1.2.1 255.255.255.252 
no ip directed-broadcast 
ip pim sparse-mode 
frame-relay interface-dlci 612 
! 
! 
interface Serial1.2 point-to-point 
ip address 10.1.2.5 255.255.255.252 
no ip directed-broadcast 
ip pim sparse-mode 
frame-relay interface-dlci 613 
! 
router eigrp 1 
network 10.0.0.0 
no auto-summary 
! 
ip classless 
no ip http server 
ip pim rp-address 10.10.10.10 
! 

end
Current configuration:

! 
ip multicast-routing 
ip dvmrp route-limit 20000 
! 
! 
interface Ethernet1 
ip address 10.1.3.1 255.255.255.0 
no ip redirects 
ip pim sparse-mode 
standby 1 priority 110 preempt 
standby 1 ip 10.1.3.3 
! 
interface Serial1 
no ip address 
encapsulation frame-relay 
! 
interface Serial1.1 point-to-point 
ip address 10.1.2.2 255.255.255.252 
ip pim sparse-mode 
frame-relay interface-dlci 621 
! 
router eigrp 1 
network 10.0.0.0 
no auto-summary 
! 
ip classless 
ip pim rp-address 10.10.10.10 
!

end
Roteador 3 Roteador 4
Current configuration:

! 
ip multicast-routing 
ip dvmrp route-limit 20000 
! 
interface Ethernet1 
ip address 10.1.3.2 255.255.255.0 
no ip redirects 
ip pim sparse-mode 
standby 1 priority 100 preempt 
standby 1 ip 10.1.3.3 
! 
interface Serial1 
no ip address 
encapsulation frame-relay 
! 
interface Serial1.2 point-to-point 
ip address 10.1.2.6 255.255.255.252 
ip pim sparse-mode 
frame-relay interface-dlci 631 
! 
router eigrp 1 
network 10.0.0.0 
no auto-summary 
eigrp log-neighbor-changes 
! 
ip classless 
no ip http server 
ip pim rp-address 10.10.10.10 
!

end
Current configuration:

ip multicast-routing 
ip dvmrp route-limit 20000 
! 
! 
! 
interface Ethernet0 
ip address 10.1.4.1 255.255.255.0 
no ip directed-broadcast 
ip igmp join-group 239.1.2.3 
! 
interface Ethernet1 
ip address 10.1.3.4 255.255.255.0 
no ip directed-broadcast 
ip pim sparse-mode 
! 
no ip http server 
ip classless 
ip route 0.0.0.0 0.0.0.0 10.1.3.3 
ip pim rp-address 10.10.10.10 
!

end

A fim simular um host no ethernet0, o comando ip igmp join-group foi configurado nesta relação em Roteador4:

router4# ip igmp join-group 

IGMP Connected Group Membership 
Group Address Interface Uptime Expires Last Reporter 
224.0.1.40 Ethernet1 4d23h never 10.1.3.1 
239.1.2.3 Ethernet0 4d23h never 10.1.4.1 

O Roteador 4 também pode efetuar ping no endereço do ponto de reunião (RP):

Type escape sequence to abort. 

Sending 5, 100-byte ICMP Echos to 10.10.10.10, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/61/68 ms

Olhe a tabela da rota de transmissão múltipla (mrouter):

Router4# show ip mroute 239.1.2.3 

IP Multicast Routing Table 

Flags: D - Dense, S - Sparse, C - Connected, L - Local, P - Pruned 
R - RP-bit set, F - Register flag, T - SPT-bit set, J - Join SPT 
X - Proxy Join Timer Running 

Timers: Uptime/Expires 
Interface state: Interface, Next-Hop or VCD, State/Mode 
(*, 239.1.2.3), 00:04:28/00:00:00, RP 10.10.10.10, flags: SJCL 
Incoming interface: Ethernet1, RPF nbr 10.1.3.3 
Outgoing interface list: 
Ethernet0, Forward/Sparse, 00:02:12/00:02:53 

Porque há um receptor para este grupo (devido ao comando ip igmp join-group usado em Roteador4), construa a (*, G) entrada na tabela de mroute. Observe que o vizinho do Encaminhamento de caminho reverso (RPF) para a entrada (*.G) é 10.1.3.3, que é o endereço de standby do HSRP. Contudo, não há a (S, G) a entrada, que significa o tráfego não está sendo recebido da fonte.

Como o Roteador 4 tem um receptor interessado no grupo, ele poderá enviar uma mensagem de associação/remoção do PIM aos vizinhos do PIM. Utilize o comando show ip pim neighbor para exibir os vizinhos do PIM do roteador 4, como mostrado a seguir:

Router4# show ip pim neighbor 

PIM Neighbor Table 
Neighbor Address Interface Uptime Expires Ver Mode 
10.1.3.1 Ethernet1 4d23h 00:01:41 v2 
10.1.3.2 Ethernet1 4d23h 00:01:36 v2

Se o comando debug ip pim 239.1.2.3 estiver habilitado, o Roteador 4 estará criando esta mensagem PIM Join/Prune, mas, na verdade, ele não a enviará:

*6 de mar 18:32:48: PIM: O RP alcançável recebido na Ethernet1 de 10.10.10.10 *Mar 6 18:32:48: para o grupo 239.1.2.3 * 6 de março 18:33:14: PIM: Join/prune message de construção para 239.1.2.3 * 6 de março 18:34:13: PIM: Mensagem Building Join/Prune para 239.1.2.3

Por que o roteador não está enviando a mensagem Join/Prune? O RFC 2362leavingcisco.com indica que “um roteador envia um join/prune message periódico a cada vizinho distinto de RPF associado com o cada (S, G), (*, G) e (*, *, RP) entrada. Mensagens de junção e remoção são enviadas somente se o vizinho de RPF for um vizinho de PIM.

No exemplo, o vizinho do RPF é 10.1.3.3, que é o endereço em standby do HSRP usado pela rota estática padrão. No entanto, este endereço não está listado como um vizinho PIM. O motivo para o endereço em standby de HSRP não estar listado como um vizinho de PIM é devido ao fato dos dois roteadores executando HSRP (roteadores 2 e 3) não originarem as mensagens do vizinho PIM a partir do endereço em standby de HSRP.

Para resolver o problema, altere a configuração do Roteador 4, de modo que o vizinho de RPF também seja um vizinho de PIM. Para fazer isso, inclua o Roteador 4 no processo EIGRP, de modo que ele agora saiba o endereço RP por meio do EIGRP.

Nota: Como o Router 4 pode executar um Routing Protocol, ele não precisa contar com um HSRP Standby Address para conectividade. O objetivo do desenvolvimento do HSRP é oferecer aos hosts uma forma de obter redundância ou failover rápido e eficiente.

A nova configuração do Roteador 4 habilitada com EIGRP está apresentada a seguir.

ip multicast-routing 
ip dvmrp route-limit 20000 
! 
! 
! 
interface Ethernet0 
ip address 10.1.4.1 255.255.255.0 
no ip directed-broadcast 
ip igmp join-group 239.1.2.3 
! 
interface Ethernet1 
ip address 10.1.3.4 255.255.255.0 
no ip directed-broadcast 
ip pim sparse-mode 
!
router eigrp 1
network 10.0.0.0
no auto-summary
! 
no ip http server 
ip classless 
ip route 0.0.0.0 0.0.0.0 10.1.3.3 
ip pim rp-address 10.10.10.10 
!
end 

Nota: Em vez de incluir o roteador 4 no processo do EIGRP (o método preferido), adicione roteadores estáticos de multicast para o roteador 4 para fazer com que ele gere RPF para os endereços IP dos roteadores reais, pois os roteadores de multicast têm preferência em relação à tabela de Unicast Routing nas verificações de RPF. Por exemplo, adicionar o mrouter 0.0.0.0 0.0.0.0 10.1.3.2 IP.


Informações Relacionadas


Document ID: 13783