IP : Hot Standby Router Protocol (HSRP)

Compartilhamento de carga com HSRP

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Tradução Manual (22 Maio 2008) | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento mostra um exemplo de como configurar o protocolo HSRP (Hot Standby Router Protocol) para aproveitar os vários caminhos de um determinado destino.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Material de Suporte

O HSRP é geralmente usado para melhorar a elasticidade em redes, mas isso pode causar uma diminuição na eficiência da rede. O exemplo neste documento tem dois trajetos da rede do host à rede de servidor. Para a Redundância, o HSRP é executado entre o r1 e o R2, qualquer um de que pode se tornar o roteador ativo e tomar a “posse” do endereço IP de Um ou Mais Servidores Cisco ICM NT virtual HSRP. O segundo roteador transforma-se o roteador em standby, e transforma-se somente o roteador ativo se o roteador ativo atual vai para baixo. Para obter mais informações sobre dos roteadores ativo e em standby, refira como usar os comandos standby preempt e standby track.

O endereço de gateway padrão dos anfitriões é atribuído como seu endereço IP de Um ou Mais Servidores Cisco ICM NT virtual HSRP. Quando os hosts precisam enviar pacotes para a rede de servidores, eles os enviam para seu gateway padrão ou para qualquer roteador que estiver ativo. Porque somente um roteador é ativo, os pacotes dos anfitriões aos server atravessam somente um dos dois caminhos disponíveis.

Nota: O dependente em cima em como você configura o R3, os pacotes que retornam dos server aos anfitriões pôde ou não pôde utilizar ambos os caminhos de retorno. Também, os pacotes que retornam dos server aos anfitriões não precisam de atravessar o roteador ativo.

Para utilizar ambos os caminhos da rede do host para a rede do servidor, é possível configurar o HSRP multigrupo (MHSRP) entre R1 e R2. Essencialmente, o r1 é configurado com dois grupos HSRP (por exemplo, grupo1 e grupo2) e o R2 é configurado igualmente com os mesmos grupos HSRP. Para o grupo 1, R1 é o roteador ativo e R2 é o roteador em standby. Para o grupo 2, o R2 é o roteador ativo e o R1 é o roteador em standby. Então você configura a metade dos gateways padrão dos anfitriões com o endereço IP de Um ou Mais Servidores Cisco ICM NT virtual do grupo1 HSRP, e a outra metade dos gateways padrão dos anfitriões com o endereço IP de Um ou Mais Servidores Cisco ICM NT virtual do grupo2 HSRP.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/13781/7a.gif

Configurações

Este documento utiliza as seguintes configurações:

Configuração de R1 MHSRP
Current configuration:

interface Ethernet0
        ip address 171.16.6.5 255.255.255.0

        standby 1 preempt
        standby 1 ip 171.16.6.100
        standby 1 track Serial0
        standby 2 preempt
        standby 2 ip 171.16.6.200
        standby 2 track serial 0
        standby 2 priority 95

Configuração de R2 MHSRP
Current configuration:

interface Ethernet0
       ip address 171.16.6.6 255.255.255.0
       standby 1 preempt
       standby 1 ip 171.16.6.100
       standby 1 track Serial0
       standby 1 priority 95
       standby 2 preempt
       standby 2 ip 171.16.6.200
       standby 2 track serial 0

A observação das configurações que quando os dois Roteadores começam primeiramente a executar o HSRP, o r1 tem uma prioridade padrão de 100 para o grupo1 e uma prioridade de 95 para o grupo 2. R2 tem uma prioridade padrão de 100 para o grupo2 e uma prioridade de 95 para o grupo1. Consequentemente, o r1 é o roteador ativo para o grupo1 e o R2 é o roteador ativo para o grupo2. Este exemplo mostra que você pode realizar o compartilhamento de carga com MHSRP. Contudo, você precisa de usar a prioridade de HSRP e cancelar a fim realizar isto. O HSRP não tem efeito no tráfego de retorno. O trajeto tomado pelo tráfego de retorno depende do protocolo de roteamento configurado no roteador.

Nota: Quando o valor e os comandos standby preempt de prioridade em standby são configurados, é imperativo mencionar explicitamente o número do grupo. Se não mencionado, então o valor é 0 à revelia. O número de grupo padrão é 0.

Nota importante

Diversos controladores Ethernet (Lance e QUICC) em produtos low-end podem ter somente um único endereço Media Access Control (MAC) de envio único em seu filtro de endereço. Estas Plataformas permitem somente um único grupo HSRP, e mudam o endereço da relação ao endereço MAC virtual hsrp quando o grupo se torna ativo. O compartilhamento de carga em Plataformas com esta limitação não é possível com HSRP. O comando use-bia foi introduzido trabalhar em torno das edições que ocorrem quando você executa o HSRP nos produtos de extremidade baixa como mencionado. Por exemplo, se você executa o HSRP e o DECNet nas mesmas relações, os problemas ocorrem porque o DECNet e o HSRP tentam alterar o MAC address. Com o comando use-bia, você pode configurar o HSRP para usar o MAC address criado pelo processo do DECNet. Contudo, você deve estar ciente que há algumas desvantagens se você usa o comando use-bia, como:

  • Quando um roteador se torna ativo o endereço IP de Um ou Mais Servidores Cisco ICM NT virtual está movido para um MAC address diferente. O roteador recém-ativado envia uma resposta de ARP (protocolo de resolução de endereço) gratuita, mas nem todas as implementações de host tratam o ARP gratuito corretamente.

  • A configuração uso-BIA quebra o proxy ARP. Um roteador em standby não pode cobrir para a base de dados do proxy ARP perdida do roteador falho.

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 13781