IP : Hot Standby Router Protocol (HSRP)

Como usar os comandos standby preempt e standby track

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Tradução Manual (3 Abril 2008) | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento descreve como os comandos standby preempt e standby track trabalham juntos e quando cada um deve ser usado.

O comando standby preempt habilita o roteador do Hot Standby Router Protocol (HSRP) com a prioridade mais elevada para se tornar imediatamente o roteador ativo. A prioridade é determinada primeiro pelo valor de prioridade configurado e, em seguida, pelo endereço IP. Em cada caso, um valor mais alto é da maior prioridade. Quando um roteador mais prioritário cancela um roteador de baixa prioridade, o roteador envia um mensagem de vitória. Quando um roteador ativo de baixa prioridade recebe um mensagem de vitória ou um mensagem Hello Messages de um roteador ativo, mais prioritário, o roteador muda ao estado do discurso e envia uma mensagem da demissão.

O comando standby track permite especificar outra interface no roteador para o processo HSRP a ser monitorado, de forma a alterar a prioridade do HSRP para um determinado grupo. Se o protocolo de linha da interface especificada vai para baixo, a prioridade de HSRP está reduzida. Isto significa que um outro roteador de HSRP com prioridade mais alta pode se transformar o roteador ativo se esse roteador manda o apoio cancelar permitido.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Software Release 12.2(10b) do � do Cisco IOS

  • Cisco 2503 Routers

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Informações de Apoio

Este diagrama mostra um exemplo que use o comando standby preempt conjuntamente com o comando standby track.

6a.gif

Exemplos de configuração

No diagrama da rede, o HSRP é configurado desse modo:

  • O r1 é o roteador ativo e segue o estado da relação do serial0 do r1. Quando o r1 é o roteador ativo, todo o tráfego dos anfitriões (host 1, 2,3) aos server está distribuído com o r1.

  • O R2 é o roteador em standby e segue R2 o estado da relação da série 1.

  • Se a relação do serial0 do r1 vai para baixo, a prioridade de HSRP do r1 está diminuída por 10. neste momento que a prioridade de HSRP R2 é mais alta do que o r1, e o R2 toma sobre como o roteador ativo. Quando o R2 se transforma o roteador ativo, todo o tráfego dos anfitriões aos server está distribuído com o R2.

Nota: O gateway padrão para os anfitriões 1, 2, e 3 é configurado com o endereço IP de Um ou Mais Servidores Cisco ICM NT virtual HSRP (171.16.6.100, neste caso). Um protocolo de roteamento, por exemplo, RASGO é configurado no Roteadores para permitir a Conectividade entre os anfitriões e os server.

Está aqui a configuração para cada roteador:

Roteador1 (Cisco 2503)
interface Ethernet0 
ip address 171.16.6.5 255.255.255.0

!--- Assigns an IP address to the interface.

no ip redirects 
standby 1 ip 171.16.6.100

!--- Assigns a standby group and standby IP address

standby 1 priority 105

!--- Assign a priority (105 in this case) to the router interface (e0)
!--- for a particular group number (1). The default is 100.

standby 1 preempt

!--- Allows the router to become the active router when the priority 
!--- is higher than all other HSRP-configured routers in the hot standby group. 
!--- If you do not use the standby preempt command in the configuration 
!--- for a router, that router does not become the active router, even if 
!--- the priority is higher than all other routers. 

standby 1 track Serial0

!--- Indicates that HSRP tracks Serial0 interface. 
!--- The interface priority can also be configured, which indicates the 
!--- amount by which the router priority decreases when 
!--- the interface goes down. The default is 10.

interface Serial0 
ip address 171.16.2.5 255.255.255.0

Roteador 2 (Cisco 2503)
interface Ethernet0
ip address 171.16.6.6 255.255.255.0

!--- Assigns an IP address to the interface.

no ip redirects
standby 1 ip

!--- Indicates the hot standby group. Here the IP address of the virtual router 
!--- is not configured. See the note after this table.

standby 1 preempt

!--- Allows the router to become the active router when the priority 
!--- is higher than all other HSRP-configured routers in the hot standby group. 
!--- If you do not use the standby preempt command in the configuration 
!--- for a router, that router does not become the active router, even if 
!--- the priority is higher than all other routers. 

standby 1 track Serial1

!--- Indicates that HSRP tracks Serial1 interface. 
!--- The interface priority can also be configured, which indicates the 
!--- amount by which the router priority decreases when 
!--- the interface goes down. The default is 10.
!--- The priority is also not configured and hence the default 
!--- priority value of 100 is applied.

interface Serial1
ip address 171.16.7.6 255.255.255.0

Nota: O R2 não tem um endereço IP em standby configurado. Isso é intencional para demonstrar que essa é uma configuração válida. Quando o r1 e o R2 trocam hellos HSRP, o R2 aprende o endereço IP em standby do r1. A fim configurar o R2 com um endereço IP em standby (o mesmo endereço em standby configurado no r1) é igualmente uma configuração válida.

R1# show standby
Ethernet0 - Group 1
Local state is Active, priority 105, may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 1.458
Virtual IP address is 171.16.6.100 configured
Active router is local
Standby router is 171.16.6.6 expires in 8.428
Virtual mac address is 0000.0c07.ac01
2 state changes, last state change 02:09:49
IP redundancy name is "hsrp-Et0-1" (default)
Priority tracking 1 interface, 1 up:
Interface    Decrement  State
Serial0         10      Up
 
R2# show standby
Ethernet0 - Group 1
Local state is Standby, priority 100, may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 1.814
Virtual IP address is 171.16.6.100
Active router is 171.16.6.5, priority 105 expires in 9.896
Standby router is local
3 state changes, last state change 00:10:21
IP redundancy name is "hsrp-Et0-1" (default)
Priority tracking 1 interface, 1 up:
Interface   Decrement  State
Serial1        10      Up

Embora o R2 não tenha uma prioridade de HSRP configurada, a saída mostra a prioridade R2 como o valor padrão HSRP, 100. A saída de ambo o Roteadores indica que o Roteadores segue o estado de serial0. O estado de R1 é ativo e o estado de R2 é standby. Ultimamente, ambo o Roteadores é configurado com o comando standby preempt.

O que acontece se a interface serial 0 R1 ficar inativa? A saída do comando show standby é semelhante a:

R1# show standby
Ethernet0 - Group 1
Local state is Standby, priority 95 (confgd 105), may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 2.670
Virtual IP address is 171.16.6.100 configured
Active router is 171.16.6.6, priority 100 expires in 8.596
Standby router is local
4 state changes, last state change 00:01:45
IP redundancy name is "hsrp-Et0-1" (default)
Priority tracking 1 interface, 0 up:
Interface    Decrement  State
Serial0         10      Down
   
R2# show standby
Ethernet0 - Group 1
Local state is Active, priority 100, may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 0.810
Virtual IP address is 171.16.6.100
Active router is local
Standby router is 171.16.6.5 expires in 9.028
Virtual mac address is 0000.0c07.ac01
4 state changes, last state change 00:01:38
IP redundancy name is "hsrp-Et0-1" (default)
Priority tracking 1 interface, 1 up:
Interface   Decrement  State
Serial1        10      Up

Observação na saída que a prioridade de HSRP do r1 está reduzida pelo 10 — a 95. Esta mudança faz a prioridade R2 de 100 mais alta. Porque o R2 foi configurado para o apoio cancelar naquele tempo que a prioridade R2 se tornou mais altamente, R2 transforma-se o roteador ativo e o r1 transforma-se o apoio. Agora, se a relação do serial0 do r1 vem apoio, a prioridade do r1 é 105, outra vez. Em tal situação, o r1 cancela e transforma-se mais uma vez o roteador ativo HSRP.

Nota: Se o apoio cancela não é configurado no R2, R2 não enviaria um mensagem de vitória ao r1, que faça com que o R2 se torne ativo. Em lugar do r1 permaneceria o roteador ativo.

Por exemplo, considere esta configuração:

standby priority 120
standby track serial 0
standby track serial 1

Uma prioridade de HSRP de 120 é configurada com o comando standby priority e o HSRP é configurado para seguir o estado de dois relações, serial0s e Serial1. Porque nenhum valor do decréscimo é especificado no comando standby track, a prioridade de HSRP está decrescida pelo valor padrão do 10 quando a relação seguida vai para baixo. Inicialmente, ambas as relações são ascendentes e a prioridade de HSRP da relação é 120, como no comando show standby output:

R1# show standby
Ethernet0 - Group 1
  Local state is Active, priority 120, may preempt
  Hellotime 3 sec, holdtime 10 sec
  Next hello sent in 1.034
  Virtual IP address is 10.0.0.5 configured
  Active router is local
  Standby router is unknown
  Virtual mac address is 0000.0c07.ac01
  2 state changes, last state change 00:00:04
  IP redundancy name is "hsrp-Et0-1" (default)
  Priority tracking 2 interfaces, 2 up:
    Interface                  Decrement  State
    Serial0                       10      Up
    Serial1                       10      Up
R1#

Agora, o interface serial 0 é derrubado.

R1#
1w0d: %LINK-3-UPDOWN: Interface Serial0, changed state to down
1w0d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
R1#

Isto reduz a prioridade de HSRP pelo 10 — de 120 a um valor de 110. Você pode usar o comando show standby verificar isto:

R1# show standby
Ethernet0 - Group 1
  Local state is Active, priority 110 (confgd 120), may preempt
  Hellotime 3 sec, holdtime 10 sec
  Next hello sent in 2.544
  Virtual IP address is 10.0.0.5 configured
  Active router is local
  Standby router is unknown
  Virtual mac address is 0000.0c07.ac01
  2 state changes, last state change 00:00:48
  IP redundancy name is "hsrp-Et0-1" (default)
  Priority tracking 2 interfaces, 1 up:
    Interface                  Decrement  State
    Serial0                       10      Down  (line protocol down)
    Serial1                       10      Up
R1#

Em seguida, o segundo interface serial 1 seguido — é derrubado:

R1#
1w0d: %LINK-3-UPDOWN: Interface Serial1, changed state to down
1w0d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1, changed state to down
R1#

Isto reduz outra vez a prioridade de HSRP pelo 10 — de 110 a um valor de 100. Você pode usar o comando show standby verificar isto:

R1# show standby
Ethernet0 - Group 1
  Local state is Active, priority 100 (confgd 120), may preempt
  Hellotime 3 sec, holdtime 10 sec
  Next hello sent in 1.846
  Virtual IP address is 10.0.0.5 configured
  Active router is local
  Standby router is unknown
  Virtual mac address is 0000.0c07.ac01
  2 state changes, last state change 00:01:06
  IP redundancy name is "hsrp-Et0-1" (default)
  Priority tracking 2 interfaces, 0 up:
    Interface                  Decrement  State
    Serial0                       10      Down  (line protocol down)
    Serial1                       10      Down  (line protocol down)
R1#

Quando qualquer das interfaces serial seguidas (serial0 ou série 1) vai para baixo, a prioridade resultante é 110. Quando ambo estes interfaces serial seguidas (serial0 e série 1) vão para baixo, a prioridade resultante é 100.

Nota: Em determinadas versões mais velhas do Cisco IOS, o decréscimo na prioridade de HSRP não é cumulativo se você não define explicitamente o valor do decréscimo no comando standby track. Refira o Bug ID CSCdp72834 (clientes registrados somente) para mais informação.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 13780