IP : Conversão de endereços de rede (NAT)

Conjuntos NAT e sub-rede zero

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento discute como conjuntos de NAT (Conversão de endereço de rede) estão sujeitos a regras de sub-rede zero exatamente como qualquer outro endereço IP.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Material de Suporte

Quando você configura um pool NAT, de modo que os endereços nesse pool sejam parte da sub-rede zero, a tradução NAT falha.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para encontrar informações adicionais sobre os comandos usados neste documento, use a Command Lookup Tool (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/13777/7a.gif

Neste exemplo de configuração, o dispositivo interno tem uma rota padrão do roteador NAT. O dispositivo exterior tem uma rota estática a um endereço a que o dispositivo interno é traduzido. O roteador NAT possui essa configuração NAT:

ip nat pool test 171.68.1.1 171.68.1.10 netmask  255.255.240.0
ip nat inside source list 7 pool test 

interface s 0
ip address 171.16.4.6 255.255.255.0
ip nat inside

interface s 1
ip address 171.16.6.6 255.255.255.0
ip nat outside

access-list 7 permit host 171.16.4.4

Observe que os endereços no teste do conjunto NAT são endereços zero de sub-rede. O ping a partir do dispositivo interno para o dispositivo externo falha porque a conversão não ocorre. Se você executa o comando debug ip nat no roteador NAT, revela estas mensagens:

NAT: translation failed (A), dropping packet s=171.16.4.4 d=171.16.6.5
NAT: translation failed (A), dropping packet s=171.16.4.4 d=171.16.6.5
NAT: translation failed (A), dropping packet s=171.16.4.4 d=171.16.6.5
NAT: translation failed (A), dropping packet s=171.16.4.4 d=171.16.6.5
NAT: translation failed (A), dropping packet s=171.16.4.4 d=171.16.6.5

Nota: O "(A)" na saída do comando debug significa que a tradução falhou após ocorrer o roteamento.

Nota: A fim evitar este problema, configurar o comando ip subnet-zero no roteador NAT. O comando é permitido à revelia no Software Release 12.0 do½ do¿Â do Cisco IOSïÂ. Em uns Cisco IOS Software Release mais adiantados, não é permitido à revelia. Se o NAT não é configurado corretamente quando usado com PANCADINHA, a seguir tradução NAT pode falhar. Estes são os códigos de falha da tradução NAT:

 A = Inside to outside fails after routing
 B = Outside to inside fails before routing
 C = Outside to inside fails after routing 
 D = Helpered fails 
 L = Internally generated packet fails 
 E = Inside to outside fails after routing

Informações Relacionadas


Document ID: 13777