IP : Border Gateway Protocol (BGP)

Como usar o HSRP para fornecer redundância em uma rede BGP multihomed

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Tradução Manual (7 Abril 2008) | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento descreve como fornecer redundância em uma rede BGP (Protocolo de gateway limite) multihomed, na qual existem conexões com dois provedores de serviço da Internet (ISPs) separados. No caso de uma falha de conectividade para um ISP, o tráfego é roteado novamente dinamicamente com o outro ISP com o BGP definido como o comando as-path {tag | prepend as-path-string} e o Hot Standby Router Protocol (HSRP).

Pré-requisitos

Requisitos

Os leitores deste documento devem estar cientes destes tópicos:

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Informações de Apoio

O objetivo da configuração neste documento é conseguir esta política de rede:

  • Todo o tráfego de saída originado dos anfitriões na rede 192.168.21.0/24 e destinado ao Internet deve ser distribuído com o r1 ao ISP-A. Contudo, se esse link falha ou o r1 falha, todo o tráfego de saída deve ser redistribuído com o R2 ao ISP-B (e então ao Internet) sem intervenção manual.

  • Todo o tráfego de entrada destinado a um sistema autônomo, AS100, do Internet deve ser distribuído pelo r1. Caso o link do ISP-A ao r1 falhar, o tráfego de entrada deve automaticamente ser redistribuído com o ISP-B ao R2.

Estas exigências podem ser cumpridas com duas Tecnologias: BGP e HSRP.

O primeiro objetivo de um caminho externo inteiramente redundante pode ser realizado com HSRP. Em geral, os PCs não são capazes de coletar e trocar informações de roteamento. O endereço IP de Um ou Mais Servidores Cisco ICM NT do gateway padrão é configurado estaticamente em um PC e se o gateway router vai para baixo, o PC perde a Conectividade a todo o dispositivo além de seu segmento de rede local. Este é o caso mesmo se um gateway alternativo existe. O HSRP foi destinado para atender a esses requisitos. Refira características e funcionalidade HSRP para mais informação.

O segundo objetivo pode ser conseguido com o comando set as-path prepend BGP, que permite que o BGP propague um mais longo COMO o trajeto (por prepending seus próprios COMO o número mais de uma vez) com o R2 ao link do ISP-B para o prefixo 192.168.21.0/24. Assim, todos traficam destinado para 192.168.21.0/24 que vem do exterior do AS100 toma o mais curto COMO o trajeto com o ISP-A ao link do r1. Se o caminho principal (ISP-A ao r1) falha, todo o tráfego toma o mais longo COMO o trajeto (ISP-B ao R2) a fim alcançar a rede 192.168.21.0/24. A fim aprender mais sobre o comando set as-path prepend BGP, refira o diagrama do atributo AS_path no documento dos Casos Práticos do BGP.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Diagrama de Rede

Este documento usa a instalação de rede mostrada aqui:

Neste diagrama, o Roteador 1 (R1) e o Roteador 2 (R2) estão no AS 100, que tem peer de BGP externo (eBGP) com ISP-A (AS 300) e ISP-B (AS 400) respectivamente. O roteador 6 (R6) é parte de AS 600, que possui correspondência eBGP com ISP-A e ISP-B. R1. O R2 tem o ibgp peering, que é necessário para assegurar o roteamento ótimo. Por exemplo, quando você tenta alcançar as rotas internas AS400, o r1 não emprega o caminho mais longo sobre o AS300. R1 para a frente o tráfego ao R2 pelo contrário.

R1 e R2 também são configurados para HSRP por um segmento de Ethernet comum. Os anfitriões no mesmo segmento de Ethernet têm uma rota padrão esses pontos para o endereço IP 192.168.21.10 do standby de HSRP.

hsrp_bgp-01.gif

Configurações

R1
Current configuration

hostname R1
!
interface serial 0
ip address 192.168.31.1 255.255.255.0
!
interface Ethernet1
  ip address 192.168.21.1 255.255.255.0
  standby 1 priority 105
  standby 1 preempt delay minimum 60
  standby 1 ip 192.168.21.10
  standby 1 track Serial0

!--- The 
standby track serial command tracks the state of 
!--- the Serial0 interface and brings down the  
!--- priority of standby group 1, if the interface goes down.
!--- The 
standby preempt delay minimum 60 command makes sure that 
!--- R1 preempts and takes over as active router again. This command also ensures that
!--- the router waits 60 seconds before doing so in order to give BGP time enough
!--- to converge and populate the routing table. This avoids
!--- traffic being sent to R1 before it is ready to forward it.

!
!
router bgp 100
  no synchronization
  network 192.168.21.0
  neighbor 192.168.21.2 remote-as 100
  neighbor 192.168.21.2 next-hop-self
  neighbor 192.168.31.3 remote-as 300
  no auto-summary
!

R2
Current configuration:  

hostname  R2 
!
interface serial 0  
ip address 192.168.42.2 255.255.255.0  
!
interface Ethernet1  
 ip address 192.168.21.2 255.255.255.0  
 standby 1 priority 100  
 standby 1 preempt  
 standby 1 ip 192.168.21.10  
! 
!  
router bgp 100  
 no synchronization  
 network 192.168.21.0   
 neighbor 192.168.21.1 remote-as 100  
 neighbor 192.168.21.1 next-hop-self  
 neighbor 192.168.42.4 remote-as 400  
 neighbor 192.168.42.4 route-map foo out 

!--- It appends AS 100 to the BGP updates sent to AS 400 
!--- in order to make it a backup for the ISP-A to R1 path.

 no auto-summary  
!  
access-list 1 permit 192.168.21.0  
route-map foo permit 10  
 match ip address 1  
 set as-path prepend 100  

end

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Quando você configura a Redundância em toda a rede, você deve considerar duas coisas:

  • A criação de um caminho redundante para os pacotes que vão de uma rede local a uma rede de destino.

  • A criação de um caminho redundante para os pacotes que voltam de um destino a uma rede local.

Pacotes indo da rede local em direção ao destino

Neste exemplo, a rede local é 192.168.21.0/24. O r1 do roteador e o R2 estão executando o HSRP no segmento de Ethernet conectado para conectar Ethernet1. O r1 é configurado como o roteador ativo HSRP com uma prioridade em standby de 105, e o R2 é configurado com uma prioridade em standby de 100. O comando do serial0 da trilha do apoio 1 (S0) no r1 permite que o processo HSRP monitore essa relação. Se o estado da relação vai para baixo, a prioridade de HSRP está reduzida. Quando o protocolo da linha da interface s0 fica inativo, a prioridade de HSRP é reduzida para 95 (o valor padrão pelo qual a prioridade é reduzida é 10). Isto faz o outro roteador de HSRP, R2, tem uma prioridade mais alta (uma prioridade de 100). O R2 transforma-se o roteador ativo HSRP e atrai-se o tráfego destinado ao endereço 192.169.21.10 do HSRP ativo.

Emita o comando show standby a fim ver o roteador de HSRP ativo quando o S0 da relação no r1 está acima:

R1#show standby 
   Ethernet1 - Group 1 
     Local state is Active, priority 105, may preempt 
     Hellotime 3 sec, holdtime 10 sec 
     Next hello sent in 0.338 
     Virtual IP address is 192.168.21.10 configured 
     Active router is local 
     Standby router is 192.168.21.2 expires in 8.280 
     Virtual mac address is 0000.0c07.ac01 
     13 state changes, last state change 00:46:10 
     IP redundancy name is "hsrp-Et0-1"(default) 
     Priority tracking 1 interface, 1 up: 
     Interface                    Decrement   State 
     Serial0                          10      Up 

R2#show standby 
   Ethernet1 - Group 1
     State is Standby
     56 state changes, last state change 00:05:13
     Virtual IP address is 192.168.21.10
     Active virtual MAC address is 0000.0c07.ac01
     Local virtual MAC address is 0000.0c07.ac01 (default)
     Hello time 3 sec, hold time 10 sec
     Next hello sent in 1.964 secs
     Preemption enabled
     Active router is 192.168.21.1, priority 105 (expires in 9.148 sec)
     Standby router is local
     Priority 100 (default 100)
     IP redundancy name is "hsrp-Et0-1" (default)

R1#show standby ethernet 1 brief
                     P indicates configured to preempt.
                     |
Interface   Grp Prio P State    Active addr     Standby addr    Group addr
Et1         1   105  P Active   local           192.168.21.2    192.168.21.10
R1#

R2#show standby ethernet 1 brief
                     P indicates configured to preempt.
                     |
Interface   Grp Prio P State    Active          Standby         Virtual IP
Et1         1   100  P Standby  192.168.21.1    local           192.168.21.10
R2#

O comando show standby mostra o R1 como o roteador HSRP ativo, devido à prioridade mais alta de 105. Desde que o r1 é o roteador ativo, o r1 possui o endereço IP em standby 192.168.21.10. Todo o tráfego IP do host configurado com o gateway padrão às rotas de 192.168.21.10 com o r1.

Se você derruba a relação do S0 no r1 do roteador, o roteador ativo HSRP muda desde que o HSRP no r1 é configurado com o comando track serial 0 à espera. Quando o protocolo da relação do Serial 0 vai para baixo, o HSRP reduz a prioridade do r1 por 10 (padrão) a 95. O r1 muda seu estado ao “apoio”. O R2 toma sobre como o roteador ativo, e possui assim o endereço IP em standby 192.168.21.10. Em conformidade, todos traficam destinado dos anfitriões nas 192.168.21.0/24 rotas do segmento traficam com o R2. A saída dos comandos debug e show confirma o mesmo.

R1(config)# interface s0 
R1(config-if)# shut 
 %STANDBY-6-STATECHANGE: Standby: 1: Ethernet1 state Active         -> Speak 
 %LINK-5-CHANGED: Interface Serial0, changed state to administratively down 
 %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down 
 %STANDBY-6-STATECHANGE: Standby: 1: Ethernet1 state Speak  -> Standby 
 %LINK-3-UPDOWN: Interface Serial0, changed state to down: 
 %STANDBY-6-STATECHANGE: Standby: 1: Ethernet1 state Active       -> Speak 
 %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down 
 %STANDBY-6-STATECHANGE: Standby: 1: Ethernet1 state Speak  -> Standby 

Observe que o r1 se transforma um roteador em standby.

Se o R2 entra no estado ativo, a seguir você vê a saída similar a esta:

R2# 
 %STANDBY-6-STATECHANGE: Standby: 1: Ethernet1 state Standby        -> Active 

Se você executar o comando show standby no R1 e R2, observe as prioridades de standby depois que a interface s0 ficar inativa no R1:

R1#show standby
Ethernet1 - Group 1
  Local state is Standby, priority 95 (confgd 105), may preempt
  Hellotime 3 sec, holdtime 10 sec
  Next hello sent in 0.808
  Virtual IP address is 192.168.21.10 configured
  Active router is 192.168.21.2, priority 100 expires in 9.008
  Standby router is local
  15 state changes, last state change 00:00:40
  IP redundancy name is "hsrp-Et0-1" (default)
  Priority tracking 1 interface, 0 up:
    Interface               Decrement   State
    Serial0                      10     Down  (administratively down)
R1#
 
R2#show standby
Ethernet1 - Group 1
  State is Active
    57 state changes, last state change 00:00:33
  Virtual IP address is 192.168.21.10
  Active virtual MAC address is 0000.0c07.ac01
    Local virtual MAC address is 0000.0c07.ac01 (bia)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 2.648 secs
  Preemption enabled
  Active router is local
  Standby router is 192.168.21.1, priority 95 (expires in 7.096 sec)
  Priority 100 (default 100)
  IP redundancy name is "hsrp-Et0-1" (default)
R2#

R2#

R1#sh standby ethernet 1 brief
                     P indicates configured to preempt.
                     |
Interface   Grp Prio P State    Active addr     Standby addr    Group addr
Et0         1   95   P Standby  192.168.21.2    local           192.168.21.10
R1# 

R2#sh standby ethernet 1 brief
                     P indicates configured to preempt.
                     |
Interface   Grp Prio P State    Active          Standby         Virtual IP
Et0         1   100  P Active   local           192.168.21.1    192.168.21.10
R2#

Observe que a prioridade em standby R1 se reduziu de 105 a 95, e R2 transformou-se o roteador ativo.

Resumo

No caso de uma falha de conectividade entre o ISP-A e o r1, o HSRP reduz a prioridade do grupo de standby no r1. O R1 vai de um estado ativo para o estado de espera. O R2 passa de um estado de standby para o estado ativo. O endereço IP em standby 192.168.21.10 torna-se ativo no R2, e nos anfitriões que enviam o tráfego ao uso R2 do Internet e ao ISP-B, fornecendo um caminho alternativo para o tráfego de saída.

Para obter mais informações sobre do comando hsrp standby track, refira como usar os comandos standby preempt e standby track.

Pacotes que chegam do destino para a rede local

De acordo com a política de rede definida na seção de informações de fundo, desde que o ISP-A é seu caminho principal e o ISP-B é o caminho backup para o tráfego que vem para 192.168.21.0/24 (para razões tais como uma conexão de largura de banda maior para o ISP-A), você pode adicionar seus próprios PORQUE número nas atualizações BGP anunciadas para o ISP-B no R2 para fazer COMO o trajeto com o ISP-B para aparecer mais por muito tempo. A fim fazer isto, configurar um mapa de rota para o vizinho de BGP 192.168.42.4. Nesse mapa de rota, adicione seus próprios COMO com o comando set as-path prepend. Aplique esse mapa de rotas às atualizações de saída do vizinho 192.168.42.4.

Nota: Na produção, você deve adicionar COMO o número mais de uma vez para assegurar-se de que a rota anunciada se torne preferida menos.

Esta é a tabela de BGP no R6 para a rede 192.168.21.0 quando a conectividade BGP entre o r1 ao ISP-A e o R2 ao ISP-B está acima:

R6#
show ip bgp 192.168.21.0
BGP routing table entry for 192.168.21.0/24, version 30 
Paths: (2 available, best #1) 
  Advertised to non peer-group peers: 
    192.168.64.4 
  300 100 
    192.168.63.3 from 192.168.63.3 (10.5.5.5) 
      Origin IGP, localpref 100, valid, external, best, ref 2 
  400 100 100 
    192.168.64.4 from 192.168.64.4 (192.168.64.4) 
      Origin IGP, localpref 100, valid, external

O BGP seleciona o melhor caminho como COMO {300 100} com o ISP-A porque tem um menor COMO o comprimento de trajeto em comparação com COMO o trajeto {400 100 100} do ISP-B. O motivo de existir um caminho AS mais comprido a partir de ISP-B é devido à configuração anexada do caminho de AS em R2.

Quando a Conectividade quebra entre o r1 e o ISP-A, o R6 deve escolher o caminho alternativo com o ISP-B alcançar a rede 192.168.21.0/24 no AS100:

R1(config)#interface s0 
R1(config-if)#shut 
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down 

Esta é a tabela de BGP no R6 para a rede 192.168.21.0/24:

R6#show ip bgp 192.168.21.0 
BGP routing table entry for 192.168.21.0/24, version 31 
Paths: (1 available, best #1) 
  Advertised to non peer-group peers: 
    192.168.63.3 
  400 100 100 
    192.168.64.4 from 192.168.64.4 (192.168.64.4) 
      Origin IGP, localpref 100, valid, external, best

Refira a configuração de exemplo para o BGP com os dois provedores de serviços diferentes (hospedagem múltipla) para obter mais informações sobre das configurações de BGP em uma rede de hospedagem múltipla.

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.


Informações Relacionadas


Document ID: 13768