IP : Border Gateway Protocol (BGP)

Configurando o recurso BGP Local-AS

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento explica os recursos locais do Border Gateway Protocol (BGP), que estavam primeiramente disponíveis no Software Release 12.0(5)S do � do Cisco IOS.

Os recursos locais permitem que um roteador pareça ser um membro de um segundo sistema autônomo, além do que seu real COMO. Esse recurso só pode ser usado para peers de eBGP verdadeiros. Você não pode usar esta característica para dois pares que são membros da confederação diferente secundário-AS.

Pré-requisitos

Requisitos

Este documento requer uma compreensão do BGP Routing Protocol e suas operações. Refira os Casos Práticos do BGP.

Componentes Utilizados

A informação neste documento aplica aos estes a versão de software e hardware.

  • Cisco IOS Software Release 12.2(28)

  • Cisco 2500 Series Routers

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Sintaxe do comando

Esta lista mostra a sintaxe dos comandos que as configurações neste uso do documento.

Local-COMO não pode ser personalizado para pares individuais em um peer-group.

Local-COMO não pode ter o protocolo BGP local COMO o número ou COMO o número do peer remoto.

O comando local-as apenas é válido quando um correspondente é um verdadeiro correspondente eBGP. Não trabalha para dois pares em secundário-AS diferentes em uma confederação.

Refira o guia de referência do comando bgp para obter informações adicionais sobre dos comandos bgp.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Informações de Apoio

Os recursos locais são úteis se o ISP-A compra o ISP-B, mas os clientes do ISP-b não querem alterar nenhuma disposições peering ou configurações. Os recursos locais permitem que o Roteadores no ISP-B transforme-se membros dos ISP-a COMO. Ao mesmo tempo, este Roteadores parece a seus clientes reter seu ISP-B COMO o número.

Em figura 1, o ISP-A não comprou ainda o ISP-B. Em figura 2, o ISP-A comprou o ISP-B, e o ISP-B usa os recursos locais.

Em figura 2, o ISP-B pertence ao AS100, e ao ISP-C ao AS300. Ao espreitar com ISP-C, o ISP-B usa o AS200 como o seu COMO o número com o uso do comando neighbor ISP-C local-as 200. Nas atualizações enviadas do ISP-B ao ISP-C, o AS_SEQUENCE no atributo AS_path contém "200 100". O "200" prepended pelo ISP-B devido ao comando local-as 200 configurado para o ISP-C.

Normalmente um ISP-A/B combinado renumbers o Roteadores no ISP-B para ser parte de AS100. Que se ISP-C é a mudança incapaz suas configurações de eBGP com ISP-B? Antes dos recursos locais, o ISP-A/B combinado tem que manter dois COMO números. O comando local-as permite que o ISP-A/B seja fisicamente um COMO quando parecer ser dois AS ao ISP-C.

Configurar

Esta seção apresenta informações para configurar as características que este documento descreve.

Nota: A fim encontrar a informação adicional nos comandos que este documento usa, usa a ferramenta de consulta de comandos (clientes registrados somente).

Diagramas da rede

Este documento usa estas instalações de rede.

Figura 1

/image/gif/paws/13761/39a.gif

Figura 2

/image/gif/paws/13761/39b.gif

Configurações

Este documento utiliza estas configurações.

ISP-B (AS100, local-como 200)
hostname ISP-B
! 
interface serial 0 
ip address 192.168.1.1 255.255.255.252 
! 
interface ethernet 0 
ip address 192.168.4.1 255.255.255.0 
! 
router bgp 100 

!--- Note the AS number 100. This is the AS number of ISP-A, which is now
!--- used by all routers in ISP-B after its acquisition by ISP-A.

 neighbor 192.168.1.2 remote-as 300 

!--- Defines the e-BGP connection to ISP-C.

 neighbor 192.168.1.2 local-as 200 

!--- This command makes the remote router in ISP-C to see this
!--- router as belonging to AS 200 instead of AS 100. 
!--- This also make this router to prepend AS 200 in 
!--- all updates to ISP-C.

network 192.168.4.0
! 
!

ISP-C (AS300)
hostname ISP-C
! 
interface serial 1 
ip address 192.168.1.2 255.255.255.252 
! 
interface ethernet 0 
ip address 192.168.9.1 255.255.255.0 
! 
router bgp 300 
 neighbor 192.168.1.1 remote-as 200

!--- Defines the e-BGP connection to ISP-B.


!--- Note AS is 200 and not AS 100.
 
 network 192.168.9.0 
! 
!

Verificar

Esta seção fornece a informação que você pode se usar para confirmar sua configuração trabalha corretamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Refira o guia de referência do comando bgp a fim aprender mais sobre os comandos show usados nesta seção.

Veja a tabela de roteamento de BGP para ver como o comando local-as mudou o AS_PATH. O que você observa é esse ISP-B prepends o AS200 às atualizações a que são enviados e recebidos do ISP-C. Além, note que o ISP-B está dentro COMO o número 100.

ISP-B# 
show ip bgp summary

  BGP router identifier 192.168.4.1, local AS number 100 
  BGP table version is 3, main routing table version 3 
  2 network entries and 2 paths using 266 bytes of memory 
  2 BGP path attribute entries using 104 bytes of memory 
  1 BGP AS-PATH entries using 24 bytes of memory 
  0 BGP route-map cache entries using 0 bytes of memory 
  0 BGP filter-list cache entries using 0 bytes of memory 
  BGP activity 2/6 prefixes, 2/0 paths, scan interval 15  secs 

  Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd 
  192.168.1.2     4   300      29      29        3    0    0 00:25:19       1

Nesta saída, note que o ISP-C considera o ISP-B como parte do AS200.

ISP-C# show ip bgp summary 
  BGP table version is 3, main routing table version 3 
  2 network entries (2/6 paths) using 480 bytes of memory 
  2 BGP path attribute entries using 192 bytes of memory 
  0 BGP route-map cache entries using 0 bytes of memory 
  0 BGP filter-list cache entries using 0 bytes of memory 

  Neighbor        V    AS MsgRcvd MsgSent  TblVer InQ OutQ   Up/Down  State/PfxRcd 
  192.168.1.1     4   200      34      34       3   0    0  00:30:19   1

Note nesta saída que o ISP-B prepends "200" às rotas aprendidas do ISP-C.

ISP-B# 
show ip bgp

  BGP table version is 3, local router ID is 192.168.4.1 
  Status codes: s suppressed, d damped, h history, * valid, > best, i - internal 
  Origin codes: i - IGP, e - EGP, ? - incomplete 

  Network          Next Hop            Metric LocPrf  Weight   Path 
  *> 192.168.4.0      0.0.0.0               0          32768   i 
  *> 192.168.9.0      192.168.1.2           0              0   200 300 i

Note que o ISP-C considera rotas do ISP-B com um AS_PATH de "200 100".

ISP-C# show ip bgp 
  BGP table version is 3, local router ID is 192.168.1.2 
  Status codes: s suppressed, d damped, h history, * valid, > best, i - internal 
  Origin codes: i - IGP, e - EGP, ? - incomplete 

  Network          Next Hop          Metric LocPrf  Weight Path 
  *> 192.168.4.0      192.168.1.1         0              0 200 100 i 
  *> 192.168.9.0      0.0.0.0             0          32768 i

Este dos comandos show configurado local-como avalia em sua saída:

ISP-B# show ip bgp neighbors 192.168.1.2
BGP neighbor is 192.168.1.2,  remote AS 300,  local AS 200, external link
  BGP version 4, remote router ID 192.168.9.1
  BGP state = Established, up for 00:22:42
  Last read 00:00:42, hold time is 180, keepalive interval is 60 seconds
  Neighbor capabilities:
    Route refresh: advertised and received(old & new)
    Address family IPv4 Unicast: advertised and received
  Message statistics:
    InQ depth is 0
    OutQ depth is 0
                         Sent       Rcvd
    Opens:                  1          1
    Notifications:          0          0
    Updates:                2          1
    Keepalives:            25         25
    Route Refresh:          0          1
    Total:                 28         28
  Default minimum time between advertisement runs is 30 seconds

! Output Suppressed

Troubleshooting

O comando debug ip bgp updates indica os prefixos recebidos com seus atributos do vizinho. Esta saída mostra que o prefixo 192.168.4.0/24 está recebido com AS PATH 200, 100.

ISP-C#
*May 10 12:45:14.947: BGP(0): 192.168.1.1 computing updates, afi 0, neighbor ver
sion 0, table version 5, starting at 0.0.0.0
*May 10 12:45:14.947: BGP(0): 192.168.1.1 send UPDATE (format) 192.168.9.0/24, n
ext 192.168.1.2, metric 0, path
*May 10 12:45:14.947: BGP(0): 192.168.1.1 1 updates enqueued (average=52, maximu
m=52)
*May 10 12:45:14.947: BGP(0): 192.168.1.1 update run completed, afi 0, ran for 0
ms, neighbor version 0, start version 5, throttled to 5
*May 10 12:45:14.947: BGP: 192.168.1.1 initial update completed
*May 10 12:45:15.259: BGP(0): 192.168.1.1 rcvd UPDATE w/ attr: nexthop 192.168.1
.1, origin i, metric 0, path 200 100
ISP-C#
*May 10 12:45:15.259: BGP(0): 192.168.1.1 rcvd 192.168.4.0/24
*May 10 12:45:15.279: BGP(0): Revise route installing 192.168.4.0/24 -> 192.168.
1.1 to main IP table
ISP-C#

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 13761