IP : Border Gateway Protocol (BGP)

Recursos de contabilidade da interface de saída da contabilidade da política do BGP e da contabilidade da política do BGP

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

A característica da contabilidade das normas do Border Gateway Protocol (BGP) (PA) permite que você esclareçam o tráfego IP diferencialmente atribuindo os contadores baseados na lista de comunidade, COMO o número, e/ou o AS_PATH na pela base da interface de entrada.

A contabilidade da interface de saída do BGP PA introduz diversos Ramais para permitir o BGP PA em uma interface de saída e para incluir a contabilidade baseada em um endereço de origem para ambos tráfego da entrada e saída em uma relação. Os contadores baseados em parâmetros tais como a lista de comunidade, o número de sistema autônomo, ou o trajeto do sistema autônomo são atribuídos para identificar o tráfego IP.

Pré-requisitos

Requisitos

Antes que você use a característica do BGP PA, permita o Cisco Express Forwarding (CEF) ou o Distributed Cisco Express Forwarding (dCEF) no roteador.

Componentes Utilizados

A característica do BGP PA é apoiada primeiramente pelas seguintes Plataformas que apoiam o Cisco IOS Release 12.0(9)S.

  • Cisco 7200, 7500, e 12000 Series Router

O número de Plataformas que apoiam esta característica no Cisco IOS Release 12.2(13)T é muito maior. As Plataformas incluem:

  • 1400, 1600, 1700, 2600, 3600, 7100, 7200, 7500, AS5300, AS5350, AS5400, AS5800, AS5850, ICS7750, IGX8400 URM, MGX8850, uBR7200.

A contabilidade da interface de saída do BGP PA foi adicionada em 12.0(22)S e introduziu primeiramente como novos recursos em 12.3(4)T. Há muitas plataformas Cisco que apoiam esta característica.

Nota: Para obter a informação atualizadas em relação ao suporte a plataforma para esta característica, alcance o Cisco Feature Navigator II (clientes registrados somente).

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Material de Suporte

Esta característica estava primeiramente disponível no Software Release 12.0(9)S ED do½ do¿Â do Cisco IOSïÂ. Para que os recursos de contabilidade das normas trabalhem, você deve permitir o BGP e o CEF/dCEF no roteador.

Usando a contabilidade da política do BGP, você pode esclarecer o tráfego (e para aplicar o faturamento) de acordo com a rota que atravessa. Por exemplo, você pode esclarecer o tráfego que é doméstico distribuído, internacional, terrestre, ou o satélite. Desta maneira, você pode identificar e esclarecer todo o tráfego em uma base por cliente.

Esta característica aproveita-se do comando bgp table-map, que classifica os prefixos que põe na tabela de roteamento de acordo com a lista de comunidade, COMO o número, AS_PATH, e assim por diante. Baseado nestes critérios de verificação de repetição de dados, a política de contabilidade BGP ajusta um número da cubeta (atualmente 1 64) de uma tabela de relatório associada com cada relação. Cada cubeta representa uma Classificação de tráfego, que permita que o tráfego IP sejam esclarecidos diferencialmente pela lista de comunidade, COMO o número, ou o AS_PATH pela interface de entrada.

Para mais informação, refira a contabilidade da política do BGP.

Nota: O BGP PA mede e classifica o tráfego IP a que é enviado, ou recebido de, pares diferentes. O PA estava previamente disponível em uma interface de entrada somente.

Os recursos de contabilidade da interface de saída da contabilidade da política do BGP introduzem diversos Ramais para permitir o BGP PA em uma interface de saída e para incluir a contabilidade baseada em um endereço de origem para ambos tráfego da entrada e saída em uma relação. Os contadores baseados em parâmetros tais como a lista de comunidade, o número de sistema autônomo, ou o trajeto do sistema autônomo são atribuídos para identificar o tráfego IP. A contabilidade da interface de saída foi adicionada no Cisco IOS Release 12.0(22)S.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurando relatórios da política BGP

  1. Especifique as comunidades nas listas de comunidade (ou defina lista AS_PATH) que classificam o tráfego para explicar.

    ip community-list 30 permit 100:190
      ip community-list 40 permit 100:198
      ip community-list 50 permit 100:197
      ip community-list 60 permit 100:296
      ip community-list 70 permit 100:201
      !
  2. Defina um mapa de rotas para combinar listas de comunidade e ajustar números apropriados da cubeta.

    route-map set_bucket permit 10
    match community 30
    set traffic-index 2
    !
    route-map set_bucket permit 20
    match community 40
    set traffic-index 3
    !
    route-map set_bucket permit 30
    match community 50
    set traffic-index 4
    !
    route-map set_bucket permit 40
    match community 60
    set traffic-index 5
    !
    route-map set_bucket permit 50
    match community 70
    set traffic-index 6 
  3. Use o comando table-map sob o BGP alterar o número da cubeta quando a tabela de IP Routing é atualizada com as rotas aprendidas do BGP.

    router bgp 110
      table-map set_bucket
      network 15.1.1.0 mask 255.255.255.0
      neighbor 14.1.1.1 remote-as 100
      !
      ip classless
      ip bgp-community new-format 
  4. Permita os recursos de contabilidade das normas na interface de entrada conectada ao cliente.

    interface POS7/0
      ip address 15.1.1.2 255.255.255.0
      no ip directed-broadcast
      bgp-policy accounting
      no keepalive
      crc 32
      clock source internal

Configurando a contabilidade da interface de saída da contabilidade da política do BGP

A contabilidade da interface de saída da configuração de BGP Pa é muito similar ao BGP PA. Primeira etapa três descrita na seção anterior é exatamente a mesma. A única mudança está no comando bgp-policy accounting que é usado para permitir a característica PA na relação. No exemplo abaixo do BGP PA é permitido na interface pos 7/0. O critério de Pa é baseado no endereço de origem do tráfego da saída

interface POS7/0
 ip address 10.15.1.2 255.255.255.0
 bgp-policy accounting output source
 no keepalive
 crc 32
 clock source internal

Comandos show que monitoram o relatório de políticas

Para inspecionar que prefixo é atribuído a que cubeta e a que a comunidade (ou as comunidades), usam os comandos show ip cef e show ip bgp.

Router# show ip cef 196.240.5.0 detail
196.240.5.0/24, version 21, cached adjacency to POS7/2
0 packets, 0 bytes, traffic_index 4
  via 14.1.1.1, 0 dependencies, recursive
   next hop 14.1.1.1, POS7/2 via 14.1.1.0/30
   valid cached adjacency

Router# show ip bgp 196.240.5.0
BGP routing table entry for 196.240.5.0/24, version 2
Paths: (1 available, best #1)
  Not advertised to any peer
  100
    14.1.1.1 from 14.1.1.1 (32.32.32.32)
      Origin IGP, metric 0, localpref 100, valid, external, best
      Community: 100:197

Para olhar estatísticas de tráfego da interface per., use o comando show cef interface policy-statistics.

LC-Slot7# show cef interface policy-statistics
:
POS7/0 is up (if_number 8)
Bucket    Packets               Bytes

1          0                      0
2          0                      0
3          50                     5000
4          100                    10000
5          100                    10000
6          10                     1000
7          0                      0
8          0                      0

Informações Relacionadas


Document ID: 13760