IP : Border Gateway Protocol (BGP)

Exemplo de configuração para remoção de números AS privados em BGP

15 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento mostra configurações de exemplo para a remoção de números privados de Sistema Autônomo (AS) de atualizações eBGP em curso. Os números de AS são classificados como privados e públicos. Da mesma forma como ocorre com os endereços IP privados e públicos, você também não pode divulgar números privados de AS na Internet. Os números públicos de AS variam entre 1 e 64511, e os números privados de AS variam entre 64512 e 65535. Você pode usar os números AS privados para dividir grandes ASs em vários ASs menores, conectados via eBGP. Além disso, se você estiver conectado com um único ISP, o ISP poderá atribuir números privados de AS para manter os números públicos de AS. Contudo, você deve remover esses números privados de AS antes de enviar as atualizações para a malha BGP (Internet).

Nota: A atribuição de privado PORQUE os números não são recomendados se você conecta aos ISP múltiplos. Privado COMO os números podem ser usados se a rede cliente conecta a um único ISP (ou escolha dirigido ou dual-homed).

Refira a remoção dos números de sistema independente privados no BGP para obter mais informações sobre de privado COMO números.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

A informação neste documento aplica aos estes a versão de software e hardware:

  • Software Release 12.2(27) do½ do¿Â do Cisco IOSïÂ

  • Cisco 2501 e Cisco 2503 Router

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Diagrama de Rede

Este documento usa um público da instalação de rede em que o roteador3 usa privado COMO o número 65000, e do uso do roteador1 e do roteador2 COMO os números AS1 e COMO 5 respectivamente.

O roteador2 está na nuvem do provedor de serviços com roteador1 (AS1 sendo executado) e roteador3 (que é executado COMO 65000) como seus clientes.

/image/gif/paws/13758/36-1.gif

Envie e receba atualizações

Este procedimento explica a sequência de evento que ocorre quando o roteador3 anuncia uma rede (10.0.0.0/24 neste caso).

  1. O roteador3 anuncia a rede 10.0.0.0/24 com COMO o atributo de trajeto 65000 ao roteador2.

  2. O roteador2 recebe a atualização do roteador3 e faz uma entrada para a rede 10.0.0.0 /24 em sua tabela de roteamento com o salto seguinte como 172.16.0.1 (interface serial S0 no roteador3).

  3. O roteador2 (dispositivo do provedor de serviços), quando configurado com o comando remove-private-as vizinho de 192.168.0.2, descasca o privado COMO o número e constrói um pacote de atualização novo com seus próprios COMO o número como COMO o atributo de trajeto para a rede 10.0.0.0/24 e envia o mesmo ao roteador1 que está no AS1.

  4. O roteador1 recebe a atualização do eBGP para a rede 10.0.0.0/24 e faz uma entrada em sua tabela de roteamento com o salto seguinte como 192.168.0.1 (interface serial S1 no roteador2). COMO o atributo de trajeto para esta rede como vista no roteador1 é COMO 5 (roteador2). Assim, o privados COMO números são impedidos de entrar nas tabelas de BGP do Internet.

Configurações

Este documento utiliza as seguintes configurações:

Roteador 3
Current configuration :
!
interface Ethernet0
 ip address 10.0.0.1 255.255.255.0
!
interface Serial0
 ip address 172.16.0.1 255.255.255.0
!
router bgp 65000
 network 10.0.0.0 mask 255.255.255.0
 neighbor 172.16.0.2 remote-as 5

!--- Configures Router 2 as an eBGP neighbor in public AS 5. 

!
end

Roteador 2
Current configuration :
!
!
interface Ethernet0
 ip address 172.30.1.1 255.255.0.0
!
interface Serial0
 ip address 172.16.0.2 255.255.255.0
!
interface Serial1
 ip address 192.168.0.1 255.255.255.0
!
router bgp 5
 network 172.30.0.0
 network 192.168.0.0
 neighbor 172.16.0.1 remote-as 65000

!--- Configures Router 3 as an eBGP neighbor in private AS 65000.

 neighbor 192.168.0.2 remote-as 1

!--- Configures Router 1 as an eBGP neighbor in public AS 1. 

 neighbor 192.168.0.2 remove-private-AS

!--- Removes the private AS numbers from outgoing eBGP updates.

!
!
end

Roteador 1
Current configuration :
!
version 12.2
!
!
interface Serial0
 ip address 192.168.0.2 255.255.255.0
 !
router bgp 1
 neighbor 192.168.0.1 remote-as 5

!--- Configures Router 2 as an eBGP neighbor in public AS 5.

!
end

Formato de PONTO do sistema autônomo

Este exemplo explica como converter COMO o número maior de 65535 ao sistema autônomo 4-Byte (formato ASDOT).

Antes da configuração ASDOT

Router#show run | beg router 
router bgp 131280
no synchronization 
bgp log-neighbor-changes 
no auto-summary 

Configuração ASDOT

Router(config-router)#bgp asnotation dot 
Router(config-router)#end 

Após a configuração

Router#show run | beg router bgp 
router bgp 2.208  <== 
no synchronization 
bgp asnotation dot 
bgp log-neighbor-changes 
no auto-summary ! 

Verificar

Esta seção fornece a informação que você pode se usar para confirmar sua configuração trabalha corretamente.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

As mensagens debugar tomadas com o comando debug ip bgp updates no roteador1 mostram que a atualização para a rede 10.0.0.0/24 recebida do roteador2 (192.68.0.1) tem COMO o atributo de trajeto 5 qual é COMO o número de roteador2. O comando show ip bgp no roteador2 e o roteador1 igualmente ilustram o mesmos.

Router1#
1w1d: %BGP-5-ADJCHANGE: neighbor 192.168.0.1 Up
1w1d: BGP(0): 192.168.0.1 computing updates, afi 0, 
       neighbor version 0, table version 1, starting at 0.0.0.0
1w1d: BGP(0): 192.168.0.1 update run completed, afi 0, 
       ran for 0ms, neighbor version 0, start version 1, throttled to 1
1w1d: BGP: 192.168.0.1 initial update completed
1w1d: BGP(0): 192.168.0.1 rcvd UPDATE w/ attr: nexthop 
       192.168.0.1, origin i, path 5
1w1d: BGP(0): 192.168.0.1 rcvd 10.0.0.0/24
1w1d: BGP(0): Revise route installing 10.0.0.0/24 -> 192.168.0.1 
      to main IP table
1w1d: BGP(0): 192.168.0.1 computing updates, afi 0, neighbor 
      version 1, table version 2, starting at 0.0.0.0
1w1d: BGP(0): 192.168.0.1 update run completed, afi 0, ran for 0ms,
      neighbor version 1, start version 2, throttled to 2

Router2#show ip bgp
BGP table version is 3, local router ID is 192.168.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete
    Network         Next Hop      Metric  LocPrf Weight   Path
 *> 10.0.0.0/24     172.16.0.2         0              0   65000 i
 *> 172.30.0.0      0.0.0.0            0         32768    i
 

Router1#show ip bgp
BGP table version is 19, local router ID is 192.168.0.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete
    Network          Next Hop      Metric  LocPrf  Weight  Path
 *> 10.0.0.0/24      192.168.0.1                        0  5 i
 *> 172.30.0.0       192.168.0.1        0               0  5 i

A tabela de BGP do roteador2 mostra que a rede 10.0.0.0 origina COMO de 65000. A tabela de BGP do roteador1 mostra que a mesma rede origina COMO do 5. Isto é devido ao comando remove-private-as vizinho de 192.168.0.2 no roteador2, que descasca o privado COMO o número e impede privado COMO números de alcançar o Internet. Por esse motivo, AS 1 (Roteador 1) tem um visão consistente de AS 5 como sendo o originador da rede 10.0.0.0/24.

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.


Informações Relacionadas


Document ID: 13758