IP : Border Gateway Protocol (BGP)

Exemplo de configuração para iBGP e eBGP, com ou sem um endereço de loopback

16 Janeiro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (18 Dezembro 2015) | Feedback


Índice


Introdução

O BGP é um protocolo de gateway exterior (EGP) usado para executar o roteamento interdomínios em redes TCP/IP. Um roteador BGP precisa estabelecer uma conexão (na porta TCP 179) para cada um de seus peers BFP antes que as atualizações do BGP sejam trocadas. A sessão do BGP entre dois peers BGP é considerada uma seção BGP externa (eBGP) se os peers BGP estão em diferentes sistemas autônomos (AS). Uma sessão BGP entre dois peers BGP é considerada uma sessão BGP interna se os peers BGP estão nos mesmos sistemas autônomos.

À revelia, o relacionamento de peer é estabelecido usando o endereço IP de Um ou Mais Servidores Cisco ICM NT da relação a mais próxima ao roteador de peer. Contudo, usando o comando neighbor update-source, toda a relação operacional, incluindo a interface de loopback, pode ser especificada para ser usado estabelecendo conexões de TCP. Este método de espreitar que usa uma interface de loopback é útil desde que não derrubará a sessão de BGP quando há caminhos múltiplos entre os bgp peer, que conduziriam de outra maneira a rasgar para baixo a sessão de BGP se a interface física usada estabelecendo a sessão vai para baixo. Além do que isso, igualmente permite o Roteadores que executa o BGP com links múltiplos entre eles para carregar o equilíbrio sobre os caminhos disponíveis.

Os exemplos de configurações neste documento referem-se ao iBGP e ao eBGP, ambos com e sem endereços de loopback.

Nota: Você pode usar essas configurações para estabelecer relação entre vizinhos. Refira a utilização do protocolo Protocolo de la puerta de enlace marginal (BGP) para o roteamento de Interdomain para mais configurações complexas.

Pré-requisitos

Requisitos

Antes que você tente esta configuração, assegure-se de que você cumpra esta exigência:

  • Conhecimento de protocolos BGP

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas. As saídas do comando mostradas neste documento foram tomadas dos 2500 Series Router que executam a versão 12.2(24a) do IO.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurar

Esta seção contém os seguintes exemplos de configuração:

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/13751-23a.gif

configuração de iBGP

Nesta configuração, ambo o Roteadores está no AS400.

R1-AGS R6-2500
Current configuration:

!-- Output suppressed.

interface Serial1
 ip address 10.10.10.1 255.255.255.0
!
router bgp 400

!--- Enables BGP for the autonomous
!--- system 400.

 neighbor 10.10.10.2 remote-as 400
 
!--- Specifies a neighbor 10.10.10.2
 !--- in the remote AS 400, making
 !--- this an iBGP connection.  
!-- Output suppressed.

end
Current configuration:

!-- Output suppressed.

interface Serial0
ip address 10.10.10.2 255.255.255.0
!
router bgp 400
 neighbor 10.10.10.1 remote-as 400

!-- Output suppressed.

end

configuração de eBGP

Nesta configuração, o roteador R1-AGS está no AS300 e o roteador R6-2500 está no AS400.

R1-AGS R6-2500
Current configuration:

!-- Output suppressed

interface Serial1
 ip address 10.10.10.1 255.255.255.0
!
router bgp 300

!--- Enables BGP for the autonomous
!--- system 300.

 neighbor 10.10.10.2 remote-as 400
 
!--- Specifies a neighbor 10.10.10.2
 !--- in the remote AS 400, making
 !--- this an eBGP connection.


!-- Output suppressed.

end
Current configuration:

!-- Output suppressed.

interface Serial0
ip address 10.10.10.2 255.255.255.0
!
router bgp 400
 neighbor 10.10.10.1 remote-as 300

!-- Output suppressed.

end

Os peers devem ser conectados diretamente ao usar o eBGP. Se não são conectados diretamente, o comando neighbor ebgp-multihop deve ser usado e um trajeto através de um IGP ou de uma rota estática para alcançar o par deve existir para que o Roteadores estabeleça o relacionamento vizinho. Na configuração acima, o roteador R1-AGS pertence ao AS300 quando o roteador R6-2500 pertencer ao AS400.

configuração de iBGP com um endereço de loopback

Você pode configurar o iBGP usando um endereço de loopback (ou alguma outra relação operacional) segundo as indicações desta seção.

R1-AGS R6-2500
Current configuration:


!-- Output suppressed.

interface Loopback0
  ip address 1.1.1.1 255.255.255.255
 !
 interface Serial1
  ip address 10.10.10.1 255.255.255.0
 !
 router bgp 300
  neighbor 2.2.2.2 remote-as 300
  neighbor 2.2.2.2 update-source Loopback0
  
!--- This command specifies that the TCP
  !--- connection with the specified external
  !--- peer should be established using the
  !--- address on the loopback interface.

 !
 ip route 2.2.2.2 255.255.255.255 10.10.10.2
 
!--- This static route ensures that the 
 !--- remote peer address used for peering
 !--- is reachable.
!-- Output suppressed.

end
Current configuration:


!-- Output suppressed.

interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Serial0
 ip address 10.10.10.2 255.255.255.0
!
router bgp 300
 neighbor 1.1.1.1 remote-as 300
 neighbor 1.1.1.1 update-source Loopback0
!
ip route 1.1.1.1 255.255.255.255 10.10.10.1

!-- Output suppressed.

end

configuração de eBGP com um endereço de loopback

Você pode igualmente configurar o eBGP usando um endereço de loopback (ou alguma outra relação operacional) segundo as indicações desta seção. As interfaces de loopback são usadas desse modo para garantir a alcançabilidade nas redes com os caminhos múltiplos segundo as indicações do compartilhamento de carga usando o endereço de loopback como uma seção do vizinho de BGP do compartilhamento de carga com o BGP no ambientes únicos e multihomed: Configurações de amostra.

R1-AGS R6-2500
Current configuration:


!-- Output suppressed.


interface Loopback0
  ip address 1.1.1.1 255.255.255.255
 !
 interface Serial1
  ip address 10.10.10.1 255.255.255.0
 !
 router bgp 300
  neighbor 2.2.2.2 remote-as 400
  neighbor 2.2.2.2 ebgp-multihop 2
 
 !--- This command changes the ttl value in 
  !--- order to allow the packet to reach the 
  !--- external BGP peer which is not directly
  !--- connected or is using an interface other
  !--- than the directly connected interface.

  neighbor 2.2.2.2 update-source Loopback0
  
!--- This command specifies that the TCP
  !--- connection with the external BGP
  !--- peer should be established using the
  !--- address on the loopback interface.
 !

 ip route 2.2.2.2 255.255.255.255 10.10.10.2

 !--- This static route ensures that the 
 !--- remote peer address used for peering
 !--- is reachable.


!-- Output suppressed.


end
Current configuration:


!-- Output suppressed.


interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Serial0
 ip address 10.10.10.2 255.255.255.0
!
router bgp 400
 neighbor 1.1.1.1 remote-as 300
 neighbor 1.1.1.1 ebgp-multihop 2
 neighbor 1.1.1.1 update-source Loopback0
!
ip route 1.1.1.1 255.255.255.255 10.10.10.1


!-- Output suppressed.


end

Verificar

Essas seções fornecem informações que você pode usar para confirmar que suas configurações estão funcionando corretamente. Determinados comandos show são suportados pela Ferramenta Output Interpreter, que permite que você veja uma análise do resultado do comando show.

Verifique a configuração de iBGP

Use o comando show ip bgp neighbors ao Exibir informação sobre as conexões TCP e de Border Gateway Protocol (BGP) e verifique se o bgp peer é estabelecido. A saída do comando show ip bgp neighbors abaixo mostra o estado BGP como “estabelecido”, que indica que o relacionamento do bgp peer esteve estabelecido com sucesso.

R1-AGS# show ip bgp neighbors | include BGP
BGP neighbor is 10.10.10.2,  remote AS 400, internal link
  BGP version 4, remote router ID 2.2.2.2
  BGP state = Established, up for 00:04:20
  BGP table version 1, neighbor version 1
R1-AGS#

O comando show ip bgp neighbors foi usado acima com o modificador | inclua o BGP. Isto faz a saída mais legível filtrando o o comando output e indicando as partes relevantes somente.

Além, o comando show ip bgp summary pode igualmente ser usado para indicar o estado de todas as conexões BGP, como mostrado abaixo.

R1-AGS(9)# show ip bgp summary
BGP router identifier 10.1.1.2, local AS number 400	
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.10.10.2      4   400       3       3        1    0    0 00:00:26        0

Verifique a configuração de eBGP

Use o comando show ip bgp neighbors ao Exibir informação sobre as conexões TCP e de Border Gateway Protocol (BGP) e verifique se o bgp peer é estabelecido. A saída do comando show ip bgp neighbors abaixo mostra o estado BGP como “estabelecido”, que indica que o relacionamento do bgp peer esteve estabelecido com sucesso.

R1-AGS# show ip bgp neighbors | include BGP
BGP neighbor is 10.10.10.2,  remote AS 400, external link
  BGP version 4, remote router ID 2.2.2.2
  BGP state = Established, up for 00:00:17
  BGP table version 1, neighbor version 1

Além, o comando show ip bgp summary pode igualmente ser usado para indicar o estado de todas as conexões BGP, como mostrado abaixo.

R1-AGS(9)# show ip bgp summary
BGP router identifier 10.10.10.1, local AS number 300
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.10.10.2      4   400       3       3        1    0    0 00:00:26        0

Verifique a configuração de iBGP com um endereço de loopback

Use o comando show ip bgp neighbors ao Exibir informação sobre as conexões TCP e de Border Gateway Protocol (BGP) e verifique se o bgp peer é estabelecido. A saída do comando show ip bgp neighbors abaixo mostra o estado BGP como “estabelecido”, que indica que o relacionamento do bgp peer esteve estabelecido com sucesso.

R1-AGS# show ip bgp neighbors | include BGP
BGP neighbor is 2.2.2.2,  remote AS 300, internal link
  BGP version 4, remote router ID 2.2.2.2
  BGP state = Established, up for 00:00:28
  BGP table version 1, neighbor version 1
R1-AGS#

Além, o comando show ip bgp summary pode igualmente ser usado para indicar o estado de todas as conexões BGP, como mostrado abaixo.

R1-AGS(9)# show ip bgp summary
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.2         4   400       3       3        1    0    0 00:00:26        0

Verifique a configuração de eBGP com um endereço de loopback

Use o comando show ip bgp neighbors ao Exibir informação sobre as conexões TCP e de Border Gateway Protocol (BGP) e verifique se o bgp peer é estabelecido. A saída do comando show ip bgp neighbors abaixo mostra o estado BGP como “estabelecido”, que indica que o relacionamento do bgp peer esteve estabelecido com sucesso.

R1-AGS# show ip bgp neighbors | include BGP
BGP neighbor is 2.2.2.2,  remote AS 400, external link
  BGP version 4, remote router ID 2.2.2.2
  BGP state = Established, up for 00:00:16
  BGP table version 1, neighbor version 1
  External BGP neighbor may be up to 2 hops away.

Além, o comando show ip bgp summary pode igualmente ser usado para indicar o estado de todas as conexões BGP, como mostrado abaixo.

R1-AGS(9)# show ip bgp summary
BGP router identifier 1.1.1.1, local AS number 300
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.2         4   400       3       3        1    0    0 00:00:26        0

Troubleshooting

Refira porque faça vizinhos de BGP firmam entre a quietude, conectam, e estados ativos? e pesquisando defeitos o BGP para a informação de Troubleshooting.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 13751