Multiprotocol Label Switching (MPLS) : MPLS

Configurando a engenharia de tráfego MPLS básico usando o IS-IS

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Esta configuração de exemplo mostra como implantar a engenharia de tráfego (TE) sobre uma rede Multiprotocol Label Switching (MPLS) existente usando Frame Relay e Intermediate System-to-Intermediate System (IS-IS). Neste exemplo, são implantados dois túneis dinâmicos (automaticamente configurados por Label Switch Routers [LSR] de ingresso) e dois túneis que usam caminhos explícitos.

O TE é um nome genérico que corresponda ao uso de Tecnologias diferentes aperfeiçoar a utilização de uma capacidade de backbone e de uma topologia dadas.

O MPLS TE oferece uma maneira de integrar as capacidades de TE (tais como as usadas nos protocolos da camada 2 como ATM) em protocolos da camada 3 (IP). O MPLS TE usa uma extensão aos protocolos existentes ([RSVP] do protocolo de reserva de recursos, IS-IS, [OSPF] aberto do caminho mais curto primeiro) para calcular e estabelecer os túneis unidirecional que são ajustados de acordo com a limitação de rede. Os fluxos de tráfego são mapeados em túneis diferentes dependendo de seus destinos.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Software Release 12.0(11)S e 12.1(3a)T de Cisco IOS�

  • Cisco 3600 Routers

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Componentes funcionais

Componente Descrição
Interfaces de túnel de IP Camada 2: Uma interface de túnel MPLS é a principal de um LSP (Caminho comutado do rótulo). É configurada com um conjunto de requisitos de recursos, tais como largura de banda e prioridade. Camada 3: a interface de túnel LSP é a extremidade principal de um link virtual unidirecional para o destino do túnel.
RSVP com extensão TE O RSVP é usado para estabelecer e manter os túneis LSP baseados no caminho calculado usando o PATH e os mensagens de RESV. A especificação do protocolo RSVP foi estendida para que as mensagens RESV distribuam também informações sobre o rótulo.
Link-state IGP (IS-IS ou OSPF com extensão Te) Usado para obtenção de informações de topologia de inundação e recursos a partir do módulo de gerenciamento de enlaces. O IS-IS usa o Tipo-Comprimento-Valores novo (TLV) e o tipo propagandas dos usos OSPF do estado do link 10 (igualmente chamadas opaques lsa).
Módulo de cálculo de caminho MPLS TE Opera apenas no início do LSP e determina um caminho utilizando informações do banco de dados do estado do enlace.
Módulo de gerenciamento de enlaces TE MPLS Em cada salto LSP, esse módulo executa a admissão de chamada do link nas mensagens de sinalização de RSVP e a contabilidade da topologia e das informações de recurso a serem liberadas pelo OSPF ou pelo IS-IS.
Encaminhamento de switching de rótulo Mecanismo básico de encaminhamento de MPLS com base em rótulos.

Configurar

Diagrama de Rede

Este documento utiliza a configuração de rede mostrada neste diagrama.

/image/gif/paws/13737/mplsteisis1.gif

Configurações

Guia de configurações rápidas

Este procedimento pode ser usado para executar uma configuração rápida. Para mais informação detalhada, refira a Engenharia de tráfego MPLS e os realces.

  1. Estabelecer sua rede com a configuração comum (neste caso, o Frame Relay é usado).

    Nota: É imperativo estabelecer uma interface de loopback com uma máscara IP de 32 bit.

    Este endereço é usado para estabelecido da rede MPLS e do TE pelo protocolo de roteamento. Esse endereço de circuito fechado deve ser acessível por meio da tabela de roteamento global.

  2. Configurando um Routing Protocol para a rede MPLS. Deve ser um protocolo de estado de link (IS-IS ou OSPF). No modo de configuração de protocolo de roteamento, entre:

    • Para IS-IS:

      metric-style wide (or metric-style both) 
      mpls traffic-eng router-id LoopbackN 
      mpls traffic-eng [level-1 | level-2 |]
    • Para OSPF:

      mpls traffic-eng area X 
      mpls traffic-eng router-id LoopbackN (must have a 255.255.255.255 mask)
  3. Habilitar MPLS TE. Insira o ip cef (ou o ip cef distribuído se disponível para aprimorar o desempenho) no modo de configuração geral. Habilite o MPLS (tag-switching ip) em cada interface envolvida. Incorpore o túnel da Engenharia de tráfego MPLS para permitir o MPLS TE, assim como o RSVP para túneis TE da zero-largura de banda.

  4. Permita o RSVP incorporando a largura de banda XXX do rsvp IP em cada interface de interesse para túneis diferente de zero da largura de banda.

  5. Configurar canais para serem usados para TE. Há muitas opções que podem ser configuradas para o túnel do MPLS TE, mas o comando tunnel mode mpls traffic-eng é imperativo. O comando tunnel mpls traffic-eng autoroute announce anuncia a presença do túnel através do Routing Protocol.

Nota: Não se esqueça de usar ip unnumbered loopbackN para o endereço IP das interfaces de túnel.

Esta configuração de exemplo mostram dois túneis dinâmicos com largura de banda diferente (e prioridades) que vai do roteador Pescara ao roteador Pesaro, e dois túneis que usam um caminho explícito que vá de Pesaro a Pescara.

Arquivo de configuração

Apenas as partes relevantes dos arquivos de configuração estão incluídas. Os comandos usados para permitir o MPLS estão italicizados, quando os comandos específicos ao TE (que inclui o RSVP) estiverem em corajoso.

Pesaro
Current configuration:
 !
 version 12.1
 !
 hostname Pesaro
 !
 ip cef
 mpls traffic-eng tunnels
 !
 interface Loopback0
  ip address 10.10.10.6 255.255.255.255
  ip router isis 
 !
 interface Tunnel158
  ip unnumbered Loopback0
  tunnel destination 10.10.10.4
  tunnel mode mpls traffic-eng
  tunnel mpls traffic-eng autoroute announce
  tunnel mpls traffic-eng priority 2 2
  tunnel mpls traffic-eng bandwidth 158
  tunnel mpls traffic-eng path-option 1 explicit name low
 !
 interface Tunnel159
  ip unnumbered Loopback0
  tunnel destination 10.10.10.4
  tunnel mode mpls traffic-eng
  tunnel mpls traffic-eng autoroute announce
  tunnel mpls traffic-eng priority 4 4
  tunnel mpls traffic-eng bandwidth 159
  tunnel mpls traffic-eng path-option 1 explicit name straight
 !

 interface Serial0/0
  no ip address
  encapsulation frame-relay
 !
 interface Serial0/0.1 point-to-point
  bandwidth 512
  ip address 10.1.1.22 255.255.255.252
  ip router isis 
  tag-switching ip
  mpls traffic-eng tunnels 
  frame-relay interface-dlci 603   
  ip rsvp bandwidth 512 512
 !
 router isis 
  net 49.0001.0000.0000.0006.00
  is-type level-1
  metric-style wide
  mpls traffic-eng router-id Loopback0
  mpls traffic-eng level-1
 !
 !
 ip classless
 !
 ip explicit-path name low enable
  next-address 10.1.1.21 
  next-address 10.1.1.10 
  next-address 10.1.1.1 
  next-address 10.1.1.14 
 !
 ip explicit-path name straight enable
  next-address 10.1.1.21 
  next-address 10.1.1.5 
  next-address 10.1.1.14 
 !
 end

Pescara
Current configuration:
 !
 version 12.0
 !
 hostname Pescara
 !

 ip cef
 !
 mpls traffic-eng tunnels
 !
 interface Loopback0
  ip address 10.10.10.4 255.255.255.255
  ip router isis 
 !
 interface Tunnel1
  ip unnumbered Loopback0

  tunnel destination 10.10.10.6
  tunnel mode mpls traffic-eng
  tunnel mpls traffic-eng autoroute announce
  tunnel mpls traffic-eng priority 5 5
  tunnel mpls traffic-eng bandwidth 25
  tunnel mpls traffic-eng path-option 2 dynamic
 !
 interface Tunnel3
  ip unnumbered Loopback0

  tunnel destination 10.10.10.6
  tunnel mode mpls traffic-eng
  tunnel mpls traffic-eng autoroute announce
  tunnel mpls traffic-eng priority 6 6
  tunnel mpls traffic-eng bandwidth  69
  tunnel mpls traffic-eng path-option 1 dynamic
 !

 interface Serial0/1
  no ip address
  encapsulation frame-relay
 !
 interface Serial0/1.1 point-to-point
  bandwidth 512
  ip address 10.1.1.14 255.255.255.252

  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 401   
  ip rsvp bandwidth 512 512
 !
 router isis 
  net 49.0001.0000.0000.0004.00
  is-type level-1
  metric-style wide
  mpls traffic-eng router-id Loopback0
  mpls traffic-eng level-1
 !
 end

Pomerol
Current configuration:

 version 12.0
 !
 hostname Pomerol
 !
 ip cef
 !
 mpls traffic-eng tunnels
!
 interface Loopback0
  ip address 10.10.10.3 255.255.255.255
  ip router isis 
 !
 interface Serial0/1
  no ip address
  encapsulation frame-relay
 !
 interface Serial0/1.1 point-to-point
  bandwidth 512
  ip address 10.1.1.6 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
   frame-relay interface-dlci 301   
  ip rsvp bandwidth 512 512
 !
 interface Serial0/1.2 point-to-point
  bandwidth 512
  ip address 10.1.1.9 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 302   
  ip rsvp bandwidth 512 512
 !
 interface Serial0/1.3 point-to-point
  bandwidth 512
  ip address 10.1.1.21 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 306   
  ip rsvp bandwidth 512 512
 !
 router isis 
  net 49.0001.0000.0000.0003.00
  is-type level-1
  metric-style wide
  mpls traffic-eng router-id Loopback0
  mpls traffic-eng level-1
 !
 ip classless
 !
 end

Pulligny
Current configuration:
 !
 version 12.1
 !
 hostname Pulligny
 !
 ip cef
 !
 mpls traffic-eng tunnels
 !
 interface Loopback0
  ip address 10.10.10.2 255.255.255.255
 !
 interface Serial0/1
  no ip address
  encapsulation frame-relay
 !
 interface Serial0/1.1 point-to-point
  bandwidth 512
  ip address 10.1.1.2 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 201   
  ip rsvp bandwidth 512 512
 !
 interface Serial0/1.2 point-to-point
  bandwidth 512
  ip address 10.1.1.10 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 203   
  ip rsvp bandwidth 512 512
 !
 router isis 
  passive-interface Loopback0
  net 49.0001.0000.0000.0002.00
  is-type level-1
  metric-style wide
  mpls traffic-eng router-id Loopback0
  mpls traffic-eng level-1
 !
 ip classless
 !
 end

Pauillac
!
 version 12.1
 !
 hostname pauillac
 !
 ip cef
 mpls traffic-eng tunnels
 !
 interface Loopback0
  ip address 10.10.10.1 255.255.255.255
  ip router isis 
 !
 interface Serial0/0
  no ip address
  encapsulation frame-relay
 !
 interface Serial0/0.1 point-to-point
  bandwidth 512
  ip address 10.1.1.1 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 102   
  ip rsvp bandwidth 512 512
 !
 interface Serial0/0.2 point-to-point
  bandwidth 512
  ip address 10.1.1.5 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 103   
  ip rsvp bandwidth 512 512
 !
 interface Serial0/0.3 point-to-point
  bandwidth 512
  ip address 10.1.1.13 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 104   
  ip rsvp bandwidth 512 512
 !
 router isis 
  net 49.0001.0000.0000.0001.00
  is-type level-1
  metric-style wide
  mpls traffic-eng router-id Loopback0
  mpls traffic-eng level-1
 !
 ip classless
 !
 end

Verificar

comandos show

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

  • show mpls traffic-eng tunnels brief

  • mostre a mpls o nome tráfego-inglês Pesaro_t158 dos túneis

  • mostre a relação do rsvp IP

  • mostre a mpls a largura de banda tráfego-inglesa 75 de 10.10.10.6 do destino do trajeto da topologia

Outros comandos úteis (não ilustrados aqui) incluem:

  • mostre a mpls isis propagandas tráfego-inglesas

  • show tag-switching forwarding-table

  • mostre o cef IP

  • mostre a mpls os túneis tráfego-ingleses sumários

Exemplo de saída de show

Em todo o LSR, você pode usar túneis tráfego-ingleses dos mpls da mostra para verificar a existência e o estado dos túneis. Por exemplo, em Pesaro, você vê um total de quatro túneis, dois que chegam em Pesaro (Pescara_t1 e T3) e dois que partem de Pesaro (t158 e t159):

Pesaro#show mpls traffic-eng tunnels brief 
Signaling Summary:
    LSP Tunnels Process:            running
    RSVP Process:                   running
    Forwarding:                     enabled
    Periodic reoptimization:        every 3600 seconds, next in 606 seconds
TUNNEL NAME                      DESTINATION      UP IF     DOWN IF   STATE/PROT
Pesaro_t158                      10.10.10.4       -         Se0/0.1   up/up
Pesaro_t159                      10.10.10.4       -         Se0/0.1   up/up     
Pescara_t1                       10.10.10.6       Se0/0.1   -         up/up     
Pescara_t3                       10.10.10.6       Se0/0.1   -         up/up     
Displayed 2 (of 2) heads, 0 (of 0) midpoints,2 (of 2) tails

Este é o que é visto quando em um roteador intermediária:

Pulligny#show mpls traffic-eng tunnels brief 
Signaling Summary:
    LSP Tunnels Process:            running
    RSVP Process:                   running
    Forwarding:                     enabled
    Periodic reoptimization:        every 3600 seconds, next in 406 seconds
TUNNEL NAME                      DESTINATION      UP IF     DOWN IF   STATE/PROT
Pescara_t3                       10.10.10.6       Se0/1.1   Se0/1.2   up/up
Pesaro_t158                      10.10.10.4       Se0/1.2   Se0/1.1   up/up
Displayed 0 (of 0) heads, 2 (of 2) midpoints, 0 (of 0) tails

A configuração detalhada de todo o túnel pode ser considerada usar esta:

Pesaro#show mpls traffic-eng tunnels name Pesaro_t158

Name: Pesaro_t158                         (Tunnel158) Destination: 10.10.10.4
  Status:
    Admin: up         Oper: up     Path: valid       Signaling: connected

    path option 1, type explicit low (Basis for Setup, path weight 40)

  Config Parameters:
    Bandwidth:  158      kbps  Priority: 2  2   Affinity: 0x0/0xFFFF
    AutoRoute:  enabled   LockDown: disabled    

  InLabel  :  - 
  OutLabel : Serial0/0.1, 17
  RSVP Signaling Info:
       Src 10.10.10.6, Dst 10.10.10.4, Tun_Id 158, Tun_Instance 1601
    RSVP Path Info:
      My Address: 10.10.10.6   
      Explicit Route: 10.1.1.21 10.1.1.10 10.1.1.1 10.1.1.14 
 10.10.10.4 
      Record   Route:  NONE
      Tspec: ave rate=158 kbits, burst=8000 bytes, peak rate=158 kbits
    RSVP Resv Info:
      Record   Route:  NONE
      Fspec: ave rate=158 kbits, burst=8000 bytes, peak rate=4294967 kbits
  History:
    Current LSP:
      Uptime: 3 hours, 33 minutes
      Selection: reoptimation
    Prior LSP:
      ID: path option 1 [1600]
      Removal Trigger: configuration changed

Neste caso, o trajeto é explícito e especificado no mensagem de RSVP (o campo que leva o trajeto é sabido igualmente como o [ERO] do objeto de ruta específica). Se este trajeto não pode ser seguido, o Engine de MPLS TE usa a opção seguinte do trajeto, que pode ser uma outra rota explícita ou uma rota dinâmica.

A informação específica RSVP está disponível usando comandos rsvp padrão. Nesta saída, há duas reservas feitas em Pulligny, em um por Pesaro_t158 (158K) e no outro por Pescara_t3 (69k).

Pulligny#show ip rsvp interface
interface    allocated  i/f max  flow max pct UDP  IP   UDP_IP   UDP M/C 
Se0/1        0M         0M       0M       0   0    0    0        0       
Se0/1.1      158K       512K     512K     30  0    1    0        0 
Se0/1.2      69K        512K     512K     13  0    1    0        0

Se você quer saber que caminho TE está usado para um destino particular (e uma largura de banda específica) sem criar um túnel, você pode usar este comando:

Nota: Note por favor que este comando está envolvido a uma segunda linha para razões espaciais.

Pescara#show mpls traffic-eng topology path destination 
                          10.10.10.6 bandwidth 75
Query Parameters:
  Destination: 10.10.10.6
    Bandwidth: 75
   Priorities: 0 (setup), 0 (hold)
     Affinity: 0x0 (value), 0xFFFFFFFF (mask)
Query Results:
  Min Bandwidth Along Path: 385 (kbps)
  Max Bandwidth Along Path: 512 (kbps)
  Hop  0: 10.1.1.14      : affinity 00000000, bandwidth 512 (kbps)
  Hop  1: 10.1.1.5       : affinity 00000000, bandwidth 385 (kbps)
  Hop  2: 10.1.1.21      : affinity 00000000, bandwidth 512 (kbps)
  Hop  3: 10.10.10.6

Se a rede faz a propagação TTL IP (refira a propagação dos mpls IP ttl), emita um comando traceroute e veja que o trajeto seguido é o túnel e que as rotas do túnel de acordo com o que é configurado:

Pescara#traceroute 10.10.10.6

Type escape sequence to abort.
Tracing the route to 10.10.10.6

  1 10.1.1.13 [MPLS: Label 29 Exp 0] 540 msec 312 msec 448 msec
  2 10.1.1.2 [MPLS: Label 27 Exp 0] 260 msec 276 msec 556 msec
  3 10.1.1.9 [MPLS: Label 29 Exp 0] 228 msec 244 msec 228 msec
  4 10.1.1.22 112 msec *  104 msec

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 13737