Multiprotocol Label Switching (MPLS) : MPLS

Configurando MPLS básico utilizando OSPF

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento mostra como configurar uma rede básica de Multiprotocol Label Switching (MPLS). Refira exemplos de configuração e TechNotes na página de suporte MPLS para obter mais informações sobre de como configurar tópicos avançados tais como VPN ou engenharia de tráfego (TE).

Pré-requisitos

Requisitos

Cisco recomenda que você é familiar com a operação básica do MPLS. Refira a vista geral do Multiprotocol Label Switching para uma vista geral do MPLS.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Software Release 12.2(28) de Cisco IOS�

  • Cisco 3600 Routers

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Mecanismo

Uma rede de MPLS normalmente é uma rede backbone composta por roteadores habilitados para MPLS denominados Label Switch Routers (LSR). Geralmente, a rede consiste em um núcleo LSR com uma borda LSR que aplique etiquetas aos pacotes.

Este é o mecanismo da instalação de uma rede MPLS:

  1. As tabelas de roteamento dos LSR diferentes são computadas com um Interior Gateway Protocol (IGP). Um protocolo de estado de enlace, tal como o Open Shortest Path First (OSPF) ou o Intermediate System-to-Intermediate System (IS-IS), é exigido se você planeia distribuir o MPLS TE.

  2. Um LDP (protocolo de distribuição de rótulo) anuncia as associações entre rotas e rótulos. Essas associações são verificadas com relação a uma tabela de roteamento. Se a rota (prefixo/máscara e salto seguinte) aprendida do LDP combina a rota aprendida do IGP na tabela de roteamento, uma entrada está criada na etiqueta as bases dessa informação dos forwards (LFIB) no LSR.

O LSR usa este mecanismo de forwarding:

  1. Uma vez que uma borda LSR recebe um pacote não rotulado, a tabela do Cisco Express Forwarding está verificada e uma etiqueta é imposta no pacote se necessária. Este LSR é chamado de LSR de ingresso.

  2. Em cima da chegada de um pacote rotulado na interface de entrada de um núcleo LSR, o LFIB fornece a interface externa e a etiqueta nova que é associada com o pacote externo.

  3. O roteador antes do último LSR (o penúltimo salto) exibe o rótulo e transmite o pacote sem o rótulo. O último salto é chamado de LSR de saída.

Este diagrama ilustra esta instalação de rede:

/image/gif/paws/13736/1b.gif

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Na informação adicional do achado FO de ordem nos comandos usados neste documento, use a ferramenta de consulta de comandos (clientes registrados somente).

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/13736/1a.gif

Manual de configuração rápida

Use este procedimento como um manual de configuração rápida.

  1. Estabelecer sua rede como de costume. O MPLS precisa uma conexão IP padrão a fim estabelecer bases de encaminhamento.

  2. Assegure-se de que o protocolo de roteamento (OSPF ou IS-IS) trabalhe corretamente. Estes comandos são italicizados nas configurações na próxima seção.

  3. Permita o cef IP, porque os melhores desempenhos usam o cef IP distribuído quando disponíveis, no modo de configuração geral. Isto é mostrado em corajoso nas configurações na próxima seção.

  4. Permita os mpls IP, ou o tag-switching IP em uns Cisco IOS Software Release mais velhos, no modo de configuração geral e em cada relação, segundo as indicações de corajoso nas configurações na próxima seção. Mesmo quando o comando mpls ip é usado, a saída running da mostra pode ainda mostrar o comando como o tag-switching IP em alguns Cisco IOS Software Release, segundo as indicações das configurações na próxima seção.

    Nota: Os LSR devem ter (acima) interfaces de loopback com uma máscara de endereço de 32 bit e estas relações devem ser alcançáveis com a tabela de roteamento do IP global.

Configurações

Este documento utiliza as seguintes configurações:

Pomerol

!
version 12.2

!
hostname Pomerol
!
ip subnet-zero
!
ip cef
!
interface Loopback0
 ip address 10.10.10.3 255.255.255.255
!
interface Serial2/0
 ip address 10.1.1.21 255.255.255.252
 tag-switching ip
!
interface Serial3/0
 ip address 10.1.1.6 255.255.255.252
 tag-switching ip
!
interface Serial4/0
 ip address 10.1.1.9 255.255.255.252
 tag-switching ip
!
router ospf 10
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 9
! 
ip classless
!
end

Pulligny

!
version 12.2
!
hostname Pulligny
!
!
ip subnet-zero
!
ip cef
!
interface Loopback0
 ip address 10.10.10.2 255.255.255.255
!
interface Serial2/0
 ip address 10.1.1.2 255.255.255.252
 tag-switching ip
!
interface Serial3/0
 ip address 10.1.1.10 255.255.255.252
 tag-switching ip
!
router ospf 10
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 9
!
ip classless
!
end

Pauillac
!
version 12.2
!
hostname Pauillac
!
ip subnet-zero
!
ip cef
!
interface Loopback0
 ip address 10.10.10.1 255.255.255.255
!
interface Serial2/0
 ip address 10.1.1.13 255.255.255.252
 tag-switching ip
!
interface Serial3/0
 ip address 10.1.1.17 255.255.255.252
 tag-switching ip
!
interface Serial4/0
 ip address 10.1.1.1 255.255.255.252
 tag-switching ip
!
interface Serial5/0
 ip address 10.1.1.5 255.255.255.252
 tag-switching ip
!
router ospf 10
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 9
!
ip classless
!
end

Pescara
!
version 12.2
!
hostname Pescara
!
ip subnet-zero
!
ip cef
!
interface Loopback0
 ip address 10.10.10.4 255.255.255.255
!
interface Serial2/0
 ip address 10.1.1.14 255.255.255.252
 tag-switching ip
!
router ospf 10
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 9
!
ip classless
!
end

Pesaro
!
version 12.2
!
hostname Pesaro
!
ip subnet-zero
!
ip cef
!
interface Loopback0
 ip address 10.10.10.6 255.255.255.255
!
interface Serial2/0
 ip address 10.1.1.22 255.255.255.252
 tag-switching ip
!
router ospf 10
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 9
!
ip classless
!
end

Perugia
!
version 12.2
!
hostname Perugia
!
ip subnet-zero
!
ip cef
!
interface Loopback0
 ip address 10.10.10.5 255.255.255.255
!
interface Serial2/0
 ip address 10.1.1.18 255.255.255.252
 tag-switching ip
!
router ospf 10
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 9
!
ip classless
!
end

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração funciona adequadamente.

Os comandos usados no MPLS básico configurando que usa a configuração de amostra de IS-IS são igualmente aplicáveis.

A fim ilustrar esta configuração de exemplo, olhe um destino particular, por exemplo 10.10.10.4, em Pomerol LSR.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

  • mostre a rota IP — Usado para verificar a rota IP para ver se há este destino na tabela de IP Routing:

    Pomerol#show ip route 10.10.10.4
    Routing entry for 10.10.10.4/32
      Known via "ospf 10", distance 110, metric 129, type intra area
      Last update from 10.1.1.5 on Serial3/0, 17:29:23 ago
      Routing Descriptor Blocks:
      * 10.1.1.5, from 10.10.10.4, 17:29:23 ago, via Serial3/0
          Route metric is 129, traffic share count is 1
    
  • mostre a tabela do forwarding dos mpls — Usado para verificar a tabela do forwarding MPLS, que é o lable switching equivalente da tabela de IP Routing para Roteamento IP padrão. Contém etiquetas e descrições de entrada e de partida dos pacotes.

    Pomerol#show mpls forwarding-table 
    Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
    tag    tag or VC   or Tunnel Id      switched   interface
    16     Pop tag     10.1.1.12/30      636        Se3/0      point2point
    17     Pop tag     10.10.10.1/32     0          Se3/0      point2point
    18     21          10.10.10.4/32     0          Se3/0      point2point
    19     Pop tag     10.1.1.0/30       0          Se4/0      point2point
           Pop tag     10.1.1.0/30       0          Se3/0      point2point
    20     Pop tag     10.10.10.6/32     612        Se2/0      point2point
    21     Pop tag     10.1.1.16/30      0          Se3/0      point2point
    22     16          10.10.10.5/32     0          Se3/0      point2point
    23     Pop tag     10.10.10.2/32     0          Se4/0      point2point
  • detalhe de tabela de encaminhamento mpls da mostra — Usado para ver detalhes de tabela de encaminhamento mpls:

    Pomerol#show mpls forwarding-table 10.10.10.4 32 detail
    Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
    tag    tag or VC   or Tunnel Id      switched   interface
    18     21          10.10.10.4/32     0          Se3/0      point2point
            MAC/Encaps=4/8, MRU=1500, Tag Stack{21}
            0F008847 00015000
            No output feature configured
        Per-packet load-sharing
  • mostre emperramentos do ldp dos mpls ou mostre os emperramentos do tdp do tag-switching (baseados em que Cisco IOS Software Release o uso) — usado para ver as ligações de rótulo associadas com um destino particular. Os emperramentos locais assim como remotos podem ser vistos.

    Pomerol#show tag-switching tdp bindings 10.10.10.4 32
      tib entry: 10.10.10.4/32, rev 14
            local binding:  tag: 18
            remote binding: tsr: 10.10.10.1:0, tag: 21
            remote binding: tsr: 10.10.10.2:0, tag: 23
            remote binding: tsr: 10.10.10.6:612, tag: 20 
    
    

    Note que as etiquetas para cada classe de encaminhamento estão estabelecidas em cada LSR, mesmo se não estão no trajeto (o mais curto) preferido. Neste caso, um pacote destinado a 10.10.10.4/32 pode ir por 10.10.10.1 (com etiqueta 21) ou por 10.10.10.2 (com etiqueta 23). O LSR seleciona primeira solução porque é a mais curta. Esta decisão é feita com a tabela de IP Routing padrão, que neste caso, é construída com OSPF.

  • mostre o detalhe do cef IP — Usado para certificar-se do Cisco Express Forwarding trabalhe corretamente e que as etiquetas estão trocadas corretamente:

    Pomerol#show ip cef 10.10.10.4 detail
    10.10.10.4/32, version 37, cached adjacency to Serial3/0
    0 packets, 0 bytes
      tag information set
        local tag: 18
        fast tag rewrite with Se3/0, point2point, tags imposed: {21}
      via 10.1.1.5, Serial3/0, 0 dependencies
        next hop 10.1.1.5, Serial3/0
        valid cached adjacency
        tag rewrite with Se3/0, point2point, tags imposed: {21}
    

Troubleshooting

Refira o Troubleshooting de MPLS para obter informações sobre de como pesquisar defeitos o MPLS.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 13736