Multiprotocol Label Switching (MPLS) : MPLS

Configurando MPLS Básicos Usando IS-IS

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Esta configuração de exemplo mostra como configurar uma rede Multiprotocol Label Switching (MPLS) para tarefas adicionais, como Virtual Private Network (VPN) ou engenharia de tráfego (veja mais Configurações de Exemplo na Página de Suporte MPLS).

Pré-requisitos

Requisitos

Antes de tentar utilizar esta configuração, verifique se os seguintes pré-requisitos são atendidos:

  • A fim executar o MPLS, você precisa um Cisco 2600 Router ou mais tarde.

  • Escolha o Cisco IOS exigido com MPLS usando o Software Advisor (clientes registrados somente).

  • Verifique para ver se há RAM e a memória Flash adicionais exigidos para executar o MPLS no Roteadores. O WAN Interface Card (WIC), o WIC-1T e o WIC-2T, podem ser usados.

Componentes Utilizados

As informações neste documento são baseadas nas versões de software e hardware abaixo.

  • Cisco 3640, Cisco 3660, Cisco4500, e Cisco 2610 Router

  • O Software Release 12.2(6h) de Cisco IOS� está sendo executado em todo o Roteadores

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Material de Suporte

Uma rede de MPLS normalmente é uma rede backbone composta por roteadores habilitados para MPLS denominados Label Switch Routers (LSR). Geralmente, a rede consiste em um LSR central com um LSR de ponta responsável por aplicar rótulos a pacotes.

O mecanismo de instalação de uma rede MPLS é o seguinte.

  • As tabelas de roteamento dos diferentes LSRs são calculados utilizando um Interior Gateway Protocol (IGP). Um protocolo de estado de enlace, como, por exemplo, o Abrir caminho mais curto primeiro (OSPF) ou o Sistema intermediário para sistema intermediário integrado (IS-IS), é obrigatório se você for implementar a Engenharia de tráfego MPLS.

  • Um LDP (protocolo de distribuição de rótulo) anuncia as associações entre rotas e rótulos. Essas associações são verificadas com relação a uma tabela de roteamento. Se a rota (prefixo/máscara e salto seguinte) aprendeu via correspondências de LDP a rota obtida via IGP na tabela de roteamento, uma entrada é criada nos Label Forwarding Information Bases (LFIB) do LSR.

O LSR usa o seguinte mecanismo de forwarding.

  • Como um LSR de borda recebe um pacote sem rótulo, a tabela de encaminhamento expresso da Cisco é verificada, e um rótulo é imposto ao pacote, se necessário. Este LSR é chamado de LSR de ingresso.

  • Quando um pacote rotulado chega na interface de entrada de um LSR central, o LFIB fornece a interface de saída e o novo rótulo que será associado ao pacote de saída.

  • O roteador antes do último LSR (o penúltimo salto) exibe o rótulo e transmite o pacote sem o rótulo. O último salto é chamado de LSR de saída.

O diagrama a seguir ilustra a configuração da rede.

/image/gif/paws/13735/1b.gif

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/13735/1a.gif

Configurações

Este documento utiliza as seguintes configurações:

Manual de configuração rápida

Termine estas etapas para configurar o MPLS:

  1. Configure sua rede como o usual (o MPLS precisa de uma conexão IP padrão para estabelecer bases de encaminhamento).

  2. Verifique se o Routing Protocol (OSPF ou IS-IS) está funcionando corretamente. Estes comandos são mostrados nos itálicos nas configurações nesta seção.

  3. Use o comando ip cef (para melhores desempenhos, use o comando ip cef distributed, quando disponível) no modo de configuração geral (mostrado em negrito nas configurações desta seção) a ser habilitado.

  4. Use o comando mpls ip (ou o comando tag-switching ip em Cisco IOS Software Release mais velhos) no modo de configuração geral e em cada relação (mostrada em corajoso nas configurações nesta seção) permitir.

    Nota:  Os LSRs devem ter interfaces de loopback (ativadas) com uma máscara de endereço de 32 bits.

Pomerol
Current configuration:
!
version 12.2
!
hostname Pomerol
!
ip cef

!--- Enables Cisco Express Forwarding globally.

!
interface Loopback0
 ip address 10.10.10.3 255.255.255.255
 ip router isis 

!--- Assigns an IP address to interface loopback0 
!--- and enables IS-IS for IP on the interface.

!
interface Serial0/0
 encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
 ip address 10.1.1.6 255.255.255.252
 ip router isis   
 tag-switching ip

!--- Enables dynamic Label Switching of 
!--- IPv4 packets on an interface.

 frame-relay interface-dlci 301   
!
interface Serial0/0.2 point-to-point
 ip address 10.1.1.9 255.255.255.252
 ip router isis  
 tag-switching ip
 frame-relay interface-dlci 303   
!
interface Serial0/0.3 point-to-point
 ip address 10.1.1.21 255.255.255.252
 ip router isis 
 tag-switching ip
 frame-relay interface-dlci 306   
!
router isis  
 net 49.0001.0000.0000.0003.00
 is-type level-1
!
ip classless
!
end

Pulligny
Current configuration:
!
version 12.1
!
hostname Pulligny
!
ip cef
!
interface Loopback0
 ip address 10.10.10.2 255.255.255.255
!
interface Serial0/1
 no ip address
 encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
 ip address 10.1.1.2 255.255.255.252
 ip router isis 
 tag-switching ip
 frame-relay interface-dlci 201   
!
interface Serial0/0.2 point-to-point
 ip address 10.1.1.10 255.255.255.252
 ip router isis 
tag-switching ip
 frame-relay interface-dlci 203   
!
router isis
 redistribute static ip
 passive-interface Loopback0
 net 49.0001.0000.0000.0002.00
 is-type level-1

!--- Enables the IS-IS process on the router,
!--- makes loopback interface passive 
!--- (does not send IS-IS packets on interface), 
!--- and assigns area and system ID to router.

!
ip classless
!
end

Pauillac
Current configuration : 2366 bytes
!
version 12.1
!
hostname pauillac
!
ip cef
!
interface Loopback0
 ip address 10.10.10.1 255.255.255.255
 ip router isis
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
 ip address 10.1.1.1 255.255.255.252
 ip router isis
 tag-switching ip
 frame-relay interface-dlci 102   
!
interface Serial0/0.2 point-to-point
 ip address 10.1.1.5 255.255.255.252
 ip access-group 150 out
 ip router isis 
 tag-switching ip
 frame-relay interface-dlci 103   
!
interface Serial0/0.3 point-to-point
 bandwidth 512
 ip address 10.1.1.13 255.255.255.252
 ip router isis 
 tag-switching ip
 frame-relay interface-dlci 104   
!
interface Serial0/0.4 point-to-point
 ip address 10.1.1.17 255.255.255.252
 ip router isis 
 tag-switching ip
 frame-relay interface-dlci 105
!
!
router isis
 net 49.0001.0000.0000.0001.00
 is-type level-1
!
ip classless
!
end

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

  • show tag-switching tdp neighbor

  • mostre emperramentos do tdp do tag-switching

  • show tag-switching forwarding-table

  • show tag-switching forwarding-table a.b.c.d detail

  • traceroute a.b.c.d

Uma lista exaustiva dos comandos é incluída na referência do comando mpls. Outros exemplos de exibir comando são descritos em configurar o MPLS básico usando o OSPF.

Saída de exemplo

Esta saída focaliza no LDP. O LDP executado atualmente nos IO é o TDP (protocolo de distribuição da etiqueta), que contém alguns Ramais proprietários Cisco, mas seja usado com LDP, o protocolo oficial de IETF para a distribuição de rótulo. O TDP será substituído pelo LDP no futuro.

Você pode usar o comando show tag-switching tdp * a fim verificar o estado de TDP. Você pode ver vizinhos com o comando show tag-switching tdp neighbor.

Pulligny# show tag-switching tdp discovery
Local TDP Identifier:    
	10.10.10.2:0
TDP Discovery Sources:    
  Interfaces:
 Serial0/0.1: xmit/recv            
   TDP Id: 10.10.10.1:0
 Serial0/0.2: xmit/recv
   TDP Id: 10.10.10.3:0

!--- Ensure you are able to ping this IP address
!--- If not, check whether a route exists in the routing table

Pulligny# show tag-switching tdp neighbor 
Peer TDP Ident: 10.10.10.1:0; Local TDP Ident 10.10.10.2:0
        TCP connection: 10.10.10.1.711 - 10.10.10.2.11001
        State: Oper; PIEs sent/rcvd: 27907/27925; ; Downstream
        Up time: 2w2d
        TDP discovery sources:
          Serial0/0.1
        Addresses bound to peer TDP Ident:
          10.1.1.1        10.1.1.13       10.1.1.17       10.10.10.1      
          10.1.1.5        10.200.28.89    
Peer TDP Ident: 10.10.10.3:0; Local TDP Ident 10.10.10.2:0
        TCP connection: 10.10.10.3.11001 - 10.10.10.2.711
        State: Oper; PIEs sent/rcvd: 22893/22874; ; Downstream
        Up time: 1w6d
        TDP discovery sources:
          Serial0/0.2
        Addresses bound to peer TDP Ident:
          10.200.28.91    10.1.1.6        10.1.1.9        10.1.1.21       
          10.10.10.3

Você pode usar o comando show tag-switching tdp bindings a fim ver os emperramentos estabelecidos entre etiquetas e rotas.

Pulligny# show tag-switching tdp bindings 
(...)
  tib entry: 10.10.10.4/32, rev 22
        local binding:  tag: 21
        remote binding: tsr: 10.10.10.1:0, tag: 22
        remote binding: tsr: 10.10.10.3:0, tag: 25
  tib entry: 10.10.10.6/32, rev 51
        local binding:  tag: 23
        remote binding: tsr: 10.10.10.3:0, tag: 18
        remote binding: tsr: 10.10.10.1:0, tag: 20
(...)

Você pode usar o comando show tag-switching forwarding-table a fim ver que emperramentos são usados para construir o LFIB.

Pulligny# show tag-switching forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface 
16     Pop tag     10.1.1.4/30       0          Se0/0.2    point2point       
       Pop tag     10.1.1.4/30       0          Se0/0.1    point2point
17     Pop tag     10.1.1.20/30      0          Se0/0.2    point2point
18     Pop tag     10.10.10.3/32     0          Se0/0.2    point2point
19     Pop tag     10.10.10.1/32     0          Se0/0.1    point2point
20     Pop tag     10.1.1.12/30      0          Se0/0.1    point2point
21     Pop tag     10.1.1.16/30      0          Se0/0.1    point2point
22     20          10.10.10.5/32     0          Se0/0.1    point2point
23     22          10.10.10.6/32     0          Se0/0.2    point2point
24     22          10.10.10.4/32     0          Se0/0.1    point2point

Você pode usar o comando detail de 10.10.10.4 da tabela do forwarding do tag-switching da mostra ver os detalhes de um destino fornecido.

Pulligny# show tag-switching forwarding-table 10.10.10.4 detail 
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface              
21     22          10.10.10.4/32     12103      Se0/0.1    point2point  
        MAC/Encaps=4/8, MTU=1500, Tag Stack{22}
        30918847 00016000
    Per-packet load-sharing

Você pode igualmente usar o comando traceroute, se a rede faz a propagação TTL IP, ver os saltos. Refira o Multiprotocol Label Switching em roteadores Cisco para obter mais informações sobre do comando mpls ip ttl propagate.

Pesaro# traceroute 10.10.10.4

Type escape sequence to abort.
Tracing the route to 10.10.10.4

  1 10.1.1.21 [MPLS: Label 25 Exp 0] 296 msec 256 msec 244 msec
  2 10.1.1.5 [MPLS: Label 22 Exp 0] 212 msec 392 msec 352 msec
  3 10.1.1.14 436 msec *  268 msec

Nota: Exp 0 aparecerá na saída se o campo experimental for usado para QoS (Qualidade de serviço).

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 13735