Multiprotocol Label Switching (MPLS) : MPLS

Configurando uma VPN MPLS básica

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Tradução Manual (22 Maio 2008) | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento fornece uma configuração de exemplo de um Multiprotocol Label Switching (MPLS) VPN quando o Border Gateway Protocol (BGP) ou o Routing Information Protocol (RIP) estam presente no local de cliente.

Quando usado com o MPLS, o recurso VPN permite que diversos sites se interconectem de forma transparente por uma rede do provedor de serviço. Uma rede de provedor de serviços pode suportar várias VPNs de IPs diferentes. Cada uma delas aparece para seus usuários como uma rede privada, separada de todas as outras redes. Na VPN, cada site pode enviar pacotes IP para qualquer outro site na mesma VPN.

Cada VPN está associada com um ou mais instâncias de VPN Routing ou de encaminhamento (VRFs) Um VRF consiste em uma tabela de IP Routing, uma tabela de Cisco Express Forwarding (CEF) derivada e um conjunto de interfaces que usam essa tabela de encaminhamento.

O roteador mantém um roteamento separado e tabela de CEF para cada VRF. Isso evita que as informações sejam enviadas para fora da VPN e permite que a mesma sub-rede seja utilizada em várias VPNs sem provocar problemas de endereço IP duplicado.

O roteador que utiliza o Multiprocol BGP (MP-BGP) distribui as informações do VPN Routing utilizando as comunidades estendidas de MP-BGP.

Para obter mais informações sobre da propagação de atualização com um VPN, refira estes documentos:

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

Roteadores P e PE

  • O Software Release 12.2(6h) de Cisco IOS� inclui a característica do MPLS VPN.

  • Algum roteador Cisco do 7200 Series ou da funcionalidade mais alta dos apoios P. O Cisco 2691, assim como alguma funcionalidade do 3640 Series ou a mais alta dos suportes de roteador PE.

Roteadores C e CE

  • Você pode usar todo o roteador que puder trocar a informação de roteamento com seu roteador de PE.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Produtos Relacionados

Para executar a característica MPLS, você deve ter um roteador da escala do Cisco 2600 ou mais altamente. Para selecionar o Cisco IOS exigido com MPLS caracterize, use o Software Advisor (clientes registrados somente). Igualmente verifique para ver se há RAM e a memória Flash adicionais exigidos para executar a característica MPLS no Roteadores. O WIC-1T, o WIC-2T, e as interfaces serial podem ser usados.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

As letras abaixo representam os tipos diferentes de Roteadores e de Switches usados.

  • P — O roteador central do fornecedor.

  • PE — O roteador de ponta do fornecedor.

  • CE — O roteador de ponta do cliente.

  • C – Roteador do cliente.

Este diagrama mostra uma configuração típica ilustrando as convenções descritas acima.

/image/gif/paws/13733/mplsvpn.gif

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/13733/new_mpls_vpn_basic1.gif

Procedimentos de configuração

Refira redes privadas virtuais MPLS para mais informação.

Habilitando ip cef

Use este procedimento a fim permitir o cef IP. Para o desempenho aprimorado, use o cef IP distribuído (onde disponível). Termine estas etapas nos PE depois que o MPLS se estabeleceu (configurando o tag-switching IP nas relações).

  1. <<<<<<<<<<<<<<<<<VPN routing/forwarding instance name>.

    Quando estiver fazendo isto:

    • Especifique o distinguidor de rota correto utilizado para aquele VPN. É utilizada para estender o endereço IP de forma que você possa identificar a qual VPN ele pertence.

      
      rd <VPN route distinguisher>
      
      
    • Estabelecer as propriedades da importação e da exportação para as comunidades extendida MP-BGP. Estes são utilizados para filtrar o processo de importação e exportação.

      
      route-target [export|import|both] <target VPN extended community>
      
      
  2. Configurar os detalhes reenviado para as interfaces respectivas usando o comando ip vrf forwarding <VPN routing/forwarding instance name> e recorde-os estabelecer o endereço IP de Um ou Mais Servidores Cisco ICM NT após ter feito isto.

  3. Dependendo do PE-CE Routing Protocol sendo usado, é possível configurar rotas estáticas ou Routing Protocols (RIP, OSPF ou BGP) entre PE e CE. As configurações detalhadas estão disponíveis no MPLS sobre a página de suporte ATM.

Configurando o MP-BGP

Configure o MP-BGP entre os roteadores PE. Há vários modos de configurar o BGP, como, por exemplo, utilizar o refletor de rota ou métodos de confederação. O método usado aqui — configuração vizinha direta — é o mais simples e o o mais menos escalável.

  1. Declare os vizinhos diferentes.

  2. Inscreva o comando address-family ipv4 vrf <VPN routing/forwarding instance name> para cada VPN atual neste roteador de PE.

    Realize uma ou mais das seguintes etapas, conforme necessário:

    • Redistribua as informações de OSPF, RIP e roteamento estático.

    • Redistribua as informações de roteamento conectado.

    • Ative os vizinhos BGP com os roteadores CE.

  3. Insira o modo address-family vpnv4 e preencha as etapas a seguir:

    • Ative os vizinhos

    • Especifique se uma comunidade estendida deve ser utilizada. Isso é obrigatório.

Configurações

Este documento utiliza as seguintes configurações:

Pescara
Current configuration:
!
version 12.2
!
hostname Pescara
!
ip cef
!


!--- Customer A commands.

ip vrf Customer_A

!--- Enables the VPN routing and forwarding (VRF) routing table.
!--- This command can be used in global or 
!--- router configuration mode. 

 rd 100:110

!--- Route distinguisher creates routing and forwarding 
!--- tables for a VRF.

 route-target export 100:1000

!--- Creates lists of import and export route-target extended 
!--- communities for the specified VRF.

 route-target import 100:1000
!


!--- Customer B commands.

ip vrf Customer_B
 rd 100:120
 route-target export 100:2000
 route-target import 100:2000
!
interface Loopback0
 ip address 10.10.10.4 255.255.255.255
 ip router isis


!--- Customer A commands.

interface Loopback101
ip vrf forwarding Customer_A

!--- Associates a VRF instance with an interface or subinterface.

 ip address 200.0.4.1 255.255.255.0

!--- Loopback101 and 102 use the same IP address, 200.0.4.1. 
!--- This is allowed because they belong to two 
!--- different customers' VRFs. 

 no ip directed-broadcast
!


!--- Customer B commands.

interface Loopback102
 ip vrf forwarding Customer_B
 ip address 200.0.4.1 255.255.255.0

!--- Loopback101 and 102 use the same IP address, 200.0.4.1. 
!--- This is allowed because they belong to two 
!--- different customers' VRFs.
 
 no ip directed-broadcast
!
interface Serial2/0
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 no fair-queue
!
interface Serial2/0.1 point-to-point
 description link to Pauillac
 bandwidth 512
 ip address 10.1.1.14 255.255.255.252
 no ip directed-broadcast
 ip router isis 
 tag-switching ip
 frame-relay interface-dlci 401   
!
router isis 
 net 49.0001.0000.0000.0004.00
 is-type level-1
!         
router bgp 100
 bgp log-neighbor-changes

!--- Enables logging of BGP neighbor resets.

 neighbor 10.10.10.6 remote-as 100

!--- Adds an entry to the BGP or multiprotocol BGP neighbor table.

 neighbor 10.10.10.6 update-source Loopback0

!--- Enables BGP sessions to use a specific operational 
!--- interface for TCP connections.

!
 

!--- Customer A and B commands.

 address-family vpnv4

!--- To enter address family configuration mode 
!--- for configuring routing sessions, such as BGP, 
!--- that use standard VPN version 4 address prefixes.

 neighbor 10.10.10.6 activate
 neighbor 10.10.10.6 send-community both
 
!--- Sends the community attribute to a BGP neighbor.

 exit-address-family
 !


!--- Customer B commands.

 address-family ipv4 vrf Customer_B

!--- To enter address family configuration mode 
!--- for configuring routing sessions, such as BGP, 
!--- that use standard VPN version 4 address prefixes.

 redistribute connected
 no auto-summary
 no synchronization
 exit-address-family
 !
 

!--- Customer A commands.

 address-family ipv4 vrf Customer_A
 redistribute connected
 no auto-summary
 no synchronization
 exit-address-family
!
ip classless
!
end

Pesaro
Current configuration:
!
version 12.1
!
hostname Pesaro
!


!--- Customer A commands.

ip vrf Customer_A
 rd 100:110
 route-target export 100:1000
 route-target import 100:1000
!


!--- Customer B commands.

ip vrf Customer_B
 rd 100:120
 route-target export 100:2000
 route-target import 100:2000
!
ip cef

!
interface Loopback0
 ip address 10.10.10.6 255.255.255.255
 ip router isis 


!--- Customer A commands.

interface Loopback101
 ip vrf forwarding Customer_A
 ip address 200.0.6.1 255.255.255.0
!


!--- Customer B commands.

interface Loopback102
 ip vrf forwarding Customer_B
 ip address 200.0.6.1 255.255.255.0
!


!--- Customer A commands.

interface Loopback111
 ip vrf forwarding Customer_A
 ip address 200.1.6.1 255.255.255.0
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 no ip mroute-cache
 random-detect
!
interface Serial0/0.1 point-to-point
 description link to Pomerol
 bandwidth 512
 ip address 10.1.1.22 255.255.255.252
 ip router isis 
 tag-switching ip
 frame-relay interface-dlci 603   
!
router isis 
 net 49.0001.0000.0000.0006.00
 is-type level-1
!
router bgp 100
 neighbor 10.10.10.4 remote-as 100
 neighbor 10.10.10.4 update-source Loopback0
 !


!--- Customer B commands.

 address-family ipv4 vrf Customer_B
 redistribute connected
 no auto-summary
 no synchronization
 exit-address-family
 !


!--- Customer A commands.

 address-family ipv4 vrf Customer_A
 redistribute connected
 no auto-summary
 no synchronization
 exit-address-family
 !


!--- Customer A and B commands.

 address-family vpnv4
 neighbor 10.10.10.4 activate
 neighbor 10.10.10.4 send-community both
 exit-address-family
!
ip classless
!         
end

Pomerol
Current configuration:
!
version 12.0
!
hostname Pomerol
!
ip cef

!
interface Loopback0
 ip address 10.10.10.3 255.255.255.255
 ip router isis 

!
interface Serial0/1
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 random-detect
!
interface Serial0/1.1 point-to-point
 description link to Pauillac
 ip address 10.1.1.6 255.255.255.252
 no ip directed-broadcast
 ip router isis 
 tag-switching mtu 1520
 tag-switching ip 
 frame-relay interface-dlci 301   
!
interface Serial0/1.2 point-to-point
 description link to Pulligny
 ip address 10.1.1.9 255.255.255.252
 no ip directed-broadcast
 ip router isis 
 tag-switching ip
 frame-relay interface-dlci 303   
!
interface Serial0/1.3 point-to-point
 description link to Pesaro
 ip address 10.1.1.21 255.255.255.252
 no ip directed-broadcast
 ip router isis 
 tag-switching ip

 frame-relay interface-dlci 306   
!
router isis 
 net 49.0001.0000.0000.0003.00
 is-type level-1
!
ip classless
!
end

Pulligny
Current configuration:
!
version 12.1
!
hostname Pulligny
!
!
ip cef

!
!
interface Loopback0
 ip address 10.10.10.2 255.255.255.255
!
interface Serial0/1
 no ip address
 encapsulation frame-relay
 random-detect
!
interface Serial0/1.1 point-to-point
 description link to Pauillac
 ip address 10.1.1.2 255.255.255.252
 ip router isis 
 tag-switching ip 
 frame-relay interface-dlci 201   
!
interface Serial0/1.2 point-to-point
 description link to Pomerol
 ip address 10.1.1.10 255.255.255.252
 ip router isis 
 tag-switching ip 
 frame-relay interface-dlci 203   
!
router isis 
 passive-interface Loopback0
 net 49.0001.0000.0000.0002.00
 is-type level-1
!
ip classless
!
end

Pauillac
!
version 12.1
!
hostname pauillac
!
ip cef

!
interface Loopback0
 ip address 10.10.10.1 255.255.255.255
 ip router isis  
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 no ip mroute-cache
 tag-switching ip
 no fair-queue
!
interface Serial0/0.1 point-to-point
 description link to Pomerol
 bandwith 512
 ip address 10.1.1.1 255.255.255.252
 ip router isis 
 tag-switching ip 
 frame-relay interface-dlci 102   
!
interface Serial0/0.2 point-to-point
 description link to Pulligny ip address 10.1.1.5 255.255.255.252

 ip router isis 
 tag-switching ip 
 frame-relay interface-dlci 103   
!
interface Serial0/0.3 point-to-point
 description link to Pescara
 bandwidth 512
 ip address 10.1.1.13 255.255.255.252
 ip router isis 
 tag-switching ip 
 frame-relay interface-dlci 104   
!
router isis 
 net 49.0001.0000.0000.0001.00
 is-type level-1
!
ip classless
!
end

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

  • vrf IP da mostra — Verifica que o VRF correto existe.

  • show ip vrf interfaces — Verifica as relações ativadas.

  • mostre o Cliente_A do vrf da rota IP — Verifica a informação de roteamento nos roteadores de PE.

  • Cliente_A 200.0.6.1 do vrf do traceroute — Verifica a informação de roteamento nos roteadores de PE.

  • show ip bgp vpnv4 tag — Verifica o BGP.

  • mostre o detalhe de 200.0.6.1 do Cliente_A do vrf do cef IP — verifica a informação de roteamento nos roteadores de PE.

Mais comandos estão detalhados no MPLS VPN Solution Troubleshooting Guide (Manual de resolução de problemas da solução MPLS VPN).

O seguinte é exemplo de saída de comando do comando show ip vrf.

Pescara#show ip vrf 
  Name                             Default RD          Interfaces
  Customer_A                       100:110             Loopback101
  Customer_B                       100:120             Loopback102

O seguinte é exemplo de saída de comando do comando show ip vrf interfaces.

Pesaro#show ip vrf interfaces 
Interface              IP-Address      VRF                              Protocol
Loopback101            200.0.6.1       Customer_A                       up      
Loopback111            200.1.6.1       Customer_A                       up      
Loopback102            200.0.6.1       Customer_B                       up      

Os seguintes comandos show ip route vrf mostram o mesmo prefixo 200.0.6.0/24 em ambas as saídas. Isto é porque o PE remoto tem a mesma rede para dois clientes, Cliente_As e Customer_B, que é permitido em uma solução típica do MPLS VPN.

Pescara#show ip route vrf Customer_A
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR

Gateway of last resort is not set

C    200.0.4.0/24 is directly connected, Loopback101
B    200.0.6.0/24 [200/0] via 10.10.10.6, 05:10:11
B    200.1.6.0/24 [200/0] via 10.10.10.6, 04:48:11
 
Pescara#show ip route vrf Customer_B
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
	   N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
	   E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
	   i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
	   * - candidate default, U - per-user static route, o - ODR       
	   P - periodic downloaded static route
	    
Gateway of last resort is not set
C 200.0.4.0/24 is directly connected, Loopback102
 
B 200.0.6.0/24 [200/0] via 10.10.10.6, 00:03:24

Executando um traceroute entre dois locais do Cliente_A, é possível ver a pilha de rótulo usada pela rede MPLS (se é configurado para fazer assim pelo mpls IP ttl).

Pescara#traceroute vrf Customer_A 200.0.6.1

Type escape sequence to abort.
Tracing the route to 200.0.6.1

  1 10.1.1.13 [MPLS: Labels 20/26 Exp 0] 400 msec 276 msec 264 msec
  2 10.1.1.6 [MPLS: Labels 18/26 Exp 0] 224 msec 460 msec 344 msec
  3 200.0.6.1 108 msec *  100 msec

Nota:  Exp 0 é um campo experimental usado pelo QoS.

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 13733