Multiprotocol Label Switching (MPLS) : MPLS

Exemplo de engenharia básica de tráfego de MPLS usando configuração de OSPF

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento fornece uma configuração de exemplo para a implementação de engenharia de tráfego (TE) em uma MPLS (rede existente de switching de rótulo multiprotocolo) usando Frame Relay e OSPF (Open Shortest Path First). Nosso exemplo implementa dois túneis dinâmicos (configuração automática pelos Label Switch Routers "LSR" de ingresso) e dois túneis que usam caminhos explícitos.

TE é um nome genérico que corresponde ao uso de diferentes tecnologias para otimizar a utilização de capacidade e topologia de um determinado backbone.

O MPLS TE oferece uma maneira de integrar as capacidades de TE (tais como as usadas nos protocolos da camada 2 como ATM) em protocolos da camada 3 (IP). O MPLS TE usa uma extensão para protocolos existentes (IS-IS [Intermediate System-to-Intermediate System], RSVP [Resource Reservation Protocol], OSPF) para calcular e estabelecer túneis unidirecionais configurados de acordo com a restrição da rede. Os fluxos de tráfego são mapeados em túneis diferentes dependendo de seus destinos.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nas versões de software e hardware:

  • Software Release 12.0(11)S e 12.1(3a)T do½ do¿Â do Cisco IOSïÂ

  • Cisco 3600 Routers

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Componentes funcionais

A tabela a seguir descreve os componentes funcionais deste exemplo de configuração:

Componente Descrição
Interfaces de túnel de IP Camada 2: Uma interface de túnel MPLS é a principal de um LSP (Caminho comutado do rótulo). É configurada com um conjunto de requisitos de recursos, tais como largura de banda e prioridade. Camada 3: a interface de túnel LSP é a extremidade principal de um link virtual unidirecional para o destino do túnel.
RSVP com extensão TE O RSVP é usado para estabelecer e manter os túneis de LSP com base no caminho calculado usando as mensagens PATH e RESV. A especificação do protocolo RSVP foi estendida para que as mensagens RESV distribuam também informações sobre o rótulo.
Protocolo de Gateway Interno de Estado-Link (IGP) [IS-IS ou OSPF com extensão TE] Usado para obtenção de informações de topologia de inundação e recursos a partir do módulo de gerenciamento de enlaces. O IS-IS usa o Tipo-Comprimento-Valores novo (TLV); O OSPF usa o tipo anúncios link states 10 (igualmente chamados opaques lsa).
Módulo de cálculo de caminho MPLS TE Opera apenas no início do LSP e determina um caminho utilizando informações do banco de dados do estado do enlace.
Módulo de gerenciamento de enlaces TE MPLS Em cada salto LSP, esse módulo executa a admissão de chamada do link nas mensagens de sinalização de RSVP e a contabilidade da topologia e das informações de recurso a serem liberadas pelo OSPF ou pelo IS-IS.
Encaminhamento de switching de rótulo Mecanismo básico de encaminhamento de MPLS com base em rótulos.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/13731/mplsteisis1.gif

Manual de configuração rápida

Você pode usar as seguintes etapas para executar uma configuração rápida. Refira a Engenharia de tráfego MPLS e os realces para mais informação detalhada.

  1. Configure a rede com a configuração de costume. (Nesse caso, usamos o Frame Relay).

    Nota: É imperativo estabelecer uma interface de loopback com uma máscara IP de 32 bit. Esse endereço será utilizado para configuração do NPLS Network e TE pelo Routing Protocol. Esse endereço de circuito fechado deve ser acessível por meio da tabela de roteamento global.

  2. Configurando um Routing Protocol para a rede MPLS. Deve ser um protocolo de estado de link (IS-IS ou OSPF). No modo de configuração de Routing Protocol, digite os seguintes comandos:

    • Para IS-IS:

      metric-style [wide | both]
      mpls traffic-eng router-id LoopbackN 
      mpls traffic-eng [level-1 | level-2 |]
      
    • Para OSPF:

      mpls traffic-eng area X 
      mpls traffic-eng router-id LoopbackN (must have a 255.255.255.255 mask)
  3. Habilitar MPLS TE. Insira o ip cef (ou o ip cef distribuído se disponível para aprimorar o desempenho) no modo de configuração geral. Habilite o MPLS (tag-switching ip) em cada interface envolvida. Incorpore o túnel da Engenharia de tráfego MPLS para permitir o MPLS TE, assim como o RSVP para túneis TE da zero-largura de banda.

  4. Permita o RSVP incorporando a largura de banda XXX do rsvp IP em cada interface de interesse para túneis diferente de zero da largura de banda.

  5. Configurar canais para serem usados para TE. Várias opções podem ser configuradas para túnel TE MPLS, mas o comando tunnel mode mpls traffic-eng é obrigatório. O comando tunnel mpls traffic-eng autoroute announce anuncia a presença do túnel através do Routing Protocol.

    Nota: Não se esqueça de usar ip unnumbered loopbackN para o endereço IP das interfaces de túnel.

    Esta configuração mostra dois túneis dinâmicos (Pescara_t1 e Pescara_t3) com larguras de banda (e prioridades) diferentes indo do roteador Pescara para o roteador Pesaro e dois túneis (Pesaro_t158 e Pesaro_t159) usando um caminho explícito do Pesaro ao Pescara.

Arquivos de configuração

Este documento utiliza as configurações mostradas abaixo. Apenas as partes relevantes dos arquivos de configuração estão incluídas. Os comandos usados para permitir o MPLS estão no texto azul; os comandos específicos ao TE (que inclui o RSVP) estão no texto em negrito.

Pesaro
Current configuration:

!

version 12.1

!

hostname Pesaro

!


ip cef


!

mpls traffic-eng tunnels

!

interface Loopback0

 ip address 10.10.10.6 255.255.255.255

!

interface Tunnel158

 ip unnumbered Loopback0

 tunnel destination 10.10.10.4

 tunnel mode mpls traffic-eng

 tunnel mpls traffic-eng autoroute announce

 tunnel mpls traffic-eng priority 2 2

 tunnel mpls traffic-eng bandwidth 158

 tunnel mpls traffic-eng path-option 1 explicit name low

!

interface Tunnel159

 ip unnumbered Loopback0

 tunnel destination 10.10.10.4

 tunnel mode mpls traffic-eng

 tunnel mpls traffic-eng autoroute announce

 tunnel mpls traffic-eng priority 4 4

 tunnel mpls traffic-eng bandwidth 159

 tunnel mpls traffic-eng path-option 1 explicit name straight

!

interface Serial0/0

 no ip address

 encapsulation frame-relay

!

interface Serial0/0.1 point-to-point

 bandwidth 512

 ip address 10.1.1.22 255.255.255.252

 
tag-switching ip


 mpls traffic-eng tunnels 

 frame-relay interface-dlci 603   

 ip rsvp bandwidth 512 512

!

router ospf 9

 network 10.1.1.0 0.0.0.255 area 9

 network 10.10.10.0 0.0.0.255 area 9

 mpls traffic-eng area 9

 mpls traffic-eng router-id Loopback0

!

ip classless

!

ip explicit-path name low enable

 next-address 10.1.1.21 

 next-address 10.1.1.10 

 next-address 10.1.1.1 

 next-address 10.1.1.14 

!

ip explicit-path name straight enable

 next-address 10.1.1.21 

 next-address 10.1.1.5 

 next-address 10.1.1.14 

!

end

Pescara
Current configuration:

!

version 12.0

!

hostname Pescara

!


ip cef


!

mpls traffic-eng tunnels

!

interface Loopback0

 ip address 10.10.10.4 255.255.255.255

!

interface Tunnel1

 ip unnumbered Loopback0

 no ip directed-broadcast

 tunnel destination 10.10.10.6

 tunnel mode mpls traffic-eng

 tunnel mpls traffic-eng autoroute announce

 tunnel mpls traffic-eng priority 5 5

 tunnel mpls traffic-eng bandwidth 25

 tunnel mpls traffic-eng path-option 2 dynamic

!

interface Tunnel3

 ip unnumbered Loopback0

 no ip directed-broadcast

 tunnel destination 10.10.10.6

 tunnel mode mpls traffic-eng

 tunnel mpls traffic-eng autoroute announce

 tunnel mpls traffic-eng priority 6 6

 tunnel mpls traffic-eng bandwidth  69

 tunnel mpls traffic-eng path-option 1 dynamic

!

interface Serial0/1

 no ip address

 encapsulation frame-relay

!

interface Serial0/1.1 point-to-point

 bandwidth 512

 ip address 10.1.1.14 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 401   

 ip rsvp bandwidth 512 512

!

router ospf 9

 network 10.1.1.0 0.0.0.255 area 9

 network 10.10.10.0 0.0.0.255 area 9

 mpls traffic-eng area 9

 mpls traffic-eng router-id Loopback0

!

end

Pomerol
Current configuration:



version 12.0

!

hostname Pomerol

!


ip cef


!

mpls traffic-eng tunnels

!

interface Loopback0

 ip address 10.10.10.3 255.255.255.255

!

interface Serial0/1

 no ip address

 encapsulation frame-relay

!

interface Serial0/1.1 point-to-point

 bandwidth 512

 ip address 10.1.1.6 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 301   

 ip rsvp bandwidth 512 512

!

interface Serial0/1.2 point-to-point

 bandwidth 512

 ip address 10.1.1.9 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 302   

 ip rsvp bandwidth 512 512

!

interface Serial0/1.3 point-to-point

 bandwidth 512

 ip address 10.1.1.21 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 306   

 ip rsvp bandwidth 512 512

!

router ospf 9

 network 10.1.1.0 0.0.0.255 area 9

 network 10.10.10.0 0.0.0.255 area 9

 mpls traffic-eng area 9

 mpls traffic-eng router-id Loopback0

!

ip classless

!

end

Pulligny
Current configuration:

!

version 12.1

!

hostname Pulligny

!


ip cef


!

mpls traffic-eng tunnels

!

interface Loopback0

 ip address 10.10.10.2 255.255.255.255

!

interface Serial0/1

 no ip address

 encapsulation frame-relay

!

interface Serial0/1.1 point-to-point

 bandwidth 512

 ip address 10.1.1.2 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 201   

 ip rsvp bandwidth 512 512

!

interface Serial0/1.2 point-to-point

 bandwidth 512

 ip address 10.1.1.10 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 203   

 ip rsvp bandwidth 512 512

!

router ospf 9

 network 10.1.1.0 0.0.0.255 area 9

 network 10.10.10.0 0.0.0.255 area 9

 mpls traffic-eng area 9

 mpls traffic-eng router-id Loopback0

!

ip classless

!

end

Pauillac
!

version 12.1

!

hostname pauillac

!


ip cef


!

mpls traffic-eng tunnels

!

interface Loopback0

 ip address 10.10.10.1 255.255.255.255

!

interface Serial0/0

 no ip address

 encapsulation frame-relay

!

interface Serial0/0.1 point-to-point

 bandwidth 512

 ip address 10.1.1.1 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 102   

 ip rsvp bandwidth 512 512

!

interface Serial0/0.2 point-to-point

 bandwidth 512

 ip address 10.1.1.5 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 103   

 ip rsvp bandwidth 512 512

!

interface Serial0/0.3 point-to-point

 bandwidth 512

 ip address 10.1.1.13 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 104   

 ip rsvp bandwidth 512 512

!

router ospf 9

 network 10.1.1.0 0.0.0.255 area 9

 network 10.10.10.0 0.0.0.255 area 9

 mpls traffic-eng area 9

 mpls traffic-eng router-id Loopback0

!

ip classless

!

end

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

Os comandos show gerais são ilustrados em configurar a engenharia de tráfego MPLS básico usando o IS-IS. Os comandos a seguir são específicos para TE de MPLS com OSPF e são ilustrados abaixo:

  • mostre a mpls OSPF IP o link tráfego-inglês

  • mostre a opaco-área do base de dados OSPF IP

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Exemplo de saída do comando show

Você pode usar o comando show ip ospf mpls traffic-eng link ver o que será anunciado pelo OSPF em um roteador dado. As características do RSVP são exibidas em negrito a seguir, indicando a largura de banda que pode ser reservada, que está sendo anunciada e usada. Você pode ver a largura de banda usada por Pescara_t1 (em Prioridade 5) e Pescara_t3 (em Prioridade 6).

Pesaro# show ip ospf mpls traffic-eng link 

  OSPF Router with ID (10.10.10.61) (Process ID 9)

  Area 9 has 1 MPLS TE links. Area instance is 3.

  Links in hash bucket 48.
    Link is associated with fragment 0. Link instance is 3 
      Link connected to Point-to-Point network
      Link ID : 10.10.10.3 Pomerol
      Interface Address : 10.1.1.22
      Neighbor Address : 10.1.1.21
      Admin Metric : 195
      Maximum bandwidth : 64000
      Maximum reservable bandwidth : 64000
      Number of Priority : 8
      Priority 0 : 64000       Priority 1 : 64000     
      Priority 2 : 64000       Priority 3 : 64000     
      Priority 4 : 64000       Priority 5 : 32000     
      Priority 6 : 24000       Priority 7 : 24000   
      Affinity Bit : 0x0

O comando show ip ospf database pode ser contido para datilografar 10 LSA e mostra o base de dados que é usado pelo processo do MPLS TE para calcular a melhor ruta (para o TE) para túneis dinâmicos (Pescara_t1 e Pescara_t3 neste exemplo). Isso pode ser verificado no seguinte resultado parcial:

Pesaro# show ip ospf database opaque-area 

  OSPF Router with ID (10.10.10.61) (Process ID 9)

  Type-10 Opaque Link Area Link States (Area 9)

  LS age: 397
  Options: (No TOS-capability, DC)
  LS Type: Opaque Area Link
  Link State ID: 1.0.0.0
  Opaque Type: 1
  Opaque ID: 0
  Advertising Router: 10.10.10.1
  LS Seq Number: 80000003
  Checksum: 0x12C9
  Length: 132
  Fragment number : 0

    MPLS TE router ID : 10.10.10.1 Pauillac

    Link connected to Point-to-Point network
      Link ID : 10.10.10.3
      Interface Address : 10.1.1.5
      Neighbor Address : 10.1.1.6
      Admin Metric : 195
      Maximum bandwidth : 64000
      Maximum reservable bandwidth : 48125
      Number of Priority : 8
      Priority 0 : 48125       Priority 1 : 48125     
      Priority 2 : 48125       Priority 3 : 48125     
      Priority 4 : 48125       Priority 5 : 16125     
      Priority 6 : 8125        Priority 7 : 8125      
      Affinity Bit : 0x0

    Number of Links : 1
  LS age: 339
  Options: (No TOS-capability, DC)
  LS Type: Opaque Area Link
  Link State ID: 1.0.0.0
  Opaque Type: 1
  Opaque ID: 0
  Advertising Router: 10.10.10.2
  LS Seq Number: 80000001
  Checksum: 0x80A7
  Length: 132
  Fragment number : 0

    MPLS TE router ID : 10.10.10.2 Pulligny

    Link connected to Point-to-Point network
      Link ID : 10.10.10.1
      Interface Address : 10.1.1.2
      Neighbor Address : 10.1.1.1
      Admin Metric : 195
      Maximum bandwidth : 64000
      Maximum reservable bandwidth : 64000
      Number of Priority : 8
      Priority 0 : 64000       Priority 1 : 64000     
      Priority 2 : 64000       Priority 3 : 64000     
      Priority 4 : 64000       Priority 5 : 64000     
      Priority 6 : 64000       Priority 7 : 64000     
      Affinity Bit : 0x0

    Number of Links : 1

 LS age: 249
  Options: (No TOS-capability, DC)
  LS Type: Opaque Area Link
  Link State ID: 1.0.0.0
  Opaque Type: 1
  Opaque ID: 0
  Advertising Router: 10.10.10.3
  LS Seq Number: 80000004
  Checksum: 0x3DDC
  Length: 132
  Fragment number : 0

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.


Informações Relacionadas


Document ID: 13731