Switches : Sistema de switching virtual 1140 Cisco Catalyst 6500

Substitua o módulo do supervisor no Sistema de comutação virtual 1140 Cisco Catalyst 6500

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento fornece um procedimento passo a passo para substituir um supervisor ruim em um sistema de switching virtual do Cisco catalyst 6500.

Um sistema de switching virtual (VSS) consiste em dois chassis do Catalyst 6500. Cada chassi é equipado com um único Supervisor Engine. Se um dos supervisores morre devido a uma falha do hardware, o supervisor da substituição que vem com uma configuração padrão não se transforma um membro VSS automaticamente. Este supervisor novo carreg inicialmente acima no modo independente, e exige a configuração VSS a fim carreg no modo VSS.

Pré-requisitos

Requisitos

Certifique-se de atender a estes requisitos antes de tentar esta configuração:

  • Copie a imagem válida do supervisor ativo VSS a um dispositivo flash compacto.

  • Copie a configuração ativa VSS a um dispositivo flash compacto (podem ser o mesmos).

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

Sistema de comutação virtual 1140 Cisco Catalyst 6500 no Software Release 12.2(33)SXH1 ou Mais Recente do � do Cisco IOS

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a Command Lookup Tool (somente clientes registrados) para obter mais informações sobre os comandos usados nesta seção.

O supervisor novo exige que você carreg com uma imagem válida e uma configuração. A imagem pode ser copiada com TFTP ou um dispositivo flash compacto. Se o flash compacto não está disponível, a imagem do software e o arquivo de configuração podem ser copiados com TFTP, também.

  1. Copie a imagem válida do supervisor ativo VSS a um dispositivo flash compacto.

    VSS#dir sup-bootdisk:
    Directory of sup-bootdisk:/
    1 -rwx 117668516 Jan 22 2008 11:53:58 +00:00 s72033-
       ipservices_wan-vz.122-33.SXH1
    2 -rwx 33554432 Aug 16 2007 12:40:22 +00:00 sea_log.dat
    3 -rwx 7366 Aug 22 2007 20:05:42 +00:00 default-config
    

    Note que no modo VSS, o active e os supervisores em standby executam a mesma imagem da versão de software.

    VSS#copy sup-bootdisk:s72033-ipservices_wan-vz.122-33.SXH1 disk0:
    Destination filename [s72033-ipservices_wan-vz.122-33.SXH1]?
    Copy in progress...CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
       CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
    
    !--- Output suppressed.
    
    
  2. Copie a configuração atual do supervisor ativo VSS a um dispositivo flash compacto.

    VSS#copy running-config disk0:
    Destination filename [startup-config]? <VSS.cfg>
    11196 bytes copied in 0.712 secs (15725 bytes/sec)

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

Falha do supervisor de Switch2

replace_vss_sup_proc_v1.gif

Instale e configurar o supervisor novo

Termine estas etapas para instalar e configurar o supervisor novo:

  1. Instale o supervisor novo no chassi e, caso que os uplinks do supervisor são usados para VSL, conecte-o fisicamente. Carreg a imagem do flash compacto.

  2. Apague o arquivo de configuração start-up do supervisor novo. Esta etapa é exigida para assegurar-se de que nenhuma configuração velha exista no supervisor novo.

  3. Copie a imagem do software que foi copiada previamente ao dispositivo flash compacto ao sup-bootdisk novo do supervisor:

    Router#copy disk0:s72033-ipservices_wan-vz.122-33.SXH1 sup-bootdisk:
    Destination filename [s72033-ipservices_wan-vz.122-33.SXH1]?
    Copy in progress ..CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
    CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
    117668516 bytes copied in 332.283 secs (354121 bytes/sec)
    
    !--- Output suppressed.
    
    
    !--- If you choose to download software image from a tftp server,
         connect one of the switch interfaces to the network in order to have connectivity 
         to the tftp server. Configure IP address to the management interface; verify 
         the connectivity between the switch and the tftp server.
    
    
    !--- The management IP address should be different from what is 
         already assigned to active VSS switch.
    !--- Configure management IP address
    
    Router(config)#interface gig 1/3
    Router(config-if)#ip address 10.10.10.100 255.255.255.0
    Router(config-if)#no shutdown
    
    !--- verify Management interface status and configuration
    
    Router#show interface gig 1/3
    GigabitEthernet1/3 is up, line protocol is up (connected)
    Hardware is C6k 1000Mb 802.3, address is 0005.dce7.8180 
       (bia 0005.dce7.8180)
    Internet address is 10.10.10.100/24
    
    !--- Output omitted
    !--- If the TFTP server and switch management interface are not in the same 
         layer-3 subnet, add a (default) route.
    
    Router(config)#ip route 0.0.0.0 0.0.0.0 10.10.10.1
    
    !--- verify IP connectivity between switch and TFTP server
    
    Router#ping 10.20.20.200
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.20.20.200, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
    
    !---Copy the new software image into supervisor bootflash:
    
    Router#copy tftp: sup-bootdisk:
    Address or name of remote host []? 10.20.20.200
    Source filename []? s72033-ipservices_wan-vz.122-33.SXH1
    Destination filename [s72033-ipservices_wan-vz.122-33.SXH1]?
    Copy in progress ..CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
    CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
    
    !--- Output omitted
    
    
  4. Copie a configuração do supervisor ativo, que previamente salvar no dispositivo flash compacto, ao arquivo de configuração novo da partida-configuração do supervisor.

    Router#copy disk0:VSS.cfg startup-config
    Destination filename [startup-config]?
    11196 bytes copied in 7.460 secs (1501 bytes/sec)
    Router#

    Nota: Esta etapa é crítica porque a configuração VSS e todos os variáveis de inicialização exigidos para carreg a imagem de IOS Software direita são adicionados.

    
    !--- Highlighted VSS configuration commands are critical 
         to boot up the supervisor in VSS mode.
    !--- Verify VSS configuration in the startup-config file
    
    Router#more nvram:startup-config
    !
    hostname VSS
    boot system flash sup-bootdisk:s72033-ipservices_wan-vz.122-33.SXH1
    
    !--- Switch Virtual domain <id> is configured with respective 
         switch priorities
    
    switch virtual domain 1
    switch mode virtual 
    
    !--- this command gets populated upon converting standalone switch to VSS mode. 
         Make sure this command is part the configuration.
    
    switch 1 priority 110
    switch 2 priority 100
    
    
    !--- Verify Virtual Switch Link (VSL) configuration
    
    interface Port-channel1
    no switchport
    no ip address
    switch virtual link 1
    mls qos trust cos
    no mls qos channel-consistency
    !
    interface Port-channel2
    no switchport
    no ip address
    switch virtual link 2
    mls qos trust cos
    no mls qos channel-consistency
    
    !--- Physical interfaces that are part of VSL
    
    interface TenGigabitEthernet1/1/4
    no switchport
    no ip address
    mls qos trust cos 
    channel-group 1 mode on
    
    interface TenGigabitEthernet1/1/5
    no switchport
    no ip address
    mls qos trust cos 
    channel-group 1 mode on
    
    interface TenGigabitEthernet2/1/4
    no switchport
    no ip address
    mls qos trust cos 
    channel-group 2 mode on
    
    interface TenGigabitEthernet2/1/5
    no switchport
    no ip address
    mls qos trust cos 
    channel-group 2 mode on
    
  5. Configurar o VSS Switch_ID que identifica um Catalyst 6500 Switch dentro de um domínio virtual do interruptor. Porque o VSS pode consistir em somente dois Switches, você precisa de escolher o dependente 1 ou 2 em que valores são definidos no interruptor ativo. Você não pode usar nenhum valor a não ser 1 ou 2.

    
    !--- Verify active Switch_ID on the active switch
    
    Router#switch read switch_num local
    Read switch_num from Active rommon is 1
    
    !--- Note that since Switch_ID=1 is used for active switch, 
         we would define Switch_ID=2 in the new supervisor.
    
    
    !--- Configure the Switch_ID on the supervisor.
    
    
    !--- Below command sets a Switch_ID ROMMON variable. 
         It is used during VSS boot up to identify a switch within a VSS domain.
    !--- Note that the Switch_ID doesn’t dictate the state (active vs. standby) of the supervisor.
    
    Router#switch set switch_num 2 local
    Set rommon's switch_num to 2
    
    !--- Verify the Switch_ID configuration on the new supervisor.
    
    Router#switch read switch_num local
    Read switch_num from Active rommon is 2
  6. Recarregue o interruptor de modo que, quando você reload, as botas do interruptor no modo VSS.

    cuidado Cuidado: Não salvar sua executar-configuração à partida-configuração neste momento. Se você faz, a partida-configuração overwritten com a configuração padrão, e o interruptor não carreg no modo VSS.

    Exemplo CLI Output:

    Router# reload
    System configuration has been modified. Save? [yes/no]: no
    Proceed with reload? [confirm]
    00:25:07: %SYS-5-RELOAD: Reload requested by console. 
       Reload Reason: Reload Command.
    00:26:49: %SYS-SP-3-LOGGER_FLUSHING: 
       System pausing to ensure console debugging output.
    00:26:49: %OIR-SP-6-CONSOLE: 
       Changing console ownership to switch processor
    
    !--- Output omitted
    !--- SP booting up, pay attention to the name of the image being loaded by SP
    
    System Bootstrap, Version 8.5(1)
    Copyright (c) 1994-2006 by cisco Systems, Inc.
    Cat6k-Sup720/SP processor with 1048576 Kbytes of main memory
    Autoboot executing command: “ boot system flash 
       sup-bootflash:s72033-ipservices_wan-vz.122-33.SXH1”
    Loading image, please wait ...
    Initializing ATA monitor library...
    Self decompressing the image : 
       ######################################
       #####################################
    Restricted Rights Legend
    Use, duplication, or disclosure by the Government is
    subject to restrictions as set forth in subparagraph
    (c) of the Commercial Computer Software - Restricted
    Rights clause at FAR sec. 52.227-19 and subparagraph
    (c) (1) (ii) of the Rights in Technical Data and Computer
    Software clause at DFARS sec. 252.227-7013.
    cisco Systems, Inc.
    170 West Tasman Drive
    San Jose, California 95134-1706
    Cisco IOS Software, s72033_sp Software 
       (s72033_sp-IPSERVICES_WAN-VM), 
       Version 12.2(33)SXH1, RELEASE SOFTWARE (fc3)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2008 by Cisco Systems, Inc.
    Compiled Thu 17-Jan-08 04:38 by prod_rel_team
    Image text-base: 0x01020150, data-base: 0x01021000
    
    !--- VSS configuration pre-parsed during bootup
    
    System detected Virtual Switch configuration...
    Interface TenGigabitEthernet 2/8/4 is member of Portchannel 2
    
    
    !--- output omitted
    
    Initializing as Virtual Switch STANDBY processor
    
    !--- VSL module ( supervisor in this scenario) 
         brought up and role is resolved as standby 
         since there is already a active VSS switch.
    
    
    00:00:30: %VSL_BRINGUP-6-MODULE_UP: 
       VSL module in slot 8 switch 2 brought up
    00:00:57: %VSLP-5-VSL_UP: 
       Ready for Role Resolution with Switch=1, 
       MAC=0014.1bc6.1c00 over 8/4
    00:01:01: %VSLP-5-RRP_ROLE_RESOLVED: 
       Role resolved as STANDBY by VSLP
    00:01:01: %VSL-5-VSL_CNTRL_LINK: New VSL Control Link 8/4
    
    !--- RP is booting up
    
    System Bootstrap, Version 12.2(17r)SX5, RELEASE SOFTWARE (fc1)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 2006 by cisco Systems, Inc.
    Cat6k-Sup720/RP platform with 1048576 Kbytes of main memory
    Download Start
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
       !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
       
       !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
       !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
       !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
       !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
       !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    Restricted Rights Legend
    Use, duplication, or disclosure by the Government is
    subject to restrictions as set forth in subparagraph
    (c) of the Commercial Computer Software - Restricted
    Rights clause at FAR sec. 52.227-19 and subparagraph
    (c) (1) (ii) of the Rights in Technical Data and Computer
    Software clause at DFARS sec. 252.227-7013.
    cisco Systems, Inc.
    170 West Tasman Drive
    San Jose, California 95134-1706
    Cisco IOS Software, s72033_rp Software (s72033_rp-IPSERVICES_WAN-VM), 
       Version 12.2(33)SXH1, RELEASE SOFTWARE (fc3)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2008 by Cisco Systems, Inc.
    Compiled Thu 17-Jan-08 04:04 by prod_rel_team
    Image text-base: 0x01020150, data-base: 0x01021000
    
    !--- output omitted
    
    Press RETURN to get started!
    
    !--- Look out for –- 
         “%PFREDUN-SW2_SPSTBY-6-STANDBY: Initializing for SSO mode”
         in the active console to make sure stadby is running in SSO mode.
    !--- After standby boots up it’s console is locked
    
    VSS-sdby>
    Standby console disabled
    VSS-sdby>
    Standby console disabled

    Nota: A fim configurar o VSS em sub-rede múltipla, a configuração à espera não é precisada no VSS. Os gateway router devem ser estabelecidos o VLAN SVI.

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Troubleshooting

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

Má combinação do software entre os motores do supervisor

Se há uma má combinação do software entre os motores do supervisor, o supervisor standy vem acima no modo de redundância RPR (não no modo de redundância SSO), e o VSS não inicializa inteiramente.

A fim resolver a edição, certifique-se de que o software requerido esta presente no flash do supervisor standy e as instruções de inicialização apontam ao software correto. Recarregue o supervisor standy de modo que carreg com o software correto e se junte ao VSS.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 109334