Switches : Switches Cisco Catalyst 6500 Series

Exemplo de configuração de switches do Catalyst para balanceamento de carga da rede Microsoft

29 Julho 2013 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (6 Junho 2013) | Feedback

Introdução

Este original descreve como configurar os switches Cisco Catalyst para interagirem com o Microsoft Network Load Balancing (NLB).

Contribuído por Shashank Singh, engenheiro de TAC da Cisco.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Catalyst 6500 Switch que executa o software de Cisco IOS®

  • Cisco IOS Software running do Catalyst 4500 Switch

  • Cisco IOS Software running do Catalyst 3550 Switch

  • Cisco IOS Software running do Catalyst 3560 Switch

  • Cisco IOS Software running do Catalyst 3750 Switch

  • Microsoft Windows 2000/2003 de server

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando. 

Informações de Apoio

A tecnologia de equilíbrio da carga de rede (NLB) pode ser usada para distribuir pedidos do cliente através de um grupo de server. A fim certificar-se os clientes experimentam sempre níveis de desempenho aceitável, Windows NLB são usados frequentemente assegurar-se de que você possa adicionar server adicionais para escalar para fora aplicações apátridas, tais como servidores de Web IIS-baseados, porque a carga do cliente aumenta. Além, reduz o tempo ocioso da máquina causado pelos server que funcionam mal. Os utilizadores finais nunca saberão que um servidor membro particular em Windows NLB está ou estêve para baixo.

O equilíbrio da carga de rede é uma tecnologia de aglomeração oferecida por Microsoft como parte os sistemas operacionais 2003 de toda a família do servidor do Windows 2000 e do Windows Server. NLB usa um algoritmo distribuído para carregar o tráfego de rede do equilíbrio através de um número de server.

NLB empacota os server em um grupo de transmissão múltipla e tenta-os usar o IP de transmissão múltipla e o MAC address padrão. Ao mesmo tempo, fornece um único IP virtual para todos os clientes como o IP de destino, que significa que os server se juntam ao mesmo grupo de transmissão múltipla, e os clientes não saberão qualquer coisa sobre ele. Usam o acesso normal do unicast ao VIP.

Você pode configurar NLB para trabalhar em um destes modos:

Modo de Unicast

A configuração padrão NLB é modo de Unicast. No modo de Unicast, NLB substitui o MAC address real de cada server no conjunto a um MAC address comum NLB. Quando todo o server no conjunto tem o mesmo MAC address, todos os pacotes enviados a esse endereço estão enviados a todos os membros do conjunto. Contudo, um problema com esta configuração é quando o conjunto dos server NLB é conectado ao mesmo interruptor, você não pode mandar duas portas no interruptor registrar o mesmo MAC address. NLB resolve este problema mascarando o MAC address do conjunto. O interruptor olha o endereço MAC de origem no encabeçamento do frame da Ethernet a fim aprender que endereços MAC são associados com suas portas. NLB cria um MAC address falso e atribui esse MAC address falso a cada server no conjunto NLB. NLB atribui a cada server NLB um MAC address falso diferente baseado no ID do host do membro. Este endereço aparece no encabeçamento do frame da Ethernet.

Por exemplo, o MAC address do conjunto NLB é 00-bf-ac-10-00-01. NLB no modo de Unicast toma o MAC address do conjunto e, para cada membro de grânulos, NLB muda o segundo octeto de modo que consista no membro NLB? a identificação do host s por exemplo, o server número 1 como o MAC address falso 00-01-ac-10-00-01, ID do host número 2 tem o MAC address falso 00-02-ac-10-00-01, tão sobre. Se um MAC address original é registrado em cada porta de switch, os pacotes não estão entregados a todos os membros da disposição; um pouco os pacotes devem ainda ser enviados às portas de switch individuais baseadas no MAC address atribuído a essa porta. Para fazer os quadros entregados a todos os membros do NLB para aglomerá-lo quando cada porta de switch conectada a um membro de grânulos NLB registra um MAC address diferente usa uma transmissão ARP é usada. Quando o roteador envia uma requisição ARP para o MAC address do endereço IP de Um ou Mais Servidores Cisco ICM NT virtual, a resposta contem um cabeçalho ARP com o MAC address real 00-bf-ac-10-00-01 do conjunto NLB, conforme o exemplo dado acima e não o MAC address falso.

Os clientes usam o MAC address no cabeçalho ARP, não o cabeçalho de Ethernet. O interruptor usa o MAC address no cabeçalho de Ethernet, não o cabeçalho ARP. A edição é quando um cliente envia um pacote ao conjunto NLB com endereço MAC de destino como o MAC address 00-bf-ac-10-00-01 do conjunto, o interruptor olha a tabela CAM para o MAC address 00-bf-ac-10-00-01. Desde que não há nenhuma porta registrada com o MAC address 00-bf-ac-10-00-01 do conjunto NLB, o quadro é entregado a todas as portas de switch. Isto introduz a inundação do interruptor. Comute edições das causas da inundação quando a quantidade significativa de tráfego está fluindo e igualmente quando tendo outros server no mesmo interruptor. Uma solução para comutar a inundação é pôr um cubo simples na frente dos membros de grânulos e então do uplink NLB o cubo a uma porta de switch. Esta solução precisa nem sequer de mascarar o MAC address do conjunto NLB porque a porta do switch único conectada ao cubo aprende o MAC address do conjunto NLB. Isto evita o problema de duas portas de switch que registram o mesmo MAC address. Quando o cliente envia os pacotes ao NLB aglomeram o MAC address, os pacotes vão diretamente à porta de switch conectada ao cubo e então aos membros de grânulos NLB.

Modo multicast

Uma outra solução é usar o modo do Multicast na configuração GUI MS NLB em vez do modo de Unicast. No Modo multicast, o System Admin clica o botão do Multicast IGMP na configuração GUI MS NLB. Esta escolha instrui os membros de grânulos responder aos ARP para seu endereço virtual usando um endereço MAC de transmissão múltipla por exemplo 0300.5e11.1111 e enviar pacotes dos relatórios de sociedade de IGMP. Se o IGMP Snooping é permitido no switch local, ele espiões os pacotes de IGMP que passam com ele. Desta maneira, quando um cliente ARP para o conjunto? o endereço IP de Um ou Mais Servidores Cisco ICM NT virtual s, o conjunto responde com Multicast MAC por exemplo 0300.5e11.1111. Quando o cliente enviar o pacote a 0300.5e11.1111, o switch local para a frente que o pacote para fora cada um das portas conectou aos membros de grânulos. Neste caso, não há nenhuma possibilidade de inundar o pacote ARP fora de todas as portas. A edição com o modo do Multicast é endereço IP de Um ou Mais Servidores Cisco ICM NT virtual torna-se inacessível quando alcançada fora da sub-rede local porque os dispositivos Cisco não aceitam uma resposta arp para um endereço IP unicast que contenha um endereço MAC de transmissão múltipla. Assim a parcela MAC da entrada de ARP mostra como incompleto. (Emita o comando show arp ver a saída.) Porque não há nenhuma parcela MAC na resposta arp, a entrada de ARP nunca apareceu na tabela ARP. Eventualmente parou ARPing e retornou um host inalcançável ICMP aos clientes. A fim cancelar isto, use a entrada de ARP estática para povoar a tabela ARP como dada abaixo. Na teoria, isto permite que o dispositivo Cisco povoe seu mac-address-table. Por exemplo, se o endereço IP de Um ou Mais Servidores Cisco ICM NT virtual é 172.16.63.241 e o endereço MAC de transmissão múltipla é 0300.5e11.1111, use este comando a fim povoar estaticamente a tabela ARP:

arp 172.16.63.241 0300.5e11.1111

Contudo, desde que os pacotes recebidos têm um endereço IP de destino do unicast e um destino multicast MAC o dispositivo Cisco ignora estes entrada e processo-Switches pacotes de cada conjunto-limite. A fim evitar este processo que comuta, introduza uma entrada estática do mac-address-table como dada abaixo a fim comutar pacotes do conjunto-limite no hardware.

mac-address-table static 0300.5e11.1111 vlan 200 interface
fa2/3 fa2/4

Nota: Estaticamente traçar o MAC às portas múltiplas é apoiado somente no software no Catalyst 4500 Switch. Usar esta configuração no Catalyst 4500 Switch pode causar a alta utilização da CPU.

 

Nota: Para o Switches do 6000/6500 Series do Cisco catalyst, você deve adicionar o parâmetro do desabilitação-snopping. Por exemplo:

mac-address-table static 0300.5e11.1111 vlan 200
interface fa2/3 fa2/4 disable-snooping

O parâmetro da desabilitação-espião é essencial e aplicável somente para o Switches do 6000/6500 Series do Cisco catalyst. Sem esta indicação, o comportamento não é afetado.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a Command Lookup Tool (somente clientes registrados) para obter mais informações sobre os comandos usados nesta seção.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

Configurações

Este documento usa a configuração do Catalyst 6509 descrita nesta seção.

Cat6K#show running-config
Building configuration...
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat6K
!
boot buffersize 126968
boot system flash slot0:c6sup11-jsv-mz.121-8a.E.bin
!
redundancy
main-cpu
auto-sync standard
ip subnet-zero
!
!
interface GigabitEthernet1/1
no ip address
shutdown
!
interface GigabitEthernet1/2
no ip address
shutdown
!
interface FastEthernet2/1
description "Uplink to the Default Gateway"
no ip address
switchport
switchport access vlan 100
!
interface FastEthernet2/2
no ip address
shutdown
!
interface FastEthernet2/3
description "Connection to Microsoft server"
no ip address
switchport
switchport access vlan 200
!
interface FastEthernet2/4
description "Connection to Microsoft server"
no ip address
switchport
switchport access vlan 200
!
interface FastEthernet2/5
no ip address
shutdown
!
interface FastEthernet2/48
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
mac-address-table static 0300.5e11.1111 vlan 200 interface fa2/3 fa2/4 disable-snooping

! --- Creating a static entry in the switch for the multicast virtual mac.

! --- fa2/3 & fa2/4 are the ports connected to server.

!--- The disable-snooping is applicable only for Cisco Catalyst 6000/6500 series switches

arp 172.16.63.241 0300.5e11.1111

! --- 172.16.63.241 is the Virtual IP of 2 servers

interface Vlan100
ip address 172.17.63.240 255.255.255.192

!--- Client Side Vlan
!
interface Vlan200
ip address 10.1.1.250 255.255.255.0

!--- Server Vlan

!--- Important: Configure the default gateway

!--- of the Microsoft Server to this address.

!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.63.193
no ip http server
!
line con 0
line vty 0 4
login
!
end

Nota: Assegure-se de que você use o modo do Multicast no conjunto NLB. Cisco recomenda que você não usa os endereços MAC de transmissão múltipla que começam com os 01 porque são sabidos para ter um conflito com a instalação IGMP.

Verificar

Use esta seção para confirmar se a sua configuração funciona corretamente.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

  • mac-address-table da mostra - Indica uma estática da tabela de endereços MAC e uma entrada dinâmica específica ou a estática e as entradas dinâmica da tabela de endereços MAC em uma relação ou em um VLAN específico.

    Cat6K#show mac-address-table 0300.5e11.1111

              Mac Address Table
    -------------------------------------------

    Vlan    Mac Address      vType        Ports
    ---- -----------      --------     -----
    200    0300.5e11.1111     STATIC    Fa2/3 Fa2/4
  • mostre IP arp - Indica o esconderijo do Address Resolution Protocol (ARP).

    Cat6K#show ip arp
    Protocol  Address          Age (min)  Hardware Addr   Type   Interface
    Internet  172.16.1.1            -     0300.5e11.1111  ARPA   Vlan200

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.

Informações Relacionadas


Comunidade de Suporte da Cisco - Conversas em Destaque

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas. Eis aqui algumas das conversas mais importantes apresentadas em nosso fórum.


Document ID: 107995