Switches : Switches Cisco Catalyst 6500 Series

Exemplo de configuração de switches do Catalyst para balanceamento de carga da rede Microsoft

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (6 Outubro 2015) | Feedback

Introdução

Este documento descreve como configurar o Switches do Cisco catalyst a fim interagir com o Balanceamento de carga da rede Microsoft (NLB).

Contribuído por Ambrose Taylor, por Dale Miller, e por Shashank Singh, engenheiros de TAC da Cisco.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Cisco Catalyst 6500 Series Switch com Supervisor Engine 2T (Sup2T) essa versão 15.1(1)SY1 do Cisco IOS ® Software da corrida

  • Cisco Catalyst 4948 Series Switch que executam a versão 15.0(2)SG7 do Cisco IOS Software

  • Server de Microsoft Windows

Nota: Consulte o manual de configuração apropriado para os comandos que são usados a fim permitir estas características em outras plataformas Cisco.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Informações de Apoio

A tecnologia NLB pode ser usada a fim distribuir pedidos do cliente através de um grupo de server. A fim assegurar-se de que os clientes experimentem sempre níveis de desempenho aceitável, Microsoft Windows NLB fornece a capacidade para adicionar server adicionais de modo que você possa escalar para fora aplicativos apátridas, tais como servidores de Web IIS-baseados, porque a carga do cliente aumenta. Além, reduz o tempo ocioso da máquina que é causado pelos server que funcionam mal.

Microsoft Windows NLB é uma tecnologia de aglomeração que seja oferecida como parte de todo o servidor do Windows 2000 e Windows 2003 sistemas operacionais da família do server. Fornece um único endereço IP de Um ou Mais Servidores Cisco ICM NT virtual para todos os clientes como o endereço IP de destino para o conjunto inteiro.

Você pode configurar NLB para trabalhar em um destes três modos:

  • Modo de Unicast
  • Modo multicast
  • Modo do Internet Group Management Protocol (IGMP)

Modo de Unicast

Estão aqui algumas notas sobre o uso de NLB no modo de Unicast:

  • No modo de Unicast, NLB substitui o endereço de controle de acesso de mídia (MAC) real de cada server no conjunto com um MAC address comum NLB. Quando todos os server no conjunto têm o mesmo MAC address, todos os pacotes que são enviados a esse endereço estão enviados a todos os membros no conjunto. O NLB cria um MAC address fictício e atribui-o a cada server no conjunto NLB. O NLB atribui a cada server NLB um MAC address fictício diferente, com base no ID do host do membro. Este endereço aparece no encabeçamento do frame da Ethernet.

  • O MAC address é usado no encabeçamento do Address Resolution Protocol (ARP), não o cabeçalho de Ethernet. O interruptor usa o MAC address no cabeçalho de Ethernet, não o cabeçalho ARP. Isto causa uma edição quando um pacote é enviado ao conjunto NLB com o endereço MAC de destino como o MAC address 00-bf-ac-10-00-01 do conjunto. O interruptor vê a tabela do Content Addressable Memory (CAM) para o MAC address 00-bf-ac-10-00-01, e desde que não há nenhuma porta registrada com o MAC address 00-bf-ac-10-00-01 do conjunto NLB, o quadro é entregado a todas as portas de switch. Isto introduz a inundação unicast. A fim evitar inundar, Cisco recomenda que você usa um vlan dedicada para NLB de modo que a inundação seja forçada.

Modo multicast

Estão aqui algumas notas sobre o uso de NLB no Modo multicast:

  • No Modo multicast, o administrador de sistema clica o botão do Multicast na configuração GUI de Microsoft NLB. Esta escolha instrui os membros de grânulos responder aos ARP para seu endereço virtual com o uso de um endereço MAC de transmissão múltipla, tal como 0300.5e01.0101.

  • O processo ARP não termina para endereços MAC de transmissão múltipla (este quebra o RFC 1812). Um endereço MAC estático é exigido a fim alcançar o conjunto fora da sub-rede local.

  • O endereço IP de Um ou Mais Servidores Cisco ICM NT virtual é 10.100.1.99 e o endereço MAC de transmissão múltipla é 0300.5e01.0101. Incorpore este comando a fim povoar estaticamente a tabela ARP:
    arp 10.100.1.99 0300.5e01.0101
  • Desde que os pacotes de entrada têm um endereço IP de destino do unicast e um MAC address do destino multicast, o dispositivo Cisco ignora esta entrada e o unicast inunda cada pacote do conjunto-limite. A fim evitar esta inundação, introduza uma entrada estática do mac-address-table a fim comutar os pacotes do conjunto-limite no hardware:
    mac address-table static 0300.5e01.0101 vlan 200 interface TenGigabitEthernet1/4
    TenGigabitEthernet1/5

Nota: Quando você traça estaticamente um MAC address às portas múltiplas, está apoiado somente pelo software no Cisco Catalyst 4500 Series Switch. Também, o uso desta configuração no Catalyst 4500 Series Switch pôde causar a alta utilização da CPU. A fim evitar este problema, você pode isolar o NLB a um VLAN específico, adiciona somente as entradas de ARP estáticas, e reserva-as inundar nesse VLAN.

Modo IGMP

Estão aqui algumas notas sobre o uso de NLB no modo IGMP:

  • O uso de NLB no modo IGMP exige menos quantidade de configuração manual. O endereço MAC virtual cai dentro da escala e dos começos do Internet Assigned Numbers Authority (IANA) com 0100.5exx.xxxx. Desde que o MAC address se conforma agora às especificações IANA, os switch Cisco podem dinamicamente programar o MAC address com o uso do IGMP Snooping. Isto remove a necessidade de programar manualmente o MAC address aos mapas de portas que são exigidos no Modo multicast a fim impedir inundar ao VLAN.

  • O IGMP Snooping programa o endereço MAC virtual para você uma vez que o interruptor recebe uns relatórios de associação de um membro no conjunto. Uma porta do mrouter deve igualmente ser programada para o NLB VLAN com o uso da transmissão múltipla independente de protocolo (PIM) ou da característica do IGMP mais investigado.

  • Desde que o endereço IP de Um ou Mais Servidores Cisco ICM NT virtual usa um endereço MAC de transmissão múltipla, é parte externa inacessível da sub-rede local. A fim endereçar isto, você deve configurar uma entrada de ARP estática em cada dispositivo com uma relação da camada 3 (L3) no conjunto VLAN. Termine isto na mesma forma que com Modo multicast. Por exemplo, se o endereço IP de Um ou Mais Servidores Cisco ICM NT virtual é 10.100.1.99 e o endereço MAC de transmissão múltipla é 0100.5e01.0101, use este comando a fim povoar estaticamente a tabela ARP:
    arp 10.100.1.99 0100.5e01.0101

Caveats

Estão aqui as observações importantes a manter-se na mente quando você usa NLB no modo IGMP:

  • Como seguido na identificação de bug Cisco CSCsw72680, você não pode usar o PIM na interface virtual do interruptor NLB VLAN (SVI) com determinadas versões de código. Veja os detalhes do bug para as liberações de código que endereçam esta edição ou usam os recursos de consulta do IGMP Snooping.

  • Como seguido na identificação de bug Cisco CSCsy62709, os pacotes são duplicados para todo o tráfego que é distribuído aos server NLB no modo IGMP. Veja os detalhes do bug para as versões de código afetadas.

  • Devido a uma limitação do hardware que seja seguida pela identificação de bug Cisco CSCug49149, o tráfego NLB não pode ser enviado através de um EtherChannel distribuído na mesma placa de linha 6708 quando o interruptor é executado no modo PFC3B ou PFC3C. O canal de porta deve ser cabografado de modo que todos os enlaces membros estejam no mesmo Forwarding Engine.

Configurar

Esta seção descreve como configurar NLB para as Plataformas do Cisco Catalyst 6500 e 4948 Series que são executado no Multicast ou no modo IGMP.

Diagrama de Rede

Configuração para o Modo multicast

Esta seção descreve como configurar NLB para as Plataformas do Cisco Catalyst 6500 e 4948 Series que são executado no Modo multicast:

6500-1#show running-config
Building configuration...
!
hostname 6500-1
!
boot system flash disk0:s2t54-adventerprisek9-mz.SPA.151-1.SY1
!
interface TenGigabitEthernet1/4
switchport
switchport trunk allowed vlan 1,100,200
switchport mode trunk
!
interface TenGigabitEthernet1/5
switchport
switchport trunk allowed vlan 1,100,200
switchport mode trunk
!
interface Vlan100
ip address 10.100.1.1 255.255.255.0

!
!        
interface Vlan200
ip address 10.200.1.1 255.255.255.0

!
!
arp 10.100.1.88 0300.5e01.0101 ARPA
!
!
mac address-table static 0300.5e01.0101 vlan 200 interface TenGigabitEthernet1/4
TenGigabitEthernet1/5 TenGigabitEthernet5/5

!
end

Estão aqui algumas observações importantes sobre esta configuração:

  • O valor do endereço IP de Um ou Mais Servidores Cisco ICM NT da relação Vlan100 configura o VLAN de usuário.

  • O valor do endereço IP de Um ou Mais Servidores Cisco ICM NT da relação Vlan200 configura o conjunto VLAN NLB. É importante que você configura o gateway padrão do servidor Microsoft a este endereço.

  • O arp 10.100.1.88 0300.5e01.0101 ARPA inclui todas as relações L3 no VLAN e é o endereço IP de Um ou Mais Servidores Cisco ICM NT virtual dos server do conjunto NLB.

  • A relação 0300.5e01.0101 200 vlan estática da tabela de endereços MAC cria uma entrada de MAC estática ao mapeamento de porta no interruptor para o endereço MAC virtual do Multicast.

Nota: Assegure-se de que você use o Modo multicast no conjunto NLB. Cisco recomenda que você não usa os endereços MAC de transmissão múltipla que começam com os 01 porque são sabidos para ter um conflito com a instalação IGMP.

4948-1#show running-config
Building configuration...
!
hostname 4948-1
!
boot system bootflash:cat4500-entservices-mz.150-2.SG7
!
interface GigabitEthernet1/1
 switchport access vlan 200
!
interface TenGigabitEthernet1/49
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
!
interface TenGigabitEthernet1/50
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
!
mac address-table static 0300.5e01.0101 vlan 200 interface Gi1/1 Te1/49 Te1/50
!
!
end

Nota: A relação 0300.5e01.0101 200 vlan estática da tabela de endereços MAC cria uma entrada estática no interruptor para o endereço MAC virtual do Multicast. É importante recordar que todas as interfaces de tronco que levam o tráfego NLB entre o Switches devem ser adicionadas. Uma vez que um endereço MAC estático é definido, inundar está forçada. Se você esquece incluir uma relação, o conjunto NLB quebra. 

Configuração para o modo IGMP

Esta seção descreve como configurar NLB para as Plataformas do Cisco Catalyst 6500 e 4948 Series que são executado no modo IGMP:

6500-1#show running-config
Building configuration...
!
hostname 6500-1
!
boot system flash disk0:s2t54-adventerprisek9-mz.SPA.151-1.SY1
!
ip igmp snooping querier
!
!
vlan configuration 1,100
 no ip igmp snooping querier
!        
vlan configuration 200
ip igmp snooping querier address 10.200.1.1
!
!
interface TenGigabitEthernet1/4
 switchport
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
!
interface TenGigabitEthernet1/5
 switchport
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
!
!
interface Vlan100
 ip address 10.100.1.1 255.255.255.0

!
!        
interface Vlan200
 ip address 10.200.1.1 255.255.255.0

!
!
arp 10.100.1.99 0100.5e01.0101 ARPA
!
!
end

Estão aqui algumas observações importantes sobre esta configuração:

  • O formador de fila do IGMP Snooping IP permite a característica do formador de fila espião.

  • O endereço 10.200.1.1 do formador de fila do IGMP Snooping IP configura o formador de fila espião para o NLB VLAN.

  • O VLAN de usuário é a relação Vlan100.

  • O conjunto VLAN NLB é a relação Vlan200. É importante que você configura o gateway padrão do servidor Microsoft a este endereço (endereço IP 10.200.1.1 255.255.255.0).

  • O arp 10.100.1.99 0100.5e01.0101 ARPA é o endereço IP de Um ou Mais Servidores Cisco ICM NT virtual dos server do conjunto NLB. O ARP estático deve estar em todas as relações L3 no VLAN.

4948-1#show running-config
Building configuration...
!
hostname 4948-1
!
boot system bootflash:cat4500-entservices-mz.150-2.SG7
!
interface GigabitEthernet1/1
 switchport access vlan 200
!
interface TenGigabitEthernet1/49
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
!
interface TenGigabitEthernet1/50
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
!
end

Nota: Não há nenhuma necessidade de configurar entradas estáticas, porque o IGMP Snooping faz este dinamicamente neste modo. Também, nenhuma configuração especial para este modo é exigida no Switches a jusante da camada 2 (L2).

Verificar

Use esta seção para confirmar se a sua configuração funciona corretamente.

Nota: A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Verificação do Modo multicast

Inscreva o comando show ip arp a fim ver o cache ARP:

6500-1#show ip arp
Protocol Address         Age (min) Hardware Addr   Type   Interface
Internet 10.100.1.99            -   0300.5e01.0101  ARPA

Inscreva o comando static da tabela de endereços MAC da mostra a fim ver uma estática da tabela de endereços MAC e uma entrada dinâmica específica ou a estática e as entradas dinâmica da tabela de endereços MAC em uma relação ou em um VLAN específico:

6500-1#show mac address-table static add 0300.5e01.0101

vlan   mac address    type   learn    age      ports
----+---------------+-------+-----+------+-----------------
200 0300.5e01.0101   static   No       -  Te1/4 Te1/5 Te5/5
4948-1#show mac address-table static add 0300.5e01.0101

Multicast Entries
vlan    mac address     type   ports
------+---------------+-------+--------------------
200    0300.5e01.0101   static Gi1/1,Te1/49,Te1/50

Verificação do modo IGMP

Inscreva o comando show ip arp a fim ver o cache ARP:

6500-1#show ip arp

Protocol Address       Age (min) Hardware Addr   Type   Interface
Internet 10.100.1.99         -   0100.5e01.0101  ARPA

Entre no mrouter do IGMP Snooping da mostra IP a fim ver a porta do mrouter que é programada pelas perguntas recebidas do formador de fila espião ascendente:

4948-1#show ip igmp snooping mrouter

Vlan    ports
----    -----
 200   Te1/49(dynamic)

Incorpore o IGMP Snooping do Multicast da tabela de endereços MAC da mostra a fim ver o MAC address dinâmico-adicionado que é instruído do IGMP Snooping e das portas membro:

4948-1#show mac address-table multicast igmp-snooping

Multicast Entries
 vlan   mac address     type    ports
------+---------------+------+-------------
 200   0100.5e01.0101  igmp Gi1/1,Te1/49

Inscreva os grupos do IGMP Snooping da mostra IP a fim ver a lista de porta dos membros de grânulos que se juntaram ao grupo de transmissão múltipla:

4948-1#show ip igmp snooping groups

Vlan      Group      Version    Port List
-----------------------------------------
200       239.1.1.1   v2         Gi1/1

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.



Document ID: 107995