IP : Conversão de endereços de rede (NAT)

Função de balanceamento de carga IO NAT para duas conexões ISP

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento descreve uma configuração para que um roteador do � do Cisco IOS conecte uma rede ao Internet com o Network Address Translation (NAT) através de duas conexões ISP. O NAT do Cisco IOS Software pode distribuir conexões de TCP e sessões de UDP subsequentes sobre conexões de rede múltipla, se as rotas de custo igual a um destino fornecido estão disponíveis.

/image/gif/paws/100658/ios-nat-load-balancing-2isp-01.gif

Pré-requisitos

Requisitos

Este documento supõe que você começa trabalhar com LAN e conexões de WAN, e não fornece o fundo da configuração ou do Troubleshooting para estabelecer a conectividade inicial. Este documento não descreve um mecanismo para diferenciar-se entre as rotas; assim, não há nenhuma maneira de preferir uma conexão mais-desejável sobre uma conexão menos-desejável.

Componentes Utilizados

Esta configuração foi desenvolvida com o uso de um Cisco 1811 Router com software avançado Cisco IOS Software Release 12.4(15)T3 dos Serviços IP. Se uma versão de software diferente é usada, algumas características não estão possivelmente disponíveis, ou o táxi dos comandos configuration difere daqueles mostrados neste documento. A configuração similar deve estar disponível em todas as plataformas de roteador do Cisco IOS, embora a configuração da interface varie provavelmente entre Plataformas diferentes.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Você precisa de adicionar para ter certeza o roteamento baseado em política para o tráfego específico que usa sempre uma conexão ISP. Os exemplos do tráfego que exigem este comportamento incluem o tráfego dos clientes do IPSec VPN, da telefonia de VoIP, e o todo o outro tráfego que dever sempre usar somente uma das opções de conexão ISP para preferir o mesmo endereço IP de Um ou Mais Servidores Cisco ICM NT, uma velocidade mais alta, ou para abaixar a latência na conexão.

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a ferramenta de consulta de comandos (clientes registrados somente) a fim encontrar mais informação nos comandos usados neste documento.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/100658/ios-nat-load-balancing-2isp-02.gif

Este exemplo de configuração descreve um roteador de acesso que use uma conexão IP DHCP-configurada a um ISP, que é mostrado pelos FastEthernet 0, e uma conexão PPPoE sobre a outra conexão ISP. Os tipos de conexão não têm nenhum impacto particular na configuração, embora os tipos de algumas conexões possam impedir a usabilidade desta configuração em cenários de falha específicos, particularmente nos casos onde a conectividade IP sobre um serviço MACILENTO Ethernet-conectado é usada, por exemplo, um modem a cabo ou serviços DSL onde um dispositivo adicional termina a conectividade de WAN e fornece a mão-fora dos Ethernet ao roteador do Cisco IOS. Nos casos onde o endereçamento do IP Estático é aplicado, ao contrário dos endereços DHCP-atribuídos ou do PPPoE, e uma falha WAN ocorre tais que a porta Ethernet ainda mantém as ligações de Ethernet ao dispositivo da conectividade de WAN, o roteador continua a tentar à Conectividade do balanceamento de carga através das boas e conexões de WAN ruins. Se seu desenvolvimento exige que as rotas inativas estejam removidas da função de balanceamento de carga, refira a configuração fornecida no documento, função de balanceamento de carga IO NAT com o roteamento de extremidade aperfeiçoado para duas conexões com o Internet, que descreve a adição de roteamento de extremidade aperfeiçoado a fim monitorar a validez da rota.

Configurações

Este documento utiliza esta configuração:

interface FastEthernet0
 ip address dhcp
 ip nat outside
 ip virtual-reassembly
!
interface FastEthernet1
 no ip address
 pppoe enable
 no cdp enable
!
interface FastEthernet2
 no cdp enable
!


!
interface Vlan1
 description LAN Interface
 ip address 192.168.108.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1452


!---Define LAN-facing interfaces with "ip nat inside".

!

!
Interface Dialer 0
 description PPPoX dialer
 ip address negotiated
 ip nat outside
 ip virtual-reassembly
 ip tcp adjust-mss


!---Define ISP-facing interfaces with "ip nat outside".

!
ip route 0.0.0.0 0.0.0.0 dialer 0 track 123
!
 
!
ip nat inside source route-map fixed-nat interface Dialer0 overload
ip nat inside source route-map dhcp-nat interface FastEthernet0 overload
!

!--- Configure NAT overload (PAT) in order to use route-maps.

 
!
access-list 110 permit ip 192.168.108.0 0.0.0.255 any
!

!--- Define ACLs for traffic that are NATed to 
!--- the ISP connections.


!
route-map fixed-nat permit 10
 match ip address 110
 match interface Dialer0
!
route-map dhcp-nat permit 10
 match ip address 110
 match interface FastEthernet0


!--- Route-maps associate NAT ACLs with NAT outside on 
!--- the ISP-facing interfaces.

Verificar

Use esta seção para confirmar se a sua configuração funciona corretamente.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

  • mostre a IP a tradução nat — Atividade dos indicadores NAT entre host internos NAT e host exteriores NAT. Este comando fornece a verificação que os host internos estão sendo traduzidos a ambos os endereços exteriores NAT.

    Router#show ip nat translation
    Pro Inside global      Inside local       Outside local      Outside global
    tcp 172.16.108.44:54486 192.168.108.3:54486 172.16.104.10:22 172.16.104.10:22
    tcp 172.16.106.42:49620 192.168.108.3:49620 172.16.102.11:80 172.16.102.11:80
    tcp 172.16.108.44:1623 192.168.108.4:1623 172.16.102.11:445  172.16.102.11:445
    Router#
  • mostre a rota IP — Verifica que as rotas múltiplas ao Internet estão disponíveis.

    Router#show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route
    
    Gateway of last resort is 172.16.108.1 to network 0.0.0.0
    
    C    192.168.108.0/24 is directly connected, Vlan1
         172.16.0.0/24 is subnetted, 2 subnets
    C       172.16.108.0 is directly connected, FastEthernet4
    C       172.16.106.0 is directly connected, Vlan106
    S*   0.0.0.0/0 [1/0] via 172.16.108.1
                   [1/0] via 172.16.106.1
    Router#

Troubleshooting

Use esta seção para resolver problemas de configuração.

Depois que você configura o roteador do Cisco IOS com NAT, se as conexões não trabalham, seja certo que:

  • O NAT é aplicado apropriadamente na parte externa e nas interfaces internas.

  • A configuração de NAT está completa, e os ACL refletem o tráfego que deve ser NATed.

  • As rotas múltiplas ao Internet/WAN estão disponíveis.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 100658