Voz e comunicações unificadas : Cisco Unified Border Element

Exemplo de configuração Transcoding unificado do elemento da beira

15 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

O Cisco Unified Border Element (CUBO) apoia transcoding para os atendimentos que passam completamente e que exigem codecs diferentes nos dois trechos de chamada. Transcoding entre vários codecs é apoiado, e o CUBO introduz um transcodificador baseado na configuração assim como em uma má combinação entre os codecs negociada nos dois trechos de chamada dos atendimentos.

Transcoding exige DSP terminar o córrego RTP e descodificar e codificar o payload de voz com o codec apropriado. Os DSP usados pelo CUBO transcoding podem ser co-residente no mesmo roteador como o CUBO ou podem ser ficados situados em uma plataforma do roteador separado.

Pré-requisitos

Requisitos

Certifique-se de atender a estes requisitos antes de tentar esta configuração:

Componentes Utilizados

A informação neste documento é baseada sobre:

  • Cisco Unified Border Element que é executado em um Cisco 3745 Router e usa o Cisco IOS Release 12.3.11T ou Mais Recente

  • Recursos de DSP Transcoding em um servidor de acesso de Cisco AS5400XM com uma placa de recurso AS5X-FC povoados com os cartões AS5X-PVDM2-64 DSP

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a Command Lookup Tool (somente clientes registrados) para obter mais informações sobre os comandos usados nesta seção.

Diagrama de Rede

Esta figura mostra um exemplo do CUBO com os DSP externos para transcoding:

/image/gif/paws/100480/cube_transcode.gif

Os recursos de DSP podem igualmente ser internos (ou co-residente de) à plataforma do mesmo roteador que os anfitriões CUBAM. Se este é o caso, o controle dos recursos de DSP é local ao roteador, e o fluxo de controle SCCP na figura não está atual.

Os recursos de DSP que o CUBO usa transcoding devem ser configurados apesar de mesmo se os DSP são co-residente com CUBO. A única diferença nas configurações é o endereçamento de IP entre o CUBO e os recursos de DSP. Para uma configuração co-residente, o endereço IP de Um ou Mais Servidores Cisco ICM NT é o mesmo para ambos.

Passos de configuração

Esta seção descreve como configurar o DSP externo que transcoding. Um Cisco 3745 Router é usado como um CUBO, e um AS5400XM é usado hospedando os recursos de DSP para transcoding.

A configuração aplica-se a este fluxo de chamadas:

  1. O atendimento parte do OGW para o CUBO através de H.323 com G.711.

  2. CUBE para a frente o atendimento através de H.323 ao OGW (que é configurado para G.729).

  3. Para a configuração de chamada ao TGW a ser bem sucedido, uma conversão do codec é exigida de G.711 a G.729. Se os recursos transcoding estão não configurados ou disponíveis, a configuração de chamada falha.

Configuração do CUBO para o controle Transcoding externo

Um roteador do CUBO é configurado para controlar os recursos de DSP para transcoding. Esta configuração usa o comando telephony-service, que é similar à configuração transcoding para Cisco unificou o gerente de uma comunicação expresso. Os recursos de DSP registram-se com a entidade de controlo (que neste exemplo é CUBO, mas poderia igualmente ser CUCME ou CUCM).

CUBO 3745
vdouut3#show running-config | begin telephony
!
telephony-service
sdspfarm units 1 -- Specifies the maximum number of DSP farms that can
                    be registered to CUBE. A maximum of 5 DSP resource units
                    (farms) can be configured.
sdspfarm transcode sessions 128 -- Specifies the maximum transcoding
                    sessions supported across all DSP farms registered
                    with CUBE.
sdspfarm tag 1 vdouut1 -- Specifies the device name of the DSP farm. For
                    uniqueness the device name can be the MAC address of the 
                    DSP source interface. In this example the hostname of
                    the DSP farm router is used.
ip source-address 1.2.61.73 port 2000 – The IP address and port-no: (TCP)
                    of the interface through which SCCP messages are
                    transmitted/received from CUBE.

Configuração do Farm de DSP para hospedar recursos de DSP Transcoding externos

Um roteador é configurado para hospedar recursos de DSP para transcoding usado por uma entidade de controlo, que neste exemplo seja CUBO em um roteador diferente. Os recursos de DSP são registrados com a entidade de controlo para fazê-los disponíveis aos fluxos de chamadas.

Farm de DSP
vdouut1#show running-config | begin voice-card
voice-card 1
  dsp services dspfarm –- This makes the DSPs available for “DSP farming”
                    which includes transcoding services.

vdouut1#show running-config | begin sccp
sccp local GigabitEthernet0/0 -- Defines the source interface of the DSP
                    farm through which SCCP messages are exchanged with
                    controlling CUBE.               
sccp ccm 1.2.61.73 identifier 1 -- Specifies the IP address of the CUBE
                    system that the DSP farm registers to. This should
                    match the CUBE IP address on the “ip source-address”
                    configuration on CUBE.
sccp
sccp ccm group 1 -- Group configuration for linking “sccp ccm global”
                    configurations as well as the dspfarm profile(s)
  bind interface GigabitEthernet0/0
associate ccm 1 priority 1 -- Associate the sccp identifier “ccm” with
                  the “sccp ccm group”.
associate profile 1 register vdouut1 -- Associate the dspfarm profile 
                  with the DSP farm device name. In this example the 
                  hostname of the DSP farm hosted router is used
                  (vdouut1). The same name must be used on CUBE where
                  “sdspfarm tag 1” is configured.
!
dspfarm profile 1 transcode -- Configure the dspfarm profile to define
                     the codecs supported, the maximum sessions, and
                     enable SCCP.
  codec g711ulaw
  codec g711alaw
  codec g729ar8
  codec g729abr8
  codec g729r8
  codec g729br8
  maximum sessions 128
  associate application SCCP

Configurações de amostra completas para Transcoding interno

Esta seção fornece um exemplo da configuração direta para uma instalação onde o mesmo roteador (um AS5400XM) seja configurado para hospedar o CUBO e os recursos de DSP para transcoding. As partes salientes da configuração aredisplayed no texto em negrito.

As diferenças entre estas instalação da configuração e configuração do Farm de DSP para hospedar recursos de DSP Transcoding externos são como segue:

  • Os recursos de DSP reais (o “Voz-cartão x” > “dsp presta serviços de manutenção ao dspfarm ") e a entidade de controlo (“telefonia-serviço ") aparecem no mesmo roteador.

  • O endereço IP de Um ou Mais Servidores Cisco ICM NT dos recursos de DSP (do “identificador 1" sccp ccm 9.13.29.30) e o endereço IP de Um ou Mais Servidores Cisco ICM NT da entidade de controlo (“telefonia-serviço” > “porta de 9.13.29.30 do fonte-endereço IP ") são o mesmo.

5400XM
5400XM#show run
Building configuration...

Current configuration : 3149 bytes
!
version 12.4
service config
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 5400XM
!
boot-start-marker
no boot startup-test
boot-end-marker
!
logging buffered 100000000 debugging
no logging console
enable secret 5 $1$g301$4BVklIIq97tihABYS6Guy/
enable password xxx
!
resource-pool disable
no aaa new-model
!
resource policy
!
voice-card 1
 dsp services dspfarm
!
voice-card 5
!
ip cef
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 h323
 modem passthrough none codec g729r8 pre-ietf
!
controller T1 5/0
 framing sf
 linecode ami
!
controller T1 5/1
 framing sf
 linecode ami
!
controller T1 5/2
 framing sf
 linecode ami
!
controller T1 5/3
 framing sf
 linecode ami
!
controller T1 5/4
 framing sf
 linecode ami
!
controller T1 5/5
 framing sf
 linecode ami
!
controller T1 5/6
 framing sf
 linecode ami
!
controller T1 5/7
 framing sf
 linecode ami
!
interface GigabitEthernet0/0
 ip address 9.13.29.30 255.255.255.0
 duplex auto
 speed auto
 negotiation auto
 no cdp enable
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
 negotiation auto
 no cdp enable
!
interface Serial0/0
 no ip address
 shutdown
 clock rate 2000000
 no fair-queue
!
interface Serial5/0
 no ip address
 shutdown
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
 no cdp enable
!
ip route 0.0.0.0 0.0.0.0 9.13.29.1
!
no ip http server
!
dialer-list 1 protocol ip permit
!
sccp local GigabitEthernet0/0
sccp ccm 9.13.29.30 identifier 1 version 4.0 -- Use its own IP address
sccp
!
sccp ccm group 1
 associate ccm 1 priority 1
 associate profile 1 register XCODE123456
 keepalive retries 1
 keepalive timeout 10
 switchover method immediate
 switchback method immediate
!
dspfarm profile 1 transcode
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 codec gsmfr
 codec g729r8
 codec g729br8
 maximum sessions 10
 associate application SCCP
!
dial-peer voice 1 voip
 destination-pattern 630222100.
 session protocol sipv2
 session target ipv4:9.13.29.22
 dtmf-relay rtp-nte digit-drop
 codec g711ulaw
!
dial-peer voice 2 voip
 session protocol sipv2
 incoming called-number 630222100.
 codec g729br8 bytes 10
!
dial-peer voice 3 voip
 destination-pattern 2000
 session protocol sipv2
 session target ipv4:9.13.29.22
 dtmf-relay rtp-nte digit-drop
!
dial-peer voice 4 voip
 session protocol sipv2
 incoming called-number 2000
 codec g711ulaw
!
gatekeeper
 shutdown
!
telephony-service
 max-ephones 1
 max-dn 1
 ip source-address 9.13.29.30 port 2000 --> Use its own IP address
 sdspfarm units 1
 sdspfarm transcode sessions 10
 sdspfarm tag 1 XCODE123456
 ss7 mtp2-variant Bellcore 0
 ss7 mtp2-variant Bellcore 1
 ss7 mtp2-variant Bellcore 2
 ss7 mtp2-variant Bellcore 3
 !
line con 0
 exec-timeout 0 0
 logging synchronous
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 password cisco
 login
!
scheduler allocate 10000 400
no process cpu extended
no process cpu autoprofile hog
end

Verificar

A saída nesta seção refere-se a configuração setup para transcoding externo.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

CUBO

O nome de dispositivo com que o Farm de DSP é registrado com CUBO e o endereço IP de Um ou Mais Servidores Cisco ICM NT do roteador host do Farm de DSP é indicado no texto em negrito.

vdouut3#show sdspfarm units
Load for five secs: 0%/0%; one minute: 0%; five minutes: 3%
Time source is NTP, 23:46:40.649 PST Tue Nov 21 2006


mtp-1 Device:vdouut1 TCP socket:[1] REGISTERED
actual_stream:256 max_stream 256 IP:1.2.61.71  27519  MTP YOKO keepalive 45  
Supported codec:
                 G711Ulaw
                 G711Alaw
                 G729
                 G729a
                 G729b
                 G729ab
 max-mtps:1, max-streams:256, alloc-streams:256, act-streams:0

Esta saída mostra a instalação da configuração do CUBO.

vdouut3#show telephony-service
ip source-address 1.2.61.73 port 2000
max-ephones 128
max-dn 1
max-conferences 8 gain -6
dspfarm units 1
dspfarm transcode sessions 128
dspfarm 1 vdouut1

Esta saída mostra que depois que um atendimento é feito aos codecs (indicados no texto em negrito) que são usados para os trechos de chamada através do CUBO.

vdouut3#show sdspfarm sessions active 
Load for five secs: 1%/0%; one minute: 1%; five minutes: 1%
Time source is NTP, 23:52:43.922 PST Tue Nov 21 2006

Stream-ID:37 mtp:1 1.2.61.71  20190  Local:2000 START  
 usage: Ip-Ip                        
 codec:G729  duration:20 vad:0 peer Stream-ID:38 

Stream-ID:38 mtp:1 1.2.61.71  21326  Local:2000 START  
 usage: Ip-Ip                        
 codec:G711Ulaw64k  duration:20 vad:0 peer Stream-ID:37

Esta saída mostra o active das sessões entre o OGW e o TGW através do CUBO.

vdouut3#show voip rtp connections     
Load for five secs: 1%/0%; one minute: 1%; five minutes: 1%
Time source is NTP, 23:54:22.722 PST Tue Nov 21 2006
VoIP RTP active connections :
No. CallId     dstCallId  LocalRTP RmtRTP LocalIP         RemoteIP       
1   3991       3992       18496    17430  1.2.61.73       1.2.61.48      
2   3992       3991       17382    19706  1.2.61.73       1.2.61.68      
Found 2 active RTP connections

Esta saída mostra um sumário compacto das sessões ativa e dos codecs (indicados no texto em negrito) usados pelos trechos de chamada.

vdouut3#show call active voice compact 
Load for five secs: 1%/0%; one minute: 1%; five minutes: 1%
Time source is NTP, 02:31:58.156 PST Wed Nov 22 2006
 <callID>  A/O FAX T<sec> Codec     type  Peer Address  IP R<ip>:<udp>
Total call-legs: 2
      4023 ANS     T25    g711ulaw  VOIP  P5200         1.2.61.48:16934
      4024 ORG     T25    g729r8    VOIP  P6200         1.2.61.68:17040

Host do Farm de DSP

Esta saída mostra o estado do status de registro dos recursos de DSP. A informação saliente aparece no texto em negrito.

vdouut1#show sccp
SCCP Admin State: UP
Gateway IP Address: 1.2.61.71, Port Number: 2000
IP Precedence: 5
User Masked Codec list: None
Call Manager: 1.2.61.73, Port Number: 2000
                Priority: N/A, Version: 3.1, Identifier: 1

Transcoding Oper State: ACTIVE - Cause Code: NONE
Active Call Manager: 1.2.61.73, Port Number: 2000
TCP Link Status: CONNECTED, Profile Identifier: 1
Reported Max Streams: 256, Reported Max OOS Streams: 0
Supported Codec: g711ulaw, Maximum Packetization Period: 30
Supported Codec: g711alaw, Maximum Packetization Period: 30
Supported Codec: g729ar8, Maximum Packetization Period: 60
Supported Codec: g729abr8, Maximum Packetization Period: 60
Supported Codec: g729r8, Maximum Packetization Period: 60
Supported Codec: g729br8, Maximum Packetization Period: 60
Supported Codec: rfc2833 dtmf, Maximum Packetization Period: 30
Supported Codec: rfc2833 pass-thru, Maximum Packetization Period: 30
Supported Codec: inband-dtmf to rfc2833 conversion, Maximum Packetization Period: 30

Esta saída mostra a configuração dos recursos de DSP (quando quietude).

vdouut1#show dspfarm all
Dspfarm Profile Configuration

 Profile ID = 1, Service = TRANSCODING, Resource ID = 1  
 Profile Description :  
 Profile Admin State : UP 
 Profile Operation State : ACTIVE 
 Application : SCCP   Status : ASSOCIATED 
 Resource Provider : FLEX_DSPRM   Status : UP 
 Number of Resource Configured : 128 
 Number of Resource Available : 128
 Codec Configuration 
 Codec : g711ulaw, Maximum Packetization Period : 30 
Codec : g711alaw, Maximum Packetization Period : 30 
 Codec : g729ar8, Maximum Packetization Period : 60 
 Codec : g729abr8, Maximum Packetization Period : 60 
 Codec : g729r8, Maximum Packetization Period : 60 
 Codec : g729br8, Maximum Packetization Period : 60


SLOT DSP VERSION  STATUS CHNL USE   TYPE   RSC_ID BRIDGE_ID PKTS_TXED PKTS_RXED

1    1   9.2.1    UP     N/A  FREE  xcode  1      -         -         -        
1    1   9.2.1    UP     N/A  FREE  xcode  1      -         -         -        
1    1   9.2.1    UP     N/A  FREE  xcode  1      -         -         -  

Esta saída mostra o estado dos recursos de DSP (depois que um atendimento é feito).

vdouut1#show sccp connections summary 
  SCCP Application Service(s) Statistics Summary:
  Total Conferencing Sessions: 0, Connections: 0
  Total Transcoding Sessions: 1, Connections: 2
  Total MTP Sessions: 0, Connections: 0
  Total ALG-Phone Sessions: 0, Connections: 0
  Total BRI-Phone Sessions: 0, Connections: 0
  Total SCCP Sessions: 1, Connections: 2

vdouut1#show dspfarm dsp active 
SLOT DSP VERSION  STATUS CHNL USE   TYPE   RSC_ID BRIDGE_ID PKTS_TXED PKTS_RXED

1    1   9.2.1    UP     1    USED  xcode  1      15        9400      9405     
1    1   9.2.1    UP     1    USED  xcode  1      16        9400      9394     

Total number of DSPFARM DSP channel(s) 1

Esta saída mostra as sessões RTP entre os recursos de DSP (este roteador) e a entidade de controlo (CUBO). Dois pés da chamada VoIP com codecs diferentes são mostrados. Os pés ambos são estabelecidos com CUBO (1.2.61.73).

vdouut1#show voip rtp connections 
VoIP RTP active connections :
No. CallId     dstCallId  LocalRTP RmtRTP LocalIP         RemoteIP       
1   46         47         17668    2000   1.2.61.71       1.2.61.73      
2   48         47         21530    2000   1.2.61.71       1.2.61.73      
Found 2 active RTP connections

vdouut1#show call active voice compact 
 <callID>  A/O FAX T<sec> Codec     type   Peer Address  IP R<ip>:<udp>
Total call-legs: 2
        46 ORG     T150   g711ulaw  VOIP   P             1.2.61.73:2000 
        48 ORG     T150   g729r8    VOIP   P             1.2.61.73:2000

Troubleshooting

Estão aqui alguns comandos de Troubleshooting úteis para transcoding:

  • debugar mensagens do sccp

  • debugar o mtp do ephone

  • debugar o estado do ephone

Nota: Consulte Informações Importantes sobre Comandos de Depuração antes de usar comandos debug.


Informações Relacionadas


Document ID: 100480