Voz e comunicações unificadas : Cisco Unified Border Element

Elemento unificado da beira (CUBO) com exemplo de configuração do gerente das comunicações unificadas de Cisco (CUCM)

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Tradução Manual (8 Abril 2009) | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

O Cisco Unified Border Element facilita a Conectividade simples e eficaz na redução de custos entre troncos do Session Initiation Protocol (SIP) das comunicações unificadas da empresa à rede telefônica pública comutada (PSTN). Projetou encontrar a empresa e o controlador de limite de sessões que do provedor de serviços (SBC) o dispositivo precisa, o Cisco Unified Border Element (CUBO) é um aplicativo de software do½ do¿Â do Cisco IOS integradoï que seja executado sobre:

  • Cisco 2800 Series Integrated Services Routers

  • Cisco 3800 Series Integrated Services Routers

  • Plataformas de multiserviço do Cisco 2600XM Series

  • Cisco 3700 Series Routers

  • Cisco 7200VXR Router

  • Cisco 7301 Router

  • Cisco AS5400XM e gateways de acesso AS5350XM

As interconexões diretas IP entre redes de comunicações unificadas oferecem a maior flexibilidade apoiar serviços emergentes quando comparadas com as interconexões tradicionais da multiplexação de divisão de tempo da rede telefônica pública comutada (PSTN) (TDM).

O Cisco Unified Border Element fornece um ponto da interface rede a rede para:

  • Sinalizando a colaboração — H.323, SORVO

  • Media que colaboram — [DTMF], fax, modem, e transcoding multifrequency de duas tonalidades do codec

  • Endereço e traduções de porta — esconder da privacidade e da topologia

  • Faturamento e normalização do registro dos destalhes da chamada (CDR)

  • Qualidade de Serviço (QoS) e gerenciamento de largura de banda — Marcação de QoS usando o [DSCP] ou o Tipo de serviço (ToS) do Differentiated Services Code Point, aplicação da largura de banda usando o [RSVP] do protocolo de reserva de recursos e a filtração do codec

Um Cisco Unified Border Element interopera com muitos elementos de rede diferentes que incluem o Gateways de voz, os Telefones IP, e os server do controle de chamada em muitos ambientes de aplicativo diferentes, de Voz da empresa e/ou serviços de vídeo avançados com o gerente ou o Cisco Unified Communications Manager Express das comunicações unificadas de Cisco, assim como um Toll Bypass e uma Voz mais simples sobre aplicativos do transporte IP (VoIP).

O Cisco Unified Border Element fornece organizações todas as funções do controlador da beira integradas na camada de rede para interconectar arquiteturas do empresa-à-serviço-fornecedor da Voz e do vídeo das comunicações unificadas. O Cisco Unified Border Element é usado pela empresa e por pequenas e médias organizações para interconectar o acesso do SORVO PSTN com SORVO e redes de comunicações unificadas da empresa de H.323.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

A informação neste documento é baseada no Cisco Unified Border Element (CUBO).

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a Command Lookup Tool (somente clientes registrados) para obter mais informações sobre os comandos usados nesta seção.

Configurações

Esta configuração permite a funcionalidade básica do Cisco Unified Border Element em uma plataforma. Esta funcionalidade termina uma chamada VoIP entrante e re-origina-a com o uso de um voip dial peer de saída. Os atendimentos podem ser H.323 A SORVER ou SORVER PARA SORVER.

voice service voip
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
allow-connections h323 to h323

Configurar o entrante e os dial peer de saída com o protocolo relevante, tipo DTMF, e informação do codec.

dial-peer voice 1 voip
session target ipv4:10.13.8.150
incoming called-number 8...
dtmf-relay h245-alphanumeric
codec g711ulaw
!
dial-peer voice 2 voip
destination-pattern 8...
session protocol sipv2
session target ipv4:10.13.8.16
dtmf-relay rtp-nte
codec g711ulaw

SORVA a configuração de agente de usuário

Configurar o agente de usuário do SORVO (UA) para o registro e a autenticação.

SORVA o agente de usuário (o UA)
sip-ua
registrar ipv4:10.1.1.10
or
registrar dns:csps.cisco.com
authentication username xyz password xyz realm cisco.com

Interconexão com o gerente das comunicações unificadas de Cisco

O gerente das comunicações unificadas de Cisco pode ser interconectado com o Cisco Unified Border Element com o uso de H.323 ou de um tronco das comunicações unificadas do SORVO.

Tronco de H.323 ao Cisco Unified Border Element

Há dois métodos de definir um tronco de H.323 ao Cisco Unified Border Element no gerente das comunicações unificadas de Cisco:

  • Com um porteiro — Configurar um tronco H.225 (GK controlado) para o Cisco Unified Border Element

  • Sem um porteiro — Configurar o Cisco Unified Border Element como um gateway de H.323

Exigências do Media Termination Point (MTP):

  • Se o Cisco Unified Border Element faz H.323 aos atendimentos de H.323, um MTP não é imperativo enquanto a liberação do Cisco Unified Border Element é 12.4(6)T ou mais tarde e o gerente das comunicações unificadas de Cisco é versão 4.1 ou mais recente.

  • Um hardware ou um software MTP podem ser co-residente no mesmo roteador como o Cisco Unified Border Element (nas Plataformas do Roteadores que apoiam CUCM MTP, que incluem o Cisco e Series ISR).

Exigências rápidas do começo de H.323:

  • Se o Cisco Unified Border Element faz H.323 PARA SORVER a colaboração para o gerente das comunicações unificadas de Cisco, a maioria de servidores proxy server SIP exigem o atendimento do SORVO ser oferta adiantada. Isto implica o lado de H.323 deve ser H.323 começa rapidamente. Daqui, o gerente das comunicações unificadas de Cisco deve ser configurado para de entrada e H.323 de partida começa rapidamente, que igualmente exige um MTP.

Figura 1 mostra a configuração para um Cisco Unified Border Element definido como um gateway de H.323 no gerente das comunicações unificadas de Cisco.

Figura 1. A configuração do Cisco Unified Border Element como um gateway de H.323 no gerente das comunicações unificadas de Cisco

/image/gif/paws/99863/cube-config01.gif

cube-config02.gif

Figura 2 mostra a configuração do Cisco Unified Border Element para combinar a configuração de gerenciador precedente das comunicações unificadas de Cisco.

Figura 2. configuração no Cisco Unified Border Element para um tronco de H.323

cube-config03.gif

Tronco do SORVO ao Cisco Unified Border Element

A versão de gerenciador é exigida 5.x das comunicações unificadas de Cisco ou mais tarde definir um tronco do SORVO das comunicações unificadas ao Cisco Unified Border Element.

Exigências MTP:

  • Tronco do SORVO sem um MTP — Configurar um tronco do SORVO das comunicações unificadas sem MTP se media atrasados ou convide-o sem o SDP é aceitável.

  • SORVA o tronco com MTP — Configurar um tronco unificado do SORVO de uma comunicação (com MTP) se media adiantados ou o convide com SDP é uma exigência (atendimentos de G.711 somente).

Figuras 3 mostram a configuração para um Cisco Unified Border Element definido com um tronco do SORVO das comunicações unificadas ao gerente das comunicações unificadas de Cisco.

Figura 3. A configuração do Cisco Unified Border Element com um tronco do SORVO ao gerente das comunicações unificadas de Cisco

/image/gif/paws/99863/cube-config04.gif

Figura 4 mostra a configuração a configuração do Cisco Unified Border Element para combinar a configuração de gerenciador precedente das comunicações unificadas de Cisco.

Figura 4. configuração no Cisco Unified Border Element para um tronco do SORVO

/image/gif/paws/99863/cube-config05.gif

MTP co-residente com o Cisco Unified Border Element

Se um software MTP é exigido pela configuração de gerenciador das comunicações unificadas de Cisco, este pode ser configurado no mesmo roteador usado para o Cisco Unified Border Element.

Esta é a configuração no Cisco Unified Border Element para um MTP:

sccp local FastEthernet0/1

sccp ccm 15.5.34.1 identifier 1 version 4.1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 1 register MTP

!

dspfarm profile 1 mtp

codec g711ulaw

maximum sessions software 100

associate application SCCP

Transcoding no Cisco Unified Border Element

O Cisco Unified Border Element pode fazer transcoding entre o ½ do ¿  G.711ï - law/a-law e vários sabores de G.729. Transcoding pode ser invocado para todo o atendimento se origina do gerente das comunicações unificadas de Cisco para o PSTN, ou do PSTN para o gerente das comunicações unificadas de Cisco. O critério principal é se os dois trechos de chamada no Cisco Unified Border Element têm codecs diferentes - G.711 e G.729. A configuração de transcoding no Cisco Unified Border Element exige DSP estar disponíveis na plataforma.

Esta é a configuração no Cisco Unified Border Element para transcoding:

voice-card 2

dspfarm

dsp services dspfarm

sccp local FastEthernet 0/0

sccp ccm 200.1.1.100 identifier 1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 1 register MTP123456782012

keepalive retries 5

switchover method immediate

switchback method immediate

switchback interval 15

!

dspfarm profile 1 transcode

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec gsmfr

codec g729r8

maximum sessions 5

associate application SCCP

telephony-service

load 7960-7940 P00303020214

max-ephones 48

max-dn 48

ip source-address 200.1.1.100 port 2000

sdspfarm units 1

sdspfarm transcode sessions 50

sdspfarm tag 1 MTP123456782012

create cnf-files version-stamp 7960 Jul 29 2002 13:50:03

Usando Tcl IVR no Cisco Unified Border Element

O Cisco Unified Border Element apoia Scripts TCL, e você pode configurar-los sob os VoIP dial-peer. Não há nenhuma necessidade para um DSP a fim usar a funcionalidade Tcl. Há um número de aplicativos Tcl já construídos no Cisco IOS Software que pode ser usado para disposições do Cisco Unified Border Element. A funcionalidade do Authentication, Authorization, and Accounting (AAA) do Cisco IOS pode igualmente ser usada conjuntamente com o script de TCL e o Cisco Unified Border Element para fornecer a authentication e autorização dos atendimentos.

aaa new-model

!

aaa authentication login h323 group radius

aaa authorization exec h323 local group radius

aaa accounting exec h323 start-stop group radius

!

application

service debitcard tftp://15.5.27.11/app_debitcard.2.0.2.8.tcl

paramspace english index 1

paramspace english language en

paramspace english location tftp://15.5.27.11/prompts/en/

param pid-len 4

paramspace english prefix en

param uid-len 6

!

gw-accounting aaa

!

radius-server host 15.5.27.11 auth-port 1645 acct-port 1646

radius-server timeout 10

radius-server key lab

radius-server vsa send accounting

radius-server vsa send authentication

Configuração de exemplo completa

router#show run
Building configuration...
Current configuration : 1122 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname IPIPGW-1
!
boot-start-marker
boot-end-marker
!
no network-clock-participate aim 0
no network-clock-participate aim 1
no aaa new-model
ip subnet-zero
ip cef
!
! aaa new-model
!
aaa authentication login h323 group radius
aaa authorization exec h323 local group radius
aaa accounting exec h323 start-stop group radius
!
application
service debitcard tftp://15.5.27.11/app_debitcard.2.0.2.8.tcl
paramspace english index 1
paramspace english language en
paramspace english location tftp://15.5.27.11/prompts/en/
param pid-len 4
paramspace english prefix en
param uid-len 6
!
gw-accounting aaa
!
radius-server host 15.5.27.11 auth-port 1645 acct-port 1646
radius-server timeout 10
radius-server key lab
radius-server vsa send accounting
radius-server vsa send authentication
!
no ip domain lookup
no ftp-server write-enable
!
voice service voip
allow-connections h323 to sip 

!--- key command

allow-connections sip to h323 

!--- key command

allow-connections sip to sip 

!--- key command

allow-connections h323 to h323 

!--- key command

!
interface FastEthernet0/0
ip address 200.1.1.100 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 200.1.1.1
ip http server
!
control-plane
!
dial-peer voice 1 voip
application debitcard 

!--- TCL Application

session target ipv4:9.13.8.150
incoming called-number 8...
dtmf-relay h245-alphanumeric 

!--- DTMF config for h.245 alphanumeric

codec g711ulaw
!
dial-peer voice 2 voip
destination-pattern 8...
session protocol sipv2
session target ipv4:9.13.8.16
dtmf-relay rtp-nte 

!--- DTMF config for RFC2833

codec g711ulaw
!
gatekeeper
shutdown
sip-ua
registrar ipv4:200.1.1.10 or registrar dns:csps.cisco.com
authentication username xyz password xyz realm cisco.com
!
line con 0
line aux 0
line vty 0 4
login
!
end

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

Comandos para Troubleshooting

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Nota: Consulte Informações Importantes sobre Comandos de Depuração antes de usar comandos debug.

  • registrar — É importante assegurar-se de que o Cisco Unified Border Element se estabeleça registrando como neste exemplo e para executar igualmente na medida do possível a eliminação de erros durante horas do NON-pico desde que os comandos debug são verbosos.

    logging console informational
    logging buffer 200000 debug
    service sequence-number
    service timestamp debug date msec
  • mostra — Esta é saída relevante:

    show version
    show run
    show voip rtp connection (once the call is up)
    show call active voice brief (once the call is up)
  • debugar — Certifique-se cancelar o log antes que um atendimento para a eliminação de erros esteja feito, e obter a saída do comando show logging após o atendimento executou.

    H.323 às encenações de H.323

    debug h225 asn1
    debug h225 q931
    debug h225 events
    debug h245 asn1
    debug h245 events
    debug h225 q931
    debug cch323 all
    debug voip ipipgw
    debug voip ccapi inout

    H.323 PARA SORVER encenações

    debug h225 asn1
    debug h225 q931
    debug h225 events
    debug h245 asn1
    debug h245 events
    debug cch323 all
    debug voip ipipgw
    debug voip ccapi inout
    debug ccsip all

    SORVO PARA SORVER encenações

    debug ccsip all
    debug voip ccapi inout
  • debugar — Além do que os comandos debugging baseados na encenação descrita mais cedo, estes comandos debugging do transcodificador devem ser permitidos:

    debug dspfarm all
    debug sccp messages
  • debugar Nomeado-eventos da sessão do rtp do voip — Se o RFC2833 (DTMF-relé RTP-NTE) é usado, você deve igualmente girar sobre este comando debug.


Informações Relacionadas


Document ID: 99863