IP : Conversão de endereços de rede (NAT)

Função de balanceamento de carga IO NAT com roteamento de extremidade aperfeiçoado para duas conexões com o Internet

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Tradução Manual (13 Junho 2008) | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento descreve uma configuração para que um roteador do � do Cisco IOS conecte uma rede ao Internet com a tradução de endereço de rede através de duas conexões ISP. O Network Address Translation (NAT) do Cisco IOS Software pode distribuir conexões de TCP e sessões de UDP subsequentes sobre conexões de rede múltipla se as rotas de custo igual a um destino fornecido estão disponíveis. Caso uma das conexões se tornar inusável, o Rastreamento de objetos, um componente do roteamento de extremidade aperfeiçoado (OER), pode ser usado para desativar a rota até que a conexão se torne disponível outra vez, que assegura a disponibilidade da rede apesar da instabilidade ou da insegurança de uma conexão com o Internet.

/image/gif/paws/99427/ios-nat-2isp-1.gif

Pré-requisitos

Requisitos

Este documento supõe que você tem o LAN funcional e as conexões de WAN; não fornece o fundo da configuração ou do Troubleshooting para estabelecer a conectividade inicial.

  1. Este documento não descreve uma maneira de diferenciar-se entre as rotas, tão lá é nenhuma maneira de preferir uma conexão mais-desejável sobre uma conexão menos-desejável.

  2. Este documento descreve a configuração de OER para permitir ou desabilitar uma ou outra rota de Internet baseada na alcançabilidade dos servidores DNS do ISP. Você precisa de identificar os anfitriões específicos que podem ser alcançáveis com somente uma das conexões ISP e não podem estar disponíveis se essa conexão ISP não está disponível.

Componentes Utilizados

Esta configuração foi desenvolvida com um Cisco 1811 Router com software avançado 12.4(15)T dos Serviços IP. Se uma versão de software diferente é usada, algumas características não estão potencialmente disponíveis, ou os comandos configuration podem diferir daqueles mostrados neste documento. A configuração similar está disponível em todas as plataformas de roteador do Cisco IOS embora a configuração da interface varie provavelmente entre Plataformas diferentes.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Você precisa potencialmente de adicionar o roteamento baseado em política para que o tráfego específico assegure-se de que use sempre uma conexão ISP. Os exemplos do tráfego que exigem este comportamento incluem os clientes do IPSec VPN, os monofones de VoIP, e o todo o outro tráfego que usarem somente uma das opções de conexão ISP para preferir o mesmo endereço IP de Um ou Mais Servidores Cisco ICM NT, uma velocidade mais alta, ou para abaixar a latência na conexão.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/99427/ios-nat-2isp-2.gif

Configurações

Este exemplo de configuração, como ilustrado no diagrama da rede, descreve um roteador de acesso que use uma conexão IP DHCP-configurada a um ISP (como mostrado pelos FastEthernet 0), e uma conexão PPPoE sobre a outra conexão ISP. Os tipos de conexão não têm nenhum impacto particular na configuração a menos que o Rastreamento de objetos e OER e/ou o roteamento baseado em política deverem ser usada com uma conexão com o Internet DHCP-atribuída. Nesses casos, pode ser muito difícil definir um roteador de próximo salto para o roteamento de política ou o OER.

Exemplo da configuração de roteador
track timer interface 5
!
! Configure timers on route tracking
!
track 123 rtr 1 reachability
 delay down 15 up 10
!
track 345 rtr 2 reachability
 delay down 15 up 10
!
! Use “ip dhcp client route track [number]” 
   ! to monitor route on DHCP interfaces
! Define ISP-facing interfaces with “ip nat outside”
!
interface FastEthernet0
 ip address dhcp
 ip dhcp client route track 345
 ip nat outside
 ip virtual-reassembly
!
interface FastEthernet1
 no ip address
 pppoe enable
 no cdp enable
!
interface FastEthernet2
 no cdp enable
!
interface FastEthernet3
 no cdp enable
!
interface FastEthernet4
 no cdp enable
!
interface FastEthernet5
 no cdp enable
!
interface FastEthernet6
 no cdp enable
!
interface FastEthernet7
 no cdp enable
!
interface FastEthernet8
 no cdp enable
!
interface FastEthernet9
 no cdp enable
!
! Define LAN-facing interfaces with “ip nat inside”
!
interface Vlan1
 description LAN Interface
 ip address 192.168.108.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1452
!
! Define ISP-facing interfaces with “ip nat outside”
!
Interface Dialer 0
 description PPPoX dialer
 ip address negotiated
 ip nat outside
 ip virtual-reassembly
 ip tcp adjust-mss
!
ip route 0.0.0.0 0.0.0.0 dialer 0 track 123
!
! Configure NAT overload (PAT) to use route-maps
!
ip nat inside source route-map fixed-nat
   interface Dialer0 overload
ip nat inside source route-map dhcp-nat 
   interface FastEthernet0 overload
!
! Configure an OER tracking entry 
   ! to monitor the first ISP connection
!
ip sla 1
 icmp-echo 172.16.108.1 source-interface Dialer0
 timeout 1000
 threshold 40
 frequency 3
!
! Configure a second OER tracking entry 
   ! to monitor the second ISP connection
!
ip sla 2
 icmp-echo 172.16.106.1 source-interface FastEthernet0
 timeout 1000
 threshold 40
 frequency 3
!
! Set the SLA schedule and duration
!
ip sla schedule 1 life forever start-time now
ip sla schedule 2 life forever start-time now
!
! Define ACLs for traffic that 
   ! will be NATed to the ISP connections
!
access-list 110 permit ip 192.168.108.0 0.0.0.255 any
!
! Route-maps associate NAT ACLs with NAT 
   ! outside on the ISP-facing interfaces
!
route-map fixed-nat permit 10
 match ip address 110
 match interface Dialer0
!
route-map dhcp-nat permit 10
 match ip address 110
 match interface FastEthernet0 

Com seguimento DHCP-atribuído da rota:

Exemplo de configuração de seguimento DHCP-atribuído da rota (opcional)
interface FastEthernet0
 description Internet Intf
 ip dhcp client route track 123
 ip address dhcp
 ip nat outside
 ip virtual-reassembly
 speed 100
 full-duplex
 no cdp enable

Verificar

Use esta seção para confirmar se a sua configuração funciona corretamente.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

  • mostre a IP a tradução nat — Atividade dos indicadores NAT entre host internos NAT e host exteriores NAT. Este comando fornece a verificação que os host internos estão traduzidos a ambos os endereços exteriores NAT.

    Router# sh ip nat tra
    Pro Inside global      Inside local       Outside local      Outside global
    tcp 172.16.108.44:54486 192.168.108.3:54486 172.16.104.10:22 172.16.104.10:22
    tcp 172.16.106.42:49620 192.168.108.3:49620 172.16.102.11:80 172.16.102.11:80
    tcp 172.16.108.44:1623 192.168.108.4:1623 172.16.102.11:445  172.16.102.11:445
    Router#
    
  • mostre a rota IP — Verifica que as rotas múltiplas ao Internet estão disponíveis.

    Router# sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, 
           L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, 
           U - per-user static route
           o - ODR, P - periodic downloaded static route
    
    Gateway of last resort is 172.16.108.1 to network 0.0.0.0
    
    C    192.168.108.0/24 is directly connected, Vlan1
         172.16.0.0/24 is subnetted, 2 subnets
    C       172.16.108.0 is directly connected, 
            FastEthernet4
    C       172.16.106.0 is directly connected, Vlan106
    S*   0.0.0.0/0 [1/0] via 172.16.108.1
                   [1/0] via 172.16.106.1
    Router#
    

Troubleshooting

Depois que você configura o roteador do Cisco IOS com NAT, se as conexões não trabalham, seja certo destes:

  • O NAT é aplicado apropriadamente na parte externa e nas interfaces internas.

  • A configuração de NAT está completa, e os ACL refletem o tráfego que deve ser NATed.

  • As rotas múltiplas ao Internet/WAN estão disponíveis.

  • Se você usa a rota que segue para ter certeza que as conexões com o Internet estão disponíveis, verifique o estado do seguimento da rota.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 99427