Switches : Switches Cisco Catalyst 3750 Series

Roteamento de stub PIM no catalizador 3750, e 3560 Series Switch

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Tradução Manual (17 Julho 2008) | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

O tráfego plano do controle de transmissão múltipla é considerado sempre por cada roteador em um ambiente de LAN. O Protocolo IP multicast do stub é usado para reduzir e minimizar o tráfego multicast desnecessário que é considerado no LAN na camada de acesso e para salvar a largura de banda nos media para enviar o tráfego multicast à distribuição/camada central ascendentes.

No Switches do Catalyst 3750 e 3560 Series, no roteamento de transmissão múltipla dos suportes de recurso do Multicast do stub PIM entre a camada de distribuição e na camada de acesso. Apoia dois tipos de relações PIM: relações do uplink PIM e interfaces passivas PIM. Em particular, uma interface roteada configurada com o modo passivo PIM não passa/tráfego plano dianteira do controle PIM; passa somente/para a frente tráfego IGMP.

Pré-requisitos

Requisitos

Certifique-se de atender a estes requisitos antes de tentar esta configuração:

  • O roteador de stub PIM não distribui o tráfego de trânsito entre roteadores de distribuição. Este comportamento é reforçado pelo roteamento de stub do unicast (EIGRP). A configuração apropriada do roteamento de stub do unicast é exigida para ajudar a este comportamento do roteador de stub PIM. A característica do stub PIM não impede o administrador de roteador que configura o RASGO, as rotas estáticas, ou o PIM RP para contornear esta limitação.

  • Somente os receptores direto-conectados e as fontes do Multicast (IGMP) são permitidos nos domínios do acesso da camada 2. O protocolo PIM não é apoiado em domínios do acesso.

  • A topologia redundante do roteador de stub PIM não é apoiada.

Componentes Utilizados

A informação neste documento é baseada na saída do Catalyst 3750 Switch.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Produtos Relacionados

Esta configuração pode igualmente ser usada com estes tipos de switch:

  • Switches do Catalyst 3750 e 3560 Series

Versão de código 12.2(37)SE do roteamento de transmissão múltipla stub do apoio PIM dos Cisco Catalyst 3750 e 3560 Switch e mais tarde.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

O PIM SS é usado nos uplinks para comunicar-se com o roteador fluxo acima. Os usuários podem usar todo o outro modo de PIM (por exemplo, denso ou escasso).

Para obter informações adicionais sobre da configuração do roteamento de transmissão múltipla nos 3750 Series Switch, refira configurar o roteamento IP Multicast.

Nota: Use a Command Lookup Tool (somente clientes registrados) para obter mais informações sobre os comandos usados nesta seção.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/98289/pim_stub-1.gif

Configurações

Este documento utiliza as seguintes configurações:

Termine estas etapas para configurar o roteamento de stub PIM:

  1. Emita este comando permitir globalmente o roteamento de transmissão múltipla no interruptor ou na pilha do interruptor:

    mix_stack(config)#ip multicast-routing distributed
    
  2. Emita este comando definir a escala SS do endereço IP Multicast com escala do grupo padrão:

    mix_stack(config)#ip pim ssm default
    
  3. Emita este comando permitir PIM SS no uplink:

    mix_stack(config)#interface GigabitEthernet3/0/25
    
    
    !--- By default switch configures the Layer 2 parameters.
    So in order to configure the Layer 3 parameter, use the next command.
    
    mix_stack(config-if)#no switchport
    
    mix_stack(config-if)#ip pim sparse-dense-mode
    
  4. Emita este comando permitir o roteamento de stub PIM na interface de VLAN:

    mix_stack(config)#interface vlan100
    mix_stack(config-if)#ip pim passive
    

Comute a configuração (do mix_stack)

mix_stack#show run
Building configuration...
 
Current configuration : 7810 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname mix_stack
!
!
switch 2 provision ws-c3750e-24pd
switch 3 provision ws-c3750g-24ts
switch 5 provision ws-c3750-24fs
switch 9 provision ws-c3750e-24pd
!
ip routing
!
!
ip multicast-routing distributed
!
!--- Output suppressed.
!
!
vlan 100
!
!
interface GigabitEthernet2/0/1
switchport access vlan 100
no keepalive
spanning-tree portfast
!
interface GigabitEthernet2/0/2
switchport access vlan 100
no keepalive
spanning-tree portfast
!
!
!--- Output suppressed.
!
!
interface GigabitEthernet3/0/25
no switchport
ip address 3.1.1.2 255.255.255.248
ip pim sparse-dense-mode
!
!
!--- Output suppressed.
!
!
interface GigabitEthernet9/0/24
no switchport
ip address 10.1.1.1 255.255.255.0
ip pim passive
no keepalive
!
!
!--- Output suppressed.
!
!
interface Vlan1
no ip address
!
interface Vlan100
ip address 100.1.1.1 255.255.255.0
ip pim passive
!
!
!--- Output suppressed.
!
! 
ip pim ssm default
!
!
!--- Output suppressed.
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
speed 115200
line vty 0 4
login
line vty 5 15
login
!
end

Verificar

Use esta seção para confirmar se a sua configuração funciona corretamente.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Emita o comando show ip pim interface a fim indicar o stub PIM que é permite para cada relação.

mix_stack#show ip pim interface 

Address    Interface               Ver/    Nbr     Query   DR     DR
                                   Mode    Count   Intvl   Prior

3.1.1.2    GigabitEthernet3/0/25   v2/SD   1       30      1      3.1.1.2
100.1.1.1  Vlan100                 v2/P    0       30      1      100.1.1.1
10.1.1.1   GigabitEthernet9/0/24   v2/P    0       30      1      10.1.1.1

Emita o detalhe dos grupos de IGMP da mostra IP para indicar o cliente interessado que se juntou ao origem de transmissão múltipla/grupo específicos.

mix_stack#show ip igmp groups 232.0.0.9 det

Flags: L - Local, U - User, SG - Static Group, VG - Virtual Group,
SS - Static Source, VS - Virtual Source,
Ac - Group accounted towards access control limit

Interface: GigabitEthernet9/0/24
Group: 232.0.0.9
Flags: SSM 
Uptime: 00:00:10
Group mode: INCLUDE
Last reporter: 10.1.1.2
CSR Grp Exp: 00:02:57
Group source list: (C - Cisco Src Report, U - URD, R - Remote, S - Static,
V - Virtual, M - SSM Mapping, L - Local,
Ac - Channel accounted towards access control limit)
Source Address Uptime v3 Exp CSR Exp Fwd Flags
200.1.1.3 00:00:10 stopped 00:02:57 Yes CM

Interface: Vlan100
Group: 232.0.0.9
Flags: SSM 
Uptime: 01:42:08
Group mode: INCLUDE
Last reporter: 100.1.1.3
CSR Grp Exp: 00:02:00
Group source list: (C - Cisco Src Report, U - URD, R - Remote, S - Static,
V - Virtual, M - SSM Mapping, L - Local,
Ac - Channel accounted towards access control limit)
Source Address Uptime v3 Exp CSR Exp Fwd Flags
200.1.1.3 01:42:12 stopped 00:02:00 Yes CM
mix_stack#

Emita o mrouter da mostra IP para verificar que o fluxo de transmissão múltipla para a frente da fonte aos clientes interessados.

mix_stack#show ip mroute 232.0.0.9
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report, 
Z - Multicast Tunnel, z - MDT-data group sender, 
Y - Joined MDT-data group, y - Sending to MDT-data group
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(200.1.1.3, 232.0.0.9), 01:44:23/00:02:52, flags: sTI
Incoming interface: GigabitEthernet3/0/25, RPF nbr 3.1.1.1
Outgoing interface list:
GigabitEthernet9/0/24, Forward/Sparse-Dense, 00:02:24/00:02:50
Vlan100, Forward/Sparse-Dense, 01:44:23/00:02:52

Informações Relacionadas


Document ID: 98289