Voz e comunicações unificadas : Cisco Unified Communications Manager (CallManager)

Gerente das comunicações unificadas: kCtiIncompatibleProtocolVersion - Erro incompatível da versão do protocolo no log de eventos

15 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento discute o kCtiIncompatibleProtocolVersion - Mensagem de Erro incompatível da versão do protocolo que é indicado no log de eventos após uma elevação do gerente das comunicações unificadas de Cisco.

Este Mensagem de Erro indica que alguns aplicativos que têm uma interface de programação de aplicativo de telefonia e o Java Telephony Application Programming Interface (TAPI/JTAPI) no uso ainda executam uma versão antiquada que não seja compatível com a versão incluída na nova versão do CallManager.

Pré-requisitos

Requisitos

Os leitores deste documento devem ter um conhecimento geral do gerente das comunicações unificadas de Cisco.

Componentes Utilizados

A informação neste documento é baseada no gerente 4.1 das comunicações unificadas de Cisco.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Problema

Depois que uma elevação do gerente das comunicações unificadas de Cisco, este Mensagem de Erro é indicada no log de eventos.

Event Type:	Error
Event Source:	Cisco CTIManager
Event Category:	None
Event ID:	3
Date:		6/28/2005
Time:		11:24:54 AM
User:		N/A
Computer:	CBHP-SUB1
Description:
Error: kCtiIncompatibleProtocolVersion - Incompatible protocol version.
 Message Version: 0
 Minimum Version: 60000
 Current Version: 60000
 CallManager Version: 
 IPAddress: 172.28.2.179
 App ID: Cisco CTIManager
 Cluster ID: CBHA-PUB1-Cluster
 Node ID: 10.27.1.6
 Process ID: 852
 Process Name: CtiHandler
Explanation: The JTAPI/TAPI application version is not compatible 
with this version of CTIManager, so received message has 

been rejected. 
Recommended Action: Verify correct version of application 
are being used; otherwise,contact TAC.. 

Este problema elevara quando o gerente das comunicações unificadas de Cisco é promovido, mas não os clientes TAPI/JTAPI.

Você deve promover o software do cliente TAPI/JTAPI em todo o server de aplicativo ou estação de trabalho cliente em que os aplicativos TAPI/JTAPI forem instalados. Se você não promove o cliente TAPI/JTAPI, seu aplicativo não inicializa.

Solução

No Mensagem de Erro do log de eventos, o TAPI ou o cliente de JTAPI instalado no dispositivo com o endereço IP de Um ou Mais Servidores Cisco ICM NT de 172.28.2.179 não foram promovidos a uma versão compatível.

Você precisa de investigar o dispositivo para encontrar que que aplicativo neste endereço usa o TAPI/JTAPI e atualize o pacote correspondente da administração do CallManager > dos aplicativos > instalam encaixes como esta seção mostra. Neste exemplo, o dispositivo é esse com o endereço IP de Um ou Mais Servidores Cisco ICM NT de 172.28.2.179.

Nota: Alguns dos aplicativos que usam relações JTAPI/TAPI são assistência pessoal, console de atendimento, IPCC expresso, TAPS, e mobilidade de extensão.

ccm-kctiIncompatible-error-1.gif

Se você precisa de promover a versão de JTAPI, JTAPI seleto de Cisco, como mostras deste exemplo:

ccm-kctiIncompatible-error-2.gif

Se você precisa de promover o provedor de serviços de telefonia, provedor de serviços de telefonia seleto de Cisco, como mostras deste exemplo:

ccm-kctiIncompatible-error-3.gif


Informações Relacionadas


Document ID: 91885