Switches : Switches Cisco Catalyst 3750 Series

Exemplos da configuração de QoS do Cisco Catalyst 3750

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Os Cisco Catalyst 3750 Switches oferecem suporte a vários recursos de QoS como classificação, marcação, policiamento, enfileiramento e agendamento. Este documento explica esses recursos de QoS com exemplos de configuração.

Pré-requisitos

Requisitos

A Cisco recomenda que você tenha conhecimento sobre Configuração de QoS.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Cisco Catalyst 3750 Switch - WS-C3750-24TS

  • Software Release 12.2(35)SE2 do ½ do ¿  de Cisco IOSïÂ

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Visão geral de QoS

Com QoS, você pode oferecer tratamento preferencial a determinados tipos de tráfego em detrimento de outros. Você pode diferenciar o tráfego usando rótulos de QoS. Os dois rótulos QoS mais comumente utilizados no cabeçalho IP da Camada 3 são o campo de precedência de IP e o DSCP. O rótulo de QoS no cabeçalho de quadros da Camada 2 é chamado Classe de Serviço (COS). As ferramentas de QoS do Catalyst Switch podem oferecer tratamento preferencial baseado em rótulos de QoS da Camada 3 ou rótulos de QoS da Camada 2. Este documento fornece vários exemplos que podem lhe dar uma ideia sobre o uso de rótulos de QoS da Camada 2 e da Camada 3 em Cisco Catalyst Switches.

/image/gif/paws/91862/cat3750-qos-config1.gif

Cisco Catalyst 3750 Switch sem QoS

A QoS está desativada por padrão em Catalyst 3750 Switches. Quando a QoS estiver desativada, todos os quadros/pacotes serão transmitidos através do switch inalterados. Por exemplo, se um quadro com CoS 5 e um pacote dentro do quadro com DSCP EF entrar no switch, a CoS e os rótulos de DSCP não serão alterados. O tráfego sairá com os mesmos valores de CoS e DSCP que entraram. Todo o tráfego, incluindo voz, é entregue com base no melhor esforço.

Switch#show mls qos
QoS is disabled
QoS ip packet dscp rewrite is enabled

!--- Even though it says QoS ip packet dscp rewrite is enabled,
!--- the switch does not alter the DSCP label on the packets when 
!--- the QoS is disabled.

Recursos de QoS do Cisco Catalyst 3750 Switch

Depois que a QoS for habilitada no 3750 Switch, alguns recursos de QoS de entrada e saída serão habilitados por padrão. Este diagrama mostra uma exibição de alto nível da arquitetura de QoS do switch:

/image/gif/paws/91862/cat3750-qos-config2.gif

Este é um resumo dos pontos baseados no diagrama:

  • Os recursos de QoS de entrada como classificação, marcação e policiamento podem ser configurados com base em portas.

  • As tabelas de mapeamento de entrada e o enfileiramento de ingresso podem ser configurados globalmente. Elas não podem ser configuradas com base em portas.

  • O SRR para fila de ingresso pode ser configurado globalmente.

  • A largura de banda do anel da pilha depende do cabeamento da pilha. Se a pilha for conectada com largura de banda total, você obterá uma largura de banda de 32 Gbps. Essa largura de banda será compartilhada por todos os switches na pilha.

  • As tabelas de mapeamento e as files de saída são configuradas globalmente. Você pode ter dois conjuntos de configurações de fila e aplicar qualquer uma das configurações do conjunto de filas a uma porta.

  • O SRR para fila da saída pode ser configurado com base em portas.

Recursos de QoS de entrada

Esta seção explica os conceitos de várias configurações de QoS de entrada possíveis. Esta seção aborda estes tópicos:

Configuração de QoS de entrada padrão

Isso demonstra como o switch trata quadros por padrão após a habilitação de QoS:

  • Um quadro entra na porta do switch e não está rotulado (isso significa que a porta é uma porta de acesso e o quadro que entra no switch não possui encapsulamento ISL ou dot1q).

  • O switch encapsula o quadro com dot1q (ignora ISL porque dot1q é o padrão em todos os novos switches).

  • Dentro da marca do quadro dot1q, há três bits disponíveis chamados bits de prioridade 802.1p ou CoS. Esses bits são definidos como 0.

  • Em seguida, o switch calcula o valor de DSCP com base na tabela de mapeamento CoS-DSCP. Conforme a tabela, o switch define o valor de DSCP como 0. O valor de DSCP está localizado no cabeçalho IP do pacote.

Em resumo, os valores de CoS e DSCP do quadro que entra no switch serão definidos como 0 por padrão se QoS estiver habilitada no switch.

Classificação e marcação

Diferentemente dos roteadores, a classificação e a marcação de QoS agem de formas diferentes em Cisco Catalyst Switches. Nos roteadores Cisco, você pode classificar os pacotes usando MQC com base no valor de DSCP do pacote recebido ou na lista de controle de acesso (ACL). Isso depende de você confiar no rótulo de QoS do pacote recebido ou não. No Cisco Catalyst 3750 Switch, você pode classificar os quadros com base em valores de CoS/DSCP recebidos ou na ACL.

A configuração baseada no valor de CoS/DSCP recebido é obtida de três maneiras diferentes:

Você pode utilizar qualquer um desses três métodos. Você não pode utilizar mais de um método em uma porta. Por exemplo, você configurou o comando mls qos trust cos em uma porta. Quando você configura a porta com o comando service-policy input <nome-mapa-políticas>, ele remove o comando mls qos trust cos automaticamente.

A seção Classificação e Marcação - Baseadas em Portas explica a configuração baseada em portas.

A seção Classificação e Marcação - Baseadas em MQC explica a classificação baseada em MQC.

Classificação e Marcação - Baseadas em Portas

Esta seção explica a classificação baseada na configuração específica da interface. Uma pergunta pode surgir com o título da seção classificação e marcação. Isso ocorre porque no Cisco Catalyst 3750 Switch, os valores de CoS ou DSCP dos quadros (pacote dentro do quadro) são remarcados usando as tabelas de mapeamento. As tabelas de mapeamento não estão disponíveis nos roteadores Cisco. Elas estão disponíveis somente nos Cisco Catalyst Switches. A funcionalidade dessas tabelas será descrita ao longo desta seção.

Esta seção aborda estas duas configurações:

/image/gif/paws/91862/cat3750-qos-config3.gif

Classificação - Configuração de Confiança da Porta

Um pacote recebido ou um quadro podem já ter um rótulo de QoS atribuído. Estas perguntas podem surgir:

  • Você confia no rótulo de QoS do pacote/quadro recebido em uma porta?

  • Se um telefone IP e um PC estão conectados a uma porta, você confia nos rótulos de QoS do telefone, PC ou ambos?

Se você não confia nos rótulos de QoS do pacote/quadro recebido, você precisa classificar o pacote com base em um rótulo de QoS de marca e lista de acesso. Se você confia nos rótulos de QoS do pacote/quadro recebido, outra pergunta será: você precisa confiar no valor de CoS ou DSCP do pacote/quadro recebido em uma porta? Isso depende do cenário. Você pode consultar os diferentes cenários com exemplos nesta seção.

As opções de configuração de confiança da porta são:

Switch(config-if)#mls qos trust ?
  cos            cos keyword
  device         trusted device class
  dscp           dscp keyword
  ip-precedence  ip-precedence keyword
  <cr>
  • Exemplo 1: Se a porta é uma porta de acesso ou porta da Camada 3, você precisa configurar o comando mls qos trust dscp. Você não pode utilizar o comando mls qos trust cos porque o quadro da porta de acesso ou porta da Camada 3 não contém a marca dot1q ou ISL. Os bits de CoS estão presentes somente no quadro dot1q ou ISL.

    interface GigabitEthernet1/0/1
     description **** Layer 3 Port ****
     no switchport
     ip address 192.168.10.1 255.255.255.0
     mls qos trust dscp
    end
    interface GigabitEthernet1/0/2
     description **** Access Port ****
     switchport access vlan 10
     switchport mode access
     mls qos trust dscp
    end
  • Exemplo 2: Se a porta for uma porta de tronco, você poderá configurar os comandos mls qos trust cos ou mls qos trust dscp. A tabela de mapeamento dscp-cos será utilizada para calcular o valor de CoS se a porta estiver configurada para confiar em DSCP. De forma semelhante, a tabela de mapeamento cos-dscp será utilizada para calcular o valor de DSCP se a porta estiver configurada para confiar em CoS.

    interface GigabitEthernet1/0/3
    description **** Trunk Port ****
    switchport trunk encapsulation dot1q
    switchport mode trunk
    switchport trunk native vlan 5
    switchport trunk allowed vlan 5,10,20,30,40,50
    mls qos trust cos
    end
    interface GigabitEthernet1/0/12
     description **** Cisco IP Phone  ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 20
     mls qos trust cos
     spanning-tree portfast
    end
    
    !--- The Cisco IP Phone uses IEEE 802.1Q frames for Voice 
    !--- VLAN traffic.
    
    
  • Exemplo 3: Se a porta for uma porta de tronco dot1q e ela estiver configurada com o comando mls qos trust cos, os quadros da VLAN nativa terão os valores de CoS e DSCP definidos como 0. Como os quadros da VLAN nativa não estão marcados e o quadro será marcado após entrar no switch, o switch definirá o valor de CoS padrão como 0 e a tabela CoS-DSCP definirá o valor de DSCP como 0.

    Nota: O valor de DSCP do pacote oriundo da VLAN nativa será redefinido como 0.

    Você também pode configurar a porta de switch para alterar o valor de CoS padrão de quadros sem marcas de 0 para quaisquer outros valores entre 0 e 7 usando o comando mls qos cos<0-7>. Este comando não altera os valores de CoS dos quadros marcados.

    Por exemplo, a porta GigabitEthernet1/0/12 é configurada com acesso VLAN10 e VLAN20 de voz.

    interface GigabitEthernet1/0/12
     description **** Cisco IP Phone  ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 20
     mls qos trust cos
     spanning-tree portfast
    
    !--- The Cisco IP Phone uses IEEE 802.1Q frames for Voice 
    !--- VLAN traffic. Voice VLAN is only supported on access ports and not  
    !--- on trunk ports, even though the configuration is allowed.
    
    end

    Por padrão, o PC envia os dados sem marcas. O tráfego sem marca do dispositivo conectado ao Cisco IP Phone passa através do telefone inalterado, independentemente do estado de confiança da porta de acesso no telefone. O telefone envia quadros dot1q marcados com ID de VLAN 20 de voz. Portanto, se você configura a porta com o comando mls qos trust cos, ela confia nos valores de CoS dos quadros do telefone (quadros marcados) e define o valor de CoS dos quadros (sem marcas) do PC como 0. Em seguida, a tabela de mapeamento CoS-DSCP define o valor de DSCP do pacote dentro do quadro como 0, pois a tabela de mapeamento CoS-DSCP possui o valor de DSCP 0 para o valor de CoS 0. Se os pacotes do PC tiverem algum valor de DSCP específico, esse valor será redefinido como 0. Se você configurar o comando mls qos cos 3 na porta, ele definirá o valor de CoS de todos os quadros do PC como 3 e não alterará o valor de CoS dos quadros do telefone.

    interface GigabitEthernet1/0/12
     description **** Cisco IP Phone  ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 20
     mls qos trust cos
     mls qos cos 3
     spanning-tree portfast
    end

    Se você configurar a porta com o comando mls qos cos 3 override, ele definirá os valores de CoS de todos os quadros (marcados ou não) como 3. Ele substituirá os valores previamente configurados.

    interface GigabitEthernet1/0/12
     description **** Cisco IP Phone  ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 20
     mls qos trust cos
     mls qos cos 3 override
    
    !--- Overrides the mls qos trust cos.
    
    
    !--- Applies CoS value 3 on all the incoming packets on both 
    !--- the vlan 10 and 20.
    
     spanning-tree portfast
    end
  • Exemplo 4: Por exemplo, veja a configuração da porta gi 1/0/12:

    interface GigabitEthernet1/0/12
     description **** Cisco IP Phone  ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 20
     mls qos trust cos
     spanning-tree portfast
    end

    Se o PC marcar seu quadro com VLAN20, ele também definirá o valor de CoS como 5. O switch processa o tráfego de dados marcado (tráfego nos tipos de quadro IEEE 802.1Q ou IEEE 802.1p ) do dispositivo) conectado à porta de acesso no Cisco IP Phone. Como a interface é configurada para confiar no valor de CoS, todo o tráfego recebido através da porta de acesso no Cisco IP Phone passa através do telefone inalterado. O switch também confia e permite tráfego do PC, e atribui a mesma prioridade que o tráfego do telefone IP. Esse não é um resultado desejável. Isso pode ser evitado usando o comando switchport priority extend cos <valor-cos>.

    interface GigabitEthernet1/0/12
     description **** Cisco IP Phone  ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 20
     mls qos trust cos
     switchport priority extend cos 0
    
    !--- Overrides the CoS value of PC traffic to 0.
    
     spanning-tree portfast
    end

    O comando switchport priority extend cos <cos-value> configura o telefone de forma que o telefone IP altere o valor de CoS do tráfego do PC para 0.

  • Exemplo 5: Por exemplo, na mesma interface, alguém conecta o PC diretamente ao switch e marca os dados do PC com quadro dot1q com um valor de CoS mais alto. Isso pode ser evitado usando o comando mls qos trust device cisco-phone.

    interface GigabitEthernet1/0/12
     description **** Cisco IP Phone  ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 20
     mls qos trust cos
     switchport priority extend cos 0
     mls qos trust device cisco-phone 
    
    !--- Specify that the Cisco IP Phone is a trusted device.
    
     spanning-tree portfast
    end
  • Exemplo 6: Por exemplo, na interface GigabitEthernet1/0/12, você deve confiar nos rótulos de QoS do PC. Além disso, o PC é conectado à VLAN nativa 10. Nesse caso, o comando mls qos trust cos não ajuda porque o pacote do PC não marca o valor de CoS. Ele marcará somente o valor de DSCP. Portanto, o switch adiciona o quadro dot1q e configura o valor de CoS padrão como 0. Em seguida, a tabela CoS-DSCP calculará e redefinirá o valor de DSCP como 0.

    Para corrigir esse problema, há duas opções. Uma é configurar a classificação e marcação com MQC. Você pode criar uma ACL que corresponda ao tráfego do seu PC com base na origem, endereços IP de destino e origem/números de porta de destino. Em seguida, você pode corresponder essa ACL no mapa de classes. É possível criar um mapa de políticas para confiar nesse tráfego. Essa solução é abordada na próxima seção. Esta seção aborda o segundo método. O segundo método é confiar no rótulo de DSCP em vez do rótulo de CoS. Em seguida, o rótulo de DSCP-CoS calcula e define o valor de CoS que corresponde ao valor de DSCP.

    interface GigabitEthernet1/0/12
     description **** Cisco IP Phone  ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 20
     mls qos trust dscp
     spanning-tree portfast
    end

    O primeiro método é o mais indicado, pois não é recomendável confiar em todos os rótulos de QoS do tráfego do PC.

Marcação - QoS Configuração de Tabelas de Mapeamento

Após a habilitação de QoS, as tabelas de mapeamento são criadas com os valores padrão e são ativadas.

Distribution1#show mls qos maps cos-dscp
   Cos-dscp map:
        cos:   0  1  2  3  4  5  6  7
     --------------------------------
       dscp:   0  8 16 24 32 40 48 56

Distribution1#show mls qos maps dscp-cos
   Dscp-cos map:
     d1 :  d2 0  1  2  3  4  5  6  7  8  9
     ---------------------------------------
      0 :    00 00 00 00 00 00 00 00 01 01
      1 :    01 01 01 01 01 01 02 02 02 02
      2 :    02 02 02 02 03 03 03 03 03 03
      3 :    03 03 04 04 04 04 04 04 04 04
      4 :    05 05 05 05 05 05 05 05 06 06
      5 :    06 06 06 06 06 06 07 07 07 07
      6 :    07 07 07 07
  • Exemplo 1: Se a porta estiver configurada para confiar em CoS, todos os valores de CoS de entrada serão de confiança e os valores de DSCP serão remarcados com base na tabela CoS-DSCP. Conforme a configuração CoS-DSCP padrão, os valores são mapeados como:

    CoS DSCP (DECIMAL) DSCP
    0 0 Padrão
    1 8 CS1
    2 16 CS2
    3 24 CS3
    4 32 CS4
    5 40 CS5
    6 48 CS6
    7 56 CS7

    Um valor importante que você precisa observar aqui é o valor de DSCP correspondente ao valor de CoS 5. Ele é CS5. O exemplo 2 aborda esse valor.

  • Exemplo 2: Por exemplo, a interface GigabitEthernet1/0/12 é configurada para confiar em CoS.

    interface GigabitEthernet1/0/12
     description **** Cisco IP Phone  ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 20
     mls qos trust cos
     spanning-tree portfast
    end

    O Cisco IP Phone marca o payload de voz com CoS 5 e DSCP EF quando ele envia o tráfego para o switch. Quando o tráfego entra na porta Gi 1/0/12, o switch confia no valor de CoS. Em seguida, o switch deriva o valor de DSCP CS5 (40) para o valor de CoS 5 da tabela CoS-DSCP. Todos os payloads de voz com CoS 5 são marcados com o valor de DSCP CS5. Esse não é o valor desejável. O valor de DSCP necessário para o payload de voz é DSCP EF. Por padrão, os outros valores de CoS para valores de DSCP são mapeados corretamente conforme os RFCs.

    Essa configuração o ajuda a definir a tabela de mapeamento CoS-DSCP para alterar o valor de DSCP EF que corresponde a CoS 5.

    Distribution1(config)# mls qos map cos-dscp 0  8 16 
    24 32 46 48 56
    
    !--- DSCP 46 is EF
    
    

    Após essa configuração, os valores são mapeados como:

    CoS DSCP (DECIMAL) DSCP
    0 0 Padrão
    1 8 CS1
    2 16 CS2
    3 24 CS3
    4 32 CS4
    5 46 EF
    6 48 CS6
    7 56 CS7

  • Exemplo 3: Se a porta for configurada para confiar em DSCP, todos os valores de DSCP recebidos serão de confiança e os valores de CoS serão remarcados com base na tabela DSCP-CoS. Conforme a configuração DSCP-CoS padrão, os valores serão mapeados como:

    DSCP DSCP (DECIMAL) CoS
    Padrão 0-7 0
    CS1 AF11 AF12 AF13 8-15 1
    CS2 AF21 AF22 AF23 16-23 2
    CS3 AF31 AF32 AF33 24-31 3
    CS4 AF41 AF42 AF43 32-39 4
    CS5 EF 40-47 5
    CS6 48-55 6
    CS7 56-63 7

    Você não precisa alterar esses valores padrão.

Esta tabela resume os valores de DSCP e valores de CoS apenas para referência:

DSCP (DECIMAL) DSCP CoS
0 Padrão 0
     
8 CS1 1
10 AF11 1
12 AF12 1
14 AF13 1
     
16 CS2 2
18 AF21 2
20 AF22 2
22 AF23 2
     
24 CS3 3
26 AF31 3
28 AF32 3
30 AF33 3
     
32 CS4 4
34 AF41 4
36 AF42 4
38 AF43 4
     
40 CS5 5
42   5
44   5
46 EF 5
     
48 CS6 6
     
56 CS7 7

Nota: Em uma rede, todos os Cisco Catalyst Switches devem ter tabelas de mapeamento idênticas. Os diversos valores da tabela de mapeamento em switches diferentes causam um comportamento indesejável de QoS.

Classificação e Marcação - Baseadas em MQC

Como explicado na seção da Classificação e Marcação, você pode utilizar a MQC para classificar e marcar o pacote. É possível utilizar a MQC em vez da configuração específica da porta. Você também pode marcar os pacotes recebidos com o mapa de políticas.

Os requisitos deste exemplo são:

  • Confie nos valores de CoS do tráfego do telefone IP.

  • Marque o valor de DSCP dos pacotes do aplicativo softphone do PC conectado ao telefone IP.

  • Não confie em todo o tráfego restante do PC.

cat3750-qos-config4.gif

Este diagrama mostra que um mapa de políticas está conectado à entrada de uma interface. Você não pode aplicar um mapa de políticas à saída de quaisquer interfaces no Catalyst 3750 Switch. A próxima configuração representa o diagrama. Esta seção não foca no enfileiramento do recurso de QoS. Ela apenas aborda a MQC aplicada à interface.

Considera-se que VLAN de dados seja 10 e seu endereço de sub-rede seja 172.16.10.0/24. Uma VLAN de voz é 100 e seu endereço de sub-rede é 192.168.100.0/24.


!--- Section A

Distribution1(config)#ip access-list extended voice-traffic
Distribution1(config-std-nacl)#permit ip 192.168.100.0 0.0.0.255 any

Distribution1(config-std-nacl)#ip access-list extended
 database-application
Distribution1(config-ext-nacl)#permit tcp any any eq 1521
Distribution1(config-ext-nacl)#permit tcp any any eq 1810
Distribution1(config-ext-nacl)#permit tcp any any eq 2481
Distribution1(config-ext-nacl)#permit tcp any any eq 7778
Distribution1(config-ext-nacl)#exit

Distribution1(config)#class-map  Class-A
Distribution1(config-cmap)#match access-group name voice-traffic
Distribution1(config-cmap)#exit
Distribution1(config)#class-map  Class-B
Distribution1(config-cmap)#match access-group name
 database-application
Distribution1(config-cmap)#exit


!--- Section B

Distribution1(config)#policy-map sample-policy1
Distribution1(config-pmap)#class Class-A
Distribution1(config-pmap-c)#trust cos
Distribution1(config-pmap-c)#exit
Distribution1(config-pmap)#class Class-B
Distribution1(config-pmap-c)#set dscp af21
Distribution1(config-pmap-c)#exit
Distribution1(config-pmap)#exit


!--- Section C

Distribution1(config)#interface gigabitEthernet 1/0/13
Distribution1(config-if)#switchport access vlan 10
Distribution1(config-if)#switchport mode access
Distribution1(config-if)#switchport voice vlan 100
Distribution1(config-if)#spanning-tree portfast
Distribution1(config-if)#service-policy input sample-policy1
Distribution1(config-if)#exit

Seção A:

  • Classifica o tráfego do telefone IP como Classe A. O telefone IP pertence à VLAN de voz e possui um endereço IP na sub-rede 192.168.100.0.

  • Classifica o tráfego do aplicativo de banco de dados como Classe B. O tráfego do PC (de fato qualquer tráfego conforme a configuração) direcionado a qualquer destino com os números de porta 1521, 1810, 2481, 7778 é classificado no mapa de classes da Classe B.

Seção B:

  • O tráfego que corresponde à Classe A é configurado para confiar no rótulo de CoS. Isso significa que os valores de CoS de todo o tráfego do telefone IP são de confiança. Como mostrado no diagrama, o valor de DSCP é derivado da tabela de mapeamento CoS-DSCP para o tráfego da Classe A.

  • O tráfego que corresponde à Classe B é configurado para definir o valor de DSCP como AF21. Como mostrado no diagrama, o valor de DCoS é derivado da tabela de mapeamento DSCP-CoS para o tráfego de Classe B.

  • As configurações sob cada classe do mapa de políticas são chamadas ações PHB. Marcação, filas, policiamento, formas e prevenção de congestionamento são as ações PHB com suporte em roteadores Cisco. Marcação e policiamento são as únicas ações PHB com suporte no Cisco Catalyst 3750 Switch.

    Distribution1(config)#policy-map test
    Distribution1(config-pmap)#class test
    Distribution1(config-pmap-c)#?
    QoS policy-map class configuration commands:
      exit            Exit from QoS class action configuration mode
      no              Negate or set default values of a command
      police          Police
      service-policy  Configure QoS Service Policy
      set             Set QoS values
      trust           Set trust value for the class
      <cr>

    Os comandos set e trust são ações PHB de Marcação. Você pode configurar ações PHB set ou trust. Você não pode configurar ambas as ações em uma classe do mapa de políticas. Entretanto, você pode configurar set em uma classe e trust em outra classe no mesmo mapa de políticas.

    O comando police é a ação PHB de Policiamento. Isso é abordado em detalhes na próxima seção.

    Não há suporte a formas no Cisco Catalyst 3750 Switch. Filas e prevenção de congestionamento são aceitas no Cisco Catalyst 3750 Switch, mas não são configuráveis com MQC. As configurações de filas e prevenção de congestionamento são abordadas em detalhes posteriormente neste documento.

Seção C:

  • O mapa de políticas pode ser aplicado somente à entrada na interface. Quando você o aplica à interface de saída, a seguinte mensagem de erro é exibida:

    Distribution1(config)#int gi 1/0/3
    Distribution1(config-if)#service-policy output test
    Warning: Assigning a policy map to the output side of an
             interface not supported
    
    Service Policy attachment failed
    Warning: Assigning a policy map to the output side of an
             interface not supported
  • Se qualquer outro método de Classificação de QoS, como baseado em porta ou em VLAN, for configurado na porta 1/0/3, essas configurações serão removidas ao aplicar o mapa de políticas. Por exemplo, a porta Gi 1/0/13 é configurada para confiar em CoS como:

    interface GigabitEthernet1/0/13
     description **** Access Port ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 100
     mls qos cos 3
     mls qos trust cos
     spanning-tree portfast
  • Quando você aplica o mapa de políticas à interface, ele remove o comando trust.

    Distribution1(config)#int gi 1/0/13
    Distribution1(config-if)#service-policy input sample-policy1
    Distribution1(config-if)#do show run int gi 1/0/13
    Building configuration...
    
    Current configuration : 228 bytes
    !
    interface GigabitEthernet1/0/13
     description **** Access Port ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 100
     service-policy input sample-policy1  
     
    !--- It replaces the mls qos trust or mls qos 
    !--- vlan-based command.
    
     mls qos cos 3    
     
    !--- This command is not removed.
    
     spanning-tree portfast
    end

    Você pode observar que service-policy input substitui somente os comandos mls qos trust ou mls qos vlan-based. Ele não altera outros comandos, como mls qos cos ou mls qos dscp-mutation. Em resumo, ele substitui o comando da classificação de QoS e não substitui os comandos de marcação de QoS.

  • No mapa de políticas, você observa somente dois mapas de classes. A Classe A corresponde ao tráfego do telefone IP e a Classe B corresponde ao tráfego do aplicativo de banco de dados do PC. O tráfego restante do PC (exceto o aplicativo de banco de dados definido na lista de acesso) é classificado sob class-default class do mapa de políticas. Esse tráfego é catch-all, captura o tráfego que não corresponde aos mapas de classes definidos e conectados ao mapa de políticas. Portanto, esse tráfego que pertence a class-default não é confiado pela porta e esses pacotes são definidos com os rótulos de CoS e DSCP padrão 0. Você pode configurar a definição de qualquer valor de CoS ou DSCP padrão como esse tráfego class-default.

    É possível definir o valor de DSCP padrão com MQC. O valor de CoS é derivado da tabela de mapeamento DSCP-CoS.

    Distribution1(config)#policy-map sample-policy1
    Distribution1(config-pmap)#class class-default
    Distribution1(config-pmap-c)#set dscp af13
    Distribution1(config-pmap-c)#exit
    

    Você pode definir o valor de CoS padrão como mostrado aqui. O valor de DSCP é derivado da tabela de mapeamento CoS-DSCP.

    Distribution1(config)#int gi 1/0/13
    Distribution1(config-if)#mls qos cos 3
    Distribution1(config-if)#do show run int gi 1/0/13
    Building configuration...
    
    Current configuration : 228 bytes
    !
    interface GigabitEthernet1/0/13
     description **** Access Port ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 100
     service-policy input sample-policy1  
     mls qos cos 3    
     spanning-tree portfast

Ajuste a prioridade mais alta ao tráfego

Neste exemplo, a configuração é usada para ajustar a prioridade mais alta ao tráfego da porta TCP 1494.

  1. Tráfego voip precisa de ser atribuído um valor DSCP do EF:

    
    !--- Classifying all traffic coming with dscp value of EF 
    !--- under this class-map.
    
    Switch(config)# class-map match-all AutoQoS-VoIP-RTP-Trust
    Switch(config-cmap)# match ip dscp ef 
    
    Switch(config)# policy-map AutoQoS-Police-CiscoPhone
    Switch(config-pmap)# class AutoQoS-VoIP-RTP-Trust
    
    !--- Again setting the dscp value back to EF.
    
    Switch(config-pmap-c)# set dscp ef
    Switch(config-pmap-c)# police 320000 8000 exceed-action 
    policed-dscp-transmit
    
  2. Tráfego de TCP 1494 precisa de ser atribuído um valor DSCP de CS4:

    Switch(config)# access-list 100 permit tcp <source source-wildcard>
                 <destination destination-wildcard> eq 1494
    
    Switch(config)# class-map tcp 
    Switch(config-cmap)# match access-group 100
    
    Switch(config)# policy-map AutoQoS-Police-CiscoPhone
    Switch(config-pmap)# class tcp
    Switch(config-pmap-c)# set dscp cs4
    
  3. Todo tráfego restante precisa de ser atribuído CS3:

    Switch(config)# access-list 200 permit ip any any
    
    Switch(config)# class-map default
    Switch(config-cmap)# match access-group 200
    
    Switch(config)# policy-map AutoQoS-Police-CiscoPhone
    Switch(config-pmap)# class default
    Switch(config-pmap-c)# set dscp cs3
    
  4. Aplique-o sob interfaces relevantes:

    Switch(config)# interface <interface-type><interface number>
    
    Switch(config-if)# service-policy <policy-map-name>
    
    

Vigilância

No Cisco Catalyst 3750 Switch, policiamento podem ser configuradas somente na porta de entrada. O policiamento ser configurado somente através da MQC. Isso significa que não há nenhum comando de interface específico para policiar o tráfego. Você pode configurar policiamento no mapa de políticas e aplicar o mapa de políticas usando somente o comando service-policy input <nome-política>. Não é possível aplicar nenhum mapa de políticas ao lado da saída de uma interface.

Distribution1(config-if)#service-policy output test
police command is not supported for this interface
Configuration failed!
Warning: Assigning a policy map to the output side of an 
         interface not supported.

Esta seção aborda estes tópicos:

Classificação, Marcação e Policiamento (ação em excesso - drop)

Esta seção explica a configuração de policiamento que descarta o tráfego excessivo. O policiamento mede o tráfego recebido e mantém a taxa de entrada conforme os bits por segundo configurados. O Cisco Catalyst 3750 Switch oferece suporte somente a taxa única, policiamento de recipiente único. Isso significa que o switch mede apenas uma taxa e pode classificar o tráfego em ação adequada e em excesso de duas cores. O diagrama mostra um mapa de políticas sample-policy2 com três mapas de classes.

Os requisitos deste exemplo são:

  • Controle de ftp, pop3, tráfego imap a 10Mbps.

  • Confiança no valor de DSCP dos pacotes do aplicativo do comunicador IP do PC conectado ao telefone IP. Além disso, também é um requisito policiar este tráfego a 1 Mbps.

  • Marque e policie a aplicação do filnet.

cat3750-qos-config5.gif

Esta configuração representa o mapa de políticas mencionado no diagrama:


!--- Create Access-list and Class map Class-A

Distribution1(config)#ip access-list extended BULK-DATA
Distribution1(config-ext-nacl)#permit tcp any any eq ftp
Distribution1(config-ext-nacl)#permit tcp any any eq ftp-data
Distribution1(config-ext-nacl)#permit tcp any any eq pop3
Distribution1(config-ext-nacl)#permit tcp any any eq 143
Distribution1(config-ext-nacl)#exit

Distribution1(config)#class-map Class-A
Distribution1(config-cmap)#match access-group name BULK-DATA
Distribution1(config-cmap)#exit


!--- Create Access-list and Class map Class-B

Distribution1(config)#ip access-list extended IP-Communicator
Distribution1(config-ext-nacl)#remark *** Voice Payload ***
Distribution1(config-ext-nacl)#permit udp any any range 16384 32767
Distribution1(config-ext-nacl)#remark *** Voice Signalling ***
Distribution1(config-ext-nacl)#permit tcp any any range 2000 2002
Distribution1(config-ext-nacl)#exit

Distribution1(config)#class-map Class-B
Distribution1(config-cmap)#match access-group name IP-Communicator
Distribution1(config-cmap)#exit


!--- Create Access-list and Class map Class-C

Distribution1(config)#ip access-list extended application
Distribution1(config-ext-nacl)#remark *** Application for example ***
Distribution1(config-ext-nacl)#permit tcp any any eq 32768
Distribution1(config-ext-nacl)#permit udp any any eq 32768
Distribution1(config-ext-nacl)#permit tcp any any eq 32769
Distribution1(config-ext-nacl)#permit udp any any eq 32769
Distribution1(config-ext-nacl)#exit

Distribution1(config)#class-map Class-C
Distribution1(config-cmap)#match access-group name application
Distribution1(config-cmap)#exit


!--- Create Policy map

Distribution1(config-cmap)#policy-map sample-policy2
Distribution1(config-pmap)#class Class-A
Distribution1(config-pmap-c)#police 10000000 8000 exceed-action drop
Distribution1(config-pmap-c)#class Class-B
Distribution1(config-pmap-c)#trust dscp
Distribution1(config-pmap-c)#police 256000 8000 exceed-action drop
Distribution1(config-pmap-c)#class Class-C
Distribution1(config-pmap-c)#set dscp CS2
Distribution1(config-pmap-c)#police 25000000 8000 exceed-action drop
Distribution1(config-pmap-c)#exit
Distribution1(config-pmap)#exit


!--- Apply Policy map to the interface

Distribution1(config)#interface GigabitEthernet1/0/20
Distribution1(config-if)#service-policy input sample-policy2

A configuração no mapa de políticas é explicada aqui:

  • Classe-Um: O tráfego correspondente à Classe A é policiado à taxa de 10 Mbps. A QoS rotula o tráfego na Classe A que não é de confiança. Os valores de CoS e DSCP são marcados como 0. Os pacotes excessivos são descartados pelo policer.

  • Classe-b: Há duas ações PHB executadas na Classe B correspondente do tráfego. Um é confiança e o segundo um é policiamento. O valor de DSCP para o tráfego da Classe B é de confiança. O valor de CoS será derivado a tabela DSCP-CoS. Em seguida, o tráfego da Classe B é policiado à taxa de 256 Kbps. Os pacotes excessivos são descartados pelo policer.

  • Classe-C: Há duas ações PHB executadas na Classe B correspondente do tráfego. Uma é marcar e a segunda é policiar. Os pacotes recebidos correspondentes à Classe C são marcados com o valor de DSCP igual a CS2, e o valor de CoS é derivado da tabela DSCP-CoS que é 2. Em seguida, o tráfego da Classe C é policiado à taxa de 25 Mbps. Os pacotes excessivos são descartados pelo policer.

Classificação, Marcação e Policiamento (ação em excesso - policed-dscp-transmit)

Esta seção explica a configuração de policiamento que marca e transmite o tráfego excessivo. Este diagrama mostra um mapa de políticas sample-policy3 com dois mapas de classes:

/image/gif/paws/91862/cat3750-qos-config6.gif

O switch marca o tráfego que excede a taxa de policiamento configurada com base nos valores da tabela de mapeamento policed-DSCP. O mapa policed-DSCP é utilizado somente quando definido na configuração de policiamento. A tabela de mapeamento policed-DSCP padrão está listada aqui:

Distribution1(config)#do show mls qos map policed-dscp
   Policed-dscp map:
     d1 :  d2 0  1  2  3  4  5  6  7  8  9
     ---------------------------------------
      0 :    00 01 02 03 04 05 06 07 08 09
      1 :    10 11 12 13 14 15 16 17 18 19
      2 :    20 21 22 23 24 25 26 27 28 29
      3 :    30 31 32 33 34 35 36 37 38 39
      4 :    40 41 42 43 44 45 46 47 48 49
      5 :    50 51 52 53 54 55 56 57 58 59
      6 :    60 61 62 63

Nessa tabela, você pode observar que os mesmos valores de DSCP são correspondidos. Por exemplo, DSCP 34 é mapeado para DSCP 34. O tráfego em conformidade com a taxa do policer é transmitido sem alterar o valor de DSCP. O tráfego que excede a taxa do policer pode ser transmitido com um valor de DSCP diferente. Por exemplo, ele pode ser marcado com um valor de DSCP com maior probabilidade de descarte.

Se você usa os valores policed-DSCP padrão, não faz o sentido utilizar policiamento. Por exemplo, você optou por policiar o tráfego à taxa de 10 Mbps. O pacote recebido possui o valor de DSCP de CS4. Se você mantiver o valor de DSCP padrão, o tráfego em conformidade com 10 Mbps será transmitido com o valor de DSCP de CS2. Além disso, o tráfego que exceder 10 Mbps será transmitido com o valor de DSCP de CS2. Isso ocorre porque os valores padrão do mapa policed-DSCP mapeiam os mesmos valores. Portanto, recomenda-se configurar corretamente a tabela de mapeamento policed-DSCP para diferenciar os valores de DSCP.

Os requisitos deste exemplo são:

  • Configure a tabela de mapeamento policed-DSCP para mapear:

    • EF a AF31

    • CS3 a AF13

    • CS2 a AF11

  • Confie nos valores de DSCP dos pacotes do comunicador IP e policie-os a 256 Kbps. Se o tráfego exceder 256 Kbps, remarque os valores de DSCP usando a tabela de mapeamento policed-DSCP.

  • Marque e policie a aplicação do filnet. Se o tráfego exceder 25 Mbps, remarque os valores de DSCP usando a tabela de mapeamento policed-DSCP.

Esta configuração representa o mapa de políticas mencionado no diagrama:


!--- Policed DSCP table Configuration

Distribution1(config)#mls qos map policed-dscp 46 to 26
Distribution1(config)#mls qos map policed-dscp 24 to 14
Distribution1(config)#mls qos map policed-dscp 16 to 10


!--- Create Access-list and Class map Class-A

Distribution1(config)#ip access-list extended IP-Communicator
Distribution1(config-ext-nacl)#remark *** Voice Payload ***
Distribution1(config-ext-nacl)#permit udp any any range 16384 32767
Distribution1(config-ext-nacl)#remark *** Voice Signalling ***
Distribution1(config-ext-nacl)#permit tcp any any range 2000 2002
Distribution1(config-ext-nacl)#exit

Distribution1(config)#class-map Class-A
Distribution1(config-cmap)#match access-group name IP-Communicator
Distribution1(config-cmap)#exit


!--- Create Access-list and Class map Class-C

Distribution1(config)#ip access-list extended application
Distribution1(config-ext-nacl)#remark *** Application for example ***
Distribution1(config-ext-nacl)#permit tcp any any eq 32768
Distribution1(config-ext-nacl)#permit udp any any eq 32768
Distribution1(config-ext-nacl)#permit tcp any any eq 32769
Distribution1(config-ext-nacl)#permit udp any any eq 32769
Distribution1(config-ext-nacl)#exit

Distribution1(config)#class-map Class-B
Distribution1(config-cmap)#match access-group name application
Distribution1(config-cmap)#exit


!--- Create Policy map

Distribution1(config-cmap)#policy-map sample-policy3
Distribution1(config-pmap-c)#class Class-A
Distribution1(config-pmap-c)#trust dscp
Distribution1(config-pmap-c)#police 256000 8000 exceed-action 
policed-dscp-transmit
Distribution1(config-pmap-c)#class Class-B
Distribution1(config-pmap-c)#set dscp CS2
Distribution1(config-pmap-c)#police 25000000 8000 exceed-action 
policed-dscp-transmit
Distribution1(config-pmap-c)#exit
Distribution1(config-pmap)#exit


!--- Apply Policy map to the interface

Distribution1(config)#interface GigabitEthernet1/0/21
Distribution1(config-if)#service-policy input sample-policy3

A configuração no mapa de políticas é explicada aqui:

  • Policiar-DSCP: Há três valores modificados na tabela de mapeamento policed-DSCP.

    • EF a AF31

    • CS3 a AF13

    • CS2 a AF11

    Os primeiros dois valores são modificados com base nos tipos de tráfego classificados nos mapas de classes das Classes A e B

  • Classe-Um: O payload de voz e o controle de voz do softphone são classificados no mapa de classes da Classe A. O tráfego do payload de voz possui o valor de DSCP de EF e o controle de voz possui o valor de DSCP de CS3. Conforme a configuração do mapa de políticas, esses valores de DSCP são de confiança. O tráfego é policiado à taxa de 256 Kbps. O tráfego em conformidade com essa taxa será enviado com o valor de DSCP recebido. O tráfego que exceder essa taxa será remarcado pela tabela DSCP policiada e transmitido. A tabela DSCP policiada remarcará EF a AF31 e CS3 a AF13 conforme os valores configurados. Em seguida, os valores de CoS correspondentes serão derivados da tabela DSCP-CoS.

  • Classe-b: Os pacotes recebidos correspondentes à Classe B serão marcados com o valor de DSCP de CS2. O tráfego da Classe B é policiado à taxa de 25 Mbps. O tráfego em conformidade com essa taxa será enviado com o valor de DSCP de 2 e o valor de CoS será derivado da tabela DSCP-CoS que é 2. O tráfego que exceder essa taxa será remarcado pela tabela DSCP policiada e transmitido. A tabela DSCP policiada remarcará EF a AF31 e CS3 a AF13 conforme os valores configurados. Em seguida, os valores de CoS correspondentes serão derivados da tabela DSCP-CoS.

Gerenciamento e Prevenção de Congestionamento

Gerenciamento e Prevenção de Congestionamento é um processo de três passos. Os passos são enfileiramento, descarte e agendamento. O enfileiramento coloca os pacotes em diferentes filas de software com base nos rótulos de QoS. O Cisco Catalyst 3750 Switch possui duas filas de entrada. Depois que o tráfego é classificado e marcado com rótulos de QoS, você pode atribuir o tráfego a duas filas diferentes com base nos rótulos de QoS.

O Weighted Tail Drop (WTD) é utilizado para gerenciar os comprimentos das filas e para fornecer precedências de descartes para classificações de tráfego diferentes.

As filas de entrada e saída são servidas pelo SRR, que controla a taxa em que os pacotes são enviados. Nas filas de entrada, o SRR envia pacotes para o anel da pilha. O SRR pode operar em dois modos chamados dimensionado e compartilhado. Para filas de entrada, compartilhar é o modo padrão e é o único modo com suporte. No modo compartilhado, as filas compartilham a largura de banda entre elas de acordo com os pesos configurados. A largura de banda é garantida nesse nível, mas não limitada a ele.

Esta seção explica três tipos de configurações.

Os comandos disponíveis para defini-las são:

Distribution1(config)#mls qos srr-queue input ?

!--- Queueing

  buffers         Configure buffer allocation
  cos-map         Configure cos-map for a queue id
  dscp-map        Configure dscp-map for a queue id

!--- Scheduling

  bandwidth       Configure SRR bandwidth
  priority-queue  Configure priority scheduling

!--- Dropping

  threshold       Configure queue tail-drop thresholds

Configuração de Enfileiramento, Descarte e Agendamento Padrão

Esta saída mostra o rótulo de QoS padrão para o mapeamento de filas. Cada fila aceita três níveis de limites. Por padrão, cada suporte de fila possui somente um valor de limite igual a 100%.

cat3750-qos-config7.gif

  • Configuração de Mapa da Fila Padrão:

    Os pacotes com CoS 5 (DSCP 40 a 47) são colocados na fila 2. Os pacotes que permanecem são colocados na fila 1.

    Distribution1#show mls qos maps cos-input-q
       Cos-inputq-threshold map:
                  cos:  0   1   2   3   4   5   6   7
                  ------------------------------------
      queue-threshold: 1-1 1-1 1-1 1-1 1-1 2-1 1-1 1-1
    
    Distribution1#show mls qos maps dscp-input-q
       Dscp-inputq-threshold map:
         d1 :d2  0    1    2    3    4    5    6    7    8    9
         ------------------------------------------------------------
          0 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
          1 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
          2 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
          3 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
          4 :  02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 01-01 01-01
          5 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
          6 :  01-01 01-01 01-01 01-01

    Esta tabela representa o mapeamento padrão CoS/DSCP para fila de entrada:

    CoS DSCP Fila de entrada
    0 0 a 7 1
    1 8 a 15 1
    2 16 a 23 1
    3 24 a 31 1
    4 32 a 39 1
    5 40 a 47 2
    6 48 a 55 1
    7 56 a 63 1

  • Configuração da Fila Padrão:

    O buffer da fila de entrada é compartilhado 90% pela fila 1 e 10% pela fila 2. Os níveis de limites 1, 2 e 3 são 100%.

    Distribution1#show mls qos input-queue
    Queue     :       1       2
    ----------------------------------------------
    buffers   :      90      10
    bandwidth :       4       4
    priority  :       0      10
    threshold1:     100     100
    threshold2:     100     100
    
  • Configuração do Agendador Padrão:

    A fila 2 é a fila prioritária. O SRR serve a fila prioritária para seu peso configurado que é 10%. Em seguida, o SRR compartilha a largura de banda remanescente (90%) com as filas de entrada e as serve como especificado pelos pesos configurados. Nesse caso, a fila 1 e a fila 2 são servidas à taxa de 45% cada.

    Distribution1#show mls qos input-queue
    Queue     :       1       2
    ----------------------------------------------
    buffers   :      90      10
    bandwidth :       4       4
    priority  :       0      10
    threshold1:     100     100
    threshold2:     100     100

Enfileiramento e Agendamento

Há três passos para configurar o enfileiramento e o agendamento. Os passos são:

  1. Configuração de Mapa da Fila:

    A configuração de mapa mapeia os pacotes para as duas filas de entrada com base nos valores de DSCP ou CoS.

  2. Configuração da Fila:

    A configuração da fila define a proporção (alocar a quantidade de espaço) para dividir os buffers de entrada entre as duas filas.

  3. Configuração do Agendador:

    O SRR configura a proporção dos pesos que controlam a frequência de pacotes que saem das filas para o anel da pilha.

As configurações da fila e do agendador controlam a quantidade de dados que pode ser inserida no buffer antes que os pacotes sejam descartados.

cat3750-qos-config8.gif

Nesta seção, os níveis de descarte WTD não são configurados. Isso significa que os pacotes serão descartados se a fila for 100%.

  • Configuração de Mapa da Fila:

    Primeiro, os valores de CoS serão mapeados para as filas. Nessa seção, os valores de limites não são configurados.

    
    !--- Assign the frames into the queue based on the CoS value.
    
    Distribution1(config)#mls qos srr-queue input cos-map
     queue 1 0 1 
    Distribution1(config)#mls qos srr-queue input cos-map
     queue 2 2 3 4 5 6 7
    
    
    !--- Show output.
    
    Distribution1#show mls qos maps cos-input-q
       Cos-inputq-threshold map:
                  cos:  0   1   2   3   4   5   6   7
                  ------------------------------------
      queue-threshold: 1-1 1-1 2-1 2-1 2-1 2-1 2-1 2-1
    
    Distribution1#show mls qos maps dscp-input-q
       Dscp-inputq-threshold map:
         d1 :d2   0    1    2    3    4    5    6    7    8    9
         ------------------------------------------------------------
         0 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         1 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         2 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         3 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         4 :  02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 01-01 01-01
         5 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         6 :  01-01 01-01 01-01 01-01

    Você pode ver o conflito nos mapas Cos-inputq-threshold e Dscp-inputq-threshold. Por exemplo, CoS 3 é mapeado para a fila 2 na tabela Cos-inputq-threshold. Entretanto, o valor de DSCP 24 (que corresponde a CoS 3) é mapeado para a fila 1 no mapa Dscp-inputq-threshold. De fato, o mapa Dscp-inputq-threshold substitui o mapa Cos-inputq-threshold. Estes mapeamentos devem ser tão consistentes quanto possível a fim de garantir o comportamento previsível e simplificar o troubleshooting. Portanto, o mapa Dscp-inputq-threshold é configurado para sincronização com o mapa Cos-inputq-threshold.

    
    !--- Assign the frames into the queue based on the DSCP value.
    
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2
      16 17 18 19 20 21 22 23
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2
      24 25 26 27 28 29 30 31
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2
      32 33 34 35 36 37 38 39
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2
      48 49 50 51 52 53 54 55
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2
      56 57 58 59 60 61 62 63
    
    Distribution1#show mls qos maps dscp-input-q
       Dscp-inputq-threshold map:
         d1 :d2  0   1   2    3    4    5    6    7    8    9
         ------------------------------------------------------------
         0 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         1 :  01-01 01-01 01-01 01-01 01-01 01-01 02-01 02-01 02-01 02-01
         2 :  02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01
         3 :  02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01
         4 :  02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01
         5 :  02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01
         6 :  02-01 02-01 02-01 02-01
  • Configuração da Fila:

    O IOS aloca o espaço padrão no buffer para enfileirar pacotes de entrada após a habilitação de QoS. Ambas as filas de entrada, fila1 e fila 2, compartilham esse espaço de buffer. No Catalyst 3750 Switch, você pode configurar o percentual desse espaço de buffer que cada fila pode utilizar. 67% da memória disponível total para a fila de entrada é alocado para a fila 1 e 33% é alocado para a fila 2.

    Distribution1(config)#mls qos srr-queue input buffers 67 33
    
    Distribution1(config)#do show mls qos input
    Queue     :       1       2
    ----------------------------------------------
    buffers   :      67      33
    bandwidth :       4       4
    priority  :       0      10
    threshold1:     100     100
    threshold2:     100     100
  • Configuração do Agendador:

    Essa configuração é executada com o comando mls qos srr-queue input bandwidth. Aqui, esta largura de banda indica a quantidade de bits servida pelo SRR nas filas.

    Distribution1(config)#mls qos srr-queue input bandwidth 90 10
    Distribution1(config)#mls qos srr-queue input priority-queue 2 
    bandwidth 20
    
    Distribution1(config)#do show mls qos input
    Queue     :       1       2
    ----------------------------------------------
    buffers   :      67      33
    bandwidth :      90      10
    priority  :       0      20
    threshold1:     100     100
    threshold2:     100     100

    Por padrão, a fila 2 é a fila prioritária e 10% da largura de banda interna total do anel está alocado para a fila de prioridade. Você também pode configurar a fila 1 como a fila prioritária. Entretanto, você não pode configurar ambas as filas como a fila prioritária.

    Se a largura de banda do anel for 10 Gbps, o SRR servirá 20% de 10 Gbps para a fila 2 primeiro, o que corresponde a 2 Gbps. A largura de banda restante de 8 Gbps do anel é compartilhada pela fila 1 e pela fila 2. Conforme a configuração, a fila 1 é servida a 90% de 8 Gbps e a fila 2 é servida novamente a 10% de 8 Gbps. Esta largura de banda de 8 Gbps é servida pelo SRR em modo compartilhado. Isso significa que os percentuais de largura de banda configurados estão garantidos, mas não limitados a ele.

    Nota: Você pode desativar a fila prioritária com o comando mls qos srr-queue input priority-queue 2 bandwidth 0.

    Distribution1(config)#do show mls qos input
    Queue     :       1       2
    ----------------------------------------------
    buffers   :      90      10
    bandwidth :      90      10
    priority  :       0       0
    threshold1:     100     100
    threshold2:     100     100
    Distribution1(config)#

Enfileiramento, Descarte e Agendamento

Nesta seção, os níveis de limites WTD são configurados além do que o tamanho do buffer de fila. Você pode atribuir cada pacote que passa através do switch a uma fila e a um limite.

cat3750-qos-config9.gif

Estes são os exemplos de configuração e as explicações:

  • Configuração de Mapa da Fila:

    Primeiro, os valores de CoS são mapeados para as filas.

    
    !--- Assign the frames into the queue based on the CoS value.
    
    Distribution1(config)#mls qos srr-queue input cos-map queue 1
     threshold 2  1
    Distribution1(config)#mls qos srr-queue input cos-map queue 1
     threshold 3  0
    Distribution1(config)#mls qos srr-queue input cos-map queue 2
     threshold 1  2
    Distribution1(config)#mls qos srr-queue input cos-map queue 2
     threshold 2  4 6 7
    Distribution1(config)#mls qos srr-queue input cos-map queue 2
     threshold 3  3 5
    
    
    !--- Show output.
    
    Distribution1(config)#do show mls qos maps cos-input-q
       Cos-inputq-threshold map:
                  cos:  0   1   2   3   4   5   6   7
                  ------------------------------------
      queue-threshold: 1-3 1-2 2-1 2-3 2-2 2-3 2-2 2-2
    
    Distribution1(config)#do show mls qos maps dscp-input-q
       Dscp-inputq-threshold map:
         d1 :d2  0    1    2    3    4    5    6    7    8    9
         ------------------------------------------------------------
         0 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         1 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         2 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         3 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         4 :  02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 01-01 01-01
         5 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         6 :  01-01 01-01 01-01 01-01

    Você pode ver o conflito nos mapas Cos-inputq-threshold e Dscp-inputq-threshold. Por exemplo, CoS 3 é mapeado para a fila 2 na tabela Cos-inputq-threshold, mas o valor de DSCP 24 (que corresponde a CoS 3) é mapeado para a fila 1 no mapa Dscp-inputq-threshold. De fato, o mapa Dscp-inputq-threshold substitui o mapa Cos-inputq-threshold. Estes mapeamentos devem ser tão consistentes quanto possível a fim de garantir o comportamento previsível e simplificar o troubleshooting. Portanto, o mapa Dscp-inputq-threshold é configurado para sincronização com o mapa Cos-inputq-threshold.

    
    !--- Assign the frames into the queue based on the DSCP value.
    
    Distribution1(config)#mls qos srr-queue input dscp-map queue 1
     threshold 2 9 10 11 12 13 14 15
    Distribution1(config)#mls qos srr-queue input dscp-map queue 1 
     threshold 3 0 1 2 3 4 5 6 7
    Distribution1(config)#mls qos srr-queue input dscp-map queue 1 
     threshold 3 32
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2 
     threshold 1 16 17 18 19 20 21 22 23
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2 
     threshold 2 33 34 35 36 37 38 39 48
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2 
     threshold 2 49 50 51 52 53 54 55 56
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2 
     threshold 2 57 58 59 60 61 62 63
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2 
     threshold 3 24 25 26 27 28 29 30 31
    
    Distribution1(config)#do show mls qos maps dscp-input-q
       Dscp-inputq-threshold map:
         d1 :d2  0    1    2    3    4    5    6    7    8    9
         ------------------------------------------------------------
         0 :  01-03 01-03 01-03 01-03 01-03 01-03 01-03 01-03 01-01 01-02
         1 :  01-02 01-02 01-02 01-02 01-02 01-02 02-01 02-01 02-01 02-01
         2 :  02-01 02-01 02-01 02-01 02-03 02-03 02-03 02-03 02-03 02-03
         3 :  02-03 02-03 01-03 02-02 02-02 02-02 02-02 02-02 02-02 02-02
         4 :  02-03 02-03 02-03 02-03 02-03 02-03 02-03 02-03 02-02 02-02
         5 :  02-02 02-02 02-02 02-02 02-02 02-02 02-02 02-02 02-02 02-02
         6 :  02-02 02-02 02-02 02-02
  • Configuração da Fila:

    Por padrão, o limite 3 é 100% e não pode ser alterado.

    Distribution1(config)#mls qos srr-queue input buffers 67 33
    Distribution1(config)#mls qos srr-queue input threshold 1 8 16
    Distribution1(config)#mls qos srr-queue input threshold 2 34 66
    
    Distribution1(config)#do show mls qos input
    Queue     :       1       2
    ----------------------------------------------
    buffers   :      67      33
    bandwidth :       4       4
    priority  :       0      10
    threshold1:       8      34
    threshold2:      16      66
  • Configuração do Agendador:

    O IOS aloca espaço padrão no buffer para cada porta de entrada após a habilitação de QoS. Ambas as filas compartilham este espaço de buffer. No Catalyst 3560/3750 Switch, você pode configurar o percentual do espaço de buffer que cada fila pode utilizar.

    Distribution1(config)#mls qos srr-queue input bandwidth 90 10
    Distribution1(config)#mls qos srr-queue input priority-queue 2
     bandwidth 20
    
    Distribution1(config)#do show mls qos input
    Queue     :       1       2
    ----------------------------------------------
    buffers   :      67      33
    bandwidth :      90      10
    priority  :       0      20
    threshold1:       8      34
    threshold2:      16      66

    Por padrão, a fila 2 é a fila prioritária e 10% da largura de banda interna total do anel está alocado para a fila de prioridade. Você também pode configurar a fila 1 como a fila prioritária. Entretanto, você não pode configurar ambas as filas como a fila prioritária.

    Se você possuir uma largura de banda do anel como 10 Gbps, o SRR servirá 20% de 10 Gbps para a fila 2 primeiro que corresponde a 2 Gbps. A largura de banda restante de 8 Gbps do anel é compartilhada pela fila 1 e pela fila 2. Conforme a configuração, a fila 1 é servida a 90% de 8 Gbps e a fila 2 é servida novamente a 10% de 8 Gbps. Esta largura de banda de 8 Gbps é servida pelo SRR em modo compartilhado. Isso significa que os percentuais de largura de banda configurados estão garantidos, mas não limitados a ele.

    Nota: Você pode desativar a fila prioritária com o comando mls qos srr-queue input priority-queue 2 bandwidth 0.

    Distribution1(config)#do show mls qos input
    Queue     :       1       2
    ----------------------------------------------
    buffers   :      90      10
    bandwidth :      90      10
    priority  :       0       0
    threshold1:     100     100
    threshold2:     100     100
    Distribution1(config)#

Recursos de QoS de saída

Gerenciamento e Prevenção de Congestionamento são os recursos de QoS de saída com suporte pelos Cisco Catalyst 3750 Switches. Gerenciamento e Prevenção de Congestionamento é um processo de três passos. Os passos são enfileiramento, descarte e agendamento.

O enfileiramento coloca os pacotes em diferentes filas de software com base nos rótulos de QoS. O Cisco Catalyst 3750 Switch possui 4 filas de saída, 3 limites por fila. Depois que o tráfego é classificado e marcado com rótulos de QoS, você pode atribuir o tráfego a quatro filas diferentes com base nos rótulos de QoS.

Cada fila pode ser configurada com tamanho de buffer, limite reservado, níveis de limites e limite máximo. O Weighted Tail Drop (WTD) é utilizado para gerenciar os comprimentos das filas e para fornecer precedências de descartes para classificações de tráfego diferentes. Os parâmetros da fila de entrada são configurados globalmente. Os parâmetros da fila de entrada não são baseados em portas. Entretanto, os parâmetros da fila de saída são configurados com base em portas. Mesmo assim a configuração será por porta. Você não pode configurar cada porta diferentemente. Você pode configurar cada porta de duas formas diferentes. Isso é chamado de conjunto de filas. Você pode definir até dois conjuntos de filas diferentes na configuração global. Em seguida, você poderá aplicar qualquer um desses dois conjuntos na interface.

As filas de entrada e saída são servidas pelo SRR, que controla a taxa em que os pacotes são enviados. Nas filas de entrada, o SRR envia pacotes para o anel da pilha. O SRR pode operar em dois modos chamados dimensionado e compartilhado. Para filas de entrada, compartilhar é o modo padrão e é o único modo com suporte. No modo compartilhado, as filas compartilham a largura de banda entre elas de acordo com os pesos configurados. A largura de banda é garantida nesse nível, mas não limitada a ele. No modo dimensionado, um percentual da largura de banda é garantido para as filas de saída e suas taxas são limitadas a essa quantidade. O tráfego dimensionado não utilizará mais do que a largura de banda alocada mesmo se o link estiver ocioso. O dimensionamento oferece um fluxo de tráfego mais homogêneo e reduz os picos e os vales de tráfego interrompido. A fila 1 pode ser configurada como a fila prioritária.

Comandos de QoS de Saída

Esta seção categoriza todos os comandos de QoS de saída disponíveis.

  • Configuração de Mapa da Fila:

    Para mapear os valores de CoS para as filas de saída:

    Rack1SW1(config)#mls qos srr-queue output cos-map queue ?
      <1-4>  enter cos-map output queue id
    
    Rack1SW1(config)#mls qos srr-queue output cos-map queue 1
     threshold ? <1-3>  enter cos-map threshold id
    
    Rack1SW1(config)#mls qos srr-queue output cos-map queue 1
     threshold 1 ? <0-7>  8 cos values separated by spaces

    Para mapear os valores de DSCP para as filas de saída:

    Rack1SW1(config)#mls qos srr-queue output dscp-map queue ?
      <1-4>  enter dscp-map output queue id
    
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 1
     threshold ? <1-3>  enter dscp-map threshold id
    
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 1
     threshold 1 ? <0-63>  dscp values separated by spaces
     (up to 8 values total)
  • Configuração da Fila:

    A configuração de fila de saída permite que você configure dois conjuntos de filas. Cada conjunto de filas pode configurar o tamanho do buffer e o valor de limite para as quatro filas de saída. Em seguida, você poderá aplicar qualquer um dos conjuntos de filas a qualquer uma das portas. Por padrão, o conjunto de filas 1 é atribuído a todas as portas quando você habilita QoS no switch.

    Rack1SW1(config)#mls qos queue-set output ?
      <1-2>  queue-set id
    
    Rack1SW1(config)#mls qos queue-set output 1 ?
      buffers    assign buffers to each egress queue
      threshold  Assign threshold values to a queue
    

    Para configurar o tamanho do buffer para todas as quatro filas de saída:

    Rack1SW1(config)#mls qos queue-set output 1 buffers ?
      <0-99>  enter buffer percentage for queue 1 0-99
    
    Rack1SW1(config)#mls qos queue-set output 1 buffers 10 ?
      <1-100>  enter buffer percentage for queue 2 1-100
     (includes CPU buffer)
    
    Rack1SW1(config)#mls qos queue-set output 1 buffers 10 20 ?
      <0-99>  enter buffer percentage for queue 3 0-99
    
    Rack1SW1(config)#mls qos queue-set output 1 buffers 10 20 30 ?
      <0-99>  enter buffer percentage for queue 4 0-99

    Para configurar dois valores de limites, os valores de limites máximo e reservado para cada fila (o limite 3 é 100% por padrão e não pode ser alterado):

    Rack1SW1(config)#mls qos queue-set output 1 threshold ?
      <1-4>  enter queue id in this queue set
    
    Rack1SW1(config)#mls qos queue-set output 1 threshold 1 ?
      <1-400>  enter drop threshold1 1-400
    
    Rack1SW1(config)#mls qos queue-set output 1 threshold 1 50 ?
      <1-400>  enter drop threshold2 1-400
    
    Rack1SW1(config)#mls qos queue-set output 1 threshold 1 50 60 ?
      <1-100>  enter reserved threshold 1-100
    
    Rack1SW1(config)#mls qos queue-set output 1 threshold 1 50 60
     100 ? <1-400>  enter maximum threshold 1-400

    Para aplicar o conjunto de filas à interface (por padrão, o conjunto de filas 1 está atribuído a todas as portas quando você habilita QoS no switch):

    Rack1SW1(config-if)#queue-set ?
      <1-2>  the qset to which this port is mapped
  • Configuração do Agendador:

    Três configurações diferentes estão disponíveis para a interface do switch. As configurações são limite, compartilhamento e dimensionamento da largura de banda. Você também pode configurar a fila 1 de saída como a fila prioritária. Se a fila prioritária estiver habilitada, o SRR a servirá até que seja esvaziada antes de servir as outras três filas. Entretanto, na fila prioritária de entrada, o SRR serve a fila prioritária com o valor configurado.

    Rack1SW1(config-if)#srr-queue bandwidth ?
      limit  Configure bandwidth-limit for this interface
      shape  Configure shaping on transmit queues
      share  Configure shared bandwidth
    
    Rack1SW1(config-if)#priority-queue ?
      out  egress priority queue

    Configuração de limite de largura de banda:

    Rack1SW1(config-if)#srr-queue bandwidth limit ?
      <10-90>  enter bandwidth limit for interface  as percentage

    Configuração de dimensionamento de largura de banda:

    Rack1SW1(config-if)#srr-queue bandwidth shape ?
      <0-65535>  enter bandwidth weight for queue id 1
    
    Rack1SW1(config-if)#srr-queue bandwidth shape 10 ?
      <0-65535>  enter bandwidth weight for queue id 2
    
    Rack1SW1(config-if)#srr-queue bandwidth shape 10 20 ?
      <0-65535>  enter bandwidth weight for queue id 3
    
    Rack1SW1(config-if)#srr-queue bandwidth shape 10 20 30 ?
      <0-65535>  enter bandwidth weight for queue id 4

    Configuração de compartilhamento de largura de banda:

    Rack1SW1(config-if)#srr-queue bandwidth share ?
      <1-255>  enter bandwidth weight for queue id 1
    
    Rack1SW1(config-if)#srr-queue bandwidth share 10 ?
      <1-255>  enter bandwidth weight for queue id 2
    
    Rack1SW1(config-if)#srr-queue bandwidth share 10 20 ?
      <1-255>  enter bandwidth weight for queue id 3
    
    Rack1SW1(config-if)#srr-queue bandwidth share 10 20 30 ?
      <1-255>  enter bandwidth weight for queue id 4

    Todas as quatro filas participarão no SRR a menos que a fila prioritária esteja habilitada. Nesse caso, o primeiro peso de largura de banda será ignorado e não será utilizado no cálculo da proporção. A fila prioritária será servida até que seja esvaziada antes que outras filas sejam servidas. A fila prioritária pode ser habilitada usando o comando priority-queue out interface configuration.

Configuração padrão

Configuração de Mapa da Fila Padrão:

/image/gif/paws/91862/cat3750-qos-config10.gif

Estes mapeamentos padrão podem ser alterados conforme seu requisito:


!--- Map CoS to Egress Queue

Distribution1#show mls qos maps cos-output-q
   Cos-outputq-threshold map:
              cos:  0   1   2   3   4   5   6   7
              ------------------------------------
  queue-threshold: 2-1 2-1 3-1 3-1 4-1 1-1 4-1 4-1


!--- Map DSCP to Egress Queue

Distribution1#show mls qos maps dscp-output-q
   Dscp-outputq-threshold map:
     d1 :d2  0    1    2    3    4    5    6    7    8    9
     ------------------------------------------------------------
     0 :  02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01
     1 :  02-01 02-01 02-01 02-01 02-01 02-01 03-01 03-01 03-01 03-01
     2 :  03-01 03-01 03-01 03-01 03-01 03-01 03-01 03-01 03-01 03-01
     3 :  03-01 03-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01
     4 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 04-01 04-01
     5 :  04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01
     6 :  04-01 04-01 04-01 04-01

Configuração da Fila Padrão:

cat3750-qos-config11.gif

As configurações padrão da fila de saída são apropriadas para a maioria das situações. Você somente deverá alterá-las se possuir uma compreensão total sobre as filas de saída e se essas configurações não atenderem à sua solução de QoS.

Dois conjuntos de filas são configurados e o conjunto de filas 1 é atribuído a todas as portas por padrão. Cada fila recebe 25% do espaço do total do buffer. 50% do espaço de buffer alocado é reservado para cada fila, o que corresponde a 12,5% do espaço total do buffer. A soma de todos os buffers reservados representa o pool reservado, e os buffers restantes são parte do pool comum. A configuração padrão define 400% como a memória máxima que esta fila pode ter antes que pacotes sejam descartados.

Distribution1#show mls qos queue-set 1
Queueset: 1
Queue     :       1       2       3       4
----------------------------------------------
buffers   :      25      25      25      25
threshold1:     100     200     100     100
threshold2:     100     200     100     100
reserved  :      50      50      50      50
maximum   :     400     400     400     400

Distribution1#show mls qos queue-set 2
Queueset: 2
Queue     :       1       2       3       4
----------------------------------------------
buffers   :      25      25      25      25
threshold1:     100     200     100     100
threshold2:     100     200     100     100
reserved  :      50      50      50      50
maximum   :     400     400     400     400

Distribution1#show mls qos int gigabitEthernet 1/0/20 buffers
GigabitEthernet1/0/20
The port is mapped to qset : 1
The allocations between the queues are : 25 25 25 25

Configuração do Agendador Padrão:

A fila prioritária está desativada. Os modos dimensionado e compartilhado são configurados para o SRR. Os pesos do modo dimensionado substituem o valor do modo compartilhado. Portanto, o resultado da rede é que a fila 1 é servida no modo dimensionado e as filas 2,3 e 4 são servidas no modo compartilhado. Isso significa que a fila 1 é servida com um valor absoluto de (1/25) por cento, ou 4%, da largura de banda. As filas 2,3 e 4 são servidas a 25% da largura de banda. Se a largura de banda estiver disponível, as filas 2,3 e 4 poderão ser servidas a mais de 25% da largura de banda.

Distribution1#show mls qos int gigabitEthernet 1/0/20 queueing
GigabitEthernet1/0/20
Egress Priority Queue : disabled
Shaped queue weights (absolute) :  25 0 0 0
Shared queue weights  :  25 25 25 25
The port bandwidth limit : 100  (Operational Bandwidth:100.0)
The port is mapped to qset : 1

Enfileiramento, Descarte e Agendamento

Estas são as configurações de exemplo:

  • Configuração de Mapa da Fila:

    Rack1SW1(config)#mls qos srr-queue output cos-map queue 1
     threshold 3 5
    Rack1SW1(config)#mls qos srr-queue output cos-map queue 1
     threshold 1 2 4
    Rack1SW1(config)#mls qos srr-queue output cos-map queue 2 
     threshold 2 3
    Rack1SW1(config)#mls qos srr-queue output cos-map queue 2
     threshold 3 6 7
    Rack1SW1(config)#mls qos srr-queue output cos-map queue 3
     threshold 3 0
    Rack1SW1(config)#mls qos srr-queue output cos-map queue 4
     threshold 3 1
    
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 1
     threshold 3  46
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 2
     threshold 1  16
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 2
     threshold 1  18 20 22
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 2
     threshold 1  25
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 2
     threshold 1  32
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 2
     threshold 1  34 36 38
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 2
     threshold 2  24 26
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 2
     threshold 3  48 56
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 3
     threshold 3  0
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 4
     threshold 1  8
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 4
     threshold 3  10 12 14
    
  • Configuração da Fila:

    Esta configuração mostra a configuração dos conjuntos de filas 1 e 2. Por padrão, o conjunto de filas 1 é aplicado a todas as interfaces.

    Rack1SW3(config)#mls qos queue-set output 1 buffers 10 10 26 54
    Rack1SW3(config)#mls qos queue-set output 2 buffers 16 6 17 61
    
    Rack1SW3(config)#mls qos queue-set output 1 threshold 2 70 80
     100 100
    Rack1SW3(config)#mls qos queue-set output 1 threshold 4 40 100
     100 100
    
    Rack1SW3(config)#mls qos queue-set output 2 threshold 1 149 149
     100 149
    Rack1SW3(config)#mls qos queue-set output 2 threshold 2 118 118
     100 235
    Rack1SW3(config)#mls qos queue-set output 2 threshold 3 41 68
     100 272
    Rack1SW3(config)#mls qos queue-set output 2 threshold 4 42 72
     100 242
    
    Rack1SW3(config)#int fa 1/0/11
    Rack1SW3(config-if)#queue-set 2
    

    A interface 1/0/11 é aplicada com o conjunto de filas 2.

    Rack1SW3(config-if)#do show mls qos int fa 1/0/10 buffers
    FastEthernet1/0/10
    The port is mapped to qset : 1
    The allocations between the queues are : 10 10 26 54
    
    Rack1SW3(config-if)#do show mls qos int fa 1/0/11 buffers
    FastEthernet1/0/11
    The port is mapped to qset : 2
    The allocations between the queues are : 16 6 17 61
  • Configuração do Agendador:

    Rack1SW3(config-if)#srr-queue bandwidth share 1 75 25 5
    Rack1SW3(config-if)#srr-queue bandwidth shape  3  0  0  0
    

    A fila de saída do Cisco Catalyst 3750 não oferece suporte a Low Latency Queueing (LLQ). Ela oferece suporte a enfileiramento prioritário. Quando você configurar a fila prioritária de saída, a fila 1 sempre será servida quando possuir um pacote.

    Rack1SW3(config-if)#srr-queue bandwidth share 1 75 25 5
    Rack1SW3(config-if)#srr-queue bandwidth shape  3  0  0  0
    Rack1SW3(config-if)#priority-queue out
    

    Quando você configurar esse comando, as proporções de peso do SRR e tamanho da fila serão afetadas porque haverá uma fila a menos participando no SRR. Isso significa que weight1 no comando srr-queue bandwidth shape ou srr-queue bandwidth share será ignorado (não utilizado no cálculo da proporção).

Este é o comando para exibir descartes em filas específicas:

Passo 1:

1/ #show platform pm if-numbers

Use os se-números comando pm da plataforma da mostra e verifique a informação de porta que corresponde a sua relação (esta é a interface enviada nos seus 3750). Por exemplo, fas 0/3 serão a porta 0/4. Mantenha 4 como o valor de porta; se o primeiro valor não é um zero, a seguir dê o número asic após o número de porta.

interface gid gpn lpn port slot unit slun port-type lpn-idb gpn-idb
------------------------------------------------------------------------
---------
Gi0/1     1    1    25   0/1  1    1    1    local     Yes     Yes
Gi0/2     2    2    26   0/0  1    2    2    local     Yes     Yes
Fa0/1     3    3    1    0/2  1    1    3    local     Yes     Yes
Fa0/2     4    4    2    0/3  1    2    4    local     Yes     Yes
Fa0/3     5    5    3    0/4  1    3    5    local     Yes     Yes
Fa0/4     6    6    4    0/5  1    4    6    local     Yes     Yes
Fa0/5     7    7    5    0/6  1    5    7    local     Yes     Yes
Fa0/6     8    8    6    0/7  1    6    8    local     Yes     Yes

O valor de porta que corresponde ao fá 0/3 da relação é 0/4. Agora você pode ver as quedas da fila do fá 0/3 da relação com o comando da porta 4 da gota stats da plataforma porta-ASIC da mostra.

2/ #show platform port-asic stats drop port 4 
       
Port-asic Port Drop Statistics - Summary
========================================
  RxQueue 0 Drop Stats: 0
  RxQueue 1 Drop Stats: 0
  RxQueue 2 Drop Stats: 0
  RxQueue 3 Drop Stats: 0
...
 
  Port 4 TxQueue Drop Statistics
    Queue 0
      Weight 0 Frames 0
      Weight 1 Frames 0
      Weight 2 Frames 0
    Queue 1
      Weight 0 Frames 0
      Weight 1 Frames 2755160   <--- Here is an example of drops
      Weight 2 Frames 0
    Queue 2
      Weight 0 Frames 0
      Weight 1 Frames 0
      Weight 2 Frames 0
    Queue 3
      Weight 0 Frames 0
      Weight 1 Frames 0
      Weight 2 Frames 8

Passo 2:

  • Configuração de limite de largura de banda:

    Para limitar a saída máxima em uma porta, defina o comando de configuração da interface srr-queue bandwidth limit. Se você configurar esse comando como 80%, a porta permanecerá ociosa 20% do tempo. A taxa da linha cairá para 80% da velocidade conectada. Esses valores não são exatos porque o hardware ajusta a taxa da linha em incrementos de seis. Este comando não está disponível em uma interface Ethernet de 10 Gigabits.

    srr-queue bandwidth limit weight1
    
    

    onde weight1 é o percentual da velocidade da porta ao qual a porta deve ser limitada. O intervalo é 10 a 90.

    Nota: As configurações padrão da fila de saída são apropriadas para a maioria das situações. Você somente deverá alterá-las se possuir uma compreensão total sobre as filas de saída e se essas configurações não atenderem à sua solução de Qualidade de Serviço (QoS).


Informações Relacionadas


Document ID: 91862