Cisco Interfaces and Modules : Módulos de rede da Cisco

Exemplo de configuração do módulo da Rede EtherSwitch (ESW)

16 Janeiro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Tradução Manual (8 Junho 2009) | Inglês (11 Novembro 2015) | Feedback


Índice


Introdução

Este documento fornece uma configuração de exemplo do EtherSwitch Network Module instalado no Roteador de Serviço Integrado (ISR). Este documento não discute o exemplo de configuração para o EtherSwitch Service Module.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Cisco 2800 Series Router no Software Release 12.4 ou Mais Recente de Cisco IOS�

  • Módulo da Rede EtherSwitch da porta 10/100 NM-16ESW-PWR= 16 (NM)

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Produtos Relacionados

Esta configuração também pode ser utilizada com estas versões de hardware e software:

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Módulos EtherSwitch - Conceitos

Há dois tipos de módulos EtherSwitch disponíveis para Cisco ISR. São elas:

  • Módulo da Rede EtherSwitch (ESW)

  • Módulo de serviço do EtherSwitch (ES)

Os módulos ESW são configurados pelo roteador IO. Estes módulos não executam o software separado. O software é integrado no roteador host IO. Você pode criar VLAN, configura os VLAN, medindo - árvore, o protocolo VLAN trunking (VTP), e assim por diante do roteador host. O roteador igualmente armazena o arquivo de base de dados de VLAN (vlan.dat) no flash. Este documento mostra o exemplo de configuração para o módulo ESW.

Os módulos ES têm seus próprios processadores, mecanismos de switching e memória Flash que executam o independente dos recursos do roteador host. Depois que o módulo ES é instalado no roteador, você pode consolar no módulo ES do roteador host. Então você pode criar VLAN, configura os VLAN, medindo - árvore, VTP, e assim por diante do módulo ES. Os módulos ES são baseados na plataforma do catalizador 3750.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a Command Lookup Tool (somente clientes registrados) para obter mais informações sobre os comandos usados nesta seção.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/82156/ether-switch-nm-config-1.gif

Configurações

Este documento utiliza as seguintes configurações:

Configurar interfaces de VLAN

À revelia todas as portas pertencem ao VLAN1. Você pode criar VLAN somente do modo de banco de dados de VLAN. Depois que os VLAN são criados do modo de banco de dados de VLAN, o arquivo vlan.dat está criado e armazenado no sistema de arquivo flash do roteador. Você pode ver os VLAN usando o comando do showvlan-interruptor. Neste exemplo, um server do protocolo de configuração dinâmica host (DHCP) (172.16.10.20) é ficado situado no VLAN10. O comando do iphelper-endereço é configurado em todos os VLAN a não ser que VLAN10 a fim obter o endereço IP de Um ou Mais Servidores Cisco ICM NT do servidor DHCP aos dispositivos situados nestes VLAN.

Roteador1

Create VLANs


Router1#vlan database
Router1(vlan)#vlan 10
VLAN 10 added:
    Name: VLAN0010
Router1(vlan)#vlan 51
VLAN 51 added:
    Name: VLAN0051
Router1(vlan)#vlan 50
VLAN 50 added:
    Name: VLAN0050
Router1(vlan)#vlan 100
VLAN 100 added:
    Name: VLAN0100
Router1(vlan)#vlan 200
VLAN 200 added:
    Name: VLAN0200
Router1(vlan)#exit
APPLY completed.
Exiting....
Router1#



Configure VLANs


Router1(config)#interface vlan 10
Router1(config-if)#ip address 172.16.10.1 255.255.255.0

Router1(config-if)#interface vlan 50
Router1(config-if)#ip address 172.16.50.1 255.255.255.0
Router1(config-if)#ip helper-address 172.16.10.20

Router1(config-if)#interface vlan 51
Router1(config-if)#ip address 172.16.51.1 255.255.255.0
Router1(config-if)#ip helper-address 172.16.10.20

Router1(config-if)#interface vlan 100
Router1(config-if)#ip address 172.16.100.1 255.255.255.0
Router1(config-if)#ip helper-address 172.16.10.20

Router1(config-if)#interface vlan 200
Router1(config-if)#ip address 172.16.200.1 255.255.255.0
Router1(config-if)#ip helper-address 172.16.10.20

Router1#show vlan-switch

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/0, Fa1/2, Fa1/3, Fa1/4, 
                                                Fa1/5, Fa1/6, Fa1/7, Fa1/8,
                                                Fa1/9, Fa1/10, Fa1/11, Fa1/12
                                                Fa1/13, Fa1/14, Fa1/15
10   VLAN0010                         active    
50   VLAN0050                         active    
51   VLAN0051                         active    
100  VLAN0100                         active    
200  VLAN0200                         active    
1002 fddi-default                     active    
1003 token-ring-default               active    
1004 fddinet-default                  active    
1005 trnet-default                    active    

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        1002   1003
10   enet  100010     1500  -      -      -        -    -        0      0   
50   enet  100050     1500  -      -      -        -    -        0      0   
51   enet  100051     1500  -      -      -        -    -        0      0   
100  enet  100100     1500  -      -      -        -    -        0      0   

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
200  enet  100200     1500  -      -      -        -    -        0      0   
1002 fddi  101002     1500  -      -      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        ibm  -        0      0   
1005 trnet 101005     1500  -      -      1        ibm  -        0      0   

Configurar o VTP, o tronco, o Canal de porta, e a medida - árvore

À revelia, o modo de VTP é o server e o Domain Name está vazio. O VTP pode ser configurado somente do modo de banco de dados de VLAN. O único modo Spanning Tree apoiado é PVST+. O encapsulamento de tronco do padrão é dot1q. Ao configurar a porta do tronco para permitir somente VLANs especificadas, você poderá receber uma mensagem de erro semelhante a Bad VLAN allowed list. Nesse caso, talvez seja necessário permitir as VLAns padrão 1-2, 1002-1005 junto com sua lista de VLANs personalizadas. Devido a isto, você igualmente precisa de permitir os VLAN padrão e seu costume VLAN no switch vizinho conectado a esta porta de tronco para evitar inconsistências do tronco.

Roteador1

VTP Configuration


Router1#vlan database
Router1(vlan)#vtp transparent
Setting device to VTP TRANSPARENT mode.
Router1(vlan)#vtp domain LAB
Changing VTP domain name from NULL to LAB
Router1(vlan)#exit
APPLY completed.
Exiting....



Spanning-Tree Configuration


Router1(config)#spanning-tree vlan 1 root primary
Router1(config)#spanning-tree vlan 10 root primary
Router1(config)#spanning-tree vlan 50 root primary
Router1(config)#spanning-tree vlan 51 root primary
Router1(config)#spanning-tree vlan 100 root primary
Router1(config)#spanning-tree vlan 200 root primary



Trunk and Port Channel Configuration


Router1(config)#interface port-channel 1
Router1(config-if)#switchport mode trunk

!--- dot1q is the default encapsulation.

Router1(config-if)#switchport trunk allowed vlan 100,200
Command rejected: Bad VLAN allowed list. You have to include all default vlans,
e.g. 1-2,1002-1005.
Command rejected: Bad VLAN allowed list. You have to include all default vlans,
e.g. 1-2,1002-1005.
Router1(config-if)#switchport trunk allowed vlan 1,1002-1005,100,200
Router1(config-if)#exit

Router1(config)#interface range fastEthernet 1/0 - 1
Router1(config-if-range)#switchport mode trunk

!--- dot1q is the default encapsulation.

Router1(config-if-range)#switchport trunk allowed vlan 1,1002-1005,100,200
Router1(config-if-range)#channel-group 1 mode on
Router1(config-if-range)#exit

Access1

Access1 Switch Configuration


Access1(config)#vlan 100,200
Access1(config-vlan)#exit

Access1(config)#vtp mode transparent
Setting device to VTP TRANSPARENT mode.

Access1(config)#vtp domain LAB
Changing VTP domain name from NULL to LAB

Access1(config)#interface port-channel 1
Access1(config-if)#switchport trunk encapsulation dot1q
Access1(config-if)#switchport mode trunk
Access1(config-if)#switchport trunk allowed vlan 1,1002-1005,100,200
Access1(config-if)#exit

Access1(config)#interface range FastEthernet 0/1 - 2
Access1(config-if-range)#switchport trunk encapsulation dot1q
Access1(config-if-range)#switchport mode trunk
Access1(config-if-range)#switchport trunk allowed vlan 1,1002-1005,100,200
Access1(config-if-range)#channel-group 1 mode on
Access1(config-if-range)#exit

Router1#show vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 52
Number of existing VLANs        : 10
VTP Operating Mode              : Transparent
VTP Domain Name                 : LAB
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x8D 0x71 0x37 0x29 0x6C 0xB0 0xF2 0x0E
Configuration last modified by 172.22.1.197 at 2-20-07 22:31:06
Router1#
Router1#show interface fastethernet 1/0 trunk

Port      Mode         Encapsulation  Status        Native vlan
Fa1/0     on           802.1q         trunk-inbndl  1
                                      (Po1)

Port      Vlans allowed on trunk
Fa1/0     1,100,200,1002-1005

Port      Vlans allowed and active in management domain
Fa1/0     1,100,200

Port      Vlans in spanning tree forwarding state and not pruned
Fa1/0     1,100,200
Router1#show spanning-tree summary
Root bridge for: VLAN1, VLAN10, VLAN50, VLAN51, VLAN100, VLAN200.
PortFast BPDU Guard is disabled
UplinkFast is disabled
BackboneFast is disabled

Name                 Blocking Listening Learning Forwarding STP Active
-------------------- -------- --------- -------- ---------- ----------
VLAN1                0        0         0        1          1
VLAN10               0        0         0        1          1
VLAN50               0        0         0        1          1
VLAN51               0        0         0        1          1
VLAN100              0        0         0        1          1
VLAN200              0        0         0        1          1
-------------------- -------- --------- -------- ---------- ----------
             6 VLANs 0        0         0        6          6

Configurar portas de acesso

A configuração da porta de acesso é similar à configuração padrão do switch LAN.

Roteador1

Port for Server Configuration


Router1(config)#interface fastEthernet 1/2
Router1(config-if)#switchport mode access
Router1(config-if)#switchport access vlan 10
Router1(config-if)#spanning-tree portfast
Router1(config-if)#speed 100
Router1(config-if)#duplex full
Router1(config-if)#exit



Port for Printer Configuration


Router1(config)#interface fastethernet 1/3
Router1(config-if)#switchport mode access
Router1(config-if)#switchport access vlan 51
Router1(config-if)#spanning-tree portfast
Router1(config-if)#exit

Configurar a porta de voz

A configuração da porta de voz é similar à configuração padrão do switch LAN.

Roteador1

Configure the port for Voice

Router1(config)#interface fastethernet 1/4
Router1(config-if)#switchport mode access
Router1(config-if)#switchport access vlan 51
Router1(config-if)#switchport voice vlan 50
Router1(config-if)#spanning-tree portfast
Router1(config-if)#mls qos trust cos

Configurar o Qualidade de Serviço (QoS)

Esta é a configuração de QoS do padrão no módulo ESW:

Router1#show wrr-queue bandwidth
WRR Queue  :   1   2   3   4

Bandwidth  :   1   2   4   8
wrr-queue bandwidth is disabled

Router1#show wrr-queue cos-map
CoS Value      :  0  1  2  3  4  5  6  7

Priority Queue :  1  1  2  2  3  3  4  4
wrr-queue cos map is disabled

Router1#show mls qos maps cos-dscp
   Cos-dscp map:
        cos:   0  1  2  3  4  5  6  7
     --------------------------------
       dscp:   0  8 16 26 32 46 48 56

Router1#show mls qos maps dscp-cos

   Dscp-cos map:
       dscp:   0  8 10 16 18 24 26 32 34 40 46 48 56
     -----------------------------------------------
        cos:   0  1  1  2  2  3  3  4  4  5  5  6  7

Estas seções explicam estas configurações:

Configurar filas do wrr

Você não pode configurar QoS com base na porta nas portas do switch de Camada 2. As filas podem ser configuradas somente de uma configuração global. O exemplo de configuração traça os valores de CoS às quatro filas diferentes. Quando um pacote entra no motor da camada 2 diretamente de uma porta de switch, está colocado em uma de quatro filas no dinâmico, buffer da memória compartilhada do 32 MB. Alguns exprimem os pacotes do portador que vêm dentro dos Telefones IP de Cisco na Voz VLAN são colocados automaticamente na prioridade mais alta (fila 4) baseada no valor 802.1p (CoS 5) gerado pelo telefone IP. As filas são prestadas serviços de manutenção então em uma base tornada mais pesada do arredondamento robin (WRR). O tráfego de controle, que usa um CoS ou um Tipo de serviço (ToS) de 3, é colocado na fila 3.

Roteador1
Router1(config)#wrr-queue cos-map 1 0 1
Router1(config)#wrr-queue cos-map 2 2
Router1(config)#wrr-queue cos-map 3 3 4
Router1(config)#wrr-queue cos-map 4 5 6 7

!--- wrr-queue cos-map <queue-number> <cos values separated by space>

Router(config)#wrr-queue bandwidth 1 16 64 255

!--- wrr-queue bandwidth <Weight of Queue1> <Weight of Queue2> 
!--- <Weight of Queue3> <Weight of Queue4>

Verifique os parâmetros da fila:

Router1#show wrr-queue bandwidth
WRR Queue  :   1   2   3   4

Bandwidth  :   1   2   4   8 

!--- Default values


WRR Queue  :   1   2   3   4

Bandwidth  :   1  16  64 255 

!--- Configured values


Router1#show wrr-queue cos-map
CoS Value      :  0  1  2  3  4  5  6  7

Priority Queue :  1  1  2  2  3  3  4  4  

!--- Default values

CoS Value      :  0  1  2  3  4  5  6  7

Priority Queue :  1  1  2  3  3  4  4  4  

!--- Configured values

Esta tabela mostra o número da fila, o valor de CoS e o peso de cada fila após a configuração.

Número da fila Valor de CoS Peso
1 0 1 1
2 2 16
3 3 4 64
4 5 6 7 255

Configurar a porta para confiar CoS

Roteador1
Router1(config)#interface fastethernet1/4
Router1(config-if)#mls qos trust cos

!--- Trust the CoS value of the frames from the IP phone.

Router1(config-if)#mls qos cos override

!--- Reset the CoS value of the frames from PC to 0.

Router1(config-if)#exit

Router1(config)#interface range fastEthernet 1/0 - 1
Router1(config-if-range)#mls qos trust cos

!--- Trust the CoS value of the frames from this trunk link.

Router1(config-if-range)#exit

Configurar o vigilante

Isto secciona mostras a configuração do vigilante na relação fa1/2 para limitar o tráfego FTP ao 5 Mbps.

Roteador1
Router1(config)#ip access-list extended ACTIVE-FTP
Router1(config-ext-nacl)#permit tcp any any eq ftp
Router1(config-ext-nacl)#permit tcp any any eq ftp-data
Router1(config-ext-nacl)#exit
Router1(config)#class-map ACTIVE-FTP-CLASS
Router1(config-cmap)#match class ACTIVE-FTP
Router1(config-cmap)#exit
Router1(config)#policy-map ACTIVE-FTP-POLICY
Router1(config-pmap)#class ACTIVE-FTP-CLASS
Router1(config-pmap-c)#police 5000000 conform-action transmit exceed-action drop
Router1(config-pmap-c)#exit
Router1(config-pmap)#exit
Router1(config)#interface fastethernet1/2
Router1(config-if)#service-policy input ACTIVE-FTP-POLICY
Router1(config-if)#exit

Há poucas limitações na configuração do vigilante nos módulos ESW. São alistados aqui:

  • Os mapas de políticas com classificação de ACL na direção de saída não são aceitas e não podem ser anexados à interface por meio do comando de configuração service-policy input policy-map-name interface.

  • Em um mapa de política, a classe nomeada class-default não é apoiada. O switch não filtra o tráfego com base no mapa de políticas definido pelo comando de configuração class class-default policy-map.

  • Você pode criar o mapa de política e aplicar-se somente ao ingresso das relações ESW. E no mapa de política, somente o vigilante é apoiado.

    Router1#show policy-map
      Policy Map FINANCE-POLICY
        Class FINANCE-CLASS
          set cos 4
    Router1(config)#interface fastethernet1/4
    Router1(config-if)#service-policy input FINANCE-POLICY
    %Error: FastEthernet1/4 Service Policy Configuration Failed.Only Police Action S
    upported
  • Não há nenhum apoio para policiar a VLAN ou nível do Switched Virtual Interface (SVI).

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 82156