Sem fio/Mobilidade : LAN Wireless (WLAN)

QoS em controladores do Wireless LAN e no exemplo de configuração de pouco peso AP

16 Janeiro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Tradução Manual (8 Junho 2009) | Inglês (20 Dezembro 2015) | Feedback


Índice


Introdução

Este documento fornece um exemplo de configuração que mostra como configurar a Qualidade de Serviço (QoS) na rede Cisco Unified Wireless usando os Controllers de LAN Wireless (WLC) e Lightweight Access Points (LAPs).

Pré-requisitos

Requisitos

Certifique-se de atender a estes requisitos antes de tentar esta configuração:

  • Conhecimento básico da configuração dos LAPs e dos WLCs da Cisco

  • Conhecimento de como configurar o roteamento básico e o QoS em uma rede ligada com fio

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Cisco 2006 WLC que executa a versão de firmware 4.0

  • Cisco 1000 Series LAPs

  • Adaptador de cliente Wireless de Cisco 802.11a/b/g que executa a versão de firmware 2.6

  • Cisco 3725 Router que executa o Software Release 12.3(4)T1 de Cisco IOS�

  • Cisco 3640 Router que executa o Cisco IOS Software Release 12.2(26)

  • Duas 3500 XL series switch de Cisco que executam o Cisco IOS Software Release 12.0(5)WC3b

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Informações de Apoio

QoS refere a capacidade da rede para fornecer melhor ou o serviço especial a um grupo de usuários ou os aplicativos ao detrimento de outros usuários ou aplicativos.

Com QoS, a largura de banda pode ser controlada mais eficientemente através dos LAN, que inclui WLAN e WAN. Isto é como QoS fornece serviço aumentada e de rede confiável:

  • Largura de banda dedicada dos apoios para usuários críticos e aplicativos

  • Tremor e latência dos controles (exigidos pelo tráfego de tempo real)

  • Controla e minimiza o congestionamento de rede

  • Dá forma ao tráfego de rede para smoothen o fluxo de tráfego

  • Ajusta prioridades do tráfego de rede

No passado, os WLAN foram usados principalmente para transportar a largura de banda baixa, tráfego do aplicativo de dados. Atualmente, com a expansão dos WLAN no vertical (tal como o retalho, a finança, e a educação) e nos ambientes de empreendimento, os WLAN são usados para transportar aplicativos de dados da largura de banda elevada conjuntamente com o sensível ao tempo, aplicativos multimídia. Esta exigência conduzida à necessidade para QoS wireless.

O grupo em funcionamento da IEEE 802.11e dentro do comitê de padrões do IEEE 802.11 terminou a definição padrão. Contudo, a adoção do padrão 802.11e está em seus estágios iniciais, e como com muitos padrões há muitos componentes opcionais. Apenas enquanto o que ocorreram com Segurança do 802.11 em 802.11i, os grupos industriais tais como o Wi-fi Alliance, e os líderes de mercado tais como Cisco estão definindo as exigências chaves em WLAN QoS com seus programas dos multimédios (WMM) e das extensões compatível Cisco do Wi-fi (o CCX). Isto assegura a entrega dos recursos chaves e da interoperação com seus programas de certificação.

Apoio de Produtos WMM do Cisco Unified Wireless, um sistema de QoS baseado no esboço da IEEE 802.11e que foi publicado pelo Wi-fi Alliance.

O controlador apoia quatro níveis de QoS:

  • Platina/Voz — Assegura um de alta qualidade do serviço para a Voz sobre o Sem fio.

  • Aplicativos de vídeo de alta qualidade do ouro/suportes de vídeo.

  • De prata/melhor esforço — Apoia a largura de banda normal para clientes. Esta é a configuração padrão.

  • Bronze/fundo — Fornece a mais baixa largura de banda para serviços do convidado.

A Voz sobre clientes IP (VoIP) deve ser ajustada à platina, ao ouro, ou à prata quando os clientes da largura de banda baixa puderem ser ajustados para bronzear.

Você pode configurar a largura de banda cada de perfis de utilização nivelados de QoS QoS e então aplicar os perfis aos WLAN. Os ajustes do perfil são empurrados para os clientes associados a esse WLAN. Além, você pode criar papéis de QoS para especificar níveis diferentes da largura de banda para o regular e os usuários convidado.

Para obter informações sobre de como configurar perfis de QoS usando o GUI, refira a utilização do GUI para configurar perfis de QoS.

Para obter informações sobre de como configurar perfis de QoS usando o CLI, refira a utilização do CLI para configurar perfis de QoS.

Consulte a seção Qos Wireless do Cisco Unified do Guia de Design de Mobilidade Corporativa para obter mais informações sobre como a QoS funciona na rede wireless Cisco Unified.

Este documento fornece um exemplo de configuração que ilustre como configurar QoS em controladores e se comunicar com uma rede ligada com fio configurada com QoS.

Realces da Marcação de pacotes QoS da camada 3

A rede de Cisco Unified Wireless apoia a marcação do Differentiated Services Code Point IP da camada 3 (DSCP) dos pacotes enviados por WLC e por regaços. Esta característica aumenta como os Access point (AP) usam esta informação da camada 3 a fim se assegurar de que os pacotes recebam o correto sobre - arejam a prioridade do AP ao cliente Wireless.

Em uma arquitetura de WLAN centralizada, os dados WLAN são escavados um túnel entre o AP e o WLC através do protocolo de pouco peso do Access point (LWAPP). A fim manter a classificação de QoS original através deste túnel, os ajustes de QoS do pacote de dados encapsulados devem apropriadamente ser traçados à camada 2 (802.1p) e mergulhar 3 (IP DSCP) campos do pacote de túnel exterior.

Não é possível marcar com DSCP os pacotes entre o controlador e o LAP quando não há valor de DSCP ou 802.1P no pacote original em si.

O controlador não aplica sua própria QoS. O suporte à QoS no WLC dá ao WLC a capacidade de aplicar a mesma prioridade definida no cabo (ou aplicativo).

Assim, a única ação que será feita em um WLC ou AP é copiar o valor do pacote original para o cabeçalho de saída do pacote LWAPP. O único objetivo das opções de QoS Gold, Silver e Bronze no WLC é executar conversões de QoS adequadas entre os valores de UP do 802.11e/802.1p e os valores de DCSP de IP, os quais dependem do aplicativo ou padrão que é usado. Mais uma vez, a QoS no WLC garante que os pacotes recebam o tratamento de QoS adequado fim a fim. O controlador não executa seu próprio comportamento de QoS. O apoio está lá para que o controlador siga o terno se QoS já existe e a prioridade precisa de ser aplicada aos pacotes wireless. Você não pode mandar QoS somente existir no controlador.

O controlador não oferece suporte a valores de marcação de Classe de Serviço (CoS) baseados na configuração da WLAN no modo LWAPP da camada 2. Recomenda-se usar o LWAPP da camada 3 para implementar a QoS da CoS.

Este é um exemplo de como a QoS funciona com WLCs. O aplicativo, por exemplo, o CallManager, poderia definir um valor de QoS de High. Assim, o pacote de dados original do aplicativo será encapsulado por um cabeçalho IP que possui o valor de DCSP definido como High. Agora o pacote chega ao controlador. Em seguida, o pacote passa pelo SSID Test. No entanto, se você possui um SSID Test em seu controlador configurado para o perfil de QoS Bronze, o cabeçalho IP do pacote que encapsula o pacote de LWAPP do controlador para o AP terá o valor Bronze (embora a prioridade do cabeçalho IP ao redor do pacote original do aplicativo seja alta). Este documento supõe que o DCSP definido pelo aplicativo e que o perfil de QoS para aquele SSID no controlador sejam os mesmos. Entretanto, esse nem sempre é o caso.

/image/gif/paws/81831/qos-wlc-lap1.gif

Por exemplo, quando o tráfego 802.11e é enviado por um cliente de WLAN, tem uma classificação da prioridade de usuário (ACIMA) em seu quadro. O AP precisa de traçar esta classificação 802.11e em um valor DSCP para o pacote Iwapp que leva o quadro. Isto assegura-se de que o pacote esteja dado a prioridade apropriada em sua maneira ao WLC. Necessidades similares de um processo de ocorrer no WLC para os pacotes Iwapp que vão ao AP. Também, um mecanismo é precisado de classificar o tráfego no AP e no WLC para clientes non-802.11e, de modo que seus pacotes Iwapp possam igualmente ser dados a prioridade apropriada. Esta tabela ilustra como os pacotes são segurados em cada dispositivo:

# De Para ACIMA DE (802.1p/802.11e) IP DSCP
1 Controlador Ponto de acesso NÃO converte o valor de DSCP do pacote recebido para o valor de UP do AVVID 802.1p. O valor de DSCP, se presente no pacote, segue de forma transparente no pacote. Copie o valor DSCP do pacote recebido.
2 Ponto de acesso Cliente Wireless Cliente WMM: Traduza o valor DSCP do pacote Iwapp entrante ao valor 802.11e ASCENDENTE. Policie o valor para assegurar-se de que não exceda o valor máximo permitido a política de QoS WLAN atribuída a esse cliente. Coloque o pacote na fila de Tx do 802.11 apropriada para o valor ASCENDENTE. Cliente regular: Coloque o pacote na fila de Tx do 802.11 do padrão para a política de QoS WLAN atribuída a esse cliente. N/A (o valor original DSCP é preservado)
3 Ponto de acesso Controlador N/A (os Access point não apoiam as etiquetas 802.1Q/802.1p) Cliente WMM: Policie o valor 802.11e ASCENDENTE para assegurar-se de que não exceda o valor máximo permitido a política de QoS atribuída a esse cliente; traduza o valor ao valor DSCP. Cliente regular: Use o valor 802.11e ASCENDENTE para a política de QoS atribuída a esse cliente; traduza o valor ao valor DSCP.
4 Controlador Switch Ethernet Traduza o valor DSCP dos pacotes Iwapp entrantes ao valor 802.1p ASCENDENTE. N/A (o valor original DSCP é preservado)

Esta tabela seguinte fornece as traduções que ocorrem entre 802.11e/802.1p ACIMA dos valores e dos valores IP DSCP. Porque a arquitetura Cisco para a Voz, o vídeo e os dados integrados (AVVID) define a tradução de 802.1 até IP DSCP, e a IEEE define a tradução de IP DSCP a 802.11e ACIMA, dois grupos diferentes de traduções devem ser usados.

O Cisco AVVID 802.1p Acima-baseou o tipo de tráfego IP DSCP do Cisco AVVID Cisco AVVID 802.1p ACIMA IEEE 802.11e ACIMA Notas
Controle de rede - 7 - Reservado para o controle de rede somente
Controle da rede interna 48 6 7 (AC_VO) Controle LWAPP
Voz 46 (EF) 5 6 (AC_VO) Controlador: Perfil de QoS da platina
Vídeo 34 (AF41) 4 5 (AC_VI) Controlador: Perfil de QoS do ouro
Controle da Voz 26 (AF31) 3 4 (AC_VI) -
O melhor esforço 0 (Be) 0 3 (AC_BE) 0 (AC_BE) Controlador: Perfil de prata de QoS -
Fundo (fundo do ouro do Cisco AVVID) 18 (AF21) 2 2 (AC_BK) -
Fundo (fundo de prata do Cisco AVVID) 10 (AF11) 1 1 (AC_BK) Controlador: Perfil de bronze de QoS

Nota: O valor ASCENDENTE da IEEE 802.11e para os valores DSCP que não são mencionados na tabela é calculado considerando 3 bit MSB do DSCP. Por exemplo, o valor ASCENDENTE da IEEE 802.11e para o DSCP 32 (100 000 no binário) seria o valor convertido decimal do MSB (100), que é 4. O valor 802.11e ASCENDENTE do DSCP 32 é 4.

Instalação de rede

Este documento utiliza a seguinte configuração de rede:

  • A rede ligada com fio compreende dos dois Roteadores, do roteador1 e do roteador2, que executam o OSPF entre eles. Os anfitriões prendidos compreendem de um servidor FTP (F1), de um cliente da Voz (V1) e de um cliente video (Vi1). Os anfitriões prendidos conectam à rede através de um switch de Camada 2 que seja conectado ao Fast Ethernet do r1 do roteador.

  • A rede Wireless conecta à rede com o roteador2 segundo as indicações do diagrama. Os anfitriões wireless compreendem de um cliente de FTP (NON-WMM permitido), de um cliente V1 da Voz (7920 telefones) e de um cliente video Vi1 (WMM permitido).

  • Os pacotes de voz devem ser dados a prioridade mais alta seguida por pacotes de vídeo. Os pacotes de FTP devem ser dados menos prioridade.

  • Na rede ligada com fio, o Weighted Random Early Detection (WRED) é usado a fim executar QoS. Os tipos de tráfego diferentes são classificados e dados a prioridade com base nos valores DSCP. O WRED é executado em pacotes prioritários.

  • Na rede Wireless, três WLAN devem ser criados para cada tipo de tráfego, e permitir perfis apropriados de QoS.

    • WLAN 1 — Clientes de FTP: Perfil de bronze de QoS

    • WLAN 2 — Clientes video: Perfil de QoS do ouro

    • WLAN 3 — Clientes da Voz: Perfil de QoS da platina

Os dispositivos para a conectividade básica IP e permitem a necessidade de QoS de ser configurado na rede ligada com fio e a rede Wireless.

/image/gif/paws/81831/qos-wlc-lap4.gif

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

A fim configurar os dispositivos para esta instalação, estes necessidade de ser executado:

Configurar a rede Wireless para QoS

Antes que você configure QoS em WLC, você deve configurar o WLC para a operação básica e registrar os regaços ao WLC. Este documento supõe que o WLC está configurado para a operação básica e que os regaços estão registrados ao WLC. Se você for um novo usuário que está tentando configurar o WLC para operação básica com LAPs, consulte Registro do LAP (Lightweight AP) em um WLC (Wireless LAN Controller).

Uma vez os regaços são registrados ao WLC, terminam estas tarefas a fim configurar os regaços e o WLC para esta instalação:

  1. Configurar WLAN para as classes de tráfego diferentes

  2. Permita perfis de QoS para os WLAN

Termine estas etapas a fim criar um WLAN no WLC para os clientes da Voz:

  1. Clique WLAN do controlador GUI a fim criar um WLAN.

  2. Clique novo a fim configurar um WLAN novo.

    Neste exemplo, o WLAN é nomeado VoiceClients e o ID de WLAN é 1.

  3. Clique em Apply.

    qos-wlc-lap5.gif

  4. Na janela WLAN > Edit, defina os parâmetros específicos da WLAN VoiceClients.

    1. Para o WLAN, escolha a relação apropriada do campo de nome da relação.

      Este exemplo traça a Voz da relação ao WLAN VoiceClients.

    2. Do Qualidade de Serviço (QoS) puxe para baixo o menu, escolhem o perfil apropriado de QoS para o WLAN.

      Neste exemplo, o perfil de QoS da platina é selecionado. Isto dá a prioridade mais alta à Voz WLAN.

    3. Para o parâmetro de 7920 suportes de telefone, escolha o tipo do controle de admissão da chamada (CAC).

      Este exemplo usa o limite AP CAC.

    4. Selecione os outros parâmetros, que dependem dos requisitos de projeto.

      Os valores padrão são usados neste exemplo.

    5. Clique em Apply.

      qos-wlc-lap6.gif

      Nota: Não permita o modo WMM se Cisco 7920 telefones é usado em sua rede. Você não pode permitir o modo WMM e modo cliente-controlado CAC no mesmo WLAN. Quando um CAC AP-controlado é permitido, o AP manda um elemento de informação proprietário de Cisco CAC (IE) e não manda o padrão QBSS IE.

O desenvolvimento da Voz sobre o infra-estruturo WLAN envolve mais do que simplesmente fornecer QoS no WLAN. Uma Voz WLAN precisa de considerar exigências da cobertura da análise de site, exigências do comportamento do usuário, vaguear e controle de admissão. Isto é coberto nos Guias de Design do Telefone IP Cisco Unified série 7900.

Similarmente, crie os WLAN para os clientes video e os clientes de FTP. Os clientes video são traçados ao vídeo da interface dinâmica e os clientes de FTP são traçados à interface dinâmica FTP. Estes são os screenshots:

Nota: Este documento não explica como criar VLAN em WLC. Consulte Exemplo de Configuração de VLANs em Wireless LAN Controllers para obter informações sobre como configurar interfaces dinâmicas em WLCs.

/image/gif/paws/81831/qos-wlc-lap7.gif

qos-wlc-lap8.gif

Nota: O apoio do cliente de WLAN para WMM não significa que o tráfego do cliente tira proveito automaticamente de WMM. Os aplicativos que procuram os benefícios de WMM atribuem uma classificação apropriada da prioridade a seu tráfego, e o sistema operacional precisam de passar essa classificação à relação WLAN. Em dispositivos finalidade-construídos, tais como os monofones de VoWLAN, isto é feito como parte do projeto. Contudo, se você executa em uma plataforma de uso geral, tal como um PC, uma classificação do tráfego de aplicativo e um apoio do OS deve ser executado antes que as características WMM possam ser usadas ao bom efeito.

Para os clientes video, o ouro do perfil de QoS é selecionado e WMM é permitido. Para clientes de FTP, o bronze é selecionado como o perfil de QoS e WMM é desabilitado porque neste exemplo os clientes de FTP não apoiam WMM.

qos-wlc-lap9.gif

qos-wlc-lap10.gif

Nota: Quando o controlador reage do modo da camada 2 e WMM está permitido, você deve pôr os AP sobre uma porta de tronco a fim permitir que juntem-se ao controlador.

Emita estes comandos a fim configurar os WLAN e o QoS no WLC usando o CLI:

  • Execute o comando config wlan create <wlan-id> <wlan-name> para criar uma nova WLAN. Para a WLAN-identificação, incorpore um ID de 1 a 16. Para o WLAN-nome, incorpore um SSID até 31 caráteres alfanuméricos.

  • Execute o comando config wlan enable <wlan-id> para habilitar uma WLAN.

  • Emita a WLAN-identificação wlan dos qos da configuração {bronze | prata | ouro | comando da platina} a fim atribuir um QoS em nível a um WLAN.

  • Emita o wmm wlan da configuração {desabilitado | reservado | } comando WLAN-identificação exigido a fim permitir o modo WMM.

  • Emita o cliente-CAC-limite 7920-support wlan da configuração {permitido | } comando WLAN-identificação deficiente para os telefones que exigem CA cliente-controlado.

  • Emita o ap-CAC-limite 7920-support wlan da configuração {permitido | } comando WLAN-identificação deficiente para os telefones que exigem CAC AP-controlado.

Configurar a rede ligada com fio para QoS

A fim configurar a rede ligada com fio para esta instalação, você precisa de configurar a Conectividade dos roteadores para básico e de permitir QoS na rede ligada com fio. O OSPF é usado como o protocolo de roteamento de unicast.

A característica WRED é usada para executar QoS na rede ligada com fio. A característica do DiffServ Compliant WRED permite o WRED de usar o valor DSCP quando calcula a probabilidade de queda para um pacote.

Estas são as configurações para o r1 do Roteadores e o R2:

Roteador1
Router1#show run
Building configuration...

Current configuration : 2321 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router1
!
!
ip subnet-zero
!
!
!
call rsvp-sync
!

!
class-map match-all FTP

!--- Classifies FTP Packets based on Access List 103.

  match access-group 103
class-map match-all Video

!--- Classifies Video Packets based on Access List 102.

  match access-group 102
class-map match-all Voice

!--- Classifies Voice Packets based on Access List 101.

  match access-group 101
!
!
policy-map Marking-For-FTP

!--- Sets DSCP value af11 for FTP packets.

  class FTP
   set ip dscp af11
policy-map Marking-For-Voice

!--- Sets DSCP value ef for Voice packets.

  class Voice
   set ip dscp ef
policy-map Marking-For-Video

!--- Sets DSCP value af41 for Video packets.

  class Video
   set ip dscp af41
!
!
!
interface Serial2/0
 description Connected to Router2
 ip address 10.2.3.2 255.255.255.0
 random-detect dscp-based 

!--- Enables WRED based on DSCP Value of the packet.

 random-detect dscp 10 30 40

!--- Sets the Minimum and Maximum Threshold of Packets 
!--- to 30 and 40 packets for the DSCP value 10.

 random-detect dscp 34 40 50

!--- Sets the Minimum and Maximum Threshold of Packets 
!--- to 40 and 50 packets for the DSCP value 34.

 random-detect dscp 46 50 60

!--- Sets the Minimum and Maximum Threshold of Packets 
!--- to 50 and 60 packets for the DSCP value 46.

 clockrate 56000
!
interface Serial2/1
 no ip address
 shutdown
!
interface Serial2/2
 no ip address
 shutdown
!
interface Serial2/3
 no ip address
 shutdown
!
interface Serial2/4
 no ip address
 shutdown
!
interface Serial2/5
 no ip address
 shutdown
!
interface Serial2/6
 no ip address
 shutdown
!
interface Serial2/7
 no ip address
 shutdown
!
interface FastEthernet3/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet3/0.1
 description Connected to Voice Clients
 encapsulation dot1Q 10
 ip address 192.168.0.1 255.255.0.0
 service-policy output Marking-For-Voice

!--- Applies the policy Marking-For-Voice to the interface.

!
interface FastEthernet3/0.2
 description Connected to Video Clients
 encapsulation dot1Q 20
 ip address 172.16.0.1 255.255.0.0
 service-policy output Marking-For-Video

!--- Applies the policy Marking-For-Video to the interface.

!
interface FastEthernet3/0.3
 description Connected to FTP Server
 encapsulation dot1Q 30
 ip address 30.0.0.1 255.0.0.0
 service-policy output Marking-For-FTP

!--- Applies the policy Marking-For-FTP to the interface.

!
interface FastEthernet3/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router ospf 1

!--- Configures OSPF as the routing protocol.

 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
 network 30.0.0.0 0.0.0.255 area 0
 network 172.16.0.0 0.0.255.255 area 0
 network 192.168.0.0 0.0.255.255 area 0
!
ip classless
ip http server
!
access-list 101 permit ip 192.168.0.0 0.0.255.255 any

!--- Access list used to classify Voice packets.

access-list 102 permit ip 172.16.0.0 0.0.255.255 any

!--- Access list used to classify Video packets.

access-list 103 permit ip 30.0.0.0 0.0.0.255 any

!--- Access list used to classify FTP packets.

!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 1/1/0
!
voice-port 1/1/1
!
dial-peer cor custom
!
!
!
dial-peer voice 1 pots
 destination-pattern 4085551234
 port 1/0/0
!
!
line con 0
line aux 0
line vty 0 4
!
end

Roteador2
Router2#show run
Building configuration...

Current configuration : 1551 bytes
!
version 12.3
service config
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!

!
interface FastEthernet0/0
 ip address dhcp
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 description Connected to Voice Clients
 encapsulation dot1Q 40
 ip address 20.0.0.1 255.0.0.0
!
interface FastEthernet0/0.2
 description Connected to Video Clients
 encapsulation dot1Q 50
 ip address 40.0.0.1 255.0.0.0
!
interface FastEthernet0/0.3
 description Connected to FTP Clients
 encapsulation dot1Q 60
 ip address 50.0.0.1 255.0.0.0
!
interface Serial0/0
 description Connected to Router1
 ip address 10.2.3.1 255.255.255.0
 random-detect dscp-based

!--- Enables WRED based on DSCP Value of the packet.

 random-detect dscp 10 30 40

!--- Sets the Minimum and Maximum Threshold of Packets 
!--- to 30 and 40 packets for the DSCP value 10.

 random-detect dscp 34 40 50

!--- Sets the Minimum and Maximum Threshold of Packets 
!--- to 40 and 50 packets for the DSCP value 34.

 random-detect dscp 46 50 60

!--- Sets the Minimum and Maximum Threshold of Packets 
!--- to 50 and 60 packets for the DSCP value 46.

!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Service-Engine2/0
 no ip address
 shutdown
 hold-queue 60 out
!
router ospf 1

!--- Configures OSPF as the routing protocol.

 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
 network 20.0.0.0 0.255.255.255 area 0
 network 40.0.0.0 0.255.255.255 area 0
 network 50.0.0.0 0.255.255.255 area 0
!
ip http server
ip classless
!
!
control-plane
!
!
voice-port 1/0/0
!
voice-port 1/0/1
!
gatekeeper
 shutdown
!
!
line con 0
line 65
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output all
line aux 0
line vty 0 4
!
!
end

Verificar e solucionar problemas

Uma vez que o Sem fio e a rede ligada com fio estão configurados para a conectividade básica e QoS está executado, os pacotes estão classificados, marcados e enviados baseado nas políticas configuradas para cada tipo de tráfego.

O aplicativo das características de QoS não pôde facilmente ser detectado em uma rede levemente carregada. As características de QoS começam impactar o desempenho do aplicativo enquanto a carga na rede aumenta. QoS trabalha para manter a latência, o tremor, e a perda para tipos do tráfego selecionado dentro dos limites aceitáveis.

Para um WMM permitido cliente video:

Quando um cliente video na face da tela envia dados ao cliente video no lado wireless, esta sequência de evento ocorre:

  1. Na interface FastEthernet de Router1, a política Marking-For-Video é aplicada aos pacotes de vídeo e os pacotes são marcados com um valor de DSCP AF41.

  2. Os pacotes de vídeo marcados passam através das interfaces serial S3/0 no roteador1 e S0/0 no roteador2. Isto é o lugar onde a probabilidade de queda do pacote é verificada contra o ponto inicial configurado para ver se há o WRED. Quando o comprimento da fila média alcançar o limiar mínimo (40 pacotes neste caso para pacotes de vídeo), o WRED deixa cair aleatoriamente alguns pacotes com o valor AF41 DSCP. Similarmente, quando o comprimento da fila média excede o limiar máximo (pacotes dos 50 pés neste caso para os packedts video), o WRED deixa cair todos os pacotes com o valor AF41 DSCP.

  3. Uma vez que os pacotes de vídeo alcançam o WLC com os FastEthernet no roteador2, o WLC traduz o valor DSCP do pacote recebido ao valor ASCENDENTE AVVID 802.1p e copia o valor DSCP do pacote recebido ao pacote Iwapp como mostrado aqui. Neste exemplo, o valor AF41 DSCP é traduzido 802.1p ao valor correspondente 4.

    qos-wlc-lap11.gif

  4. Quando o pacote alcança o REGAÇO, o REGAÇO traduz o valor DSCP do pacote Iwapp entrante ao valor 802.11e ASCENDENTE e policia o valor a fim assegurar-se de que não exceda o valor máximo permitido a política de QoS WLAN atribuída a esse cliente. O REGAÇO coloca então o pacote na fila de Tx do 802.11 apropriada para o valor ASCENDENTE. Neste exemplo, o valor AF41 DSCP é traduzido 802.11e ao valor ASCENDENTE correspondente 5.

    /image/gif/paws/81831/qos-wlc-lap12.gif

Quando um cliente video no lado wireless envia dados à face da tela, esta sequência de evento ocorre:

  1. Quando um cliente permitido WMM envia um pacote ao REGAÇO, o REGAÇO policia o valor 802.11e ASCENDENTE a fim assegurar-se de que não exceda o valor máximo permitido a política de QoS atribuída a esse cliente. Então, traduz o valor ao valor DSCP. Neste exemplo, o vídeo WLAN foi configurado com o ouro do perfil de QoS, que tem um valor 802.11e ASCENDENTE de 4. Este valor é traduzido ao valor correspondente AF41 DSCP e enviado ao controlador.

    /image/gif/paws/81831/qos-wlc-lap13.gif

  2. O controlador traduz o valor DSCP do pacote Iwapp entrante ao valor 802.1p ASCENDENTE como mostrado e o valor original DSCP é enviado igualmente inalterado.

    /image/gif/paws/81831/qos-wlc-lap14.gif

  3. Os pacotes com valor af41 DSCP nos FastEthernet no roteador2 passam através das interfaces serial no roteador2 e no roteador1, e alcançam os clientes video na face da tela. Quando o pacote atravessa as interfaces serial, a probabilidade de queda do pacote está verificada contra o ponto inicial configurado para ver se há o WRED.

Para um WMM cliente de FTP desabilitado:

Quando o servidor FTP na face da tela envia dados ao cliente de FTP no lado wireless, esta sequência de evento ocorre:

  1. Na interface FastEthernet de Router1, a política Marking-For-FTP é aplicada aos pacotes FTP e os pacotes são marcados com um valor de DSCP AF11.

  2. Os pacotes de FTP marcados passam através das interfaces serial s3/0 no roteador1 e S0/0 no roteador2. Isto é o lugar onde a probabilidade de queda do pacote é verificada contra o ponto inicial configurado para ver se há o WRED. Quando o comprimento da fila média alcançar o limiar mínimo (30 pacotes neste caso para pacotes de FTP), o WRED deixa cair aleatoriamente alguns pacotes com o valor AF11 DSCP. Similarmente, quando o comprimento da fila média excede o limiar máximo (40 pacotes neste caso para pacotes de FTP), o WRED deixa cair todos os pacotes com o valor AF11 DSCP.

  3. Uma vez que os pacotes de FTP alcançam o WLC com os FastEthernet no roteador2, o WLC traduz o valor DSCP do pacote recebido ao valor ASCENDENTE AVVID 802.1p e copia o valor DSCP do pacote recebido ao pacote Iwapp como mostrado aqui. Neste exemplo, o valor AF11 DSCP é traduzido 802.1p ao valor correspondente 1.

  4. Quando o pacote alcança o REGAÇO, o REGAÇO coloca o pacote na fila de Tx do 802.11 do padrão para a política de QoS WLAN atribuída a esse cliente. Neste exemplo, o pacote é colocado na fila para o perfil de bronze de QoS.

Quando um cliente de FTP no lado wireless envia dados à face da tela, esta sequência de evento ocorre:

  1. Quando um cliente de FTP na rede Wireless envia um pacote ao REGAÇO, o REGAÇO usa o valor 802.11e ASCENDENTE para a política de QoS atribuída a esse cliente. Então, o REGAÇO traduz o valor ao valor DSCP e envia o pacote ao controlador. Porque o cliente de FTP pertence à IEEE 802.11e que do bronze do perfil de QoS o valor ASCENDENTE 1 é traduzido ao valor AF11 DSCP.

  2. O controlador traduz o valor DSCP do pacote Iwapp entrante ao valor 802.1p ASCENDENTE como mostrado e o valor original DSCP é enviado igualmente inalterado. O pacote é enviado então ao roteador2 através do switch de Camada 2.

  3. Os pacotes com valor AF11 DSCP nos FastEthernet no roteador2 passam através das interfaces serial no roteador2 e no roteador1, e alcançam os clientes video na face da tela. Quando o pacote atravessa as interfaces serial, a probabilidade de queda do pacote está verificada contra o ponto inicial configurado para ver se há o WRED.

Um procedimento similar ocorrer quando travessia do pacote de voz do prendida à rede Wireless e vice-versa.

Comandos para Troubleshooting

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Nota: Consulte Informações Importantes sobre Comandos de Depuração antes de usar comandos debug.

Você pode emitir estes comandos cisco ios no Roteadores a fim pesquisar defeitos e verificar sua configuração de QoS:

  • fila da mostra {número de interface do nome da interface} — Alista a informação sobre os pacotes que estão esperando em uma fila na relação.

  • o enfileiramento da mostra aleatório-detecta a relação {número de interface do nome da interface} — lista configuração e informação estatística sobre a ferramenta do Enfileiramento em uma relação.

  • mostre a relação do mapa de política {número de interface do nome da interface} — indica as estatísticas e as configurações das políticas da entrada e saída que são anexadas a uma relação. Certifique-se usar este comando no modo exec apropriado.

    Router1#show policy-map interface F3/0.1
     FastEthernet3/0.1
    
      Service-policy output: Marking-For-Voice
    
        Class-map: Voice (match-all)
          18 packets, 1224 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: access-group 101
          QoS Set
            dscp ef
              Packets marked 18
    
        Class-map: class-default (match-any)
          2 packets, 128 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: any
  • debugar os qos ajustados — Indica a informação na Marcação de pacotes QoS.

No WLC, emita este comando a fim ver os ajustes do perfil de QoS:

  • qos da mostra {bronze/prata/ouro/platina} — Fornece informação no perfil de QoS configurado para os WLAN.

    Este é um exemplo de saída do comando show qos:

    (Cisco Controller) >show qos Platinum
    
    Description...................................... For Voice Applications
    Average Data Rate................................   0
    Burst Data Rate..................................   0
    Average Realtime Data Rate.......................   0
    Realtime Burst Data Rate.........................   0
    Maximum RF usage per AP (%)...................... 100
    Queue Length..................................... 100
    protocol......................................... none
    
    (Cisco Controller) >show qos Gold
    
    Description...................................... For Video Applications
    Average Data Rate................................   0
    Burst Data Rate..................................   0
    Average Realtime Data Rate.......................   0
    Realtime Burst Data Rate.........................   0
    Maximum RF usage per AP (%)...................... 100
    Queue Length.....................................  75
    protocol......................................... none
    
    (Cisco Controller) >show qos Bronze
    
    Description...................................... For Background
    Average Data Rate................................   0
    Burst Data Rate..................................   0
    Average Realtime Data Rate.......................   0
    Realtime Burst Data Rate.........................   0
    Maximum RF usage per AP (%)...................... 100
    Queue Length.....................................  25
    protocol......................................... none
  • show wlan <WLAN-ID> — Exibe informações sobre a WLAN. Está aqui um exemplo de saída:

    (Cisco Controller) >show wlan 1
    
    WLAN Identifier.................................. 1
    Network Name (SSID).............................. VoiceClients
    Status........................................... Enabled
    MAC Filtering.................................... Disabled
    Broadcast SSID................................... Enabled
    AAA Policy Override.............................. Disabled
    Number of Active Clients......................... 0
    Exclusionlist Timeout............................ 60 seconds
    Session Timeout.................................. 1800 seconds
    Interface........................................ management
    WLAN ACL......................................... unconfigured
    DHCP Server...................................... Default
    DHCP Address Assignment Required................. Disabled
    Quality of Service............................... Platinum (voice)
    WMM.............................................. Disabled
    CCX - AironetIe Support.......................... Enabled
    CCX - Gratuitous ProbeResponse (GPR)............. Disabled
    Dot11-Phone Mode (7920).......................... Disabled
    Wired Protocol................................... None
    IPv6 Support..................................... Disabled
    Radio Policy..................................... All
    Security
    
       802.11 Authentication:........................ Open System
       Static WEP Keys............................... Disabled
       802.1X........................................ Enabled
       Encryption:..................................... 104-bit WEP
       Wi-Fi Protected Access (WPA/WPA2)............. Disabled
       CKIP ......................................... Disabled
       IP Security Passthru.......................... Disabled
       Web Based Authentication...................... Disabled
       Web-Passthrough............................... Disabled
       Auto Anchor................................... Disabled
       H-REAP Local Switching........................ Disabled
       Management Frame Protection................... Enabled (Global MFP Disabled)

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 81831