Sem fio/Mobilidade : LAN Wireless (WLAN)

Multicast com exemplo de configuração dos controladores (WLC) e do Lightweight Access Points do Wireless LAN (regaços)

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (20 Dezembro 2015) | Feedback


Índice


Introdução

Este documento fornece um exemplo de configuração sobre como configurar Controllers de Wireless LAN (WLCs) e Lightweight Access Points (LAPs) para multicasting e comunicação com uma rede com fio compatível com multicast.

Pré-requisitos

Requisitos

Certifique-se de atender a estes requisitos antes de tentar esta configuração:

  • Conhecimento básico da configuração dos LAPs e dos WLCs da Cisco

  • Conhecimento de como configurar o roteamento e o multicasting básicos em uma rede ligada com fio

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Cisco 4400 WLC que executa a versão de firmware 4.0

  • Cisco 1000 Series LAPs

  • Adaptador de cliente Wireless de Cisco 802.11a/b/g que executa a versão de firmware 2.6

  • Cisco 2500 Router que executa o Software Release 12.4(2) do½ do¿Â do Cisco IOSïÂ

  • Duas 3500 XL series switch de Cisco que executam o Cisco IOS Software Release 12.0(5)WC3b

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Multicast nos controladores do Wireless LAN (WLC)

Antes da liberação de software de rede 3.2 do Cisco Unified Wireless, quando o Protocolo IP multicast foi permitido, o controlador pacotes de transmissão múltipla entregados aos clientes do Wireless LAN (WLAN) fazendo cópias dos pacotes de transmissão múltipla, a seguir enviou os pacotes através de um túnel de pouco peso do protocolo do Access point do unicast (LWAPP) a cada Access Point (AP) conectado ao controlador. Cada frame de transmissão múltipla recebido pelo controlador de um VLAN no primeiro roteador de salto foi copiado e enviado sobre o túnel LWAPP a cada um dos AP conectou-lhe.

O controlador pôde precisar de gerar até 300 cópias de cada pacote de transmissão múltipla, que depende do número de AP. Este mecanismo é incapaz, e coloca uma grande carga de processamento no controlador. Isto inunda a rede com um grande número pacotes do unicast duplicados.

Nas liberações de software de rede 3.2 do Cisco Unified Wireless e mais atrasado, o desempenho do Multicast da rede de Cisco Unified Wireless foi aperfeiçoado. Estas liberações introduzem uma maneira de mais eficiente de entregar o tráfego multicast do controlador aos AP. Em vez de usar o unicast para entregar cada pacote de transmissão múltipla sobre o túnel LWAPP a cada AP, um grupo de transmissão múltipla LWAPP é usado para entregar o pacote de transmissão múltipla a cada AP. Isto permite que o Roteadores na rede use técnicas padrão do Multicast para replicate e entregar pacotes de transmissão múltipla aos AP. Para o grupo de transmissão múltipla LWAPP, o controlador transforma-se o origem de transmissão múltipla e os AP assentam bem nos receptores de transmissão múltipla. Para a característica do desempenho do Multicast, os AP aceitam perguntas do Internet Group Management Protocol (IGMP) somente do roteador e dos pacotes de transmissão múltipla com um endereço IP de origem do controlador com que são associados atualmente.

Se sua rede apoia o multicasting do pacote, você pode configurar o método do Multicast que o controlador usa. O controlador executa o multicasting em dois modos:

  • Modo de Unicast — Neste modo, os unicasts do controlador cada pacote de transmissão múltipla a cada AP associado ao controlador. Este modo é incapaz mas pôde ser exigido nas redes que não apoiam o multicasting.

  • Modo multicast — Neste modo, o controlador envia pacotes de transmissão múltipla a um grupo de transmissão múltipla LWAPP. Este método reduz-se em cima no processador do controlador e desloca-se o trabalho da replicação do pacote a sua rede, que é muitos mais eficiente do que o método do unicast.

    Você pode permitir o modo do Multicast usando o controlador GUI ou CLI.

Comportamento do Multicast em versões de software WLC diferentes

Antes da versão de firmware 4.0.206.0 WLC, a transmissão de pacote de transmissão múltipla permitiu no unicast ou no modo do Multicast, transmissão de pacote de transmissão igualmente permitida. Na versão de firmware 4.0.206.0 WLC, a transmissão e o tráfego multicast devem ser permitidos separadamente. A transmissão é desabilitada à revelia. Emita este comando do WLC CLI a fim permitir a transmissão:

config network broadcast enable

Também, a transmissão usa o modo do Multicast que é configurado no WLC, mesmo se o Multicast não é girado sobre. Se você quer permitir a transmissão sem permitir o Multicast, você executa este através do CLI mas não com o GUI. Isto é porque você não pode ajustar o endereço IP de Um ou Mais Servidores Cisco ICM NT ou o modo a menos que você permitir o Multicast no GUI. Consequentemente, se o modo do Multicast é unicast e a transmissão está girada sobre, este é os usos da transmissão do modo (o tráfego de broadcast replicated e unicast a cada AP). Se o modo do Multicast é ajustado ao Multicast com um endereço de multicast, a seguir a transmissão usa este modo (cada pacote de transmissão é enviado através do grupo de transmissão múltipla aos AP).

config network multicast mode multicast 
                           Or
config network multicast unicast

O Multicast com ultrapassagem AAA é apoiado da liberação 4.2 do controlador do Wireless LAN e mais atrasado. Você tem que permitir o IGMP Snooping no controlador de fazer o trabalho do Multicast com ultrapassagem AAA.

No Software Release 4.2 do controlador, o IGMP Snooping é introduzido para dirigir melhor pacotes de transmissão múltipla. Quando esta característica é permitida, o controlador recolhe relatórios IGMP dos clientes, processa os relatórios, cria o grupo de transmissão múltipla original ID (MGIDs) dos relatórios IGMP após ter verificado o endereço de multicast da camada 3 e o número de VLAN, e envia os relatórios IGMP ao interruptor da infraestrutura. O controlador envia estes relatórios com o endereço de origem como o endereço da relação em que recebeu os relatórios dos clientes.

O controlador atualiza então a tabela do Access point MGID no AP com o endereço MAC de cliente. Quando o controlador receber o tráfego multicast para um grupo de transmissão múltipla particular, ele para a frente ele a todos os AP. Contudo, somente aqueles AP que têm os clientes ativo que escutam ou subscritos a esse grupo de transmissão múltipla para enviar o tráfego multicast nesse WLAN particular. Os pacotes IP são enviados com um MGID que seja original para um ingresso VLAN e o grupo da transmissão múltipla de destino. Os pacotes de transmissão múltipla da camada 2 são enviados com um MGID que seja original para a interface de ingresso.

Nota: O IGMP Snooping não é apoiado nos controladores do 2000 Series, nos controladores do 2100 Series, ou no módulo de rede do controlador de LAN do Cisco Wireless para o Roteadores dos Serviços integrados de Cisco.

Os aplicativos multicast conheceram limitações de desempenho nos controladores do 2100 Series e no módulo de rede do controlador de LAN do Cisco Wireless para o Roteadores dos Serviços integrados de Cisco. Cisco está trabalhando para endereçar estas limitações em uma liberação de código futura da produção. Entretanto, Cisco recomenda que você usa o 4400 Series ou os controladores de WiSM para aplicativos intensivos do Multicast.

Nota: O Multicast não é apoiado nos AP que são conectados diretamente à porta local de um controlador do 2100 Series.

Refira o capítulo do projeto do Multicast do Cisco Unified Wireless do Guia de Design da mobilidade da empresa para obter mais informações sobre do Multicast com WLC.

Este documento fornece um exemplo de configuração que ilustre como configurar o multicasting em WLC a fim conectar a uma rede ligada com fio permitida Multicast.

Multicast wireless que vagueia

Um desafio principal para um cliente do Multicast em um ambiente Wireless é manter sua sociedade de grupo de transmissão múltipla quando movido sobre o WLAN. As gotas na conexão Wireless que se movem do AP-à-AP podem causar um rompimento no aplicativo multicast de um cliente. O Internet Group Management Protocol (IGMP) joga um papel importante na manutenção da informação dinâmica da membrasia do clube.

Uma compreensão básica do IGMP é importante compreender o que acontece à sessão do Multicast de um cliente quando vagueia sobre a rede. Em um exemplo vagueando da camada 2, as sessões são mantidas simplesmente porque o AP estrangeiro, se configurado corretamente, já pertence ao grupo de transmissão múltipla, e o tráfego não é escavado um túnel a um ponto de âncora diferente na rede. Os ambientes vagueando da camada 3 são um pouco de mais complexos desse modo, e, dependente em cima do que modo do Tunelamento você configurou em seus controladores, os mensagens IGMP enviados de um cliente Wireless podem ser afetados. O modo do Tunelamento da mobilidade do padrão em um controlador é assimétrico. Isto significa que o tráfego de retorno ao cliente está enviado à âncora WLC e encaminhado então ao WLC estrangeiro, onde a conexão de cliente associada reside. Os pacotes externos são encaminhados para fora a relação estrangeira WLC. No modo simétrico do Tunelamento da mobilidade, ambo o tráfego de entrada e de saída é escavado um túnel ao controlador da âncora.

Diretrizes para usar o Modo multicast

Use estas diretrizes quando você permite o modo do Multicast em sua rede:

  • A solução de rede do Cisco Unified Wireless usa alguns intervalos de endereço IP para finalidades específicas. Mantenha estas escalas na mente quando você configura um grupo de transmissão múltipla:

    Embora não recomendado, todo o endereço de multicast pode ser atribuído ao grupo de transmissão múltipla LWAPP; isto inclui os endereços de multicast locais do link reservado usados pelo OSPF, pelo EIGRP, pelo PIM, pelo HSRP, e pelos outros protocolos de transmissão múltipla.

    Cisco recomenda que os endereços de multicast estejam atribuídos do bloco administrativamente no escopo 239/8. O IANA reservou a escala de 239.0.0.0-239.255.255.255 como endereços administrativamente no escopo para domínios do Multicast do uso em privado. Veja a nota para restrições adicionais. Estes endereços são similares na natureza às escalas reservados do unicast do IP privado, tais como 10.0.0.0/8, definidas no RFC 1918. Os administradores de rede estão livres usar em outra parte os endereços de multicast nesta escala dentro de seu domínio sem medo do conflito com outro no Internet. Este administrativo ou espaço de endereço privado devem ser usados dentro da empresa e sua licença ou entrada obstruída do domínio autônomo (COMO).

    Nota: Não use a escala de endereço 239.0.0.X ou a escala de endereço 239.128.0.X. Os endereços nestas escalas sobrepõem com os endereços MAC locais de link e inundam para fora todas as portas de switch, mesmo com o IGMP Snooping girado sobre.

    Cisco recomenda que os administradores de rede de empreendimento mais adicionais subdividem esta escala de endereço em espaços administrativos geográficos menores dentro da rede de empreendimento para limitar o “espaço” de aplicativos multicast particulares. Isto impede que o tráfego multicast da alta taxa saa de um terreno (onde a largura de banda é abundante) e congestionando os links de WAN. Igualmente permite a filtração eficiente do Multicast da largura de banda elevada de alcançar o controlador e a rede Wireless. Para obter mais informações sobre das diretrizes do endereço de multicast, refira diretrizes para a atribuição de endereço IP Multicast da empresa.

  • Quando você permite o modo do Multicast no controlador, você deve configurar um endereço de grupo de transmissão múltipla LWAPP no controlador. Os AP subscrevem ao grupo de transmissão múltipla LWAPP que usa o Internet Group Management Protocol (IGMP).

  • 1130, 1200, 1230, e 1240 os AP do Cisco 1100, usam IGMP versão 1, 2, e 3. Contudo, o Cisco 1000 Series AP usa somente IGMP v1 para juntar-se ao grupo de transmissão múltipla.

  • O Modo multicast trabalha somente no modo LWAPP da camada 3.

  • Os AP no modo de monitor, no modo do sniffer, ou no modo desonesto do detector não se juntam ao endereço de grupo de transmissão múltipla LWAPP.

  • Quando você usa os controladores que executam a versão 4.1 ou anterior, você pode usar o mesmo endereço de multicast em todos os controladores. Se você usa os controladores que executam a versão 4.2 ou mais recente, o grupo de transmissão múltipla LWAPP configurado nos controladores deve ser diferente para cada controlador usado na rede.

  • Se você usa controladores com versão 4.1 ou anterior, o modo do Multicast não trabalha através dos eventos da mobilidade do intersubnet, tais como o Tunelamento do convidado, o específico de site VLAN, ou a ultrapassagem da relação que usa o RAIO. O modo do Multicast trabalha nestes eventos da mobilidade da sub-rede quando você desabilita as características da camada 2 IGMP snooping/CGMP no LAN ligado com fio.

    Em umas versões mais atrasadas, isto é, 4.2 ou mais atrasado, o modo do Multicast não se operam através dos eventos da mobilidade do intersubnet, tais como o Tunelamento do convidado. Faz, contudo, operar-se com relação cancela esse RAIO do uso (mas somente quando o IGMP Snooping é permitido) e com específico de site VLAN (grupo VLAN do Access point).

  • O controlador deixa cair todos os pacotes de transmissão múltipla enviados aos números de porta 12222, 12223, e 12224 UDP. Certifique-se que os aplicativos multicast em sua rede não usam aqueles números de porta.

  • O tráfego multicast é transmitido no 6 Mbps em uma rede 802.11a. Consequentemente, se diversos WLAN tentam transmitir no 1.5 Mbps, a perda de pacotes ocorre. Isto quebra a sessão do Multicast.

Instalação de rede

Nesta instalação, a rede ligada com fio é compreendida dos três Roteadores, do r1, do R2 e do R3, essa corrida OSPF entre eles.

Os anfitriões prendidos conectam à rede através de um switch de Camada 2 que seja conectado ao r1 do roteador. A rede Wireless conecta à rede através do roteador R3, segundo as indicações do diagrama.

Os dispositivos precisam de ser configurados para a conectividade básica IP e permitem o multicasting na rede. Consequentemente, os usuários podem enviar e receber o tráfego multicast da face da tela ao lado wireless e vice-versa.

Este documento usa estes endereços IP de Um ou Mais Servidores Cisco ICM NT para o WLC, o REGAÇO e os clientes Wireless:

WLC Management Interface IP address: 172.16.1.30/16
WLC AP Manager Interface IP address: 172.16.1.31/16
LAP IP address: 172.16.1.50/16
Wireless Client C1 IP address: 172.16.1.75/16
Wireless Client C2 IP address: 172.16.1.76/16
Wired Client W1 IP address: 192.168.0.20/16
Wired Client W2 IP address: 192.168.0.30/16
Wired Client W3 IP address: 192.168.0.40/16

/image/gif/paws/81671/multicast-wlc-lap1.gif

Configurar

A fim configurar os dispositivos para esta instalação, estes necessidade de ser executado:

Configurar a rede Wireless para Multicasting

Antes que você configure o multicasting em WLC, você deve configurar o WLC para a operação básica e registrar os regaços ao WLC. Este documento supõe que o WLC está configurado para a operação básica e que os regaços estão registrados ao WLC. Se você for um novo usuário que está tentando configurar o WLC para operação básica com LAPs, consulte Registro do LAP (Lightweight AP) em um WLC (Wireless LAN Controller).

Nota: Não use o 239.0.0.X ou as escalas de endereço 239.128.0.X. Os endereços nestas escalas sobrepõem com os endereços MAC locais de link e inundam todas as portas de switch, mesmo com o IGMP Snooping permitido. Refira a seção de endereços de multicast da camada 2 da visão geral da tecnologia do Protocolo IP multicast para obter mais informações sobre dos endereços MAC de transmissão múltipla de sobreposição.

Uma vez os regaços são registrados ao WLC, terminam estas tarefas a fim configurar os regaços e o WLC para esta instalação:

  1. Configurar o WLAN para clientes

  2. Permita o Modo multicast dos Ethernet através do GUI

Configurar o WLAN para clientes

A primeira etapa é cria um WLAN a que os clientes Wireless podem conectar e receber o acesso à rede. Termine estas etapas a fim criar um WLAN no WLC:

  1. Clique WLAN do controlador GUI a fim criar um WLAN.

  2. Clique novo a fim configurar um WLAN novo.

    Neste exemplo, o WLAN é nomeado MulticastUsers e o ID de WLAN é 1.

    /image/gif/paws/81671/multicast-wlc-lap2.gif

  3. Clique em Apply.

  4. No o WLAN > edita o indicador, define os parâmetros específicos ao WLAN.

    1. Para o WLAN, escolha a relação apropriada do campo de nome da relação.

      Este exemplo traça a interface de gerenciamento ao WLAN.

    2. Selecione os outros parâmetros, que depende dos requisitos de projeto.

      Os valores padrão são usados neste exemplo.

    3. Clique em Apply.

      multicast-wlc-lap3.gif

      Nota: Neste exemplo, mergulhe 2 métodos de segurança para autenticar usuários Wireless não são usados. , Não escolha consequentemente nenhuns no campo de Segurança da camada 2. À revelia, a opção de segurança da camada 2 é 802.1x.

      Nota: Em vez de traçar o WLAN (SSID) à interface de gerenciamento, as interfaces dinâmica podem igualmente ser configuradas no WLC para segmentar os usuários Wireless e o WLAN pode ser traçado às interfaces dinâmica. Consulte Exemplo de Configuração de VLANs em Wireless LAN Controllers para obter informações sobre como configurar interfaces dinâmicas em WLCs.

Emita estes comandos a fim configurar os WLAN no WLC usando o CLI:

  1. Execute o comando config wlan create <wlan-id> <wlan-name> para criar uma nova WLAN. Para a WLAN-identificação, incorpore um ID de 1 a 16. Para o WLAN-nome, incorpore um SSID até 31 caráteres alfanuméricos.

  2. Execute o comando config wlan enable <wlan-id> para habilitar uma WLAN.

    Para o exemplo neste documento, os comandos são:

    config wlan create 1 MulticastUsers
    config wlan enable 1
    

Permita o Modo multicast dos Ethernet através do GUI

A próxima etapa é configurar o WLC para multicasting. Conclua estes passos:

  1. Do página da web do general de controlador, assegure-se de que o modo de transporte de LWAPP esteja ajustado para mergulhar 3.

    A característica do desempenho do Multicast trabalha somente neste modo.

    /image/gif/paws/81671/multicast-wlc-lap4.gif

    Nota: Quando o Multicast é permitido como o unicast do Multicast, os pacotes replicated para cada AP; esta pode ser utilização de processador, assim que use-a com cuidado. O Multicast permitido como o Multicast do Multicast usa o endereço de multicast atribuído usuário para fazer para fora um Multicast mais tradicional aos AP.

  2. Do menu suspenso para o Modo multicast dos Ethernet, escolha o Multicast e incorpore um endereço de grupo de transmissão múltipla.

    Neste exemplo, o endereço é 239.255.1.60.

    /image/gif/paws/81671/multicast-wlc-lap7.gif

  3. Clique em Apply.

    Nota: O WLC 4100 não apoia o modo do Multicast. O Multicast é feito somente no modo de Unicast. Isto significa que o controlador tem que replicate o pacote de transmissão múltipla para cada AP e unicast o pacote de transmissão múltipla a cada um dos AP.

    Emita estes comandos a fim permitir o Multicast com o CLI:

    1. Da linha de comando, emita o comando enable global do Multicast da rede da configuração.

    2. Da linha de comando, emita o <multicast-grupo-IP-endereço > o comando do Multicast do modo do Multicast da rede da configuração.

      Para o exemplo neste documento, os comandos são:

      config network multicast global enable
      config network multicast mode multicast 239.255.1.60
      

Depois que o administrador permite o Multicast (o modo do Multicast está desabilitado à revelia) e configura um grupo de transmissão múltipla LWAPP, o algoritmo novo do Multicast trabalha em uma destas maneiras:

Quando a fonte do grupo de transmissão múltipla estiver no LAN ligado com fio:

O LWAPP AP transfere o controlador o endereço de grupo de transmissão múltipla LWAPP que durante o normal se junta ao processo (no tempo da bota) ao controlador. Depois que um AP se junta a um controlador e se transfere sua configuração, o AP emite um pedido IGMP a fim juntar-se ao grupo de transmissão múltipla do controlador LWAPP. Isto provoca a instalação normal para o estado do Multicast no Roteadores Multicast-permitido, entre o controlador e os AP. O endereço IP de origem para o grupo de transmissão múltipla é o endereço IP de Um ou Mais Servidores Cisco ICM NT da interface de gerenciamento do controlador, não o endereço IP de Um ou Mais Servidores Cisco ICM NT do gerenciador AP usado para o modo da camada 3.

Quando o controlador recebe um pacote de transmissão múltipla de algum do cliente VLAN no primeiro roteador de salto, transmite o pacote ao grupo de transmissão múltipla LWAPP através da interface de gerenciamento a mais baixo nível de QoS. Os bit de QoS para o pacote de transmissão múltipla LWAPP duro-são codificados no mais de baixo nível e não podem ser mudados pelo usuário.

A rede Multicast-permitida entrega o pacote de transmissão múltipla LWAPP a cada um dos AP que se juntaram ao grupo de transmissão múltipla LWAPP. Os usos da rede Multicast-permitidos os mecanismos normais do Multicast no Roteadores replicate ao longo do caminho o pacote, como necessário, de modo que o pacote de transmissão múltipla alcance todos os AP. Isto alivia o controlador da replicação dos pacotes de transmissão múltipla.

Os AP podem receber outros pacotes de transmissão múltipla, mas processo somente os pacotes de transmissão múltipla que vêm do controlador a que são juntados atualmente. Todas as outras cópias são rejeitadas. Se mais de um WLAN SSID é associado ao VLAN de onde o pacote de transmissão múltipla original esteve enviado, o AP transmite o pacote de transmissão múltipla sobre cada WLAN SSID (que segue ao bitmap WLAN no cabeçalho LWAPP). Além, se esse WLAN SSID está em ambos os rádios (802.11g e 802.11a), ambos os rádios transmitem o pacote de transmissão múltipla no WLAN SSID se há clientes associados com ele, mesmo se aqueles clientes não pediram o tráfego multicast.

Quando a fonte do grupo de transmissão múltipla for um cliente Wireless:

O pacote de transmissão múltipla é unicast (LWAPP-encapsulado) do AP ao controlador, similar ao tráfego padrão do cliente Wireless.

O controlador faz duas cópias do pacote de transmissão múltipla. Uma cópia é mandada o VLAN associado com o WLAN SSID em que chegou. Isto permite receptores no LAN ligado com fio de receber o fluxo de transmissão múltipla e o roteador para aprender sobre o grupo de transmissão múltipla novo. A segunda cópia do pacote LWAPP-é encapsulada e enviada ao grupo de transmissão múltipla LWAPP de modo que os clientes Wireless possam receber o fluxo de transmissão múltipla.

Configurar a rede ligada com fio para Multicasting

A fim configurar a rede ligada com fio para esta instalação, você precisa de configurar a Conectividade dos roteadores para básico e de permitir o multicasting na rede ligada com fio.

Como mencionado mais cedo, o OSPF é usado como o protocolo de roteamento de unicast.

Todo o protocolo de transmissão múltipla pode ser usado na rede ligada com fio. Este documento usa o PIM-DM como o protocolo de transmissão múltipla. Refira o manual de configuração do Protocolo IP multicast do Cisco IOS para informações detalhadas sobre dos protocolos diferentes que podem ser usados multicasting em uma rede ligada com fio.

Estas são as configurações para o r1 do Roteadores, o R2 e o R3:

R1 do roteador
RouterR1#show run
Building configuration...

Current configuration : 836 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterR1
!
!
ip subnet-zero
!
ip multicast-routing

!--- Enables IP Multicasting on the network.

!
!
!
interface Ethernet0
 ip address 192.168.0.1 255.255.0.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

 ip cgmp

!--- Enables Cisco Group Management Protocol (CGMP) on the interface 
!--- connected to the Layer 2 switch.

!
interface Serial0
 description Connected to RouterR2
 ip address 10.2.3.2 255.255.255.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

!
interface Serial1
 description Connected to RouterR3
 ip address 10.2.4.1 255.255.255.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

!
interface Serial2
 no ip address
 shutdown
!
interface Serial3
 no ip address
 shutdown
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
!
router ospf 1

!--- Configures OSPF as the unicast routing protocol.

 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
 network 192.168.0.0 0.0.255.255 area 0
 !
ip classless
ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

Roteador R2
RouterR2#show run
Building configuration...

Current configuration : 616 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterR2
!
!
ip subnet-zero
!
ip multicast-routing

!--- Enables IP Multicasting on the network.

!
!
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 description Connnected to RouterR3
 ip address 10.2.2.2 255.255.255.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

!
interface Serial1
 description Connected to RouterR1
 ip address 10.2.3.1 255.255.255.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

!
router ospf 1

!--- Configures OSPF as the unicast routing protocol.

 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
!
ip classless
ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

Roteador R3
RouterR3#show run
Building configuration...

Current configuration : 711 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RouterR3
!
!
ip subnet-zero
!
ip multicast-routing

!--- Enables IP Multicasting on the network.

!
!
!
interface Ethernet0
 ip address 172.16.1.1 255.255.0.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

 ip cgmp

!--- Enables Cisco Group Management Protocol (CGMP) on the interface 
!--- connected to the Layer 2 switch.

 
!
interface Serial0
 description Connected to RouterR2
 ip address 10.2.2.1 255.255.255.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

!
interface Serial1
 description Connected to RouterR1
 ip address 10.2.4.2 255.255.255.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

!
router ospf 1

!--- Configures OSPF as the unicast routing protocol.

 log-adjacency-changes
 network 172.16.0.0 0.0.255.255 area 0
 network 10.0.0.0 0.255.255.255 area 0
!
ip classless
ip http server
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

Para switch de Camada 2, nenhuma configuração é exigida multicasting. Todos os switch de Camada 2 com base em IOS têm o CGMP permitido à revelia. Consequentemente, o Switches processa automaticamente os mensagens CGMP do Roteadores.

Verificar e solucionar problemas

Use esta seção para confirmar se a sua configuração funciona corretamente.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

A fim verificar a configuração, você precisa de enviar o tráfego multicast da fonte W1 e de verificar se o tráfego multicast corre através da rede ligada com fio e alcança os membros prendidos e wireless do grupo, W2, C1 e C2.

Execute esta tarefa a fim testar se o Protocolo IP multicast é configurado corretamente em sua rede.

Se todo o Roteadores do capaz de efetuar multicast (transmissão múltipla) é membros de um grupo de transmissão múltipla, sibilando que o grupo faz com que todo o Roteadores responda, que podem ser um administrativos e uma ferramenta para debug úteis.

Uma outra razão mandar um roteador juntar-se a um grupo de transmissão múltipla é quando outros anfitriões na rede têm uma configuração do Interior Gateway Routing Protocol (IGRP) que impeça que respondam corretamente a perguntas IGMP. Quando você manda o roteador se juntar ao grupo de transmissão múltipla, este faz com que os roteadores fluxo acima mantenham a informação da tabela de roteamento de transmissão múltipla para esse grupo e mantenham os trajetos para esse active do grupo. A fim configurar parte de um roteador para ser o grupo de transmissão múltipla, emita este comando do modo de configuração da interface:

ip igmp join-group <group-address> 
Example: Router(config-if)#ip igmp join-group 239.255.1.60

Está aqui a saída do sibilo do roteador R3:

RouterR3#ping 239.255.1.60

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 239.255.1.60, timeout is 2 seconds:

Reply to request 0 from 10.2.2.2, 40 ms
Reply to request 0 from 10.2.3.1, 84 ms
Reply to request 0 from 10.2.4.1, 44 ms

Encontrando um salto defeituoso

Execute esta tarefa a fim monitorar e diagnosticar uma configuração básica do Protocolo IP multicast. Você pode usar este procedimento quando um receptor e uma fonte não se operam como esperado.

/image/gif/paws/81671/multicast-wlc-lap6.gif

Estão aqui as saídas da sociedade do igmp da mostra IP e os comandos show ip mroute count para o exemplo de configuração. Estas saídas foram tomadas do roteador R3.

RouterR3#sh ip igmp membership
Flags: A  - aggregate, T - tracked
       L  - Local, S - static, V - virtual, R - Reported through v3
       I - v3lite, U - Urd, M - SSM (S,G) channel
       1,2,3 - The version of IGMP the group is in
Channel/Group-Flags:
       / - Filtering entry (Exclude mode (S,G), Include mode (*,G))
Reporter:
       <ip-address> - last reporter if group is not explicitly tracked
       <n>/<m>      - <n> reporter in include mode, <m> reporter in exclude

 Channel/Group                  Reporter        Uptime   Exp.  Flags  Interface
 *,224.0.1.40                   10.2.2.1        1d21h    stop  2LA    Se0
 *,239.255.1.60                    172.16.1.1      1d06h    02:17 1LA    Et0
RouterR3#sh ip mroute count
IP Multicast Statistics
5 routes using 3094 bytes of memory
2 groups, 1.50 average sources per group
Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kilobits per second
Other counts: Total/RPF failed/Other drops(OIF-null, rate-limit etc)

Group: 239.255.1.60, Source count: 3, Packets forwarded: 6860, 
Packets received: 7087
  Source: 172.16.1.30/32, Forwarding: 304/1/147/0, Other: 304/0/0
  Source: 172.16.1.75/32, Forwarding: 6329/8/57/3, Other: 6329/0/0
  Source: 192.168.0.20/32, Forwarding: 227/1/69/0, Other: 454/227/0

Group: 224.0.1.40, Source count: 0, Packets forwarded: 0, Packets received: 0

Destas saídas, você pode ver que fluxos de tráfego multicast da fonte W1 e é recebido pelos membros do grupo.


Informações Relacionadas


Document ID: 81671